MoonSharp

MoonSharp Reference Guide
MoonSharp

This is the API reference for the MoonSharp.Interpreter assembly.

To get started, please visit the MoonSharp homepage.

Send comments on this topic to info@moonsharp.org


MoonSharp.Interpreter Namespace

MoonSharp.Interpreter Namespace
Namespace containing all the most commonly used classes for MoonSharp operation. When in doubt, refer to Script and DynValue classes as starting points.
Classes
 | Class | Description
Public class | AsyncExtensions | This class contains extension methods providing async wrappers of many methods. Asynchronous execution is performed by scheduling the method on the thread pool (through a Task.Factory.StartNew). This type is supported only on .NET 4.x and .NET 4.x PCL targets.
Public class | CallbackArguments | This class is a container for arguments received by a CallbackFunction
Public class | CallbackFunction | This class wraps a CLR function
Public class | Closure | A class representing a script function
Public class | Coroutine | A class representing a script coroutine
Public class | DynamicExpression | Represents a dynamic expression in the script
Public class | DynamicExpressionException | Exception thrown when a dynamic expression is invalid
Public class | DynValue | A class representing a value in a Lua/MoonSharp script.
Public class | InternalErrorException | Exception thrown when an inconsistent state is reached in the interpreter
Public class | InterpreterException | Base type of all exceptions thrown in MoonSharp
Public class | LinqHelpers | LINQ helper methods
Public class | LuaTypeExtensions | Extension methods to DataType
Public class | ModuleRegister | Class managing modules (mostly as extension methods)
Public class | MoonSharpHiddenAttribute | Forces a class member visibility to scripts. Can be used to hide public members. Equivalent to MoonSharpVisible(false).
Public class | MoonSharpHideMemberAttribute | Lists a userdata member not to be exposed to scripts referencing it by name.
Public class | MoonSharpModuleAttribute | Marks a CLR type to be a MoonSharp module. Modules are the fastest way to bring interop between scripts and CLR code, albeit at the cost of a very increased complexity in writing them. Modules is what's used for the standard library, for maximum efficiency. Modules are basically classes containing only static methods, with the callback function signature. See Table and ModuleRegister for (extension) methods used to register modules to a table. See CallbackFunction for information regarding the standard callback signature along with easier ways to marshal methods. See UserData for easier object marshalling.
Public class | MoonSharpModuleConstantAttribute | In a module type, mark fields with this attribute to have them exposed as a module constant. See MoonSharpModuleAttribute for more information about modules.
Public class | MoonSharpModuleMethodAttribute | In a module type, mark methods or fields with this attribute to have them exposed as module functions. Methods must have the signature "public static DynValue ...(ScriptExecutionContextCallbackArguments)". Fields must be static or const strings, with an anonymous Lua function inside. See MoonSharpModuleAttribute for more information about modules.
Public class | MoonSharpPropertyAttribute | Marks a property as a configruation property
Public class | MoonSharpUserDataAttribute | Marks a type of automatic registration as userdata (which happens only if UserData.RegisterAssembly is called).
Public class | MoonSharpUserDataMetamethodAttribute | Marks a method as the handler of metamethods of a userdata type
Public class | RefIdObject | A base class for many MoonSharp objects. Helds a ReferenceID property which gets a different value for every object instance, for debugging purposes. Note that the ID is not assigned in a thread safe manner for speed reason, so the IDs are guaranteed to be unique only if everything is running on one thread at a time.
Public class | Script | This class implements a MoonSharp scripting session. Multiple Script objects can coexist in the same program but cannot share data among themselves unless some mechanism is put in place.
Public class | ScriptExecutionContext | Class giving access to details of the environment where the script is executing
Public class | ScriptGlobalOptions | Class containing script global options, that is options which cannot be customized per-script. GlobalOptions
Public class | ScriptOptions | This class contains options to customize behaviour of Script objects.
Public class | ScriptRuntimeException | Exception for all runtime errors. In addition to constructors, it offers a lot of static methods generating more "standard" Lua errors.
Public class | SymbolRef | This class stores a possible l-value (that is a potential target of an assignment)
Public class | SyntaxErrorException | Exception for all parsing/lexing errors.
Public class | Table | A class representing a Lua table.
Public class | TailCallData | Class used to support "tail" continuations - a way for C# / Lua interaction which supports coroutine yielding (at the expense of a LOT of added complexity in calling code).
Public class | UserData | Class exposing C# objects as Lua userdata. For efficiency, a global registry of types is maintained, instead of a per-script one.
Public class | WellKnownSymbols | Constants of well known "symbols" in the MoonSharp grammar
Public class | YieldRequest | Class wrapping a request to yield a coroutine
Structures
 | Structure | Description
Public structure | TablePair | A class representing a key/value pair for Table use
Interfaces
 | Interface | Description
Public interface | IScriptPrivateResource | Common interface for all resources which are uniquely bound to a script.
Delegates
 | Delegate | Description
Public delegate | ScriptFunctionDelegate | A Delegate type which can wrap a script function
Public delegate | ScriptFunctionDelegateT | A Delegate type which can wrap a script function with a generic typed return value
Enumerations
 | Enumeration | Description
Public enumeration | ClosureUpvaluesType | Type of closure based on upvalues
Public enumeration | ColonOperatorBehaviour | Defines behaviour of the colon ':' operator in CLR callbacks. Default behaviour is for ':' being treated the same as a '.' if the functions is implemented on the CLR side (e.g. in C#).
Public enumeration | CoreModules | Enumeration (combinable as flags) of all the standard library modules
Public enumeration | CoroutineCoroutineType | Possible types of coroutine
Public enumeration | CoroutineState | State of coroutines
Public enumeration | DataType | Enumeration of possible data types in MoonSharp
Public enumeration | InteropAccessMode | Enumerations of the possible strategies to marshal CLR objects to MoonSharp userdata and functions when using automatic descriptors. Note that these are "hints" and MoonSharp is free to ignore the access mode specified (if different from HideMembers) and downgrade the access mode to "Reflection". This particularly happens when running on AOT platforms like iOS. See also : CallbackFunction and UserData .
Public enumeration | SymbolRefType | Enumeration of the types of SymbolRef
Public enumeration | TypeValidationFlags | Flags to alter the way the DynValue.CheckType and other related functions operate on data types for validation.


AsyncExtensions Class

AsyncExtensions Class
This class contains extension methods providing async wrappers of many methods. Asynchronous execution is performed by scheduling the method on the thread pool (through a Task.Factory.StartNew). This type is supported only on .NET 4.x and .NET 4.x PCL targets.
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterAsyncExtensions

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static class AsyncExtensions
<ExtensionAttribute>
Public NotInheritable Class AsyncExtensions
[ExtensionAttribute]
public ref class AsyncExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type AsyncExtensions =  class end

The AsyncExtensions type exposes the following members.

Methods
Name | Description
CallAsync(Closure) | Asynchronously calls this function with the specified args This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Closure, DynValue) | Asynchronously calls this function with the specified args This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Closure, Object) | Asynchronously calls this function with the specified args This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Script, DynValue) | Calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Script, Object) | Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Script, DynValue, DynValue) | Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Script, DynValue, Object) | Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Script, Object, Object) | Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CreateDynamicExpressionAsync | Asynchronously creates a new dynamic expression. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
DoFileAsync | Asynchronously loads and executes a file containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
DoStreamAsync | Asynchronously loads and executes a stream containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
DoStringAsync | Asynchronously loads and executes a string containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
DumpAsync | Asynchronously dumps a function on the specified stream. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
EvaluateAsync | Asynchronously evaluates a REPL command. This method returns the result of the computation, or null if more input is needed for having valid code. In case of errors, exceptions are propagated to the caller. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
LoadFileAsync | Asynchronously loads a string containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
LoadFunctionAsync | Asynchronously loads a string containing a Lua/MoonSharp function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
LoadStreamAsync | Asynchronously loads a Lua/MoonSharp script from a System.IO.Stream. NOTE: This will *NOT* close the stream! This method is supported only on .NET 4.x and .NET 4.x PCL targets.
LoadStringAsync | Asynchronously loads a string containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
ResumeAsync(Coroutine) | Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
ResumeAsync(Coroutine, DynValue) | Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
ResumeAsync(Coroutine, ScriptExecutionContext) | Resumes the coroutine. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
ResumeAsync(Coroutine, Object) | Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
ResumeAsync(Coroutine, ScriptExecutionContext, DynValue) | Resumes the coroutine. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
ResumeAsync(Coroutine, ScriptExecutionContext, Object) | Resumes the coroutine This method is supported only on .NET 4.x and .NET 4.x PCL targets.
Top
See Also

Reference

MoonSharp.Interpreter Namespace


AsyncExtensions Methods

AsyncExtensions Methods

The AsyncExtensions type exposes the following members.

Methods
Name | Description
CallAsync(Closure) | Asynchronously calls this function with the specified args This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Closure, DynValue) | Asynchronously calls this function with the specified args This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Closure, Object) | Asynchronously calls this function with the specified args This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Script, DynValue) | Calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Script, Object) | Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Script, DynValue, DynValue) | Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Script, DynValue, Object) | Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Script, Object, Object) | Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CreateDynamicExpressionAsync | Asynchronously creates a new dynamic expression. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
DoFileAsync | Asynchronously loads and executes a file containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
DoStreamAsync | Asynchronously loads and executes a stream containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
DoStringAsync | Asynchronously loads and executes a string containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
DumpAsync | Asynchronously dumps a function on the specified stream. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
EvaluateAsync | Asynchronously evaluates a REPL command. This method returns the result of the computation, or null if more input is needed for having valid code. In case of errors, exceptions are propagated to the caller. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
LoadFileAsync | Asynchronously loads a string containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
LoadFunctionAsync | Asynchronously loads a string containing a Lua/MoonSharp function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
LoadStreamAsync | Asynchronously loads a Lua/MoonSharp script from a System.IO.Stream. NOTE: This will *NOT* close the stream! This method is supported only on .NET 4.x and .NET 4.x PCL targets.
LoadStringAsync | Asynchronously loads a string containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
ResumeAsync(Coroutine) | Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
ResumeAsync(Coroutine, DynValue) | Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
ResumeAsync(Coroutine, ScriptExecutionContext) | Resumes the coroutine. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
ResumeAsync(Coroutine, Object) | Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
ResumeAsync(Coroutine, ScriptExecutionContext, DynValue) | Resumes the coroutine. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
ResumeAsync(Coroutine, ScriptExecutionContext, Object) | Resumes the coroutine This method is supported only on .NET 4.x and .NET 4.x PCL targets.
Top
See Also

Reference

AsyncExtensions Class
MoonSharp.Interpreter Namespace


AsyncExtensions.CallAsync Method

AsyncExtensionsCallAsync Method
Overload List
Name | Description
CallAsync(Closure) | Asynchronously calls this function with the specified args This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Closure, DynValue) | Asynchronously calls this function with the specified args This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Closure, Object) | Asynchronously calls this function with the specified args This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Script, DynValue) | Calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Script, Object) | Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Script, DynValue, DynValue) | Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Script, DynValue, Object) | Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
CallAsync(Script, Object, Object) | Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
Top
See Also

Reference

AsyncExtensions Class
MoonSharp.Interpreter Namespace


AsyncExtensions.CallAsync Method (Closure)

AsyncExtensionsCallAsync Method (Closure)
Asynchronously calls this function with the specified args This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> CallAsync(
    this Closure function
)
<ExtensionAttribute>
Public Shared Function CallAsync (
    function As Closure
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ CallAsync(
    Closure^ function
)
[<ExtensionAttribute>]
static member CallAsync :
        function : Closure -> Task<DynValue>

Parameters

function
Type: MoonSharp.InterpreterClosure
The function.

Return Value

Type: Task DynValue

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Closure. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | Thrown if function is not of DataType.Function
See Also

Reference

AsyncExtensions Class
CallAsync Overload
MoonSharp.Interpreter Namespace


AsyncExtensions.CallAsync Method (Closure, DynValue[])

AsyncExtensionsCallAsync Method (Closure, DynValue)
Asynchronously calls this function with the specified args This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> CallAsync(
    this Closure function,
    params DynValue[] args
)
<ExtensionAttribute>
Public Shared Function CallAsync (
    function As Closure,
    ParamArray args As DynValue()
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ CallAsync(
    Closure^ function,
    ... array<DynValue^>^ args
)
[<ExtensionAttribute>]
static member CallAsync :
        function : Closure *
        args : DynValue[] -> Task<DynValue>

Parameters

function
Type: MoonSharp.InterpreterClosure
The function.
args
Type: MoonSharp.InterpreterDynValue
The arguments to pass to the function.

Return Value

Type: Task DynValue

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Closure. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | Thrown if function is not of DataType.Function
See Also

Reference

AsyncExtensions Class
CallAsync Overload
MoonSharp.Interpreter Namespace


AsyncExtensions.CallAsync Method (Closure, Object[])

AsyncExtensionsCallAsync Method (Closure, Object)
Asynchronously calls this function with the specified args This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> CallAsync(
    this Closure function,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Function CallAsync (
    function As Closure,
    ParamArray args As Object()
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ CallAsync(
    Closure^ function,
    ... array<Object^>^ args
)
[<ExtensionAttribute>]
static member CallAsync :
        function : Closure *
        args : Object[] -> Task<DynValue>

Parameters

function
Type: MoonSharp.InterpreterClosure
The function.
args
Type: SystemObject
The arguments to pass to the function.

Return Value

Type: Task DynValue

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Closure. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | Thrown if function is not of DataType.Function
See Also

Reference

AsyncExtensions Class
CallAsync Overload
MoonSharp.Interpreter Namespace


AsyncExtensions.CallAsync Method (Script, DynValue)

AsyncExtensionsCallAsync Method (Script, DynValue)
Calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> CallAsync(
    this Script script,
    DynValue function
)
<ExtensionAttribute>
Public Shared Function CallAsync (
    script As Script,
    function As DynValue
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ CallAsync(
    Script^ script,
    DynValue^ function
)
[<ExtensionAttribute>]
static member CallAsync :
        script : Script *
        function : DynValue -> Task<DynValue>

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
function
Type: MoonSharp.InterpreterDynValue
The Lua/MoonSharp function to be called

Return Value

Type: Task DynValue
The return value(s) of the function call.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Script. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | Thrown if function is not of DataType.Function
See Also

Reference

AsyncExtensions Class
CallAsync Overload
MoonSharp.Interpreter Namespace


AsyncExtensions.CallAsync Method (Script, Object)

AsyncExtensionsCallAsync Method (Script, Object)
Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> CallAsync(
    this Script script,
    Object function
)
<ExtensionAttribute>
Public Shared Function CallAsync (
    script As Script,
    function As Object
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ CallAsync(
    Script^ script,
    Object^ function
)
[<ExtensionAttribute>]
static member CallAsync :
        script : Script *
        function : Object -> Task<DynValue>

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
function
Type: SystemObject
The Lua/MoonSharp function to be called

Return Value

Type: Task DynValue

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Script. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | Thrown if function is not of DataType.Function
See Also

Reference

AsyncExtensions Class
CallAsync Overload
MoonSharp.Interpreter Namespace


AsyncExtensions.CallAsync Method (Script, DynValue, DynValue[])

AsyncExtensionsCallAsync Method (Script, DynValue, DynValue)
Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> CallAsync(
    this Script script,
    DynValue function,
    params DynValue[] args
)
<ExtensionAttribute>
Public Shared Function CallAsync (
    script As Script,
    function As DynValue,
    ParamArray args As DynValue()
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ CallAsync(
    Script^ script,
    DynValue^ function,
    ... array<DynValue^>^ args
)
[<ExtensionAttribute>]
static member CallAsync :
        script : Script *
        function : DynValue *
        args : DynValue[] -> Task<DynValue>

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
function
Type: MoonSharp.InterpreterDynValue
The Lua/MoonSharp function to be called
args
Type: MoonSharp.InterpreterDynValue
The arguments to pass to the function.

Return Value

Type: Task DynValue
The return value(s) of the function call.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Script. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | Thrown if function is not of DataType.Function
See Also

Reference

AsyncExtensions Class
CallAsync Overload
MoonSharp.Interpreter Namespace


AsyncExtensions.CallAsync Method (Script, DynValue, Object[])

AsyncExtensionsCallAsync Method (Script, DynValue, Object)
Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> CallAsync(
    this Script script,
    DynValue function,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Function CallAsync (
    script As Script,
    function As DynValue,
    ParamArray args As Object()
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ CallAsync(
    Script^ script,
    DynValue^ function,
    ... array<Object^>^ args
)
[<ExtensionAttribute>]
static member CallAsync :
        script : Script *
        function : DynValue *
        args : Object[] -> Task<DynValue>

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
function
Type: MoonSharp.InterpreterDynValue
The Lua/MoonSharp function to be called
args
Type: SystemObject
The arguments to pass to the function.

Return Value

Type: Task DynValue
The return value(s) of the function call.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Script. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | Thrown if function is not of DataType.Function
See Also

Reference

AsyncExtensions Class
CallAsync Overload
MoonSharp.Interpreter Namespace


AsyncExtensions.CallAsync Method (Script, Object, Object[])

AsyncExtensionsCallAsync Method (Script, Object, Object)
Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> CallAsync(
    this Script script,
    Object function,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Function CallAsync (
    script As Script,
    function As Object,
    ParamArray args As Object()
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ CallAsync(
    Script^ script,
    Object^ function,
    ... array<Object^>^ args
)
[<ExtensionAttribute>]
static member CallAsync :
        script : Script *
        function : Object *
        args : Object[] -> Task<DynValue>

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
function
Type: SystemObject
The Lua/MoonSharp function to be called
args
Type: SystemObject
The arguments to pass to the function.

Return Value

Type: Task DynValue

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Script. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | Thrown if function is not of DataType.Function
See Also

Reference

AsyncExtensions Class
CallAsync Overload
MoonSharp.Interpreter Namespace


AsyncExtensions.CreateDynamicExpressionAsync Method

AsyncExtensionsCreateDynamicExpressionAsync Method
Asynchronously creates a new dynamic expression. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynamicExpression> CreateDynamicExpressionAsync(
    this Script script,
    string code
)
<ExtensionAttribute>
Public Shared Function CreateDynamicExpressionAsync (
    script As Script,
    code As String
) As Task(Of DynamicExpression)
public:
[ExtensionAttribute]
static Task<DynamicExpression^>^ CreateDynamicExpressionAsync(
    Script^ script,
    String^ code
)
[<ExtensionAttribute>]
static member CreateDynamicExpressionAsync :
        script : Script *
        code : string -> Task<DynamicExpression>

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
code
Type: SystemString
The code of the expression.

Return Value

Type: Task DynamicExpression

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Script. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsyncExtensions Class
MoonSharp.Interpreter Namespace


AsyncExtensions.DoFileAsync Method

AsyncExtensionsDoFileAsync Method
Asynchronously loads and executes a file containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> DoFileAsync(
    this Script script,
    string filename,
    Table globalContext = null,
    string codeFriendlyName = null
)
<ExtensionAttribute>
Public Shared Function DoFileAsync (
    script As Script,
    filename As String,
    Optional globalContext As Table = Nothing,
    Optional codeFriendlyName As String = Nothing
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ DoFileAsync(
    Script^ script,
    String^ filename,
    Table^ globalContext = nullptr,
    String^ codeFriendlyName = nullptr
)
[<ExtensionAttribute>]
static member DoFileAsync :
        script : Script *
        filename : string *
        ?globalContext : Table *
        ?codeFriendlyName : string
(* Defaults:
        let _globalContext = defaultArg globalContext null
        let _codeFriendlyName = defaultArg codeFriendlyName null
*)
-> Task<DynValue>

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
filename
Type: SystemString
The filename.
globalContext (Optional)
Type: MoonSharp.InterpreterTable
The global context.
codeFriendlyName (Optional)
Type: SystemString
Name of the code - used to report errors, etc. Also used by debuggers to locate the original source file.

Return Value

Type: Task DynValue
A DynValue containing the result of the processing of the loaded chunk.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Script. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsyncExtensions Class
MoonSharp.Interpreter Namespace


AsyncExtensions.DoStreamAsync Method

AsyncExtensionsDoStreamAsync Method
Asynchronously loads and executes a stream containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> DoStreamAsync(
    this Script script,
    Stream stream,
    Table globalContext = null,
    string codeFriendlyName = null
)
<ExtensionAttribute>
Public Shared Function DoStreamAsync (
    script As Script,
    stream As Stream,
    Optional globalContext As Table = Nothing,
    Optional codeFriendlyName As String = Nothing
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ DoStreamAsync(
    Script^ script,
    Stream^ stream,
    Table^ globalContext = nullptr,
    String^ codeFriendlyName = nullptr
)
[<ExtensionAttribute>]
static member DoStreamAsync :
        script : Script *
        stream : Stream *
        ?globalContext : Table *
        ?codeFriendlyName : string
(* Defaults:
        let _globalContext = defaultArg globalContext null
        let _codeFriendlyName = defaultArg codeFriendlyName null
*)
-> Task<DynValue>

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
stream
Type: System.IOStream
The stream.
globalContext (Optional)
Type: MoonSharp.InterpreterTable
The global context.
codeFriendlyName (Optional)
Type: SystemString
Name of the code - used to report errors, etc. Also used by debuggers to locate the original source file.

Return Value

Type: Task DynValue
A DynValue containing the result of the processing of the loaded chunk.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Script. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsyncExtensions Class
MoonSharp.Interpreter Namespace


AsyncExtensions.DoStringAsync Method

AsyncExtensionsDoStringAsync Method
Asynchronously loads and executes a string containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> DoStringAsync(
    this Script script,
    string code,
    Table globalContext = null,
    string codeFriendlyName = null
)
<ExtensionAttribute>
Public Shared Function DoStringAsync (
    script As Script,
    code As String,
    Optional globalContext As Table = Nothing,
    Optional codeFriendlyName As String = Nothing
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ DoStringAsync(
    Script^ script,
    String^ code,
    Table^ globalContext = nullptr,
    String^ codeFriendlyName = nullptr
)
[<ExtensionAttribute>]
static member DoStringAsync :
        script : Script *
        code : string *
        ?globalContext : Table *
        ?codeFriendlyName : string
(* Defaults:
        let _globalContext = defaultArg globalContext null
        let _codeFriendlyName = defaultArg codeFriendlyName null
*)
-> Task<DynValue>

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
code
Type: SystemString
The code.
globalContext (Optional)
Type: MoonSharp.InterpreterTable
The global context.
codeFriendlyName (Optional)
Type: SystemString
Name of the code - used to report errors, etc. Also used by debuggers to locate the original source file.

Return Value

Type: Task DynValue
A DynValue containing the result of the processing of the loaded chunk.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Script. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsyncExtensions Class
MoonSharp.Interpreter Namespace


AsyncExtensions.DumpAsync Method

AsyncExtensionsDumpAsync Method
Asynchronously dumps a function on the specified stream. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task DumpAsync(
    this Script script,
    DynValue function,
    Stream stream
)
<ExtensionAttribute>
Public Shared Function DumpAsync (
    script As Script,
    function As DynValue,
    stream As Stream
) As Task
public:
[ExtensionAttribute]
static Task^ DumpAsync(
    Script^ script,
    DynValue^ function,
    Stream^ stream
)
[<ExtensionAttribute>]
static member DumpAsync :
        script : Script *
        function : DynValue *
        stream : Stream -> Task

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
function
Type: MoonSharp.InterpreterDynValue
The function.
stream
Type: System.IOStream
The stream.

Return Value

Type: Task

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Script. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | function arg is not a function! or stream is readonly! or function arg has upvalues other than _ENV
See Also

Reference

AsyncExtensions Class
MoonSharp.Interpreter Namespace


AsyncExtensions.EvaluateAsync Method

AsyncExtensionsEvaluateAsync Method
Asynchronously evaluates a REPL command. This method returns the result of the computation, or null if more input is needed for having valid code. In case of errors, exceptions are propagated to the caller. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> EvaluateAsync(
    this ReplInterpreter interpreter,
    string input
)
<ExtensionAttribute>
Public Shared Function EvaluateAsync (
    interpreter As ReplInterpreter,
    input As String
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ EvaluateAsync(
    ReplInterpreter^ interpreter,
    String^ input
)
[<ExtensionAttribute>]
static member EvaluateAsync :
        interpreter : ReplInterpreter *
        input : string -> Task<DynValue>

Parameters

interpreter
Type: MoonSharp.Interpreter.REPLReplInterpreter
The interpreter.
input
Type: SystemString
The input.

Return Value

Type: Task DynValue
This method returns the result of the computation, or null if more input is needed for a computation.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ReplInterpreter. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsyncExtensions Class
MoonSharp.Interpreter Namespace


AsyncExtensions.LoadFileAsync Method

AsyncExtensionsLoadFileAsync Method
Asynchronously loads a string containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> LoadFileAsync(
    this Script script,
    string filename,
    Table globalContext = null,
    string friendlyFilename = null
)
<ExtensionAttribute>
Public Shared Function LoadFileAsync (
    script As Script,
    filename As String,
    Optional globalContext As Table = Nothing,
    Optional friendlyFilename As String = Nothing
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ LoadFileAsync(
    Script^ script,
    String^ filename,
    Table^ globalContext = nullptr,
    String^ friendlyFilename = nullptr
)
[<ExtensionAttribute>]
static member LoadFileAsync :
        script : Script *
        filename : string *
        ?globalContext : Table *
        ?friendlyFilename : string
(* Defaults:
        let _globalContext = defaultArg globalContext null
        let _friendlyFilename = defaultArg friendlyFilename null
*)
-> Task<DynValue>

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
filename
Type: SystemString
The code.
globalContext (Optional)
Type: MoonSharp.InterpreterTable
The global table to bind to this chunk.
friendlyFilename (Optional)
Type: SystemString
The filename to be used in error messages.

Return Value

Type: Task DynValue
A DynValue containing a function which will execute the loaded code.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Script. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsyncExtensions Class
MoonSharp.Interpreter Namespace


AsyncExtensions.LoadFunctionAsync Method

AsyncExtensionsLoadFunctionAsync Method
Asynchronously loads a string containing a Lua/MoonSharp function. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> LoadFunctionAsync(
    this Script script,
    string code,
    Table globalTable = null,
    string funcFriendlyName = null
)
<ExtensionAttribute>
Public Shared Function LoadFunctionAsync (
    script As Script,
    code As String,
    Optional globalTable As Table = Nothing,
    Optional funcFriendlyName As String = Nothing
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ LoadFunctionAsync(
    Script^ script,
    String^ code,
    Table^ globalTable = nullptr,
    String^ funcFriendlyName = nullptr
)
[<ExtensionAttribute>]
static member LoadFunctionAsync :
        script : Script *
        code : string *
        ?globalTable : Table *
        ?funcFriendlyName : string
(* Defaults:
        let _globalTable = defaultArg globalTable null
        let _funcFriendlyName = defaultArg funcFriendlyName null
*)
-> Task<DynValue>

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
code
Type: SystemString
The code.
globalTable (Optional)
Type: MoonSharp.InterpreterTable
The global table to bind to this chunk.
funcFriendlyName (Optional)
Type: SystemString
Name of the function used to report errors, etc.

Return Value

Type: Task DynValue
A DynValue containing a function which will execute the loaded code.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Script. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsyncExtensions Class
MoonSharp.Interpreter Namespace


AsyncExtensions.LoadStreamAsync Method

AsyncExtensionsLoadStreamAsync Method
Asynchronously loads a Lua/MoonSharp script from a System.IO.Stream. NOTE: This will *NOT* close the stream! This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> LoadStreamAsync(
    this Script script,
    Stream stream,
    Table globalTable = null,
    string codeFriendlyName = null
)
<ExtensionAttribute>
Public Shared Function LoadStreamAsync (
    script As Script,
    stream As Stream,
    Optional globalTable As Table = Nothing,
    Optional codeFriendlyName As String = Nothing
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ LoadStreamAsync(
    Script^ script,
    Stream^ stream,
    Table^ globalTable = nullptr,
    String^ codeFriendlyName = nullptr
)
[<ExtensionAttribute>]
static member LoadStreamAsync :
        script : Script *
        stream : Stream *
        ?globalTable : Table *
        ?codeFriendlyName : string
(* Defaults:
        let _globalTable = defaultArg globalTable null
        let _codeFriendlyName = defaultArg codeFriendlyName null
*)
-> Task<DynValue>

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
stream
Type: System.IOStream
The stream containing code.
globalTable (Optional)
Type: MoonSharp.InterpreterTable
The global table to bind to this chunk.
codeFriendlyName (Optional)
Type: SystemString
Name of the code - used to report errors, etc.

Return Value

Type: Task DynValue
A DynValue containing a function which will execute the loaded code.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Script. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsyncExtensions Class
MoonSharp.Interpreter Namespace


AsyncExtensions.LoadStringAsync Method

AsyncExtensionsLoadStringAsync Method
Asynchronously loads a string containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> LoadStringAsync(
    this Script script,
    string code,
    Table globalTable = null,
    string codeFriendlyName = null
)
<ExtensionAttribute>
Public Shared Function LoadStringAsync (
    script As Script,
    code As String,
    Optional globalTable As Table = Nothing,
    Optional codeFriendlyName As String = Nothing
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ LoadStringAsync(
    Script^ script,
    String^ code,
    Table^ globalTable = nullptr,
    String^ codeFriendlyName = nullptr
)
[<ExtensionAttribute>]
static member LoadStringAsync :
        script : Script *
        code : string *
        ?globalTable : Table *
        ?codeFriendlyName : string
(* Defaults:
        let _globalTable = defaultArg globalTable null
        let _codeFriendlyName = defaultArg codeFriendlyName null
*)
-> Task<DynValue>

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
code
Type: SystemString
The code.
globalTable (Optional)
Type: MoonSharp.InterpreterTable
The global table to bind to this chunk.
codeFriendlyName (Optional)
Type: SystemString
Name of the code - used to report errors, etc.

Return Value

Type: Task DynValue
A DynValue containing a function which will execute the loaded code.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Script. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsyncExtensions Class
MoonSharp.Interpreter Namespace


AsyncExtensions.ResumeAsync Method

AsyncExtensionsResumeAsync Method
Overload List
Name | Description
ResumeAsync(Coroutine) | Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
ResumeAsync(Coroutine, DynValue) | Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
ResumeAsync(Coroutine, ScriptExecutionContext) | Resumes the coroutine. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
ResumeAsync(Coroutine, Object) | Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
ResumeAsync(Coroutine, ScriptExecutionContext, DynValue) | Resumes the coroutine. This method is supported only on .NET 4.x and .NET 4.x PCL targets.
ResumeAsync(Coroutine, ScriptExecutionContext, Object) | Resumes the coroutine This method is supported only on .NET 4.x and .NET 4.x PCL targets.
Top
See Also

Reference

AsyncExtensions Class
MoonSharp.Interpreter Namespace


AsyncExtensions.ResumeAsync Method (Coroutine)

AsyncExtensionsResumeAsync Method (Coroutine)
Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> ResumeAsync(
    this Coroutine cor
)
<ExtensionAttribute>
Public Shared Function ResumeAsync (
    cor As Coroutine
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ ResumeAsync(
    Coroutine^ cor
)
[<ExtensionAttribute>]
static member ResumeAsync :
        cor : Coroutine -> Task<DynValue>

Parameters

cor
Type: MoonSharp.InterpreterCoroutine
The coroutine

Return Value

Type: Task DynValue

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Coroutine. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
InvalidOperationException | Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead
See Also

Reference

AsyncExtensions Class
ResumeAsync Overload
MoonSharp.Interpreter Namespace


AsyncExtensions.ResumeAsync Method (Coroutine, DynValue[])

AsyncExtensionsResumeAsync Method (Coroutine, DynValue)
Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> ResumeAsync(
    this Coroutine cor,
    params DynValue[] args
)
<ExtensionAttribute>
Public Shared Function ResumeAsync (
    cor As Coroutine,
    ParamArray args As DynValue()
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ ResumeAsync(
    Coroutine^ cor,
    ... array<DynValue^>^ args
)
[<ExtensionAttribute>]
static member ResumeAsync :
        cor : Coroutine *
        args : DynValue[] -> Task<DynValue>

Parameters

cor
Type: MoonSharp.InterpreterCoroutine
The coroutine
args
Type: MoonSharp.InterpreterDynValue
The arguments.

Return Value

Type: Task DynValue

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Coroutine. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
InvalidOperationException | Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead
See Also

Reference

AsyncExtensions Class
ResumeAsync Overload
MoonSharp.Interpreter Namespace


AsyncExtensions.ResumeAsync Method (Coroutine, ScriptExecutionContext)

AsyncExtensionsResumeAsync Method (Coroutine, ScriptExecutionContext)
Resumes the coroutine. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> ResumeAsync(
    this Coroutine cor,
    ScriptExecutionContext context
)
<ExtensionAttribute>
Public Shared Function ResumeAsync (
    cor As Coroutine,
    context As ScriptExecutionContext
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ ResumeAsync(
    Coroutine^ cor,
    ScriptExecutionContext^ context
)
[<ExtensionAttribute>]
static member ResumeAsync :
        cor : Coroutine *
        context : ScriptExecutionContext -> Task<DynValue>

Parameters

cor
Type: MoonSharp.InterpreterCoroutine
The coroutine
context
Type: MoonSharp.InterpreterScriptExecutionContext
The ScriptExecutionContext.

Return Value

Type: Task DynValue

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Coroutine. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsyncExtensions Class
ResumeAsync Overload
MoonSharp.Interpreter Namespace


AsyncExtensions.ResumeAsync Method (Coroutine, Object[])

AsyncExtensionsResumeAsync Method (Coroutine, Object)
Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> ResumeAsync(
    this Coroutine cor,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Function ResumeAsync (
    cor As Coroutine,
    ParamArray args As Object()
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ ResumeAsync(
    Coroutine^ cor,
    ... array<Object^>^ args
)
[<ExtensionAttribute>]
static member ResumeAsync :
        cor : Coroutine *
        args : Object[] -> Task<DynValue>

Parameters

cor
Type: MoonSharp.InterpreterCoroutine
The coroutine
args
Type: SystemObject
The arguments.

Return Value

Type: Task DynValue

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Coroutine. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
InvalidOperationException | Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead.
See Also

Reference

AsyncExtensions Class
ResumeAsync Overload
MoonSharp.Interpreter Namespace


AsyncExtensions.ResumeAsync Method (Coroutine, ScriptExecutionContext, DynValue[])

AsyncExtensionsResumeAsync Method (Coroutine, ScriptExecutionContext, DynValue)
Resumes the coroutine. This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> ResumeAsync(
    this Coroutine cor,
    ScriptExecutionContext context,
    params DynValue[] args
)
<ExtensionAttribute>
Public Shared Function ResumeAsync (
    cor As Coroutine,
    context As ScriptExecutionContext,
    ParamArray args As DynValue()
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ ResumeAsync(
    Coroutine^ cor,
    ScriptExecutionContext^ context,
    ... array<DynValue^>^ args
)
[<ExtensionAttribute>]
static member ResumeAsync :
        cor : Coroutine *
        context : ScriptExecutionContext *
        args : DynValue[] -> Task<DynValue>

Parameters

cor
Type: MoonSharp.InterpreterCoroutine
The coroutine
context
Type: MoonSharp.InterpreterScriptExecutionContext
The ScriptExecutionContext.
args
Type: MoonSharp.InterpreterDynValue
The arguments.

Return Value

Type: Task DynValue

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Coroutine. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsyncExtensions Class
ResumeAsync Overload
MoonSharp.Interpreter Namespace


AsyncExtensions.ResumeAsync Method (Coroutine, ScriptExecutionContext, Object[])

AsyncExtensionsResumeAsync Method (Coroutine, ScriptExecutionContext, Object)
Resumes the coroutine This method is supported only on .NET 4.x and .NET 4.x PCL targets.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<DynValue> ResumeAsync(
    this Coroutine cor,
    ScriptExecutionContext context,
    params Object[] args
)
<ExtensionAttribute>
Public Shared Function ResumeAsync (
    cor As Coroutine,
    context As ScriptExecutionContext,
    ParamArray args As Object()
) As Task(Of DynValue)
public:
[ExtensionAttribute]
static Task<DynValue^>^ ResumeAsync(
    Coroutine^ cor,
    ScriptExecutionContext^ context,
    ... array<Object^>^ args
)
[<ExtensionAttribute>]
static member ResumeAsync :
        cor : Coroutine *
        context : ScriptExecutionContext *
        args : Object[] -> Task<DynValue>

Parameters

cor
Type: MoonSharp.InterpreterCoroutine
The coroutine
context
Type: MoonSharp.InterpreterScriptExecutionContext
The ScriptExecutionContext.
args
Type: SystemObject
The arguments.

Return Value

Type: Task DynValue

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Coroutine. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AsyncExtensions Class
ResumeAsync Overload
MoonSharp.Interpreter Namespace


CallbackArguments Class

CallbackArguments Class
This class is a container for arguments received by a CallbackFunction
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterCallbackArguments

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class CallbackArguments
Public Class CallbackArguments
public ref class CallbackArguments
type CallbackArguments =  class end

The CallbackArguments type exposes the following members.

Constructors
 | Name | Description
Public method | CallbackArguments | Initializes a new instance of the CallbackArguments class.
Top
Properties
 | Name | Description
Public property | Count | Gets the count of arguments
Public property | IsMethodCall | Gets or sets a value indicating whether this is a method call.
Public property | Item | Gets the DynValue at the specified index, or Void if not found
Top
Methods
 | Name | Description
Public method | AsInt | Gets the specified argument as an integer
Public method | AsLong | Gets the specified argument as a long integer
Public method | AsStringUsingMeta | Gets the specified argument as a string, calling the __tostring metamethod if needed, in a NON yield-compatible way.
Public method | AsType | Gets the specified argument as as an argument of the specified type. If not possible, an exception is raised.
Public method | AsUserDataT | Gets the specified argument as as an argument of the specified user data type. If not possible, an exception is raised.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArray | Converts the arguments to an array
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RawGet | Gets the DynValue at the specified index, or null.
Public method | SkipMethodCall | Returns a copy of CallbackArguments where the first ("self") argument is skipped if this was a method call, otherwise returns itself.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


CallbackArguments Constructor

CallbackArguments Constructor
Initializes a new instance of the CallbackArguments class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CallbackArguments(
    IList<DynValue> args,
    bool isMethodCall
)
Public Sub New (
    args As IList(Of DynValue),
    isMethodCall As Boolean
)
public:
CallbackArguments(
    IList<DynValue^>^ args,
    bool isMethodCall
)
new :
        args : IList<DynValue> *
        isMethodCall : bool -> CallbackArguments

Parameters

args
Type: System.Collections.GenericIList DynValue
The arguments.
isMethodCall
Type: SystemBoolean
if set to true [is method call].
See Also

Reference

CallbackArguments Class
MoonSharp.Interpreter Namespace


CallbackArguments Properties

CallbackArguments Properties

The CallbackArguments type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the count of arguments
Public property | IsMethodCall | Gets or sets a value indicating whether this is a method call.
Public property | Item | Gets the DynValue at the specified index, or Void if not found
Top
See Also

Reference

CallbackArguments Class
MoonSharp.Interpreter Namespace


CallbackArguments.Count Property

CallbackArgumentsCount Property
Gets the count of arguments

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Type: Int32
See Also

Reference

CallbackArguments Class
MoonSharp.Interpreter Namespace


CallbackArguments.IsMethodCall Property

CallbackArgumentsIsMethodCall Property
Gets or sets a value indicating whether this is a method call.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMethodCall { get; }
Public ReadOnly Property IsMethodCall As Boolean
    Get
public:
property bool IsMethodCall {
    bool get ();
}
member IsMethodCall : bool with get

Property Value

Type: Boolean
See Also

Reference

CallbackArguments Class
MoonSharp.Interpreter Namespace


CallbackArguments.Item Property

CallbackArgumentsItem Property
Gets the DynValue at the specified index, or Void if not found

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As DynValue
    Get
public:
property DynValue^ default[int index] {
    DynValue^ get (int index);
}
member Item : DynValue with get

Parameters

index
Type: SystemInt32

Property Value

Type: DynValue
See Also

Reference

CallbackArguments Class
MoonSharp.Interpreter Namespace


CallbackArguments Methods

CallbackArguments Methods

The CallbackArguments type exposes the following members.

Methods
 | Name | Description
Public method | AsInt | Gets the specified argument as an integer
Public method | AsLong | Gets the specified argument as a long integer
Public method | AsStringUsingMeta | Gets the specified argument as a string, calling the __tostring metamethod if needed, in a NON yield-compatible way.
Public method | AsType | Gets the specified argument as as an argument of the specified type. If not possible, an exception is raised.
Public method | AsUserDataT | Gets the specified argument as as an argument of the specified user data type. If not possible, an exception is raised.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetArray | Converts the arguments to an array
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RawGet | Gets the DynValue at the specified index, or null.
Public method | SkipMethodCall | Returns a copy of CallbackArguments where the first ("self") argument is skipped if this was a method call, otherwise returns itself.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CallbackArguments Class
MoonSharp.Interpreter Namespace


CallbackArguments.AsInt Method

CallbackArgumentsAsInt Method
Gets the specified argument as an integer

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int AsInt(
    int argNum,
    string funcName
)
Public Function AsInt (
    argNum As Integer,
    funcName As String
) As Integer
public:
int AsInt(
    int argNum,
    String^ funcName
)
member AsInt :
        argNum : int *
        funcName : string -> int

Parameters

argNum
Type: SystemInt32
The argument number.
funcName
Type: SystemString
Name of the function.

Return Value

Type: Int32
See Also

Reference

CallbackArguments Class
MoonSharp.Interpreter Namespace


CallbackArguments.AsLong Method

CallbackArgumentsAsLong Method
Gets the specified argument as a long integer

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public long AsLong(
    int argNum,
    string funcName
)
Public Function AsLong (
    argNum As Integer,
    funcName As String
) As Long
public:
long long AsLong(
    int argNum,
    String^ funcName
)
member AsLong :
        argNum : int *
        funcName : string -> int64

Parameters

argNum
Type: SystemInt32
The argument number.
funcName
Type: SystemString
Name of the function.

Return Value

Type: Int64
See Also

Reference

CallbackArguments Class
MoonSharp.Interpreter Namespace


CallbackArguments.AsStringUsingMeta Method

CallbackArgumentsAsStringUsingMeta Method
Gets the specified argument as a string, calling the __tostring metamethod if needed, in a NON yield-compatible way.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string AsStringUsingMeta(
    ScriptExecutionContext executionContext,
    int argNum,
    string funcName
)
Public Function AsStringUsingMeta (
    executionContext As ScriptExecutionContext,
    argNum As Integer,
    funcName As String
) As String
public:
String^ AsStringUsingMeta(
    ScriptExecutionContext^ executionContext,
    int argNum,
    String^ funcName
)
member AsStringUsingMeta :
        executionContext : ScriptExecutionContext *
        argNum : int *
        funcName : string -> string

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext
The execution context.
argNum
Type: SystemInt32
The argument number.
funcName
Type: SystemString
Name of the function.

Return Value

Type: String
Exceptions
Exception | Condition
ScriptRuntimeException | 'tostring' must return a string to '{0}'
See Also

Reference

CallbackArguments Class
MoonSharp.Interpreter Namespace


CallbackArguments.AsType Method

CallbackArgumentsAsType Method
Gets the specified argument as as an argument of the specified type. If not possible, an exception is raised.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue AsType(
    int argNum,
    string funcName,
    DataType type,
    bool allowNil = false
)
Public Function AsType (
    argNum As Integer,
    funcName As String,
    type As DataType,
    Optional allowNil As Boolean = false
) As DynValue
public:
DynValue^ AsType(
    int argNum,
    String^ funcName,
    DataType type,
    bool allowNil = false
)
member AsType :
        argNum : int *
        funcName : string *
        type : DataType *
        ?allowNil : bool
(* Defaults:
        let _allowNil = defaultArg allowNil false
*)
-> DynValue

Parameters

argNum
Type: SystemInt32
The argument number.
funcName
Type: SystemString
Name of the function.
type
Type: MoonSharp.InterpreterDataType
The type desired.
allowNil (Optional)
Type: SystemBoolean
if set to true nil values are allowed.

Return Value

Type: DynValue
See Also

Reference

CallbackArguments Class
MoonSharp.Interpreter Namespace


CallbackArguments.AsUserData(T) Method

CallbackArgumentsAsUserDataT Method
Gets the specified argument as as an argument of the specified user data type. If not possible, an exception is raised.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public T AsUserData<T>(
    int argNum,
    string funcName,
    bool allowNil = false
)

Public Function AsUserData(Of T) (
    argNum As Integer,
    funcName As String,
    Optional allowNil As Boolean = false
) As T
public:
generic<typename T>
T AsUserData(
    int argNum,
    String^ funcName,
    bool allowNil = false
)
member AsUserData :
        argNum : int *
        funcName : string *
        ?allowNil : bool
(* Defaults:
        let _allowNil = defaultArg allowNil false
*)
-> 'T

Parameters

argNum
Type: SystemInt32
The argument number.
funcName
Type: SystemString
Name of the function.
allowNil (Optional)
Type: SystemBoolean
if set to true nil values are allowed.

Type Parameters

T
The desired userdata type

Return Value

Type: T
See Also

Reference

CallbackArguments Class
MoonSharp.Interpreter Namespace


CallbackArguments.GetArray Method

CallbackArgumentsGetArray Method
Converts the arguments to an array

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue[] GetArray(
    int skip = 0
)
Public Function GetArray (
    Optional skip As Integer = 0
) As DynValue()
public:
array<DynValue^>^ GetArray(
    int skip = 0
)
member GetArray :
        ?skip : int
(* Defaults:
        let _skip = defaultArg skip 0
*)
-> DynValue[]

Parameters

skip (Optional)
Type: SystemInt32
The number of elements to skip (default= 0).

Return Value

Type: DynValue
See Also

Reference

CallbackArguments Class
MoonSharp.Interpreter Namespace


CallbackArguments.RawGet Method

CallbackArgumentsRawGet Method
Gets the DynValue at the specified index, or null.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue RawGet(
    int index,
    bool translateVoids
)
Public Function RawGet (
    index As Integer,
    translateVoids As Boolean
) As DynValue
public:
DynValue^ RawGet(
    int index,
    bool translateVoids
)
member RawGet :
        index : int *
        translateVoids : bool -> DynValue

Parameters

index
Type: SystemInt32
The index.
translateVoids
Type: SystemBoolean
if set to true all voids are translated to nils.

Return Value

Type: DynValue
See Also

Reference

CallbackArguments Class
MoonSharp.Interpreter Namespace


CallbackArguments.SkipMethodCall Method

CallbackArgumentsSkipMethodCall Method
Returns a copy of CallbackArguments where the first ("self") argument is skipped if this was a method call, otherwise returns itself.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CallbackArguments SkipMethodCall()
Public Function SkipMethodCall As CallbackArguments
public:
CallbackArguments^ SkipMethodCall()
member SkipMethodCall : unit -> CallbackArguments

Return Value

Type: CallbackArguments
See Also

Reference

CallbackArguments Class
MoonSharp.Interpreter Namespace


CallbackFunction Class

CallbackFunction Class
This class wraps a CLR function
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterRefIdObject
MoonSharp.InterpreterCallbackFunction

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CallbackFunction : RefIdObject
Public NotInheritable Class CallbackFunction
    Inherits RefIdObject
public ref class CallbackFunction sealed : public RefIdObject
[<SealedAttribute>]
type CallbackFunction =
    class
        inherit RefIdObject
    end

The CallbackFunction type exposes the following members.

Constructors
 | Name | Description
Public method | CallbackFunction | Initializes a new instance of the CallbackFunction class.
Top
Properties
 | Name | Description
Public property | AdditionalData | Gets or sets an object used as additional data to the callback function (available in the execution context).
Public property | ClrCallback | Gets the call back.
 | DefaultAccessMode | Gets or sets the default access mode used when marshalling delegates
Public property | Name | Gets the name of the function
Public property | ReferenceID | Gets the reference identifier. (Inherited from RefIdObject.)
Top
Methods
 | Name | Description
 | CheckCallbackSignature | Checks the callback signature of a method is compatible for callbacks
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FormatTypeString | Formats a string with a type name and a ref-id (Inherited from RefIdObject.)
 | FromDelegate | Creates a CallbackFunction from a delegate.
 | FromMethodInfo | Creates a CallbackFunction from a MethodInfo relative to a function.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Invokes the callback function
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


CallbackFunction Constructor

CallbackFunction Constructor
Initializes a new instance of the CallbackFunction class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CallbackFunction(
    Func<ScriptExecutionContext, CallbackArguments, DynValue> callBack,
    string name = null
)
Public Sub New (
    callBack As Func(Of ScriptExecutionContext, CallbackArguments, DynValue),
    Optional name As String = Nothing
)
public:
CallbackFunction(
    Func<ScriptExecutionContext^, CallbackArguments^, DynValue^>^ callBack,
    String^ name = nullptr
)
new :
        callBack : Func<ScriptExecutionContext, CallbackArguments, DynValue> *
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> CallbackFunction

Parameters

callBack
Type: SystemFunc ScriptExecutionContext, CallbackArguments, DynValue
The callback function to be called.
name (Optional)
Type: SystemString
The callback name, used in stacktraces, debugger, etc..
See Also

Reference

CallbackFunction Class
MoonSharp.Interpreter Namespace


CallbackFunction Properties

CallbackFunction Properties

The CallbackFunction type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Gets or sets an object used as additional data to the callback function (available in the execution context).
Public property | ClrCallback | Gets the call back.
 | DefaultAccessMode | Gets or sets the default access mode used when marshalling delegates
Public property | Name | Gets the name of the function
Public property | ReferenceID | Gets the reference identifier. (Inherited from RefIdObject.)
Top
See Also

Reference

CallbackFunction Class
MoonSharp.Interpreter Namespace


CallbackFunction.AdditionalData Property

CallbackFunctionAdditionalData Property
Gets or sets an object used as additional data to the callback function (available in the execution context).

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Object AdditionalData { get; set; }
Public Property AdditionalData As Object
    Get
    Set
public:
property Object^ AdditionalData {
    Object^ get ();
    void set (Object^ value);
}
member AdditionalData : Object with get, set

Property Value

Type: Object
See Also

Reference

CallbackFunction Class
MoonSharp.Interpreter Namespace


CallbackFunction.ClrCallback Property

CallbackFunctionClrCallback Property
Gets the call back.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Func<ScriptExecutionContext, CallbackArguments, DynValue> ClrCallback { get; }
Public ReadOnly Property ClrCallback As Func(Of ScriptExecutionContext, CallbackArguments, DynValue)
    Get
public:
property Func<ScriptExecutionContext^, CallbackArguments^, DynValue^>^ ClrCallback {
    Func<ScriptExecutionContext^, CallbackArguments^, DynValue^>^ get ();
}
member ClrCallback : Func<ScriptExecutionContext, CallbackArguments, DynValue> with get

Property Value

Type: Func ScriptExecutionContext, CallbackArguments, DynValue
The call back.
See Also

Reference

CallbackFunction Class
MoonSharp.Interpreter Namespace


CallbackFunction.DefaultAccessMode Property

CallbackFunctionDefaultAccessMode Property
Gets or sets the default access mode used when marshalling delegates

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static InteropAccessMode DefaultAccessMode { get; set; }
Public Shared Property DefaultAccessMode As InteropAccessMode
    Get
    Set
public:
static property InteropAccessMode DefaultAccessMode {
    InteropAccessMode get ();
    void set (InteropAccessMode value);
}
static member DefaultAccessMode : InteropAccessMode with get, set

Property Value

Type: InteropAccessMode
The default access mode. Default, HideMembers and BackgroundOptimized are NOT supported.
Exceptions
Exception | Condition
ArgumentException | Default, HideMembers and BackgroundOptimized are NOT supported.
See Also

Reference

CallbackFunction Class
MoonSharp.Interpreter Namespace


CallbackFunction.Name Property

CallbackFunctionName Property
Gets the name of the function

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

CallbackFunction Class
MoonSharp.Interpreter Namespace


CallbackFunction Methods

CallbackFunction Methods

The CallbackFunction type exposes the following members.

Methods
 | Name | Description
 | CheckCallbackSignature | Checks the callback signature of a method is compatible for callbacks
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FormatTypeString | Formats a string with a type name and a ref-id (Inherited from RefIdObject.)
 | FromDelegate | Creates a CallbackFunction from a delegate.
 | FromMethodInfo | Creates a CallbackFunction from a MethodInfo relative to a function.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Invokes the callback function
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CallbackFunction Class
MoonSharp.Interpreter Namespace


CallbackFunction.CheckCallbackSignature Method

CallbackFunctionCheckCallbackSignature Method
Checks the callback signature of a method is compatible for callbacks

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckCallbackSignature(
    MethodInfo mi,
    bool requirePublicVisibility
)
Public Shared Function CheckCallbackSignature (
    mi As MethodInfo,
    requirePublicVisibility As Boolean
) As Boolean
public:
static bool CheckCallbackSignature(
    MethodInfo^ mi,
    bool requirePublicVisibility
)
static member CheckCallbackSignature :
        mi : MethodInfo *
        requirePublicVisibility : bool -> bool

Parameters

mi
Type: System.ReflectionMethodInfo

[Missing <param name="mi"/> documentation for "M:MoonSharp.Interpreter.CallbackFunction.CheckCallbackSignature(System.Reflection.MethodInfo,System.Boolean)"]

requirePublicVisibility
Type: SystemBoolean

[Missing <param name="requirePublicVisibility"/> documentation for "M:MoonSharp.Interpreter.CallbackFunction.CheckCallbackSignature(System.Reflection.MethodInfo,System.Boolean)"]

Return Value

Type: Boolean
See Also

Reference

CallbackFunction Class
MoonSharp.Interpreter Namespace


CallbackFunction.FromDelegate Method

CallbackFunctionFromDelegate Method
Creates a CallbackFunction from a delegate.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static CallbackFunction FromDelegate(
    Script script,
    Delegate del,
    InteropAccessMode accessMode = InteropAccessMode.Default
)
Public Shared Function FromDelegate (
    script As Script,
    del As Delegate,
    Optional accessMode As InteropAccessMode = InteropAccessMode.Default
) As CallbackFunction
public:
static CallbackFunction^ FromDelegate(
    Script^ script,
    Delegate^ del,
    InteropAccessMode accessMode = InteropAccessMode::Default
)
static member FromDelegate :
        script : Script *
        del : Delegate *
        ?accessMode : InteropAccessMode
(* Defaults:
        let _accessMode = defaultArg accessMode InteropAccessMode.Default
*)
-> CallbackFunction

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
del
Type: SystemDelegate
The delegate.
accessMode (Optional)
Type: MoonSharp.InterpreterInteropAccessMode
The access mode.

Return Value

Type: CallbackFunction
See Also

Reference

CallbackFunction Class
MoonSharp.Interpreter Namespace


CallbackFunction.FromMethodInfo Method

CallbackFunctionFromMethodInfo Method
Creates a CallbackFunction from a MethodInfo relative to a function.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static CallbackFunction FromMethodInfo(
    Script script,
    MethodInfo mi,
    Object obj = null,
    InteropAccessMode accessMode = InteropAccessMode.Default
)
Public Shared Function FromMethodInfo (
    script As Script,
    mi As MethodInfo,
    Optional obj As Object = Nothing,
    Optional accessMode As InteropAccessMode = InteropAccessMode.Default
) As CallbackFunction
public:
static CallbackFunction^ FromMethodInfo(
    Script^ script,
    MethodInfo^ mi,
    Object^ obj = nullptr,
    InteropAccessMode accessMode = InteropAccessMode::Default
)
static member FromMethodInfo :
        script : Script *
        mi : MethodInfo *
        ?obj : Object *
        ?accessMode : InteropAccessMode
(* Defaults:
        let _obj = defaultArg obj null
        let _accessMode = defaultArg accessMode InteropAccessMode.Default
*)
-> CallbackFunction

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
mi
Type: System.ReflectionMethodInfo
The MethodInfo object.
obj (Optional)
Type: SystemObject
The object to which the function applies, or null for static methods.
accessMode (Optional)
Type: MoonSharp.InterpreterInteropAccessMode
The access mode.

Return Value

Type: CallbackFunction
Exceptions
Exception | Condition
ArgumentException | The method is not static.
See Also

Reference

CallbackFunction Class
MoonSharp.Interpreter Namespace


CallbackFunction.Invoke Method

CallbackFunctionInvoke Method
Invokes the callback function

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Invoke(
    ScriptExecutionContext executionContext,
    IList<DynValue> args,
    bool isMethodCall = false
)
Public Function Invoke (
    executionContext As ScriptExecutionContext,
    args As IList(Of DynValue),
    Optional isMethodCall As Boolean = false
) As DynValue
public:
DynValue^ Invoke(
    ScriptExecutionContext^ executionContext,
    IList<DynValue^>^ args,
    bool isMethodCall = false
)
member Invoke :
        executionContext : ScriptExecutionContext *
        args : IList<DynValue> *
        ?isMethodCall : bool
(* Defaults:
        let _isMethodCall = defaultArg isMethodCall false
*)
-> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext
The execution context.
args
Type: System.Collections.GenericIList DynValue
The arguments.
isMethodCall (Optional)
Type: SystemBoolean
if set to true this is a method call.

Return Value

Type: DynValue
See Also

Reference

CallbackFunction Class
MoonSharp.Interpreter Namespace


Closure Class

Closure Class
A class representing a script function
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterRefIdObject
MoonSharp.InterpreterClosure

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class Closure : RefIdObject, IScriptPrivateResource
Public Class Closure
    Inherits RefIdObject
    Implements IScriptPrivateResource
public ref class Closure : public RefIdObject,
    IScriptPrivateResource
type Closure =
    class
        inherit RefIdObject
        interface IScriptPrivateResource
    end

The Closure type exposes the following members.

Properties
 | Name | Description
Public property | EntryPointByteCodeLocation | Gets the entry point location in bytecode .
Public property | OwnerScript | Gets the script owning this function
Public property | ReferenceID | Gets the reference identifier. (Inherited from RefIdObject.)
Top
Methods
 | Name | Description
Public method | Call | Calls this function with the specified args
Public method | Call(Object) | Calls this function with the specified args
Public method | Call(DynValue) | Calls this function with the specified args
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormatTypeString | Formats a string with a type name and a ref-id (Inherited from RefIdObject.)
Public method | GetDelegate | Gets a delegate wrapping calls to this scripted function
Public method | GetDelegateT | Gets a delegate wrapping calls to this scripted function
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUpvalue | Gets the value of an upvalue. To set the value, use GetUpvalue(idx).Assign(...);
Public method | GetUpvalueName | Gets the name of the specified upvalue.
Public method | GetUpvaluesCount | Gets the number of upvalues in this closure
Public method | GetUpvaluesType | Gets the type of the upvalues contained in this closure
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CallAsync | Overloaded. Asynchronously calls this function with the specified args This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | CallAsync(Object) | Overloaded. Asynchronously calls this function with the specified args This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | CallAsync(DynValue) | Overloaded. Asynchronously calls this function with the specified args This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


Closure Properties

Closure Properties

The Closure type exposes the following members.

Properties
 | Name | Description
Public property | EntryPointByteCodeLocation | Gets the entry point location in bytecode .
Public property | OwnerScript | Gets the script owning this function
Public property | ReferenceID | Gets the reference identifier. (Inherited from RefIdObject.)
Top
See Also

Reference

Closure Class
MoonSharp.Interpreter Namespace


Closure.EntryPointByteCodeLocation Property

ClosureEntryPointByteCodeLocation Property
Gets the entry point location in bytecode .

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int EntryPointByteCodeLocation { get; }
Public ReadOnly Property EntryPointByteCodeLocation As Integer
    Get
public:
property int EntryPointByteCodeLocation {
    int get ();
}
member EntryPointByteCodeLocation : int with get

Property Value

Type: Int32
See Also

Reference

Closure Class
MoonSharp.Interpreter Namespace


Closure.OwnerScript Property

ClosureOwnerScript Property
Gets the script owning this function

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Script OwnerScript { get; }
Public ReadOnly Property OwnerScript As Script
    Get
public:
virtual property Script^ OwnerScript {
    Script^ get () sealed;
}
abstract OwnerScript : Script with get
override OwnerScript : Script with get

Property Value

Type: Script

Implements

IScriptPrivateResourceOwnerScript
See Also

Reference

Closure Class
MoonSharp.Interpreter Namespace


Closure Methods

Closure Methods

The Closure type exposes the following members.

Methods
 | Name | Description
Public method | Call | Calls this function with the specified args
Public method | Call(Object) | Calls this function with the specified args
Public method | Call(DynValue) | Calls this function with the specified args
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormatTypeString | Formats a string with a type name and a ref-id (Inherited from RefIdObject.)
Public method | GetDelegate | Gets a delegate wrapping calls to this scripted function
Public method | GetDelegateT | Gets a delegate wrapping calls to this scripted function
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUpvalue | Gets the value of an upvalue. To set the value, use GetUpvalue(idx).Assign(...);
Public method | GetUpvalueName | Gets the name of the specified upvalue.
Public method | GetUpvaluesCount | Gets the number of upvalues in this closure
Public method | GetUpvaluesType | Gets the type of the upvalues contained in this closure
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CallAsync | Overloaded. Asynchronously calls this function with the specified args This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | CallAsync(Object) | Overloaded. Asynchronously calls this function with the specified args This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | CallAsync(DynValue) | Overloaded. Asynchronously calls this function with the specified args This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Top
See Also

Reference

Closure Class
MoonSharp.Interpreter Namespace


Closure.Call Method

ClosureCall Method
Overload List
 | Name | Description
Public method | Call | Calls this function with the specified args
Public method | Call(Object) | Calls this function with the specified args
Public method | Call(DynValue) | Calls this function with the specified args
Top
See Also

Reference

Closure Class
MoonSharp.Interpreter Namespace


Closure.Call Method

ClosureCall Method
Calls this function with the specified args

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Call()
Public Function Call As DynValue
public:
DynValue^ Call()
member Call : unit -> DynValue

Return Value

Type: DynValue
Exceptions
Exception | Condition
ArgumentException | Thrown if function is not of DataType.Function
See Also

Reference

Closure Class
Call Overload
MoonSharp.Interpreter Namespace


Closure.Call Method (Object[])

ClosureCall Method (Object)
Calls this function with the specified args

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Call(
    params Object[] args
)
Public Function Call (
    ParamArray args As Object()
) As DynValue
public:
DynValue^ Call(
    ... array<Object^>^ args
)
member Call :
        args : Object[] -> DynValue

Parameters

args
Type: SystemObject
The arguments to pass to the function.

Return Value

Type: DynValue
Exceptions
Exception | Condition
ArgumentException | Thrown if function is not of DataType.Function
See Also

Reference

Closure Class
Call Overload
MoonSharp.Interpreter Namespace


Closure.Call Method (DynValue[])

ClosureCall Method (DynValue)
Calls this function with the specified args

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Call(
    params DynValue[] args
)
Public Function Call (
    ParamArray args As DynValue()
) As DynValue
public:
DynValue^ Call(
    ... array<DynValue^>^ args
)
member Call :
        args : DynValue[] -> DynValue

Parameters

args
Type: MoonSharp.InterpreterDynValue
The arguments to pass to the function.

Return Value

Type: DynValue
Exceptions
Exception | Condition
ArgumentException | Thrown if function is not of DataType.Function
See Also

Reference

Closure Class
Call Overload
MoonSharp.Interpreter Namespace


Closure.GetDelegate Method

ClosureGetDelegate Method
Overload List
 | Name | Description
Public method | GetDelegate | Gets a delegate wrapping calls to this scripted function
Public method | GetDelegateT | Gets a delegate wrapping calls to this scripted function
Top
See Also

Reference

Closure Class
MoonSharp.Interpreter Namespace


Closure.GetDelegate Method

ClosureGetDelegate Method
Gets a delegate wrapping calls to this scripted function

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptFunctionDelegate GetDelegate()
Public Function GetDelegate As ScriptFunctionDelegate
public:
ScriptFunctionDelegate^ GetDelegate()
member GetDelegate : unit -> ScriptFunctionDelegate

Return Value

Type: ScriptFunctionDelegate
See Also

Reference

Closure Class
GetDelegate Overload
MoonSharp.Interpreter Namespace


Closure.GetDelegate(T) Method

ClosureGetDelegateT Method
Gets a delegate wrapping calls to this scripted function

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptFunctionDelegate<T> GetDelegate<T>()

Public Function GetDelegate(Of T) As ScriptFunctionDelegate(Of T)
public:
generic<typename T>
ScriptFunctionDelegate<T>^ GetDelegate()
member GetDelegate : unit -> ScriptFunctionDelegate<'T>

Type Parameters

T
The type of return value of the delegate.

Return Value

Type: ScriptFunctionDelegate T
See Also

Reference

Closure Class
GetDelegate Overload
MoonSharp.Interpreter Namespace


Closure.GetUpvalue Method

ClosureGetUpvalue Method
Gets the value of an upvalue. To set the value, use GetUpvalue(idx).Assign(...);

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue GetUpvalue(
    int idx
)
Public Function GetUpvalue (
    idx As Integer
) As DynValue
public:
DynValue^ GetUpvalue(
    int idx
)
member GetUpvalue :
        idx : int -> DynValue

Parameters

idx
Type: SystemInt32
The index of the upvalue.

Return Value

Type: DynValue
The value of an upvalue
See Also

Reference

Closure Class
MoonSharp.Interpreter Namespace


Closure.GetUpvalueName Method

ClosureGetUpvalueName Method
Gets the name of the specified upvalue.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string GetUpvalueName(
    int idx
)
Public Function GetUpvalueName (
    idx As Integer
) As String
public:
String^ GetUpvalueName(
    int idx
)
member GetUpvalueName :
        idx : int -> string

Parameters

idx
Type: SystemInt32
The index of the upvalue.

Return Value

Type: String
The upvalue name
See Also

Reference

Closure Class
MoonSharp.Interpreter Namespace


Closure.GetUpvaluesCount Method

ClosureGetUpvaluesCount Method
Gets the number of upvalues in this closure

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int GetUpvaluesCount()
Public Function GetUpvaluesCount As Integer
public:
int GetUpvaluesCount()
member GetUpvaluesCount : unit -> int

Return Value

Type: Int32
The number of upvalues in this closure
See Also

Reference

Closure Class
MoonSharp.Interpreter Namespace


Closure.GetUpvaluesType Method

ClosureGetUpvaluesType Method
Gets the type of the upvalues contained in this closure

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ClosureUpvaluesType GetUpvaluesType()
Public Function GetUpvaluesType As ClosureUpvaluesType
public:
ClosureUpvaluesType GetUpvaluesType()
member GetUpvaluesType : unit -> ClosureUpvaluesType

Return Value

Type: ClosureUpvaluesType
See Also

Reference

Closure Class
MoonSharp.Interpreter Namespace


Closure.UpvaluesType Enumeration

ClosureUpvaluesType Enumeration
Type of closure based on upvalues

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public enum UpvaluesType
Public Enumeration UpvaluesType
public enum class UpvaluesType
type UpvaluesType
Members
Member name | Value | Description
None | 0 | The closure has no upvalues (thus, technically, it's a function and not a closure!)
Environment | 1 | The closure has _ENV as its only upvalue
Closure | 2 | The closure is a "real" closure, with multiple upvalues
See Also

Reference

MoonSharp.Interpreter Namespace


ColonOperatorBehaviour Enumeration

ColonOperatorBehaviour Enumeration
Defines behaviour of the colon ':' operator in CLR callbacks. Default behaviour is for ':' being treated the same as a '.' if the functions is implemented on the CLR side (e.g. in C#).

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public enum ColonOperatorBehaviour
Public Enumeration ColonOperatorBehaviour
public enum class ColonOperatorBehaviour
type ColonOperatorBehaviour
Members
Member name | Value | Description
TreatAsDot | 0 | The colon is treated the same as the dot ('.') operator.
TreatAsDotOnUserData | 1 | The colon is treated the same as the dot ('.') operator if the first argument is userdata, as a Lua colon operator otherwise.
TreatAsColon | 2 | The colon is treated in the same as the Lua colon operator works.
See Also

Reference

MoonSharp.Interpreter Namespace


CoreModules Enumeration

CoreModules Enumeration
Enumeration (combinable as flags) of all the standard library modules

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum CoreModules
<FlagsAttribute>
Public Enumeration CoreModules
[FlagsAttribute]
public enum class CoreModules
[<FlagsAttribute>]
type CoreModules
Members
Member name | Value | Description
None | 0 | Value used to specify no modules to be loaded (equals 0).
Basic | 64 | The basic methods. Includes "assert", "collectgarbage", "error", "print", "select", "type", "tonumber" and "tostring".
GlobalConsts | 1 | The global constants: "_G", "_VERSION" and "_MOONSHARP".
TableIterators | 2 | The table iterators: "next", "ipairs" and "pairs".
Metatables | 4 | The metatable methods : "setmetatable", "getmetatable", "rawset", "rawget", "rawequal" and "rawlen".
String | 8 | The string package
LoadMethods | 16 | The load methods: "load", "loadsafe", "loadfile", "loadfilesafe", "dofile" and "require"
Table | 32 | The table package
ErrorHandling | 128 | The error handling methods: "pcall" and "xpcall"
Math | 256 | The math package
Coroutine | 512 | The coroutine package
Bit32 | 1024 | The bit32 package
OS_Time | 2048 | The time methods of the "os" package: "clock", "difftime", "date" and "time"
OS_System | 4096 | The methods of "os" package excluding those listed for OS_Time. These are not supported under Unity.
IO | 8192 | The methods of "io" and "file" packages. These are not supported under Unity.
Debug | 16384 | The "debug" package (it has limited support)
Dynamic | 32768 | The "dynamic" package (introduced by MoonSharp).
Json | 65536 | The "json" package (introduced by MoonSharp).
Preset_HardSandbox | 1387 | A sort of "hard" sandbox preset, including string, math, table, bit32 packages, constants and table iterators.
Preset_SoftSandbox | 102383 | A softer sandbox preset, adding metatables support, error handling, coroutine, time functions, json parsing and dynamic evaluations.
Preset_Default | 114687 | The default preset. Includes everything except "debug" as now. Beware that using this preset allows scripts unlimited access to the system.
Preset_Complete | 131071 | The complete package. Beware that using this preset allows scripts unlimited access to the system.
See Also

Reference

MoonSharp.Interpreter Namespace


Coroutine Class

Coroutine Class
A class representing a script coroutine
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterRefIdObject
MoonSharp.InterpreterCoroutine

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class Coroutine : RefIdObject, IScriptPrivateResource
Public Class Coroutine
    Inherits RefIdObject
    Implements IScriptPrivateResource
public ref class Coroutine : public RefIdObject,
    IScriptPrivateResource
type Coroutine =
    class
        inherit RefIdObject
        interface IScriptPrivateResource
    end

The Coroutine type exposes the following members.

Properties
 | Name | Description
Public property | AutoYieldCounter | Gets or sets the automatic yield counter.
Public property | OwnerScript | Gets the script owning this resource.
Public property | ReferenceID | Gets the reference identifier. (Inherited from RefIdObject.)
Public property | State | Gets the coroutine state.
Public property | Type | Gets the type of coroutine
Top
Methods
 | Name | Description
Public method | AsEnumerable | Gets this coroutine as a typed enumerable which can be looped over for resuming. Returns its result as System.Object. Only the first element of tuples is returned. Only non-CLR coroutines can be resumed with this method. Use an overload of the Resume method accepting a ScriptExecutionContext instead.
Public method | AsEnumerableT | Gets this coroutine as a typed enumerable which can be looped over for resuming. Returns its result as the specified type. Only the first element of tuples is returned. Only non-CLR coroutines can be resumed with this method. Use an overload of the Resume method accepting a ScriptExecutionContext instead.
Public method | AsTypedEnumerable | Gets this coroutine as a typed enumerable which can be looped over for resuming. Returns its result as DynValue(s)
Public method | AsUnityCoroutine | The purpose of this method is to convert a MoonSharp/Lua coroutine to a Unity3D coroutine. This loops over the coroutine, discarding returned values, and returning null for each invocation. This means however that the coroutine will be invoked each frame. Only non-CLR coroutines can be resumed with this method. Use an overload of the Resume method accepting a ScriptExecutionContext instead.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormatTypeString | Formats a string with a type name and a ref-id (Inherited from RefIdObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetStackTrace | Gets the coroutine stack trace for debug purposes
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Resume | Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead.
Public method | Resume(Object) | Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead.
Public method | Resume(DynValue) | Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead.
Public method | Resume(ScriptExecutionContext) | Resumes the coroutine.
Public method | Resume(ScriptExecutionContext, DynValue) | Resumes the coroutine.
Public method | Resume(ScriptExecutionContext, Object) | Resumes the coroutine
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ResumeAsync | Overloaded. Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | ResumeAsync(Object) | Overloaded. Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | ResumeAsync(DynValue) | Overloaded. Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | ResumeAsync(ScriptExecutionContext) | Overloaded. Resumes the coroutine. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | ResumeAsync(ScriptExecutionContext, DynValue) | Overloaded. Resumes the coroutine. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | ResumeAsync(ScriptExecutionContext, Object) | Overloaded. Resumes the coroutine This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


Coroutine Properties

Coroutine Properties

The Coroutine type exposes the following members.

Properties
 | Name | Description
Public property | AutoYieldCounter | Gets or sets the automatic yield counter.
Public property | OwnerScript | Gets the script owning this resource.
Public property | ReferenceID | Gets the reference identifier. (Inherited from RefIdObject.)
Public property | State | Gets the coroutine state.
Public property | Type | Gets the type of coroutine
Top
See Also

Reference

Coroutine Class
MoonSharp.Interpreter Namespace


Coroutine.AutoYieldCounter Property

CoroutineAutoYieldCounter Property
Gets or sets the automatic yield counter.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public long AutoYieldCounter { get; set; }
Public Property AutoYieldCounter As Long
    Get
    Set
public:
property long long AutoYieldCounter {
    long long get ();
    void set (long long value);
}
member AutoYieldCounter : int64 with get, set

Property Value

Type: Int64
The automatic yield counter.
See Also

Reference

Coroutine Class
MoonSharp.Interpreter Namespace


Coroutine.OwnerScript Property

CoroutineOwnerScript Property
Gets the script owning this resource.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Script OwnerScript { get; }
Public ReadOnly Property OwnerScript As Script
    Get
public:
virtual property Script^ OwnerScript {
    Script^ get () sealed;
}
abstract OwnerScript : Script with get
override OwnerScript : Script with get

Property Value

Type: Script
The script owning this resource.

Implements

IScriptPrivateResourceOwnerScript
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

Coroutine Class
MoonSharp.Interpreter Namespace


Coroutine.State Property

CoroutineState Property
Gets the coroutine state.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CoroutineState State { get; }
Public ReadOnly Property State As CoroutineState
    Get
public:
property CoroutineState State {
    CoroutineState get ();
}
member State : CoroutineState with get

Property Value

Type: CoroutineState
See Also

Reference

Coroutine Class
MoonSharp.Interpreter Namespace


Coroutine.Type Property

CoroutineType Property
Gets the type of coroutine

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CoroutineCoroutineType Type { get; }
Public ReadOnly Property Type As CoroutineCoroutineType
    Get
public:
property CoroutineCoroutineType Type {
    CoroutineCoroutineType get ();
}
member Type : CoroutineCoroutineType with get

Property Value

Type: CoroutineCoroutineType
See Also

Reference

Coroutine Class
MoonSharp.Interpreter Namespace


Coroutine Methods

Coroutine Methods

The Coroutine type exposes the following members.

Methods
 | Name | Description
Public method | AsEnumerable | Gets this coroutine as a typed enumerable which can be looped over for resuming. Returns its result as System.Object. Only the first element of tuples is returned. Only non-CLR coroutines can be resumed with this method. Use an overload of the Resume method accepting a ScriptExecutionContext instead.
Public method | AsEnumerableT | Gets this coroutine as a typed enumerable which can be looped over for resuming. Returns its result as the specified type. Only the first element of tuples is returned. Only non-CLR coroutines can be resumed with this method. Use an overload of the Resume method accepting a ScriptExecutionContext instead.
Public method | AsTypedEnumerable | Gets this coroutine as a typed enumerable which can be looped over for resuming. Returns its result as DynValue(s)
Public method | AsUnityCoroutine | The purpose of this method is to convert a MoonSharp/Lua coroutine to a Unity3D coroutine. This loops over the coroutine, discarding returned values, and returning null for each invocation. This means however that the coroutine will be invoked each frame. Only non-CLR coroutines can be resumed with this method. Use an overload of the Resume method accepting a ScriptExecutionContext instead.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormatTypeString | Formats a string with a type name and a ref-id (Inherited from RefIdObject.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetStackTrace | Gets the coroutine stack trace for debug purposes
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Resume | Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead.
Public method | Resume(Object) | Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead.
Public method | Resume(DynValue) | Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead.
Public method | Resume(ScriptExecutionContext) | Resumes the coroutine.
Public method | Resume(ScriptExecutionContext, DynValue) | Resumes the coroutine.
Public method | Resume(ScriptExecutionContext, Object) | Resumes the coroutine
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | ResumeAsync | Overloaded. Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | ResumeAsync(Object) | Overloaded. Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | ResumeAsync(DynValue) | Overloaded. Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | ResumeAsync(ScriptExecutionContext) | Overloaded. Resumes the coroutine. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | ResumeAsync(ScriptExecutionContext, DynValue) | Overloaded. Resumes the coroutine. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | ResumeAsync(ScriptExecutionContext, Object) | Overloaded. Resumes the coroutine This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Top
See Also

Reference

Coroutine Class
MoonSharp.Interpreter Namespace


Coroutine.AsEnumerable Method

CoroutineAsEnumerable Method
Overload List
 | Name | Description
Public method | AsEnumerable | Gets this coroutine as a typed enumerable which can be looped over for resuming. Returns its result as System.Object. Only the first element of tuples is returned. Only non-CLR coroutines can be resumed with this method. Use an overload of the Resume method accepting a ScriptExecutionContext instead.
Public method | AsEnumerableT | Gets this coroutine as a typed enumerable which can be looped over for resuming. Returns its result as the specified type. Only the first element of tuples is returned. Only non-CLR coroutines can be resumed with this method. Use an overload of the Resume method accepting a ScriptExecutionContext instead.
Top
See Also

Reference

Coroutine Class
MoonSharp.Interpreter Namespace


Coroutine.AsEnumerable Method

CoroutineAsEnumerable Method
Gets this coroutine as a typed enumerable which can be looped over for resuming. Returns its result as System.Object. Only the first element of tuples is returned. Only non-CLR coroutines can be resumed with this method. Use an overload of the Resume method accepting a ScriptExecutionContext instead.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<Object> AsEnumerable()
Public Function AsEnumerable As IEnumerable(Of Object)
public:
IEnumerable<Object^>^ AsEnumerable()
member AsEnumerable : unit -> IEnumerable<Object>

Return Value

Type: IEnumerable Object
Exceptions
Exception | Condition
InvalidOperationException | Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead
See Also

Reference

Coroutine Class
AsEnumerable Overload
MoonSharp.Interpreter Namespace


Coroutine.AsEnumerable(T) Method

CoroutineAsEnumerableT Method
Gets this coroutine as a typed enumerable which can be looped over for resuming. Returns its result as the specified type. Only the first element of tuples is returned. Only non-CLR coroutines can be resumed with this method. Use an overload of the Resume method accepting a ScriptExecutionContext instead.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<T> AsEnumerable<T>()

Public Function AsEnumerable(Of T) As IEnumerable(Of T)
public:
generic<typename T>
IEnumerable<T>^ AsEnumerable()
member AsEnumerable : unit -> IEnumerable<'T>

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:MoonSharp.Interpreter.Coroutine.AsEnumerable``1"]

Return Value

Type: IEnumerable T
Exceptions
Exception | Condition
InvalidOperationException | Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead
See Also

Reference

Coroutine Class
AsEnumerable Overload
MoonSharp.Interpreter Namespace


Coroutine.AsTypedEnumerable Method

CoroutineAsTypedEnumerable Method
Gets this coroutine as a typed enumerable which can be looped over for resuming. Returns its result as DynValue(s)

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<DynValue> AsTypedEnumerable()
Public Function AsTypedEnumerable As IEnumerable(Of DynValue)
public:
IEnumerable<DynValue^>^ AsTypedEnumerable()
member AsTypedEnumerable : unit -> IEnumerable<DynValue>

Return Value

Type: IEnumerable DynValue
Exceptions
Exception | Condition
InvalidOperationException | Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead
See Also

Reference

Coroutine Class
MoonSharp.Interpreter Namespace


Coroutine.AsUnityCoroutine Method

CoroutineAsUnityCoroutine Method
The purpose of this method is to convert a MoonSharp/Lua coroutine to a Unity3D coroutine. This loops over the coroutine, discarding returned values, and returning null for each invocation. This means however that the coroutine will be invoked each frame. Only non-CLR coroutines can be resumed with this method. Use an overload of the Resume method accepting a ScriptExecutionContext instead.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerator AsUnityCoroutine()
Public Function AsUnityCoroutine As IEnumerator
public:
IEnumerator^ AsUnityCoroutine()
member AsUnityCoroutine : unit -> IEnumerator

Return Value

Type: IEnumerator
Exceptions
Exception | Condition
InvalidOperationException | Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead
See Also

Reference

Coroutine Class
MoonSharp.Interpreter Namespace


Coroutine.GetStackTrace Method

CoroutineGetStackTrace Method
Gets the coroutine stack trace for debug purposes

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public WatchItem[] GetStackTrace(
    int skip,
    SourceRef entrySourceRef = null
)
Public Function GetStackTrace (
    skip As Integer,
    Optional entrySourceRef As SourceRef = Nothing
) As WatchItem()
public:
array<WatchItem^>^ GetStackTrace(
    int skip,
    SourceRef^ entrySourceRef = nullptr
)
member GetStackTrace :
        skip : int *
        ?entrySourceRef : SourceRef
(* Defaults:
        let _entrySourceRef = defaultArg entrySourceRef null
*)
-> WatchItem[]

Parameters

skip
Type: SystemInt32
The skip.
entrySourceRef (Optional)
Type: MoonSharp.Interpreter.DebuggingSourceRef
The entry source reference.

Return Value

Type: WatchItem
See Also

Reference

Coroutine Class
MoonSharp.Interpreter Namespace


Coroutine.Resume Method

CoroutineResume Method
Overload List
 | Name | Description
Public method | Resume | Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead.
Public method | Resume(Object) | Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead.
Public method | Resume(DynValue) | Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead.
Public method | Resume(ScriptExecutionContext) | Resumes the coroutine.
Public method | Resume(ScriptExecutionContext, DynValue) | Resumes the coroutine.
Public method | Resume(ScriptExecutionContext, Object) | Resumes the coroutine
Top
See Also

Reference

Coroutine Class
MoonSharp.Interpreter Namespace


Coroutine.Resume Method

CoroutineResume Method
Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Resume()
Public Function Resume As DynValue
public:
DynValue^ Resume()
member Resume : unit -> DynValue

Return Value

Type: DynValue
Exceptions
Exception | Condition
InvalidOperationException | Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead
See Also

Reference

Coroutine Class
Resume Overload
MoonSharp.Interpreter Namespace


Coroutine.Resume Method (Object[])

CoroutineResume Method (Object)
Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Resume(
    params Object[] args
)
Public Function Resume (
    ParamArray args As Object()
) As DynValue
public:
DynValue^ Resume(
    ... array<Object^>^ args
)
member Resume :
        args : Object[] -> DynValue

Parameters

args
Type: SystemObject
The arguments.

Return Value

Type: DynValue
Exceptions
Exception | Condition
InvalidOperationException | Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead.
See Also

Reference

Coroutine Class
Resume Overload
MoonSharp.Interpreter Namespace


Coroutine.Resume Method (DynValue[])

CoroutineResume Method (DynValue)
Resumes the coroutine. Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Resume(
    params DynValue[] args
)
Public Function Resume (
    ParamArray args As DynValue()
) As DynValue
public:
DynValue^ Resume(
    ... array<DynValue^>^ args
)
member Resume :
        args : DynValue[] -> DynValue

Parameters

args
Type: MoonSharp.InterpreterDynValue
The arguments.

Return Value

Type: DynValue
Exceptions
Exception | Condition
InvalidOperationException | Only non-CLR coroutines can be resumed with this overload of the Resume method. Use the overload accepting a ScriptExecutionContext instead
See Also

Reference

Coroutine Class
Resume Overload
MoonSharp.Interpreter Namespace


Coroutine.Resume Method (ScriptExecutionContext)

CoroutineResume Method (ScriptExecutionContext)
Resumes the coroutine.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Resume(
    ScriptExecutionContext context
)
Public Function Resume (
    context As ScriptExecutionContext
) As DynValue
public:
DynValue^ Resume(
    ScriptExecutionContext^ context
)
member Resume :
        context : ScriptExecutionContext -> DynValue

Parameters

context
Type: MoonSharp.InterpreterScriptExecutionContext
The ScriptExecutionContext.

Return Value

Type: DynValue
See Also

Reference

Coroutine Class
Resume Overload
MoonSharp.Interpreter Namespace


Coroutine.Resume Method (ScriptExecutionContext, DynValue[])

CoroutineResume Method (ScriptExecutionContext, DynValue)
Resumes the coroutine.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Resume(
    ScriptExecutionContext context,
    params DynValue[] args
)
Public Function Resume (
    context As ScriptExecutionContext,
    ParamArray args As DynValue()
) As DynValue
public:
DynValue^ Resume(
    ScriptExecutionContext^ context,
    ... array<DynValue^>^ args
)
member Resume :
        context : ScriptExecutionContext *
        args : DynValue[] -> DynValue

Parameters

context
Type: MoonSharp.InterpreterScriptExecutionContext
The ScriptExecutionContext.
args
Type: MoonSharp.InterpreterDynValue
The arguments.

Return Value

Type: DynValue
See Also

Reference

Coroutine Class
Resume Overload
MoonSharp.Interpreter Namespace


Coroutine.Resume Method (ScriptExecutionContext, Object[])

CoroutineResume Method (ScriptExecutionContext, Object)
Resumes the coroutine

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Resume(
    ScriptExecutionContext context,
    params Object[] args
)
Public Function Resume (
    context As ScriptExecutionContext,
    ParamArray args As Object()
) As DynValue
public:
DynValue^ Resume(
    ScriptExecutionContext^ context,
    ... array<Object^>^ args
)
member Resume :
        context : ScriptExecutionContext *
        args : Object[] -> DynValue

Parameters

context
Type: MoonSharp.InterpreterScriptExecutionContext
The ScriptExecutionContext.
args
Type: SystemObject
The arguments.

Return Value

Type: DynValue
See Also

Reference

Coroutine Class
Resume Overload
MoonSharp.Interpreter Namespace


Coroutine.CoroutineType Enumeration

CoroutineCoroutineType Enumeration
Possible types of coroutine

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public enum CoroutineType
Public Enumeration CoroutineType
public enum class CoroutineType
type CoroutineType
Members
Member name | Value | Description
Coroutine | 0 | A valid coroutine
ClrCallback | 1 | A CLR callback assigned to a coroutine.
ClrCallbackDead | 2 | A CLR callback assigned to a coroutine and already executed.
See Also

Reference

MoonSharp.Interpreter Namespace


CoroutineState Enumeration

CoroutineState Enumeration
State of coroutines

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public enum CoroutineState
Public Enumeration CoroutineState
public enum class CoroutineState
type CoroutineState
Members
Member name | Value | Description
Main | 0 | This is the main coroutine
NotStarted | 1 | Coroutine has not started yet
Suspended | 2 | Coroutine is suspended
ForceSuspended | 3 | Coroutine has been forcefully suspended (i.e. auto-yielded)
Running | 4 | Coroutine is running
Dead | 5 | Coroutine has terminated
See Also

Reference

MoonSharp.Interpreter Namespace


DataType Enumeration

DataType Enumeration
Enumeration of possible data types in MoonSharp

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public enum DataType
Public Enumeration DataType
public enum class DataType
type DataType
Members
Member name | Value | Description
Nil | 0 | A nil value, as in Lua
Void | 1 | A place holder for no value
Boolean | 2 | A Lua boolean
Number | 3 | A Lua number
String | 4 | A Lua string
Function | 5 | A Lua function
Table | 6 | A Lua table
Tuple | 7 | A set of multiple values
UserData | 8 | A userdata reference - that is a wrapped CLR object
Thread | 9 | A coroutine handle
ClrFunction | 10 | A callback function
TailCallRequest | 11 | A request to execute a tail call
YieldRequest | 12 | A request to coroutine.yield
See Also

Reference

MoonSharp.Interpreter Namespace


DynamicExpression Class

DynamicExpression Class
Represents a dynamic expression in the script
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterDynamicExpression

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class DynamicExpression : IScriptPrivateResource
Public Class DynamicExpression
    Implements IScriptPrivateResource
public ref class DynamicExpression : IScriptPrivateResource
type DynamicExpression =
    class
        interface IScriptPrivateResource
    end

The DynamicExpression type exposes the following members.

Properties
 | Name | Description
Public property | OwnerScript | Gets the script owning this resource.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object, is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | Evaluate | Evaluates the expression
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindSymbol | Finds a symbol in the expression
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsConstant | Determines whether this instance is a constant expression
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | ExpressionCode | The code which generated this expression
Top
See Also

Reference

MoonSharp.Interpreter Namespace


DynamicExpression Properties

DynamicExpression Properties

The DynamicExpression type exposes the following members.

Properties
 | Name | Description
Public property | OwnerScript | Gets the script owning this resource.
Top
See Also

Reference

DynamicExpression Class
MoonSharp.Interpreter Namespace


DynamicExpression.OwnerScript Property

DynamicExpressionOwnerScript Property
Gets the script owning this resource.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Script OwnerScript { get; }
Public ReadOnly Property OwnerScript As Script
    Get
public:
virtual property Script^ OwnerScript {
    Script^ get () sealed;
}
abstract OwnerScript : Script with get
override OwnerScript : Script with get

Property Value

Type: Script
The script owning this resource.

Implements

IScriptPrivateResourceOwnerScript
See Also

Reference

DynamicExpression Class
MoonSharp.Interpreter Namespace


DynamicExpression Methods

DynamicExpression Methods

The DynamicExpression type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object, is equal to this instance. (Overrides ObjectEquals(Object).)
Public method | Evaluate | Evaluates the expression
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindSymbol | Finds a symbol in the expression
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsConstant | Determines whether this instance is a constant expression
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DynamicExpression Class
MoonSharp.Interpreter Namespace


DynamicExpression.Equals Method

DynamicExpressionEquals Method
Determines whether the specified Object, is equal to this instance.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

DynamicExpression Class
MoonSharp.Interpreter Namespace


DynamicExpression.Evaluate Method

DynamicExpressionEvaluate Method
Evaluates the expression

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Evaluate(
    ScriptExecutionContext context = null
)
Public Function Evaluate (
    Optional context As ScriptExecutionContext = Nothing
) As DynValue
public:
DynValue^ Evaluate(
    ScriptExecutionContext^ context = nullptr
)
member Evaluate :
        ?context : ScriptExecutionContext
(* Defaults:
        let _context = defaultArg context null
*)
-> DynValue

Parameters

context (Optional)
Type: MoonSharp.InterpreterScriptExecutionContext
The context.

Return Value

Type: DynValue
See Also

Reference

DynamicExpression Class
MoonSharp.Interpreter Namespace


DynamicExpression.FindSymbol Method

DynamicExpressionFindSymbol Method
Finds a symbol in the expression

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public SymbolRef FindSymbol(
    ScriptExecutionContext context
)
Public Function FindSymbol (
    context As ScriptExecutionContext
) As SymbolRef
public:
SymbolRef^ FindSymbol(
    ScriptExecutionContext^ context
)
member FindSymbol :
        context : ScriptExecutionContext -> SymbolRef

Parameters

context
Type: MoonSharp.InterpreterScriptExecutionContext
The context.

Return Value

Type: SymbolRef
See Also

Reference

DynamicExpression Class
MoonSharp.Interpreter Namespace


DynamicExpression.GetHashCode Method

DynamicExpressionGetHashCode Method
Returns a hash code for this instance.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

DynamicExpression Class
MoonSharp.Interpreter Namespace


DynamicExpression.IsConstant Method

DynamicExpressionIsConstant Method
Determines whether this instance is a constant expression

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsConstant()
Public Function IsConstant As Boolean
public:
bool IsConstant()
member IsConstant : unit -> bool

Return Value

Type: Boolean
See Also

Reference

DynamicExpression Class
MoonSharp.Interpreter Namespace


DynamicExpression Fields

DynamicExpression Fields

The DynamicExpression type exposes the following members.

Fields
 | Name | Description
Public field | ExpressionCode | The code which generated this expression
Top
See Also

Reference

DynamicExpression Class
MoonSharp.Interpreter Namespace


DynamicExpression.ExpressionCode Field

DynamicExpressionExpressionCode Field
The code which generated this expression

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public readonly string ExpressionCode
Public ReadOnly ExpressionCode As String
public:
initonly String^ ExpressionCode
val ExpressionCode: string

Field Value

Type: String
See Also

Reference

DynamicExpression Class
MoonSharp.Interpreter Namespace


DynamicExpressionException Class

DynamicExpressionException Class
Exception thrown when a dynamic expression is invalid
Inheritance Hierarchy
SystemObject
SystemException
MoonSharp.InterpreterInterpreterException
MoonSharp.InterpreterScriptRuntimeException
MoonSharp.InterpreterDynamicExpressionException

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class DynamicExpressionException : ScriptRuntimeException
Public Class DynamicExpressionException
    Inherits ScriptRuntimeException
public ref class DynamicExpressionException : public ScriptRuntimeException
type DynamicExpressionException =
    class
        inherit ScriptRuntimeException
    end

The DynamicExpressionException type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicExpressionException(String) | Initializes a new instance of the DynamicExpressionException class.
Public method | DynamicExpressionException(String, Object) | Initializes a new instance of the DynamicExpressionException class.
Top
Properties
 | Name | Description
Public property | CallStack | Gets the interpreter call stack. (Inherited from InterpreterException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | DecoratedMessage | Gets the decorated message (error message plus error location in script) if possible. (Inherited from InterpreterException.)
Public property | DoNotDecorateMessage | Gets or sets a value indicating whether the message should not be decorated (Inherited from InterpreterException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | InstructionPtr | Gets the instruction pointer of the execution (if it makes sense) (Inherited from InterpreterException.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rethrow | Rethrows this instance if (Inherited from ScriptRuntimeException.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


DynamicExpressionException Constructor

DynamicExpressionException Constructor
Overload List
 | Name | Description
Public method | DynamicExpressionException(String) | Initializes a new instance of the DynamicExpressionException class.
Public method | DynamicExpressionException(String, Object) | Initializes a new instance of the DynamicExpressionException class.
Top
See Also

Reference

DynamicExpressionException Class
MoonSharp.Interpreter Namespace


DynamicExpressionException Constructor (String)

DynamicExpressionException Constructor (String)
Initializes a new instance of the DynamicExpressionException class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynamicExpressionException(
    string message
)
Public Sub New (
    message As String
)
public:
DynamicExpressionException(
    String^ message
)
new :
        message : string -> DynamicExpressionException

Parameters

message
Type: SystemString
The message.
See Also

Reference

DynamicExpressionException Class
DynamicExpressionException Overload
MoonSharp.Interpreter Namespace


DynamicExpressionException Constructor (String, Object[])

DynamicExpressionException Constructor (String, Object)
Initializes a new instance of the DynamicExpressionException class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynamicExpressionException(
    string format,
    params Object[] args
)
Public Sub New (
    format As String,
    ParamArray args As Object()
)
public:
DynamicExpressionException(
    String^ format,
    ... array<Object^>^ args
)
new :
        format : string *
        args : Object[] -> DynamicExpressionException

Parameters

format
Type: SystemString
The format.
args
Type: SystemObject
The arguments.
See Also

Reference

DynamicExpressionException Class
DynamicExpressionException Overload
MoonSharp.Interpreter Namespace


DynamicExpressionException Properties

DynamicExpressionException Properties

The DynamicExpressionException type exposes the following members.

Properties
 | Name | Description
Public property | CallStack | Gets the interpreter call stack. (Inherited from InterpreterException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | DecoratedMessage | Gets the decorated message (error message plus error location in script) if possible. (Inherited from InterpreterException.)
Public property | DoNotDecorateMessage | Gets or sets a value indicating whether the message should not be decorated (Inherited from InterpreterException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | InstructionPtr | Gets the instruction pointer of the execution (if it makes sense) (Inherited from InterpreterException.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

DynamicExpressionException Class
MoonSharp.Interpreter Namespace


DynamicExpressionException Methods

DynamicExpressionException Methods

The DynamicExpressionException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rethrow | Rethrows this instance if (Inherited from ScriptRuntimeException.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

DynamicExpressionException Class
MoonSharp.Interpreter Namespace


DynamicExpressionException Events

DynamicExpressionException Events

The DynamicExpressionException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

DynamicExpressionException Class
MoonSharp.Interpreter Namespace


DynValue Class

DynValue Class
A class representing a value in a Lua/MoonSharp script.
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterDynValue

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DynValue
Public NotInheritable Class DynValue
public ref class DynValue sealed
[<SealedAttribute>]
type DynValue =  class end

The DynValue type exposes the following members.

Constructors
 | Name | Description
Public method | DynValue | Initializes a new instance of the DynValue class
Top
Properties
 | Name | Description
Public property | Boolean | Gets the boolean value (valid only if the Type is Boolean)
Public property | Callback | Gets the CLR callback (valid only if the Type is ClrFunction)
Public property | Coroutine | Gets the coroutine handle. (valid only if the Type is Thread).
 | False | A preinitialized, readonly instance, equaling False
Public property | Function | Gets the function (valid only if the Type is Function)
 | Nil | A preinitialized, readonly instance, equaling Nil
Public property | Number | Gets the numeric value (valid only if the Type is Number)
Public property | ReadOnly | Returns true if this instance is write protected.
Public property | ReferenceID | Gets a unique reference identifier. This is guaranteed to be unique only for dynvalues created in a single thread as it's not thread-safe.
Public property | String | Gets the string value (valid only if the Type is String)
Public property | Table | Gets the table (valid only if the Type is Table)
Public property | TailCallData | Gets the tail call data.
 | True | A preinitialized, readonly instance, equaling True
Public property | Tuple | Gets the values in the tuple (valid only if the Type is Tuple). This field is currently also used to hold arguments in values whose Type is TailCallRequest.
Public property | Type | Gets the type of the value.
Public property | UserData | Gets the tail call data.
 | Void | A preinitialized, readonly instance, equaling Void
Public property | YieldRequest | Gets the yield request data.
Top
Methods
 | Name | Description
Public method | AsReadOnly | Returns this value as readonly - eventually cloning it in the process if it isn't readonly to start with.
Public method | Assign | Performs an assignment, overwriting the value with the specified one.
Public method | CastToBool | Casts this DynValue to a bool
Public method | CastToNumber | Casts this DynValue to a double, using coercion if the type is string.
Public method | CastToString | Casts this DynValue to string, using coercion if the type is number.
Public method | CheckType | Checks the type of this value corresponds to the desired type. A propert ScriptRuntimeException is thrown if the value is not of the specified type or - considering the TypeValidationFlags - is not convertible to the specified type.
Public method | CheckUserDataTypeT | Checks if the type is a specific userdata type, and returns it or throws.
Public method | Clone | Clones this instance.
Public method | Clone(Boolean) | Clones this instance, overriding the "readonly" status.
Public method | CloneAsWritable | Clones this instance, returning a writable copy.
Public method | Equals | Determines whether the specified Object, is equal to this instance. (Overrides ObjectEquals(Object).)
 | FromObject | Creates a new DynValue from a CLR object
Public method | GetAsPrivateResource | Returns this DynValue as an instance of IScriptPrivateResource, if possible, null otherwise
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetLength | Gets the length of a string or table value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsNil | Determines whether this instance is nil or void
Public method | IsNilOrNan | Determines whether is nil, void or NaN (and thus unsuitable for using as a table key).
Public method | IsNotNil | Determines whether this instance is not nil or void
Public method | IsNotVoid | Determines whether this instance is not void
Public method | IsVoid | Determines whether this instance is void
 | NewBoolean | Creates a new writable value initialized to the specified boolean.
 | NewCallback(CallbackFunction) | Creates a new writable value initialized to the specified CLR callback. See also CallbackFunction.FromDelegate and CallbackFunction.FromMethodInfo factory methods.
 | NewCallback(FuncScriptExecutionContext, CallbackArguments, DynValue, String) | Creates a new writable value initialized to the specified CLR callback.
 | NewClosure | Creates a new writable value initialized to the specified closure (function).
 | NewCoroutine | Creates a new writable value initialized to the specified coroutine. Internal use only, for external use, see Script.CoroutineCreate
 | NewNil | Creates a new writable value initialized to Nil.
 | NewNumber | Creates a new writable value initialized to the specified number.
 | NewPrimeTable | Creates a new writable value initialized to an empty prime table (a prime table is a table made only of numbers, strings, booleans and other prime tables).
 | NewString(String) | Creates a new writable value initialized to the specified string.
 | NewString(StringBuilder) | Creates a new writable value initialized to the specified StringBuilder.
 | NewString(String, Object) | Creates a new writable value initialized to the specified string using String.Format like syntax
 | NewTable(Script) | Creates a new writable value initialized to an empty table.
 | NewTable(Table) | Creates a new writable value initialized to the specified table.
 | NewTable(Script, DynValue) | Creates a new writable value initialized to with array contents.
 | NewTailCallReq(TailCallData) | Creates a new request for a tail call. This is the preferred way to execute Lua/MoonSharp code from a callback, although it's not always possible to use it. When a function (callback or script closure) returns a TailCallRequest, the bytecode processor immediately executes the function contained in the request. By executing script in this way, a callback function ensures it's not on the stack anymore and thus a number of functionality (state savings, coroutines, etc) keeps working at full power.
 | NewTailCallReq(DynValue, DynValue) | Creates a new request for a tail call. This is the preferred way to execute Lua/MoonSharp code from a callback, although it's not always possible to use it. When a function (callback or script closure) returns a TailCallRequest, the bytecode processor immediately executes the function contained in the request. By executing script in this way, a callback function ensures it's not on the stack anymore and thus a number of functionality (state savings, coroutines, etc) keeps working at full power.
 | NewTuple | Creates a new tuple initialized to the specified values.
 | NewTupleNested | Creates a new tuple initialized to the specified values - which can be potentially other tuples
 | NewUserData | Creates a new userdata value
 | NewYieldReq | Creates a new request for a yield of the current coroutine.
Public method | ToDebugPrintString | Returns a string which is what it's expected to be output by debuggers.
Public method | ToDynamic | Converts this MoonSharp DynValue to a CLR object, marked as dynamic
Public method | ToObject | Converts this MoonSharp DynValue to a CLR object.
Public method | ToObject(Type) | Converts this MoonSharp DynValue to a CLR object of the specified type.
Public method | ToObjectT | Converts this MoonSharp DynValue to a CLR object of the specified type.
Public method | ToPrintString | Returns a string which is what it's expected to be output by the print function applied to this value.
Public method | ToScalar | Converts a tuple to a scalar value. If it's already a scalar value, this function returns "this".
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | SerializeValue | (Defined by SerializationExtensions.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


DynValue Constructor

DynValue Constructor
Initializes a new instance of the DynValue class

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue()
Public Sub New
public:
DynValue()
new : unit -> DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue Properties

DynValue Properties

The DynValue type exposes the following members.

Properties
 | Name | Description
Public property | Boolean | Gets the boolean value (valid only if the Type is Boolean)
Public property | Callback | Gets the CLR callback (valid only if the Type is ClrFunction)
Public property | Coroutine | Gets the coroutine handle. (valid only if the Type is Thread).
 | False | A preinitialized, readonly instance, equaling False
Public property | Function | Gets the function (valid only if the Type is Function)
 | Nil | A preinitialized, readonly instance, equaling Nil
Public property | Number | Gets the numeric value (valid only if the Type is Number)
Public property | ReadOnly | Returns true if this instance is write protected.
Public property | ReferenceID | Gets a unique reference identifier. This is guaranteed to be unique only for dynvalues created in a single thread as it's not thread-safe.
Public property | String | Gets the string value (valid only if the Type is String)
Public property | Table | Gets the table (valid only if the Type is Table)
Public property | TailCallData | Gets the tail call data.
 | True | A preinitialized, readonly instance, equaling True
Public property | Tuple | Gets the values in the tuple (valid only if the Type is Tuple). This field is currently also used to hold arguments in values whose Type is TailCallRequest.
Public property | Type | Gets the type of the value.
Public property | UserData | Gets the tail call data.
 | Void | A preinitialized, readonly instance, equaling Void
Public property | YieldRequest | Gets the yield request data.
Top
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.Boolean Property

DynValueBoolean Property
Gets the boolean value (valid only if the Type is Boolean)

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool Boolean { get; }
Public ReadOnly Property Boolean As Boolean
    Get
public:
property bool Boolean {
    bool get ();
}
member Boolean : bool with get

Property Value

Type: Boolean
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.Callback Property

DynValueCallback Property
Gets the CLR callback (valid only if the Type is ClrFunction)

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CallbackFunction Callback { get; }
Public ReadOnly Property Callback As CallbackFunction
    Get
public:
property CallbackFunction^ Callback {
    CallbackFunction^ get ();
}
member Callback : CallbackFunction with get

Property Value

Type: CallbackFunction
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.Coroutine Property

DynValueCoroutine Property
Gets the coroutine handle. (valid only if the Type is Thread).

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Coroutine Coroutine { get; }
Public ReadOnly Property Coroutine As Coroutine
    Get
public:
property Coroutine^ Coroutine {
    Coroutine^ get ();
}
member Coroutine : Coroutine with get

Property Value

Type: Coroutine
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.False Property

DynValueFalse Property
A preinitialized, readonly instance, equaling False

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue False { get; }
Public Shared ReadOnly Property False As DynValue
    Get
public:
static property DynValue^ False {
    DynValue^ get ();
}
static member False : DynValue with get

Property Value

Type: DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.Function Property

DynValueFunction Property
Gets the function (valid only if the Type is Function)

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Closure Function { get; }
Public ReadOnly Property Function As Closure
    Get
public:
property Closure^ Function {
    Closure^ get ();
}
member Function : Closure with get

Property Value

Type: Closure
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.Nil Property

DynValueNil Property
A preinitialized, readonly instance, equaling Nil

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue Nil { get; }
Public Shared ReadOnly Property Nil As DynValue
    Get
public:
static property DynValue^ Nil {
    DynValue^ get ();
}
static member Nil : DynValue with get

Property Value

Type: DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.Number Property

DynValueNumber Property
Gets the numeric value (valid only if the Type is Number)

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public double Number { get; }
Public ReadOnly Property Number As Double
    Get
public:
property double Number {
    double get ();
}
member Number : float with get

Property Value

Type: Double
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.ReadOnly Property

DynValueReadOnly Property
Returns true if this instance is write protected.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReadOnly { get; }
Public ReadOnly Property ReadOnly As Boolean
    Get
public:
property bool ReadOnly {
    bool get ();
}
member ReadOnly : bool with get

Property Value

Type: Boolean
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.ReferenceID Property

DynValueReferenceID Property
Gets a unique reference identifier. This is guaranteed to be unique only for dynvalues created in a single thread as it's not thread-safe.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int ReferenceID { get; }
Public ReadOnly Property ReferenceID As Integer
    Get
public:
property int ReferenceID {
    int get ();
}
member ReferenceID : int with get

Property Value

Type: Int32
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.String Property

DynValueString Property
Gets the string value (valid only if the Type is String)

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string String { get; }
Public ReadOnly Property String As String
    Get
public:
property String^ String {
    String^ get ();
}
member String : string with get

Property Value

Type: String
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.Table Property

DynValueTable Property
Gets the table (valid only if the Type is Table)

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Table Table { get; }
Public ReadOnly Property Table As Table
    Get
public:
property Table^ Table {
    Table^ get ();
}
member Table : Table with get

Property Value

Type: Table
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.TailCallData Property

DynValueTailCallData Property
Gets the tail call data.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public TailCallData TailCallData { get; }
Public ReadOnly Property TailCallData As TailCallData
    Get
public:
property TailCallData^ TailCallData {
    TailCallData^ get ();
}
member TailCallData : TailCallData with get

Property Value

Type: TailCallData
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.True Property

DynValueTrue Property
A preinitialized, readonly instance, equaling True

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue True { get; }
Public Shared ReadOnly Property True As DynValue
    Get
public:
static property DynValue^ True {
    DynValue^ get ();
}
static member True : DynValue with get

Property Value

Type: DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.Tuple Property

DynValueTuple Property
Gets the values in the tuple (valid only if the Type is Tuple). This field is currently also used to hold arguments in values whose Type is TailCallRequest.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue[] Tuple { get; }
Public ReadOnly Property Tuple As DynValue()
    Get
public:
property array<DynValue^>^ Tuple {
    array<DynValue^>^ get ();
}
member Tuple : DynValue[] with get

Property Value

Type: DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.Type Property

DynValueType Property
Gets the type of the value.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DataType Type { get; }
Public ReadOnly Property Type As DataType
    Get
public:
property DataType Type {
    DataType get ();
}
member Type : DataType with get

Property Value

Type: DataType
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.UserData Property

DynValueUserData Property
Gets the tail call data.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public UserData UserData { get; }
Public ReadOnly Property UserData As UserData
    Get
public:
property UserData^ UserData {
    UserData^ get ();
}
member UserData : UserData with get

Property Value

Type: UserData
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.Void Property

DynValueVoid Property
A preinitialized, readonly instance, equaling Void

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue Void { get; }
Public Shared ReadOnly Property Void As DynValue
    Get
public:
static property DynValue^ Void {
    DynValue^ get ();
}
static member Void : DynValue with get

Property Value

Type: DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.YieldRequest Property

DynValueYieldRequest Property
Gets the yield request data.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public YieldRequest YieldRequest { get; }
Public ReadOnly Property YieldRequest As YieldRequest
    Get
public:
property YieldRequest^ YieldRequest {
    YieldRequest^ get ();
}
member YieldRequest : YieldRequest with get

Property Value

Type: YieldRequest
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue Methods

DynValue Methods

The DynValue type exposes the following members.

Methods
 | Name | Description
Public method | AsReadOnly | Returns this value as readonly - eventually cloning it in the process if it isn't readonly to start with.
Public method | Assign | Performs an assignment, overwriting the value with the specified one.
Public method | CastToBool | Casts this DynValue to a bool
Public method | CastToNumber | Casts this DynValue to a double, using coercion if the type is string.
Public method | CastToString | Casts this DynValue to string, using coercion if the type is number.
Public method | CheckType | Checks the type of this value corresponds to the desired type. A propert ScriptRuntimeException is thrown if the value is not of the specified type or - considering the TypeValidationFlags - is not convertible to the specified type.
Public method | CheckUserDataTypeT | Checks if the type is a specific userdata type, and returns it or throws.
Public method | Clone | Clones this instance.
Public method | Clone(Boolean) | Clones this instance, overriding the "readonly" status.
Public method | CloneAsWritable | Clones this instance, returning a writable copy.
Public method | Equals | Determines whether the specified Object, is equal to this instance. (Overrides ObjectEquals(Object).)
 | FromObject | Creates a new DynValue from a CLR object
Public method | GetAsPrivateResource | Returns this DynValue as an instance of IScriptPrivateResource, if possible, null otherwise
Public method | GetHashCode | Returns a hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetLength | Gets the length of a string or table value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsNil | Determines whether this instance is nil or void
Public method | IsNilOrNan | Determines whether is nil, void or NaN (and thus unsuitable for using as a table key).
Public method | IsNotNil | Determines whether this instance is not nil or void
Public method | IsNotVoid | Determines whether this instance is not void
Public method | IsVoid | Determines whether this instance is void
 | NewBoolean | Creates a new writable value initialized to the specified boolean.
 | NewCallback(CallbackFunction) | Creates a new writable value initialized to the specified CLR callback. See also CallbackFunction.FromDelegate and CallbackFunction.FromMethodInfo factory methods.
 | NewCallback(FuncScriptExecutionContext, CallbackArguments, DynValue, String) | Creates a new writable value initialized to the specified CLR callback.
 | NewClosure | Creates a new writable value initialized to the specified closure (function).
 | NewCoroutine | Creates a new writable value initialized to the specified coroutine. Internal use only, for external use, see Script.CoroutineCreate
 | NewNil | Creates a new writable value initialized to Nil.
 | NewNumber | Creates a new writable value initialized to the specified number.
 | NewPrimeTable | Creates a new writable value initialized to an empty prime table (a prime table is a table made only of numbers, strings, booleans and other prime tables).
 | NewString(String) | Creates a new writable value initialized to the specified string.
 | NewString(StringBuilder) | Creates a new writable value initialized to the specified StringBuilder.
 | NewString(String, Object) | Creates a new writable value initialized to the specified string using String.Format like syntax
 | NewTable(Script) | Creates a new writable value initialized to an empty table.
 | NewTable(Table) | Creates a new writable value initialized to the specified table.
 | NewTable(Script, DynValue) | Creates a new writable value initialized to with array contents.
 | NewTailCallReq(TailCallData) | Creates a new request for a tail call. This is the preferred way to execute Lua/MoonSharp code from a callback, although it's not always possible to use it. When a function (callback or script closure) returns a TailCallRequest, the bytecode processor immediately executes the function contained in the request. By executing script in this way, a callback function ensures it's not on the stack anymore and thus a number of functionality (state savings, coroutines, etc) keeps working at full power.
 | NewTailCallReq(DynValue, DynValue) | Creates a new request for a tail call. This is the preferred way to execute Lua/MoonSharp code from a callback, although it's not always possible to use it. When a function (callback or script closure) returns a TailCallRequest, the bytecode processor immediately executes the function contained in the request. By executing script in this way, a callback function ensures it's not on the stack anymore and thus a number of functionality (state savings, coroutines, etc) keeps working at full power.
 | NewTuple | Creates a new tuple initialized to the specified values.
 | NewTupleNested | Creates a new tuple initialized to the specified values - which can be potentially other tuples
 | NewUserData | Creates a new userdata value
 | NewYieldReq | Creates a new request for a yield of the current coroutine.
Public method | ToDebugPrintString | Returns a string which is what it's expected to be output by debuggers.
Public method | ToDynamic | Converts this MoonSharp DynValue to a CLR object, marked as dynamic
Public method | ToObject | Converts this MoonSharp DynValue to a CLR object.
Public method | ToObject(Type) | Converts this MoonSharp DynValue to a CLR object of the specified type.
Public method | ToObjectT | Converts this MoonSharp DynValue to a CLR object of the specified type.
Public method | ToPrintString | Returns a string which is what it's expected to be output by the print function applied to this value.
Public method | ToScalar | Converts a tuple to a scalar value. If it's already a scalar value, this function returns "this".
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | SerializeValue | (Defined by SerializationExtensions.)
Top
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.AsReadOnly Method

DynValueAsReadOnly Method
Returns this value as readonly - eventually cloning it in the process if it isn't readonly to start with.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue AsReadOnly()
Public Function AsReadOnly As DynValue
public:
DynValue^ AsReadOnly()
member AsReadOnly : unit -> DynValue

Return Value

Type: DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.Assign Method

DynValueAssign Method
Performs an assignment, overwriting the value with the specified one.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void Assign(
    DynValue value
)
Public Sub Assign (
    value As DynValue
)
public:
void Assign(
    DynValue^ value
)
member Assign :
        value : DynValue -> unit

Parameters

value
Type: MoonSharp.InterpreterDynValue
The value.
Exceptions
Exception | Condition
ScriptRuntimeException | If the value is readonly.
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.CastToBool Method

DynValueCastToBool Method
Casts this DynValue to a bool

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool CastToBool()
Public Function CastToBool As Boolean
public:
bool CastToBool()
member CastToBool : unit -> bool

Return Value

Type: Boolean
False if value is false or nil, true otherwise.
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.CastToNumber Method

DynValueCastToNumber Method
Casts this DynValue to a double, using coercion if the type is string.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<double> CastToNumber()
Public Function CastToNumber As Nullable(Of Double)
public:
Nullable<double> CastToNumber()
member CastToNumber : unit -> Nullable<float>

Return Value

Type: Nullable Double
The string representation, or null if not number, not string or non-convertible-string.
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.CastToString Method

DynValueCastToString Method
Casts this DynValue to string, using coercion if the type is number.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string CastToString()
Public Function CastToString As String
public:
String^ CastToString()
member CastToString : unit -> string

Return Value

Type: String
The string representation, or null if not number, not string.
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.CheckType Method

DynValueCheckType Method
Checks the type of this value corresponds to the desired type. A propert ScriptRuntimeException is thrown if the value is not of the specified type or - considering the TypeValidationFlags - is not convertible to the specified type.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue CheckType(
    string funcName,
    DataType desiredType,
    int argNum = -1,
    TypeValidationFlags flags = TypeValidationFlags.AutoConvert
)
Public Function CheckType (
    funcName As String,
    desiredType As DataType,
    Optional argNum As Integer = -1,
    Optional flags As TypeValidationFlags = TypeValidationFlags.AutoConvert
) As DynValue
public:
DynValue^ CheckType(
    String^ funcName,
    DataType desiredType,
    int argNum = -1,
    TypeValidationFlags flags = TypeValidationFlags::AutoConvert
)
member CheckType :
        funcName : string *
        desiredType : DataType *
        ?argNum : int *
        ?flags : TypeValidationFlags
(* Defaults:
        let _argNum = defaultArg argNum -1
        let _flags = defaultArg flags TypeValidationFlags.AutoConvert
*)
-> DynValue

Parameters

funcName
Type: SystemString
Name of the function requesting the value, for error message purposes.
desiredType
Type: MoonSharp.InterpreterDataType
The desired data type.
argNum (Optional)
Type: SystemInt32
The argument number, for error message purposes.
flags (Optional)
Type: MoonSharp.InterpreterTypeValidationFlags
The TypeValidationFlags.

Return Value

Type: DynValue
Exceptions
Exception | Condition
ScriptRuntimeException | Thrown if the value is not of the specified type or - considering the TypeValidationFlags - is not convertible to the specified type.
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.CheckUserDataType(T) Method

DynValueCheckUserDataTypeT Method
Checks if the type is a specific userdata type, and returns it or throws.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public T CheckUserDataType<T>(
    string funcName,
    int argNum = -1,
    TypeValidationFlags flags = TypeValidationFlags.AutoConvert
)

Public Function CheckUserDataType(Of T) (
    funcName As String,
    Optional argNum As Integer = -1,
    Optional flags As TypeValidationFlags = TypeValidationFlags.AutoConvert
) As T
public:
generic<typename T>
T CheckUserDataType(
    String^ funcName,
    int argNum = -1,
    TypeValidationFlags flags = TypeValidationFlags::AutoConvert
)
member CheckUserDataType :
        funcName : string *
        ?argNum : int *
        ?flags : TypeValidationFlags
(* Defaults:
        let _argNum = defaultArg argNum -1
        let _flags = defaultArg flags TypeValidationFlags.AutoConvert
*)
-> 'T

Parameters

funcName
Type: SystemString
Name of the function.
argNum (Optional)
Type: SystemInt32
The argument number.
flags (Optional)
Type: MoonSharp.InterpreterTypeValidationFlags
The flags.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:MoonSharp.Interpreter.DynValue.CheckUserDataType``1(System.String,System.Int32,MoonSharp.Interpreter.TypeValidationFlags)"]

Return Value

Type: T
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.Clone Method

DynValueClone Method
Overload List
 | Name | Description
Public method | Clone | Clones this instance.
Public method | Clone(Boolean) | Clones this instance, overriding the "readonly" status.
Top
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.Clone Method

DynValueClone Method
Clones this instance.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Clone()
Public Function Clone As DynValue
public:
DynValue^ Clone()
member Clone : unit -> DynValue

Return Value

Type: DynValue
See Also

Reference

DynValue Class
Clone Overload
MoonSharp.Interpreter Namespace


DynValue.Clone Method (Boolean)

DynValueClone Method (Boolean)
Clones this instance, overriding the "readonly" status.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Clone(
    bool readOnly
)
Public Function Clone (
    readOnly As Boolean
) As DynValue
public:
DynValue^ Clone(
    bool readOnly
)
member Clone :
        readOnly : bool -> DynValue

Parameters

readOnly
Type: SystemBoolean
if set to true the new instance is set as readonly, or writeable otherwise.

Return Value

Type: DynValue
See Also

Reference

DynValue Class
Clone Overload
MoonSharp.Interpreter Namespace


DynValue.CloneAsWritable Method

DynValueCloneAsWritable Method
Clones this instance, returning a writable copy.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue CloneAsWritable()
Public Function CloneAsWritable As DynValue
public:
DynValue^ CloneAsWritable()
member CloneAsWritable : unit -> DynValue

Return Value

Type: DynValue
Exceptions
Exception | Condition
ArgumentException | Can't clone Symbol values
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.Equals Method

DynValueEquals Method
Determines whether the specified Object, is equal to this instance.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
The Object to compare with this instance.

Return Value

Type: Boolean
true if the specified Object is equal to this instance; otherwise, false.
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.FromObject Method

DynValueFromObject Method
Creates a new DynValue from a CLR object

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue FromObject(
    Script script,
    Object obj
)
Public Shared Function FromObject (
    script As Script,
    obj As Object
) As DynValue
public:
static DynValue^ FromObject(
    Script^ script,
    Object^ obj
)
static member FromObject :
        script : Script *
        obj : Object -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object.

Return Value

Type: DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.GetAsPrivateResource Method

DynValueGetAsPrivateResource Method
Returns this DynValue as an instance of IScriptPrivateResource, if possible, null otherwise

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptPrivateResource GetAsPrivateResource()
Public Function GetAsPrivateResource As IScriptPrivateResource
public:
IScriptPrivateResource^ GetAsPrivateResource()
member GetAsPrivateResource : unit -> IScriptPrivateResource

Return Value

Type: IScriptPrivateResource
False if value is false or nil, true otherwise.
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.GetHashCode Method

DynValueGetHashCode Method
Returns a hash code for this instance.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.GetLength Method

DynValueGetLength Method
Gets the length of a string or table value.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue GetLength()
Public Function GetLength As DynValue
public:
DynValue^ GetLength()
member GetLength : unit -> DynValue

Return Value

Type: DynValue
Exceptions
Exception | Condition
ScriptRuntimeException | Value is not a table or string.
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.IsNil Method

DynValueIsNil Method
Determines whether this instance is nil or void

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNil()
Public Function IsNil As Boolean
public:
bool IsNil()
member IsNil : unit -> bool

Return Value

Type: Boolean
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.IsNilOrNan Method

DynValueIsNilOrNan Method
Determines whether is nil, void or NaN (and thus unsuitable for using as a table key).

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNilOrNan()
Public Function IsNilOrNan As Boolean
public:
bool IsNilOrNan()
member IsNilOrNan : unit -> bool

Return Value

Type: Boolean
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.IsNotNil Method

DynValueIsNotNil Method
Determines whether this instance is not nil or void

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNotNil()
Public Function IsNotNil As Boolean
public:
bool IsNotNil()
member IsNotNil : unit -> bool

Return Value

Type: Boolean
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.IsNotVoid Method

DynValueIsNotVoid Method
Determines whether this instance is not void

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNotVoid()
Public Function IsNotVoid As Boolean
public:
bool IsNotVoid()
member IsNotVoid : unit -> bool

Return Value

Type: Boolean
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.IsVoid Method

DynValueIsVoid Method
Determines whether this instance is void

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsVoid()
Public Function IsVoid As Boolean
public:
bool IsVoid()
member IsVoid : unit -> bool

Return Value

Type: Boolean
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.NewBoolean Method

DynValueNewBoolean Method
Creates a new writable value initialized to the specified boolean.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewBoolean(
    bool v
)
Public Shared Function NewBoolean (
    v As Boolean
) As DynValue
public:
static DynValue^ NewBoolean(
    bool v
)
static member NewBoolean :
        v : bool -> DynValue

Parameters

v
Type: SystemBoolean

[Missing <param name="v"/> documentation for "M:MoonSharp.Interpreter.DynValue.NewBoolean(System.Boolean)"]

Return Value

Type: DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.NewCallback Method

DynValueNewCallback Method
Overload List
Name | Description
NewCallback(CallbackFunction) | Creates a new writable value initialized to the specified CLR callback. See also CallbackFunction.FromDelegate and CallbackFunction.FromMethodInfo factory methods.
NewCallback(FuncScriptExecutionContext, CallbackArguments, DynValue, String) | Creates a new writable value initialized to the specified CLR callback.
Top
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.NewCallback Method (CallbackFunction)

DynValueNewCallback Method (CallbackFunction)
Creates a new writable value initialized to the specified CLR callback. See also CallbackFunction.FromDelegate and CallbackFunction.FromMethodInfo factory methods.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewCallback(
    CallbackFunction function
)
Public Shared Function NewCallback (
    function As CallbackFunction
) As DynValue
public:
static DynValue^ NewCallback(
    CallbackFunction^ function
)
static member NewCallback :
        function : CallbackFunction -> DynValue

Parameters

function
Type: MoonSharp.InterpreterCallbackFunction

[Missing <param name="function"/> documentation for "M:MoonSharp.Interpreter.DynValue.NewCallback(MoonSharp.Interpreter.CallbackFunction)"]

Return Value

Type: DynValue
See Also

Reference

DynValue Class
NewCallback Overload
MoonSharp.Interpreter Namespace


DynValue.NewCallback Method (Func(ScriptExecutionContext, CallbackArguments, DynValue), String)

DynValueNewCallback Method (FuncScriptExecutionContext, CallbackArguments, DynValue, String)
Creates a new writable value initialized to the specified CLR callback.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewCallback(
    Func<ScriptExecutionContext, CallbackArguments, DynValue> callBack,
    string name = null
)
Public Shared Function NewCallback (
    callBack As Func(Of ScriptExecutionContext, CallbackArguments, DynValue),
    Optional name As String = Nothing
) As DynValue
public:
static DynValue^ NewCallback(
    Func<ScriptExecutionContext^, CallbackArguments^, DynValue^>^ callBack,
    String^ name = nullptr
)
static member NewCallback :
        callBack : Func<ScriptExecutionContext, CallbackArguments, DynValue> *
        ?name : string
(* Defaults:
        let _name = defaultArg name null
*)
-> DynValue

Parameters

callBack
Type: SystemFunc ScriptExecutionContext, CallbackArguments, DynValue

[Missing <param name="callBack"/> documentation for "M:MoonSharp.Interpreter.DynValue.NewCallback(System.Func{MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments,MoonSharp.Interpreter.DynValue},System.String)"]

name (Optional)
Type: SystemString

[Missing <param name="name"/> documentation for "M:MoonSharp.Interpreter.DynValue.NewCallback(System.Func{MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments,MoonSharp.Interpreter.DynValue},System.String)"]

Return Value

Type: DynValue
See Also

Reference

DynValue Class
NewCallback Overload
MoonSharp.Interpreter Namespace


DynValue.NewClosure Method

DynValueNewClosure Method
Creates a new writable value initialized to the specified closure (function).

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewClosure(
    Closure function
)
Public Shared Function NewClosure (
    function As Closure
) As DynValue
public:
static DynValue^ NewClosure(
    Closure^ function
)
static member NewClosure :
        function : Closure -> DynValue

Parameters

function
Type: MoonSharp.InterpreterClosure

[Missing <param name="function"/> documentation for "M:MoonSharp.Interpreter.DynValue.NewClosure(MoonSharp.Interpreter.Closure)"]

Return Value

Type: DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.NewCoroutine Method

DynValueNewCoroutine Method
Creates a new writable value initialized to the specified coroutine. Internal use only, for external use, see Script.CoroutineCreate

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewCoroutine(
    Coroutine coroutine
)
Public Shared Function NewCoroutine (
    coroutine As Coroutine
) As DynValue
public:
static DynValue^ NewCoroutine(
    Coroutine^ coroutine
)
static member NewCoroutine :
        coroutine : Coroutine -> DynValue

Parameters

coroutine
Type: MoonSharp.InterpreterCoroutine
The coroutine object.

Return Value

Type: DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.NewNil Method

DynValueNewNil Method
Creates a new writable value initialized to Nil.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewNil()
Public Shared Function NewNil As DynValue
public:
static DynValue^ NewNil()
static member NewNil : unit -> DynValue

Return Value

Type: DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.NewNumber Method

DynValueNewNumber Method
Creates a new writable value initialized to the specified number.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewNumber(
    double num
)
Public Shared Function NewNumber (
    num As Double
) As DynValue
public:
static DynValue^ NewNumber(
    double num
)
static member NewNumber :
        num : float -> DynValue

Parameters

num
Type: SystemDouble

[Missing <param name="num"/> documentation for "M:MoonSharp.Interpreter.DynValue.NewNumber(System.Double)"]

Return Value

Type: DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.NewPrimeTable Method

DynValueNewPrimeTable Method
Creates a new writable value initialized to an empty prime table (a prime table is a table made only of numbers, strings, booleans and other prime tables).

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewPrimeTable()
Public Shared Function NewPrimeTable As DynValue
public:
static DynValue^ NewPrimeTable()
static member NewPrimeTable : unit -> DynValue

Return Value

Type: DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.NewString Method

DynValueNewString Method
Overload List
Name | Description
NewString(String) | Creates a new writable value initialized to the specified string.
NewString(StringBuilder) | Creates a new writable value initialized to the specified StringBuilder.
NewString(String, Object) | Creates a new writable value initialized to the specified string using String.Format like syntax
Top
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.NewString Method (String)

DynValueNewString Method (String)
Creates a new writable value initialized to the specified string.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewString(
    string str
)
Public Shared Function NewString (
    str As String
) As DynValue
public:
static DynValue^ NewString(
    String^ str
)
static member NewString :
        str : string -> DynValue

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:MoonSharp.Interpreter.DynValue.NewString(System.String)"]

Return Value

Type: DynValue
See Also

Reference

DynValue Class
NewString Overload
MoonSharp.Interpreter Namespace


DynValue.NewString Method (StringBuilder)

DynValueNewString Method (StringBuilder)
Creates a new writable value initialized to the specified StringBuilder.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewString(
    StringBuilder sb
)
Public Shared Function NewString (
    sb As StringBuilder
) As DynValue
public:
static DynValue^ NewString(
    StringBuilder^ sb
)
static member NewString :
        sb : StringBuilder -> DynValue

Parameters

sb
Type: System.TextStringBuilder

[Missing <param name="sb"/> documentation for "M:MoonSharp.Interpreter.DynValue.NewString(System.Text.StringBuilder)"]

Return Value

Type: DynValue
See Also

Reference

DynValue Class
NewString Overload
MoonSharp.Interpreter Namespace


DynValue.NewString Method (String, Object[])

DynValueNewString Method (String, Object)
Creates a new writable value initialized to the specified string using String.Format like syntax

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewString(
    string format,
    params Object[] args
)
Public Shared Function NewString (
    format As String,
    ParamArray args As Object()
) As DynValue
public:
static DynValue^ NewString(
    String^ format,
    ... array<Object^>^ args
)
static member NewString :
        format : string *
        args : Object[] -> DynValue

Parameters

format
Type: SystemString

[Missing <param name="format"/> documentation for "M:MoonSharp.Interpreter.DynValue.NewString(System.String,System.Object[])"]

args
Type: SystemObject

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.DynValue.NewString(System.String,System.Object[])"]

Return Value

Type: DynValue
See Also

Reference

DynValue Class
NewString Overload
MoonSharp.Interpreter Namespace


DynValue.NewTable Method

DynValueNewTable Method
Overload List
Name | Description
NewTable(Script) | Creates a new writable value initialized to an empty table.
NewTable(Table) | Creates a new writable value initialized to the specified table.
NewTable(Script, DynValue) | Creates a new writable value initialized to with array contents.
Top
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.NewTable Method (Script)

DynValueNewTable Method (Script)
Creates a new writable value initialized to an empty table.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewTable(
    Script script
)
Public Shared Function NewTable (
    script As Script
) As DynValue
public:
static DynValue^ NewTable(
    Script^ script
)
static member NewTable :
        script : Script -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript

[Missing <param name="script"/> documentation for "M:MoonSharp.Interpreter.DynValue.NewTable(MoonSharp.Interpreter.Script)"]

Return Value

Type: DynValue
See Also

Reference

DynValue Class
NewTable Overload
MoonSharp.Interpreter Namespace


DynValue.NewTable Method (Table)

DynValueNewTable Method (Table)
Creates a new writable value initialized to the specified table.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewTable(
    Table table
)
Public Shared Function NewTable (
    table As Table
) As DynValue
public:
static DynValue^ NewTable(
    Table^ table
)
static member NewTable :
        table : Table -> DynValue

Parameters

table
Type: MoonSharp.InterpreterTable

[Missing <param name="table"/> documentation for "M:MoonSharp.Interpreter.DynValue.NewTable(MoonSharp.Interpreter.Table)"]

Return Value

Type: DynValue
See Also

Reference

DynValue Class
NewTable Overload
MoonSharp.Interpreter Namespace


DynValue.NewTable Method (Script, DynValue[])

DynValueNewTable Method (Script, DynValue)
Creates a new writable value initialized to with array contents.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewTable(
    Script script,
    params DynValue[] arrayValues
)
Public Shared Function NewTable (
    script As Script,
    ParamArray arrayValues As DynValue()
) As DynValue
public:
static DynValue^ NewTable(
    Script^ script,
    ... array<DynValue^>^ arrayValues
)
static member NewTable :
        script : Script *
        arrayValues : DynValue[] -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript

[Missing <param name="script"/> documentation for "M:MoonSharp.Interpreter.DynValue.NewTable(MoonSharp.Interpreter.Script,MoonSharp.Interpreter.DynValue[])"]

arrayValues
Type: MoonSharp.InterpreterDynValue

[Missing <param name="arrayValues"/> documentation for "M:MoonSharp.Interpreter.DynValue.NewTable(MoonSharp.Interpreter.Script,MoonSharp.Interpreter.DynValue[])"]

Return Value

Type: DynValue
See Also

Reference

DynValue Class
NewTable Overload
MoonSharp.Interpreter Namespace


DynValue.NewTailCallReq Method

DynValueNewTailCallReq Method
Overload List
Name | Description
NewTailCallReq(TailCallData) | Creates a new request for a tail call. This is the preferred way to execute Lua/MoonSharp code from a callback, although it's not always possible to use it. When a function (callback or script closure) returns a TailCallRequest, the bytecode processor immediately executes the function contained in the request. By executing script in this way, a callback function ensures it's not on the stack anymore and thus a number of functionality (state savings, coroutines, etc) keeps working at full power.
NewTailCallReq(DynValue, DynValue) | Creates a new request for a tail call. This is the preferred way to execute Lua/MoonSharp code from a callback, although it's not always possible to use it. When a function (callback or script closure) returns a TailCallRequest, the bytecode processor immediately executes the function contained in the request. By executing script in this way, a callback function ensures it's not on the stack anymore and thus a number of functionality (state savings, coroutines, etc) keeps working at full power.
Top
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.NewTailCallReq Method (TailCallData)

DynValueNewTailCallReq Method (TailCallData)
Creates a new request for a tail call. This is the preferred way to execute Lua/MoonSharp code from a callback, although it's not always possible to use it. When a function (callback or script closure) returns a TailCallRequest, the bytecode processor immediately executes the function contained in the request. By executing script in this way, a callback function ensures it's not on the stack anymore and thus a number of functionality (state savings, coroutines, etc) keeps working at full power.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewTailCallReq(
    TailCallData tailCallData
)
Public Shared Function NewTailCallReq (
    tailCallData As TailCallData
) As DynValue
public:
static DynValue^ NewTailCallReq(
    TailCallData^ tailCallData
)
static member NewTailCallReq :
        tailCallData : TailCallData -> DynValue

Parameters

tailCallData
Type: MoonSharp.InterpreterTailCallData
The data for the tail call.

Return Value

Type: DynValue
See Also

Reference

DynValue Class
NewTailCallReq Overload
MoonSharp.Interpreter Namespace


DynValue.NewTailCallReq Method (DynValue, DynValue[])

DynValueNewTailCallReq Method (DynValue, DynValue)
Creates a new request for a tail call. This is the preferred way to execute Lua/MoonSharp code from a callback, although it's not always possible to use it. When a function (callback or script closure) returns a TailCallRequest, the bytecode processor immediately executes the function contained in the request. By executing script in this way, a callback function ensures it's not on the stack anymore and thus a number of functionality (state savings, coroutines, etc) keeps working at full power.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewTailCallReq(
    DynValue tailFn,
    params DynValue[] args
)
Public Shared Function NewTailCallReq (
    tailFn As DynValue,
    ParamArray args As DynValue()
) As DynValue
public:
static DynValue^ NewTailCallReq(
    DynValue^ tailFn,
    ... array<DynValue^>^ args
)
static member NewTailCallReq :
        tailFn : DynValue *
        args : DynValue[] -> DynValue

Parameters

tailFn
Type: MoonSharp.InterpreterDynValue
The function to be called.
args
Type: MoonSharp.InterpreterDynValue
The arguments.

Return Value

Type: DynValue
See Also

Reference

DynValue Class
NewTailCallReq Overload
MoonSharp.Interpreter Namespace


DynValue.NewTuple Method

DynValueNewTuple Method
Creates a new tuple initialized to the specified values.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewTuple(
    params DynValue[] values
)
Public Shared Function NewTuple (
    ParamArray values As DynValue()
) As DynValue
public:
static DynValue^ NewTuple(
    ... array<DynValue^>^ values
)
static member NewTuple :
        values : DynValue[] -> DynValue

Parameters

values
Type: MoonSharp.InterpreterDynValue

[Missing <param name="values"/> documentation for "M:MoonSharp.Interpreter.DynValue.NewTuple(MoonSharp.Interpreter.DynValue[])"]

Return Value

Type: DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.NewTupleNested Method

DynValueNewTupleNested Method
Creates a new tuple initialized to the specified values - which can be potentially other tuples

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewTupleNested(
    params DynValue[] values
)
Public Shared Function NewTupleNested (
    ParamArray values As DynValue()
) As DynValue
public:
static DynValue^ NewTupleNested(
    ... array<DynValue^>^ values
)
static member NewTupleNested :
        values : DynValue[] -> DynValue

Parameters

values
Type: MoonSharp.InterpreterDynValue

[Missing <param name="values"/> documentation for "M:MoonSharp.Interpreter.DynValue.NewTupleNested(MoonSharp.Interpreter.DynValue[])"]

Return Value

Type: DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.NewUserData Method

DynValueNewUserData Method
Creates a new userdata value

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewUserData(
    UserData userData
)
Public Shared Function NewUserData (
    userData As UserData
) As DynValue
public:
static DynValue^ NewUserData(
    UserData^ userData
)
static member NewUserData :
        userData : UserData -> DynValue

Parameters

userData
Type: MoonSharp.InterpreterUserData

[Missing <param name="userData"/> documentation for "M:MoonSharp.Interpreter.DynValue.NewUserData(MoonSharp.Interpreter.UserData)"]

Return Value

Type: DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.NewYieldReq Method

DynValueNewYieldReq Method
Creates a new request for a yield of the current coroutine.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue NewYieldReq(
    DynValue[] args
)
Public Shared Function NewYieldReq (
    args As DynValue()
) As DynValue
public:
static DynValue^ NewYieldReq(
    array<DynValue^>^ args
)
static member NewYieldReq :
        args : DynValue[] -> DynValue

Parameters

args
Type: MoonSharp.InterpreterDynValue
The yield argumenst.

Return Value

Type: DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.ToDebugPrintString Method

DynValueToDebugPrintString Method
Returns a string which is what it's expected to be output by debuggers.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string ToDebugPrintString()
Public Function ToDebugPrintString As String
public:
String^ ToDebugPrintString()
member ToDebugPrintString : unit -> string

Return Value

Type: String
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.ToDynamic Method

DynValueToDynamic Method
Converts this MoonSharp DynValue to a CLR object, marked as dynamic

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Object ToDynamic()
Public Function ToDynamic As Object
public:
Object^ ToDynamic()
member ToDynamic : unit -> Object

Return Value

Type: Object
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.ToObject Method

DynValueToObject Method
Overload List
 | Name | Description
Public method | ToObject | Converts this MoonSharp DynValue to a CLR object.
Public method | ToObjectT | Converts this MoonSharp DynValue to a CLR object of the specified type.
Public method | ToObject(Type) | Converts this MoonSharp DynValue to a CLR object of the specified type.
Top
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.ToObject Method

DynValueToObject Method
Converts this MoonSharp DynValue to a CLR object.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Object ToObject()
Public Function ToObject As Object
public:
Object^ ToObject()
member ToObject : unit -> Object

Return Value

Type: Object
See Also

Reference

DynValue Class
ToObject Overload
MoonSharp.Interpreter Namespace


DynValue.ToObject(T) Method

DynValueToObjectT Method
Converts this MoonSharp DynValue to a CLR object of the specified type.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public T ToObject<T>()

Public Function ToObject(Of T) As T
public:
generic<typename T>
T ToObject()
member ToObject : unit -> 'T

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:MoonSharp.Interpreter.DynValue.ToObject``1"]

Return Value

Type: T
See Also

Reference

DynValue Class
ToObject Overload
MoonSharp.Interpreter Namespace


DynValue.ToObject Method (Type)

DynValueToObject Method (Type)
Converts this MoonSharp DynValue to a CLR object of the specified type.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Object ToObject(
    Type desiredType
)
Public Function ToObject (
    desiredType As Type
) As Object
public:
Object^ ToObject(
    Type^ desiredType
)
member ToObject :
        desiredType : Type -> Object

Parameters

desiredType
Type: SystemType

[Missing <param name="desiredType"/> documentation for "M:MoonSharp.Interpreter.DynValue.ToObject(System.Type)"]

Return Value

Type: Object
See Also

Reference

DynValue Class
ToObject Overload
MoonSharp.Interpreter Namespace


DynValue.ToPrintString Method

DynValueToPrintString Method
Returns a string which is what it's expected to be output by the print function applied to this value.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string ToPrintString()
Public Function ToPrintString As String
public:
String^ ToPrintString()
member ToPrintString : unit -> string

Return Value

Type: String
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.ToScalar Method

DynValueToScalar Method
Converts a tuple to a scalar value. If it's already a scalar value, this function returns "this".

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue ToScalar()
Public Function ToScalar As DynValue
public:
DynValue^ ToScalar()
member ToScalar : unit -> DynValue

Return Value

Type: DynValue
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


DynValue.ToString Method

DynValueToString Method
Returns a String that represents this instance.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String that represents this instance.
See Also

Reference

DynValue Class
MoonSharp.Interpreter Namespace


InternalErrorException Class

InternalErrorException Class
Exception thrown when an inconsistent state is reached in the interpreter
Inheritance Hierarchy
SystemObject
SystemException
MoonSharp.InterpreterInterpreterException
MoonSharp.InterpreterInternalErrorException

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class InternalErrorException : InterpreterException
<SerializableAttribute>
Public Class InternalErrorException
    Inherits InterpreterException
[SerializableAttribute]
public ref class InternalErrorException : public InterpreterException
[<SerializableAttribute>]
type InternalErrorException =
    class
        inherit InterpreterException
    end

The InternalErrorException type exposes the following members.

Properties
 | Name | Description
Public property | CallStack | Gets the interpreter call stack. (Inherited from InterpreterException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | DecoratedMessage | Gets the decorated message (error message plus error location in script) if possible. (Inherited from InterpreterException.)
Public property | DoNotDecorateMessage | Gets or sets a value indicating whether the message should not be decorated (Inherited from InterpreterException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | InstructionPtr | Gets the instruction pointer of the execution (if it makes sense) (Inherited from InterpreterException.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rethrow | Rethrows this instance if (Inherited from InterpreterException.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


InternalErrorException Properties

InternalErrorException Properties

The InternalErrorException type exposes the following members.

Properties
 | Name | Description
Public property | CallStack | Gets the interpreter call stack. (Inherited from InterpreterException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | DecoratedMessage | Gets the decorated message (error message plus error location in script) if possible. (Inherited from InterpreterException.)
Public property | DoNotDecorateMessage | Gets or sets a value indicating whether the message should not be decorated (Inherited from InterpreterException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | InstructionPtr | Gets the instruction pointer of the execution (if it makes sense) (Inherited from InterpreterException.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

InternalErrorException Class
MoonSharp.Interpreter Namespace


InternalErrorException Methods

InternalErrorException Methods

The InternalErrorException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rethrow | Rethrows this instance if (Inherited from InterpreterException.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

InternalErrorException Class
MoonSharp.Interpreter Namespace


InternalErrorException Events

InternalErrorException Events

The InternalErrorException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

InternalErrorException Class
MoonSharp.Interpreter Namespace


InteropAccessMode Enumeration

InteropAccessMode Enumeration
Enumerations of the possible strategies to marshal CLR objects to MoonSharp userdata and functions when using automatic descriptors. Note that these are "hints" and MoonSharp is free to ignore the access mode specified (if different from HideMembers) and downgrade the access mode to "Reflection". This particularly happens when running on AOT platforms like iOS. See also : CallbackFunction and UserData .

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public enum InteropAccessMode
Public Enumeration InteropAccessMode
public enum class InteropAccessMode
type InteropAccessMode
Members
Member name | Value | Description
Reflection | 0 | Optimization is not performed and reflection is used everytime to access members. This is the slowest approach but saves a lot of memory if members are seldomly used.
LazyOptimized | 1 | Optimization is done on the fly the first time a member is accessed. This saves memory for all members that are never accessed, at the cost of an increased script execution time.
Preoptimized | 2 | Optimization is done at registration time.
BackgroundOptimized | 3 | Optimization is done in a background thread which starts at registration time. If a member is accessed before optimization is completed, reflection is used.
Hardwired | 4 | Use the hardwired descriptor(s)
HideMembers | 5 | No optimization is done, and members are not accessible at all.
NoReflectionAllowed | 6 | No reflection is allowed, nor code generation. This is used as a safeguard when registering types which should not use a standard reflection based descriptor - for example for types implementing IUserDataType
Default | 7 | Use the default access mode
See Also

Reference

MoonSharp.Interpreter Namespace


InterpreterException Class

InterpreterException Class
Base type of all exceptions thrown in MoonSharp
Inheritance Hierarchy
SystemObject
SystemException
MoonSharp.InterpreterInterpreterException
MoonSharp.InterpreterInternalErrorException
MoonSharp.InterpreterScriptRuntimeException
MoonSharp.InterpreterSyntaxErrorException

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class InterpreterException : Exception
Public Class InterpreterException
    Inherits Exception
public ref class InterpreterException : public Exception
type InterpreterException =
    class
        inherit Exception
    end

The InterpreterException type exposes the following members.

Constructors
 | Name | Description
Protected method | InterpreterException(Exception) | Initializes a new instance of the InterpreterException class.
Protected method | InterpreterException(String) | Initializes a new instance of the InterpreterException class.
Protected method | InterpreterException(Exception, String) | Initializes a new instance of the InterpreterException class.
Protected method | InterpreterException(String, Object) | Initializes a new instance of the InterpreterException class.
Top
Properties
 | Name | Description
Public property | CallStack | Gets the interpreter call stack.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | DecoratedMessage | Gets the decorated message (error message plus error location in script) if possible.
Public property | DoNotDecorateMessage | Gets or sets a value indicating whether the message should not be decorated
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | InstructionPtr | Gets the instruction pointer of the execution (if it makes sense)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rethrow | Rethrows this instance if
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


InterpreterException Constructor

InterpreterException Constructor
Overload List
 | Name | Description
Protected method | InterpreterException(Exception) | Initializes a new instance of the InterpreterException class.
Protected method | InterpreterException(String) | Initializes a new instance of the InterpreterException class.
Protected method | InterpreterException(Exception, String) | Initializes a new instance of the InterpreterException class.
Protected method | InterpreterException(String, Object) | Initializes a new instance of the InterpreterException class.
Top
See Also

Reference

InterpreterException Class
MoonSharp.Interpreter Namespace


InterpreterException Constructor (Exception)

InterpreterException Constructor (Exception)
Initializes a new instance of the InterpreterException class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected InterpreterException(
    Exception ex
)
Protected Sub New (
    ex As Exception
)
protected:
InterpreterException(
    Exception^ ex
)
new :
        ex : Exception -> InterpreterException

Parameters

ex
Type: SystemException
The ex.
See Also

Reference

InterpreterException Class
InterpreterException Overload
MoonSharp.Interpreter Namespace


InterpreterException Constructor (String)

InterpreterException Constructor (String)
Initializes a new instance of the InterpreterException class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected InterpreterException(
    string message
)
Protected Sub New (
    message As String
)
protected:
InterpreterException(
    String^ message
)
new :
        message : string -> InterpreterException

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

InterpreterException Class
InterpreterException Overload
MoonSharp.Interpreter Namespace


InterpreterException Constructor (Exception, String)

InterpreterException Constructor (Exception, String)
Initializes a new instance of the InterpreterException class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected InterpreterException(
    Exception ex,
    string message
)
Protected Sub New (
    ex As Exception,
    message As String
)
protected:
InterpreterException(
    Exception^ ex,
    String^ message
)
new :
        ex : Exception *
        message : string -> InterpreterException

Parameters

ex
Type: SystemException
The ex.
message
Type: SystemString

[Missing <param name="message"/> documentation for "M:MoonSharp.Interpreter.InterpreterException.#ctor(System.Exception,System.String)"]

See Also

Reference

InterpreterException Class
InterpreterException Overload
MoonSharp.Interpreter Namespace


InterpreterException Constructor (String, Object[])

InterpreterException Constructor (String, Object)
Initializes a new instance of the InterpreterException class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected InterpreterException(
    string format,
    params Object[] args
)
Protected Sub New (
    format As String,
    ParamArray args As Object()
)
protected:
InterpreterException(
    String^ format,
    ... array<Object^>^ args
)
new :
        format : string *
        args : Object[] -> InterpreterException

Parameters

format
Type: SystemString
The format.
args
Type: SystemObject
The arguments.
See Also

Reference

InterpreterException Class
InterpreterException Overload
MoonSharp.Interpreter Namespace


InterpreterException Properties

InterpreterException Properties

The InterpreterException type exposes the following members.

Properties
 | Name | Description
Public property | CallStack | Gets the interpreter call stack.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | DecoratedMessage | Gets the decorated message (error message plus error location in script) if possible.
Public property | DoNotDecorateMessage | Gets or sets a value indicating whether the message should not be decorated
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | InstructionPtr | Gets the instruction pointer of the execution (if it makes sense)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

InterpreterException Class
MoonSharp.Interpreter Namespace


InterpreterException.CallStack Property

InterpreterExceptionCallStack Property
Gets the interpreter call stack.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IList<WatchItem> CallStack { get; }
Public ReadOnly Property CallStack As IList(Of WatchItem)
    Get
public:
property IList<WatchItem^>^ CallStack {
    IList<WatchItem^>^ get ();
}
member CallStack : IList<WatchItem> with get

Property Value

Type: IList WatchItem
See Also

Reference

InterpreterException Class
MoonSharp.Interpreter Namespace


InterpreterException.DecoratedMessage Property

InterpreterExceptionDecoratedMessage Property
Gets the decorated message (error message plus error location in script) if possible.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string DecoratedMessage { get; }
Public ReadOnly Property DecoratedMessage As String
    Get
public:
property String^ DecoratedMessage {
    String^ get ();
}
member DecoratedMessage : string with get

Property Value

Type: String
See Also

Reference

InterpreterException Class
MoonSharp.Interpreter Namespace


InterpreterException.DoNotDecorateMessage Property

InterpreterExceptionDoNotDecorateMessage Property
Gets or sets a value indicating whether the message should not be decorated

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool DoNotDecorateMessage { get; set; }
Public Property DoNotDecorateMessage As Boolean
    Get
    Set
public:
property bool DoNotDecorateMessage {
    bool get ();
    void set (bool value);
}
member DoNotDecorateMessage : bool with get, set

Property Value

Type: Boolean
See Also

Reference

InterpreterException Class
MoonSharp.Interpreter Namespace


InterpreterException.InstructionPtr Property

InterpreterExceptionInstructionPtr Property
Gets the instruction pointer of the execution (if it makes sense)

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int InstructionPtr { get; }
Public ReadOnly Property InstructionPtr As Integer
    Get
public:
property int InstructionPtr {
    int get ();
}
member InstructionPtr : int with get

Property Value

Type: Int32
See Also

Reference

InterpreterException Class
MoonSharp.Interpreter Namespace


InterpreterException Methods

InterpreterException Methods

The InterpreterException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rethrow | Rethrows this instance if
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

InterpreterException Class
MoonSharp.Interpreter Namespace


InterpreterException.Rethrow Method

InterpreterExceptionRethrow Method
Rethrows this instance if

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void Rethrow()
Public Overridable Sub Rethrow
public:
virtual void Rethrow()
abstract Rethrow : unit -> unit
override Rethrow : unit -> unit

Return Value

Type:
See Also

Reference

InterpreterException Class
MoonSharp.Interpreter Namespace


InterpreterException Events

InterpreterException Events

The InterpreterException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

InterpreterException Class
MoonSharp.Interpreter Namespace


IScriptPrivateResource Interface

IScriptPrivateResource Interface
Common interface for all resources which are uniquely bound to a script.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptPrivateResource
Public Interface IScriptPrivateResource
public interface class IScriptPrivateResource
type IScriptPrivateResource =  interface end

The IScriptPrivateResource type exposes the following members.

Properties
 | Name | Description
Public property | OwnerScript | Gets the script owning this resource.
Top
See Also

Reference

MoonSharp.Interpreter Namespace


IScriptPrivateResource Properties

IScriptPrivateResource Properties

The IScriptPrivateResource type exposes the following members.

Properties
 | Name | Description
Public property | OwnerScript | Gets the script owning this resource.
Top
See Also

Reference

IScriptPrivateResource Interface
MoonSharp.Interpreter Namespace


IScriptPrivateResource.OwnerScript Property

IScriptPrivateResourceOwnerScript Property
Gets the script owning this resource.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
Script OwnerScript { get; }
ReadOnly Property OwnerScript As Script
    Get
property Script^ OwnerScript {
    Script^ get ();
}
abstract OwnerScript : Script with get

Property Value

Type: Script
The script owning this resource.
See Also

Reference

IScriptPrivateResource Interface
MoonSharp.Interpreter Namespace


LinqHelpers Class

LinqHelpers Class
LINQ helper methods
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterLinqHelpers

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static class LinqHelpers
<ExtensionAttribute>
Public NotInheritable Class LinqHelpers
[ExtensionAttribute]
public ref class LinqHelpers abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type LinqHelpers =  class end

The LinqHelpers type exposes the following members.

Methods
Name | Description
AsObjects(IEnumerableDynValue) | Converts the elements to CLR objects
AsObjectsT(IEnumerableDynValue) | Converts the elements to CLR objects of the desired type
ConvertT | Converts the specified enumerable dynvalues of a given script type to objects of a given type
OfDataType | Filters an enumeration for items of the given script type
Top
See Also

Reference

MoonSharp.Interpreter Namespace


LinqHelpers Methods

LinqHelpers Methods

The LinqHelpers type exposes the following members.

Methods
Name | Description
AsObjects(IEnumerableDynValue) | Converts the elements to CLR objects
AsObjectsT(IEnumerableDynValue) | Converts the elements to CLR objects of the desired type
ConvertT | Converts the specified enumerable dynvalues of a given script type to objects of a given type
OfDataType | Filters an enumeration for items of the given script type
Top
See Also

Reference

LinqHelpers Class
MoonSharp.Interpreter Namespace


LinqHelpers.AsObjects Method

LinqHelpersAsObjects Method
Overload List
Name | Description
AsObjects(IEnumerableDynValue) | Converts the elements to CLR objects
AsObjectsT(IEnumerableDynValue) | Converts the elements to CLR objects of the desired type
Top
See Also

Reference

LinqHelpers Class
MoonSharp.Interpreter Namespace


LinqHelpers.AsObjects Method (IEnumerable(DynValue))

LinqHelpersAsObjects Method (IEnumerableDynValue)
Converts the elements to CLR objects

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<Object> AsObjects(
    this IEnumerable<DynValue> enumerable
)
<ExtensionAttribute>
Public Shared Function AsObjects (
    enumerable As IEnumerable(Of DynValue)
) As IEnumerable(Of Object)
public:
[ExtensionAttribute]
static IEnumerable<Object^>^ AsObjects(
    IEnumerable<DynValue^>^ enumerable
)
[<ExtensionAttribute>]
static member AsObjects :
        enumerable : IEnumerable<DynValue> -> IEnumerable<Object>

Parameters

enumerable
Type: System.Collections.GenericIEnumerable DynValue
The enumerable.

Return Value

Type: IEnumerable Object

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable DynValue . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

LinqHelpers Class
AsObjects Overload
MoonSharp.Interpreter Namespace


LinqHelpers.AsObjects(T) Method (IEnumerable(DynValue))

LinqHelpersAsObjectsT Method (IEnumerableDynValue)
Converts the elements to CLR objects of the desired type

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<T> AsObjects<T>(
    this IEnumerable<DynValue> enumerable
)

<ExtensionAttribute>
Public Shared Function AsObjects(Of T) (
    enumerable As IEnumerable(Of DynValue)
) As IEnumerable(Of T)
public:
[ExtensionAttribute]
generic<typename T>
static IEnumerable<T>^ AsObjects(
    IEnumerable<DynValue^>^ enumerable
)
[<ExtensionAttribute>]
static member AsObjects :
        enumerable : IEnumerable<DynValue> -> IEnumerable<'T>

Parameters

enumerable
Type: System.Collections.GenericIEnumerable DynValue
The enumerable.

Type Parameters

T
The desired type

Return Value

Type: IEnumerable T

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable DynValue . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

LinqHelpers Class
AsObjects Overload
MoonSharp.Interpreter Namespace


LinqHelpers.Convert(T) Method

LinqHelpersConvertT Method
Converts the specified enumerable dynvalues of a given script type to objects of a given type

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<T> Convert<T>(
    this IEnumerable<DynValue> enumerable,
    DataType type
)

<ExtensionAttribute>
Public Shared Function Convert(Of T) (
    enumerable As IEnumerable(Of DynValue),
    type As DataType
) As IEnumerable(Of T)
public:
[ExtensionAttribute]
generic<typename T>
static IEnumerable<T>^ Convert(
    IEnumerable<DynValue^>^ enumerable,
    DataType type
)
[<ExtensionAttribute>]
static member Convert :
        enumerable : IEnumerable<DynValue> *
        type : DataType -> IEnumerable<'T>

Parameters

enumerable
Type: System.Collections.GenericIEnumerable DynValue
The enumerable.
type
Type: MoonSharp.InterpreterDataType
The type.

Type Parameters

T
The desired type

Return Value

Type: IEnumerable T

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable DynValue . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

LinqHelpers Class
MoonSharp.Interpreter Namespace


LinqHelpers.OfDataType Method

LinqHelpersOfDataType Method
Filters an enumeration for items of the given script type

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<DynValue> OfDataType(
    this IEnumerable<DynValue> enumerable,
    DataType type
)
<ExtensionAttribute>
Public Shared Function OfDataType (
    enumerable As IEnumerable(Of DynValue),
    type As DataType
) As IEnumerable(Of DynValue)
public:
[ExtensionAttribute]
static IEnumerable<DynValue^>^ OfDataType(
    IEnumerable<DynValue^>^ enumerable,
    DataType type
)
[<ExtensionAttribute>]
static member OfDataType :
        enumerable : IEnumerable<DynValue> *
        type : DataType -> IEnumerable<DynValue>

Parameters

enumerable
Type: System.Collections.GenericIEnumerable DynValue
The enumerable.
type
Type: MoonSharp.InterpreterDataType
The script type.

Return Value

Type: IEnumerable DynValue

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable DynValue . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

LinqHelpers Class
MoonSharp.Interpreter Namespace


LuaTypeExtensions Class

LuaTypeExtensions Class
Extension methods to DataType
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterLuaTypeExtensions

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static class LuaTypeExtensions
<ExtensionAttribute>
Public NotInheritable Class LuaTypeExtensions
[ExtensionAttribute]
public ref class LuaTypeExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type LuaTypeExtensions =  class end

The LuaTypeExtensions type exposes the following members.

Methods
Name | Description
CanHaveTypeMetatables | Determines whether this data type can have type metatables.
ToErrorTypeString | Converts the DataType to the string returned by the "type(...)" Lua function
ToLuaDebuggerString | Converts the DataType to the string returned by the "type(...)" Lua function, with additional values to support debuggers
ToLuaTypeString | Converts the DataType to the string returned by the "type(...)" Lua function
Top
See Also

Reference

MoonSharp.Interpreter Namespace


LuaTypeExtensions Methods

LuaTypeExtensions Methods

The LuaTypeExtensions type exposes the following members.

Methods
Name | Description
CanHaveTypeMetatables | Determines whether this data type can have type metatables.
ToErrorTypeString | Converts the DataType to the string returned by the "type(...)" Lua function
ToLuaDebuggerString | Converts the DataType to the string returned by the "type(...)" Lua function, with additional values to support debuggers
ToLuaTypeString | Converts the DataType to the string returned by the "type(...)" Lua function
Top
See Also

Reference

LuaTypeExtensions Class
MoonSharp.Interpreter Namespace


LuaTypeExtensions.CanHaveTypeMetatables Method

LuaTypeExtensionsCanHaveTypeMetatables Method
Determines whether this data type can have type metatables.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanHaveTypeMetatables(
    this DataType type
)
<ExtensionAttribute>
Public Shared Function CanHaveTypeMetatables (
    type As DataType
) As Boolean
public:
[ExtensionAttribute]
static bool CanHaveTypeMetatables(
    DataType type
)
[<ExtensionAttribute>]
static member CanHaveTypeMetatables :
        type : DataType -> bool

Parameters

type
Type: MoonSharp.InterpreterDataType
The type.

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DataType. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

LuaTypeExtensions Class
MoonSharp.Interpreter Namespace


LuaTypeExtensions.ToErrorTypeString Method

LuaTypeExtensionsToErrorTypeString Method
Converts the DataType to the string returned by the "type(...)" Lua function

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string ToErrorTypeString(
    this DataType type
)
<ExtensionAttribute>
Public Shared Function ToErrorTypeString (
    type As DataType
) As String
public:
[ExtensionAttribute]
static String^ ToErrorTypeString(
    DataType type
)
[<ExtensionAttribute>]
static member ToErrorTypeString :
        type : DataType -> string

Parameters

type
Type: MoonSharp.InterpreterDataType
The type.

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DataType. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ScriptRuntimeException | The DataType is not a Lua type
See Also

Reference

LuaTypeExtensions Class
MoonSharp.Interpreter Namespace


LuaTypeExtensions.ToLuaDebuggerString Method

LuaTypeExtensionsToLuaDebuggerString Method
Converts the DataType to the string returned by the "type(...)" Lua function, with additional values to support debuggers

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string ToLuaDebuggerString(
    this DataType type
)
<ExtensionAttribute>
Public Shared Function ToLuaDebuggerString (
    type As DataType
) As String
public:
[ExtensionAttribute]
static String^ ToLuaDebuggerString(
    DataType type
)
[<ExtensionAttribute>]
static member ToLuaDebuggerString :
        type : DataType -> string

Parameters

type
Type: MoonSharp.InterpreterDataType
The type.

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DataType. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ScriptRuntimeException | The DataType is not a Lua type
See Also

Reference

LuaTypeExtensions Class
MoonSharp.Interpreter Namespace


LuaTypeExtensions.ToLuaTypeString Method

LuaTypeExtensionsToLuaTypeString Method
Converts the DataType to the string returned by the "type(...)" Lua function

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string ToLuaTypeString(
    this DataType type
)
<ExtensionAttribute>
Public Shared Function ToLuaTypeString (
    type As DataType
) As String
public:
[ExtensionAttribute]
static String^ ToLuaTypeString(
    DataType type
)
[<ExtensionAttribute>]
static member ToLuaTypeString :
        type : DataType -> string

Parameters

type
Type: MoonSharp.InterpreterDataType
The type.

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DataType. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ScriptRuntimeException | The DataType is not a Lua type
See Also

Reference

LuaTypeExtensions Class
MoonSharp.Interpreter Namespace


ModuleRegister Class

ModuleRegister Class
Class managing modules (mostly as extension methods)
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterModuleRegister

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static class ModuleRegister
<ExtensionAttribute>
Public NotInheritable Class ModuleRegister
[ExtensionAttribute]
public ref class ModuleRegister abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type ModuleRegister =  class end

The ModuleRegister type exposes the following members.

Methods
Name | Description
RegisterConstants | Registers the standard constants (_G, _VERSION, _MOONSHARP) to a table
RegisterCoreModules | Register the core modules to a table
RegisterModuleType(Table, Type) | Registers a module type to the specified table
RegisterModuleTypeT(Table) | Registers a module type to the specified table
Top
See Also

Reference

MoonSharp.Interpreter Namespace


ModuleRegister Methods

ModuleRegister Methods

The ModuleRegister type exposes the following members.

Methods
Name | Description
RegisterConstants | Registers the standard constants (_G, _VERSION, _MOONSHARP) to a table
RegisterCoreModules | Register the core modules to a table
RegisterModuleType(Table, Type) | Registers a module type to the specified table
RegisterModuleTypeT(Table) | Registers a module type to the specified table
Top
See Also

Reference

ModuleRegister Class
MoonSharp.Interpreter Namespace


ModuleRegister.RegisterConstants Method

ModuleRegisterRegisterConstants Method
Registers the standard constants (_G, _VERSION, _MOONSHARP) to a table

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Table RegisterConstants(
    this Table table
)
<ExtensionAttribute>
Public Shared Function RegisterConstants (
    table As Table
) As Table
public:
[ExtensionAttribute]
static Table^ RegisterConstants(
    Table^ table
)
[<ExtensionAttribute>]
static member RegisterConstants :
        table : Table -> Table

Parameters

table
Type: MoonSharp.InterpreterTable
The table.

Return Value

Type: Table

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Table. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ModuleRegister Class
MoonSharp.Interpreter Namespace


ModuleRegister.RegisterCoreModules Method

ModuleRegisterRegisterCoreModules Method
Register the core modules to a table

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Table RegisterCoreModules(
    this Table table,
    CoreModules modules
)
<ExtensionAttribute>
Public Shared Function RegisterCoreModules (
    table As Table,
    modules As CoreModules
) As Table
public:
[ExtensionAttribute]
static Table^ RegisterCoreModules(
    Table^ table,
    CoreModules modules
)
[<ExtensionAttribute>]
static member RegisterCoreModules :
        table : Table *
        modules : CoreModules -> Table

Parameters

table
Type: MoonSharp.InterpreterTable
The table.
modules
Type: MoonSharp.InterpreterCoreModules
The modules.

Return Value

Type: Table

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Table. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ModuleRegister Class
MoonSharp.Interpreter Namespace


ModuleRegister.RegisterModuleType Method

ModuleRegisterRegisterModuleType Method
Overload List
Name | Description
RegisterModuleTypeT(Table) | Registers a module type to the specified table
RegisterModuleType(Table, Type) | Registers a module type to the specified table
Top
See Also

Reference

ModuleRegister Class
MoonSharp.Interpreter Namespace


ModuleRegister.RegisterModuleType(T) Method (Table)

ModuleRegisterRegisterModuleTypeT Method (Table)
Registers a module type to the specified table

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Table RegisterModuleType<T>(
    this Table table
)

<ExtensionAttribute>
Public Shared Function RegisterModuleType(Of T) (
    table As Table
) As Table
public:
[ExtensionAttribute]
generic<typename T>
static Table^ RegisterModuleType(
    Table^ table
)
[<ExtensionAttribute>]
static member RegisterModuleType :
        table : Table -> Table

Parameters

table
Type: MoonSharp.InterpreterTable
The table.

Type Parameters

T
The module type

Return Value

Type: Table

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Table. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | If the module contains some incompatibility
See Also

Reference

ModuleRegister Class
RegisterModuleType Overload
MoonSharp.Interpreter Namespace


ModuleRegister.RegisterModuleType Method (Table, Type)

ModuleRegisterRegisterModuleType Method (Table, Type)
Registers a module type to the specified table

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Table RegisterModuleType(
    this Table gtable,
    Type t
)
<ExtensionAttribute>
Public Shared Function RegisterModuleType (
    gtable As Table,
    t As Type
) As Table
public:
[ExtensionAttribute]
static Table^ RegisterModuleType(
    Table^ gtable,
    Type^ t
)
[<ExtensionAttribute>]
static member RegisterModuleType :
        gtable : Table *
        t : Type -> Table

Parameters

gtable
Type: MoonSharp.InterpreterTable
The table.
t
Type: SystemType
The type

Return Value

Type: Table

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Table. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | If the module contains some incompatibility
See Also

Reference

ModuleRegister Class
RegisterModuleType Overload
MoonSharp.Interpreter Namespace


MoonSharpHiddenAttribute Class

MoonSharpHiddenAttribute Class
Forces a class member visibility to scripts. Can be used to hide public members. Equivalent to MoonSharpVisible(false).
Inheritance Hierarchy
SystemObject
SystemAttribute
MoonSharp.InterpreterMoonSharpHiddenAttribute

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MoonSharpHiddenAttribute : Attribute
Public NotInheritable Class MoonSharpHiddenAttribute
    Inherits Attribute
public ref class MoonSharpHiddenAttribute sealed : public Attribute
[<SealedAttribute>]
type MoonSharpHiddenAttribute =
    class
        inherit Attribute
    end

The MoonSharpHiddenAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | MoonSharpHiddenAttribute | Initializes a new instance of the MoonSharpHiddenAttribute class
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


MoonSharpHiddenAttribute Constructor

MoonSharpHiddenAttribute Constructor
Initializes a new instance of the MoonSharpHiddenAttribute class

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MoonSharpHiddenAttribute()
Public Sub New
public:
MoonSharpHiddenAttribute()
new : unit -> MoonSharpHiddenAttribute
See Also

Reference

MoonSharpHiddenAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpHiddenAttribute Properties

MoonSharpHiddenAttribute Properties

The MoonSharpHiddenAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

MoonSharpHiddenAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpHiddenAttribute Methods

MoonSharpHiddenAttribute Methods

The MoonSharpHiddenAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharpHiddenAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpHideMemberAttribute Class

MoonSharpHideMemberAttribute Class
Lists a userdata member not to be exposed to scripts referencing it by name.
Inheritance Hierarchy
SystemObject
SystemAttribute
MoonSharp.InterpreterMoonSharpHideMemberAttribute

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MoonSharpHideMemberAttribute : Attribute
Public NotInheritable Class MoonSharpHideMemberAttribute
    Inherits Attribute
public ref class MoonSharpHideMemberAttribute sealed : public Attribute
[<SealedAttribute>]
type MoonSharpHideMemberAttribute =
    class
        inherit Attribute
    end

The MoonSharpHideMemberAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | MoonSharpHideMemberAttribute | Initializes a new instance of the MoonSharpHideMemberAttribute class.
Top
Properties
 | Name | Description
Public property | MemberName | Gets the name of the member to be hidden.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


MoonSharpHideMemberAttribute Constructor

MoonSharpHideMemberAttribute Constructor
Initializes a new instance of the MoonSharpHideMemberAttribute class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MoonSharpHideMemberAttribute(
    string memberName
)
Public Sub New (
    memberName As String
)
public:
MoonSharpHideMemberAttribute(
    String^ memberName
)
new :
        memberName : string -> MoonSharpHideMemberAttribute

Parameters

memberName
Type: SystemString
Name of the member to hide.
See Also

Reference

MoonSharpHideMemberAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpHideMemberAttribute Properties

MoonSharpHideMemberAttribute Properties

The MoonSharpHideMemberAttribute type exposes the following members.

Properties
 | Name | Description
Public property | MemberName | Gets the name of the member to be hidden.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

MoonSharpHideMemberAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpHideMemberAttribute.MemberName Property

MoonSharpHideMemberAttributeMemberName Property
Gets the name of the member to be hidden.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string MemberName { get; }
Public ReadOnly Property MemberName As String
    Get
public:
property String^ MemberName {
    String^ get ();
}
member MemberName : string with get

Property Value

Type: String
See Also

Reference

MoonSharpHideMemberAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpHideMemberAttribute Methods

MoonSharpHideMemberAttribute Methods

The MoonSharpHideMemberAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharpHideMemberAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpModuleAttribute Class

MoonSharpModuleAttribute Class
Marks a CLR type to be a MoonSharp module. Modules are the fastest way to bring interop between scripts and CLR code, albeit at the cost of a very increased complexity in writing them. Modules is what's used for the standard library, for maximum efficiency. Modules are basically classes containing only static methods, with the callback function signature. See Table and ModuleRegister for (extension) methods used to register modules to a table. See CallbackFunction for information regarding the standard callback signature along with easier ways to marshal methods. See UserData for easier object marshalling.
Inheritance Hierarchy
SystemObject
SystemAttribute
MoonSharp.InterpreterMoonSharpModuleAttribute

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MoonSharpModuleAttribute : Attribute
Public NotInheritable Class MoonSharpModuleAttribute
    Inherits Attribute
public ref class MoonSharpModuleAttribute sealed : public Attribute
[<SealedAttribute>]
type MoonSharpModuleAttribute =
    class
        inherit Attribute
    end

The MoonSharpModuleAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | MoonSharpModuleAttribute | Initializes a new instance of the MoonSharpModuleAttribute class
Top
Properties
 | Name | Description
Public property | Namespace | Gets or sets the namespace, that is the name of the table which will contain the defined functions. Can be null to be in the global table.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


MoonSharpModuleAttribute Constructor

MoonSharpModuleAttribute Constructor
Initializes a new instance of the MoonSharpModuleAttribute class

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MoonSharpModuleAttribute()
Public Sub New
public:
MoonSharpModuleAttribute()
new : unit -> MoonSharpModuleAttribute
See Also

Reference

MoonSharpModuleAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpModuleAttribute Properties

MoonSharpModuleAttribute Properties

The MoonSharpModuleAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Namespace | Gets or sets the namespace, that is the name of the table which will contain the defined functions. Can be null to be in the global table.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

MoonSharpModuleAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpModuleAttribute.Namespace Property

MoonSharpModuleAttributeNamespace Property
Gets or sets the namespace, that is the name of the table which will contain the defined functions. Can be null to be in the global table.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Namespace { get; set; }
Public Property Namespace As String
    Get
    Set
public:
property String^ Namespace {
    String^ get ();
    void set (String^ value);
}
member Namespace : string with get, set

Property Value

Type: String
See Also

Reference

MoonSharpModuleAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpModuleAttribute Methods

MoonSharpModuleAttribute Methods

The MoonSharpModuleAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharpModuleAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpModuleConstantAttribute Class

MoonSharpModuleConstantAttribute Class
In a module type, mark fields with this attribute to have them exposed as a module constant. See MoonSharpModuleAttribute for more information about modules.
Inheritance Hierarchy
SystemObject
SystemAttribute
MoonSharp.InterpreterMoonSharpModuleConstantAttribute

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MoonSharpModuleConstantAttribute : Attribute
Public NotInheritable Class MoonSharpModuleConstantAttribute
    Inherits Attribute
public ref class MoonSharpModuleConstantAttribute sealed : public Attribute
[<SealedAttribute>]
type MoonSharpModuleConstantAttribute =
    class
        inherit Attribute
    end

The MoonSharpModuleConstantAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | MoonSharpModuleConstantAttribute | Initializes a new instance of the MoonSharpModuleConstantAttribute class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the constant - if different from the name of the field itself
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


MoonSharpModuleConstantAttribute Constructor

MoonSharpModuleConstantAttribute Constructor
Initializes a new instance of the MoonSharpModuleConstantAttribute class

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MoonSharpModuleConstantAttribute()
Public Sub New
public:
MoonSharpModuleConstantAttribute()
new : unit -> MoonSharpModuleConstantAttribute
See Also

Reference

MoonSharpModuleConstantAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpModuleConstantAttribute Properties

MoonSharpModuleConstantAttribute Properties

The MoonSharpModuleConstantAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the constant - if different from the name of the field itself
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

MoonSharpModuleConstantAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpModuleConstantAttribute.Name Property

MoonSharpModuleConstantAttributeName Property
Gets or sets the name of the constant - if different from the name of the field itself

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

MoonSharpModuleConstantAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpModuleConstantAttribute Methods

MoonSharpModuleConstantAttribute Methods

The MoonSharpModuleConstantAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharpModuleConstantAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpModuleMethodAttribute Class

MoonSharpModuleMethodAttribute Class
In a module type, mark methods or fields with this attribute to have them exposed as module functions. Methods must have the signature "public static DynValue ...(ScriptExecutionContextCallbackArguments)". Fields must be static or const strings, with an anonymous Lua function inside. See MoonSharpModuleAttribute for more information about modules.
Inheritance Hierarchy
SystemObject
SystemAttribute
MoonSharp.InterpreterMoonSharpModuleMethodAttribute

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MoonSharpModuleMethodAttribute : Attribute
Public NotInheritable Class MoonSharpModuleMethodAttribute
    Inherits Attribute
public ref class MoonSharpModuleMethodAttribute sealed : public Attribute
[<SealedAttribute>]
type MoonSharpModuleMethodAttribute =
    class
        inherit Attribute
    end

The MoonSharpModuleMethodAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | MoonSharpModuleMethodAttribute | Initializes a new instance of the MoonSharpModuleMethodAttribute class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the function in the module (defaults to member name)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


MoonSharpModuleMethodAttribute Constructor

MoonSharpModuleMethodAttribute Constructor
Initializes a new instance of the MoonSharpModuleMethodAttribute class

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MoonSharpModuleMethodAttribute()
Public Sub New
public:
MoonSharpModuleMethodAttribute()
new : unit -> MoonSharpModuleMethodAttribute
See Also

Reference

MoonSharpModuleMethodAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpModuleMethodAttribute Properties

MoonSharpModuleMethodAttribute Properties

The MoonSharpModuleMethodAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the function in the module (defaults to member name)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

MoonSharpModuleMethodAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpModuleMethodAttribute.Name Property

MoonSharpModuleMethodAttributeName Property
Gets or sets the name of the function in the module (defaults to member name)

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

MoonSharpModuleMethodAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpModuleMethodAttribute Methods

MoonSharpModuleMethodAttribute Methods

The MoonSharpModuleMethodAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharpModuleMethodAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpPropertyAttribute Class

MoonSharpPropertyAttribute Class
Marks a property as a configruation property
Inheritance Hierarchy
SystemObject
SystemAttribute
MoonSharp.InterpreterMoonSharpPropertyAttribute

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MoonSharpPropertyAttribute : Attribute
Public NotInheritable Class MoonSharpPropertyAttribute
    Inherits Attribute
public ref class MoonSharpPropertyAttribute sealed : public Attribute
[<SealedAttribute>]
type MoonSharpPropertyAttribute =
    class
        inherit Attribute
    end

The MoonSharpPropertyAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | MoonSharpPropertyAttribute | Initializes a new instance of the MoonSharpPropertyAttribute class.
Public method | MoonSharpPropertyAttribute(String) | Initializes a new instance of the MoonSharpPropertyAttribute class.
Top
Properties
 | Name | Description
Public property | Name | The metamethod name (like '__div', '__ipairs', etc.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


MoonSharpPropertyAttribute Constructor

MoonSharpPropertyAttribute Constructor
Overload List
 | Name | Description
Public method | MoonSharpPropertyAttribute | Initializes a new instance of the MoonSharpPropertyAttribute class.
Public method | MoonSharpPropertyAttribute(String) | Initializes a new instance of the MoonSharpPropertyAttribute class.
Top
See Also

Reference

MoonSharpPropertyAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpPropertyAttribute Constructor

MoonSharpPropertyAttribute Constructor
Initializes a new instance of the MoonSharpPropertyAttribute class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MoonSharpPropertyAttribute()
Public Sub New
public:
MoonSharpPropertyAttribute()
new : unit -> MoonSharpPropertyAttribute
See Also

Reference

MoonSharpPropertyAttribute Class
MoonSharpPropertyAttribute Overload
MoonSharp.Interpreter Namespace


MoonSharpPropertyAttribute Constructor (String)

MoonSharpPropertyAttribute Constructor (String)
Initializes a new instance of the MoonSharpPropertyAttribute class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MoonSharpPropertyAttribute(
    string name
)
Public Sub New (
    name As String
)
public:
MoonSharpPropertyAttribute(
    String^ name
)
new :
        name : string -> MoonSharpPropertyAttribute

Parameters

name
Type: SystemString
The name for this property
See Also

Reference

MoonSharpPropertyAttribute Class
MoonSharpPropertyAttribute Overload
MoonSharp.Interpreter Namespace


MoonSharpPropertyAttribute Properties

MoonSharpPropertyAttribute Properties

The MoonSharpPropertyAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Name | The metamethod name (like '__div', '__ipairs', etc.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

MoonSharpPropertyAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpPropertyAttribute.Name Property

MoonSharpPropertyAttributeName Property
The metamethod name (like '__div', '__ipairs', etc.)

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

MoonSharpPropertyAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpPropertyAttribute Methods

MoonSharpPropertyAttribute Methods

The MoonSharpPropertyAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharpPropertyAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpUserDataAttribute Class

MoonSharpUserDataAttribute Class
Marks a type of automatic registration as userdata (which happens only if UserData.RegisterAssembly is called).
Inheritance Hierarchy
SystemObject
SystemAttribute
MoonSharp.InterpreterMoonSharpUserDataAttribute

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MoonSharpUserDataAttribute : Attribute
Public NotInheritable Class MoonSharpUserDataAttribute
    Inherits Attribute
public ref class MoonSharpUserDataAttribute sealed : public Attribute
[<SealedAttribute>]
type MoonSharpUserDataAttribute =
    class
        inherit Attribute
    end

The MoonSharpUserDataAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | MoonSharpUserDataAttribute | Initializes a new instance of the MoonSharpUserDataAttribute class.
Top
Properties
 | Name | Description
Public property | AccessMode | The interop access mode
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


MoonSharpUserDataAttribute Constructor

MoonSharpUserDataAttribute Constructor
Initializes a new instance of the MoonSharpUserDataAttribute class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MoonSharpUserDataAttribute()
Public Sub New
public:
MoonSharpUserDataAttribute()
new : unit -> MoonSharpUserDataAttribute
See Also

Reference

MoonSharpUserDataAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpUserDataAttribute Properties

MoonSharpUserDataAttribute Properties

The MoonSharpUserDataAttribute type exposes the following members.

Properties
 | Name | Description
Public property | AccessMode | The interop access mode
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

MoonSharpUserDataAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpUserDataAttribute.AccessMode Property

MoonSharpUserDataAttributeAccessMode Property
The interop access mode

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public InteropAccessMode AccessMode { get; set; }
Public Property AccessMode As InteropAccessMode
    Get
    Set
public:
property InteropAccessMode AccessMode {
    InteropAccessMode get ();
    void set (InteropAccessMode value);
}
member AccessMode : InteropAccessMode with get, set

Property Value

Type: InteropAccessMode
See Also

Reference

MoonSharpUserDataAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpUserDataAttribute Methods

MoonSharpUserDataAttribute Methods

The MoonSharpUserDataAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharpUserDataAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpUserDataMetamethodAttribute Class

MoonSharpUserDataMetamethodAttribute Class
Marks a method as the handler of metamethods of a userdata type
Inheritance Hierarchy
SystemObject
SystemAttribute
MoonSharp.InterpreterMoonSharpUserDataMetamethodAttribute

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MoonSharpUserDataMetamethodAttribute : Attribute
Public NotInheritable Class MoonSharpUserDataMetamethodAttribute
    Inherits Attribute
public ref class MoonSharpUserDataMetamethodAttribute sealed : public Attribute
[<SealedAttribute>]
type MoonSharpUserDataMetamethodAttribute =
    class
        inherit Attribute
    end

The MoonSharpUserDataMetamethodAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | MoonSharpUserDataMetamethodAttribute | Initializes a new instance of the MoonSharpUserDataMetamethodAttribute class.
Top
Properties
 | Name | Description
Public property | Name | The metamethod name (like '__div', '__ipairs', etc.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


MoonSharpUserDataMetamethodAttribute Constructor

MoonSharpUserDataMetamethodAttribute Constructor
Initializes a new instance of the MoonSharpUserDataMetamethodAttribute class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MoonSharpUserDataMetamethodAttribute(
    string name
)
Public Sub New (
    name As String
)
public:
MoonSharpUserDataMetamethodAttribute(
    String^ name
)
new :
        name : string -> MoonSharpUserDataMetamethodAttribute

Parameters

name
Type: SystemString
The metamethod name (like '__div', '__ipairs', etc.)
See Also

Reference

MoonSharpUserDataMetamethodAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpUserDataMetamethodAttribute Properties

MoonSharpUserDataMetamethodAttribute Properties

The MoonSharpUserDataMetamethodAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Name | The metamethod name (like '__div', '__ipairs', etc.)
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

MoonSharpUserDataMetamethodAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpUserDataMetamethodAttribute.Name Property

MoonSharpUserDataMetamethodAttributeName Property
The metamethod name (like '__div', '__ipairs', etc.)

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

MoonSharpUserDataMetamethodAttribute Class
MoonSharp.Interpreter Namespace


MoonSharpUserDataMetamethodAttribute Methods

MoonSharpUserDataMetamethodAttribute Methods

The MoonSharpUserDataMetamethodAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharpUserDataMetamethodAttribute Class
MoonSharp.Interpreter Namespace


RefIdObject Class

RefIdObject Class
A base class for many MoonSharp objects. Helds a ReferenceID property which gets a different value for every object instance, for debugging purposes. Note that the ID is not assigned in a thread safe manner for speed reason, so the IDs are guaranteed to be unique only if everything is running on one thread at a time.
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterRefIdObject
MoonSharp.InterpreterCallbackFunction
MoonSharp.InterpreterClosure
MoonSharp.InterpreterCoroutine
MoonSharp.InterpreterTable
MoonSharp.InterpreterUserData

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class RefIdObject
Public Class RefIdObject
public ref class RefIdObject
type RefIdObject =  class end

The RefIdObject type exposes the following members.

Constructors
 | Name | Description
Public method | RefIdObject | Initializes a new instance of the RefIdObject class
Top
Properties
 | Name | Description
Public property | ReferenceID | Gets the reference identifier.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormatTypeString | Formats a string with a type name and a ref-id
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


RefIdObject Constructor

RefIdObject Constructor
Initializes a new instance of the RefIdObject class

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public RefIdObject()
Public Sub New
public:
RefIdObject()
new : unit -> RefIdObject
See Also

Reference

RefIdObject Class
MoonSharp.Interpreter Namespace


RefIdObject Properties

RefIdObject Properties

The RefIdObject type exposes the following members.

Properties
 | Name | Description
Public property | ReferenceID | Gets the reference identifier.
Top
See Also

Reference

RefIdObject Class
MoonSharp.Interpreter Namespace


RefIdObject.ReferenceID Property

RefIdObjectReferenceID Property
Gets the reference identifier.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int ReferenceID { get; }
Public ReadOnly Property ReferenceID As Integer
    Get
public:
property int ReferenceID {
    int get ();
}
member ReferenceID : int with get

Property Value

Type: Int32
The reference identifier.
See Also

Reference

RefIdObject Class
MoonSharp.Interpreter Namespace


RefIdObject Methods

RefIdObject Methods

The RefIdObject type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormatTypeString | Formats a string with a type name and a ref-id
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RefIdObject Class
MoonSharp.Interpreter Namespace


RefIdObject.FormatTypeString Method

RefIdObjectFormatTypeString Method
Formats a string with a type name and a ref-id

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string FormatTypeString(
    string typeString
)
Public Function FormatTypeString (
    typeString As String
) As String
public:
String^ FormatTypeString(
    String^ typeString
)
member FormatTypeString :
        typeString : string -> string

Parameters

typeString
Type: SystemString
The type name.

Return Value

Type: String
See Also

Reference

RefIdObject Class
MoonSharp.Interpreter Namespace


Script Class

Script Class
This class implements a MoonSharp scripting session. Multiple Script objects can coexist in the same program but cannot share data among themselves unless some mechanism is put in place.
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterScript

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class Script : IScriptPrivateResource
Public Class Script
    Implements IScriptPrivateResource
public ref class Script : IScriptPrivateResource
type Script =
    class
        interface IScriptPrivateResource
    end

The Script type exposes the following members.

Constructors
 | Name | Description
Public method | Script | Initializes a new instance of the Script clas.s
Public method | Script(CoreModules) | Initializes a new instance of the Script class.
Top
Properties
 | Name | Description
Public property | DebuggerEnabled | Gets or sets a value indicating whether the debugger is enabled. Note that unless a debugger attached, this property returns a value which might not reflect the real status of the debugger. Use this property if you want to disable the debugger for some executions.
 | DefaultOptions | Gets or sets the script loader which will be used as the value of the ScriptLoader property for all newly created scripts.
 | GlobalOptions | Gets the global options, that is options which cannot be customized per-script.
Public property | Globals | Gets the default global table for this script. Unless a different table is intentionally passed (or setfenv has been used) execution uses this table.
Public property | Options | Gets access to the script options.
Public property | PerformanceStats | Gets access to performance statistics.
Public property | Registry | MoonSharp (like Lua itself) provides a registry, a predefined table that can be used by any CLR code to store whatever Lua values it needs to store. Any CLR code can store data into this table, but it should take care to choose keys that are different from those used by other libraries, to avoid collisions. Typically, you should use as key a string GUID, a string containing your library name, or a userdata with the address of a CLR object in your code.
Public property | SourceCodeCount | Gets the source code count.
Top
Methods
 | Name | Description
Public method | AttachDebugger | Attaches a debugger. This usually should be called by the debugger itself and not by user code.
Public method | Call(Object) | Calls the specified function.
Public method | Call(DynValue) | Calls the specified function.
Public method | Call(Object, Object) | Calls the specified function.
Public method | Call(DynValue, DynValue) | Calls the specified function.
Public method | Call(DynValue, Object) | Calls the specified function.
Public method | CreateConstantDynamicExpression | Creates a new dynamic expression which is actually quite static, returning always the same constant value.
Public method | CreateCoroutine(Object) | Creates a coroutine pointing at the specified function.
Public method | CreateCoroutine(DynValue) | Creates a coroutine pointing at the specified function.
Public method | CreateDynamicExpression | Creates a new dynamic expression.
Public method | DoFile | Loads and executes a file containing a Lua/MoonSharp script.
Public method | DoStream | Loads and executes a stream containing a Lua/MoonSharp script.
Public method | DoString | Loads and executes a string containing a Lua/MoonSharp script.
Public method | Dump | Dumps on the specified stream.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSourceCode | Gets the source code.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeMetatable | Gets a type metatable.
Public method | LoadFile | Loads a string containing a Lua/MoonSharp script.
Public method | LoadFunction | Loads a string containing a Lua/MoonSharp function.
Public method | LoadStream | Loads a Lua/MoonSharp script from a System.IO.Stream. NOTE: This will *NOT* close the stream!
Public method | LoadString | Loads a string containing a Lua/MoonSharp script.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RequireModule | Loads a module as per the "require" Lua function. http://www.lua.org/pil/8.1.html
 | RunFile | Runs the specified file with all possible defaults for quick experimenting.
 | RunString | Runs the specified code with all possible defaults for quick experimenting.
Public method | SetTypeMetatable | Sets a type metatable.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | WarmUp | Warms up the parser/lexer structures so that MoonSharp operations start faster.
Top
Fields
Name | Description
LUA_VERSION | The Lua version being supported
VERSION | The version of the MoonSharp engine
Top
Extension Methods
 | Name | Description
Public Extension Method | CallAsync(Object) | Overloaded. Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | CallAsync(DynValue) | Overloaded. Calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | CallAsync(Object, Object) | Overloaded. Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | CallAsync(DynValue, DynValue) | Overloaded. Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | CallAsync(DynValue, Object) | Overloaded. Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | CreateDynamicExpressionAsync | Asynchronously creates a new dynamic expression. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | DoFileAsync | Asynchronously loads and executes a file containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | DoStreamAsync | Asynchronously loads and executes a stream containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | DoStringAsync | Asynchronously loads and executes a string containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | DumpAsync | Asynchronously dumps a function on the specified stream. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | LoadFileAsync | Asynchronously loads a string containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | LoadFunctionAsync | Asynchronously loads a string containing a Lua/MoonSharp function. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | LoadStreamAsync | Asynchronously loads a Lua/MoonSharp script from a System.IO.Stream. NOTE: This will *NOT* close the stream! This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | LoadStringAsync | Asynchronously loads a string containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


Script Constructor

Script Constructor
Overload List
 | Name | Description
Public method | Script | Initializes a new instance of the Script clas.s
Public method | Script(CoreModules) | Initializes a new instance of the Script class.
Top
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script Constructor

Script Constructor
Initializes a new instance of the Script clas.s

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Script()
Public Sub New
public:
Script()
new : unit -> Script
See Also

Reference

Script Class
Script Overload
MoonSharp.Interpreter Namespace


Script Constructor (CoreModules)

Script Constructor (CoreModules)
Initializes a new instance of the Script class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Script(
    CoreModules coreModules
)
Public Sub New (
    coreModules As CoreModules
)
public:
Script(
    CoreModules coreModules
)
new :
        coreModules : CoreModules -> Script

Parameters

coreModules
Type: MoonSharp.InterpreterCoreModules
The core modules to be pre-registered in the default global table.
See Also

Reference

Script Class
Script Overload
MoonSharp.Interpreter Namespace


Script Properties

Script Properties

The Script type exposes the following members.

Properties
 | Name | Description
Public property | DebuggerEnabled | Gets or sets a value indicating whether the debugger is enabled. Note that unless a debugger attached, this property returns a value which might not reflect the real status of the debugger. Use this property if you want to disable the debugger for some executions.
 | DefaultOptions | Gets or sets the script loader which will be used as the value of the ScriptLoader property for all newly created scripts.
 | GlobalOptions | Gets the global options, that is options which cannot be customized per-script.
Public property | Globals | Gets the default global table for this script. Unless a different table is intentionally passed (or setfenv has been used) execution uses this table.
Public property | Options | Gets access to the script options.
Public property | PerformanceStats | Gets access to performance statistics.
Public property | Registry | MoonSharp (like Lua itself) provides a registry, a predefined table that can be used by any CLR code to store whatever Lua values it needs to store. Any CLR code can store data into this table, but it should take care to choose keys that are different from those used by other libraries, to avoid collisions. Typically, you should use as key a string GUID, a string containing your library name, or a userdata with the address of a CLR object in your code.
Public property | SourceCodeCount | Gets the source code count.
Top
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.DebuggerEnabled Property

ScriptDebuggerEnabled Property
Gets or sets a value indicating whether the debugger is enabled. Note that unless a debugger attached, this property returns a value which might not reflect the real status of the debugger. Use this property if you want to disable the debugger for some executions.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool DebuggerEnabled { get; set; }
Public Property DebuggerEnabled As Boolean
    Get
    Set
public:
property bool DebuggerEnabled {
    bool get ();
    void set (bool value);
}
member DebuggerEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.DefaultOptions Property

ScriptDefaultOptions Property
Gets or sets the script loader which will be used as the value of the ScriptLoader property for all newly created scripts.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptOptions DefaultOptions { get; }
Public Shared ReadOnly Property DefaultOptions As ScriptOptions
    Get
public:
static property ScriptOptions^ DefaultOptions {
    ScriptOptions^ get ();
}
static member DefaultOptions : ScriptOptions with get

Property Value

Type: ScriptOptions
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.GlobalOptions Property

ScriptGlobalOptions Property
Gets the global options, that is options which cannot be customized per-script.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptGlobalOptions GlobalOptions { get; }
Public Shared ReadOnly Property GlobalOptions As ScriptGlobalOptions
    Get
public:
static property ScriptGlobalOptions^ GlobalOptions {
    ScriptGlobalOptions^ get ();
}
static member GlobalOptions : ScriptGlobalOptions with get

Property Value

Type: ScriptGlobalOptions
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.Globals Property

ScriptGlobals Property
Gets the default global table for this script. Unless a different table is intentionally passed (or setfenv has been used) execution uses this table.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Table Globals { get; }
Public ReadOnly Property Globals As Table
    Get
public:
property Table^ Globals {
    Table^ get ();
}
member Globals : Table with get

Property Value

Type: Table
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.Options Property

ScriptOptions Property
Gets access to the script options.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptOptions Options { get; }
Public ReadOnly Property Options As ScriptOptions
    Get
public:
property ScriptOptions^ Options {
    ScriptOptions^ get ();
}
member Options : ScriptOptions with get

Property Value

Type: ScriptOptions
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.PerformanceStats Property

ScriptPerformanceStats Property
Gets access to performance statistics.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public PerformanceStatistics PerformanceStats { get; }
Public ReadOnly Property PerformanceStats As PerformanceStatistics
    Get
public:
property PerformanceStatistics^ PerformanceStats {
    PerformanceStatistics^ get ();
}
member PerformanceStats : PerformanceStatistics with get

Property Value

Type: PerformanceStatistics
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.Registry Property

ScriptRegistry Property
MoonSharp (like Lua itself) provides a registry, a predefined table that can be used by any CLR code to store whatever Lua values it needs to store. Any CLR code can store data into this table, but it should take care to choose keys that are different from those used by other libraries, to avoid collisions. Typically, you should use as key a string GUID, a string containing your library name, or a userdata with the address of a CLR object in your code.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Table Registry { get; }
Public ReadOnly Property Registry As Table
    Get
public:
property Table^ Registry {
    Table^ get ();
}
member Registry : Table with get

Property Value

Type: Table
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.SourceCodeCount Property

ScriptSourceCodeCount Property
Gets the source code count.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int SourceCodeCount { get; }
Public ReadOnly Property SourceCodeCount As Integer
    Get
public:
property int SourceCodeCount {
    int get ();
}
member SourceCodeCount : int with get

Property Value

Type: Int32
The source code count.
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script Methods

Script Methods

The Script type exposes the following members.

Methods
 | Name | Description
Public method | AttachDebugger | Attaches a debugger. This usually should be called by the debugger itself and not by user code.
Public method | Call(Object) | Calls the specified function.
Public method | Call(DynValue) | Calls the specified function.
Public method | Call(Object, Object) | Calls the specified function.
Public method | Call(DynValue, DynValue) | Calls the specified function.
Public method | Call(DynValue, Object) | Calls the specified function.
Public method | CreateConstantDynamicExpression | Creates a new dynamic expression which is actually quite static, returning always the same constant value.
Public method | CreateCoroutine(Object) | Creates a coroutine pointing at the specified function.
Public method | CreateCoroutine(DynValue) | Creates a coroutine pointing at the specified function.
Public method | CreateDynamicExpression | Creates a new dynamic expression.
Public method | DoFile | Loads and executes a file containing a Lua/MoonSharp script.
Public method | DoStream | Loads and executes a stream containing a Lua/MoonSharp script.
Public method | DoString | Loads and executes a string containing a Lua/MoonSharp script.
Public method | Dump | Dumps on the specified stream.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetSourceCode | Gets the source code.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeMetatable | Gets a type metatable.
Public method | LoadFile | Loads a string containing a Lua/MoonSharp script.
Public method | LoadFunction | Loads a string containing a Lua/MoonSharp function.
Public method | LoadStream | Loads a Lua/MoonSharp script from a System.IO.Stream. NOTE: This will *NOT* close the stream!
Public method | LoadString | Loads a string containing a Lua/MoonSharp script.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RequireModule | Loads a module as per the "require" Lua function. http://www.lua.org/pil/8.1.html
 | RunFile | Runs the specified file with all possible defaults for quick experimenting.
 | RunString | Runs the specified code with all possible defaults for quick experimenting.
Public method | SetTypeMetatable | Sets a type metatable.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | WarmUp | Warms up the parser/lexer structures so that MoonSharp operations start faster.
Top
Extension Methods
 | Name | Description
Public Extension Method | CallAsync(Object) | Overloaded. Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | CallAsync(DynValue) | Overloaded. Calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | CallAsync(Object, Object) | Overloaded. Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | CallAsync(DynValue, DynValue) | Overloaded. Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | CallAsync(DynValue, Object) | Overloaded. Asynchronously calls the specified function. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | CreateDynamicExpressionAsync | Asynchronously creates a new dynamic expression. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | DoFileAsync | Asynchronously loads and executes a file containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | DoStreamAsync | Asynchronously loads and executes a stream containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | DoStringAsync | Asynchronously loads and executes a string containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | DumpAsync | Asynchronously dumps a function on the specified stream. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | LoadFileAsync | Asynchronously loads a string containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | LoadFunctionAsync | Asynchronously loads a string containing a Lua/MoonSharp function. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | LoadStreamAsync | Asynchronously loads a Lua/MoonSharp script from a System.IO.Stream. NOTE: This will *NOT* close the stream! This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Public Extension Method | LoadStringAsync | Asynchronously loads a string containing a Lua/MoonSharp script. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Top
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.AttachDebugger Method

ScriptAttachDebugger Method
Attaches a debugger. This usually should be called by the debugger itself and not by user code.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void AttachDebugger(
    IDebugger debugger
)
Public Sub AttachDebugger (
    debugger As IDebugger
)
public:
void AttachDebugger(
    IDebugger^ debugger
)
member AttachDebugger :
        debugger : IDebugger -> unit

Parameters

debugger
Type: MoonSharp.Interpreter.DebuggingIDebugger
The debugger object.
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.Call Method

ScriptCall Method
Overload List
 | Name | Description
Public method | Call(Object) | Calls the specified function.
Public method | Call(DynValue) | Calls the specified function.
Public method | Call(Object, Object) | Calls the specified function.
Public method | Call(DynValue, DynValue) | Calls the specified function.
Public method | Call(DynValue, Object) | Calls the specified function.
Top
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.Call Method (Object)

ScriptCall Method (Object)
Calls the specified function.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Call(
    Object function
)
Public Function Call (
    function As Object
) As DynValue
public:
DynValue^ Call(
    Object^ function
)
member Call :
        function : Object -> DynValue

Parameters

function
Type: SystemObject
The Lua/MoonSharp function to be called

Return Value

Type: DynValue
Exceptions
Exception | Condition
ArgumentException | Thrown if function is not of DataType.Function
See Also

Reference

Script Class
Call Overload
MoonSharp.Interpreter Namespace


Script.Call Method (DynValue)

ScriptCall Method (DynValue)
Calls the specified function.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Call(
    DynValue function
)
Public Function Call (
    function As DynValue
) As DynValue
public:
DynValue^ Call(
    DynValue^ function
)
member Call :
        function : DynValue -> DynValue

Parameters

function
Type: MoonSharp.InterpreterDynValue
The Lua/MoonSharp function to be called

Return Value

Type: DynValue
The return value(s) of the function call.
Exceptions
Exception | Condition
ArgumentException | Thrown if function is not of DataType.Function
See Also

Reference

Script Class
Call Overload
MoonSharp.Interpreter Namespace


Script.Call Method (Object, Object[])

ScriptCall Method (Object, Object)
Calls the specified function.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Call(
    Object function,
    params Object[] args
)
Public Function Call (
    function As Object,
    ParamArray args As Object()
) As DynValue
public:
DynValue^ Call(
    Object^ function,
    ... array<Object^>^ args
)
member Call :
        function : Object *
        args : Object[] -> DynValue

Parameters

function
Type: SystemObject
The Lua/MoonSharp function to be called
args
Type: SystemObject
The arguments to pass to the function.

Return Value

Type: DynValue
Exceptions
Exception | Condition
ArgumentException | Thrown if function is not of DataType.Function
See Also

Reference

Script Class
Call Overload
MoonSharp.Interpreter Namespace


Script.Call Method (DynValue, DynValue[])

ScriptCall Method (DynValue, DynValue)
Calls the specified function.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Call(
    DynValue function,
    params DynValue[] args
)
Public Function Call (
    function As DynValue,
    ParamArray args As DynValue()
) As DynValue
public:
DynValue^ Call(
    DynValue^ function,
    ... array<DynValue^>^ args
)
member Call :
        function : DynValue *
        args : DynValue[] -> DynValue

Parameters

function
Type: MoonSharp.InterpreterDynValue
The Lua/MoonSharp function to be called
args
Type: MoonSharp.InterpreterDynValue
The arguments to pass to the function.

Return Value

Type: DynValue
The return value(s) of the function call.
Exceptions
Exception | Condition
ArgumentException | Thrown if function is not of DataType.Function
See Also

Reference

Script Class
Call Overload
MoonSharp.Interpreter Namespace


Script.Call Method (DynValue, Object[])

ScriptCall Method (DynValue, Object)
Calls the specified function.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Call(
    DynValue function,
    params Object[] args
)
Public Function Call (
    function As DynValue,
    ParamArray args As Object()
) As DynValue
public:
DynValue^ Call(
    DynValue^ function,
    ... array<Object^>^ args
)
member Call :
        function : DynValue *
        args : Object[] -> DynValue

Parameters

function
Type: MoonSharp.InterpreterDynValue
The Lua/MoonSharp function to be called
args
Type: SystemObject
The arguments to pass to the function.

Return Value

Type: DynValue
The return value(s) of the function call.
Exceptions
Exception | Condition
ArgumentException | Thrown if function is not of DataType.Function
See Also

Reference

Script Class
Call Overload
MoonSharp.Interpreter Namespace


Script.CreateConstantDynamicExpression Method

ScriptCreateConstantDynamicExpression Method
Creates a new dynamic expression which is actually quite static, returning always the same constant value.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynamicExpression CreateConstantDynamicExpression(
    string code,
    DynValue constant
)
Public Function CreateConstantDynamicExpression (
    code As String,
    constant As DynValue
) As DynamicExpression
public:
DynamicExpression^ CreateConstantDynamicExpression(
    String^ code,
    DynValue^ constant
)
member CreateConstantDynamicExpression :
        code : string *
        constant : DynValue -> DynamicExpression

Parameters

code
Type: SystemString
The code of the not-so-dynamic expression.
constant
Type: MoonSharp.InterpreterDynValue
The constant to return.

Return Value

Type: DynamicExpression
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.CreateCoroutine Method

ScriptCreateCoroutine Method
Overload List
 | Name | Description
Public method | CreateCoroutine(Object) | Creates a coroutine pointing at the specified function.
Public method | CreateCoroutine(DynValue) | Creates a coroutine pointing at the specified function.
Top
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.CreateCoroutine Method (Object)

ScriptCreateCoroutine Method (Object)
Creates a coroutine pointing at the specified function.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue CreateCoroutine(
    Object function
)
Public Function CreateCoroutine (
    function As Object
) As DynValue
public:
DynValue^ CreateCoroutine(
    Object^ function
)
member CreateCoroutine :
        function : Object -> DynValue

Parameters

function
Type: SystemObject
The function.

Return Value

Type: DynValue
The coroutine handle.
Exceptions
Exception | Condition
ArgumentException | Thrown if function is not of DataType.Function or DataType.ClrFunction
See Also

Reference

Script Class
CreateCoroutine Overload
MoonSharp.Interpreter Namespace


Script.CreateCoroutine Method (DynValue)

ScriptCreateCoroutine Method (DynValue)
Creates a coroutine pointing at the specified function.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue CreateCoroutine(
    DynValue function
)
Public Function CreateCoroutine (
    function As DynValue
) As DynValue
public:
DynValue^ CreateCoroutine(
    DynValue^ function
)
member CreateCoroutine :
        function : DynValue -> DynValue

Parameters

function
Type: MoonSharp.InterpreterDynValue
The function.

Return Value

Type: DynValue
The coroutine handle.
Exceptions
Exception | Condition
ArgumentException | Thrown if function is not of DataType.Function or DataType.ClrFunction
See Also

Reference

Script Class
CreateCoroutine Overload
MoonSharp.Interpreter Namespace


Script.CreateDynamicExpression Method

ScriptCreateDynamicExpression Method
Creates a new dynamic expression.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynamicExpression CreateDynamicExpression(
    string code
)
Public Function CreateDynamicExpression (
    code As String
) As DynamicExpression
public:
DynamicExpression^ CreateDynamicExpression(
    String^ code
)
member CreateDynamicExpression :
        code : string -> DynamicExpression

Parameters

code
Type: SystemString
The code of the expression.

Return Value

Type: DynamicExpression
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.DoFile Method

ScriptDoFile Method
Loads and executes a file containing a Lua/MoonSharp script.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue DoFile(
    string filename,
    Table globalContext = null,
    string codeFriendlyName = null
)
Public Function DoFile (
    filename As String,
    Optional globalContext As Table = Nothing,
    Optional codeFriendlyName As String = Nothing
) As DynValue
public:
DynValue^ DoFile(
    String^ filename,
    Table^ globalContext = nullptr,
    String^ codeFriendlyName = nullptr
)
member DoFile :
        filename : string *
        ?globalContext : Table *
        ?codeFriendlyName : string
(* Defaults:
        let _globalContext = defaultArg globalContext null
        let _codeFriendlyName = defaultArg codeFriendlyName null
*)
-> DynValue

Parameters

filename
Type: SystemString
The filename.
globalContext (Optional)
Type: MoonSharp.InterpreterTable
The global context.
codeFriendlyName (Optional)
Type: SystemString
Name of the code - used to report errors, etc. Also used by debuggers to locate the original source file.

Return Value

Type: DynValue
A DynValue containing the result of the processing of the loaded chunk.
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.DoStream Method

ScriptDoStream Method
Loads and executes a stream containing a Lua/MoonSharp script.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue DoStream(
    Stream stream,
    Table globalContext = null,
    string codeFriendlyName = null
)
Public Function DoStream (
    stream As Stream,
    Optional globalContext As Table = Nothing,
    Optional codeFriendlyName As String = Nothing
) As DynValue
public:
DynValue^ DoStream(
    Stream^ stream,
    Table^ globalContext = nullptr,
    String^ codeFriendlyName = nullptr
)
member DoStream :
        stream : Stream *
        ?globalContext : Table *
        ?codeFriendlyName : string
(* Defaults:
        let _globalContext = defaultArg globalContext null
        let _codeFriendlyName = defaultArg codeFriendlyName null
*)
-> DynValue

Parameters

stream
Type: System.IOStream
The stream.
globalContext (Optional)
Type: MoonSharp.InterpreterTable
The global context.
codeFriendlyName (Optional)
Type: SystemString
Name of the code - used to report errors, etc. Also used by debuggers to locate the original source file.

Return Value

Type: DynValue
A DynValue containing the result of the processing of the loaded chunk.
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.DoString Method

ScriptDoString Method
Loads and executes a string containing a Lua/MoonSharp script.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue DoString(
    string code,
    Table globalContext = null,
    string codeFriendlyName = null
)
Public Function DoString (
    code As String,
    Optional globalContext As Table = Nothing,
    Optional codeFriendlyName As String = Nothing
) As DynValue
public:
DynValue^ DoString(
    String^ code,
    Table^ globalContext = nullptr,
    String^ codeFriendlyName = nullptr
)
member DoString :
        code : string *
        ?globalContext : Table *
        ?codeFriendlyName : string
(* Defaults:
        let _globalContext = defaultArg globalContext null
        let _codeFriendlyName = defaultArg codeFriendlyName null
*)
-> DynValue

Parameters

code
Type: SystemString
The code.
globalContext (Optional)
Type: MoonSharp.InterpreterTable
The global context.
codeFriendlyName (Optional)
Type: SystemString
Name of the code - used to report errors, etc. Also used by debuggers to locate the original source file.

Return Value

Type: DynValue
A DynValue containing the result of the processing of the loaded chunk.
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.Dump Method

ScriptDump Method
Dumps on the specified stream.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void Dump(
    DynValue function,
    Stream stream
)
Public Sub Dump (
    function As DynValue,
    stream As Stream
)
public:
void Dump(
    DynValue^ function,
    Stream^ stream
)
member Dump :
        function : DynValue *
        stream : Stream -> unit

Parameters

function
Type: MoonSharp.InterpreterDynValue
The function.
stream
Type: System.IOStream
The stream.
Exceptions
Exception | Condition
ArgumentException | function arg is not a function! or stream is readonly! or function arg has upvalues other than _ENV
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.GetSourceCode Method

ScriptGetSourceCode Method
Gets the source code.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public SourceCode GetSourceCode(
    int sourceCodeID
)
Public Function GetSourceCode (
    sourceCodeID As Integer
) As SourceCode
public:
SourceCode^ GetSourceCode(
    int sourceCodeID
)
member GetSourceCode :
        sourceCodeID : int -> SourceCode

Parameters

sourceCodeID
Type: SystemInt32
The source code identifier.

Return Value

Type: SourceCode
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.GetTypeMetatable Method

ScriptGetTypeMetatable Method
Gets a type metatable.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Table GetTypeMetatable(
    DataType type
)
Public Function GetTypeMetatable (
    type As DataType
) As Table
public:
Table^ GetTypeMetatable(
    DataType type
)
member GetTypeMetatable :
        type : DataType -> Table

Parameters

type
Type: MoonSharp.InterpreterDataType
The type.

Return Value

Type: Table
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.LoadFile Method

ScriptLoadFile Method
Loads a string containing a Lua/MoonSharp script.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue LoadFile(
    string filename,
    Table globalContext = null,
    string friendlyFilename = null
)
Public Function LoadFile (
    filename As String,
    Optional globalContext As Table = Nothing,
    Optional friendlyFilename As String = Nothing
) As DynValue
public:
DynValue^ LoadFile(
    String^ filename,
    Table^ globalContext = nullptr,
    String^ friendlyFilename = nullptr
)
member LoadFile :
        filename : string *
        ?globalContext : Table *
        ?friendlyFilename : string
(* Defaults:
        let _globalContext = defaultArg globalContext null
        let _friendlyFilename = defaultArg friendlyFilename null
*)
-> DynValue

Parameters

filename
Type: SystemString
The code.
globalContext (Optional)
Type: MoonSharp.InterpreterTable
The global table to bind to this chunk.
friendlyFilename (Optional)
Type: SystemString
The filename to be used in error messages.

Return Value

Type: DynValue
A DynValue containing a function which will execute the loaded code.
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.LoadFunction Method

ScriptLoadFunction Method
Loads a string containing a Lua/MoonSharp function.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue LoadFunction(
    string code,
    Table globalTable = null,
    string funcFriendlyName = null
)
Public Function LoadFunction (
    code As String,
    Optional globalTable As Table = Nothing,
    Optional funcFriendlyName As String = Nothing
) As DynValue
public:
DynValue^ LoadFunction(
    String^ code,
    Table^ globalTable = nullptr,
    String^ funcFriendlyName = nullptr
)
member LoadFunction :
        code : string *
        ?globalTable : Table *
        ?funcFriendlyName : string
(* Defaults:
        let _globalTable = defaultArg globalTable null
        let _funcFriendlyName = defaultArg funcFriendlyName null
*)
-> DynValue

Parameters

code
Type: SystemString
The code.
globalTable (Optional)
Type: MoonSharp.InterpreterTable
The global table to bind to this chunk.
funcFriendlyName (Optional)
Type: SystemString
Name of the function used to report errors, etc.

Return Value

Type: DynValue
A DynValue containing a function which will execute the loaded code.
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.LoadStream Method

ScriptLoadStream Method
Loads a Lua/MoonSharp script from a System.IO.Stream. NOTE: This will *NOT* close the stream!

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue LoadStream(
    Stream stream,
    Table globalTable = null,
    string codeFriendlyName = null
)
Public Function LoadStream (
    stream As Stream,
    Optional globalTable As Table = Nothing,
    Optional codeFriendlyName As String = Nothing
) As DynValue
public:
DynValue^ LoadStream(
    Stream^ stream,
    Table^ globalTable = nullptr,
    String^ codeFriendlyName = nullptr
)
member LoadStream :
        stream : Stream *
        ?globalTable : Table *
        ?codeFriendlyName : string
(* Defaults:
        let _globalTable = defaultArg globalTable null
        let _codeFriendlyName = defaultArg codeFriendlyName null
*)
-> DynValue

Parameters

stream
Type: System.IOStream
The stream containing code.
globalTable (Optional)
Type: MoonSharp.InterpreterTable
The global table to bind to this chunk.
codeFriendlyName (Optional)
Type: SystemString
Name of the code - used to report errors, etc.

Return Value

Type: DynValue
A DynValue containing a function which will execute the loaded code.
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.LoadString Method

ScriptLoadString Method
Loads a string containing a Lua/MoonSharp script.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue LoadString(
    string code,
    Table globalTable = null,
    string codeFriendlyName = null
)
Public Function LoadString (
    code As String,
    Optional globalTable As Table = Nothing,
    Optional codeFriendlyName As String = Nothing
) As DynValue
public:
DynValue^ LoadString(
    String^ code,
    Table^ globalTable = nullptr,
    String^ codeFriendlyName = nullptr
)
member LoadString :
        code : string *
        ?globalTable : Table *
        ?codeFriendlyName : string
(* Defaults:
        let _globalTable = defaultArg globalTable null
        let _codeFriendlyName = defaultArg codeFriendlyName null
*)
-> DynValue

Parameters

code
Type: SystemString
The code.
globalTable (Optional)
Type: MoonSharp.InterpreterTable
The global table to bind to this chunk.
codeFriendlyName (Optional)
Type: SystemString
Name of the code - used to report errors, etc. Also used by debuggers to locate the original source file.

Return Value

Type: DynValue
A DynValue containing a function which will execute the loaded code.
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.RequireModule Method

ScriptRequireModule Method
Loads a module as per the "require" Lua function. http://www.lua.org/pil/8.1.html

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue RequireModule(
    string modname,
    Table globalContext = null
)
Public Function RequireModule (
    modname As String,
    Optional globalContext As Table = Nothing
) As DynValue
public:
DynValue^ RequireModule(
    String^ modname,
    Table^ globalContext = nullptr
)
member RequireModule :
        modname : string *
        ?globalContext : Table
(* Defaults:
        let _globalContext = defaultArg globalContext null
*)
-> DynValue

Parameters

modname
Type: SystemString
The module name
globalContext (Optional)
Type: MoonSharp.InterpreterTable
The global context.

Return Value

Type: DynValue
Exceptions
Exception | Condition
ScriptRuntimeException | Raised if module is not found
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.RunFile Method

ScriptRunFile Method
Runs the specified file with all possible defaults for quick experimenting.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue RunFile(
    string filename
)
Public Shared Function RunFile (
    filename As String
) As DynValue
public:
static DynValue^ RunFile(
    String^ filename
)
static member RunFile :
        filename : string -> DynValue

Parameters

filename
Type: SystemString
The filename.

Return Value

Type: DynValue
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.RunString Method

ScriptRunString Method
Runs the specified code with all possible defaults for quick experimenting.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue RunString(
    string code
)
Public Shared Function RunString (
    code As String
) As DynValue
public:
static DynValue^ RunString(
    String^ code
)
static member RunString :
        code : string -> DynValue

Parameters

code
Type: SystemString
The Lua/MoonSharp code.

Return Value

Type: DynValue
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.SetTypeMetatable Method

ScriptSetTypeMetatable Method
Sets a type metatable.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void SetTypeMetatable(
    DataType type,
    Table metatable
)
Public Sub SetTypeMetatable (
    type As DataType,
    metatable As Table
)
public:
void SetTypeMetatable(
    DataType type,
    Table^ metatable
)
member SetTypeMetatable :
        type : DataType *
        metatable : Table -> unit

Parameters

type
Type: MoonSharp.InterpreterDataType
The type. Must be Nil, Boolean, Number, String or Function
metatable
Type: MoonSharp.InterpreterTable
The metatable.
Exceptions
Exception | Condition
ArgumentException | Specified type not supported : + type.ToString()
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.WarmUp Method

ScriptWarmUp Method
Warms up the parser/lexer structures so that MoonSharp operations start faster.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static void WarmUp()
Public Shared Sub WarmUp
public:
static void WarmUp()
static member WarmUp : unit -> unit
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script Fields

Script Fields

The Script type exposes the following members.

Fields
Name | Description
LUA_VERSION | The Lua version being supported
VERSION | The version of the MoonSharp engine
Top
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.LUA_VERSION Field

ScriptLUA_VERSION Field
The Lua version being supported

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public const string LUA_VERSION = "5.2"
Public Const LUA_VERSION As String = "5.2"
public:
literal String^ LUA_VERSION = "5.2"
static val mutable LUA_VERSION: string

Field Value

Type: String
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


Script.VERSION Field

ScriptVERSION Field
The version of the MoonSharp engine

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public const string VERSION = "1.8.5.0"
Public Const VERSION As String = "1.8.5.0"
public:
literal String^ VERSION = "1.8.5.0"
static val mutable VERSION: string

Field Value

Type: String
See Also

Reference

Script Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext Class

ScriptExecutionContext Class
Class giving access to details of the environment where the script is executing
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterScriptExecutionContext

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptExecutionContext : IScriptPrivateResource
Public Class ScriptExecutionContext
    Implements IScriptPrivateResource
public ref class ScriptExecutionContext : IScriptPrivateResource
type ScriptExecutionContext =
    class
        interface IScriptPrivateResource
    end

The ScriptExecutionContext type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Gets or sets the additional data associated to this CLR function call.
Public property | CallingLocation | Gets the location of the code calling back
Public property | CurrentGlobalEnv | Gets the current global env, or null if not found.
Public property | IsDynamicExecution | Gets a value indicating whether this instance is running a dynamic execution. Under a dynamic execution, most methods of ScriptExecutionContext are not reliable as the processing engine of the script is not "really" running or is not available.
Public property | OwnerScript | Gets the script owning this resource.
Top
Methods
 | Name | Description
Public method | Call | Calls the specified function, supporting most cases. The called function must not yield.
Public method | EmulateClassicCall | Calls a callback function implemented in "classic way". Useful to port C code from Lua, or C# code from UniLua and KopiLua. Lua : http://www.lua.org/ UniLua : http://github.com/xebecnan/UniLua KopiLua : http://github.com/NLua/KopiLua
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateSymbol | Tries to get the reference of a symbol in the current execution state
Public method | EvaluateSymbolByName | Tries to get the value of a symbol in the current execution state
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindSymbolByName | Finds a symbol by name in the current execution state
Public method | GetBinaryMetamethod | Gets the metamethod to be used for a binary operation using op1 and op2.
Public method | GetCallingCoroutine | Gets the coroutine which is performing the call
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMetamethod | Gets the specified metamethod associated with the given value.
Public method | GetMetamethodTailCall | prepares a tail call request for the specified metamethod, or null if no metamethod is found.
Public method | GetMetatable | Gets the metatable associated with the given value.
Public method | GetScript | Gets the script object associated with this request
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PerformMessageDecorationBeforeUnwind | Performs a message decoration before unwinding after an error. To be used in the implementation of xpcall like functions.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


ScriptExecutionContext Properties

ScriptExecutionContext Properties

The ScriptExecutionContext type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalData | Gets or sets the additional data associated to this CLR function call.
Public property | CallingLocation | Gets the location of the code calling back
Public property | CurrentGlobalEnv | Gets the current global env, or null if not found.
Public property | IsDynamicExecution | Gets a value indicating whether this instance is running a dynamic execution. Under a dynamic execution, most methods of ScriptExecutionContext are not reliable as the processing engine of the script is not "really" running or is not available.
Public property | OwnerScript | Gets the script owning this resource.
Top
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext.AdditionalData Property

ScriptExecutionContextAdditionalData Property
Gets or sets the additional data associated to this CLR function call.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Object AdditionalData { get; set; }
Public Property AdditionalData As Object
    Get
    Set
public:
property Object^ AdditionalData {
    Object^ get ();
    void set (Object^ value);
}
member AdditionalData : Object with get, set

Property Value

Type: Object
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext.CallingLocation Property

ScriptExecutionContextCallingLocation Property
Gets the location of the code calling back

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public SourceRef CallingLocation { get; }
Public ReadOnly Property CallingLocation As SourceRef
    Get
public:
property SourceRef^ CallingLocation {
    SourceRef^ get ();
}
member CallingLocation : SourceRef with get

Property Value

Type: SourceRef
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext.CurrentGlobalEnv Property

ScriptExecutionContextCurrentGlobalEnv Property
Gets the current global env, or null if not found.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Table CurrentGlobalEnv { get; }
Public ReadOnly Property CurrentGlobalEnv As Table
    Get
public:
property Table^ CurrentGlobalEnv {
    Table^ get ();
}
member CurrentGlobalEnv : Table with get

Property Value

Type: Table
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext.IsDynamicExecution Property

ScriptExecutionContextIsDynamicExecution Property
Gets a value indicating whether this instance is running a dynamic execution. Under a dynamic execution, most methods of ScriptExecutionContext are not reliable as the processing engine of the script is not "really" running or is not available.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDynamicExecution { get; }
Public ReadOnly Property IsDynamicExecution As Boolean
    Get
public:
property bool IsDynamicExecution {
    bool get ();
}
member IsDynamicExecution : bool with get

Property Value

Type: Boolean
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext.OwnerScript Property

ScriptExecutionContextOwnerScript Property
Gets the script owning this resource.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Script OwnerScript { get; }
Public ReadOnly Property OwnerScript As Script
    Get
public:
virtual property Script^ OwnerScript {
    Script^ get () sealed;
}
abstract OwnerScript : Script with get
override OwnerScript : Script with get

Property Value

Type: Script
The script owning this resource.

Implements

IScriptPrivateResourceOwnerScript
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext Methods

ScriptExecutionContext Methods

The ScriptExecutionContext type exposes the following members.

Methods
 | Name | Description
Public method | Call | Calls the specified function, supporting most cases. The called function must not yield.
Public method | EmulateClassicCall | Calls a callback function implemented in "classic way". Useful to port C code from Lua, or C# code from UniLua and KopiLua. Lua : http://www.lua.org/ UniLua : http://github.com/xebecnan/UniLua KopiLua : http://github.com/NLua/KopiLua
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | EvaluateSymbol | Tries to get the reference of a symbol in the current execution state
Public method | EvaluateSymbolByName | Tries to get the value of a symbol in the current execution state
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindSymbolByName | Finds a symbol by name in the current execution state
Public method | GetBinaryMetamethod | Gets the metamethod to be used for a binary operation using op1 and op2.
Public method | GetCallingCoroutine | Gets the coroutine which is performing the call
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetMetamethod | Gets the specified metamethod associated with the given value.
Public method | GetMetamethodTailCall | prepares a tail call request for the specified metamethod, or null if no metamethod is found.
Public method | GetMetatable | Gets the metatable associated with the given value.
Public method | GetScript | Gets the script object associated with this request
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PerformMessageDecorationBeforeUnwind | Performs a message decoration before unwinding after an error. To be used in the implementation of xpcall like functions.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext.Call Method

ScriptExecutionContextCall Method
Calls the specified function, supporting most cases. The called function must not yield.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Call(
    DynValue func,
    params DynValue[] args
)
Public Function Call (
    func As DynValue,
    ParamArray args As DynValue()
) As DynValue
public:
DynValue^ Call(
    DynValue^ func,
    ... array<DynValue^>^ args
)
member Call :
        func : DynValue *
        args : DynValue[] -> DynValue

Parameters

func
Type: MoonSharp.InterpreterDynValue
The function; it must be a Function or ClrFunction or have a call metamethod defined.
args
Type: MoonSharp.InterpreterDynValue
The arguments.

Return Value

Type: DynValue
Exceptions
Exception | Condition
ScriptRuntimeException | If the function yields, returns a tail call request with continuations/handlers or, of course, if it encounters errors.
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext.EmulateClassicCall Method

ScriptExecutionContextEmulateClassicCall Method
Calls a callback function implemented in "classic way". Useful to port C code from Lua, or C# code from UniLua and KopiLua. Lua : http://www.lua.org/ UniLua : http://github.com/xebecnan/UniLua KopiLua : http://github.com/NLua/KopiLua

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue EmulateClassicCall(
    CallbackArguments args,
    string functionName,
    Func<LuaState, int> callback
)
Public Function EmulateClassicCall (
    args As CallbackArguments,
    functionName As String,
    callback As Func(Of LuaState, Integer)
) As DynValue
public:
DynValue^ EmulateClassicCall(
    CallbackArguments^ args,
    String^ functionName,
    Func<LuaState^, int>^ callback
)
member EmulateClassicCall :
        args : CallbackArguments *
        functionName : string *
        callback : Func<LuaState, int> -> DynValue

Parameters

args
Type: MoonSharp.InterpreterCallbackArguments
The arguments.
functionName
Type: SystemString
Name of the function - for error messages.
callback
Type: SystemFunc LuaState, Int32
The callback.

Return Value

Type: DynValue
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext.EvaluateSymbol Method

ScriptExecutionContextEvaluateSymbol Method
Tries to get the reference of a symbol in the current execution state

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue EvaluateSymbol(
    SymbolRef symref
)
Public Function EvaluateSymbol (
    symref As SymbolRef
) As DynValue
public:
DynValue^ EvaluateSymbol(
    SymbolRef^ symref
)
member EvaluateSymbol :
        symref : SymbolRef -> DynValue

Parameters

symref
Type: MoonSharp.InterpreterSymbolRef

[Missing <param name="symref"/> documentation for "M:MoonSharp.Interpreter.ScriptExecutionContext.EvaluateSymbol(MoonSharp.Interpreter.SymbolRef)"]

Return Value

Type: DynValue
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext.EvaluateSymbolByName Method

ScriptExecutionContextEvaluateSymbolByName Method
Tries to get the value of a symbol in the current execution state

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue EvaluateSymbolByName(
    string symbol
)
Public Function EvaluateSymbolByName (
    symbol As String
) As DynValue
public:
DynValue^ EvaluateSymbolByName(
    String^ symbol
)
member EvaluateSymbolByName :
        symbol : string -> DynValue

Parameters

symbol
Type: SystemString

[Missing <param name="symbol"/> documentation for "M:MoonSharp.Interpreter.ScriptExecutionContext.EvaluateSymbolByName(System.String)"]

Return Value

Type: DynValue
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext.FindSymbolByName Method

ScriptExecutionContextFindSymbolByName Method
Finds a symbol by name in the current execution state

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public SymbolRef FindSymbolByName(
    string symbol
)
Public Function FindSymbolByName (
    symbol As String
) As SymbolRef
public:
SymbolRef^ FindSymbolByName(
    String^ symbol
)
member FindSymbolByName :
        symbol : string -> SymbolRef

Parameters

symbol
Type: SystemString

[Missing <param name="symbol"/> documentation for "M:MoonSharp.Interpreter.ScriptExecutionContext.FindSymbolByName(System.String)"]

Return Value

Type: SymbolRef
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext.GetBinaryMetamethod Method

ScriptExecutionContextGetBinaryMetamethod Method
Gets the metamethod to be used for a binary operation using op1 and op2.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue GetBinaryMetamethod(
    DynValue op1,
    DynValue op2,
    string eventName
)
Public Function GetBinaryMetamethod (
    op1 As DynValue,
    op2 As DynValue,
    eventName As String
) As DynValue
public:
DynValue^ GetBinaryMetamethod(
    DynValue^ op1,
    DynValue^ op2,
    String^ eventName
)
member GetBinaryMetamethod :
        op1 : DynValue *
        op2 : DynValue *
        eventName : string -> DynValue

Parameters

op1
Type: MoonSharp.InterpreterDynValue

[Missing <param name="op1"/> documentation for "M:MoonSharp.Interpreter.ScriptExecutionContext.GetBinaryMetamethod(MoonSharp.Interpreter.DynValue,MoonSharp.Interpreter.DynValue,System.String)"]

op2
Type: MoonSharp.InterpreterDynValue

[Missing <param name="op2"/> documentation for "M:MoonSharp.Interpreter.ScriptExecutionContext.GetBinaryMetamethod(MoonSharp.Interpreter.DynValue,MoonSharp.Interpreter.DynValue,System.String)"]

eventName
Type: SystemString

[Missing <param name="eventName"/> documentation for "M:MoonSharp.Interpreter.ScriptExecutionContext.GetBinaryMetamethod(MoonSharp.Interpreter.DynValue,MoonSharp.Interpreter.DynValue,System.String)"]

Return Value

Type: DynValue
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext.GetCallingCoroutine Method

ScriptExecutionContextGetCallingCoroutine Method
Gets the coroutine which is performing the call

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Coroutine GetCallingCoroutine()
Public Function GetCallingCoroutine As Coroutine
public:
Coroutine^ GetCallingCoroutine()
member GetCallingCoroutine : unit -> Coroutine

Return Value

Type: Coroutine
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext.GetMetamethod Method

ScriptExecutionContextGetMetamethod Method
Gets the specified metamethod associated with the given value.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue GetMetamethod(
    DynValue value,
    string metamethod
)
Public Function GetMetamethod (
    value As DynValue,
    metamethod As String
) As DynValue
public:
DynValue^ GetMetamethod(
    DynValue^ value,
    String^ metamethod
)
member GetMetamethod :
        value : DynValue *
        metamethod : string -> DynValue

Parameters

value
Type: MoonSharp.InterpreterDynValue
The value.
metamethod
Type: SystemString
The metamethod name.

Return Value

Type: DynValue
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext.GetMetamethodTailCall Method

ScriptExecutionContextGetMetamethodTailCall Method
prepares a tail call request for the specified metamethod, or null if no metamethod is found.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue GetMetamethodTailCall(
    DynValue value,
    string metamethod,
    params DynValue[] args
)
Public Function GetMetamethodTailCall (
    value As DynValue,
    metamethod As String,
    ParamArray args As DynValue()
) As DynValue
public:
DynValue^ GetMetamethodTailCall(
    DynValue^ value,
    String^ metamethod,
    ... array<DynValue^>^ args
)
member GetMetamethodTailCall :
        value : DynValue *
        metamethod : string *
        args : DynValue[] -> DynValue

Parameters

value
Type: MoonSharp.InterpreterDynValue

[Missing <param name="value"/> documentation for "M:MoonSharp.Interpreter.ScriptExecutionContext.GetMetamethodTailCall(MoonSharp.Interpreter.DynValue,System.String,MoonSharp.Interpreter.DynValue[])"]

metamethod
Type: SystemString

[Missing <param name="metamethod"/> documentation for "M:MoonSharp.Interpreter.ScriptExecutionContext.GetMetamethodTailCall(MoonSharp.Interpreter.DynValue,System.String,MoonSharp.Interpreter.DynValue[])"]

args
Type: MoonSharp.InterpreterDynValue

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.ScriptExecutionContext.GetMetamethodTailCall(MoonSharp.Interpreter.DynValue,System.String,MoonSharp.Interpreter.DynValue[])"]

Return Value

Type: DynValue
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext.GetMetatable Method

ScriptExecutionContextGetMetatable Method
Gets the metatable associated with the given value.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Table GetMetatable(
    DynValue value
)
Public Function GetMetatable (
    value As DynValue
) As Table
public:
Table^ GetMetatable(
    DynValue^ value
)
member GetMetatable :
        value : DynValue -> Table

Parameters

value
Type: MoonSharp.InterpreterDynValue
The value.

Return Value

Type: Table
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext.GetScript Method

ScriptExecutionContextGetScript Method
Gets the script object associated with this request

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Script GetScript()
Public Function GetScript As Script
public:
Script^ GetScript()
member GetScript : unit -> Script

Return Value

Type: Script
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptExecutionContext.PerformMessageDecorationBeforeUnwind Method

ScriptExecutionContextPerformMessageDecorationBeforeUnwind Method
Performs a message decoration before unwinding after an error. To be used in the implementation of xpcall like functions.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void PerformMessageDecorationBeforeUnwind(
    DynValue messageHandler,
    ScriptRuntimeException exception
)
Public Sub PerformMessageDecorationBeforeUnwind (
    messageHandler As DynValue,
    exception As ScriptRuntimeException
)
public:
void PerformMessageDecorationBeforeUnwind(
    DynValue^ messageHandler,
    ScriptRuntimeException^ exception
)
member PerformMessageDecorationBeforeUnwind :
        messageHandler : DynValue *
        exception : ScriptRuntimeException -> unit

Parameters

messageHandler
Type: MoonSharp.InterpreterDynValue
The message handler.
exception
Type: MoonSharp.InterpreterScriptRuntimeException
The exception.
See Also

Reference

ScriptExecutionContext Class
MoonSharp.Interpreter Namespace


ScriptFunctionDelegate Delegate

ScriptFunctionDelegate Delegate
A Delegate type which can wrap a script function

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public delegate Object ScriptFunctionDelegate(
    params Object[] args
)
Public Delegate Function ScriptFunctionDelegate (
    ParamArray args As Object()
) As Object
public delegate Object^ ScriptFunctionDelegate(
    ... array<Object^>^ args
)
type ScriptFunctionDelegate =
    delegate of
        args : Object[] -> Object

Parameters

args
Type: SystemObject
The arguments.

Return Value

Type: Object
The return value of the script function
See Also

Reference

MoonSharp.Interpreter Namespace


ScriptFunctionDelegate(T) Delegate

ScriptFunctionDelegateT Delegate
A Delegate type which can wrap a script function with a generic typed return value

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public delegate T ScriptFunctionDelegate<T>(
    params Object[] args
)

Public Delegate Function ScriptFunctionDelegate(Of T) (
    ParamArray args As Object()
) As T
generic<typename T>
public delegate T ScriptFunctionDelegate(
    ... array<Object^>^ args
)
type ScriptFunctionDelegate =
    delegate of
        args : Object[] -> 'T

Parameters

args
Type: SystemObject
The arguments.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:MoonSharp.Interpreter.ScriptFunctionDelegate`1"]

Return Value

Type: T
The return value of the script function
See Also

Reference

MoonSharp.Interpreter Namespace


ScriptGlobalOptions Class

ScriptGlobalOptions Class
Class containing script global options, that is options which cannot be customized per-script. GlobalOptions
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterScriptGlobalOptions

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptGlobalOptions
Public Class ScriptGlobalOptions
public ref class ScriptGlobalOptions
type ScriptGlobalOptions =  class end

The ScriptGlobalOptions type exposes the following members.

Properties
 | Name | Description
Public property | CustomConverters | Gets or sets the custom converters.
Public property | Platform | Gets or sets the platform abstraction to use.
Public property | RethrowExceptionNested | Gets or sets a value indicating whether interpreter exceptions should be re-thrown as nested exceptions.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


ScriptGlobalOptions Properties

ScriptGlobalOptions Properties

The ScriptGlobalOptions type exposes the following members.

Properties
 | Name | Description
Public property | CustomConverters | Gets or sets the custom converters.
Public property | Platform | Gets or sets the platform abstraction to use.
Public property | RethrowExceptionNested | Gets or sets a value indicating whether interpreter exceptions should be re-thrown as nested exceptions.
Top
See Also

Reference

ScriptGlobalOptions Class
MoonSharp.Interpreter Namespace


ScriptGlobalOptions.CustomConverters Property

ScriptGlobalOptionsCustomConverters Property
Gets or sets the custom converters.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CustomConvertersCollection CustomConverters { get; set; }
Public Property CustomConverters As CustomConvertersCollection
    Get
    Set
public:
property CustomConvertersCollection^ CustomConverters {
    CustomConvertersCollection^ get ();
    void set (CustomConvertersCollection^ value);
}
member CustomConverters : CustomConvertersCollection with get, set

Property Value

Type: CustomConvertersCollection
See Also

Reference

ScriptGlobalOptions Class
MoonSharp.Interpreter Namespace


ScriptGlobalOptions.Platform Property

ScriptGlobalOptionsPlatform Property
Gets or sets the platform abstraction to use.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IPlatformAccessor Platform { get; set; }
Public Property Platform As IPlatformAccessor
    Get
    Set
public:
property IPlatformAccessor^ Platform {
    IPlatformAccessor^ get ();
    void set (IPlatformAccessor^ value);
}
member Platform : IPlatformAccessor with get, set

Property Value

Type: IPlatformAccessor
The current platform abstraction.
See Also

Reference

ScriptGlobalOptions Class
MoonSharp.Interpreter Namespace


ScriptGlobalOptions.RethrowExceptionNested Property

ScriptGlobalOptionsRethrowExceptionNested Property
Gets or sets a value indicating whether interpreter exceptions should be re-thrown as nested exceptions.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool RethrowExceptionNested { get; set; }
Public Property RethrowExceptionNested As Boolean
    Get
    Set
public:
property bool RethrowExceptionNested {
    bool get ();
    void set (bool value);
}
member RethrowExceptionNested : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ScriptGlobalOptions Class
MoonSharp.Interpreter Namespace


ScriptGlobalOptions Methods

ScriptGlobalOptions Methods

The ScriptGlobalOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptGlobalOptions Class
MoonSharp.Interpreter Namespace


ScriptOptions Class

ScriptOptions Class
This class contains options to customize behaviour of Script objects.
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterScriptOptions

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class ScriptOptions
Public Class ScriptOptions
public ref class ScriptOptions
type ScriptOptions =  class end

The ScriptOptions type exposes the following members.

Properties
 | Name | Description
Public property | CheckThreadAccess | Gets or sets a value indicating whether the thread check is enabled. A "lazy" thread check is performed everytime execution is entered to ensure that no two threads calls MoonSharp execution concurrently. However 1) the check is performed best effort (thus, it might not detect all issues) and 2) it might trigger in very odd legal situations (like, switching threads inside a CLR-callback without actually having concurrency. Disable this option if the thread check is giving problems in your scenario, but please check that you are not calling MoonSharp execution concurrently as it is not supported.
Public property | ColonOperatorClrCallbackBehaviour | Gets or sets a value which dictates the behaviour of the colon (':') operator in callbacks to CLR code.
Public property | DebugInput | Gets or sets the debug input handler (takes a prompt as an input, for interactive interpreters, like debug.debug).
Public property | DebugPrint | Gets or sets the debug print handler
Public property | ScriptLoader | Gets or sets the current script-loader.
Public property | Stderr | Gets or sets the stream used as stderr. If null, a default stream is used.
Public property | Stdin | Gets or sets the stream used as stdin. If null, a default stream is used.
Public property | Stdout | Gets or sets the stream used as stdout. If null, a default stream is used.
Public property | TailCallOptimizationThreshold | Gets or sets the stack depth threshold at which MoonSharp starts doing tail call optimizations. TCOs can provide the little benefit of avoiding stack overflows in corner case scenarios, at the expense of losing debug information and error stack traces in all other, more common scenarios. MoonSharp choice is to start performing TCOs only after a certain threshold of stack usage is reached - by default half the current stack depth (128K entries), thus 64K entries, on either the internal stacks. Set this to int.MaxValue to disable TCOs entirely, or to 0 to always have TCOs enabled.
Public property | UseLuaErrorLocations | Gets or sets a value indicating whether error messages will use Lua error locations instead of MoonSharp improved ones. Use this for compatibility with legacy Lua code which parses error messages.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


ScriptOptions Properties

ScriptOptions Properties

The ScriptOptions type exposes the following members.

Properties
 | Name | Description
Public property | CheckThreadAccess | Gets or sets a value indicating whether the thread check is enabled. A "lazy" thread check is performed everytime execution is entered to ensure that no two threads calls MoonSharp execution concurrently. However 1) the check is performed best effort (thus, it might not detect all issues) and 2) it might trigger in very odd legal situations (like, switching threads inside a CLR-callback without actually having concurrency. Disable this option if the thread check is giving problems in your scenario, but please check that you are not calling MoonSharp execution concurrently as it is not supported.
Public property | ColonOperatorClrCallbackBehaviour | Gets or sets a value which dictates the behaviour of the colon (':') operator in callbacks to CLR code.
Public property | DebugInput | Gets or sets the debug input handler (takes a prompt as an input, for interactive interpreters, like debug.debug).
Public property | DebugPrint | Gets or sets the debug print handler
Public property | ScriptLoader | Gets or sets the current script-loader.
Public property | Stderr | Gets or sets the stream used as stderr. If null, a default stream is used.
Public property | Stdin | Gets or sets the stream used as stdin. If null, a default stream is used.
Public property | Stdout | Gets or sets the stream used as stdout. If null, a default stream is used.
Public property | TailCallOptimizationThreshold | Gets or sets the stack depth threshold at which MoonSharp starts doing tail call optimizations. TCOs can provide the little benefit of avoiding stack overflows in corner case scenarios, at the expense of losing debug information and error stack traces in all other, more common scenarios. MoonSharp choice is to start performing TCOs only after a certain threshold of stack usage is reached - by default half the current stack depth (128K entries), thus 64K entries, on either the internal stacks. Set this to int.MaxValue to disable TCOs entirely, or to 0 to always have TCOs enabled.
Public property | UseLuaErrorLocations | Gets or sets a value indicating whether error messages will use Lua error locations instead of MoonSharp improved ones. Use this for compatibility with legacy Lua code which parses error messages.
Top
See Also

Reference

ScriptOptions Class
MoonSharp.Interpreter Namespace


ScriptOptions.CheckThreadAccess Property

ScriptOptionsCheckThreadAccess Property
Gets or sets a value indicating whether the thread check is enabled. A "lazy" thread check is performed everytime execution is entered to ensure that no two threads calls MoonSharp execution concurrently. However 1) the check is performed best effort (thus, it might not detect all issues) and 2) it might trigger in very odd legal situations (like, switching threads inside a CLR-callback without actually having concurrency. Disable this option if the thread check is giving problems in your scenario, but please check that you are not calling MoonSharp execution concurrently as it is not supported.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool CheckThreadAccess { get; set; }
Public Property CheckThreadAccess As Boolean
    Get
    Set
public:
property bool CheckThreadAccess {
    bool get ();
    void set (bool value);
}
member CheckThreadAccess : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ScriptOptions Class
MoonSharp.Interpreter Namespace


ScriptOptions.ColonOperatorClrCallbackBehaviour Property

ScriptOptionsColonOperatorClrCallbackBehaviour Property
Gets or sets a value which dictates the behaviour of the colon (':') operator in callbacks to CLR code.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ColonOperatorBehaviour ColonOperatorClrCallbackBehaviour { get; set; }
Public Property ColonOperatorClrCallbackBehaviour As ColonOperatorBehaviour
    Get
    Set
public:
property ColonOperatorBehaviour ColonOperatorClrCallbackBehaviour {
    ColonOperatorBehaviour get ();
    void set (ColonOperatorBehaviour value);
}
member ColonOperatorClrCallbackBehaviour : ColonOperatorBehaviour with get, set

Property Value

Type: ColonOperatorBehaviour
See Also

Reference

ScriptOptions Class
MoonSharp.Interpreter Namespace


ScriptOptions.DebugInput Property

ScriptOptionsDebugInput Property
Gets or sets the debug input handler (takes a prompt as an input, for interactive interpreters, like debug.debug).

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Func<string, string> DebugInput { get; set; }
Public Property DebugInput As Func(Of String, String)
    Get
    Set
public:
property Func<String^, String^>^ DebugInput {
    Func<String^, String^>^ get ();
    void set (Func<String^, String^>^ value);
}
member DebugInput : Func<string, string> with get, set

Property Value

Type: Func String, String
See Also

Reference

ScriptOptions Class
MoonSharp.Interpreter Namespace


ScriptOptions.DebugPrint Property

ScriptOptionsDebugPrint Property
Gets or sets the debug print handler

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Action<string> DebugPrint { get; set; }
Public Property DebugPrint As Action(Of String)
    Get
    Set
public:
property Action<String^>^ DebugPrint {
    Action<String^>^ get ();
    void set (Action<String^>^ value);
}
member DebugPrint : Action<string> with get, set

Property Value

Type: Action String
See Also

Reference

ScriptOptions Class
MoonSharp.Interpreter Namespace


ScriptOptions.ScriptLoader Property

ScriptOptionsScriptLoader Property
Gets or sets the current script-loader.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IScriptLoader ScriptLoader { get; set; }
Public Property ScriptLoader As IScriptLoader
    Get
    Set
public:
property IScriptLoader^ ScriptLoader {
    IScriptLoader^ get ();
    void set (IScriptLoader^ value);
}
member ScriptLoader : IScriptLoader with get, set

Property Value

Type: IScriptLoader
See Also

Reference

ScriptOptions Class
MoonSharp.Interpreter Namespace


ScriptOptions.Stderr Property

ScriptOptionsStderr Property
Gets or sets the stream used as stderr. If null, a default stream is used.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Stream Stderr { get; set; }
Public Property Stderr As Stream
    Get
    Set
public:
property Stream^ Stderr {
    Stream^ get ();
    void set (Stream^ value);
}
member Stderr : Stream with get, set

Property Value

Type: Stream
See Also

Reference

ScriptOptions Class
MoonSharp.Interpreter Namespace


ScriptOptions.Stdin Property

ScriptOptionsStdin Property
Gets or sets the stream used as stdin. If null, a default stream is used.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Stream Stdin { get; set; }
Public Property Stdin As Stream
    Get
    Set
public:
property Stream^ Stdin {
    Stream^ get ();
    void set (Stream^ value);
}
member Stdin : Stream with get, set

Property Value

Type: Stream
See Also

Reference

ScriptOptions Class
MoonSharp.Interpreter Namespace


ScriptOptions.Stdout Property

ScriptOptionsStdout Property
Gets or sets the stream used as stdout. If null, a default stream is used.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Stream Stdout { get; set; }
Public Property Stdout As Stream
    Get
    Set
public:
property Stream^ Stdout {
    Stream^ get ();
    void set (Stream^ value);
}
member Stdout : Stream with get, set

Property Value

Type: Stream
See Also

Reference

ScriptOptions Class
MoonSharp.Interpreter Namespace


ScriptOptions.TailCallOptimizationThreshold Property

ScriptOptionsTailCallOptimizationThreshold Property
Gets or sets the stack depth threshold at which MoonSharp starts doing tail call optimizations. TCOs can provide the little benefit of avoiding stack overflows in corner case scenarios, at the expense of losing debug information and error stack traces in all other, more common scenarios. MoonSharp choice is to start performing TCOs only after a certain threshold of stack usage is reached - by default half the current stack depth (128K entries), thus 64K entries, on either the internal stacks. Set this to int.MaxValue to disable TCOs entirely, or to 0 to always have TCOs enabled.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int TailCallOptimizationThreshold { get; set; }
Public Property TailCallOptimizationThreshold As Integer
    Get
    Set
public:
property int TailCallOptimizationThreshold {
    int get ();
    void set (int value);
}
member TailCallOptimizationThreshold : int with get, set

Property Value

Type: Int32
See Also

Reference

ScriptOptions Class
MoonSharp.Interpreter Namespace


ScriptOptions.UseLuaErrorLocations Property

ScriptOptionsUseLuaErrorLocations Property
Gets or sets a value indicating whether error messages will use Lua error locations instead of MoonSharp improved ones. Use this for compatibility with legacy Lua code which parses error messages.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseLuaErrorLocations { get; set; }
Public Property UseLuaErrorLocations As Boolean
    Get
    Set
public:
property bool UseLuaErrorLocations {
    bool get ();
    void set (bool value);
}
member UseLuaErrorLocations : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ScriptOptions Class
MoonSharp.Interpreter Namespace


ScriptOptions Methods

ScriptOptions Methods

The ScriptOptions type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptOptions Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException Class

ScriptRuntimeException Class
Exception for all runtime errors. In addition to constructors, it offers a lot of static methods generating more "standard" Lua errors.
Inheritance Hierarchy
SystemObject
SystemException
MoonSharp.InterpreterInterpreterException
MoonSharp.InterpreterScriptRuntimeException
MoonSharp.InterpreterDynamicExpressionException

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class ScriptRuntimeException : InterpreterException
<SerializableAttribute>
Public Class ScriptRuntimeException
    Inherits InterpreterException
[SerializableAttribute]
public ref class ScriptRuntimeException : public InterpreterException
[<SerializableAttribute>]
type ScriptRuntimeException =
    class
        inherit InterpreterException
    end

The ScriptRuntimeException type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptRuntimeException(Exception) | Initializes a new instance of the ScriptRuntimeException class.
Public method | ScriptRuntimeException(String) | Initializes a new instance of the ScriptRuntimeException class.
Public method | ScriptRuntimeException(ScriptRuntimeException) | Initializes a new instance of the ScriptRuntimeException class.
Public method | ScriptRuntimeException(String, Object) | Initializes a new instance of the ScriptRuntimeException class.
Top
Properties
 | Name | Description
Public property | CallStack | Gets the interpreter call stack. (Inherited from InterpreterException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | DecoratedMessage | Gets the decorated message (error message plus error location in script) if possible. (Inherited from InterpreterException.)
Public property | DoNotDecorateMessage | Gets or sets a value indicating whether the message should not be decorated (Inherited from InterpreterException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | InstructionPtr | Gets the instruction pointer of the execution (if it makes sense) (Inherited from InterpreterException.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
 | AccessInstanceMemberOnStatics(IMemberDescriptor) | Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to access a non-static member from a static userdata was made
 | AccessInstanceMemberOnStatics(IUserDataDescriptor, IMemberDescriptor) | Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to access a non-static member from a static userdata was made
 | ArithmeticOnNonNumber | Creates a ScriptRuntimeException with a predefined error message specifying that an arithmetic operation was attempted on non-numbers
 | AttemptToCallNonFunc | Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to call a non-function was made
 | BadArgument(Int32, String, String) | Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with a bad argument
 | BadArgument(Int32, String, DataType, DataType, Boolean) | Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with a bad argument
 | BadArgument(Int32, String, String, String, Boolean) | Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with a bad argument
 | BadArgumentIndexOutOfRange | Creates a ScriptRuntimeException with a predefined error message specifying that an out of range index was specified
 | BadArgumentNoNegativeNumbers | Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with a negative number when a positive one was expected.
 | BadArgumentNoValue | Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with no value when a value was required. This function creates a message like "bad argument #xxx to 'yyy' (zzz expected, got no value)" while BadArgumentValueExpected(Int32, String) creates a message like "bad argument #xxx to 'yyy' (value expected)"
 | BadArgumentUserData | Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with a bad userdata argument
 | BadArgumentValueExpected | Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with no value when a value was required. This function creates a message like "bad argument #xxx to 'yyy' (value expected)" while BadArgumentNoValue(Int32, String, DataType) creates a message like "bad argument #xxx to 'yyy' (zzz expected, got no value)"
 | CannotResumeNotSuspended | Creates a ScriptRuntimeException with a predefined error message specifying that an attempt resume a coroutine in an invalid state was done.
 | CannotYield | Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to yield across a CLR boundary was made.
 | CannotYieldMain | Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to yield from the main coroutine was made.
 | CompareInvalidType | Creates a ScriptRuntimeException with a predefined error message specifying that a comparison operator was applied on an invalid combination of operand types
 | ConcatOnNonString | Creates a ScriptRuntimeException with a predefined error message specifying that a concat operation was attempted on non-strings
 | ConvertObjectFailed(Object) | Creates a ScriptRuntimeException with a predefined error message specifying that a conversion of a CLR type to a Lua type has failed.
 | ConvertObjectFailed(DataType) | Creates a ScriptRuntimeException with a predefined error message specifying that a conversion of a Lua type to a CLR type has failed.
 | ConvertObjectFailed(DataType, Type) | Creates a ScriptRuntimeException with a predefined error message specifying that a constrained conversion of a Lua type to a CLR type has failed.
 | ConvertToNumberFailed | Creates a ScriptRuntimeException with a predefined error message specifying that a conversion to number failed.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
 | IndexType | Creates a ScriptRuntimeException with a predefined error message specifying that an invalid attempt to index the specified object was made
 | LenOnInvalidType | Creates a ScriptRuntimeException with a predefined error message specifying that a len operator was applied on an invalid operand
 | LoopInCall | Creates a ScriptRuntimeException with a predefined error message specifying that a loop was detected when performing __call over metatables.
 | LoopInIndex | Creates a ScriptRuntimeException with a predefined error message specifying that a loop was detected when performing __index over metatables.
 | LoopInNewIndex | Creates a ScriptRuntimeException with a predefined error message specifying that a loop was detected when performing __newindex over metatables.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rethrow | Rethrows this instance if (Overrides InterpreterExceptionRethrow.)
 | TableIndexIsNaN | Creates a ScriptRuntimeException with a predefined error message specifying that a table indexing operation used a NaN as the key.
 | TableIndexIsNil | Creates a ScriptRuntimeException with a predefined error message specifying that a table indexing operation used nil as the key.
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
 | UserDataArgumentTypeMismatch | Creates a ScriptRuntimeException with a predefined error message specifying that a userdata of a specific CLR type was expected and a non-userdata type was passed.
 | UserDataMissingField | Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to index an invalid member of a userdata was done.
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


ScriptRuntimeException Constructor

ScriptRuntimeException Constructor
Overload List
 | Name | Description
Public method | ScriptRuntimeException(Exception) | Initializes a new instance of the ScriptRuntimeException class.
Public method | ScriptRuntimeException(String) | Initializes a new instance of the ScriptRuntimeException class.
Public method | ScriptRuntimeException(ScriptRuntimeException) | Initializes a new instance of the ScriptRuntimeException class.
Public method | ScriptRuntimeException(String, Object) | Initializes a new instance of the ScriptRuntimeException class.
Top
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException Constructor (Exception)

ScriptRuntimeException Constructor (Exception)
Initializes a new instance of the ScriptRuntimeException class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptRuntimeException(
    Exception ex
)
Public Sub New (
    ex As Exception
)
public:
ScriptRuntimeException(
    Exception^ ex
)
new :
        ex : Exception -> ScriptRuntimeException

Parameters

ex
Type: SystemException
The ex.
See Also

Reference

ScriptRuntimeException Class
ScriptRuntimeException Overload
MoonSharp.Interpreter Namespace


ScriptRuntimeException Constructor (String)

ScriptRuntimeException Constructor (String)
Initializes a new instance of the ScriptRuntimeException class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptRuntimeException(
    string message
)
Public Sub New (
    message As String
)
public:
ScriptRuntimeException(
    String^ message
)
new :
        message : string -> ScriptRuntimeException

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

ScriptRuntimeException Class
ScriptRuntimeException Overload
MoonSharp.Interpreter Namespace


ScriptRuntimeException Constructor (ScriptRuntimeException)

ScriptRuntimeException Constructor (ScriptRuntimeException)
Initializes a new instance of the ScriptRuntimeException class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptRuntimeException(
    ScriptRuntimeException ex
)
Public Sub New (
    ex As ScriptRuntimeException
)
public:
ScriptRuntimeException(
    ScriptRuntimeException^ ex
)
new :
        ex : ScriptRuntimeException -> ScriptRuntimeException

Parameters

ex
Type: MoonSharp.InterpreterScriptRuntimeException
The ex.
See Also

Reference

ScriptRuntimeException Class
ScriptRuntimeException Overload
MoonSharp.Interpreter Namespace


ScriptRuntimeException Constructor (String, Object[])

ScriptRuntimeException Constructor (String, Object)
Initializes a new instance of the ScriptRuntimeException class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptRuntimeException(
    string format,
    params Object[] args
)
Public Sub New (
    format As String,
    ParamArray args As Object()
)
public:
ScriptRuntimeException(
    String^ format,
    ... array<Object^>^ args
)
new :
        format : string *
        args : Object[] -> ScriptRuntimeException

Parameters

format
Type: SystemString
The format.
args
Type: SystemObject
The arguments.
See Also

Reference

ScriptRuntimeException Class
ScriptRuntimeException Overload
MoonSharp.Interpreter Namespace


ScriptRuntimeException Properties

ScriptRuntimeException Properties

The ScriptRuntimeException type exposes the following members.

Properties
 | Name | Description
Public property | CallStack | Gets the interpreter call stack. (Inherited from InterpreterException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | DecoratedMessage | Gets the decorated message (error message plus error location in script) if possible. (Inherited from InterpreterException.)
Public property | DoNotDecorateMessage | Gets or sets a value indicating whether the message should not be decorated (Inherited from InterpreterException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | InstructionPtr | Gets the instruction pointer of the execution (if it makes sense) (Inherited from InterpreterException.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException Methods

ScriptRuntimeException Methods

The ScriptRuntimeException type exposes the following members.

Methods
 | Name | Description
 | AccessInstanceMemberOnStatics(IMemberDescriptor) | Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to access a non-static member from a static userdata was made
 | AccessInstanceMemberOnStatics(IUserDataDescriptor, IMemberDescriptor) | Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to access a non-static member from a static userdata was made
 | ArithmeticOnNonNumber | Creates a ScriptRuntimeException with a predefined error message specifying that an arithmetic operation was attempted on non-numbers
 | AttemptToCallNonFunc | Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to call a non-function was made
 | BadArgument(Int32, String, String) | Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with a bad argument
 | BadArgument(Int32, String, DataType, DataType, Boolean) | Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with a bad argument
 | BadArgument(Int32, String, String, String, Boolean) | Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with a bad argument
 | BadArgumentIndexOutOfRange | Creates a ScriptRuntimeException with a predefined error message specifying that an out of range index was specified
 | BadArgumentNoNegativeNumbers | Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with a negative number when a positive one was expected.
 | BadArgumentNoValue | Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with no value when a value was required. This function creates a message like "bad argument #xxx to 'yyy' (zzz expected, got no value)" while BadArgumentValueExpected(Int32, String) creates a message like "bad argument #xxx to 'yyy' (value expected)"
 | BadArgumentUserData | Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with a bad userdata argument
 | BadArgumentValueExpected | Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with no value when a value was required. This function creates a message like "bad argument #xxx to 'yyy' (value expected)" while BadArgumentNoValue(Int32, String, DataType) creates a message like "bad argument #xxx to 'yyy' (zzz expected, got no value)"
 | CannotResumeNotSuspended | Creates a ScriptRuntimeException with a predefined error message specifying that an attempt resume a coroutine in an invalid state was done.
 | CannotYield | Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to yield across a CLR boundary was made.
 | CannotYieldMain | Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to yield from the main coroutine was made.
 | CompareInvalidType | Creates a ScriptRuntimeException with a predefined error message specifying that a comparison operator was applied on an invalid combination of operand types
 | ConcatOnNonString | Creates a ScriptRuntimeException with a predefined error message specifying that a concat operation was attempted on non-strings
 | ConvertObjectFailed(Object) | Creates a ScriptRuntimeException with a predefined error message specifying that a conversion of a CLR type to a Lua type has failed.
 | ConvertObjectFailed(DataType) | Creates a ScriptRuntimeException with a predefined error message specifying that a conversion of a Lua type to a CLR type has failed.
 | ConvertObjectFailed(DataType, Type) | Creates a ScriptRuntimeException with a predefined error message specifying that a constrained conversion of a Lua type to a CLR type has failed.
 | ConvertToNumberFailed | Creates a ScriptRuntimeException with a predefined error message specifying that a conversion to number failed.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
 | IndexType | Creates a ScriptRuntimeException with a predefined error message specifying that an invalid attempt to index the specified object was made
 | LenOnInvalidType | Creates a ScriptRuntimeException with a predefined error message specifying that a len operator was applied on an invalid operand
 | LoopInCall | Creates a ScriptRuntimeException with a predefined error message specifying that a loop was detected when performing __call over metatables.
 | LoopInIndex | Creates a ScriptRuntimeException with a predefined error message specifying that a loop was detected when performing __index over metatables.
 | LoopInNewIndex | Creates a ScriptRuntimeException with a predefined error message specifying that a loop was detected when performing __newindex over metatables.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rethrow | Rethrows this instance if (Overrides InterpreterExceptionRethrow.)
 | TableIndexIsNaN | Creates a ScriptRuntimeException with a predefined error message specifying that a table indexing operation used a NaN as the key.
 | TableIndexIsNil | Creates a ScriptRuntimeException with a predefined error message specifying that a table indexing operation used nil as the key.
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
 | UserDataArgumentTypeMismatch | Creates a ScriptRuntimeException with a predefined error message specifying that a userdata of a specific CLR type was expected and a non-userdata type was passed.
 | UserDataMissingField | Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to index an invalid member of a userdata was done.
Top
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.AccessInstanceMemberOnStatics Method

ScriptRuntimeExceptionAccessInstanceMemberOnStatics Method
Overload List
Name | Description
AccessInstanceMemberOnStatics(IMemberDescriptor) | Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to access a non-static member from a static userdata was made
AccessInstanceMemberOnStatics(IUserDataDescriptor, IMemberDescriptor) | Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to access a non-static member from a static userdata was made
Top
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.AccessInstanceMemberOnStatics Method (IMemberDescriptor)

ScriptRuntimeExceptionAccessInstanceMemberOnStatics Method (IMemberDescriptor)
Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to access a non-static member from a static userdata was made

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException AccessInstanceMemberOnStatics(
    IMemberDescriptor desc
)
Public Shared Function AccessInstanceMemberOnStatics (
    desc As IMemberDescriptor
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ AccessInstanceMemberOnStatics(
    IMemberDescriptor^ desc
)
static member AccessInstanceMemberOnStatics :
        desc : IMemberDescriptor -> ScriptRuntimeException

Parameters

desc
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsIMemberDescriptor
The member descriptor.

Return Value

Type: ScriptRuntimeException
See Also

Reference

ScriptRuntimeException Class
AccessInstanceMemberOnStatics Overload
MoonSharp.Interpreter Namespace


ScriptRuntimeException.AccessInstanceMemberOnStatics Method (IUserDataDescriptor, IMemberDescriptor)

ScriptRuntimeExceptionAccessInstanceMemberOnStatics Method (IUserDataDescriptor, IMemberDescriptor)
Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to access a non-static member from a static userdata was made

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException AccessInstanceMemberOnStatics(
    IUserDataDescriptor typeDescr,
    IMemberDescriptor desc
)
Public Shared Function AccessInstanceMemberOnStatics (
    typeDescr As IUserDataDescriptor,
    desc As IMemberDescriptor
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ AccessInstanceMemberOnStatics(
    IUserDataDescriptor^ typeDescr,
    IMemberDescriptor^ desc
)
static member AccessInstanceMemberOnStatics :
        typeDescr : IUserDataDescriptor *
        desc : IMemberDescriptor -> ScriptRuntimeException

Parameters

typeDescr
Type: MoonSharp.Interpreter.InteropIUserDataDescriptor
The type descriptor.
desc
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsIMemberDescriptor
The member descriptor.

Return Value

Type: ScriptRuntimeException
See Also

Reference

ScriptRuntimeException Class
AccessInstanceMemberOnStatics Overload
MoonSharp.Interpreter Namespace


ScriptRuntimeException.ArithmeticOnNonNumber Method

ScriptRuntimeExceptionArithmeticOnNonNumber Method
Creates a ScriptRuntimeException with a predefined error message specifying that an arithmetic operation was attempted on non-numbers

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException ArithmeticOnNonNumber(
    DynValue l,
    DynValue r = null
)
Public Shared Function ArithmeticOnNonNumber (
    l As DynValue,
    Optional r As DynValue = Nothing
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ ArithmeticOnNonNumber(
    DynValue^ l,
    DynValue^ r = nullptr
)
static member ArithmeticOnNonNumber :
        l : DynValue *
        ?r : DynValue
(* Defaults:
        let _r = defaultArg r null
*)
-> ScriptRuntimeException

Parameters

l
Type: MoonSharp.InterpreterDynValue
The left operand.
r (Optional)
Type: MoonSharp.InterpreterDynValue
The right operand (or null).

Return Value

Type: ScriptRuntimeException
The exception to be raised.
Exceptions
Exception | Condition
InternalErrorException | If both are numbers
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.AttemptToCallNonFunc Method

ScriptRuntimeExceptionAttemptToCallNonFunc Method
Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to call a non-function was made

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException AttemptToCallNonFunc(
    DataType type,
    string debugText = null
)
Public Shared Function AttemptToCallNonFunc (
    type As DataType,
    Optional debugText As String = Nothing
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ AttemptToCallNonFunc(
    DataType type,
    String^ debugText = nullptr
)
static member AttemptToCallNonFunc :
        type : DataType *
        ?debugText : string
(* Defaults:
        let _debugText = defaultArg debugText null
*)
-> ScriptRuntimeException

Parameters

type
Type: MoonSharp.InterpreterDataType
The lua non-function data type.
debugText (Optional)
Type: SystemString
The debug text to aid location (appears as "near 'xxx'").

Return Value

Type: ScriptRuntimeException
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.BadArgument Method

ScriptRuntimeExceptionBadArgument Method
Overload List
Name | Description
BadArgument(Int32, String, String) | Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with a bad argument
BadArgument(Int32, String, DataType, DataType, Boolean) | Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with a bad argument
BadArgument(Int32, String, String, String, Boolean) | Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with a bad argument
Top
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.BadArgument Method (Int32, String, String)

ScriptRuntimeExceptionBadArgument Method (Int32, String, String)
Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with a bad argument

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException BadArgument(
    int argNum,
    string funcName,
    string message
)
Public Shared Function BadArgument (
    argNum As Integer,
    funcName As String,
    message As String
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ BadArgument(
    int argNum,
    String^ funcName,
    String^ message
)
static member BadArgument :
        argNum : int *
        funcName : string *
        message : string -> ScriptRuntimeException

Parameters

argNum
Type: SystemInt32
The argument number (0-based).
funcName
Type: SystemString
Name of the function generating this error.
message
Type: SystemString
The error message.

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
BadArgument Overload
MoonSharp.Interpreter Namespace


ScriptRuntimeException.BadArgument Method (Int32, String, DataType, DataType, Boolean)

ScriptRuntimeExceptionBadArgument Method (Int32, String, DataType, DataType, Boolean)
Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with a bad argument

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException BadArgument(
    int argNum,
    string funcName,
    DataType expected,
    DataType got,
    bool allowNil
)
Public Shared Function BadArgument (
    argNum As Integer,
    funcName As String,
    expected As DataType,
    got As DataType,
    allowNil As Boolean
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ BadArgument(
    int argNum,
    String^ funcName,
    DataType expected,
    DataType got,
    bool allowNil
)
static member BadArgument :
        argNum : int *
        funcName : string *
        expected : DataType *
        got : DataType *
        allowNil : bool -> ScriptRuntimeException

Parameters

argNum
Type: SystemInt32
The argument number (0-based).
funcName
Type: SystemString
Name of the function generating this error.
expected
Type: MoonSharp.InterpreterDataType
The expected data type.
got
Type: MoonSharp.InterpreterDataType
The data type received.
allowNil
Type: SystemBoolean
True if nils were allowed in this call.

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
BadArgument Overload
MoonSharp.Interpreter Namespace


ScriptRuntimeException.BadArgument Method (Int32, String, String, String, Boolean)

ScriptRuntimeExceptionBadArgument Method (Int32, String, String, String, Boolean)
Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with a bad argument

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException BadArgument(
    int argNum,
    string funcName,
    string expected,
    string got,
    bool allowNil
)
Public Shared Function BadArgument (
    argNum As Integer,
    funcName As String,
    expected As String,
    got As String,
    allowNil As Boolean
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ BadArgument(
    int argNum,
    String^ funcName,
    String^ expected,
    String^ got,
    bool allowNil
)
static member BadArgument :
        argNum : int *
        funcName : string *
        expected : string *
        got : string *
        allowNil : bool -> ScriptRuntimeException

Parameters

argNum
Type: SystemInt32
The argument number (0-based).
funcName
Type: SystemString
Name of the function generating this error.
expected
Type: SystemString
The expected type description.
got
Type: SystemString
The description of the type received.
allowNil
Type: SystemBoolean
True if nils were allowed in this call.

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
BadArgument Overload
MoonSharp.Interpreter Namespace


ScriptRuntimeException.BadArgumentIndexOutOfRange Method

ScriptRuntimeExceptionBadArgumentIndexOutOfRange Method
Creates a ScriptRuntimeException with a predefined error message specifying that an out of range index was specified

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException BadArgumentIndexOutOfRange(
    string funcName,
    int argNum
)
Public Shared Function BadArgumentIndexOutOfRange (
    funcName As String,
    argNum As Integer
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ BadArgumentIndexOutOfRange(
    String^ funcName,
    int argNum
)
static member BadArgumentIndexOutOfRange :
        funcName : string *
        argNum : int -> ScriptRuntimeException

Parameters

funcName
Type: SystemString
Name of the function generating this error.
argNum
Type: SystemInt32
The argument number (0-based).

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.BadArgumentNoNegativeNumbers Method

ScriptRuntimeExceptionBadArgumentNoNegativeNumbers Method
Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with a negative number when a positive one was expected.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException BadArgumentNoNegativeNumbers(
    int argNum,
    string funcName
)
Public Shared Function BadArgumentNoNegativeNumbers (
    argNum As Integer,
    funcName As String
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ BadArgumentNoNegativeNumbers(
    int argNum,
    String^ funcName
)
static member BadArgumentNoNegativeNumbers :
        argNum : int *
        funcName : string -> ScriptRuntimeException

Parameters

argNum
Type: SystemInt32
The argument number (0-based).
funcName
Type: SystemString
Name of the function generating this error.

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.BadArgumentNoValue Method

ScriptRuntimeExceptionBadArgumentNoValue Method
Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with no value when a value was required. This function creates a message like "bad argument #xxx to 'yyy' (zzz expected, got no value)" while BadArgumentValueExpected(Int32, String) creates a message like "bad argument #xxx to 'yyy' (value expected)"

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException BadArgumentNoValue(
    int argNum,
    string funcName,
    DataType expected
)
Public Shared Function BadArgumentNoValue (
    argNum As Integer,
    funcName As String,
    expected As DataType
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ BadArgumentNoValue(
    int argNum,
    String^ funcName,
    DataType expected
)
static member BadArgumentNoValue :
        argNum : int *
        funcName : string *
        expected : DataType -> ScriptRuntimeException

Parameters

argNum
Type: SystemInt32
The argument number (0-based).
funcName
Type: SystemString
Name of the function generating this error.
expected
Type: MoonSharp.InterpreterDataType
The expected data type.

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.BadArgumentUserData Method

ScriptRuntimeExceptionBadArgumentUserData Method
Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with a bad userdata argument

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException BadArgumentUserData(
    int argNum,
    string funcName,
    Type expected,
    Object got,
    bool allowNil
)
Public Shared Function BadArgumentUserData (
    argNum As Integer,
    funcName As String,
    expected As Type,
    got As Object,
    allowNil As Boolean
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ BadArgumentUserData(
    int argNum,
    String^ funcName,
    Type^ expected,
    Object^ got,
    bool allowNil
)
static member BadArgumentUserData :
        argNum : int *
        funcName : string *
        expected : Type *
        got : Object *
        allowNil : bool -> ScriptRuntimeException

Parameters

argNum
Type: SystemInt32
The argument number (0-based).
funcName
Type: SystemString
Name of the function generating this error.
expected
Type: SystemType
The expected System.Type.
got
Type: SystemObject
The object which was used.
allowNil
Type: SystemBoolean
True if nils were allowed in this call.

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.BadArgumentValueExpected Method

ScriptRuntimeExceptionBadArgumentValueExpected Method
Creates a ScriptRuntimeException with a predefined error message specifying that a function was called with no value when a value was required. This function creates a message like "bad argument #xxx to 'yyy' (value expected)" while BadArgumentNoValue(Int32, String, DataType) creates a message like "bad argument #xxx to 'yyy' (zzz expected, got no value)"

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException BadArgumentValueExpected(
    int argNum,
    string funcName
)
Public Shared Function BadArgumentValueExpected (
    argNum As Integer,
    funcName As String
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ BadArgumentValueExpected(
    int argNum,
    String^ funcName
)
static member BadArgumentValueExpected :
        argNum : int *
        funcName : string -> ScriptRuntimeException

Parameters

argNum
Type: SystemInt32
The argument number (0-based).
funcName
Type: SystemString
Name of the function generating this error.

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.CannotResumeNotSuspended Method

ScriptRuntimeExceptionCannotResumeNotSuspended Method
Creates a ScriptRuntimeException with a predefined error message specifying that an attempt resume a coroutine in an invalid state was done.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException CannotResumeNotSuspended(
    CoroutineState state
)
Public Shared Function CannotResumeNotSuspended (
    state As CoroutineState
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ CannotResumeNotSuspended(
    CoroutineState state
)
static member CannotResumeNotSuspended :
        state : CoroutineState -> ScriptRuntimeException

Parameters

state
Type: MoonSharp.InterpreterCoroutineState
The state of the coroutine.

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.CannotYield Method

ScriptRuntimeExceptionCannotYield Method
Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to yield across a CLR boundary was made.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException CannotYield()
Public Shared Function CannotYield As ScriptRuntimeException
public:
static ScriptRuntimeException^ CannotYield()
static member CannotYield : unit -> ScriptRuntimeException

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.CannotYieldMain Method

ScriptRuntimeExceptionCannotYieldMain Method
Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to yield from the main coroutine was made.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException CannotYieldMain()
Public Shared Function CannotYieldMain As ScriptRuntimeException
public:
static ScriptRuntimeException^ CannotYieldMain()
static member CannotYieldMain : unit -> ScriptRuntimeException

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.CompareInvalidType Method

ScriptRuntimeExceptionCompareInvalidType Method
Creates a ScriptRuntimeException with a predefined error message specifying that a comparison operator was applied on an invalid combination of operand types

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException CompareInvalidType(
    DynValue l,
    DynValue r
)
Public Shared Function CompareInvalidType (
    l As DynValue,
    r As DynValue
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ CompareInvalidType(
    DynValue^ l,
    DynValue^ r
)
static member CompareInvalidType :
        l : DynValue *
        r : DynValue -> ScriptRuntimeException

Parameters

l
Type: MoonSharp.InterpreterDynValue
The left operand.
r
Type: MoonSharp.InterpreterDynValue
The right operand.

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.ConcatOnNonString Method

ScriptRuntimeExceptionConcatOnNonString Method
Creates a ScriptRuntimeException with a predefined error message specifying that a concat operation was attempted on non-strings

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException ConcatOnNonString(
    DynValue l,
    DynValue r
)
Public Shared Function ConcatOnNonString (
    l As DynValue,
    r As DynValue
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ ConcatOnNonString(
    DynValue^ l,
    DynValue^ r
)
static member ConcatOnNonString :
        l : DynValue *
        r : DynValue -> ScriptRuntimeException

Parameters

l
Type: MoonSharp.InterpreterDynValue
The left operand.
r
Type: MoonSharp.InterpreterDynValue
The right operand.

Return Value

Type: ScriptRuntimeException
The exception to be raised.
Exceptions
Exception | Condition
InternalErrorException | If both are numbers or strings
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.ConvertObjectFailed Method

ScriptRuntimeExceptionConvertObjectFailed Method
Overload List
Name | Description
ConvertObjectFailed(Object) | Creates a ScriptRuntimeException with a predefined error message specifying that a conversion of a CLR type to a Lua type has failed.
ConvertObjectFailed(DataType) | Creates a ScriptRuntimeException with a predefined error message specifying that a conversion of a Lua type to a CLR type has failed.
ConvertObjectFailed(DataType, Type) | Creates a ScriptRuntimeException with a predefined error message specifying that a constrained conversion of a Lua type to a CLR type has failed.
Top
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.ConvertObjectFailed Method (Object)

ScriptRuntimeExceptionConvertObjectFailed Method (Object)
Creates a ScriptRuntimeException with a predefined error message specifying that a conversion of a CLR type to a Lua type has failed.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException ConvertObjectFailed(
    Object obj
)
Public Shared Function ConvertObjectFailed (
    obj As Object
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ ConvertObjectFailed(
    Object^ obj
)
static member ConvertObjectFailed :
        obj : Object -> ScriptRuntimeException

Parameters

obj
Type: SystemObject
The object which could not be converted.

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
ConvertObjectFailed Overload
MoonSharp.Interpreter Namespace


ScriptRuntimeException.ConvertObjectFailed Method (DataType)

ScriptRuntimeExceptionConvertObjectFailed Method (DataType)
Creates a ScriptRuntimeException with a predefined error message specifying that a conversion of a Lua type to a CLR type has failed.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException ConvertObjectFailed(
    DataType t
)
Public Shared Function ConvertObjectFailed (
    t As DataType
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ ConvertObjectFailed(
    DataType t
)
static member ConvertObjectFailed :
        t : DataType -> ScriptRuntimeException

Parameters

t
Type: MoonSharp.InterpreterDataType
The Lua type.

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
ConvertObjectFailed Overload
MoonSharp.Interpreter Namespace


ScriptRuntimeException.ConvertObjectFailed Method (DataType, Type)

ScriptRuntimeExceptionConvertObjectFailed Method (DataType, Type)
Creates a ScriptRuntimeException with a predefined error message specifying that a constrained conversion of a Lua type to a CLR type has failed.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException ConvertObjectFailed(
    DataType t,
    Type t2
)
Public Shared Function ConvertObjectFailed (
    t As DataType,
    t2 As Type
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ ConvertObjectFailed(
    DataType t,
    Type^ t2
)
static member ConvertObjectFailed :
        t : DataType *
        t2 : Type -> ScriptRuntimeException

Parameters

t
Type: MoonSharp.InterpreterDataType
The Lua type.
t2
Type: SystemType
The expected CLR type.

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
ConvertObjectFailed Overload
MoonSharp.Interpreter Namespace


ScriptRuntimeException.ConvertToNumberFailed Method

ScriptRuntimeExceptionConvertToNumberFailed Method
Creates a ScriptRuntimeException with a predefined error message specifying that a conversion to number failed.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException ConvertToNumberFailed(
    int stage
)
Public Shared Function ConvertToNumberFailed (
    stage As Integer
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ ConvertToNumberFailed(
    int stage
)
static member ConvertToNumberFailed :
        stage : int -> ScriptRuntimeException

Parameters

stage
Type: SystemInt32
Selects the correct error message: 0 - "value must be a number" 1 - "'for' initial value must be a number" 2 - "'for' step must be a number" 3 - "'for' limit must be a number"

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.IndexType Method

ScriptRuntimeExceptionIndexType Method
Creates a ScriptRuntimeException with a predefined error message specifying that an invalid attempt to index the specified object was made

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException IndexType(
    DynValue obj
)
Public Shared Function IndexType (
    obj As DynValue
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ IndexType(
    DynValue^ obj
)
static member IndexType :
        obj : DynValue -> ScriptRuntimeException

Parameters

obj
Type: MoonSharp.InterpreterDynValue
The object.

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.LenOnInvalidType Method

ScriptRuntimeExceptionLenOnInvalidType Method
Creates a ScriptRuntimeException with a predefined error message specifying that a len operator was applied on an invalid operand

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException LenOnInvalidType(
    DynValue r
)
Public Shared Function LenOnInvalidType (
    r As DynValue
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ LenOnInvalidType(
    DynValue^ r
)
static member LenOnInvalidType :
        r : DynValue -> ScriptRuntimeException

Parameters

r
Type: MoonSharp.InterpreterDynValue
The operand.

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.LoopInCall Method

ScriptRuntimeExceptionLoopInCall Method
Creates a ScriptRuntimeException with a predefined error message specifying that a loop was detected when performing __call over metatables.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException LoopInCall()
Public Shared Function LoopInCall As ScriptRuntimeException
public:
static ScriptRuntimeException^ LoopInCall()
static member LoopInCall : unit -> ScriptRuntimeException

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.LoopInIndex Method

ScriptRuntimeExceptionLoopInIndex Method
Creates a ScriptRuntimeException with a predefined error message specifying that a loop was detected when performing __index over metatables.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException LoopInIndex()
Public Shared Function LoopInIndex As ScriptRuntimeException
public:
static ScriptRuntimeException^ LoopInIndex()
static member LoopInIndex : unit -> ScriptRuntimeException

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.LoopInNewIndex Method

ScriptRuntimeExceptionLoopInNewIndex Method
Creates a ScriptRuntimeException with a predefined error message specifying that a loop was detected when performing __newindex over metatables.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException LoopInNewIndex()
Public Shared Function LoopInNewIndex As ScriptRuntimeException
public:
static ScriptRuntimeException^ LoopInNewIndex()
static member LoopInNewIndex : unit -> ScriptRuntimeException

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.Rethrow Method

ScriptRuntimeExceptionRethrow Method
Rethrows this instance if

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void Rethrow()
Public Overrides Sub Rethrow
public:
virtual void Rethrow() override
abstract Rethrow : unit -> unit
override Rethrow : unit -> unit

Return Value

Type:
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.TableIndexIsNaN Method

ScriptRuntimeExceptionTableIndexIsNaN Method
Creates a ScriptRuntimeException with a predefined error message specifying that a table indexing operation used a NaN as the key.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException TableIndexIsNaN()
Public Shared Function TableIndexIsNaN As ScriptRuntimeException
public:
static ScriptRuntimeException^ TableIndexIsNaN()
static member TableIndexIsNaN : unit -> ScriptRuntimeException

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.TableIndexIsNil Method

ScriptRuntimeExceptionTableIndexIsNil Method
Creates a ScriptRuntimeException with a predefined error message specifying that a table indexing operation used nil as the key.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException TableIndexIsNil()
Public Shared Function TableIndexIsNil As ScriptRuntimeException
public:
static ScriptRuntimeException^ TableIndexIsNil()
static member TableIndexIsNil : unit -> ScriptRuntimeException

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.UserDataArgumentTypeMismatch Method

ScriptRuntimeExceptionUserDataArgumentTypeMismatch Method
Creates a ScriptRuntimeException with a predefined error message specifying that a userdata of a specific CLR type was expected and a non-userdata type was passed.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException UserDataArgumentTypeMismatch(
    DataType t,
    Type clrType
)
Public Shared Function UserDataArgumentTypeMismatch (
    t As DataType,
    clrType As Type
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ UserDataArgumentTypeMismatch(
    DataType t,
    Type^ clrType
)
static member UserDataArgumentTypeMismatch :
        t : DataType *
        clrType : Type -> ScriptRuntimeException

Parameters

t
Type: MoonSharp.InterpreterDataType
The Lua type.
clrType
Type: SystemType
The expected CLR type.

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException.UserDataMissingField Method

ScriptRuntimeExceptionUserDataMissingField Method
Creates a ScriptRuntimeException with a predefined error message specifying that an attempt to index an invalid member of a userdata was done.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static ScriptRuntimeException UserDataMissingField(
    string typename,
    string fieldname
)
Public Shared Function UserDataMissingField (
    typename As String,
    fieldname As String
) As ScriptRuntimeException
public:
static ScriptRuntimeException^ UserDataMissingField(
    String^ typename,
    String^ fieldname
)
static member UserDataMissingField :
        typename : string *
        fieldname : string -> ScriptRuntimeException

Parameters

typename
Type: SystemString
The name of the userdata type.
fieldname
Type: SystemString
The field name.

Return Value

Type: ScriptRuntimeException
The exception to be raised.
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


ScriptRuntimeException Events

ScriptRuntimeException Events

The ScriptRuntimeException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ScriptRuntimeException Class
MoonSharp.Interpreter Namespace


SymbolRef Class

SymbolRef Class
This class stores a possible l-value (that is a potential target of an assignment)
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterSymbolRef

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class SymbolRef
Public Class SymbolRef
public ref class SymbolRef
type SymbolRef =  class end

The SymbolRef type exposes the following members.

Constructors
 | Name | Description
Public method | SymbolRef | Initializes a new instance of the SymbolRef class
Top
Properties
 | Name | Description
 | DefaultEnv | Gets the default _ENV.
Public property | Environment | Gets the environment this symbol refers to (for global symbols only)
Public property | Index | Gets the index of this symbol in its scope context
Public property | Name | Gets the name of this symbol
Public property | Type | Gets the type of this symbol reference
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Global | Creates a new symbol reference pointing to a global var
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


SymbolRef Constructor

SymbolRef Constructor
Initializes a new instance of the SymbolRef class

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public SymbolRef()
Public Sub New
public:
SymbolRef()
new : unit -> SymbolRef
See Also

Reference

SymbolRef Class
MoonSharp.Interpreter Namespace


SymbolRef Properties

SymbolRef Properties

The SymbolRef type exposes the following members.

Properties
 | Name | Description
 | DefaultEnv | Gets the default _ENV.
Public property | Environment | Gets the environment this symbol refers to (for global symbols only)
Public property | Index | Gets the index of this symbol in its scope context
Public property | Name | Gets the name of this symbol
Public property | Type | Gets the type of this symbol reference
Top
See Also

Reference

SymbolRef Class
MoonSharp.Interpreter Namespace


SymbolRef.DefaultEnv Property

SymbolRefDefaultEnv Property
Gets the default _ENV.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static SymbolRef DefaultEnv { get; }
Public Shared ReadOnly Property DefaultEnv As SymbolRef
    Get
public:
static property SymbolRef^ DefaultEnv {
    SymbolRef^ get ();
}
static member DefaultEnv : SymbolRef with get

Property Value

Type: SymbolRef
See Also

Reference

SymbolRef Class
MoonSharp.Interpreter Namespace


SymbolRef.Environment Property

SymbolRefEnvironment Property
Gets the environment this symbol refers to (for global symbols only)

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public SymbolRef Environment { get; }
Public ReadOnly Property Environment As SymbolRef
    Get
public:
property SymbolRef^ Environment {
    SymbolRef^ get ();
}
member Environment : SymbolRef with get

Property Value

Type: SymbolRef
See Also

Reference

SymbolRef Class
MoonSharp.Interpreter Namespace


SymbolRef.Index Property

SymbolRefIndex Property
Gets the index of this symbol in its scope context

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
member Index : int with get

Property Value

Type: Int32
See Also

Reference

SymbolRef Class
MoonSharp.Interpreter Namespace


SymbolRef.Name Property

SymbolRefName Property
Gets the name of this symbol

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

SymbolRef Class
MoonSharp.Interpreter Namespace


SymbolRef.Type Property

SymbolRefType Property
Gets the type of this symbol reference

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public SymbolRefType Type { get; }
Public ReadOnly Property Type As SymbolRefType
    Get
public:
property SymbolRefType Type {
    SymbolRefType get ();
}
member Type : SymbolRefType with get

Property Value

Type: SymbolRefType
See Also

Reference

SymbolRef Class
MoonSharp.Interpreter Namespace


SymbolRef Methods

SymbolRef Methods

The SymbolRef type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Global | Creates a new symbol reference pointing to a global var
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

SymbolRef Class
MoonSharp.Interpreter Namespace


SymbolRef.Global Method

SymbolRefGlobal Method
Creates a new symbol reference pointing to a global var

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static SymbolRef Global(
    string name,
    SymbolRef envSymbol
)
Public Shared Function Global (
    name As String,
    envSymbol As SymbolRef
) As SymbolRef
public:
static SymbolRef^ Global(
    String^ name,
    SymbolRef^ envSymbol
)
static member Global :
        name : string *
        envSymbol : SymbolRef -> SymbolRef

Parameters

name
Type: SystemString
The name.
envSymbol
Type: MoonSharp.InterpreterSymbolRef
The _ENV symbol.

Return Value

Type: SymbolRef
See Also

Reference

SymbolRef Class
MoonSharp.Interpreter Namespace


SymbolRef.ToString Method

SymbolRefToString Method
Returns a String that represents this instance.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String that represents this instance.
See Also

Reference

SymbolRef Class
MoonSharp.Interpreter Namespace


SymbolRefType Enumeration

SymbolRefType Enumeration
Enumeration of the types of SymbolRef

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public enum SymbolRefType
Public Enumeration SymbolRefType
public enum class SymbolRefType
type SymbolRefType
Members
Member name | Value | Description
Local | 0 | The symbol ref of a local variable
Upvalue | 1 | The symbol ref of an upvalue variable
Global | 2 | The symbol ref of a global variable
DefaultEnv | 3 | The symbol ref of the global environment
See Also

Reference

MoonSharp.Interpreter Namespace


SyntaxErrorException Class

SyntaxErrorException Class
Exception for all parsing/lexing errors.
Inheritance Hierarchy
SystemObject
SystemException
MoonSharp.InterpreterInterpreterException
MoonSharp.InterpreterSyntaxErrorException

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class SyntaxErrorException : InterpreterException
<SerializableAttribute>
Public Class SyntaxErrorException
    Inherits InterpreterException
[SerializableAttribute]
public ref class SyntaxErrorException : public InterpreterException
[<SerializableAttribute>]
type SyntaxErrorException =
    class
        inherit InterpreterException
    end

The SyntaxErrorException type exposes the following members.

Properties
 | Name | Description
Public property | CallStack | Gets the interpreter call stack. (Inherited from InterpreterException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | DecoratedMessage | Gets the decorated message (error message plus error location in script) if possible. (Inherited from InterpreterException.)
Public property | DoNotDecorateMessage | Gets or sets a value indicating whether the message should not be decorated (Inherited from InterpreterException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | InstructionPtr | Gets the instruction pointer of the execution (if it makes sense) (Inherited from InterpreterException.)
Public property | IsPrematureStreamTermination | Gets or sets a value indicating whether this exception was caused by premature stream termination (that is, unexpected EOF). This can be used in REPL interfaces to tell between unrecoverable errors and those which can be recovered by extra input.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rethrow | Rethrows this instance if (Overrides InterpreterExceptionRethrow.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


SyntaxErrorException Properties

SyntaxErrorException Properties

The SyntaxErrorException type exposes the following members.

Properties
 | Name | Description
Public property | CallStack | Gets the interpreter call stack. (Inherited from InterpreterException.)
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | DecoratedMessage | Gets the decorated message (error message plus error location in script) if possible. (Inherited from InterpreterException.)
Public property | DoNotDecorateMessage | Gets or sets a value indicating whether the message should not be decorated (Inherited from InterpreterException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | InstructionPtr | Gets the instruction pointer of the execution (if it makes sense) (Inherited from InterpreterException.)
Public property | IsPrematureStreamTermination | Gets or sets a value indicating whether this exception was caused by premature stream termination (that is, unexpected EOF). This can be used in REPL interfaces to tell between unrecoverable errors and those which can be recovered by extra input.
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

SyntaxErrorException Class
MoonSharp.Interpreter Namespace


SyntaxErrorException.IsPrematureStreamTermination Property

SyntaxErrorExceptionIsPrematureStreamTermination Property
Gets or sets a value indicating whether this exception was caused by premature stream termination (that is, unexpected EOF). This can be used in REPL interfaces to tell between unrecoverable errors and those which can be recovered by extra input.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPrematureStreamTermination { get; set; }
Public Property IsPrematureStreamTermination As Boolean
    Get
    Set
public:
property bool IsPrematureStreamTermination {
    bool get ();
    void set (bool value);
}
member IsPrematureStreamTermination : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SyntaxErrorException Class
MoonSharp.Interpreter Namespace


SyntaxErrorException Methods

SyntaxErrorException Methods

The SyntaxErrorException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Rethrow | Rethrows this instance if (Overrides InterpreterExceptionRethrow.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

SyntaxErrorException Class
MoonSharp.Interpreter Namespace


SyntaxErrorException.Rethrow Method

SyntaxErrorExceptionRethrow Method
Rethrows this instance if

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void Rethrow()
Public Overrides Sub Rethrow
public:
virtual void Rethrow() override
abstract Rethrow : unit -> unit
override Rethrow : unit -> unit

Return Value

Type:
See Also

Reference

SyntaxErrorException Class
MoonSharp.Interpreter Namespace


SyntaxErrorException Events

SyntaxErrorException Events

The SyntaxErrorException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

SyntaxErrorException Class
MoonSharp.Interpreter Namespace


Table Class

Table Class
A class representing a Lua table.
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterRefIdObject
MoonSharp.InterpreterTable

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class Table : RefIdObject, IScriptPrivateResource
Public Class Table
    Inherits RefIdObject
    Implements IScriptPrivateResource
public ref class Table : public RefIdObject,
    IScriptPrivateResource
type Table =
    class
        inherit RefIdObject
        interface IScriptPrivateResource
    end

The Table type exposes the following members.

Constructors
 | Name | Description
Public method | Table(Script) | Initializes a new instance of the Table class.
Public method | Table(Script, DynValue) | Initializes a new instance of the Table class.
Top
Properties
 | Name | Description
Public property | ItemObject | Gets or sets the Object with the specified key(s). This will marshall CLR and MoonSharp objects in the best possible way.
Public property | ItemObject | Gets or sets the Object with the specified key(s). This will marshall CLR and MoonSharp objects in the best possible way. Multiple keys can be used to access subtables.
Public property | Keys | Enumerates the keys.
Public property | Length | Gets the length of the "array part".
Public property | MetaTable | Gets the meta-table associated with this instance.
Public property | OwnerScript | Gets the script owning this resource.
Public property | Pairs | Enumerates the key/value pairs.
Public property | ReferenceID | Gets the reference identifier. (Inherited from RefIdObject.)
Public property | Values | Enumerates the values
Top
Methods
 | Name | Description
Public method | Append | Append the value to the table using the next available integer index.
Public method | Clear | Removes all items from the Table.
Public method | CollectDeadKeys | Collects the dead keys. This frees up memory but invalidates pending iterators. It's called automatically internally when the semantics of Lua tables allow, but can be forced externally if it's known that no iterators are pending.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormatTypeString | Formats a string with a type name and a ref-id (Inherited from RefIdObject.)
Public method | Get(Int32) | Gets the value associated with the specified key.
Public method | Get(Object) | Gets the value associated with the specified key. (expressed as a Object).
Public method | Get(Object) | Gets the value associated with the specified keys (expressed as an array of Object). This will marshall CLR and MoonSharp objects in the best possible way. Multiple keys can be used to access subtables.
Public method | Get(String) | Gets the value associated with the specified key.
Public method | Get(DynValue) | Gets the value associated with the specified key.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextKey | Returns the next pair from a value
Public method | RawGet(Int32) | Gets the value associated with the specified key, without bringing to Nil the non-existant values.
Public method | RawGet(Object) | Gets the value associated with the specified key, without bringing to Nil the non-existant values.
Public method | RawGet(Object) | Gets the value associated with the specified keys (expressed as an array of Object). This will marshall CLR and MoonSharp objects in the best possible way. Multiple keys can be used to access subtables.
Public method | RawGet(String) | Gets the value associated with the specified key, without bringing to Nil the non-existant values.
Public method | RawGet(DynValue) | Gets the value associated with the specified key, without bringing to Nil the non-existant values.
Public method | Remove(Int32) | Remove the value associated with the specified key from the table.
Public method | Remove(Object) | Remove the value associated with the specified key from the table.
Public method | Remove(Object) | Remove the value associated with the specified keys from the table. Multiple keys can be used to access subtables.
Public method | Remove(String) | Remove the value associated with the specified key from the table.
Public method | Remove(DynValue) | Remove the value associated with the specified key from the table.
Public method | Set(Int32, DynValue) | Sets the value associated to the specified key.
Public method | Set(Object, DynValue) | Sets the value associated with the specified key.
Public method | Set(Object, DynValue) | Sets the value associated with the specified keys. Multiple keys can be used to access subtables.
Public method | Set(String, DynValue) | Sets the value associated to the specified key.
Public method | Set(DynValue, DynValue) | Sets the value associated to the specified key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | RegisterConstants | Registers the standard constants (_G, _VERSION, _MOONSHARP) to a table (Defined by ModuleRegister.)
Public Extension Method | RegisterCoreModules | Register the core modules to a table (Defined by ModuleRegister.)
Public Extension Method | RegisterModuleType(Type) | Overloaded. Registers a module type to the specified table (Defined by ModuleRegister.)
Public Extension Method | RegisterModuleTypeT | Overloaded. Registers a module type to the specified table (Defined by ModuleRegister.)
Public Extension Method | Serialize | (Defined by SerializationExtensions.)
Public Extension Method | TableToJson | Converts a table to a json string (Defined by JsonTableConverter.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


Table Constructor

Table Constructor
Overload List
 | Name | Description
Public method | Table(Script) | Initializes a new instance of the Table class.
Public method | Table(Script, DynValue) | Initializes a new instance of the Table class.
Top
See Also

Reference

Table Class
MoonSharp.Interpreter Namespace


Table Constructor (Script)

Table Constructor (Script)
Initializes a new instance of the Table class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Table(
    Script owner
)
Public Sub New (
    owner As Script
)
public:
Table(
    Script^ owner
)
new :
        owner : Script -> Table

Parameters

owner
Type: MoonSharp.InterpreterScript
The owner script.
See Also

Reference

Table Class
Table Overload
MoonSharp.Interpreter Namespace


Table Constructor (Script, DynValue[])

Table Constructor (Script, DynValue)
Initializes a new instance of the Table class.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Table(
    Script owner,
    params DynValue[] arrayValues
)
Public Sub New (
    owner As Script,
    ParamArray arrayValues As DynValue()
)
public:
Table(
    Script^ owner,
    ... array<DynValue^>^ arrayValues
)
new :
        owner : Script *
        arrayValues : DynValue[] -> Table

Parameters

owner
Type: MoonSharp.InterpreterScript
The owner.
arrayValues
Type: MoonSharp.InterpreterDynValue
The values for the "array-like" part of the table.
See Also

Reference

Table Class
Table Overload
MoonSharp.Interpreter Namespace


Table Properties

Table Properties

The Table type exposes the following members.

Properties
 | Name | Description
Public property | ItemObject | Gets or sets the Object with the specified key(s). This will marshall CLR and MoonSharp objects in the best possible way.
Public property | ItemObject | Gets or sets the Object with the specified key(s). This will marshall CLR and MoonSharp objects in the best possible way. Multiple keys can be used to access subtables.
Public property | Keys | Enumerates the keys.
Public property | Length | Gets the length of the "array part".
Public property | MetaTable | Gets the meta-table associated with this instance.
Public property | OwnerScript | Gets the script owning this resource.
Public property | Pairs | Enumerates the key/value pairs.
Public property | ReferenceID | Gets the reference identifier. (Inherited from RefIdObject.)
Public property | Values | Enumerates the values
Top
See Also

Reference

Table Class
MoonSharp.Interpreter Namespace


Table.Item Property

TableItem Property
Overload List
 | Name | Description
Public property | ItemObject | Gets or sets the Object with the specified key(s). This will marshall CLR and MoonSharp objects in the best possible way.
Public property | ItemObject | Gets or sets the Object with the specified key(s). This will marshall CLR and MoonSharp objects in the best possible way. Multiple keys can be used to access subtables.
Top
See Also

Reference

Table Class
MoonSharp.Interpreter Namespace


Table.Item Property (Object)

TableItem Property (Object)
Gets or sets the Object with the specified key(s). This will marshall CLR and MoonSharp objects in the best possible way.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Object this[
    Object key
] { get; set; }
Public Default Property Item (
    key As Object
) As Object
    Get
    Set
public:
property Object^ default[Object^ key] {
    Object^ get (Object^ key);
    void set (Object^ key, Object^ value);
}
member Item : Object with get, set

Parameters

key
Type: SystemObject
The key.

Property Value

Type: Object
The Object.

Return Value

Type: Object
See Also

Reference

Table Class
Item Overload
MoonSharp.Interpreter Namespace


Table.Item Property (Object[])

TableItem Property (Object)
Gets or sets the Object with the specified key(s). This will marshall CLR and MoonSharp objects in the best possible way. Multiple keys can be used to access subtables.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Object this[
    params Object[] keys
] { get; set; }
Public Default Property Item (
    ParamArray keys As Object()
) As Object
    Get
    Set
public:
property Object^ default[... array<Object^>^ keys] {
    Object^ get (... array<Object^>^ keys);
    void set (... array<Object^>^ keys, Object^ value);
}
member Item : Object with get, set

Parameters

keys
Type: SystemObject
The keys to access the table and subtables

Property Value

Type: Object
The Object.
See Also

Reference

Table Class
Item Overload
MoonSharp.Interpreter Namespace


Table.Keys Property

TableKeys Property
Enumerates the keys.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<DynValue> Keys { get; }
Public ReadOnly Property Keys As IEnumerable(Of DynValue)
    Get
public:
property IEnumerable<DynValue^>^ Keys {
    IEnumerable<DynValue^>^ get ();
}
member Keys : IEnumerable<DynValue> with get

Return Value

Type: IEnumerable DynValue
See Also

Reference

Table Class
MoonSharp.Interpreter Namespace


Table.Length Property

TableLength Property
Gets the length of the "array part".

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get
public:
property int Length {
    int get ();
}
member Length : int with get

Property Value

Type: Int32
See Also

Reference

Table Class
MoonSharp.Interpreter Namespace


Table.MetaTable Property

TableMetaTable Property
Gets the meta-table associated with this instance.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Table MetaTable { get; set; }
Public Property MetaTable As Table
    Get
    Set
public:
property Table^ MetaTable {
    Table^ get ();
    void set (Table^ value);
}
member MetaTable : Table with get, set

Property Value

Type: Table
See Also

Reference

Table Class
MoonSharp.Interpreter Namespace


Table.OwnerScript Property

TableOwnerScript Property
Gets the script owning this resource.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Script OwnerScript { get; }
Public ReadOnly Property OwnerScript As Script
    Get
public:
virtual property Script^ OwnerScript {
    Script^ get () sealed;
}
abstract OwnerScript : Script with get
override OwnerScript : Script with get

Property Value

Type: Script

Implements

IScriptPrivateResourceOwnerScript
See Also

Reference

Table Class
MoonSharp.Interpreter Namespace


Table.Pairs Property

TablePairs Property
Enumerates the key/value pairs.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<TablePair> Pairs { get; }
Public ReadOnly Property Pairs As IEnumerable(Of TablePair)
    Get
public:
property IEnumerable<TablePair>^ Pairs {
    IEnumerable<TablePair>^ get ();
}
member Pairs : IEnumerable<TablePair> with get

Return Value

Type: IEnumerable TablePair
See Also

Reference

Table Class
MoonSharp.Interpreter Namespace


Table.Values Property

TableValues Property
Enumerates the values

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<DynValue> Values { get; }
Public ReadOnly Property Values As IEnumerable(Of DynValue)
    Get
public:
property IEnumerable<DynValue^>^ Values {
    IEnumerable<DynValue^>^ get ();
}
member Values : IEnumerable<DynValue> with get

Return Value

Type: IEnumerable DynValue
See Also

Reference

Table Class
MoonSharp.Interpreter Namespace


Table Methods

Table Methods

The Table type exposes the following members.

Methods
 | Name | Description
Public method | Append | Append the value to the table using the next available integer index.
Public method | Clear | Removes all items from the Table.
Public method | CollectDeadKeys | Collects the dead keys. This frees up memory but invalidates pending iterators. It's called automatically internally when the semantics of Lua tables allow, but can be forced externally if it's known that no iterators are pending.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormatTypeString | Formats a string with a type name and a ref-id (Inherited from RefIdObject.)
Public method | Get(Int32) | Gets the value associated with the specified key.
Public method | Get(Object) | Gets the value associated with the specified key. (expressed as a Object).
Public method | Get(Object) | Gets the value associated with the specified keys (expressed as an array of Object). This will marshall CLR and MoonSharp objects in the best possible way. Multiple keys can be used to access subtables.
Public method | Get(String) | Gets the value associated with the specified key.
Public method | Get(DynValue) | Gets the value associated with the specified key.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextKey | Returns the next pair from a value
Public method | RawGet(Int32) | Gets the value associated with the specified key, without bringing to Nil the non-existant values.
Public method | RawGet(Object) | Gets the value associated with the specified key, without bringing to Nil the non-existant values.
Public method | RawGet(Object) | Gets the value associated with the specified keys (expressed as an array of Object). This will marshall CLR and MoonSharp objects in the best possible way. Multiple keys can be used to access subtables.
Public method | RawGet(String) | Gets the value associated with the specified key, without bringing to Nil the non-existant values.
Public method | RawGet(DynValue) | Gets the value associated with the specified key, without bringing to Nil the non-existant values.
Public method | Remove(Int32) | Remove the value associated with the specified key from the table.
Public method | Remove(Object) | Remove the value associated with the specified key from the table.
Public method | Remove(Object) | Remove the value associated with the specified keys from the table. Multiple keys can be used to access subtables.
Public method | Remove(String) | Remove the value associated with the specified key from the table.
Public method | Remove(DynValue) | Remove the value associated with the specified key from the table.
Public method | Set(Int32, DynValue) | Sets the value associated to the specified key.
Public method | Set(Object, DynValue) | Sets the value associated with the specified key.
Public method | Set(Object, DynValue) | Sets the value associated with the specified keys. Multiple keys can be used to access subtables.
Public method | Set(String, DynValue) | Sets the value associated to the specified key.
Public method | Set(DynValue, DynValue) | Sets the value associated to the specified key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | RegisterConstants | Registers the standard constants (_G, _VERSION, _MOONSHARP) to a table (Defined by ModuleRegister.)
Public Extension Method | RegisterCoreModules | Register the core modules to a table (Defined by ModuleRegister.)
Public Extension Method | RegisterModuleType(Type) | Overloaded. Registers a module type to the specified table (Defined by ModuleRegister.)
Public Extension Method | RegisterModuleTypeT | Overloaded. Registers a module type to the specified table (Defined by ModuleRegister.)
Public Extension Method | Serialize | (Defined by SerializationExtensions.)
Public Extension Method | TableToJson | Converts a table to a json string (Defined by JsonTableConverter.)
Top
See Also

Reference

Table Class
MoonSharp.Interpreter Namespace


Table.Append Method

TableAppend Method
Append the value to the table using the next available integer index.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void Append(
    DynValue value
)
Public Sub Append (
    value As DynValue
)
public:
void Append(
    DynValue^ value
)
member Append :
        value : DynValue -> unit

Parameters

value
Type: MoonSharp.InterpreterDynValue
The value.
See Also

Reference

Table Class
MoonSharp.Interpreter Namespace


Table.Clear Method

TableClear Method
Removes all items from the Table.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Table Class
MoonSharp.Interpreter Namespace


Table.CollectDeadKeys Method

TableCollectDeadKeys Method
Collects the dead keys. This frees up memory but invalidates pending iterators. It's called automatically internally when the semantics of Lua tables allow, but can be forced externally if it's known that no iterators are pending.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void CollectDeadKeys()
Public Sub CollectDeadKeys
public:
void CollectDeadKeys()
member CollectDeadKeys : unit -> unit
See Also

Reference

Table Class
MoonSharp.Interpreter Namespace


Table.Get Method

TableGet Method
Overload List
 | Name | Description
Public method | Get(Int32) | Gets the value associated with the specified key.
Public method | Get(Object) | Gets the value associated with the specified key. (expressed as a Object).
Public method | Get(Object) | Gets the value associated with the specified keys (expressed as an array of Object). This will marshall CLR and MoonSharp objects in the best possible way. Multiple keys can be used to access subtables.
Public method | Get(String) | Gets the value associated with the specified key.
Public method | Get(DynValue) | Gets the value associated with the specified key.
Top
See Also

Reference

Table Class
MoonSharp.Interpreter Namespace


Table.Get Method (Int32)

TableGet Method (Int32)
Gets the value associated with the specified key.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Get(
    int key
)
Public Function Get (
    key As Integer
) As DynValue
public:
DynValue^ Get(
    int key
)
member Get :
        key : int -> DynValue

Parameters

key
Type: SystemInt32
The key.

Return Value

Type: DynValue
See Also

Reference

Table Class
Get Overload
MoonSharp.Interpreter Namespace


Table.Get Method (Object)

TableGet Method (Object)
Gets the value associated with the specified key. (expressed as a Object).

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Get(
    Object key
)
Public Function Get (
    key As Object
) As DynValue
public:
DynValue^ Get(
    Object^ key
)
member Get :
        key : Object -> DynValue

Parameters

key
Type: SystemObject
The key.

Return Value

Type: DynValue
See Also

Reference

Table Class
Get Overload
MoonSharp.Interpreter Namespace


Table.Get Method (Object[])

TableGet Method (Object)
Gets the value associated with the specified keys (expressed as an array of Object). This will marshall CLR and MoonSharp objects in the best possible way. Multiple keys can be used to access subtables.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Get(
    params Object[] keys
)
Public Function Get (
    ParamArray keys As Object()
) As DynValue
public:
DynValue^ Get(
    ... array<Object^>^ keys
)
member Get :
        keys : Object[] -> DynValue

Parameters

keys
Type: SystemObject
The keys to access the table and subtables

Return Value

Type: DynValue
See Also

Reference

Table Class
Get Overload
MoonSharp.Interpreter Namespace


Table.Get Method (String)

TableGet Method (String)
Gets the value associated with the specified key.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Get(
    string key
)
Public Function Get (
    key As String
) As DynValue
public:
DynValue^ Get(
    String^ key
)
member Get :
        key : string -> DynValue

Parameters

key
Type: SystemString
The key.

Return Value

Type: DynValue
See Also

Reference

Table Class
Get Overload
MoonSharp.Interpreter Namespace


Table.Get Method (DynValue)

TableGet Method (DynValue)
Gets the value associated with the specified key.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Get(
    DynValue key
)
Public Function Get (
    key As DynValue
) As DynValue
public:
DynValue^ Get(
    DynValue^ key
)
member Get :
        key : DynValue -> DynValue

Parameters

key
Type: MoonSharp.InterpreterDynValue
The key.

Return Value

Type: DynValue
See Also

Reference

Table Class
Get Overload
MoonSharp.Interpreter Namespace


Table.NextKey Method

TableNextKey Method
Returns the next pair from a value

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TablePair> NextKey(
    DynValue v
)
Public Function NextKey (
    v As DynValue
) As Nullable(Of TablePair)
public:
Nullable<TablePair> NextKey(
    DynValue^ v
)
member NextKey :
        v : DynValue -> Nullable<TablePair>

Parameters

v
Type: MoonSharp.InterpreterDynValue

[Missing <param name="v"/> documentation for "M:MoonSharp.Interpreter.Table.NextKey(MoonSharp.Interpreter.DynValue)"]

Return Value

Type: Nullable TablePair
See Also

Reference

Table Class
MoonSharp.Interpreter Namespace


Table.RawGet Method

TableRawGet Method
Overload List
 | Name | Description
Public method | RawGet(Int32) | Gets the value associated with the specified key, without bringing to Nil the non-existant values.
Public method | RawGet(Object) | Gets the value associated with the specified key, without bringing to Nil the non-existant values.
Public method | RawGet(Object) | Gets the value associated with the specified keys (expressed as an array of Object). This will marshall CLR and MoonSharp objects in the best possible way. Multiple keys can be used to access subtables.
Public method | RawGet(String) | Gets the value associated with the specified key, without bringing to Nil the non-existant values.
Public method | RawGet(DynValue) | Gets the value associated with the specified key, without bringing to Nil the non-existant values.
Top
See Also

Reference

Table Class
MoonSharp.Interpreter Namespace


Table.RawGet Method (Int32)

TableRawGet Method (Int32)
Gets the value associated with the specified key, without bringing to Nil the non-existant values.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue RawGet(
    int key
)
Public Function RawGet (
    key As Integer
) As DynValue
public:
DynValue^ RawGet(
    int key
)
member RawGet :
        key : int -> DynValue

Parameters

key
Type: SystemInt32
The key.

Return Value

Type: DynValue
See Also

Reference

Table Class
RawGet Overload
MoonSharp.Interpreter Namespace


Table.RawGet Method (Object)

TableRawGet Method (Object)
Gets the value associated with the specified key, without bringing to Nil the non-existant values.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue RawGet(
    Object key
)
Public Function RawGet (
    key As Object
) As DynValue
public:
DynValue^ RawGet(
    Object^ key
)
member RawGet :
        key : Object -> DynValue

Parameters

key
Type: SystemObject
The key.

Return Value

Type: DynValue
See Also

Reference

Table Class
RawGet Overload
MoonSharp.Interpreter Namespace


Table.RawGet Method (Object[])

TableRawGet Method (Object)
Gets the value associated with the specified keys (expressed as an array of Object). This will marshall CLR and MoonSharp objects in the best possible way. Multiple keys can be used to access subtables.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue RawGet(
    params Object[] keys
)
Public Function RawGet (
    ParamArray keys As Object()
) As DynValue
public:
DynValue^ RawGet(
    ... array<Object^>^ keys
)
member RawGet :
        keys : Object[] -> DynValue

Parameters

keys
Type: SystemObject
The keys to access the table and subtables

Return Value

Type: DynValue
See Also

Reference

Table Class
RawGet Overload
MoonSharp.Interpreter Namespace


Table.RawGet Method (String)

TableRawGet Method (String)
Gets the value associated with the specified key, without bringing to Nil the non-existant values.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue RawGet(
    string key
)
Public Function RawGet (
    key As String
) As DynValue
public:
DynValue^ RawGet(
    String^ key
)
member RawGet :
        key : string -> DynValue

Parameters

key
Type: SystemString
The key.

Return Value

Type: DynValue
See Also

Reference

Table Class
RawGet Overload
MoonSharp.Interpreter Namespace


Table.RawGet Method (DynValue)

TableRawGet Method (DynValue)
Gets the value associated with the specified key, without bringing to Nil the non-existant values.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue RawGet(
    DynValue key
)
Public Function RawGet (
    key As DynValue
) As DynValue
public:
DynValue^ RawGet(
    DynValue^ key
)
member RawGet :
        key : DynValue -> DynValue

Parameters

key
Type: MoonSharp.InterpreterDynValue
The key.

Return Value

Type: DynValue
See Also

Reference

Table Class
RawGet Overload
MoonSharp.Interpreter Namespace


Table.Remove Method

TableRemove Method
Overload List
 | Name | Description
Public method | Remove(Int32) | Remove the value associated with the specified key from the table.
Public method | Remove(Object) | Remove the value associated with the specified key from the table.
Public method | Remove(Object) | Remove the value associated with the specified keys from the table. Multiple keys can be used to access subtables.
Public method | Remove(String) | Remove the value associated with the specified key from the table.
Public method | Remove(DynValue) | Remove the value associated with the specified key from the table.
Top
See Also

Reference

Table Class
MoonSharp.Interpreter Namespace


Table.Remove Method (Int32)

TableRemove Method (Int32)
Remove the value associated with the specified key from the table.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    int key
)
Public Function Remove (
    key As Integer
) As Boolean
public:
bool Remove(
    int key
)
member Remove :
        key : int -> bool

Parameters

key
Type: SystemInt32
The key.

Return Value

Type: Boolean
true if values was successfully removed; otherwise, false.
See Also

Reference

Table Class
Remove Overload
MoonSharp.Interpreter Namespace


Table.Remove Method (Object)

TableRemove Method (Object)
Remove the value associated with the specified key from the table.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    Object key
)
Public Function Remove (
    key As Object
) As Boolean
public:
bool Remove(
    Object^ key
)
member Remove :
        key : Object -> bool

Parameters

key
Type: SystemObject
The key.

Return Value

Type: Boolean
true if values was successfully removed; otherwise, false.
See Also

Reference

Table Class
Remove Overload
MoonSharp.Interpreter Namespace


Table.Remove Method (Object[])

TableRemove Method (Object)
Remove the value associated with the specified keys from the table. Multiple keys can be used to access subtables.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    params Object[] keys
)
Public Function Remove (
    ParamArray keys As Object()
) As Boolean
public:
bool Remove(
    ... array<Object^>^ keys
)
member Remove :
        keys : Object[] -> bool

Parameters

keys
Type: SystemObject

[Missing <param name="keys"/> documentation for "M:MoonSharp.Interpreter.Table.Remove(System.Object[])"]

Return Value

Type: Boolean
true if values was successfully removed; otherwise, false.
See Also

Reference

Table Class
Remove Overload
MoonSharp.Interpreter Namespace


Table.Remove Method (String)

TableRemove Method (String)
Remove the value associated with the specified key from the table.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    string key
)
Public Function Remove (
    key As String
) As Boolean
public:
bool Remove(
    String^ key
)
member Remove :
        key : string -> bool

Parameters

key
Type: SystemString
The key.

Return Value

Type: Boolean
true if values was successfully removed; otherwise, false.
See Also

Reference

Table Class
Remove Overload
MoonSharp.Interpreter Namespace


Table.Remove Method (DynValue)

TableRemove Method (DynValue)
Remove the value associated with the specified key from the table.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    DynValue key
)
Public Function Remove (
    key As DynValue
) As Boolean
public:
bool Remove(
    DynValue^ key
)
member Remove :
        key : DynValue -> bool

Parameters

key
Type: MoonSharp.InterpreterDynValue
The key.

Return Value

Type: Boolean
true if values was successfully removed; otherwise, false.
See Also

Reference

Table Class
Remove Overload
MoonSharp.Interpreter Namespace


Table.Set Method

TableSet Method
Overload List
 | Name | Description
Public method | Set(Int32, DynValue) | Sets the value associated to the specified key.
Public method | Set(Object, DynValue) | Sets the value associated with the specified key.
Public method | Set(Object, DynValue) | Sets the value associated with the specified keys. Multiple keys can be used to access subtables.
Public method | Set(String, DynValue) | Sets the value associated to the specified key.
Public method | Set(DynValue, DynValue) | Sets the value associated to the specified key.
Top
See Also

Reference

Table Class
MoonSharp.Interpreter Namespace


Table.Set Method (Int32, DynValue)

TableSet Method (Int32, DynValue)
Sets the value associated to the specified key.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void Set(
    int key,
    DynValue value
)
Public Sub Set (
    key As Integer,
    value As DynValue
)
public:
void Set(
    int key,
    DynValue^ value
)
member Set :
        key : int *
        value : DynValue -> unit

Parameters

key
Type: SystemInt32
The key.
value
Type: MoonSharp.InterpreterDynValue
The value.
See Also

Reference

Table Class
Set Overload
MoonSharp.Interpreter Namespace


Table.Set Method (Object, DynValue)

TableSet Method (Object, DynValue)
Sets the value associated with the specified key.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void Set(
    Object key,
    DynValue value
)
Public Sub Set (
    key As Object,
    value As DynValue
)
public:
void Set(
    Object^ key,
    DynValue^ value
)
member Set :
        key : Object *
        value : DynValue -> unit

Parameters

key
Type: SystemObject
The key.
value
Type: MoonSharp.InterpreterDynValue
The value.
See Also

Reference

Table Class
Set Overload
MoonSharp.Interpreter Namespace


Table.Set Method (Object[], DynValue)

TableSet Method (Object, DynValue)
Sets the value associated with the specified keys. Multiple keys can be used to access subtables.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void Set(
    Object[] keys,
    DynValue value
)
Public Sub Set (
    keys As Object(),
    value As DynValue
)
public:
void Set(
    array<Object^>^ keys,
    DynValue^ value
)
member Set :
        keys : Object[] *
        value : DynValue -> unit

Parameters

keys
Type: SystemObject

[Missing <param name="keys"/> documentation for "M:MoonSharp.Interpreter.Table.Set(System.Object[],MoonSharp.Interpreter.DynValue)"]

value
Type: MoonSharp.InterpreterDynValue
The value.
See Also

Reference

Table Class
Set Overload
MoonSharp.Interpreter Namespace


Table.Set Method (String, DynValue)

TableSet Method (String, DynValue)
Sets the value associated to the specified key.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void Set(
    string key,
    DynValue value
)
Public Sub Set (
    key As String,
    value As DynValue
)
public:
void Set(
    String^ key,
    DynValue^ value
)
member Set :
        key : string *
        value : DynValue -> unit

Parameters

key
Type: SystemString
The key.
value
Type: MoonSharp.InterpreterDynValue
The value.
See Also

Reference

Table Class
Set Overload
MoonSharp.Interpreter Namespace


Table.Set Method (DynValue, DynValue)

TableSet Method (DynValue, DynValue)
Sets the value associated to the specified key.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void Set(
    DynValue key,
    DynValue value
)
Public Sub Set (
    key As DynValue,
    value As DynValue
)
public:
void Set(
    DynValue^ key,
    DynValue^ value
)
member Set :
        key : DynValue *
        value : DynValue -> unit

Parameters

key
Type: MoonSharp.InterpreterDynValue
The key.
value
Type: MoonSharp.InterpreterDynValue
The value.
See Also

Reference

Table Class
Set Overload
MoonSharp.Interpreter Namespace


TablePair Structure

TablePair Structure
A class representing a key/value pair for Table use

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public struct TablePair
Public Structure TablePair
public value class TablePair
[<SealedAttribute>]
type TablePair =  struct end

The TablePair type exposes the following members.

Constructors
 | Name | Description
Public method | TablePair | Initializes a new instance of the TablePair struct.
Top
Properties
 | Name | Description
Public property | Key | Gets the key.
 | Nil | Gets the nil pair
Public property | Value | Gets or sets the value.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


TablePair Constructor

TablePair Constructor
Initializes a new instance of the TablePair struct.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public TablePair(
    DynValue key,
    DynValue val
)
Public Sub New (
    key As DynValue,
    val As DynValue
)
public:
TablePair(
    DynValue^ key,
    DynValue^ val
)
new :
        key : DynValue *
        val : DynValue -> TablePair

Parameters

key
Type: MoonSharp.InterpreterDynValue
The key.
val
Type: MoonSharp.InterpreterDynValue
The value.
See Also

Reference

TablePair Structure
MoonSharp.Interpreter Namespace


TablePair Properties

TablePair Properties

The TablePair type exposes the following members.

Properties
 | Name | Description
Public property | Key | Gets the key.
 | Nil | Gets the nil pair
Public property | Value | Gets or sets the value.
Top
See Also

Reference

TablePair Structure
MoonSharp.Interpreter Namespace


TablePair.Key Property

TablePairKey Property
Gets the key.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Key { get; }
Public ReadOnly Property Key As DynValue
    Get
public:
property DynValue^ Key {
    DynValue^ get ();
}
member Key : DynValue with get

Property Value

Type: DynValue
See Also

Reference

TablePair Structure
MoonSharp.Interpreter Namespace


TablePair.Nil Property

TablePairNil Property
Gets the nil pair

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static TablePair Nil { get; }
Public Shared ReadOnly Property Nil As TablePair
    Get
public:
static property TablePair Nil {
    TablePair get ();
}
static member Nil : TablePair with get

Property Value

Type: TablePair
See Also

Reference

TablePair Structure
MoonSharp.Interpreter Namespace


TablePair.Value Property

TablePairValue Property
Gets or sets the value.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Value { get; set; }
Public Property Value As DynValue
    Get
    Set
public:
property DynValue^ Value {
    DynValue^ get ();
    void set (DynValue^ value);
}
member Value : DynValue with get, set

Property Value

Type: DynValue
See Also

Reference

TablePair Structure
MoonSharp.Interpreter Namespace


TablePair Methods

TablePair Methods

The TablePair type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

TablePair Structure
MoonSharp.Interpreter Namespace


TailCallData Class

TailCallData Class
Class used to support "tail" continuations - a way for C# / Lua interaction which supports coroutine yielding (at the expense of a LOT of added complexity in calling code).
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterTailCallData

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class TailCallData
Public Class TailCallData
public ref class TailCallData
type TailCallData =  class end

The TailCallData type exposes the following members.

Constructors
 | Name | Description
Public method | TailCallData | Initializes a new instance of the TailCallData class
Top
Properties
 | Name | Description
Public property | Args | Gets or sets the arguments to the function
Public property | Continuation | Gets or sets the callback to be used as a continuation.
Public property | ErrorHandler | Gets or sets the callback to be used in case of errors.
Public property | ErrorHandlerBeforeUnwind | Gets or sets the error handler to be called before stack unwinding
Public property | Function | Gets or sets the function to call
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter Namespace


TailCallData Constructor

TailCallData Constructor
Initializes a new instance of the TailCallData class

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public TailCallData()
Public Sub New
public:
TailCallData()
new : unit -> TailCallData
See Also

Reference

TailCallData Class
MoonSharp.Interpreter Namespace


TailCallData Properties

TailCallData Properties

The TailCallData type exposes the following members.

Properties
 | Name | Description
Public property | Args | Gets or sets the arguments to the function
Public property | Continuation | Gets or sets the callback to be used as a continuation.
Public property | ErrorHandler | Gets or sets the callback to be used in case of errors.
Public property | ErrorHandlerBeforeUnwind | Gets or sets the error handler to be called before stack unwinding
Public property | Function | Gets or sets the function to call
Top
See Also

Reference

TailCallData Class
MoonSharp.Interpreter Namespace


TailCallData.Args Property

TailCallDataArgs Property
Gets or sets the arguments to the function

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue[] Args { get; set; }
Public Property Args As DynValue()
    Get
    Set
public:
property array<DynValue^>^ Args {
    array<DynValue^>^ get ();
    void set (array<DynValue^>^ value);
}
member Args : DynValue[] with get, set

Property Value

Type: DynValue
See Also

Reference

TailCallData Class
MoonSharp.Interpreter Namespace


TailCallData.Continuation Property

TailCallDataContinuation Property
Gets or sets the callback to be used as a continuation.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CallbackFunction Continuation { get; set; }
Public Property Continuation As CallbackFunction
    Get
    Set
public:
property CallbackFunction^ Continuation {
    CallbackFunction^ get ();
    void set (CallbackFunction^ value);
}
member Continuation : CallbackFunction with get, set

Property Value

Type: CallbackFunction
See Also

Reference

TailCallData Class
MoonSharp.Interpreter Namespace


TailCallData.ErrorHandler Property

TailCallDataErrorHandler Property
Gets or sets the callback to be used in case of errors.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CallbackFunction ErrorHandler { get; set; }
Public Property ErrorHandler As CallbackFunction
    Get
    Set
public:
property CallbackFunction^ ErrorHandler {
    CallbackFunction^ get ();
    void set (CallbackFunction^ value);
}
member ErrorHandler : CallbackFunction with get, set

Property Value

Type: CallbackFunction
See Also

Reference

TailCallData Class
MoonSharp.Interpreter Namespace


TailCallData.ErrorHandlerBeforeUnwind Property

TailCallDataErrorHandlerBeforeUnwind Property
Gets or sets the error handler to be called before stack unwinding

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue ErrorHandlerBeforeUnwind { get; set; }
Public Property ErrorHandlerBeforeUnwind As DynValue
    Get
    Set
public:
property DynValue^ ErrorHandlerBeforeUnwind {
    DynValue^ get ();
    void set (DynValue^ value);
}
member ErrorHandlerBeforeUnwind : DynValue with get, set

Property Value

Type: DynValue
See Also

Reference

TailCallData Class
MoonSharp.Interpreter Namespace


TailCallData.Function Property

TailCallDataFunction Property
Gets or sets the function to call

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Function { get; set; }
Public Property Function As DynValue
    Get
    Set
public:
property DynValue^ Function {
    DynValue^ get ();
    void set (DynValue^ value);
}
member Function : DynValue with get, set

Property Value

Type: DynValue
See Also

Reference

TailCallData Class
MoonSharp.Interpreter Namespace


TailCallData Methods

TailCallData Methods

The TailCallData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TailCallData Class
MoonSharp.Interpreter Namespace


TypeValidationFlags Enumeration

TypeValidationFlags Enumeration
Flags to alter the way the DynValue.CheckType and other related functions operate on data types for validation.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum TypeValidationFlags
<FlagsAttribute>
Public Enumeration TypeValidationFlags
[FlagsAttribute]
public enum class TypeValidationFlags
[<FlagsAttribute>]
type TypeValidationFlags
Members
Member name | Value | Description
None | 0 | No type validation specific behaviour
AllowNil | 1 | Nil and Void values are allowed (and returned by the call)
AutoConvert | 2 | Simple autoconversions are attempted: 1) Numbers are convertible to strings 2) Strings are convertible to numbers if they contain a number 3) Everything is convertible to boolean (with void and nil converting to 'false', everything else converting to 'true') Note: if both AutoConvert and AllowNil are specified, nils will NOT be converted to false booleans.
Default | 2 | The default : Autoconverting values, no nils.
See Also

Reference

MoonSharp.Interpreter Namespace


UserData Class

UserData Class
Class exposing C# objects as Lua userdata. For efficiency, a global registry of types is maintained, instead of a per-script one.
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterRefIdObject
MoonSharp.InterpreterUserData

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class UserData : RefIdObject
Public Class UserData
    Inherits RefIdObject
public ref class UserData : public RefIdObject
type UserData =
    class
        inherit RefIdObject
    end

The UserData type exposes the following members.

Properties
 | Name | Description
 | DefaultAccessMode | Gets or sets the default access mode to be used in the whole application
Public property | Descriptor | Gets the type descriptor of this userdata
Public property | Object | Gets the object associated to this userdata (null for statics)
Public property | ReferenceID | Gets the reference identifier. (Inherited from RefIdObject.)
 | RegistrationPolicy | Gets or sets the registration policy to be used in the whole application
Public property | UserValue | Gets or sets the "uservalue". See debug.getuservalue and debug.setuservalue. http://www.lua.org/manual/5.2/manual.html#pdf-debug.setuservalue
Top
Methods
 | Name | Description
 | Create(Object) | Creates a userdata DynValue from the specified object
 | Create(Object, IUserDataDescriptor) | Creates a userdata DynValue from the specified object, using a specific descriptor
 | CreateStatic(Type) | Creates a static userdata DynValue from the specified Type
 | CreateStatic(IUserDataDescriptor) | Creates a static userdata DynValue from the specified IUserDataDescriptor
 | CreateStaticT | Creates a static userdata DynValue from the specified Type
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormatTypeString | Formats a string with a type name and a ref-id (Inherited from RefIdObject.)
 | GetDescriptionOfRegisteredTypes | Gets a table with the description of registered types.
 | GetDescriptorForObject | Gets the best possible type descriptor for a specified CLR object.
 | GetDescriptorForType(Type, Boolean) | Gets the best possible type descriptor for a specified CLR type.
 | GetDescriptorForTypeT(Boolean) | Gets the best possible type descriptor for a specified CLR type.
 | GetExtensionMethodsByNameAndType | Gets all the extension methods which can match a given name and extending a given Type
 | GetExtensionMethodsChangeVersion | Gets a number which gets incremented everytime the extension methods registry changes. Use this to invalidate caches based on extension methods
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetRegisteredTypes | Gets all the registered types.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsTypeRegistered(Type) | Determines whether the specified type is registered. Note that this should be used only to check if a descriptor has been registered EXACTLY. For many types a descriptor can still be created, for example through the descriptor of a base type or implemented interfaces.
 | IsTypeRegisteredT | Determines whether the specified type is registered. Note that this should be used only to check if a descriptor has been registered EXACTLY. For many types a descriptor can still be created, for example through the descriptor of a base type or implemented interfaces.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterAssembly | Registers all types marked with a MoonSharpUserDataAttribute that ar contained in an assembly.
 | RegisterExtensionType | Registers an extension Type (that is a type containing extension methods)
 | RegisterProxyType(IProxyFactory, InteropAccessMode, String) | Registers a proxy type.
 | RegisterProxyTypeTProxy, TTarget(FuncTTarget, TProxy, InteropAccessMode, String) | Registers a proxy type using a delegate.
 | RegisterType(IUserDataDescriptor) | Registers a type with a custom userdata descriptor
 | RegisterType(Type, IUserDataDescriptor) | Registers a type with a custom userdata descriptor
 | RegisterType(Type, InteropAccessMode, String) | Registers a type for userdata interop
 | RegisterTypeT(IUserDataDescriptor) | Registers a type with a custom userdata descriptor
 | RegisterTypeT(InteropAccessMode, String) | Registers a type for userdata interop
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UnregisterType(Type) | Unregisters a type. WARNING: unregistering types at runtime is a dangerous practice and may cause unwanted errors. Use this only for testing purposes or to re-register the same type in a slightly different way. Additionally, it's a good practice to discard all previous loaded scripts after calling this method.
 | UnregisterTypeT | Unregisters a type. WARNING: unregistering types at runtime is a dangerous practice and may cause unwanted errors. Use this only for testing purposes or to re-register the same type in a slightly different way. Additionally, it's a good practice to discard all previous loaded scripts after calling this method.
Top
See Also

Reference

MoonSharp.Interpreter Namespace


UserData Properties

UserData Properties

The UserData type exposes the following members.

Properties
 | Name | Description
 | DefaultAccessMode | Gets or sets the default access mode to be used in the whole application
Public property | Descriptor | Gets the type descriptor of this userdata
Public property | Object | Gets the object associated to this userdata (null for statics)
Public property | ReferenceID | Gets the reference identifier. (Inherited from RefIdObject.)
 | RegistrationPolicy | Gets or sets the registration policy to be used in the whole application
Public property | UserValue | Gets or sets the "uservalue". See debug.getuservalue and debug.setuservalue. http://www.lua.org/manual/5.2/manual.html#pdf-debug.setuservalue
Top
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.DefaultAccessMode Property

UserDataDefaultAccessMode Property
Gets or sets the default access mode to be used in the whole application

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static InteropAccessMode DefaultAccessMode { get; set; }
Public Shared Property DefaultAccessMode As InteropAccessMode
    Get
    Set
public:
static property InteropAccessMode DefaultAccessMode {
    InteropAccessMode get ();
    void set (InteropAccessMode value);
}
static member DefaultAccessMode : InteropAccessMode with get, set

Property Value

Type: InteropAccessMode
The default access mode.
Exceptions
Exception | Condition
ArgumentException | InteropAccessMode is InteropAccessMode.Default
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.Descriptor Property

UserDataDescriptor Property
Gets the type descriptor of this userdata

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IUserDataDescriptor Descriptor { get; }
Public ReadOnly Property Descriptor As IUserDataDescriptor
    Get
public:
property IUserDataDescriptor^ Descriptor {
    IUserDataDescriptor^ get ();
}
member Descriptor : IUserDataDescriptor with get

Property Value

Type: IUserDataDescriptor
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.Object Property

UserDataObject Property
Gets the object associated to this userdata (null for statics)

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Object Object { get; }
Public ReadOnly Property Object As Object
    Get
public:
property Object^ Object {
    Object^ get ();
}
member Object : Object with get

Property Value

Type: Object
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.RegistrationPolicy Property

UserDataRegistrationPolicy Property
Gets or sets the registration policy to be used in the whole application

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IRegistrationPolicy RegistrationPolicy { get; set; }
Public Shared Property RegistrationPolicy As IRegistrationPolicy
    Get
    Set
public:
static property IRegistrationPolicy^ RegistrationPolicy {
    IRegistrationPolicy^ get ();
    void set (IRegistrationPolicy^ value);
}
static member RegistrationPolicy : IRegistrationPolicy with get, set

Property Value

Type: IRegistrationPolicy
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.UserValue Property

UserDataUserValue Property
Gets or sets the "uservalue". See debug.getuservalue and debug.setuservalue. http://www.lua.org/manual/5.2/manual.html#pdf-debug.setuservalue

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue UserValue { get; set; }
Public Property UserValue As DynValue
    Get
    Set
public:
property DynValue^ UserValue {
    DynValue^ get ();
    void set (DynValue^ value);
}
member UserValue : DynValue with get, set

Property Value

Type: DynValue
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData Methods

UserData Methods

The UserData type exposes the following members.

Methods
 | Name | Description
 | Create(Object) | Creates a userdata DynValue from the specified object
 | Create(Object, IUserDataDescriptor) | Creates a userdata DynValue from the specified object, using a specific descriptor
 | CreateStatic(Type) | Creates a static userdata DynValue from the specified Type
 | CreateStatic(IUserDataDescriptor) | Creates a static userdata DynValue from the specified IUserDataDescriptor
 | CreateStaticT | Creates a static userdata DynValue from the specified Type
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormatTypeString | Formats a string with a type name and a ref-id (Inherited from RefIdObject.)
 | GetDescriptionOfRegisteredTypes | Gets a table with the description of registered types.
 | GetDescriptorForObject | Gets the best possible type descriptor for a specified CLR object.
 | GetDescriptorForType(Type, Boolean) | Gets the best possible type descriptor for a specified CLR type.
 | GetDescriptorForTypeT(Boolean) | Gets the best possible type descriptor for a specified CLR type.
 | GetExtensionMethodsByNameAndType | Gets all the extension methods which can match a given name and extending a given Type
 | GetExtensionMethodsChangeVersion | Gets a number which gets incremented everytime the extension methods registry changes. Use this to invalidate caches based on extension methods
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | GetRegisteredTypes | Gets all the registered types.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsTypeRegistered(Type) | Determines whether the specified type is registered. Note that this should be used only to check if a descriptor has been registered EXACTLY. For many types a descriptor can still be created, for example through the descriptor of a base type or implemented interfaces.
 | IsTypeRegisteredT | Determines whether the specified type is registered. Note that this should be used only to check if a descriptor has been registered EXACTLY. For many types a descriptor can still be created, for example through the descriptor of a base type or implemented interfaces.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterAssembly | Registers all types marked with a MoonSharpUserDataAttribute that ar contained in an assembly.
 | RegisterExtensionType | Registers an extension Type (that is a type containing extension methods)
 | RegisterProxyType(IProxyFactory, InteropAccessMode, String) | Registers a proxy type.
 | RegisterProxyTypeTProxy, TTarget(FuncTTarget, TProxy, InteropAccessMode, String) | Registers a proxy type using a delegate.
 | RegisterType(IUserDataDescriptor) | Registers a type with a custom userdata descriptor
 | RegisterType(Type, IUserDataDescriptor) | Registers a type with a custom userdata descriptor
 | RegisterType(Type, InteropAccessMode, String) | Registers a type for userdata interop
 | RegisterTypeT(IUserDataDescriptor) | Registers a type with a custom userdata descriptor
 | RegisterTypeT(InteropAccessMode, String) | Registers a type for userdata interop
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UnregisterType(Type) | Unregisters a type. WARNING: unregistering types at runtime is a dangerous practice and may cause unwanted errors. Use this only for testing purposes or to re-register the same type in a slightly different way. Additionally, it's a good practice to discard all previous loaded scripts after calling this method.
 | UnregisterTypeT | Unregisters a type. WARNING: unregistering types at runtime is a dangerous practice and may cause unwanted errors. Use this only for testing purposes or to re-register the same type in a slightly different way. Additionally, it's a good practice to discard all previous loaded scripts after calling this method.
Top
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.Create Method

UserDataCreate Method
Overload List
Name | Description
Create(Object) | Creates a userdata DynValue from the specified object
Create(Object, IUserDataDescriptor) | Creates a userdata DynValue from the specified object, using a specific descriptor
Top
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.Create Method (Object)

UserDataCreate Method (Object)
Creates a userdata DynValue from the specified object

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue Create(
    Object o
)
Public Shared Function Create (
    o As Object
) As DynValue
public:
static DynValue^ Create(
    Object^ o
)
static member Create :
        o : Object -> DynValue

Parameters

o
Type: SystemObject
The object

Return Value

Type: DynValue
See Also

Reference

UserData Class
Create Overload
MoonSharp.Interpreter Namespace


UserData.Create Method (Object, IUserDataDescriptor)

UserDataCreate Method (Object, IUserDataDescriptor)
Creates a userdata DynValue from the specified object, using a specific descriptor

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue Create(
    Object o,
    IUserDataDescriptor descr
)
Public Shared Function Create (
    o As Object,
    descr As IUserDataDescriptor
) As DynValue
public:
static DynValue^ Create(
    Object^ o,
    IUserDataDescriptor^ descr
)
static member Create :
        o : Object *
        descr : IUserDataDescriptor -> DynValue

Parameters

o
Type: SystemObject
The object
descr
Type: MoonSharp.Interpreter.InteropIUserDataDescriptor
The descriptor.

Return Value

Type: DynValue
See Also

Reference

UserData Class
Create Overload
MoonSharp.Interpreter Namespace


UserData.CreateStatic Method

UserDataCreateStatic Method
Overload List
Name | Description
CreateStaticT | Creates a static userdata DynValue from the specified Type
CreateStatic(Type) | Creates a static userdata DynValue from the specified Type
CreateStatic(IUserDataDescriptor) | Creates a static userdata DynValue from the specified IUserDataDescriptor
Top
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.CreateStatic(T) Method

UserDataCreateStaticT Method
Creates a static userdata DynValue from the specified Type

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue CreateStatic<T>()

Public Shared Function CreateStatic(Of T) As DynValue
public:
generic<typename T>
static DynValue^ CreateStatic()
static member CreateStatic : unit -> DynValue

Type Parameters

T
The Type

Return Value

Type: DynValue
See Also

Reference

UserData Class
CreateStatic Overload
MoonSharp.Interpreter Namespace


UserData.CreateStatic Method (Type)

UserDataCreateStatic Method (Type)
Creates a static userdata DynValue from the specified Type

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue CreateStatic(
    Type t
)
Public Shared Function CreateStatic (
    t As Type
) As DynValue
public:
static DynValue^ CreateStatic(
    Type^ t
)
static member CreateStatic :
        t : Type -> DynValue

Parameters

t
Type: SystemType
The type

Return Value

Type: DynValue
See Also

Reference

UserData Class
CreateStatic Overload
MoonSharp.Interpreter Namespace


UserData.CreateStatic Method (IUserDataDescriptor)

UserDataCreateStatic Method (IUserDataDescriptor)
Creates a static userdata DynValue from the specified IUserDataDescriptor

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue CreateStatic(
    IUserDataDescriptor descr
)
Public Shared Function CreateStatic (
    descr As IUserDataDescriptor
) As DynValue
public:
static DynValue^ CreateStatic(
    IUserDataDescriptor^ descr
)
static member CreateStatic :
        descr : IUserDataDescriptor -> DynValue

Parameters

descr
Type: MoonSharp.Interpreter.InteropIUserDataDescriptor
The IUserDataDescriptor

Return Value

Type: DynValue
See Also

Reference

UserData Class
CreateStatic Overload
MoonSharp.Interpreter Namespace


UserData.GetDescriptionOfRegisteredTypes Method

UserDataGetDescriptionOfRegisteredTypes Method
Gets a table with the description of registered types.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Table GetDescriptionOfRegisteredTypes(
    bool useHistoricalData = false
)
Public Shared Function GetDescriptionOfRegisteredTypes (
    Optional useHistoricalData As Boolean = false
) As Table
public:
static Table^ GetDescriptionOfRegisteredTypes(
    bool useHistoricalData = false
)
static member GetDescriptionOfRegisteredTypes :
        ?useHistoricalData : bool
(* Defaults:
        let _useHistoricalData = defaultArg useHistoricalData false
*)
-> Table

Parameters

useHistoricalData (Optional)
Type: SystemBoolean
if set to true, it will also include the last found descriptor of all unregistered types.

Return Value

Type: Table
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.GetDescriptorForObject Method

UserDataGetDescriptorForObject Method
Gets the best possible type descriptor for a specified CLR object.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IUserDataDescriptor GetDescriptorForObject(
    Object o
)
Public Shared Function GetDescriptorForObject (
    o As Object
) As IUserDataDescriptor
public:
static IUserDataDescriptor^ GetDescriptorForObject(
    Object^ o
)
static member GetDescriptorForObject :
        o : Object -> IUserDataDescriptor

Parameters

o
Type: SystemObject
The object.

Return Value

Type: IUserDataDescriptor
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.GetDescriptorForType Method

UserDataGetDescriptorForType Method
Overload List
Name | Description
GetDescriptorForTypeT(Boolean) | Gets the best possible type descriptor for a specified CLR type.
GetDescriptorForType(Type, Boolean) | Gets the best possible type descriptor for a specified CLR type.
Top
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.GetDescriptorForType(T) Method (Boolean)

UserDataGetDescriptorForTypeT Method (Boolean)
Gets the best possible type descriptor for a specified CLR type.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IUserDataDescriptor GetDescriptorForType<T>(
    bool searchInterfaces
)

Public Shared Function GetDescriptorForType(Of T) (
    searchInterfaces As Boolean
) As IUserDataDescriptor
public:
generic<typename T>
static IUserDataDescriptor^ GetDescriptorForType(
    bool searchInterfaces
)
static member GetDescriptorForType :
        searchInterfaces : bool -> IUserDataDescriptor

Parameters

searchInterfaces
Type: SystemBoolean
if set to true interfaces are used in the search.

Type Parameters

T
The CLR type for which the descriptor is desired.

Return Value

Type: IUserDataDescriptor
See Also

Reference

UserData Class
GetDescriptorForType Overload
MoonSharp.Interpreter Namespace


UserData.GetDescriptorForType Method (Type, Boolean)

UserDataGetDescriptorForType Method (Type, Boolean)
Gets the best possible type descriptor for a specified CLR type.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IUserDataDescriptor GetDescriptorForType(
    Type type,
    bool searchInterfaces
)
Public Shared Function GetDescriptorForType (
    type As Type,
    searchInterfaces As Boolean
) As IUserDataDescriptor
public:
static IUserDataDescriptor^ GetDescriptorForType(
    Type^ type,
    bool searchInterfaces
)
static member GetDescriptorForType :
        type : Type *
        searchInterfaces : bool -> IUserDataDescriptor

Parameters

type
Type: SystemType
The CLR type for which the descriptor is desired.
searchInterfaces
Type: SystemBoolean
if set to true interfaces are used in the search.

Return Value

Type: IUserDataDescriptor
See Also

Reference

UserData Class
GetDescriptorForType Overload
MoonSharp.Interpreter Namespace


UserData.GetExtensionMethodsByNameAndType Method

UserDataGetExtensionMethodsByNameAndType Method
Gets all the extension methods which can match a given name and extending a given Type

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static List<IOverloadableMemberDescriptor> GetExtensionMethodsByNameAndType(
    string name,
    Type extendedType
)
Public Shared Function GetExtensionMethodsByNameAndType (
    name As String,
    extendedType As Type
) As List(Of IOverloadableMemberDescriptor)
public:
static List<IOverloadableMemberDescriptor^>^ GetExtensionMethodsByNameAndType(
    String^ name,
    Type^ extendedType
)
static member GetExtensionMethodsByNameAndType :
        name : string *
        extendedType : Type -> List<IOverloadableMemberDescriptor>

Parameters

name
Type: SystemString
The name.
extendedType
Type: SystemType
The extended type.

Return Value

Type: List IOverloadableMemberDescriptor
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.GetExtensionMethodsChangeVersion Method

UserDataGetExtensionMethodsChangeVersion Method
Gets a number which gets incremented everytime the extension methods registry changes. Use this to invalidate caches based on extension methods

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static int GetExtensionMethodsChangeVersion()
Public Shared Function GetExtensionMethodsChangeVersion As Integer
public:
static int GetExtensionMethodsChangeVersion()
static member GetExtensionMethodsChangeVersion : unit -> int

Return Value

Type: Int32
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.GetRegisteredTypes Method

UserDataGetRegisteredTypes Method
Gets all the registered types.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<Type> GetRegisteredTypes(
    bool useHistoricalData = false
)
Public Shared Function GetRegisteredTypes (
    Optional useHistoricalData As Boolean = false
) As IEnumerable(Of Type)
public:
static IEnumerable<Type^>^ GetRegisteredTypes(
    bool useHistoricalData = false
)
static member GetRegisteredTypes :
        ?useHistoricalData : bool
(* Defaults:
        let _useHistoricalData = defaultArg useHistoricalData false
*)
-> IEnumerable<Type>

Parameters

useHistoricalData (Optional)
Type: SystemBoolean
if set to true, it will also include the last found descriptor of all unregistered types.

Return Value

Type: IEnumerable Type
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.IsTypeRegistered Method

UserDataIsTypeRegistered Method
Overload List
Name | Description
IsTypeRegisteredT | Determines whether the specified type is registered. Note that this should be used only to check if a descriptor has been registered EXACTLY. For many types a descriptor can still be created, for example through the descriptor of a base type or implemented interfaces.
IsTypeRegistered(Type) | Determines whether the specified type is registered. Note that this should be used only to check if a descriptor has been registered EXACTLY. For many types a descriptor can still be created, for example through the descriptor of a base type or implemented interfaces.
Top
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.IsTypeRegistered(T) Method

UserDataIsTypeRegisteredT Method
Determines whether the specified type is registered. Note that this should be used only to check if a descriptor has been registered EXACTLY. For many types a descriptor can still be created, for example through the descriptor of a base type or implemented interfaces.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsTypeRegistered<T>()

Public Shared Function IsTypeRegistered(Of T) As Boolean
public:
generic<typename T>
static bool IsTypeRegistered()
static member IsTypeRegistered : unit -> bool

Type Parameters

T
The type.

Return Value

Type: Boolean
See Also

Reference

UserData Class
IsTypeRegistered Overload
MoonSharp.Interpreter Namespace


UserData.IsTypeRegistered Method (Type)

UserDataIsTypeRegistered Method (Type)
Determines whether the specified type is registered. Note that this should be used only to check if a descriptor has been registered EXACTLY. For many types a descriptor can still be created, for example through the descriptor of a base type or implemented interfaces.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsTypeRegistered(
    Type t
)
Public Shared Function IsTypeRegistered (
    t As Type
) As Boolean
public:
static bool IsTypeRegistered(
    Type^ t
)
static member IsTypeRegistered :
        t : Type -> bool

Parameters

t
Type: SystemType
The type.

Return Value

Type: Boolean
See Also

Reference

UserData Class
IsTypeRegistered Overload
MoonSharp.Interpreter Namespace


UserData.RegisterAssembly Method

UserDataRegisterAssembly Method
Registers all types marked with a MoonSharpUserDataAttribute that ar contained in an assembly.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static void RegisterAssembly(
    Assembly asm = null,
    bool includeExtensionTypes = false
)
Public Shared Sub RegisterAssembly (
    Optional asm As Assembly = Nothing,
    Optional includeExtensionTypes As Boolean = false
)
public:
static void RegisterAssembly(
    Assembly^ asm = nullptr,
    bool includeExtensionTypes = false
)
static member RegisterAssembly :
        ?asm : Assembly *
        ?includeExtensionTypes : bool
(* Defaults:
        let _asm = defaultArg asm null
        let _includeExtensionTypes = defaultArg includeExtensionTypes false
*)
-> unit

Parameters

asm (Optional)
Type: System.ReflectionAssembly
The assembly.
includeExtensionTypes (Optional)
Type: SystemBoolean
if set to true extension types are registered to the appropriate registry.
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.RegisterExtensionType Method

UserDataRegisterExtensionType Method
Registers an extension Type (that is a type containing extension methods)

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static void RegisterExtensionType(
    Type type,
    InteropAccessMode mode = InteropAccessMode.Default
)
Public Shared Sub RegisterExtensionType (
    type As Type,
    Optional mode As InteropAccessMode = InteropAccessMode.Default
)
public:
static void RegisterExtensionType(
    Type^ type,
    InteropAccessMode mode = InteropAccessMode::Default
)
static member RegisterExtensionType :
        type : Type *
        ?mode : InteropAccessMode
(* Defaults:
        let _mode = defaultArg mode InteropAccessMode.Default
*)
-> unit

Parameters

type
Type: SystemType
The type.
mode (Optional)
Type: MoonSharp.InterpreterInteropAccessMode
The InteropAccessMode.
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.RegisterProxyType Method

UserDataRegisterProxyType Method
Overload List
Name | Description
RegisterProxyTypeTProxy, TTarget(FuncTTarget, TProxy, InteropAccessMode, String) | Registers a proxy type using a delegate.
RegisterProxyType(IProxyFactory, InteropAccessMode, String) | Registers a proxy type.
Top
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.RegisterProxyType(TProxy, TTarget) Method (Func(TTarget, TProxy), InteropAccessMode, String)

UserDataRegisterProxyTypeTProxy, TTarget Method (FuncTTarget, TProxy, InteropAccessMode, String)
Registers a proxy type using a delegate.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IUserDataDescriptor RegisterProxyType<TProxy, TTarget>(
    Func<TTarget, TProxy> wrapDelegate,
    InteropAccessMode accessMode = InteropAccessMode.Default,
    string friendlyName = null
)
where TProxy : class
where TTarget : class

Public Shared Function RegisterProxyType(Of TProxy As Class, TTarget As Class) (
    wrapDelegate As Func(Of TTarget, TProxy),
    Optional accessMode As InteropAccessMode = InteropAccessMode.Default,
    Optional friendlyName As String = Nothing
) As IUserDataDescriptor
public:
generic<typename TProxy, typename TTarget>
where TProxy : ref class
where TTarget : ref class
static IUserDataDescriptor^ RegisterProxyType(
    Func<TTarget, TProxy>^ wrapDelegate,
    InteropAccessMode accessMode = InteropAccessMode::Default,
    String^ friendlyName = nullptr
)
static member RegisterProxyType :
        wrapDelegate : Func<'TTarget, 'TProxy> *
        ?accessMode : InteropAccessMode *
        ?friendlyName : string
(* Defaults:
        let _accessMode = defaultArg accessMode InteropAccessMode.Default
        let _friendlyName = defaultArg friendlyName null
*)
-> IUserDataDescriptor  when 'TProxy : not struct when 'TTarget : not struct

Parameters

wrapDelegate
Type: SystemFunc TTarget, TProxy
A delegate creating a proxy object from a target object.
accessMode (Optional)
Type: MoonSharp.InterpreterInteropAccessMode
The access mode.
friendlyName (Optional)
Type: SystemString
A friendly name for the descriptor.

Type Parameters

TProxy
The type of the proxy.
TTarget
The type of the target.

Return Value

Type: IUserDataDescriptor
See Also

Reference

UserData Class
RegisterProxyType Overload
MoonSharp.Interpreter Namespace


UserData.RegisterProxyType Method (IProxyFactory, InteropAccessMode, String)

UserDataRegisterProxyType Method (IProxyFactory, InteropAccessMode, String)
Registers a proxy type.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IUserDataDescriptor RegisterProxyType(
    IProxyFactory proxyFactory,
    InteropAccessMode accessMode = InteropAccessMode.Default,
    string friendlyName = null
)
Public Shared Function RegisterProxyType (
    proxyFactory As IProxyFactory,
    Optional accessMode As InteropAccessMode = InteropAccessMode.Default,
    Optional friendlyName As String = Nothing
) As IUserDataDescriptor
public:
static IUserDataDescriptor^ RegisterProxyType(
    IProxyFactory^ proxyFactory,
    InteropAccessMode accessMode = InteropAccessMode::Default,
    String^ friendlyName = nullptr
)
static member RegisterProxyType :
        proxyFactory : IProxyFactory *
        ?accessMode : InteropAccessMode *
        ?friendlyName : string
(* Defaults:
        let _accessMode = defaultArg accessMode InteropAccessMode.Default
        let _friendlyName = defaultArg friendlyName null
*)
-> IUserDataDescriptor

Parameters

proxyFactory
Type: MoonSharp.Interpreter.InteropIProxyFactory
The proxy factory.
accessMode (Optional)
Type: MoonSharp.InterpreterInteropAccessMode
The access mode.
friendlyName (Optional)
Type: SystemString
A friendly name for the descriptor.

Return Value

Type: IUserDataDescriptor
See Also

Reference

UserData Class
RegisterProxyType Overload
MoonSharp.Interpreter Namespace


UserData.RegisterType Method

UserDataRegisterType Method
Overload List
Name | Description
RegisterTypeT(IUserDataDescriptor) | Registers a type with a custom userdata descriptor
RegisterType(IUserDataDescriptor) | Registers a type with a custom userdata descriptor
RegisterType(Type, IUserDataDescriptor) | Registers a type with a custom userdata descriptor
RegisterTypeT(InteropAccessMode, String) | Registers a type for userdata interop
RegisterType(Type, InteropAccessMode, String) | Registers a type for userdata interop
Top
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.RegisterType(T) Method (IUserDataDescriptor)

UserDataRegisterTypeT Method (IUserDataDescriptor)
Registers a type with a custom userdata descriptor

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IUserDataDescriptor RegisterType<T>(
    IUserDataDescriptor customDescriptor
)

Public Shared Function RegisterType(Of T) (
    customDescriptor As IUserDataDescriptor
) As IUserDataDescriptor
public:
generic<typename T>
static IUserDataDescriptor^ RegisterType(
    IUserDataDescriptor^ customDescriptor
)
static member RegisterType :
        customDescriptor : IUserDataDescriptor -> IUserDataDescriptor

Parameters

customDescriptor
Type: MoonSharp.Interpreter.InteropIUserDataDescriptor
The custom descriptor.

Type Parameters

T
The type to be registered

Return Value

Type: IUserDataDescriptor
See Also

Reference

UserData Class
RegisterType Overload
MoonSharp.Interpreter Namespace


UserData.RegisterType Method (IUserDataDescriptor)

UserDataRegisterType Method (IUserDataDescriptor)
Registers a type with a custom userdata descriptor

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IUserDataDescriptor RegisterType(
    IUserDataDescriptor customDescriptor
)
Public Shared Function RegisterType (
    customDescriptor As IUserDataDescriptor
) As IUserDataDescriptor
public:
static IUserDataDescriptor^ RegisterType(
    IUserDataDescriptor^ customDescriptor
)
static member RegisterType :
        customDescriptor : IUserDataDescriptor -> IUserDataDescriptor

Parameters

customDescriptor
Type: MoonSharp.Interpreter.InteropIUserDataDescriptor
The custom descriptor.

Return Value

Type: IUserDataDescriptor
See Also

Reference

UserData Class
RegisterType Overload
MoonSharp.Interpreter Namespace


UserData.RegisterType Method (Type, IUserDataDescriptor)

UserDataRegisterType Method (Type, IUserDataDescriptor)
Registers a type with a custom userdata descriptor

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IUserDataDescriptor RegisterType(
    Type type,
    IUserDataDescriptor customDescriptor
)
Public Shared Function RegisterType (
    type As Type,
    customDescriptor As IUserDataDescriptor
) As IUserDataDescriptor
public:
static IUserDataDescriptor^ RegisterType(
    Type^ type,
    IUserDataDescriptor^ customDescriptor
)
static member RegisterType :
        type : Type *
        customDescriptor : IUserDataDescriptor -> IUserDataDescriptor

Parameters

type
Type: SystemType
The type to be registered
customDescriptor
Type: MoonSharp.Interpreter.InteropIUserDataDescriptor
The custom descriptor.

Return Value

Type: IUserDataDescriptor
See Also

Reference

UserData Class
RegisterType Overload
MoonSharp.Interpreter Namespace


UserData.RegisterType(T) Method (InteropAccessMode, String)

UserDataRegisterTypeT Method (InteropAccessMode, String)
Registers a type for userdata interop

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IUserDataDescriptor RegisterType<T>(
    InteropAccessMode accessMode = InteropAccessMode.Default,
    string friendlyName = null
)

Public Shared Function RegisterType(Of T) (
    Optional accessMode As InteropAccessMode = InteropAccessMode.Default,
    Optional friendlyName As String = Nothing
) As IUserDataDescriptor
public:
generic<typename T>
static IUserDataDescriptor^ RegisterType(
    InteropAccessMode accessMode = InteropAccessMode::Default,
    String^ friendlyName = nullptr
)
static member RegisterType :
        ?accessMode : InteropAccessMode *
        ?friendlyName : string
(* Defaults:
        let _accessMode = defaultArg accessMode InteropAccessMode.Default
        let _friendlyName = defaultArg friendlyName null
*)
-> IUserDataDescriptor

Parameters

accessMode (Optional)
Type: MoonSharp.InterpreterInteropAccessMode
The access mode (optional).
friendlyName (Optional)
Type: SystemString
Friendly name for the type (optional)

Type Parameters

T
The type to be registered

Return Value

Type: IUserDataDescriptor
See Also

Reference

UserData Class
RegisterType Overload
MoonSharp.Interpreter Namespace


UserData.RegisterType Method (Type, InteropAccessMode, String)

UserDataRegisterType Method (Type, InteropAccessMode, String)
Registers a type for userdata interop

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IUserDataDescriptor RegisterType(
    Type type,
    InteropAccessMode accessMode = InteropAccessMode.Default,
    string friendlyName = null
)
Public Shared Function RegisterType (
    type As Type,
    Optional accessMode As InteropAccessMode = InteropAccessMode.Default,
    Optional friendlyName As String = Nothing
) As IUserDataDescriptor
public:
static IUserDataDescriptor^ RegisterType(
    Type^ type,
    InteropAccessMode accessMode = InteropAccessMode::Default,
    String^ friendlyName = nullptr
)
static member RegisterType :
        type : Type *
        ?accessMode : InteropAccessMode *
        ?friendlyName : string
(* Defaults:
        let _accessMode = defaultArg accessMode InteropAccessMode.Default
        let _friendlyName = defaultArg friendlyName null
*)
-> IUserDataDescriptor

Parameters

type
Type: SystemType
The type to be registered
accessMode (Optional)
Type: MoonSharp.InterpreterInteropAccessMode
The access mode (optional).
friendlyName (Optional)
Type: SystemString
Friendly name for the type (optional)

Return Value

Type: IUserDataDescriptor
See Also

Reference

UserData Class
RegisterType Overload
MoonSharp.Interpreter Namespace


UserData.UnregisterType Method

UserDataUnregisterType Method
Overload List
Name | Description
UnregisterTypeT | Unregisters a type. WARNING: unregistering types at runtime is a dangerous practice and may cause unwanted errors. Use this only for testing purposes or to re-register the same type in a slightly different way. Additionally, it's a good practice to discard all previous loaded scripts after calling this method.
UnregisterType(Type) | Unregisters a type. WARNING: unregistering types at runtime is a dangerous practice and may cause unwanted errors. Use this only for testing purposes or to re-register the same type in a slightly different way. Additionally, it's a good practice to discard all previous loaded scripts after calling this method.
Top
See Also

Reference

UserData Class
MoonSharp.Interpreter Namespace


UserData.UnregisterType(T) Method

UserDataUnregisterTypeT Method
Unregisters a type. WARNING: unregistering types at runtime is a dangerous practice and may cause unwanted errors. Use this only for testing purposes or to re-register the same type in a slightly different way. Additionally, it's a good practice to discard all previous loaded scripts after calling this method.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterType<T>()

Public Shared Sub UnregisterType(Of T)
public:
generic<typename T>
static void UnregisterType()
static member UnregisterType : unit -> unit

Type Parameters

T
The type to be unregistered
See Also

Reference

UserData Class
UnregisterType Overload
MoonSharp.Interpreter Namespace


UserData.UnregisterType Method (Type)

UserDataUnregisterType Method (Type)
Unregisters a type. WARNING: unregistering types at runtime is a dangerous practice and may cause unwanted errors. Use this only for testing purposes or to re-register the same type in a slightly different way. Additionally, it's a good practice to discard all previous loaded scripts after calling this method.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static void UnregisterType(
    Type t
)
Public Shared Sub UnregisterType (
    t As Type
)
public:
static void UnregisterType(
    Type^ t
)
static member UnregisterType :
        t : Type -> unit

Parameters

t
Type: SystemType
The The type to be unregistered
See Also

Reference

UserData Class
UnregisterType Overload
MoonSharp.Interpreter Namespace


WellKnownSymbols Class

WellKnownSymbols Class
Constants of well known "symbols" in the MoonSharp grammar
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterWellKnownSymbols

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static class WellKnownSymbols
Public NotInheritable Class WellKnownSymbols
public ref class WellKnownSymbols abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WellKnownSymbols =  class end

The WellKnownSymbols type exposes the following members.

Fields
Name | Description
ENV | The environment symbol ("_ENV")
VARARGS | The variadic argument symbol ("...")
Top
See Also

Reference

MoonSharp.Interpreter Namespace


WellKnownSymbols Fields

WellKnownSymbols Fields

The WellKnownSymbols type exposes the following members.

Fields
Name | Description
ENV | The environment symbol ("_ENV")
VARARGS | The variadic argument symbol ("...")
Top
See Also

Reference

WellKnownSymbols Class
MoonSharp.Interpreter Namespace


WellKnownSymbols.ENV Field

WellKnownSymbolsENV Field
The environment symbol ("_ENV")

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public const string ENV = "_ENV"
Public Const ENV As String = "_ENV"
public:
literal String^ ENV = "_ENV"
static val mutable ENV: string

Field Value

Type: String
See Also

Reference

WellKnownSymbols Class
MoonSharp.Interpreter Namespace


WellKnownSymbols.VARARGS Field

WellKnownSymbolsVARARGS Field
The variadic argument symbol ("...")

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public const string VARARGS = "..."
Public Const VARARGS As String = "..."
public:
literal String^ VARARGS = "..."
static val mutable VARARGS: string

Field Value

Type: String
See Also

Reference

WellKnownSymbols Class
MoonSharp.Interpreter Namespace


YieldRequest Class

YieldRequest Class
Class wrapping a request to yield a coroutine
Inheritance Hierarchy
SystemObject
MoonSharp.InterpreterYieldRequest

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class YieldRequest
Public Class YieldRequest
public ref class YieldRequest
type YieldRequest =  class end

The YieldRequest type exposes the following members.

Constructors
 | Name | Description
Public method | YieldRequest | Initializes a new instance of the YieldRequest class
Top
Properties
 | Name | Description
Public property | Forced | Gets or sets a value indicating whether this YieldRequest is a forced yield.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | ReturnValues | The return values of the coroutine
Top
See Also

Reference

MoonSharp.Interpreter Namespace


YieldRequest Constructor

YieldRequest Constructor
Initializes a new instance of the YieldRequest class

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public YieldRequest()
Public Sub New
public:
YieldRequest()
new : unit -> YieldRequest
See Also

Reference

YieldRequest Class
MoonSharp.Interpreter Namespace


YieldRequest Properties

YieldRequest Properties

The YieldRequest type exposes the following members.

Properties
 | Name | Description
Public property | Forced | Gets or sets a value indicating whether this YieldRequest is a forced yield.
Top
See Also

Reference

YieldRequest Class
MoonSharp.Interpreter Namespace


YieldRequest.Forced Property

YieldRequestForced Property
Gets or sets a value indicating whether this YieldRequest is a forced yield.

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool Forced { get; }
Public ReadOnly Property Forced As Boolean
    Get
public:
property bool Forced {
    bool get ();
}
member Forced : bool with get

Property Value

Type: Boolean
See Also

Reference

YieldRequest Class
MoonSharp.Interpreter Namespace


YieldRequest Methods

YieldRequest Methods

The YieldRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

YieldRequest Class
MoonSharp.Interpreter Namespace


YieldRequest Fields

YieldRequest Fields

The YieldRequest type exposes the following members.

Fields
 | Name | Description
Public field | ReturnValues | The return values of the coroutine
Top
See Also

Reference

YieldRequest Class
MoonSharp.Interpreter Namespace


YieldRequest.ReturnValues Field

YieldRequestReturnValues Field
The return values of the coroutine

Namespace: MoonSharp.Interpreter
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue[] ReturnValues
Public ReturnValues As DynValue()
public:
array<DynValue^>^ ReturnValues
val mutable ReturnValues: DynValue[]

Field Value

Type: DynValue
See Also

Reference

YieldRequest Class
MoonSharp.Interpreter Namespace


MoonSharp.Interpreter.CoreLib Namespace

MoonSharp.Interpreter.CoreLib Namespace
Namespace containing the implementation of the Lua standard library, as MoonSharp modules. There's seldom the need to access these classes directly.
Classes
 | Class | Description
Public class | BasicModule | Class implementing basic Lua functions (print, type, tostring, etc) as a MoonSharp module.
Public class | Bit32Module | Class implementing bit32 Lua functions
Public class | CoroutineModule | Class implementing coroutine Lua functions
Public class | DebugModule | Class implementing debug Lua functions. Support for the debug module is partial.
Public class | DynamicModule | Class implementing dynamic expression evaluations at runtime (a MoonSharp addition).
Public class | ErrorHandlingModule | Class implementing error handling Lua functions (pcall and xpcall)
Public class | IoModule | Class implementing io Lua functions. Proper support requires a compatible IPlatformAccessor
Public class | JsonModule |
Public class | LoadModule | Class implementing loading Lua functions like 'require', 'load', etc.
Public class | MathModule | Class implementing math Lua functions
Public class | MetaTableModule | Class implementing metatable related Lua functions (xxxmetatable and rawxxx).
Public class | OsSystemModule | Class implementing system related Lua functions from the 'os' module. Proper support requires a compatible IPlatformAccessor
Public class | OsTimeModule | Class implementing time related Lua functions from the 'os' module.
Public class | StringModule | Class implementing string Lua functions
Public class | TableIteratorsModule | Class implementing table Lua iterators (pairs, ipairs, next)
Public class | TableModule | Class implementing table Lua functions
Public class | TableModule_Globals | Class exposing table.unpack and table.pack in the global namespace (to work around the most common Lua 5.1 compatibility issue).


BasicModule Class

BasicModule Class
Class implementing basic Lua functions (print, type, tostring, etc) as a MoonSharp module.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.CoreLibBasicModule

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class BasicModule
Public Class BasicModule
public ref class BasicModule
type BasicModule =  class end

The BasicModule type exposes the following members.

Constructors
 | Name | Description
Public method | BasicModule | Initializes a new instance of the BasicModule class
Top
Methods
 | Name | Description
 | assert |
 | collectgarbage |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | error |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | print |
 | select |
 | tonumber |
 | tostring |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | type |
Top
See Also

Reference

MoonSharp.Interpreter.CoreLib Namespace


BasicModule Constructor

BasicModule Constructor
Initializes a new instance of the BasicModule class

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public BasicModule()
Public Sub New
public:
BasicModule()
new : unit -> BasicModule
See Also

Reference

BasicModule Class
MoonSharp.Interpreter.CoreLib Namespace


BasicModule Methods

BasicModule Methods

The BasicModule type exposes the following members.

Methods
 | Name | Description
 | assert |
 | collectgarbage |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | error |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | print |
 | select |
 | tonumber |
 | tostring |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | type |
Top
See Also

Reference

BasicModule Class
MoonSharp.Interpreter.CoreLib Namespace


BasicModule.assert Method

BasicModuleassert Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.assert(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue assert(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function assert (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ assert(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member assert :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.assert(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.assert(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

BasicModule Class
MoonSharp.Interpreter.CoreLib Namespace


BasicModule.collectgarbage Method

BasicModulecollectgarbage Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.collectgarbage(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue collectgarbage(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function collectgarbage (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ collectgarbage(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member collectgarbage :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.collectgarbage(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.collectgarbage(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

BasicModule Class
MoonSharp.Interpreter.CoreLib Namespace


BasicModule.error Method

BasicModuleerror Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.error(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue error(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function error (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ error(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member error :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.error(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.error(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

BasicModule Class
MoonSharp.Interpreter.CoreLib Namespace


BasicModule.print Method

BasicModuleprint Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.print(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue print(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function print (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ print(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member print :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.print(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.print(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

BasicModule Class
MoonSharp.Interpreter.CoreLib Namespace


BasicModule.select Method

BasicModuleselect Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.select(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue select(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function select (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ select(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member select :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.select(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.select(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

BasicModule Class
MoonSharp.Interpreter.CoreLib Namespace


BasicModule.tonumber Method

BasicModuletonumber Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.tonumber(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue tonumber(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function tonumber (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ tonumber(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member tonumber :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.tonumber(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.tonumber(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

BasicModule Class
MoonSharp.Interpreter.CoreLib Namespace


BasicModule.tostring Method

BasicModuletostring Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.tostring(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue tostring(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function tostring (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ tostring(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member tostring :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.tostring(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.tostring(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

BasicModule Class
MoonSharp.Interpreter.CoreLib Namespace


BasicModule.type Method

BasicModuletype Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.type(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue type(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function type (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ type(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member type :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.type(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.BasicModule.type(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

BasicModule Class
MoonSharp.Interpreter.CoreLib Namespace


Bit32Module Class

Bit32Module Class
Class implementing bit32 Lua functions
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.CoreLibBit32Module

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class Bit32Module
Public Class Bit32Module
public ref class Bit32Module
type Bit32Module =  class end

The Bit32Module type exposes the following members.

Constructors
 | Name | Description
Public method | Bit32Module | Initializes a new instance of the Bit32Module class
Top
Methods
 | Name | Description
 | arshift |
 | band |
 | Bitwise |
 | bnot |
 | bor |
 | btest |
 | bxor |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | extract |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | lrotate |
 | lshift |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | replace |
 | rrotate |
 | rshift |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.CoreLib Namespace


Bit32Module Constructor

Bit32Module Constructor
Initializes a new instance of the Bit32Module class

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Bit32Module()
Public Sub New
public:
Bit32Module()
new : unit -> Bit32Module
See Also

Reference

Bit32Module Class
MoonSharp.Interpreter.CoreLib Namespace


Bit32Module Methods

Bit32Module Methods

The Bit32Module type exposes the following members.

Methods
 | Name | Description
 | arshift |
 | band |
 | Bitwise |
 | bnot |
 | bor |
 | btest |
 | bxor |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | extract |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | lrotate |
 | lshift |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | replace |
 | rrotate |
 | rshift |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Bit32Module Class
MoonSharp.Interpreter.CoreLib Namespace


Bit32Module.arshift Method

Bit32Modulearshift Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.arshift(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue arshift(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function arshift (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ arshift(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member arshift :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.arshift(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.arshift(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

Bit32Module Class
MoonSharp.Interpreter.CoreLib Namespace


Bit32Module.band Method

Bit32Moduleband Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.band(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue band(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function band (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ band(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member band :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.band(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.band(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

Bit32Module Class
MoonSharp.Interpreter.CoreLib Namespace


Bit32Module.Bitwise Method

Bit32ModuleBitwise Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.Bitwise(System.String,MoonSharp.Interpreter.CallbackArguments,System.Func{System.UInt32,System.UInt32,System.UInt32})"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static uint Bitwise(
    string funcName,
    CallbackArguments args,
    Func<uint, uint, uint> accumFunc
)
Public Shared Function Bitwise (
    funcName As String,
    args As CallbackArguments,
    accumFunc As Func(Of UInteger, UInteger, UInteger)
) As UInteger
public:
static unsigned int Bitwise(
    String^ funcName,
    CallbackArguments^ args,
    Func<unsigned int, unsigned int, unsigned int>^ accumFunc
)
static member Bitwise :
        funcName : string *
        args : CallbackArguments *
        accumFunc : Func<uint32, uint32, uint32> -> uint32

Parameters

funcName
Type: SystemString

[Missing <param name="funcName"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.Bitwise(System.String,MoonSharp.Interpreter.CallbackArguments,System.Func{System.UInt32,System.UInt32,System.UInt32})"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.Bitwise(System.String,MoonSharp.Interpreter.CallbackArguments,System.Func{System.UInt32,System.UInt32,System.UInt32})"]

accumFunc
Type: SystemFunc UInt32, UInt32, UInt32

[Missing <param name="accumFunc"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.Bitwise(System.String,MoonSharp.Interpreter.CallbackArguments,System.Func{System.UInt32,System.UInt32,System.UInt32})"]

Return Value

Type: UInt32
See Also

Reference

Bit32Module Class
MoonSharp.Interpreter.CoreLib Namespace


Bit32Module.bnot Method

Bit32Modulebnot Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.bnot(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue bnot(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function bnot (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ bnot(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member bnot :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.bnot(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.bnot(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

Bit32Module Class
MoonSharp.Interpreter.CoreLib Namespace


Bit32Module.bor Method

Bit32Modulebor Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.bor(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue bor(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function bor (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ bor(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member bor :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.bor(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.bor(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

Bit32Module Class
MoonSharp.Interpreter.CoreLib Namespace


Bit32Module.btest Method

Bit32Modulebtest Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.btest(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue btest(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function btest (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ btest(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member btest :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.btest(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.btest(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

Bit32Module Class
MoonSharp.Interpreter.CoreLib Namespace


Bit32Module.bxor Method

Bit32Modulebxor Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.bxor(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue bxor(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function bxor (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ bxor(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member bxor :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.bxor(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.bxor(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

Bit32Module Class
MoonSharp.Interpreter.CoreLib Namespace


Bit32Module.extract Method

Bit32Moduleextract Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.extract(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue extract(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function extract (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ extract(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member extract :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.extract(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.extract(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

Bit32Module Class
MoonSharp.Interpreter.CoreLib Namespace


Bit32Module.lrotate Method

Bit32Modulelrotate Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.lrotate(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue lrotate(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function lrotate (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ lrotate(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member lrotate :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.lrotate(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.lrotate(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

Bit32Module Class
MoonSharp.Interpreter.CoreLib Namespace


Bit32Module.lshift Method

Bit32Modulelshift Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.lshift(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue lshift(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function lshift (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ lshift(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member lshift :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.lshift(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.lshift(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

Bit32Module Class
MoonSharp.Interpreter.CoreLib Namespace


Bit32Module.replace Method

Bit32Modulereplace Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.replace(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue replace(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function replace (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ replace(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member replace :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.replace(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.replace(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

Bit32Module Class
MoonSharp.Interpreter.CoreLib Namespace


Bit32Module.rrotate Method

Bit32Modulerrotate Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.rrotate(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue rrotate(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function rrotate (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ rrotate(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member rrotate :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.rrotate(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.rrotate(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

Bit32Module Class
MoonSharp.Interpreter.CoreLib Namespace


Bit32Module.rshift Method

Bit32Modulershift Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.rshift(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue rshift(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function rshift (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ rshift(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member rshift :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.rshift(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.Bit32Module.rshift(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

Bit32Module Class
MoonSharp.Interpreter.CoreLib Namespace


CoroutineModule Class

CoroutineModule Class
Class implementing coroutine Lua functions
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.CoreLibCoroutineModule

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class CoroutineModule
Public Class CoroutineModule
public ref class CoroutineModule
type CoroutineModule =  class end

The CoroutineModule type exposes the following members.

Constructors
 | Name | Description
Public method | CoroutineModule | Initializes a new instance of the CoroutineModule class
Top
Methods
 | Name | Description
 | __wrap_wrapper |
 | create |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | resume |
 | running |
 | status |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | wrap |
 | yield |
Top
See Also

Reference

MoonSharp.Interpreter.CoreLib Namespace


CoroutineModule Constructor

CoroutineModule Constructor
Initializes a new instance of the CoroutineModule class

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CoroutineModule()
Public Sub New
public:
CoroutineModule()
new : unit -> CoroutineModule
See Also

Reference

CoroutineModule Class
MoonSharp.Interpreter.CoreLib Namespace


CoroutineModule Methods

CoroutineModule Methods

The CoroutineModule type exposes the following members.

Methods
 | Name | Description
 | __wrap_wrapper |
 | create |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | resume |
 | running |
 | status |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | wrap |
 | yield |
Top
See Also

Reference

CoroutineModule Class
MoonSharp.Interpreter.CoreLib Namespace


CoroutineModule.__wrap_wrapper Method

CoroutineModule__wrap_wrapper Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.__wrap_wrapper(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue __wrap_wrapper(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function __wrap_wrapper (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ __wrap_wrapper(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member __wrap_wrapper :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.__wrap_wrapper(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.__wrap_wrapper(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

CoroutineModule Class
MoonSharp.Interpreter.CoreLib Namespace


CoroutineModule.create Method

CoroutineModulecreate Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.create(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue create(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function create (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ create(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member create :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.create(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.create(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

CoroutineModule Class
MoonSharp.Interpreter.CoreLib Namespace


CoroutineModule.resume Method

CoroutineModuleresume Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.resume(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue resume(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function resume (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ resume(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member resume :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.resume(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.resume(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

CoroutineModule Class
MoonSharp.Interpreter.CoreLib Namespace


CoroutineModule.running Method

CoroutineModulerunning Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.running(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue running(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function running (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ running(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member running :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.running(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.running(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

CoroutineModule Class
MoonSharp.Interpreter.CoreLib Namespace


CoroutineModule.status Method

CoroutineModulestatus Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.status(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue status(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function status (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ status(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member status :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.status(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.status(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

CoroutineModule Class
MoonSharp.Interpreter.CoreLib Namespace


CoroutineModule.wrap Method

CoroutineModulewrap Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.wrap(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue wrap(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function wrap (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ wrap(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member wrap :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.wrap(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.wrap(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

CoroutineModule Class
MoonSharp.Interpreter.CoreLib Namespace


CoroutineModule.yield Method

CoroutineModuleyield Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.yield(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue yield(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function yield (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ yield(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member yield :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.yield(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.CoroutineModule.yield(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

CoroutineModule Class
MoonSharp.Interpreter.CoreLib Namespace


DebugModule Class

DebugModule Class
Class implementing debug Lua functions. Support for the debug module is partial.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.CoreLibDebugModule

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class DebugModule
Public Class DebugModule
public ref class DebugModule
type DebugModule =  class end

The DebugModule type exposes the following members.

Constructors
 | Name | Description
Public method | DebugModule | Initializes a new instance of the DebugModule class
Top
Methods
 | Name | Description
 | debug |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | getmetatable |
 | getregistry |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | getupvalue |
 | getuservalue |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | setmetatable |
 | setupvalue |
 | setuservalue |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | traceback |
 | upvalueid |
 | upvaluejoin |
Top
See Also

Reference

MoonSharp.Interpreter.CoreLib Namespace


DebugModule Constructor

DebugModule Constructor
Initializes a new instance of the DebugModule class

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DebugModule()
Public Sub New
public:
DebugModule()
new : unit -> DebugModule
See Also

Reference

DebugModule Class
MoonSharp.Interpreter.CoreLib Namespace


DebugModule Methods

DebugModule Methods

The DebugModule type exposes the following members.

Methods
 | Name | Description
 | debug |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | getmetatable |
 | getregistry |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | getupvalue |
 | getuservalue |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | setmetatable |
 | setupvalue |
 | setuservalue |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | traceback |
 | upvalueid |
 | upvaluejoin |
Top
See Also

Reference

DebugModule Class
MoonSharp.Interpreter.CoreLib Namespace


DebugModule.debug Method

DebugModuledebug Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.debug(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue debug(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function debug (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ debug(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member debug :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.debug(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.debug(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

DebugModule Class
MoonSharp.Interpreter.CoreLib Namespace


DebugModule.getmetatable Method

DebugModulegetmetatable Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.getmetatable(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue getmetatable(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function getmetatable (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ getmetatable(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member getmetatable :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.getmetatable(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.getmetatable(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

DebugModule Class
MoonSharp.Interpreter.CoreLib Namespace


DebugModule.getregistry Method

DebugModulegetregistry Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.getregistry(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue getregistry(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function getregistry (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ getregistry(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member getregistry :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.getregistry(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.getregistry(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

DebugModule Class
MoonSharp.Interpreter.CoreLib Namespace


DebugModule.getupvalue Method

DebugModulegetupvalue Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.getupvalue(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue getupvalue(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function getupvalue (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ getupvalue(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member getupvalue :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.getupvalue(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.getupvalue(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

DebugModule Class
MoonSharp.Interpreter.CoreLib Namespace


DebugModule.getuservalue Method

DebugModulegetuservalue Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.getuservalue(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue getuservalue(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function getuservalue (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ getuservalue(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member getuservalue :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.getuservalue(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.getuservalue(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

DebugModule Class
MoonSharp.Interpreter.CoreLib Namespace


DebugModule.setmetatable Method

DebugModulesetmetatable Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.setmetatable(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue setmetatable(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function setmetatable (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ setmetatable(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member setmetatable :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.setmetatable(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.setmetatable(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

DebugModule Class
MoonSharp.Interpreter.CoreLib Namespace


DebugModule.setupvalue Method

DebugModulesetupvalue Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.setupvalue(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue setupvalue(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function setupvalue (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ setupvalue(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member setupvalue :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.setupvalue(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.setupvalue(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

DebugModule Class
MoonSharp.Interpreter.CoreLib Namespace


DebugModule.setuservalue Method

DebugModulesetuservalue Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.setuservalue(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue setuservalue(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function setuservalue (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ setuservalue(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member setuservalue :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.setuservalue(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.setuservalue(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

DebugModule Class
MoonSharp.Interpreter.CoreLib Namespace


DebugModule.traceback Method

DebugModuletraceback Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.traceback(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue traceback(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function traceback (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ traceback(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member traceback :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.traceback(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.traceback(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

DebugModule Class
MoonSharp.Interpreter.CoreLib Namespace


DebugModule.upvalueid Method

DebugModuleupvalueid Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.upvalueid(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue upvalueid(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function upvalueid (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ upvalueid(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member upvalueid :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.upvalueid(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.upvalueid(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

DebugModule Class
MoonSharp.Interpreter.CoreLib Namespace


DebugModule.upvaluejoin Method

DebugModuleupvaluejoin Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.upvaluejoin(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue upvaluejoin(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function upvaluejoin (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ upvaluejoin(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member upvaluejoin :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.upvaluejoin(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DebugModule.upvaluejoin(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

DebugModule Class
MoonSharp.Interpreter.CoreLib Namespace


DynamicModule Class

DynamicModule Class
Class implementing dynamic expression evaluations at runtime (a MoonSharp addition).
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.CoreLibDynamicModule

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class DynamicModule
Public Class DynamicModule
public ref class DynamicModule
type DynamicModule =  class end

The DynamicModule type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicModule | Initializes a new instance of the DynamicModule class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | eval |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoonSharpInit |
 | prepare |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.CoreLib Namespace


DynamicModule Constructor

DynamicModule Constructor
Initializes a new instance of the DynamicModule class

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynamicModule()
Public Sub New
public:
DynamicModule()
new : unit -> DynamicModule
See Also

Reference

DynamicModule Class
MoonSharp.Interpreter.CoreLib Namespace


DynamicModule Methods

DynamicModule Methods

The DynamicModule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | eval |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoonSharpInit |
 | prepare |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DynamicModule Class
MoonSharp.Interpreter.CoreLib Namespace


DynamicModule.eval Method

DynamicModuleeval Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.DynamicModule.eval(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue eval(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function eval (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ eval(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member eval :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DynamicModule.eval(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DynamicModule.eval(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

DynamicModule Class
MoonSharp.Interpreter.CoreLib Namespace


DynamicModule.MoonSharpInit Method

DynamicModuleMoonSharpInit Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.DynamicModule.MoonSharpInit(MoonSharp.Interpreter.Table,MoonSharp.Interpreter.Table)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static void MoonSharpInit(
    Table globalTable,
    Table stringTable
)
Public Shared Sub MoonSharpInit (
    globalTable As Table,
    stringTable As Table
)
public:
static void MoonSharpInit(
    Table^ globalTable,
    Table^ stringTable
)
static member MoonSharpInit :
        globalTable : Table *
        stringTable : Table -> unit

Parameters

globalTable
Type: MoonSharp.InterpreterTable

[Missing <param name="globalTable"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DynamicModule.MoonSharpInit(MoonSharp.Interpreter.Table,MoonSharp.Interpreter.Table)"]

stringTable
Type: MoonSharp.InterpreterTable

[Missing <param name="stringTable"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DynamicModule.MoonSharpInit(MoonSharp.Interpreter.Table,MoonSharp.Interpreter.Table)"]

See Also

Reference

DynamicModule Class
MoonSharp.Interpreter.CoreLib Namespace


DynamicModule.prepare Method

DynamicModuleprepare Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.DynamicModule.prepare(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue prepare(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function prepare (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ prepare(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member prepare :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DynamicModule.prepare(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.DynamicModule.prepare(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

DynamicModule Class
MoonSharp.Interpreter.CoreLib Namespace


ErrorHandlingModule Class

ErrorHandlingModule Class
Class implementing error handling Lua functions (pcall and xpcall)
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.CoreLibErrorHandlingModule

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class ErrorHandlingModule
Public Class ErrorHandlingModule
public ref class ErrorHandlingModule
type ErrorHandlingModule =  class end

The ErrorHandlingModule type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorHandlingModule | Initializes a new instance of the ErrorHandlingModule class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | pcall |
 | pcall_continuation |
 | pcall_onerror |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | xpcall |
Top
See Also

Reference

MoonSharp.Interpreter.CoreLib Namespace


ErrorHandlingModule Constructor

ErrorHandlingModule Constructor
Initializes a new instance of the ErrorHandlingModule class

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ErrorHandlingModule()
Public Sub New
public:
ErrorHandlingModule()
new : unit -> ErrorHandlingModule
See Also

Reference

ErrorHandlingModule Class
MoonSharp.Interpreter.CoreLib Namespace


ErrorHandlingModule Methods

ErrorHandlingModule Methods

The ErrorHandlingModule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | pcall |
 | pcall_continuation |
 | pcall_onerror |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | xpcall |
Top
See Also

Reference

ErrorHandlingModule Class
MoonSharp.Interpreter.CoreLib Namespace


ErrorHandlingModule.pcall Method

ErrorHandlingModulepcall Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.ErrorHandlingModule.pcall(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue pcall(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function pcall (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ pcall(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member pcall :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.ErrorHandlingModule.pcall(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.ErrorHandlingModule.pcall(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

ErrorHandlingModule Class
MoonSharp.Interpreter.CoreLib Namespace


ErrorHandlingModule.pcall_continuation Method

ErrorHandlingModulepcall_continuation Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.ErrorHandlingModule.pcall_continuation(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue pcall_continuation(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function pcall_continuation (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ pcall_continuation(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member pcall_continuation :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.ErrorHandlingModule.pcall_continuation(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.ErrorHandlingModule.pcall_continuation(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

ErrorHandlingModule Class
MoonSharp.Interpreter.CoreLib Namespace


ErrorHandlingModule.pcall_onerror Method

ErrorHandlingModulepcall_onerror Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.ErrorHandlingModule.pcall_onerror(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue pcall_onerror(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function pcall_onerror (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ pcall_onerror(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member pcall_onerror :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.ErrorHandlingModule.pcall_onerror(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.ErrorHandlingModule.pcall_onerror(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

ErrorHandlingModule Class
MoonSharp.Interpreter.CoreLib Namespace


ErrorHandlingModule.xpcall Method

ErrorHandlingModulexpcall Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.ErrorHandlingModule.xpcall(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue xpcall(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function xpcall (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ xpcall(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member xpcall :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.ErrorHandlingModule.xpcall(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.ErrorHandlingModule.xpcall(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

ErrorHandlingModule Class
MoonSharp.Interpreter.CoreLib Namespace


IoModule Class

IoModule Class
Class implementing io Lua functions. Proper support requires a compatible IPlatformAccessor
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.CoreLibIoModule

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class IoModule
Public Class IoModule
public ref class IoModule
type IoModule =  class end

The IoModule type exposes the following members.

Constructors
 | Name | Description
Public method | IoModule | Initializes a new instance of the IoModule class
Top
Methods
 | Name | Description
 | close |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | flush |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | input |
 | IoExceptionToLuaMessage |
 | lines |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoonSharpInit |
 | open |
 | output |
 | read |
 | SetDefaultFile |
 | tmpfile |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | type |
 | write |
Top
See Also

Reference

MoonSharp.Interpreter.CoreLib Namespace


IoModule Constructor

IoModule Constructor
Initializes a new instance of the IoModule class

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IoModule()
Public Sub New
public:
IoModule()
new : unit -> IoModule
See Also

Reference

IoModule Class
MoonSharp.Interpreter.CoreLib Namespace


IoModule Methods

IoModule Methods

The IoModule type exposes the following members.

Methods
 | Name | Description
 | close |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | flush |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | input |
 | IoExceptionToLuaMessage |
 | lines |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoonSharpInit |
 | open |
 | output |
 | read |
 | SetDefaultFile |
 | tmpfile |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | type |
 | write |
Top
See Also

Reference

IoModule Class
MoonSharp.Interpreter.CoreLib Namespace


IoModule.close Method

IoModuleclose Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.close(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue close(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function close (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ close(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member close :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.close(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.close(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

IoModule Class
MoonSharp.Interpreter.CoreLib Namespace


IoModule.flush Method

IoModuleflush Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.flush(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue flush(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function flush (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ flush(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member flush :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.flush(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.flush(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

IoModule Class
MoonSharp.Interpreter.CoreLib Namespace


IoModule.input Method

IoModuleinput Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.input(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue input(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function input (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ input(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member input :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.input(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.input(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

IoModule Class
MoonSharp.Interpreter.CoreLib Namespace


IoModule.IoExceptionToLuaMessage Method

IoModuleIoExceptionToLuaMessage Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.IoExceptionToLuaMessage(System.Exception,System.String)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string IoExceptionToLuaMessage(
    Exception ex,
    string filename
)
Public Shared Function IoExceptionToLuaMessage (
    ex As Exception,
    filename As String
) As String
public:
static String^ IoExceptionToLuaMessage(
    Exception^ ex,
    String^ filename
)
static member IoExceptionToLuaMessage :
        ex : Exception *
        filename : string -> string

Parameters

ex
Type: SystemException

[Missing <param name="ex"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.IoExceptionToLuaMessage(System.Exception,System.String)"]

filename
Type: SystemString

[Missing <param name="filename"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.IoExceptionToLuaMessage(System.Exception,System.String)"]

Return Value

Type: String
See Also

Reference

IoModule Class
MoonSharp.Interpreter.CoreLib Namespace


IoModule.lines Method

IoModulelines Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.lines(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue lines(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function lines (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ lines(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member lines :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.lines(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.lines(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

IoModule Class
MoonSharp.Interpreter.CoreLib Namespace


IoModule.MoonSharpInit Method

IoModuleMoonSharpInit Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.MoonSharpInit(MoonSharp.Interpreter.Table,MoonSharp.Interpreter.Table)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static void MoonSharpInit(
    Table globalTable,
    Table ioTable
)
Public Shared Sub MoonSharpInit (
    globalTable As Table,
    ioTable As Table
)
public:
static void MoonSharpInit(
    Table^ globalTable,
    Table^ ioTable
)
static member MoonSharpInit :
        globalTable : Table *
        ioTable : Table -> unit

Parameters

globalTable
Type: MoonSharp.InterpreterTable

[Missing <param name="globalTable"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.MoonSharpInit(MoonSharp.Interpreter.Table,MoonSharp.Interpreter.Table)"]

ioTable
Type: MoonSharp.InterpreterTable

[Missing <param name="ioTable"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.MoonSharpInit(MoonSharp.Interpreter.Table,MoonSharp.Interpreter.Table)"]

See Also

Reference

IoModule Class
MoonSharp.Interpreter.CoreLib Namespace


IoModule.open Method

IoModuleopen Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.open(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue open(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function open (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ open(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member open :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.open(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.open(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

IoModule Class
MoonSharp.Interpreter.CoreLib Namespace


IoModule.output Method

IoModuleoutput Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.output(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue output(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function output (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ output(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member output :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.output(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.output(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

IoModule Class
MoonSharp.Interpreter.CoreLib Namespace


IoModule.read Method

IoModuleread Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.read(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue read(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function read (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ read(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member read :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.read(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.read(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

IoModule Class
MoonSharp.Interpreter.CoreLib Namespace


IoModule.SetDefaultFile Method

IoModuleSetDefaultFile Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.SetDefaultFile(MoonSharp.Interpreter.Script,MoonSharp.Interpreter.Platforms.StandardFileType,System.IO.Stream)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static void SetDefaultFile(
    Script script,
    StandardFileType file,
    Stream stream
)
Public Shared Sub SetDefaultFile (
    script As Script,
    file As StandardFileType,
    stream As Stream
)
public:
static void SetDefaultFile(
    Script^ script,
    StandardFileType file,
    Stream^ stream
)
static member SetDefaultFile :
        script : Script *
        file : StandardFileType *
        stream : Stream -> unit

Parameters

script
Type: MoonSharp.InterpreterScript

[Missing <param name="script"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.SetDefaultFile(MoonSharp.Interpreter.Script,MoonSharp.Interpreter.Platforms.StandardFileType,System.IO.Stream)"]

file
Type: MoonSharp.Interpreter.PlatformsStandardFileType

[Missing <param name="file"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.SetDefaultFile(MoonSharp.Interpreter.Script,MoonSharp.Interpreter.Platforms.StandardFileType,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.SetDefaultFile(MoonSharp.Interpreter.Script,MoonSharp.Interpreter.Platforms.StandardFileType,System.IO.Stream)"]

See Also

Reference

IoModule Class
MoonSharp.Interpreter.CoreLib Namespace


IoModule.tmpfile Method

IoModuletmpfile Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.tmpfile(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue tmpfile(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function tmpfile (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ tmpfile(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member tmpfile :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.tmpfile(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.tmpfile(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

IoModule Class
MoonSharp.Interpreter.CoreLib Namespace


IoModule.type Method

IoModuletype Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.type(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue type(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function type (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ type(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member type :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.type(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.type(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

IoModule Class
MoonSharp.Interpreter.CoreLib Namespace


IoModule.write Method

IoModulewrite Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.write(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue write(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function write (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ write(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member write :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.write(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.IoModule.write(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

IoModule Class
MoonSharp.Interpreter.CoreLib Namespace


JsonModule Class

JsonModule Class

[Missing <summary> documentation for "T:MoonSharp.Interpreter.CoreLib.JsonModule"]

Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.CoreLibJsonModule

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class JsonModule
Public Class JsonModule
public ref class JsonModule
type JsonModule =  class end

The JsonModule type exposes the following members.

Constructors
 | Name | Description
Public method | JsonModule | Initializes a new instance of the JsonModule class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | isnull |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | null |
 | parse |
 | serialize |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.CoreLib Namespace


JsonModule Constructor

JsonModule Constructor
Initializes a new instance of the JsonModule class

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public JsonModule()
Public Sub New
public:
JsonModule()
new : unit -> JsonModule
See Also

Reference

JsonModule Class
MoonSharp.Interpreter.CoreLib Namespace


JsonModule Methods

JsonModule Methods

The JsonModule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | isnull |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | null |
 | parse |
 | serialize |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JsonModule Class
MoonSharp.Interpreter.CoreLib Namespace


JsonModule.isnull Method

JsonModuleisnull Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.JsonModule.isnull(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue isnull(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function isnull (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ isnull(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member isnull :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.JsonModule.isnull(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.JsonModule.isnull(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

JsonModule Class
MoonSharp.Interpreter.CoreLib Namespace


JsonModule.null Method

JsonModulenull Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.JsonModule.null(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue null(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function null (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ null(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member null :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.JsonModule.null(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.JsonModule.null(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

JsonModule Class
MoonSharp.Interpreter.CoreLib Namespace


JsonModule.parse Method

JsonModuleparse Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.JsonModule.parse(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue parse(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function parse (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ parse(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member parse :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.JsonModule.parse(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.JsonModule.parse(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

JsonModule Class
MoonSharp.Interpreter.CoreLib Namespace


JsonModule.serialize Method

JsonModuleserialize Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.JsonModule.serialize(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue serialize(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function serialize (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ serialize(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member serialize :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.JsonModule.serialize(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.JsonModule.serialize(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

JsonModule Class
MoonSharp.Interpreter.CoreLib Namespace


LoadModule Class

LoadModule Class
Class implementing loading Lua functions like 'require', 'load', etc.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.CoreLibLoadModule

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class LoadModule
Public Class LoadModule
public ref class LoadModule
type LoadModule =  class end

The LoadModule type exposes the following members.

Constructors
 | Name | Description
Public method | LoadModule | Initializes a new instance of the LoadModule class
Top
Methods
 | Name | Description
 | __require_clr_impl |
 | dofile |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | load |
 | load_impl |
 | loadfile |
 | loadfilesafe |
 | loadsafe |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoonSharpInit |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
require |
Top
See Also

Reference

MoonSharp.Interpreter.CoreLib Namespace


LoadModule Constructor

LoadModule Constructor
Initializes a new instance of the LoadModule class

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public LoadModule()
Public Sub New
public:
LoadModule()
new : unit -> LoadModule
See Also

Reference

LoadModule Class
MoonSharp.Interpreter.CoreLib Namespace


LoadModule Methods

LoadModule Methods

The LoadModule type exposes the following members.

Methods
 | Name | Description
 | __require_clr_impl |
 | dofile |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | load |
 | load_impl |
 | loadfile |
 | loadfilesafe |
 | loadsafe |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoonSharpInit |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LoadModule Class
MoonSharp.Interpreter.CoreLib Namespace


LoadModule.__require_clr_impl Method

LoadModule__require_clr_impl Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.__require_clr_impl(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue __require_clr_impl(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function __require_clr_impl (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ __require_clr_impl(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member __require_clr_impl :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.__require_clr_impl(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.__require_clr_impl(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

LoadModule Class
MoonSharp.Interpreter.CoreLib Namespace


LoadModule.dofile Method

LoadModuledofile Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.dofile(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue dofile(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function dofile (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ dofile(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member dofile :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.dofile(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.dofile(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

LoadModule Class
MoonSharp.Interpreter.CoreLib Namespace


LoadModule.load Method

LoadModuleload Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.load(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue load(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function load (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ load(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member load :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.load(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.load(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

LoadModule Class
MoonSharp.Interpreter.CoreLib Namespace


LoadModule.load_impl Method

LoadModuleload_impl Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.load_impl(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments,MoonSharp.Interpreter.Table)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue load_impl(
    ScriptExecutionContext executionContext,
    CallbackArguments args,
    Table defaultEnv
)
Public Shared Function load_impl (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments,
    defaultEnv As Table
) As DynValue
public:
static DynValue^ load_impl(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args,
    Table^ defaultEnv
)
static member load_impl :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments *
        defaultEnv : Table -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.load_impl(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments,MoonSharp.Interpreter.Table)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.load_impl(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments,MoonSharp.Interpreter.Table)"]

defaultEnv
Type: MoonSharp.InterpreterTable

[Missing <param name="defaultEnv"/> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.load_impl(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments,MoonSharp.Interpreter.Table)"]

Return Value

Type: DynValue
See Also

Reference

LoadModule Class
MoonSharp.Interpreter.CoreLib Namespace


LoadModule.loadfile Method

LoadModuleloadfile Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.loadfile(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue loadfile(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function loadfile (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ loadfile(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member loadfile :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.loadfile(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.loadfile(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

LoadModule Class
MoonSharp.Interpreter.CoreLib Namespace


LoadModule.loadfilesafe Method

LoadModuleloadfilesafe Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.loadfilesafe(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue loadfilesafe(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function loadfilesafe (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ loadfilesafe(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member loadfilesafe :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.loadfilesafe(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.loadfilesafe(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

LoadModule Class
MoonSharp.Interpreter.CoreLib Namespace


LoadModule.loadsafe Method

LoadModuleloadsafe Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.loadsafe(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue loadsafe(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function loadsafe (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ loadsafe(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member loadsafe :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.loadsafe(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.loadsafe(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

LoadModule Class
MoonSharp.Interpreter.CoreLib Namespace


LoadModule.MoonSharpInit Method

LoadModuleMoonSharpInit Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.MoonSharpInit(MoonSharp.Interpreter.Table,MoonSharp.Interpreter.Table)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static void MoonSharpInit(
    Table globalTable,
    Table ioTable
)
Public Shared Sub MoonSharpInit (
    globalTable As Table,
    ioTable As Table
)
public:
static void MoonSharpInit(
    Table^ globalTable,
    Table^ ioTable
)
static member MoonSharpInit :
        globalTable : Table *
        ioTable : Table -> unit

Parameters

globalTable
Type: MoonSharp.InterpreterTable

[Missing <param name="globalTable"/> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.MoonSharpInit(MoonSharp.Interpreter.Table,MoonSharp.Interpreter.Table)"]

ioTable
Type: MoonSharp.InterpreterTable

[Missing <param name="ioTable"/> documentation for "M:MoonSharp.Interpreter.CoreLib.LoadModule.MoonSharpInit(MoonSharp.Interpreter.Table,MoonSharp.Interpreter.Table)"]

See Also

Reference

LoadModule Class
MoonSharp.Interpreter.CoreLib Namespace


LoadModule Fields

LoadModule Fields

The LoadModule type exposes the following members.

Fields
Name | Description
require |
Top
See Also

Reference

LoadModule Class
MoonSharp.Interpreter.CoreLib Namespace


LoadModule.require Field

LoadModulerequire Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.CoreLib.LoadModule.require"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public const string require = "
function(modulename)
    if (package == nil) then package = { }; end
    if (package.loaded == nil) then package.loaded = { }; end

    local m = package.loaded[modulename];

    if (m ~= nil) then
        return m;
    end

    local func = __require_clr_impl(modulename);

    local res = func(modulename);

    if (res == nil) then
        res = true;
    end

    package.loaded[modulename] = res;

    return res;
end"
Public Const require As String = "
function(modulename)
    if (package == nil) then package = { }; end
    if (package.loaded == nil) then package.loaded = { }; end

    local m = package.loaded[modulename];

    if (m ~= nil) then
        return m;
    end

    local func = __require_clr_impl(modulename);

    local res = func(modulename);

    if (res == nil) then
        res = true;
    end

    package.loaded[modulename] = res;

    return res;
end"
public:
literal String^ require = "
function(modulename)
    if (package == nil) then package = { }; end
    if (package.loaded == nil) then package.loaded = { }; end

    local m = package.loaded[modulename];

    if (m ~= nil) then
        return m;
    end

    local func = __require_clr_impl(modulename);

    local res = func(modulename);

    if (res == nil) then
        res = true;
    end

    package.loaded[modulename] = res;

    return res;
end"
static val mutable require: string

Field Value

Type: String
See Also

Reference

LoadModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule Class

MathModule Class
Class implementing math Lua functions
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.CoreLibMathModule

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class MathModule
Public Class MathModule
public ref class MathModule
type MathModule =  class end

The MathModule type exposes the following members.

Constructors
 | Name | Description
Public method | MathModule | Initializes a new instance of the MathModule class
Top
Methods
 | Name | Description
 | abs |
 | acos |
 | asin |
 | atan |
 | atan2 |
 | ceil |
 | cos |
 | cosh |
 | deg |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | exp |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | floor |
 | fmod |
 | frexp |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ldexp |
 | log |
 | max |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | min |
 | modf |
 | MoonSharpInit |
 | pow |
 | rad |
 | random |
 | randomseed |
 | sin |
 | sinh |
 | sqrt |
 | tan |
 | tanh |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
huge |
pi |
Top
See Also

Reference

MoonSharp.Interpreter.CoreLib Namespace


MathModule Constructor

MathModule Constructor
Initializes a new instance of the MathModule class

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MathModule()
Public Sub New
public:
MathModule()
new : unit -> MathModule
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule Methods

MathModule Methods

The MathModule type exposes the following members.

Methods
 | Name | Description
 | abs |
 | acos |
 | asin |
 | atan |
 | atan2 |
 | ceil |
 | cos |
 | cosh |
 | deg |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | exp |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | floor |
 | fmod |
 | frexp |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ldexp |
 | log |
 | max |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | min |
 | modf |
 | MoonSharpInit |
 | pow |
 | rad |
 | random |
 | randomseed |
 | sin |
 | sinh |
 | sqrt |
 | tan |
 | tanh |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.abs Method

MathModuleabs Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.abs(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue abs(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function abs (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ abs(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member abs :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.abs(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.abs(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.acos Method

MathModuleacos Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.acos(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue acos(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function acos (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ acos(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member acos :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.acos(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.acos(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.asin Method

MathModuleasin Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.asin(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue asin(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function asin (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ asin(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member asin :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.asin(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.asin(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.atan Method

MathModuleatan Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.atan(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue atan(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function atan (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ atan(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member atan :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.atan(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.atan(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.atan2 Method

MathModuleatan2 Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.atan2(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue atan2(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function atan2 (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ atan2(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member atan2 :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.atan2(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.atan2(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.ceil Method

MathModuleceil Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.ceil(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue ceil(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function ceil (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ ceil(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member ceil :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.ceil(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.ceil(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.cos Method

MathModulecos Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.cos(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue cos(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function cos (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ cos(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member cos :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.cos(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.cos(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.cosh Method

MathModulecosh Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.cosh(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue cosh(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function cosh (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ cosh(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member cosh :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.cosh(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.cosh(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.deg Method

MathModuledeg Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.deg(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue deg(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function deg (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ deg(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member deg :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.deg(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.deg(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.exp Method

MathModuleexp Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.exp(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue exp(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function exp (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ exp(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member exp :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.exp(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.exp(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.floor Method

MathModulefloor Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.floor(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue floor(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function floor (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ floor(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member floor :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.floor(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.floor(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.fmod Method

MathModulefmod Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.fmod(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue fmod(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function fmod (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ fmod(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member fmod :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.fmod(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.fmod(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.frexp Method

MathModulefrexp Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.frexp(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue frexp(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function frexp (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ frexp(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member frexp :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.frexp(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.frexp(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.ldexp Method

MathModuleldexp Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.ldexp(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue ldexp(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function ldexp (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ ldexp(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member ldexp :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.ldexp(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.ldexp(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.log Method

MathModulelog Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.log(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue log(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function log (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ log(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member log :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.log(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.log(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.max Method

MathModulemax Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.max(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue max(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function max (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ max(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member max :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.max(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.max(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.min Method

MathModulemin Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.min(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue min(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function min (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ min(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member min :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.min(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.min(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.modf Method

MathModulemodf Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.modf(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue modf(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function modf (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ modf(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member modf :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.modf(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.modf(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.MoonSharpInit Method

MathModuleMoonSharpInit Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.MoonSharpInit(MoonSharp.Interpreter.Table,MoonSharp.Interpreter.Table)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static void MoonSharpInit(
    Table globalTable,
    Table ioTable
)
Public Shared Sub MoonSharpInit (
    globalTable As Table,
    ioTable As Table
)
public:
static void MoonSharpInit(
    Table^ globalTable,
    Table^ ioTable
)
static member MoonSharpInit :
        globalTable : Table *
        ioTable : Table -> unit

Parameters

globalTable
Type: MoonSharp.InterpreterTable

[Missing <param name="globalTable"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.MoonSharpInit(MoonSharp.Interpreter.Table,MoonSharp.Interpreter.Table)"]

ioTable
Type: MoonSharp.InterpreterTable

[Missing <param name="ioTable"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.MoonSharpInit(MoonSharp.Interpreter.Table,MoonSharp.Interpreter.Table)"]

See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.pow Method

MathModulepow Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.pow(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue pow(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function pow (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ pow(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member pow :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.pow(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.pow(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.rad Method

MathModulerad Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.rad(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue rad(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function rad (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ rad(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member rad :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.rad(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.rad(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.random Method

MathModulerandom Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.random(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue random(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function random (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ random(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member random :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.random(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.random(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.randomseed Method

MathModulerandomseed Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.randomseed(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue randomseed(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function randomseed (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ randomseed(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member randomseed :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.randomseed(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.randomseed(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.sin Method

MathModulesin Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.sin(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue sin(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function sin (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ sin(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member sin :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.sin(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.sin(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.sinh Method

MathModulesinh Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.sinh(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue sinh(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function sinh (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ sinh(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member sinh :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.sinh(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.sinh(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.sqrt Method

MathModulesqrt Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.sqrt(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue sqrt(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function sqrt (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ sqrt(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member sqrt :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.sqrt(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.sqrt(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.tan Method

MathModuletan Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.tan(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue tan(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function tan (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ tan(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member tan :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.tan(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.tan(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.tanh Method

MathModuletanh Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.tanh(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue tanh(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function tanh (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ tanh(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member tanh :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.tanh(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MathModule.tanh(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule Fields

MathModule Fields

The MathModule type exposes the following members.

Fields
Name | Description
huge |
pi |
Top
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.huge Field

MathModulehuge Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.CoreLib.MathModule.huge"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public const double huge = 1,79769313486232E+308
Public Const huge As Double = 1,79769313486232E+308
public:
literal double huge = 1,79769313486232E+308
static val mutable huge: float

Field Value

Type: Double
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MathModule.pi Field

MathModulepi Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.CoreLib.MathModule.pi"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public const double pi = 3,14159265358979
Public Const pi As Double = 3,14159265358979
public:
literal double pi = 3,14159265358979
static val mutable pi: float

Field Value

Type: Double
See Also

Reference

MathModule Class
MoonSharp.Interpreter.CoreLib Namespace


MetaTableModule Class

MetaTableModule Class
Class implementing metatable related Lua functions (xxxmetatable and rawxxx).
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.CoreLibMetaTableModule

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class MetaTableModule
Public Class MetaTableModule
public ref class MetaTableModule
type MetaTableModule =  class end

The MetaTableModule type exposes the following members.

Constructors
 | Name | Description
Public method | MetaTableModule | Initializes a new instance of the MetaTableModule class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | getmetatable |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | rawequal |
 | rawget |
 | rawlen |
 | rawset |
 | setmetatable |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.CoreLib Namespace


MetaTableModule Constructor

MetaTableModule Constructor
Initializes a new instance of the MetaTableModule class

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MetaTableModule()
Public Sub New
public:
MetaTableModule()
new : unit -> MetaTableModule
See Also

Reference

MetaTableModule Class
MoonSharp.Interpreter.CoreLib Namespace


MetaTableModule Methods

MetaTableModule Methods

The MetaTableModule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
 | getmetatable |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | rawequal |
 | rawget |
 | rawlen |
 | rawset |
 | setmetatable |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MetaTableModule Class
MoonSharp.Interpreter.CoreLib Namespace


MetaTableModule.getmetatable Method

MetaTableModulegetmetatable Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MetaTableModule.getmetatable(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue getmetatable(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function getmetatable (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ getmetatable(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member getmetatable :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MetaTableModule.getmetatable(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MetaTableModule.getmetatable(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MetaTableModule Class
MoonSharp.Interpreter.CoreLib Namespace


MetaTableModule.rawequal Method

MetaTableModulerawequal Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MetaTableModule.rawequal(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue rawequal(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function rawequal (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ rawequal(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member rawequal :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MetaTableModule.rawequal(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MetaTableModule.rawequal(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MetaTableModule Class
MoonSharp.Interpreter.CoreLib Namespace


MetaTableModule.rawget Method

MetaTableModulerawget Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MetaTableModule.rawget(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue rawget(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function rawget (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ rawget(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member rawget :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MetaTableModule.rawget(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MetaTableModule.rawget(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MetaTableModule Class
MoonSharp.Interpreter.CoreLib Namespace


MetaTableModule.rawlen Method

MetaTableModulerawlen Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MetaTableModule.rawlen(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue rawlen(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function rawlen (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ rawlen(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member rawlen :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MetaTableModule.rawlen(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MetaTableModule.rawlen(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MetaTableModule Class
MoonSharp.Interpreter.CoreLib Namespace


MetaTableModule.rawset Method

MetaTableModulerawset Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MetaTableModule.rawset(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue rawset(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function rawset (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ rawset(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member rawset :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MetaTableModule.rawset(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MetaTableModule.rawset(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MetaTableModule Class
MoonSharp.Interpreter.CoreLib Namespace


MetaTableModule.setmetatable Method

MetaTableModulesetmetatable Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.MetaTableModule.setmetatable(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue setmetatable(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function setmetatable (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ setmetatable(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member setmetatable :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MetaTableModule.setmetatable(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.MetaTableModule.setmetatable(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

MetaTableModule Class
MoonSharp.Interpreter.CoreLib Namespace


OsSystemModule Class

OsSystemModule Class
Class implementing system related Lua functions from the 'os' module. Proper support requires a compatible IPlatformAccessor
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.CoreLibOsSystemModule

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class OsSystemModule
Public Class OsSystemModule
public ref class OsSystemModule
type OsSystemModule =  class end

The OsSystemModule type exposes the following members.

Constructors
 | Name | Description
Public method | OsSystemModule | Initializes a new instance of the OsSystemModule class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | execute |
 | exit |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | getenv |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | remove |
 | rename |
 | setlocale |
 | tmpname |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.CoreLib Namespace


OsSystemModule Constructor

OsSystemModule Constructor
Initializes a new instance of the OsSystemModule class

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public OsSystemModule()
Public Sub New
public:
OsSystemModule()
new : unit -> OsSystemModule
See Also

Reference

OsSystemModule Class
MoonSharp.Interpreter.CoreLib Namespace


OsSystemModule Methods

OsSystemModule Methods

The OsSystemModule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
 | execute |
 | exit |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | getenv |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | remove |
 | rename |
 | setlocale |
 | tmpname |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OsSystemModule Class
MoonSharp.Interpreter.CoreLib Namespace


OsSystemModule.execute Method

OsSystemModuleexecute Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.execute(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue execute(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function execute (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ execute(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member execute :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.execute(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.execute(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

OsSystemModule Class
MoonSharp.Interpreter.CoreLib Namespace


OsSystemModule.exit Method

OsSystemModuleexit Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.exit(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue exit(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function exit (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ exit(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member exit :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.exit(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.exit(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

OsSystemModule Class
MoonSharp.Interpreter.CoreLib Namespace


OsSystemModule.getenv Method

OsSystemModulegetenv Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.getenv(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue getenv(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function getenv (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ getenv(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member getenv :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.getenv(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.getenv(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

OsSystemModule Class
MoonSharp.Interpreter.CoreLib Namespace


OsSystemModule.remove Method

OsSystemModuleremove Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.remove(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue remove(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function remove (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ remove(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member remove :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.remove(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.remove(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

OsSystemModule Class
MoonSharp.Interpreter.CoreLib Namespace


OsSystemModule.rename Method

OsSystemModulerename Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.rename(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue rename(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function rename (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ rename(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member rename :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.rename(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.rename(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

OsSystemModule Class
MoonSharp.Interpreter.CoreLib Namespace


OsSystemModule.setlocale Method

OsSystemModulesetlocale Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.setlocale(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue setlocale(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function setlocale (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ setlocale(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member setlocale :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.setlocale(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.setlocale(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

OsSystemModule Class
MoonSharp.Interpreter.CoreLib Namespace


OsSystemModule.tmpname Method

OsSystemModuletmpname Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.tmpname(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue tmpname(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function tmpname (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ tmpname(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member tmpname :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.tmpname(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsSystemModule.tmpname(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

OsSystemModule Class
MoonSharp.Interpreter.CoreLib Namespace


OsTimeModule Class

OsTimeModule Class
Class implementing time related Lua functions from the 'os' module.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.CoreLibOsTimeModule

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class OsTimeModule
Public Class OsTimeModule
public ref class OsTimeModule
type OsTimeModule =  class end

The OsTimeModule type exposes the following members.

Constructors
 | Name | Description
Public method | OsTimeModule | Initializes a new instance of the OsTimeModule class
Top
Methods
 | Name | Description
 | clock |
 | date |
 | difftime |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | time |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.CoreLib Namespace


OsTimeModule Constructor

OsTimeModule Constructor
Initializes a new instance of the OsTimeModule class

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public OsTimeModule()
Public Sub New
public:
OsTimeModule()
new : unit -> OsTimeModule
See Also

Reference

OsTimeModule Class
MoonSharp.Interpreter.CoreLib Namespace


OsTimeModule Methods

OsTimeModule Methods

The OsTimeModule type exposes the following members.

Methods
 | Name | Description
 | clock |
 | date |
 | difftime |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | time |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OsTimeModule Class
MoonSharp.Interpreter.CoreLib Namespace


OsTimeModule.clock Method

OsTimeModuleclock Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.OsTimeModule.clock(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue clock(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function clock (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ clock(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member clock :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsTimeModule.clock(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsTimeModule.clock(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

OsTimeModule Class
MoonSharp.Interpreter.CoreLib Namespace


OsTimeModule.date Method

OsTimeModuledate Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.OsTimeModule.date(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue date(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function date (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ date(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member date :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsTimeModule.date(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsTimeModule.date(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

OsTimeModule Class
MoonSharp.Interpreter.CoreLib Namespace


OsTimeModule.difftime Method

OsTimeModuledifftime Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.OsTimeModule.difftime(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue difftime(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function difftime (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ difftime(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member difftime :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsTimeModule.difftime(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsTimeModule.difftime(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

OsTimeModule Class
MoonSharp.Interpreter.CoreLib Namespace


OsTimeModule.time Method

OsTimeModuletime Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.OsTimeModule.time(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue time(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function time (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ time(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member time :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsTimeModule.time(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.OsTimeModule.time(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

OsTimeModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule Class

StringModule Class
Class implementing string Lua functions
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.CoreLibStringModule

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class StringModule
Public Class StringModule
public ref class StringModule
type StringModule =  class end

The StringModule type exposes the following members.

Constructors
 | Name | Description
Public method | StringModule | Initializes a new instance of the StringModule class
Top
Methods
 | Name | Description
 | byte |
 | char |
 | contains |
 | dump |
 | endsWith |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | find |
 | format |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | gmatch |
 | gsub |
 | len |
 | lower |
 | match |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoonSharpInit |
 | rep |
 | reverse |
 | startsWith |
 | sub |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | unicode |
 | upper |
Top
Fields
Name | Description
BASE64_DUMP_HEADER |
Top
See Also

Reference

MoonSharp.Interpreter.CoreLib Namespace


StringModule Constructor

StringModule Constructor
Initializes a new instance of the StringModule class

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public StringModule()
Public Sub New
public:
StringModule()
new : unit -> StringModule
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule Methods

StringModule Methods

The StringModule type exposes the following members.

Methods
 | Name | Description
 | byte |
 | char |
 | contains |
 | dump |
 | endsWith |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | find |
 | format |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | gmatch |
 | gsub |
 | len |
 | lower |
 | match |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MoonSharpInit |
 | rep |
 | reverse |
 | startsWith |
 | sub |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | unicode |
 | upper |
Top
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.byte Method

StringModulebyte Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.byte(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue byte(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function byte (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ byte(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member byte :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.byte(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.byte(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.char Method

StringModulechar Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.char(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue char(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function char (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ char(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member char :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.char(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.char(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.contains Method

StringModulecontains Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.contains(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue contains(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function contains (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ contains(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member contains :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.contains(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.contains(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.dump Method

StringModuledump Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.dump(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue dump(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function dump (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ dump(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member dump :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.dump(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.dump(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.endsWith Method

StringModuleendsWith Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.endsWith(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue endsWith(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function endsWith (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ endsWith(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member endsWith :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.endsWith(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.endsWith(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.find Method

StringModulefind Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.find(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue find(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function find (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ find(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member find :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.find(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.find(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.format Method

StringModuleformat Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.format(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue format(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function format (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ format(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member format :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.format(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.format(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.gmatch Method

StringModulegmatch Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.gmatch(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue gmatch(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function gmatch (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ gmatch(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member gmatch :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.gmatch(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.gmatch(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.gsub Method

StringModulegsub Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.gsub(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue gsub(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function gsub (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ gsub(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member gsub :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.gsub(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.gsub(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.len Method

StringModulelen Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.len(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue len(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function len (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ len(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member len :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.len(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.len(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.lower Method

StringModulelower Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.lower(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue lower(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function lower (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ lower(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member lower :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.lower(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.lower(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.match Method

StringModulematch Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.match(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue match(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function match (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ match(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member match :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.match(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.match(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.MoonSharpInit Method

StringModuleMoonSharpInit Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.MoonSharpInit(MoonSharp.Interpreter.Table,MoonSharp.Interpreter.Table)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static void MoonSharpInit(
    Table globalTable,
    Table stringTable
)
Public Shared Sub MoonSharpInit (
    globalTable As Table,
    stringTable As Table
)
public:
static void MoonSharpInit(
    Table^ globalTable,
    Table^ stringTable
)
static member MoonSharpInit :
        globalTable : Table *
        stringTable : Table -> unit

Parameters

globalTable
Type: MoonSharp.InterpreterTable

[Missing <param name="globalTable"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.MoonSharpInit(MoonSharp.Interpreter.Table,MoonSharp.Interpreter.Table)"]

stringTable
Type: MoonSharp.InterpreterTable

[Missing <param name="stringTable"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.MoonSharpInit(MoonSharp.Interpreter.Table,MoonSharp.Interpreter.Table)"]

See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.rep Method

StringModulerep Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.rep(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue rep(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function rep (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ rep(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member rep :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.rep(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.rep(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.reverse Method

StringModulereverse Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.reverse(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue reverse(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function reverse (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ reverse(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member reverse :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.reverse(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.reverse(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.startsWith Method

StringModulestartsWith Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.startsWith(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue startsWith(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function startsWith (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ startsWith(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member startsWith :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.startsWith(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.startsWith(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.sub Method

StringModulesub Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.sub(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue sub(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function sub (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ sub(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member sub :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.sub(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.sub(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.unicode Method

StringModuleunicode Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.unicode(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue unicode(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function unicode (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ unicode(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member unicode :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.unicode(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.unicode(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.upper Method

StringModuleupper Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.upper(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue upper(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function upper (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ upper(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member upper :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.upper(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.StringModule.upper(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule Fields

StringModule Fields

The StringModule type exposes the following members.

Fields
Name | Description
BASE64_DUMP_HEADER |
Top
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


StringModule.BASE64_DUMP_HEADER Field

StringModuleBASE64_DUMP_HEADER Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.CoreLib.StringModule.BASE64_DUMP_HEADER"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public const string BASE64_DUMP_HEADER = "MoonSharp_dump_b64::"
Public Const BASE64_DUMP_HEADER As String = "MoonSharp_dump_b64::"
public:
literal String^ BASE64_DUMP_HEADER = "MoonSharp_dump_b64::"
static val mutable BASE64_DUMP_HEADER: string

Field Value

Type: String
See Also

Reference

StringModule Class
MoonSharp.Interpreter.CoreLib Namespace


TableIteratorsModule Class

TableIteratorsModule Class
Class implementing table Lua iterators (pairs, ipairs, next)
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.CoreLibTableIteratorsModule

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class TableIteratorsModule
Public Class TableIteratorsModule
public ref class TableIteratorsModule
type TableIteratorsModule =  class end

The TableIteratorsModule type exposes the following members.

Constructors
 | Name | Description
Public method | TableIteratorsModule | Initializes a new instance of the TableIteratorsModule class
Top
Methods
 | Name | Description
 | __next_i |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ipairs |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | next |
 | pairs |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.CoreLib Namespace


TableIteratorsModule Constructor

TableIteratorsModule Constructor
Initializes a new instance of the TableIteratorsModule class

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public TableIteratorsModule()
Public Sub New
public:
TableIteratorsModule()
new : unit -> TableIteratorsModule
See Also

Reference

TableIteratorsModule Class
MoonSharp.Interpreter.CoreLib Namespace


TableIteratorsModule Methods

TableIteratorsModule Methods

The TableIteratorsModule type exposes the following members.

Methods
 | Name | Description
 | __next_i |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ipairs |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | next |
 | pairs |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TableIteratorsModule Class
MoonSharp.Interpreter.CoreLib Namespace


TableIteratorsModule.__next_i Method

TableIteratorsModule__next_i Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.TableIteratorsModule.__next_i(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue __next_i(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function __next_i (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ __next_i(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member __next_i :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableIteratorsModule.__next_i(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableIteratorsModule.__next_i(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

TableIteratorsModule Class
MoonSharp.Interpreter.CoreLib Namespace


TableIteratorsModule.ipairs Method

TableIteratorsModuleipairs Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.TableIteratorsModule.ipairs(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue ipairs(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function ipairs (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ ipairs(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member ipairs :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableIteratorsModule.ipairs(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableIteratorsModule.ipairs(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

TableIteratorsModule Class
MoonSharp.Interpreter.CoreLib Namespace


TableIteratorsModule.next Method

TableIteratorsModulenext Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.TableIteratorsModule.next(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue next(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function next (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ next(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member next :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableIteratorsModule.next(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableIteratorsModule.next(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

TableIteratorsModule Class
MoonSharp.Interpreter.CoreLib Namespace


TableIteratorsModule.pairs Method

TableIteratorsModulepairs Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.TableIteratorsModule.pairs(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue pairs(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function pairs (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ pairs(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member pairs :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableIteratorsModule.pairs(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableIteratorsModule.pairs(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

TableIteratorsModule Class
MoonSharp.Interpreter.CoreLib Namespace


TableModule Class

TableModule Class
Class implementing table Lua functions
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.CoreLibTableModule

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class TableModule
Public Class TableModule
public ref class TableModule
type TableModule =  class end

The TableModule type exposes the following members.

Constructors
 | Name | Description
Public method | TableModule | Initializes a new instance of the TableModule class
Top
Methods
 | Name | Description
 | concat |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | insert |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | pack |
 | remove |
 | sort |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | unpack |
Top
See Also

Reference

MoonSharp.Interpreter.CoreLib Namespace


TableModule Constructor

TableModule Constructor
Initializes a new instance of the TableModule class

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public TableModule()
Public Sub New
public:
TableModule()
new : unit -> TableModule
See Also

Reference

TableModule Class
MoonSharp.Interpreter.CoreLib Namespace


TableModule Methods

TableModule Methods

The TableModule type exposes the following members.

Methods
 | Name | Description
 | concat |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | insert |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | pack |
 | remove |
 | sort |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | unpack |
Top
See Also

Reference

TableModule Class
MoonSharp.Interpreter.CoreLib Namespace


TableModule.concat Method

TableModuleconcat Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule.concat(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue concat(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function concat (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ concat(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member concat :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule.concat(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule.concat(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

TableModule Class
MoonSharp.Interpreter.CoreLib Namespace


TableModule.insert Method

TableModuleinsert Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule.insert(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue insert(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function insert (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ insert(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member insert :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule.insert(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule.insert(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

TableModule Class
MoonSharp.Interpreter.CoreLib Namespace


TableModule.pack Method

TableModulepack Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule.pack(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue pack(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function pack (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ pack(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member pack :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule.pack(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule.pack(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

TableModule Class
MoonSharp.Interpreter.CoreLib Namespace


TableModule.remove Method

TableModuleremove Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule.remove(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue remove(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function remove (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ remove(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member remove :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule.remove(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule.remove(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

TableModule Class
MoonSharp.Interpreter.CoreLib Namespace


TableModule.sort Method

TableModulesort Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule.sort(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue sort(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function sort (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ sort(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member sort :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule.sort(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule.sort(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

TableModule Class
MoonSharp.Interpreter.CoreLib Namespace


TableModule.unpack Method

TableModuleunpack Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule.unpack(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue unpack(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function unpack (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ unpack(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member unpack :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule.unpack(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule.unpack(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

TableModule Class
MoonSharp.Interpreter.CoreLib Namespace


TableModule_Globals Class

TableModule_Globals Class
Class exposing table.unpack and table.pack in the global namespace (to work around the most common Lua 5.1 compatibility issue).
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.CoreLibTableModule_Globals

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class TableModule_Globals
Public Class TableModule_Globals
public ref class TableModule_Globals
type TableModule_Globals =  class end

The TableModule_Globals type exposes the following members.

Constructors
 | Name | Description
Public method | TableModule_Globals | Initializes a new instance of the TableModule_Globals class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | pack |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | unpack |
Top
See Also

Reference

MoonSharp.Interpreter.CoreLib Namespace


TableModule_Globals Constructor

TableModule_Globals Constructor
Initializes a new instance of the TableModule_Globals class

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public TableModule_Globals()
Public Sub New
public:
TableModule_Globals()
new : unit -> TableModule_Globals
See Also

Reference

TableModule_Globals Class
MoonSharp.Interpreter.CoreLib Namespace


TableModule_Globals Methods

TableModule_Globals Methods

The TableModule_Globals type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | pack |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | unpack |
Top
See Also

Reference

TableModule_Globals Class
MoonSharp.Interpreter.CoreLib Namespace


TableModule_Globals.pack Method

TableModule_Globalspack Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule_Globals.pack(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue pack(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function pack (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ pack(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member pack :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule_Globals.pack(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule_Globals.pack(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

TableModule_Globals Class
MoonSharp.Interpreter.CoreLib Namespace


TableModule_Globals.unpack Method

TableModule_Globalsunpack Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule_Globals.unpack(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.CoreLib
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue unpack(
    ScriptExecutionContext executionContext,
    CallbackArguments args
)
Public Shared Function unpack (
    executionContext As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
static DynValue^ unpack(
    ScriptExecutionContext^ executionContext,
    CallbackArguments^ args
)
static member unpack :
        executionContext : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

executionContext
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="executionContext"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule_Globals.unpack(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.CoreLib.TableModule_Globals.unpack(MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue
See Also

Reference

TableModule_Globals Class
MoonSharp.Interpreter.CoreLib Namespace


MoonSharp.Interpreter.Debugging Namespace

MoonSharp.Interpreter.Debugging Namespace
Namespace containing classes used to support debuggers
Classes
 | Class | Description
Public class | DebuggerAction | Wrapper for a debugger initiated action
Public class | DebugService | Class providing services specific to debugger implementations.
Public class | SourceCode | Class representing the source code of a given script
Public class | SourceRef | Class representing a reference to source code interval
Public class | WatchItem | A watch item for the debugger to consume. Most properties make or not sense depending on the WatchType.
Interfaces
 | Interface | Description
Public interface | IDebugger | Interface for debuggers to implement, in order to provide debugging facilities to Scripts.
Enumerations
 | Enumeration | Description
Public enumeration | DebuggerActionActionType | Type of the action
Public enumeration | DebuggerCaps | Enumeration of capabilities for a debugger
Public enumeration | WatchType | Enumeration of the possible watch types


DebuggerAction Class

DebuggerAction Class
Wrapper for a debugger initiated action
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.DebuggingDebuggerAction

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class DebuggerAction
Public Class DebuggerAction
public ref class DebuggerAction
type DebuggerAction =  class end

The DebuggerAction type exposes the following members.

Constructors
 | Name | Description
Public method | DebuggerAction | Initializes a new instance of the DebuggerAction class.
Top
Properties
 | Name | Description
Public property | Action | The type of action
Public property | Age | Gets the age of this debugger action
Public property | Lines | Gets or sets the lines. This is used for the ResetBreakpoints and sets line-based bps only.
Public property | SourceCol | Gets or sets the source column this action refers to.
Public property | SourceID | Gets or sets the source identifier this action refers to. GetSourceCode(Int32)
Public property | SourceLine | Gets or sets the source line this action refers to.
Public property | TimeStampUTC | Gets the time stamp UTC of this action
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

MoonSharp.Interpreter.Debugging Namespace


DebuggerAction Constructor

DebuggerAction Constructor
Initializes a new instance of the DebuggerAction class.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggerAction()
Public Sub New
public:
DebuggerAction()
new : unit -> DebuggerAction
See Also

Reference

DebuggerAction Class
MoonSharp.Interpreter.Debugging Namespace


DebuggerAction Properties

DebuggerAction Properties

The DebuggerAction type exposes the following members.

Properties
 | Name | Description
Public property | Action | The type of action
Public property | Age | Gets the age of this debugger action
Public property | Lines | Gets or sets the lines. This is used for the ResetBreakpoints and sets line-based bps only.
Public property | SourceCol | Gets or sets the source column this action refers to.
Public property | SourceID | Gets or sets the source identifier this action refers to. GetSourceCode(Int32)
Public property | SourceLine | Gets or sets the source line this action refers to.
Public property | TimeStampUTC | Gets the time stamp UTC of this action
Top
See Also

Reference

DebuggerAction Class
MoonSharp.Interpreter.Debugging Namespace


DebuggerAction.Action Property

DebuggerActionAction Property
The type of action

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DebuggerActionActionType Action { get; set; }
Public Property Action As DebuggerActionActionType
    Get
    Set
public:
property DebuggerActionActionType Action {
    DebuggerActionActionType get ();
    void set (DebuggerActionActionType value);
}
member Action : DebuggerActionActionType with get, set

Property Value

Type: DebuggerActionActionType
See Also

Reference

DebuggerAction Class
MoonSharp.Interpreter.Debugging Namespace


DebuggerAction.Age Property

DebuggerActionAge Property
Gets the age of this debugger action

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Age { get; }
Public ReadOnly Property Age As TimeSpan
    Get
public:
property TimeSpan Age {
    TimeSpan get ();
}
member Age : TimeSpan with get

Property Value

Type: TimeSpan
See Also

Reference

DebuggerAction Class
MoonSharp.Interpreter.Debugging Namespace


DebuggerAction.Lines Property

DebuggerActionLines Property
Gets or sets the lines. This is used for the ResetBreakpoints and sets line-based bps only.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int[] Lines { get; set; }
Public Property Lines As Integer()
    Get
    Set
public:
property array<int>^ Lines {
    array<int>^ get ();
    void set (array<int>^ value);
}
member Lines : int[] with get, set

Property Value

Type: Int32
See Also

Reference

DebuggerAction Class
MoonSharp.Interpreter.Debugging Namespace


DebuggerAction.SourceCol Property

DebuggerActionSourceCol Property
Gets or sets the source column this action refers to.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int SourceCol { get; set; }
Public Property SourceCol As Integer
    Get
    Set
public:
property int SourceCol {
    int get ();
    void set (int value);
}
member SourceCol : int with get, set

Property Value

Type: Int32
See Also

Reference

DebuggerAction Class
MoonSharp.Interpreter.Debugging Namespace


DebuggerAction.SourceID Property

DebuggerActionSourceID Property
Gets or sets the source identifier this action refers to. GetSourceCode(Int32)

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int SourceID { get; set; }
Public Property SourceID As Integer
    Get
    Set
public:
property int SourceID {
    int get ();
    void set (int value);
}
member SourceID : int with get, set

Property Value

Type: Int32
See Also

Reference

DebuggerAction Class
MoonSharp.Interpreter.Debugging Namespace


DebuggerAction.SourceLine Property

DebuggerActionSourceLine Property
Gets or sets the source line this action refers to.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int SourceLine { get; set; }
Public Property SourceLine As Integer
    Get
    Set
public:
property int SourceLine {
    int get ();
    void set (int value);
}
member SourceLine : int with get, set

Property Value

Type: Int32
See Also

Reference

DebuggerAction Class
MoonSharp.Interpreter.Debugging Namespace


DebuggerAction.TimeStampUTC Property

DebuggerActionTimeStampUTC Property
Gets the time stamp UTC of this action

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime TimeStampUTC { get; }
Public ReadOnly Property TimeStampUTC As DateTime
    Get
public:
property DateTime TimeStampUTC {
    DateTime get ();
}
member TimeStampUTC : DateTime with get

Property Value

Type: DateTime
See Also

Reference

DebuggerAction Class
MoonSharp.Interpreter.Debugging Namespace


DebuggerAction Methods

DebuggerAction Methods

The DebuggerAction type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

DebuggerAction Class
MoonSharp.Interpreter.Debugging Namespace


DebuggerAction.ToString Method

DebuggerActionToString Method
Returns a String that represents this instance.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String that represents this instance.
See Also

Reference

DebuggerAction Class
MoonSharp.Interpreter.Debugging Namespace


DebuggerAction.ActionType Enumeration

DebuggerActionActionType Enumeration
Type of the action

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public enum ActionType
Public Enumeration ActionType
public enum class ActionType
type ActionType
Members
Member name | Value | Description
ByteCodeStepIn | 0 | Step-in at the bytecode level
ByteCodeStepOver | 1 | Step-over at the bytecode level
ByteCodeStepOut | 2 | Step-out at the bytecode level
StepIn | 3 | Step-in at the source level
StepOver | 4 | Step-over at the source level
StepOut | 5 | Step-out at the source level
Run | 6 | Continue execution "freely"
ToggleBreakpoint | 7 | Toggles breakpoint
SetBreakpoint | 8 | Sets a breakpoint
ClearBreakpoint | 9 | Clears a breakpoint
ResetBreakpoints | 10 | Reset all breakpoints
Refresh | 11 | Refresh the data
HardRefresh | 12 | Hard refresh of data
None | 13 | No action
See Also

Reference

MoonSharp.Interpreter.Debugging Namespace


DebuggerCaps Enumeration

DebuggerCaps Enumeration
Enumeration of capabilities for a debugger

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum DebuggerCaps
<FlagsAttribute>
Public Enumeration DebuggerCaps
[FlagsAttribute]
public enum class DebuggerCaps
[<FlagsAttribute>]
type DebuggerCaps
Members
Member name | Value | Description
CanDebugSourceCode | 1 | Flag set if the debugger can debug source code
CanDebugByteCode | 2 | Flag set if the can debug VM bytecode
HasLineBasedBreakpoints | 4 | Flag set if the debugger uses breakpoints based on lines instead of tokens
See Also

Reference

MoonSharp.Interpreter.Debugging Namespace


DebugService Class

DebugService Class
Class providing services specific to debugger implementations.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.DebuggingDebugService

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DebugService : IScriptPrivateResource
Public NotInheritable Class DebugService
    Implements IScriptPrivateResource
public ref class DebugService sealed : IScriptPrivateResource
[<SealedAttribute>]
type DebugService =
    class
        interface IScriptPrivateResource
    end

The DebugService type exposes the following members.

Properties
 | Name | Description
Public property | OwnerScript | Gets the script owning this resource.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResetBreakPoints | Resets the break points for a given file. Supports only line-based breakpoints.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Debugging Namespace
MoonSharp.InterpreterIScriptPrivateResource


DebugService Properties

DebugService Properties

The DebugService type exposes the following members.

Properties
 | Name | Description
Public property | OwnerScript | Gets the script owning this resource.
Top
See Also

Reference

DebugService Class
MoonSharp.Interpreter.Debugging Namespace


DebugService.OwnerScript Property

DebugServiceOwnerScript Property
Gets the script owning this resource.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Script OwnerScript { get; }
Public ReadOnly Property OwnerScript As Script
    Get
public:
virtual property Script^ OwnerScript {
    Script^ get () sealed;
}
abstract OwnerScript : Script with get
override OwnerScript : Script with get

Property Value

Type: Script
The script owning this resource.

Implements

IScriptPrivateResourceOwnerScript
See Also

Reference

DebugService Class
MoonSharp.Interpreter.Debugging Namespace


DebugService Methods

DebugService Methods

The DebugService type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResetBreakPoints | Resets the break points for a given file. Supports only line-based breakpoints.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DebugService Class
MoonSharp.Interpreter.Debugging Namespace


DebugService.ResetBreakPoints Method

DebugServiceResetBreakPoints Method
Resets the break points for a given file. Supports only line-based breakpoints.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public HashSet<int> ResetBreakPoints(
    SourceCode src,
    HashSet<int> lines
)
Public Function ResetBreakPoints (
    src As SourceCode,
    lines As HashSet(Of Integer)
) As HashSet(Of Integer)
public:
HashSet<int>^ ResetBreakPoints(
    SourceCode^ src,
    HashSet<int>^ lines
)
member ResetBreakPoints :
        src : SourceCode *
        lines : HashSet<int> -> HashSet<int>

Parameters

src
Type: MoonSharp.Interpreter.DebuggingSourceCode
The source.
lines
Type: System.Collections.GenericHashSet Int32
The lines.

Return Value

Type: HashSet Int32
The lines for which breakpoints have been set
See Also

Reference

DebugService Class
MoonSharp.Interpreter.Debugging Namespace


IDebugger Interface

IDebugger Interface
Interface for debuggers to implement, in order to provide debugging facilities to Scripts.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public interface IDebugger
Public Interface IDebugger
public interface class IDebugger
type IDebugger =  interface end

The IDebugger type exposes the following members.

Methods
 | Name | Description
Public method | GetAction | Called by the script engine to get what action to do next.
Public method | GetDebuggerCaps | Gets the debugger caps.
Public method | GetWatchItems | Called by the script engine to get which expressions are active watches in the debugger.
Public method | IsPauseRequested | Called by the script engine at execution time to check if a break has been requested. Should return pretty fast as it's called A LOT.
Public method | RefreshBreakpoints | Called by the script engine to refresh the breakpoint list.
Public method | SetByteCode | Called by the script engine when the bytecode changes.
Public method | SetDebugService | Sets the debug service for this debugger
Public method | SetSourceCode | Called by the script engine when a source code is added or changed.
Public method | SignalExecutionEnded | Called by the script engine when the execution ends.
Public method | SignalRuntimeException | Called by the script engine when a runtime error occurs. The debugger can return true to signal the engine that it wants to break into the source of the error. If it does so, it should also return true to subsequent calls to IsPauseRequested().
Public method | Update | Called by the script engine to update watches of a given type. Note that this method is not called only for watches in the strictest term, but also for the stack, etc.
Top
See Also

Reference

MoonSharp.Interpreter.Debugging Namespace


IDebugger Methods

IDebugger Methods

The IDebugger type exposes the following members.

Methods
 | Name | Description
Public method | GetAction | Called by the script engine to get what action to do next.
Public method | GetDebuggerCaps | Gets the debugger caps.
Public method | GetWatchItems | Called by the script engine to get which expressions are active watches in the debugger.
Public method | IsPauseRequested | Called by the script engine at execution time to check if a break has been requested. Should return pretty fast as it's called A LOT.
Public method | RefreshBreakpoints | Called by the script engine to refresh the breakpoint list.
Public method | SetByteCode | Called by the script engine when the bytecode changes.
Public method | SetDebugService | Sets the debug service for this debugger
Public method | SetSourceCode | Called by the script engine when a source code is added or changed.
Public method | SignalExecutionEnded | Called by the script engine when the execution ends.
Public method | SignalRuntimeException | Called by the script engine when a runtime error occurs. The debugger can return true to signal the engine that it wants to break into the source of the error. If it does so, it should also return true to subsequent calls to IsPauseRequested().
Public method | Update | Called by the script engine to update watches of a given type. Note that this method is not called only for watches in the strictest term, but also for the stack, etc.
Top
See Also

Reference

IDebugger Interface
MoonSharp.Interpreter.Debugging Namespace


IDebugger.GetAction Method

IDebuggerGetAction Method
Called by the script engine to get what action to do next.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
DebuggerAction GetAction(
    int ip,
    SourceRef sourceref
)
Function GetAction (
    ip As Integer,
    sourceref As SourceRef
) As DebuggerAction
DebuggerAction^ GetAction(
    int ip,
    SourceRef^ sourceref
)
abstract GetAction :
        ip : int *
        sourceref : SourceRef -> DebuggerAction

Parameters

ip
Type: SystemInt32
The instruction pointer in bytecode.
sourceref
Type: MoonSharp.Interpreter.DebuggingSourceRef
The source reference.

Return Value

Type: DebuggerAction
T
See Also

Reference

IDebugger Interface
MoonSharp.Interpreter.Debugging Namespace


IDebugger.GetDebuggerCaps Method

IDebuggerGetDebuggerCaps Method
Gets the debugger caps.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
DebuggerCaps GetDebuggerCaps()
Function GetDebuggerCaps As DebuggerCaps
DebuggerCaps GetDebuggerCaps()
abstract GetDebuggerCaps : unit -> DebuggerCaps

Return Value

Type: DebuggerCaps
See Also

Reference

IDebugger Interface
MoonSharp.Interpreter.Debugging Namespace


IDebugger.GetWatchItems Method

IDebuggerGetWatchItems Method
Called by the script engine to get which expressions are active watches in the debugger.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
List<DynamicExpression> GetWatchItems()
Function GetWatchItems As List(Of DynamicExpression)
List<DynamicExpression^>^ GetWatchItems()
abstract GetWatchItems : unit -> List<DynamicExpression>

Return Value

Type: List DynamicExpression
A list of watches
See Also

Reference

IDebugger Interface
MoonSharp.Interpreter.Debugging Namespace


IDebugger.IsPauseRequested Method

IDebuggerIsPauseRequested Method
Called by the script engine at execution time to check if a break has been requested. Should return pretty fast as it's called A LOT.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
bool IsPauseRequested()
Function IsPauseRequested As Boolean
bool IsPauseRequested()
abstract IsPauseRequested : unit -> bool

Return Value

Type: Boolean
See Also

Reference

IDebugger Interface
MoonSharp.Interpreter.Debugging Namespace


IDebugger.RefreshBreakpoints Method

IDebuggerRefreshBreakpoints Method
Called by the script engine to refresh the breakpoint list.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
void RefreshBreakpoints(
    IEnumerable<SourceRef> refs
)
Sub RefreshBreakpoints (
    refs As IEnumerable(Of SourceRef)
)
void RefreshBreakpoints(
    IEnumerable<SourceRef^>^ refs
)
abstract RefreshBreakpoints :
        refs : IEnumerable<SourceRef> -> unit

Parameters

refs
Type: System.Collections.GenericIEnumerable SourceRef

[Missing <param name="refs"/> documentation for "M:MoonSharp.Interpreter.Debugging.IDebugger.RefreshBreakpoints(System.Collections.Generic.IEnumerable{MoonSharp.Interpreter.Debugging.SourceRef})"]

See Also

Reference

IDebugger Interface
MoonSharp.Interpreter.Debugging Namespace


IDebugger.SetByteCode Method

IDebuggerSetByteCode Method
Called by the script engine when the bytecode changes.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
void SetByteCode(
    string[] byteCode
)
Sub SetByteCode (
    byteCode As String()
)
void SetByteCode(
    array<String^>^ byteCode
)
abstract SetByteCode :
        byteCode : string[] -> unit

Parameters

byteCode
Type: SystemString
The bytecode source
See Also

Reference

IDebugger Interface
MoonSharp.Interpreter.Debugging Namespace


IDebugger.SetDebugService Method

IDebuggerSetDebugService Method
Sets the debug service for this debugger

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
void SetDebugService(
    DebugService debugService
)
Sub SetDebugService (
    debugService As DebugService
)
void SetDebugService(
    DebugService^ debugService
)
abstract SetDebugService :
        debugService : DebugService -> unit

Parameters

debugService
Type: MoonSharp.Interpreter.DebuggingDebugService
The debug service.
See Also

Reference

IDebugger Interface
MoonSharp.Interpreter.Debugging Namespace


IDebugger.SetSourceCode Method

IDebuggerSetSourceCode Method
Called by the script engine when a source code is added or changed.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
void SetSourceCode(
    SourceCode sourceCode
)
Sub SetSourceCode (
    sourceCode As SourceCode
)
void SetSourceCode(
    SourceCode^ sourceCode
)
abstract SetSourceCode :
        sourceCode : SourceCode -> unit

Parameters

sourceCode
Type: MoonSharp.Interpreter.DebuggingSourceCode
The source code object.
See Also

Reference

IDebugger Interface
MoonSharp.Interpreter.Debugging Namespace


IDebugger.SignalExecutionEnded Method

IDebuggerSignalExecutionEnded Method
Called by the script engine when the execution ends.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
void SignalExecutionEnded()
Sub SignalExecutionEnded
void SignalExecutionEnded()
abstract SignalExecutionEnded : unit -> unit
See Also

Reference

IDebugger Interface
MoonSharp.Interpreter.Debugging Namespace


IDebugger.SignalRuntimeException Method

IDebuggerSignalRuntimeException Method
Called by the script engine when a runtime error occurs. The debugger can return true to signal the engine that it wants to break into the source of the error. If it does so, it should also return true to subsequent calls to IsPauseRequested().

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
bool SignalRuntimeException(
    ScriptRuntimeException ex
)
Function SignalRuntimeException (
    ex As ScriptRuntimeException
) As Boolean
bool SignalRuntimeException(
    ScriptRuntimeException^ ex
)
abstract SignalRuntimeException :
        ex : ScriptRuntimeException -> bool

Parameters

ex
Type: MoonSharp.InterpreterScriptRuntimeException
The runtime exception.

Return Value

Type: Boolean
True if this error should break execution.
See Also

Reference

IDebugger Interface
MoonSharp.Interpreter.Debugging Namespace


IDebugger.Update Method

IDebuggerUpdate Method
Called by the script engine to update watches of a given type. Note that this method is not called only for watches in the strictest term, but also for the stack, etc.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
void Update(
    WatchType watchType,
    IEnumerable<WatchItem> items
)
Sub Update (
    watchType As WatchType,
    items As IEnumerable(Of WatchItem)
)
void Update(
    WatchType watchType,
    IEnumerable<WatchItem^>^ items
)
abstract Update :
        watchType : WatchType *
        items : IEnumerable<WatchItem> -> unit

Parameters

watchType
Type: MoonSharp.Interpreter.DebuggingWatchType
Type of the watch.
items
Type: System.Collections.GenericIEnumerable WatchItem
The items.
See Also

Reference

IDebugger Interface
MoonSharp.Interpreter.Debugging Namespace


SourceCode Class

SourceCode Class
Class representing the source code of a given script
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.DebuggingSourceCode

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class SourceCode : IScriptPrivateResource
Public Class SourceCode
    Implements IScriptPrivateResource
public ref class SourceCode : IScriptPrivateResource
type SourceCode =
    class
        interface IScriptPrivateResource
    end

The SourceCode type exposes the following members.

Properties
 | Name | Description
Public property | Code | Gets the source code as a string
Public property | Lines | Gets the source code lines.
Public property | Name | Gets the name of the source code
Public property | OwnerScript | Gets the script owning this resource.
Public property | SourceID | Gets the source identifier inside a script
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCodeSnippet | Gets the code snippet represented by a source ref
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Debugging Namespace


SourceCode Properties

SourceCode Properties

The SourceCode type exposes the following members.

Properties
 | Name | Description
Public property | Code | Gets the source code as a string
Public property | Lines | Gets the source code lines.
Public property | Name | Gets the name of the source code
Public property | OwnerScript | Gets the script owning this resource.
Public property | SourceID | Gets the source identifier inside a script
Top
See Also

Reference

SourceCode Class
MoonSharp.Interpreter.Debugging Namespace


SourceCode.Code Property

SourceCodeCode Property
Gets the source code as a string

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Code { get; }
Public ReadOnly Property Code As String
    Get
public:
property String^ Code {
    String^ get ();
}
member Code : string with get

Property Value

Type: String
See Also

Reference

SourceCode Class
MoonSharp.Interpreter.Debugging Namespace


SourceCode.Lines Property

SourceCodeLines Property
Gets the source code lines.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string[] Lines { get; }
Public ReadOnly Property Lines As String()
    Get
public:
property array<String^>^ Lines {
    array<String^>^ get ();
}
member Lines : string[] with get

Property Value

Type: String
See Also

Reference

SourceCode Class
MoonSharp.Interpreter.Debugging Namespace


SourceCode.Name Property

SourceCodeName Property
Gets the name of the source code

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

SourceCode Class
MoonSharp.Interpreter.Debugging Namespace


SourceCode.OwnerScript Property

SourceCodeOwnerScript Property
Gets the script owning this resource.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Script OwnerScript { get; }
Public ReadOnly Property OwnerScript As Script
    Get
public:
virtual property Script^ OwnerScript {
    Script^ get () sealed;
}
abstract OwnerScript : Script with get
override OwnerScript : Script with get

Property Value

Type: Script

Implements

IScriptPrivateResourceOwnerScript
See Also

Reference

SourceCode Class
MoonSharp.Interpreter.Debugging Namespace


SourceCode.SourceID Property

SourceCodeSourceID Property
Gets the source identifier inside a script

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int SourceID { get; }
Public ReadOnly Property SourceID As Integer
    Get
public:
property int SourceID {
    int get ();
}
member SourceID : int with get

Property Value

Type: Int32
See Also

Reference

SourceCode Class
MoonSharp.Interpreter.Debugging Namespace


SourceCode Methods

SourceCode Methods

The SourceCode type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCodeSnippet | Gets the code snippet represented by a source ref
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SourceCode Class
MoonSharp.Interpreter.Debugging Namespace


SourceCode.GetCodeSnippet Method

SourceCodeGetCodeSnippet Method
Gets the code snippet represented by a source ref

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string GetCodeSnippet(
    SourceRef sourceCodeRef
)
Public Function GetCodeSnippet (
    sourceCodeRef As SourceRef
) As String
public:
String^ GetCodeSnippet(
    SourceRef^ sourceCodeRef
)
member GetCodeSnippet :
        sourceCodeRef : SourceRef -> string

Parameters

sourceCodeRef
Type: MoonSharp.Interpreter.DebuggingSourceRef
The source code reference.

Return Value

Type: String
See Also

Reference

SourceCode Class
MoonSharp.Interpreter.Debugging Namespace


SourceRef Class

SourceRef Class
Class representing a reference to source code interval
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.DebuggingSourceRef

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class SourceRef
Public Class SourceRef
public ref class SourceRef
type SourceRef =  class end

The SourceRef type exposes the following members.

Constructors
 | Name | Description
Public method | SourceRef(SourceRef, Boolean) | Initializes a new instance of the SourceRef class
Public method | SourceRef(Int32, Int32, Int32, Int32, Int32, Boolean) | Initializes a new instance of the SourceRef class
Top
Properties
 | Name | Description
Public property | CannotBreakpoint | Gets a value indicating whether this instance cannot be set as a breakpoint
Public property | FromChar | Gets from which column the source code ref starts
Public property | FromLine | Gets from which line the source code ref starts
Public property | IsClrLocation | Gets a value indicating whether this location is inside CLR .
Public property | IsStepStop | Gets a value indicating whether this instance is a stop "step" in source mode
Public property | SourceIdx | Gets the index of the source.
Public property | ToChar | Gets to which column the source code ref ends
Public property | ToLine | Gets to which line the source code ref ends
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormatLocation | Formats the location according to script preferences
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IncludesLocation | Gets whether the source ref includes the specified location
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetNoBreakPoint | Sets the CannotBreakpoint flag.
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
Fields
 | Name | Description
Public field | Breakpoint | Gets a value indicating whether this instance is a breakpoint
Top
See Also

Reference

MoonSharp.Interpreter.Debugging Namespace


SourceRef Constructor

SourceRef Constructor
Overload List
 | Name | Description
Public method | SourceRef(SourceRef, Boolean) | Initializes a new instance of the SourceRef class
Public method | SourceRef(Int32, Int32, Int32, Int32, Int32, Boolean) | Initializes a new instance of the SourceRef class
Top
See Also

Reference

SourceRef Class
MoonSharp.Interpreter.Debugging Namespace


SourceRef Constructor (SourceRef, Boolean)

SourceRef Constructor (SourceRef, Boolean)
Initializes a new instance of the SourceRef class

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public SourceRef(
    SourceRef src,
    bool isStepStop
)
Public Sub New (
    src As SourceRef,
    isStepStop As Boolean
)
public:
SourceRef(
    SourceRef^ src,
    bool isStepStop
)
new :
        src : SourceRef *
        isStepStop : bool -> SourceRef

Parameters

src
Type: MoonSharp.Interpreter.DebuggingSourceRef

[Missing <param name="src"/> documentation for "M:MoonSharp.Interpreter.Debugging.SourceRef.#ctor(MoonSharp.Interpreter.Debugging.SourceRef,System.Boolean)"]

isStepStop
Type: SystemBoolean

[Missing <param name="isStepStop"/> documentation for "M:MoonSharp.Interpreter.Debugging.SourceRef.#ctor(MoonSharp.Interpreter.Debugging.SourceRef,System.Boolean)"]

See Also

Reference

SourceRef Class
SourceRef Overload
MoonSharp.Interpreter.Debugging Namespace


SourceRef Constructor (Int32, Int32, Int32, Int32, Int32, Boolean)

SourceRef Constructor (Int32, Int32, Int32, Int32, Int32, Boolean)
Initializes a new instance of the SourceRef class

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public SourceRef(
    int sourceIdx,
    int from,
    int to,
    int fromline,
    int toline,
    bool isStepStop
)
Public Sub New (
    sourceIdx As Integer,
    from As Integer,
    to As Integer,
    fromline As Integer,
    toline As Integer,
    isStepStop As Boolean
)
public:
SourceRef(
    int sourceIdx,
    int from,
    int to,
    int fromline,
    int toline,
    bool isStepStop
)
new :
        sourceIdx : int *
        from : int *
        to : int *
        fromline : int *
        toline : int *
        isStepStop : bool -> SourceRef

Parameters

sourceIdx
Type: SystemInt32

[Missing <param name="sourceIdx"/> documentation for "M:MoonSharp.Interpreter.Debugging.SourceRef.#ctor(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Boolean)"]

from
Type: SystemInt32

[Missing <param name="from"/> documentation for "M:MoonSharp.Interpreter.Debugging.SourceRef.#ctor(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Boolean)"]

to
Type: SystemInt32

[Missing <param name="to"/> documentation for "M:MoonSharp.Interpreter.Debugging.SourceRef.#ctor(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Boolean)"]

fromline
Type: SystemInt32

[Missing <param name="fromline"/> documentation for "M:MoonSharp.Interpreter.Debugging.SourceRef.#ctor(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Boolean)"]

toline
Type: SystemInt32

[Missing <param name="toline"/> documentation for "M:MoonSharp.Interpreter.Debugging.SourceRef.#ctor(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Boolean)"]

isStepStop
Type: SystemBoolean

[Missing <param name="isStepStop"/> documentation for "M:MoonSharp.Interpreter.Debugging.SourceRef.#ctor(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,System.Boolean)"]

See Also

Reference

SourceRef Class
SourceRef Overload
MoonSharp.Interpreter.Debugging Namespace


SourceRef Properties

SourceRef Properties

The SourceRef type exposes the following members.

Properties
 | Name | Description
Public property | CannotBreakpoint | Gets a value indicating whether this instance cannot be set as a breakpoint
Public property | FromChar | Gets from which column the source code ref starts
Public property | FromLine | Gets from which line the source code ref starts
Public property | IsClrLocation | Gets a value indicating whether this location is inside CLR .
Public property | IsStepStop | Gets a value indicating whether this instance is a stop "step" in source mode
Public property | SourceIdx | Gets the index of the source.
Public property | ToChar | Gets to which column the source code ref ends
Public property | ToLine | Gets to which line the source code ref ends
Top
See Also

Reference

SourceRef Class
MoonSharp.Interpreter.Debugging Namespace


SourceRef.CannotBreakpoint Property

SourceRefCannotBreakpoint Property
Gets a value indicating whether this instance cannot be set as a breakpoint

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool CannotBreakpoint { get; }
Public ReadOnly Property CannotBreakpoint As Boolean
    Get
public:
property bool CannotBreakpoint {
    bool get ();
}
member CannotBreakpoint : bool with get

Property Value

Type: Boolean
See Also

Reference

SourceRef Class
MoonSharp.Interpreter.Debugging Namespace


SourceRef.FromChar Property

SourceRefFromChar Property
Gets from which column the source code ref starts

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int FromChar { get; }
Public ReadOnly Property FromChar As Integer
    Get
public:
property int FromChar {
    int get ();
}
member FromChar : int with get

Property Value

Type: Int32
See Also

Reference

SourceRef Class
MoonSharp.Interpreter.Debugging Namespace


SourceRef.FromLine Property

SourceRefFromLine Property
Gets from which line the source code ref starts

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int FromLine { get; }
Public ReadOnly Property FromLine As Integer
    Get
public:
property int FromLine {
    int get ();
}
member FromLine : int with get

Property Value

Type: Int32
See Also

Reference

SourceRef Class
MoonSharp.Interpreter.Debugging Namespace


SourceRef.IsClrLocation Property

SourceRefIsClrLocation Property
Gets a value indicating whether this location is inside CLR .

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsClrLocation { get; }
Public ReadOnly Property IsClrLocation As Boolean
    Get
public:
property bool IsClrLocation {
    bool get ();
}
member IsClrLocation : bool with get

Property Value

Type: Boolean
See Also

Reference

SourceRef Class
MoonSharp.Interpreter.Debugging Namespace


SourceRef.IsStepStop Property

SourceRefIsStepStop Property
Gets a value indicating whether this instance is a stop "step" in source mode

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStepStop { get; }
Public ReadOnly Property IsStepStop As Boolean
    Get
public:
property bool IsStepStop {
    bool get ();
}
member IsStepStop : bool with get

Property Value

Type: Boolean
See Also

Reference

SourceRef Class
MoonSharp.Interpreter.Debugging Namespace


SourceRef.SourceIdx Property

SourceRefSourceIdx Property
Gets the index of the source.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int SourceIdx { get; }
Public ReadOnly Property SourceIdx As Integer
    Get
public:
property int SourceIdx {
    int get ();
}
member SourceIdx : int with get

Property Value

Type: Int32
See Also

Reference

SourceRef Class
MoonSharp.Interpreter.Debugging Namespace


SourceRef.ToChar Property

SourceRefToChar Property
Gets to which column the source code ref ends

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int ToChar { get; }
Public ReadOnly Property ToChar As Integer
    Get
public:
property int ToChar {
    int get ();
}
member ToChar : int with get

Property Value

Type: Int32
See Also

Reference

SourceRef Class
MoonSharp.Interpreter.Debugging Namespace


SourceRef.ToLine Property

SourceRefToLine Property
Gets to which line the source code ref ends

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int ToLine { get; }
Public ReadOnly Property ToLine As Integer
    Get
public:
property int ToLine {
    int get ();
}
member ToLine : int with get

Property Value

Type: Int32
See Also

Reference

SourceRef Class
MoonSharp.Interpreter.Debugging Namespace


SourceRef Methods

SourceRef Methods

The SourceRef type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FormatLocation | Formats the location according to script preferences
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IncludesLocation | Gets whether the source ref includes the specified location
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetNoBreakPoint | Sets the CannotBreakpoint flag.
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

SourceRef Class
MoonSharp.Interpreter.Debugging Namespace


SourceRef.FormatLocation Method

SourceRefFormatLocation Method
Formats the location according to script preferences

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string FormatLocation(
    Script script,
    bool forceClassicFormat = false
)
Public Function FormatLocation (
    script As Script,
    Optional forceClassicFormat As Boolean = false
) As String
public:
String^ FormatLocation(
    Script^ script,
    bool forceClassicFormat = false
)
member FormatLocation :
        script : Script *
        ?forceClassicFormat : bool
(* Defaults:
        let _forceClassicFormat = defaultArg forceClassicFormat false
*)
-> string

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
forceClassicFormat (Optional)
Type: SystemBoolean
if set to true the classic Lua format is forced.

Return Value

Type: String
See Also

Reference

SourceRef Class
MoonSharp.Interpreter.Debugging Namespace


SourceRef.IncludesLocation Method

SourceRefIncludesLocation Method
Gets whether the source ref includes the specified location

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IncludesLocation(
    int sourceIdx,
    int line,
    int col
)
Public Function IncludesLocation (
    sourceIdx As Integer,
    line As Integer,
    col As Integer
) As Boolean
public:
bool IncludesLocation(
    int sourceIdx,
    int line,
    int col
)
member IncludesLocation :
        sourceIdx : int *
        line : int *
        col : int -> bool

Parameters

sourceIdx
Type: SystemInt32
Index of the source.
line
Type: SystemInt32
The line.
col
Type: SystemInt32
The column.

Return Value

Type: Boolean
See Also

Reference

SourceRef Class
MoonSharp.Interpreter.Debugging Namespace


SourceRef.SetNoBreakPoint Method

SourceRefSetNoBreakPoint Method
Sets the CannotBreakpoint flag.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public SourceRef SetNoBreakPoint()
Public Function SetNoBreakPoint As SourceRef
public:
SourceRef^ SetNoBreakPoint()
member SetNoBreakPoint : unit -> SourceRef

Return Value

Type: SourceRef
See Also

Reference

SourceRef Class
MoonSharp.Interpreter.Debugging Namespace


SourceRef.ToString Method

SourceRefToString Method
Returns a String that represents this instance.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String that represents this instance.
See Also

Reference

SourceRef Class
MoonSharp.Interpreter.Debugging Namespace


SourceRef Fields

SourceRef Fields

The SourceRef type exposes the following members.

Fields
 | Name | Description
Public field | Breakpoint | Gets a value indicating whether this instance is a breakpoint
Top
See Also

Reference

SourceRef Class
MoonSharp.Interpreter.Debugging Namespace


SourceRef.Breakpoint Field

SourceRefBreakpoint Field
Gets a value indicating whether this instance is a breakpoint

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool Breakpoint
Public Breakpoint As Boolean
public:
bool Breakpoint
val mutable Breakpoint: bool

Field Value

Type: Boolean
See Also

Reference

SourceRef Class
MoonSharp.Interpreter.Debugging Namespace


WatchItem Class

WatchItem Class
A watch item for the debugger to consume. Most properties make or not sense depending on the WatchType.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.DebuggingWatchItem

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class WatchItem
Public Class WatchItem
public ref class WatchItem
type WatchItem =  class end

The WatchItem type exposes the following members.

Constructors
 | Name | Description
Public method | WatchItem | Initializes a new instance of the WatchItem class
Top
Properties
 | Name | Description
Public property | Address | Gets or sets the address of the item
Public property | BasePtr | Gets or sets the base pointer (base value of v-stack at entering the function). Valid only for call-stack items
Public property | IsError | Gets or sets a value indicating whether this instance is generating an error.
Public property | Location | Gets or sets the source location this item refers to.
Public property | LValue | Gets or sets the symbol reference of the item
Public property | Name | Gets or sets the name of the item
Public property | RetAddress | Gets or sets the return address. Valid only for call-stack items
Public property | Value | Gets or sets the value of the item
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

MoonSharp.Interpreter.Debugging Namespace


WatchItem Constructor

WatchItem Constructor
Initializes a new instance of the WatchItem class

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public WatchItem()
Public Sub New
public:
WatchItem()
new : unit -> WatchItem
See Also

Reference

WatchItem Class
MoonSharp.Interpreter.Debugging Namespace


WatchItem Properties

WatchItem Properties

The WatchItem type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets or sets the address of the item
Public property | BasePtr | Gets or sets the base pointer (base value of v-stack at entering the function). Valid only for call-stack items
Public property | IsError | Gets or sets a value indicating whether this instance is generating an error.
Public property | Location | Gets or sets the source location this item refers to.
Public property | LValue | Gets or sets the symbol reference of the item
Public property | Name | Gets or sets the name of the item
Public property | RetAddress | Gets or sets the return address. Valid only for call-stack items
Public property | Value | Gets or sets the value of the item
Top
See Also

Reference

WatchItem Class
MoonSharp.Interpreter.Debugging Namespace


WatchItem.Address Property

WatchItemAddress Property
Gets or sets the address of the item

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int Address { get; set; }
Public Property Address As Integer
    Get
    Set
public:
property int Address {
    int get ();
    void set (int value);
}
member Address : int with get, set

Property Value

Type: Int32
See Also

Reference

WatchItem Class
MoonSharp.Interpreter.Debugging Namespace


WatchItem.BasePtr Property

WatchItemBasePtr Property
Gets or sets the base pointer (base value of v-stack at entering the function). Valid only for call-stack items

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int BasePtr { get; set; }
Public Property BasePtr As Integer
    Get
    Set
public:
property int BasePtr {
    int get ();
    void set (int value);
}
member BasePtr : int with get, set

Property Value

Type: Int32
See Also

Reference

WatchItem Class
MoonSharp.Interpreter.Debugging Namespace


WatchItem.IsError Property

WatchItemIsError Property
Gets or sets a value indicating whether this instance is generating an error.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsError { get; set; }
Public Property IsError As Boolean
    Get
    Set
public:
property bool IsError {
    bool get ();
    void set (bool value);
}
member IsError : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WatchItem Class
MoonSharp.Interpreter.Debugging Namespace


WatchItem.Location Property

WatchItemLocation Property
Gets or sets the source location this item refers to.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public SourceRef Location { get; set; }
Public Property Location As SourceRef
    Get
    Set
public:
property SourceRef^ Location {
    SourceRef^ get ();
    void set (SourceRef^ value);
}
member Location : SourceRef with get, set

Property Value

Type: SourceRef
See Also

Reference

WatchItem Class
MoonSharp.Interpreter.Debugging Namespace


WatchItem.LValue Property

WatchItemLValue Property
Gets or sets the symbol reference of the item

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public SymbolRef LValue { get; set; }
Public Property LValue As SymbolRef
    Get
    Set
public:
property SymbolRef^ LValue {
    SymbolRef^ get ();
    void set (SymbolRef^ value);
}
member LValue : SymbolRef with get, set

Property Value

Type: SymbolRef
See Also

Reference

WatchItem Class
MoonSharp.Interpreter.Debugging Namespace


WatchItem.Name Property

WatchItemName Property
Gets or sets the name of the item

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

WatchItem Class
MoonSharp.Interpreter.Debugging Namespace


WatchItem.RetAddress Property

WatchItemRetAddress Property
Gets or sets the return address. Valid only for call-stack items

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int RetAddress { get; set; }
Public Property RetAddress As Integer
    Get
    Set
public:
property int RetAddress {
    int get ();
    void set (int value);
}
member RetAddress : int with get, set

Property Value

Type: Int32
See Also

Reference

WatchItem Class
MoonSharp.Interpreter.Debugging Namespace


WatchItem.Value Property

WatchItemValue Property
Gets or sets the value of the item

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Value { get; set; }
Public Property Value As DynValue
    Get
    Set
public:
property DynValue^ Value {
    DynValue^ get ();
    void set (DynValue^ value);
}
member Value : DynValue with get, set

Property Value

Type: DynValue
See Also

Reference

WatchItem Class
MoonSharp.Interpreter.Debugging Namespace


WatchItem Methods

WatchItem Methods

The WatchItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

WatchItem Class
MoonSharp.Interpreter.Debugging Namespace


WatchItem.ToString Method

WatchItemToString Method
Returns a String that represents this instance.

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String that represents this instance.
See Also

Reference

WatchItem Class
MoonSharp.Interpreter.Debugging Namespace


WatchType Enumeration

WatchType Enumeration
Enumeration of the possible watch types

Namespace: MoonSharp.Interpreter.Debugging
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public enum WatchType
Public Enumeration WatchType
public enum class WatchType
type WatchType
Members
Member name | Value | Description
Watches | 0 | A real variable watch
VStack | 1 | The status of the v-stack
CallStack | 2 | The call stack
Coroutines | 3 | The list of coroutines
Locals | 4 | Topmost local variables
Threads | 5 | The list of currently active coroutines
MaxValue | 6 | The maximum value of this enum
See Also

Reference

MoonSharp.Interpreter.Debugging Namespace


MoonSharp.Interpreter.Diagnostics Namespace

MoonSharp.Interpreter.Diagnostics Namespace
Namespace containing classes used to support self diagnostics (e.g. performance counters)
Classes
 | Class | Description
Public class | PerformanceResult | The result of a performance counter
Public class | PerformanceStatistics | A single object of this type exists for every script and gives access to performance statistics.
Enumerations
 | Enumeration | Description
Public enumeration | PerformanceCounter | Enumeration of the possible performance counters
Public enumeration | PerformanceCounterType | Enumeration of unit of measures of the performance counters


PerformanceCounter Enumeration

PerformanceCounter Enumeration
Enumeration of the possible performance counters

Namespace: MoonSharp.Interpreter.Diagnostics
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public enum PerformanceCounter
Public Enumeration PerformanceCounter
public enum class PerformanceCounter
type PerformanceCounter
Members
Member name | Value | Description
AstCreation | 0 | Measures the time spent parsing the source creating the AST
Compilation | 1 | Measures the time spent converting ASTs in bytecode
Execution | 2 | Measures the time spent in executing scripts
AdaptersCompilation | 3 | Measures the on the fly creation/compilation of functions in userdata descriptors
LastValue | 4 | Sentinel value to get the enum size
See Also

Reference

MoonSharp.Interpreter.Diagnostics Namespace


PerformanceCounterType Enumeration

PerformanceCounterType Enumeration
Enumeration of unit of measures of the performance counters

Namespace: MoonSharp.Interpreter.Diagnostics
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public enum PerformanceCounterType
Public Enumeration PerformanceCounterType
public enum class PerformanceCounterType
type PerformanceCounterType
Members
Member name | Value | Description
MemoryBytes | 0 | The performance counter is specified in bytes (of memory)
TimeMilliseconds | 1 | The performance counter is specified in milliseconds
See Also

Reference

MoonSharp.Interpreter.Diagnostics Namespace


PerformanceResult Class

PerformanceResult Class
The result of a performance counter
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.DiagnosticsPerformanceResult

Namespace: MoonSharp.Interpreter.Diagnostics
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class PerformanceResult
Public Class PerformanceResult
public ref class PerformanceResult
type PerformanceResult =  class end

The PerformanceResult type exposes the following members.

Constructors
 | Name | Description
Public method | PerformanceResult | Initializes a new instance of the PerformanceResult class
Top
Properties
 | Name | Description
Public property | Counter | Gets the quantity monitored - see Type to understand what this field contains
Public property | Global | Gets a value indicating whether this PerformanceResult is global or relative to the resource for which it's called.
Public property | Instances | Gets the number of instances which led to the specified counter being incremented - e.g. the times a specific code is executed, or object instanced
Public property | Name | Gets the name of the performance counter which generated this result.
Public property | Type | Gets the unit of measure of the Counter field.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PerformanceCounterTypeToString | Converts a PerformanceCounterType to a string.
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

MoonSharp.Interpreter.Diagnostics Namespace


PerformanceResult Constructor

PerformanceResult Constructor
Initializes a new instance of the PerformanceResult class

Namespace: MoonSharp.Interpreter.Diagnostics
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public PerformanceResult()
Public Sub New
public:
PerformanceResult()
new : unit -> PerformanceResult
See Also

Reference

PerformanceResult Class
MoonSharp.Interpreter.Diagnostics Namespace


PerformanceResult Properties

PerformanceResult Properties

The PerformanceResult type exposes the following members.

Properties
 | Name | Description
Public property | Counter | Gets the quantity monitored - see Type to understand what this field contains
Public property | Global | Gets a value indicating whether this PerformanceResult is global or relative to the resource for which it's called.
Public property | Instances | Gets the number of instances which led to the specified counter being incremented - e.g. the times a specific code is executed, or object instanced
Public property | Name | Gets the name of the performance counter which generated this result.
Public property | Type | Gets the unit of measure of the Counter field.
Top
See Also

Reference

PerformanceResult Class
MoonSharp.Interpreter.Diagnostics Namespace


PerformanceResult.Counter Property

PerformanceResultCounter Property
Gets the quantity monitored - see Type to understand what this field contains

Namespace: MoonSharp.Interpreter.Diagnostics
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public long Counter { get; }
Public ReadOnly Property Counter As Long
    Get
public:
property long long Counter {
    long long get ();
}
member Counter : int64 with get

Property Value

Type: Int64
See Also

Reference

PerformanceResult Class
MoonSharp.Interpreter.Diagnostics Namespace


PerformanceResult.Global Property

PerformanceResultGlobal Property
Gets a value indicating whether this PerformanceResult is global or relative to the resource for which it's called.

Namespace: MoonSharp.Interpreter.Diagnostics
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool Global { get; }
Public ReadOnly Property Global As Boolean
    Get
public:
property bool Global {
    bool get ();
}
member Global : bool with get

Property Value

Type: Boolean
See Also

Reference

PerformanceResult Class
MoonSharp.Interpreter.Diagnostics Namespace


PerformanceResult.Instances Property

PerformanceResultInstances Property
Gets the number of instances which led to the specified counter being incremented - e.g. the times a specific code is executed, or object instanced

Namespace: MoonSharp.Interpreter.Diagnostics
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int Instances { get; }
Public ReadOnly Property Instances As Integer
    Get
public:
property int Instances {
    int get ();
}
member Instances : int with get

Property Value

Type: Int32
See Also

Reference

PerformanceResult Class
MoonSharp.Interpreter.Diagnostics Namespace


PerformanceResult.Name Property

PerformanceResultName Property
Gets the name of the performance counter which generated this result.

Namespace: MoonSharp.Interpreter.Diagnostics
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

PerformanceResult Class
MoonSharp.Interpreter.Diagnostics Namespace


PerformanceResult.Type Property

PerformanceResultType Property
Gets the unit of measure of the Counter field.

Namespace: MoonSharp.Interpreter.Diagnostics
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public PerformanceCounterType Type { get; }
Public ReadOnly Property Type As PerformanceCounterType
    Get
public:
property PerformanceCounterType Type {
    PerformanceCounterType get ();
}
member Type : PerformanceCounterType with get

Property Value

Type: PerformanceCounterType
See Also

Reference

PerformanceResult Class
MoonSharp.Interpreter.Diagnostics Namespace


PerformanceResult Methods

PerformanceResult Methods

The PerformanceResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PerformanceCounterTypeToString | Converts a PerformanceCounterType to a string.
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

PerformanceResult Class
MoonSharp.Interpreter.Diagnostics Namespace


PerformanceResult.PerformanceCounterTypeToString Method

PerformanceResultPerformanceCounterTypeToString Method
Converts a PerformanceCounterType to a string.

Namespace: MoonSharp.Interpreter.Diagnostics
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string PerformanceCounterTypeToString(
    PerformanceCounterType Type
)
Public Shared Function PerformanceCounterTypeToString (
    Type As PerformanceCounterType
) As String
public:
static String^ PerformanceCounterTypeToString(
    PerformanceCounterType Type
)
static member PerformanceCounterTypeToString :
        Type : PerformanceCounterType -> string

Parameters

Type
Type: MoonSharp.Interpreter.DiagnosticsPerformanceCounterType
The type.

Return Value

Type: String
See Also

Reference

PerformanceResult Class
MoonSharp.Interpreter.Diagnostics Namespace


PerformanceResult.ToString Method

PerformanceResultToString Method
Returns a String that represents this instance.

Namespace: MoonSharp.Interpreter.Diagnostics
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

PerformanceResult Class
MoonSharp.Interpreter.Diagnostics Namespace


PerformanceStatistics Class

PerformanceStatistics Class
A single object of this type exists for every script and gives access to performance statistics.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.DiagnosticsPerformanceStatistics

Namespace: MoonSharp.Interpreter.Diagnostics
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class PerformanceStatistics
Public Class PerformanceStatistics
public ref class PerformanceStatistics
type PerformanceStatistics =  class end

The PerformanceStatistics type exposes the following members.

Constructors
 | Name | Description
Public method | PerformanceStatistics | Initializes a new instance of the PerformanceStatistics class
Top
Properties
 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this collection of performance stats is enabled.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPerformanceCounterResult | Gets the result of the specified performance counter .
Public method | GetPerformanceLog | Gets a string with a complete performance log.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Diagnostics Namespace


PerformanceStatistics Constructor

PerformanceStatistics Constructor
Initializes a new instance of the PerformanceStatistics class

Namespace: MoonSharp.Interpreter.Diagnostics
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public PerformanceStatistics()
Public Sub New
public:
PerformanceStatistics()
new : unit -> PerformanceStatistics
See Also

Reference

PerformanceStatistics Class
MoonSharp.Interpreter.Diagnostics Namespace


PerformanceStatistics Properties

PerformanceStatistics Properties

The PerformanceStatistics type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether this collection of performance stats is enabled.
Top
See Also

Reference

PerformanceStatistics Class
MoonSharp.Interpreter.Diagnostics Namespace


PerformanceStatistics.Enabled Property

PerformanceStatisticsEnabled Property
Gets or sets a value indicating whether this collection of performance stats is enabled.

Namespace: MoonSharp.Interpreter.Diagnostics
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
true if enabled; otherwise, false.
See Also

Reference

PerformanceStatistics Class
MoonSharp.Interpreter.Diagnostics Namespace


PerformanceStatistics Methods

PerformanceStatistics Methods

The PerformanceStatistics type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPerformanceCounterResult | Gets the result of the specified performance counter .
Public method | GetPerformanceLog | Gets a string with a complete performance log.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PerformanceStatistics Class
MoonSharp.Interpreter.Diagnostics Namespace


PerformanceStatistics.GetPerformanceCounterResult Method

PerformanceStatisticsGetPerformanceCounterResult Method
Gets the result of the specified performance counter .

Namespace: MoonSharp.Interpreter.Diagnostics
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public PerformanceResult GetPerformanceCounterResult(
    PerformanceCounter pc
)
Public Function GetPerformanceCounterResult (
    pc As PerformanceCounter
) As PerformanceResult
public:
PerformanceResult^ GetPerformanceCounterResult(
    PerformanceCounter pc
)
member GetPerformanceCounterResult :
        pc : PerformanceCounter -> PerformanceResult

Parameters

pc
Type: MoonSharp.Interpreter.DiagnosticsPerformanceCounter
The PerformanceCounter.

Return Value

Type: PerformanceResult
See Also

Reference

PerformanceStatistics Class
MoonSharp.Interpreter.Diagnostics Namespace


PerformanceStatistics.GetPerformanceLog Method

PerformanceStatisticsGetPerformanceLog Method
Gets a string with a complete performance log.

Namespace: MoonSharp.Interpreter.Diagnostics
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string GetPerformanceLog()
Public Function GetPerformanceLog As String
public:
String^ GetPerformanceLog()
member GetPerformanceLog : unit -> string

Return Value

Type: String
See Also

Reference

PerformanceStatistics Class
MoonSharp.Interpreter.Diagnostics Namespace


MoonSharp.Interpreter.Execution.VM Namespace

MoonSharp.Interpreter.Execution.VM Namespace

[Missing <summary> documentation for "N:MoonSharp.Interpreter.Execution.VM"]

Enumerations
 | Enumeration | Description
Public enumeration | OpCodeMetadataType |


OpCodeMetadataType Enumeration

OpCodeMetadataType Enumeration

[Missing <summary> documentation for "T:MoonSharp.Interpreter.Execution.VM.OpCodeMetadataType"]

Namespace: MoonSharp.Interpreter.Execution.VM
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public enum OpCodeMetadataType
Public Enumeration OpCodeMetadataType
public enum class OpCodeMetadataType
type OpCodeMetadataType
Members
Member name | Value | Description
ChunkEntrypoint | 0 |
FunctionEntrypoint | 1 |
See Also

Reference

MoonSharp.Interpreter.Execution.VM Namespace


MoonSharp.Interpreter.Interop Namespace

MoonSharp.Interpreter.Interop Namespace
Namespace containing classes used to customize and support advanced interoperations between scripts and CLR code.
Classes
 | Class | Description
Public class | AnonWrapper | Internal type used by AnonWrapperT for registration
Public class | AnonWrapperT | Wrapper which allows for easier management of userdata without registering a new userdata type - useful if a type which is not exposed to scripts but can be managed as a "black box" by scripts is desired.
Public class | ArrayMemberDescriptor | Member descriptor for indexer of array types
Public class | CompositeUserDataDescriptor | A user data descriptor which aggregates multiple descriptors and tries dispatching members on them, in order. Used, for example, for objects implementing multiple interfaces but for which no descriptor is specifically registered.
Public class | CustomConvertersCollection | A collection of custom converters between MoonSharp types and CLR types. If a converter function is not specified or returns null, the standard conversion path applies.
Public class | DelegateProxyFactoryTProxy, TTarget | Implementation of IProxyFactory taking two delegates for simple instancing of proxies.
Public class | DescriptorHelpers | Helper extension methods used to simplify some parts of userdata descriptor implementations
Public class | DynValueMemberDescriptor | Class providing a simple descriptor for constant DynValues in userdata
Public class | EventMemberDescriptor | Class providing easier marshalling of CLR events. Handling is limited to a narrow range of handler signatures, which, however, covers in practice most of all available events.
Public class | FieldMemberDescriptor | Class providing easier marshalling of CLR fields
Public class | FunctionMemberDescriptorBase | Class providing easier marshalling of CLR functions
Public class | InteropRegistrationPolicy | Collection of the standard policies to handle UserData type registrations. Provided mostly for compile-time backward compatibility with old code. See also : IRegistrationPolicy .
Public class | MethodMemberDescriptor | Class providing easier marshalling of CLR functions
Public class | MoonSharpVisibleAttribute | Forces a class member visibility to scripts. Can be used to hide public members or to expose non-public ones.
Public class | ObjectCallbackMemberDescriptor | Member descriptor which allows to define new members which behave similarly to class instance members
Public class | OverloadedMethodMemberDescriptor | Class providing easier marshalling of overloaded CLR functions
Public class | PropertyMemberDescriptor | Class providing easier marshalling of CLR properties
Public class | PropertyTableAssigner | Utility class which may be used to set properties on an object from values contained in a Lua table. Properties must be decorated with the MoonSharpPropertyAttribute. See PropertyTableAssignerT for a generic compile time type-safe version.
Public class | PropertyTableAssignerT | Utility class which may be used to set properties on an object of type T, from values contained in a Lua table. Properties must be decorated with the MoonSharpPropertyAttribute. This is a generic version of PropertyTableAssigner.
Public class | ProxyUserDataDescriptor | Data descriptor used for proxy objects
Public class | StandardEnumUserDataDescriptor | Standard descriptor for Enum values
Public class | StandardGenericsUserDataDescriptor | Standard user data descriptor used to instantiate generics.
Public class | StandardUserDataDescriptor | Standard descriptor for userdata types.
Public class | ValueTypeDefaultCtorMemberDescriptor | Member descriptor for the default constructor of value types.
Structures
 | Structure | Description
Public structure | ReflectionSpecialName | Class helping identifying special names found with reflection
Interfaces
 | Interface | Description
Public interface | IGeneratorUserDataDescriptor | An interface for type descriptors having the ability to generate other descriptors on the fly.
Public interface | IPropertyTableAssigner | Common interface for property assigners - basically used for sub-assigners
Public interface | IProxyFactory | Interface for proxy objects (type unsafe version)
Public interface | IProxyFactoryTProxy, TTarget | Interface for proxy objects (type safe version)
Public interface | IUserDataDescriptor | Interface used by MoonSharp to access objects of a given type from scripts.
Public interface | IUserDataType | As a convenience, every type deriving from IUserDataType is "self-described". That is, no descriptor is needed/generated and the object itself is used to describe the type for interop. See also UserData, IUserDataDescriptor and StandardUserDataDescriptor .
Enumerations
 | Enumeration | Description
Public enumeration | ReflectionSpecialNameType | Helps identifying a reflection special name


AnonWrapper Class

AnonWrapper Class
Internal type used by AnonWrapperT for registration
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropAnonWrapper
MoonSharp.Interpreter.InteropAnonWrapperT

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class AnonWrapper
Public Class AnonWrapper
public ref class AnonWrapper
type AnonWrapper =  class end

The AnonWrapper type exposes the following members.

Constructors
 | Name | Description
Public method | AnonWrapper | Initializes a new instance of the AnonWrapper class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


AnonWrapper Constructor

AnonWrapper Constructor
Initializes a new instance of the AnonWrapper class

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public AnonWrapper()
Public Sub New
public:
AnonWrapper()
new : unit -> AnonWrapper
See Also

Reference

AnonWrapper Class
MoonSharp.Interpreter.Interop Namespace


AnonWrapper Methods

AnonWrapper Methods

The AnonWrapper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnonWrapper Class
MoonSharp.Interpreter.Interop Namespace


AnonWrapper(T) Class

AnonWrapperT Class
Wrapper which allows for easier management of userdata without registering a new userdata type - useful if a type which is not exposed to scripts but can be managed as a "black box" by scripts is desired.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropAnonWrapper
MoonSharp.Interpreter.InteropAnonWrapperT

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class AnonWrapper<T> : AnonWrapper

Public Class AnonWrapper(Of T)
    Inherits AnonWrapper
generic<typename T>
public ref class AnonWrapper : public AnonWrapper
type AnonWrapper<'T> =
    class
        inherit AnonWrapper
    end

Type Parameters

T
The type to wrap

The AnonWrapperT type exposes the following members.

Constructors
 | Name | Description
Public method | AnonWrapperT | Initializes a new instance of the AnonWrapperT class.
Public method | AnonWrapperT(T) | Initializes a new instance of the AnonWrapperT class.
Top
Properties
 | Name | Description
Public property | Value | Gets or sets the value this instance wraps.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


AnonWrapper(T) Constructor

AnonWrapperT Constructor
Overload List
 | Name | Description
Public method | AnonWrapperT | Initializes a new instance of the AnonWrapperT class.
Public method | AnonWrapperT(T) | Initializes a new instance of the AnonWrapperT class.
Top
See Also

Reference

AnonWrapperT Class
MoonSharp.Interpreter.Interop Namespace


AnonWrapper(T) Constructor

AnonWrapperT Constructor
Initializes a new instance of the AnonWrapperT class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public AnonWrapper()
Public Sub New
public:
AnonWrapper()
new : unit -> AnonWrapper
See Also

Reference

AnonWrapperT Class
AnonWrapperT Overload
MoonSharp.Interpreter.Interop Namespace


AnonWrapper(T) Constructor (T)

AnonWrapperT Constructor (T)
Initializes a new instance of the AnonWrapperT class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public AnonWrapper(
    T o
)
Public Sub New (
    o As T
)
public:
AnonWrapper(
    T o
)
new :
        o : 'T -> AnonWrapper

Parameters

o
Type: T
The o.
See Also

Reference

AnonWrapperT Class
AnonWrapperT Overload
MoonSharp.Interpreter.Interop Namespace


AnonWrapper(T) Properties

AnonWrapperT Properties

The AnonWrapperT generic type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets or sets the value this instance wraps.
Top
See Also

Reference

AnonWrapperT Class
MoonSharp.Interpreter.Interop Namespace


AnonWrapper(T).Value Property

AnonWrapperTValue Property
Gets or sets the value this instance wraps.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public T Value { get; set; }
Public Property Value As T
    Get
    Set
public:
property T Value {
    T get ();
    void set (T value);
}
member Value : 'T with get, set

Property Value

Type: T
See Also

Reference

AnonWrapperT Class
MoonSharp.Interpreter.Interop Namespace


AnonWrapper(T) Methods

AnonWrapperT Methods

The AnonWrapperT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AnonWrapperT Class
MoonSharp.Interpreter.Interop Namespace


ArrayMemberDescriptor Class

ArrayMemberDescriptor Class
Member descriptor for indexer of array types
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropFunctionMemberDescriptorBase
MoonSharp.Interpreter.InteropObjectCallbackMemberDescriptor
MoonSharp.Interpreter.InteropArrayMemberDescriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class ArrayMemberDescriptor : ObjectCallbackMemberDescriptor,
    IWireableDescriptor
Public Class ArrayMemberDescriptor
    Inherits ObjectCallbackMemberDescriptor
    Implements IWireableDescriptor
public ref class ArrayMemberDescriptor : public ObjectCallbackMemberDescriptor,
    IWireableDescriptor
type ArrayMemberDescriptor =
    class
        inherit ObjectCallbackMemberDescriptor
        interface IWireableDescriptor
    end

The ArrayMemberDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | ArrayMemberDescriptor(String, Boolean) | Initializes a new instance of the ArrayMemberDescriptor class.
Public method | ArrayMemberDescriptor(String, Boolean, ParameterDescriptor) | Initializes a new instance of the ArrayMemberDescriptor class.
Top
Properties
 | Name | Description
Public property | ExtensionMethodType | Gets the type which this extension method extends, null if this is not an extension method. (Inherited from FunctionMemberDescriptorBase.)
Public property | IsStatic | Gets a value indicating whether the described method is static. (Inherited from FunctionMemberDescriptorBase.)
Public property | MemberAccess | Gets the types of access supported by this member (Inherited from FunctionMemberDescriptorBase.)
Public property | Name | Gets the name of the described method (Inherited from FunctionMemberDescriptorBase.)
Public property | Parameters | Gets the type of the arguments of the underlying CLR function (Inherited from FunctionMemberDescriptorBase.)
Public property | SortDiscriminant | Gets a sort discriminant to give consistent overload resolution matching in case of perfectly equal scores (Inherited from FunctionMemberDescriptorBase.)
Public property | VarArgsArrayType | Gets a value indicating the type of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned. (Inherited from FunctionMemberDescriptorBase.)
Public property | VarArgsElementType | Gets a value indicating the type of the elements of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned. (Inherited from FunctionMemberDescriptorBase.)
Top
Methods
 | Name | Description
Protected method | BuildArgumentList | Builds the argument list. (Inherited from FunctionMemberDescriptorBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | The internal callback which actually executes the method (Inherited from ObjectCallbackMemberDescriptor.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCallback | Gets a callback function as a delegate (Inherited from FunctionMemberDescriptorBase.)
Public method | GetCallbackAsDynValue | Gets the callback function as a DynValue. (Inherited from FunctionMemberDescriptorBase.)
Public method | GetCallbackFunction | Gets the callback function. (Inherited from FunctionMemberDescriptorBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts. (Inherited from FunctionMemberDescriptorBase.)
Protected method | Initialize | Initializes this instance. This *MUST* be called by the constructors extending this class to complete initialization. (Inherited from FunctionMemberDescriptorBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForWiring | Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.
Public method | SetValue | Sets the value. (Inherited from FunctionMemberDescriptorBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


ArrayMemberDescriptor Constructor

ArrayMemberDescriptor Constructor
Overload List
 | Name | Description
Public method | ArrayMemberDescriptor(String, Boolean) | Initializes a new instance of the ArrayMemberDescriptor class.
Public method | ArrayMemberDescriptor(String, Boolean, ParameterDescriptor) | Initializes a new instance of the ArrayMemberDescriptor class.
Top
See Also

Reference

ArrayMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ArrayMemberDescriptor Constructor (String, Boolean)

ArrayMemberDescriptor Constructor (String, Boolean)
Initializes a new instance of the ArrayMemberDescriptor class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ArrayMemberDescriptor(
    string name,
    bool isSetter
)
Public Sub New (
    name As String,
    isSetter As Boolean
)
public:
ArrayMemberDescriptor(
    String^ name,
    bool isSetter
)
new :
        name : string *
        isSetter : bool -> ArrayMemberDescriptor

Parameters

name
Type: SystemString
The name.
isSetter
Type: SystemBoolean
if set to true [is setter].
See Also

Reference

ArrayMemberDescriptor Class
ArrayMemberDescriptor Overload
MoonSharp.Interpreter.Interop Namespace


ArrayMemberDescriptor Constructor (String, Boolean, ParameterDescriptor[])

ArrayMemberDescriptor Constructor (String, Boolean, ParameterDescriptor)
Initializes a new instance of the ArrayMemberDescriptor class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ArrayMemberDescriptor(
    string name,
    bool isSetter,
    ParameterDescriptor[] indexerParams
)
Public Sub New (
    name As String,
    isSetter As Boolean,
    indexerParams As ParameterDescriptor()
)
public:
ArrayMemberDescriptor(
    String^ name,
    bool isSetter,
    array<ParameterDescriptor^>^ indexerParams
)
new :
        name : string *
        isSetter : bool *
        indexerParams : ParameterDescriptor[] -> ArrayMemberDescriptor

Parameters

name
Type: SystemString
The name.
isSetter
Type: SystemBoolean
if set to true is a setter indexer.
indexerParams
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsParameterDescriptor
The indexer parameters.
See Also

Reference

ArrayMemberDescriptor Class
ArrayMemberDescriptor Overload
MoonSharp.Interpreter.Interop Namespace


ArrayMemberDescriptor Properties

ArrayMemberDescriptor Properties

The ArrayMemberDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionMethodType | Gets the type which this extension method extends, null if this is not an extension method. (Inherited from FunctionMemberDescriptorBase.)
Public property | IsStatic | Gets a value indicating whether the described method is static. (Inherited from FunctionMemberDescriptorBase.)
Public property | MemberAccess | Gets the types of access supported by this member (Inherited from FunctionMemberDescriptorBase.)
Public property | Name | Gets the name of the described method (Inherited from FunctionMemberDescriptorBase.)
Public property | Parameters | Gets the type of the arguments of the underlying CLR function (Inherited from FunctionMemberDescriptorBase.)
Public property | SortDiscriminant | Gets a sort discriminant to give consistent overload resolution matching in case of perfectly equal scores (Inherited from FunctionMemberDescriptorBase.)
Public property | VarArgsArrayType | Gets a value indicating the type of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned. (Inherited from FunctionMemberDescriptorBase.)
Public property | VarArgsElementType | Gets a value indicating the type of the elements of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned. (Inherited from FunctionMemberDescriptorBase.)
Top
See Also

Reference

ArrayMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ArrayMemberDescriptor Methods

ArrayMemberDescriptor Methods

The ArrayMemberDescriptor type exposes the following members.

Methods
 | Name | Description
Protected method | BuildArgumentList | Builds the argument list. (Inherited from FunctionMemberDescriptorBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | The internal callback which actually executes the method (Inherited from ObjectCallbackMemberDescriptor.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCallback | Gets a callback function as a delegate (Inherited from FunctionMemberDescriptorBase.)
Public method | GetCallbackAsDynValue | Gets the callback function as a DynValue. (Inherited from FunctionMemberDescriptorBase.)
Public method | GetCallbackFunction | Gets the callback function. (Inherited from FunctionMemberDescriptorBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts. (Inherited from FunctionMemberDescriptorBase.)
Protected method | Initialize | Initializes this instance. This *MUST* be called by the constructors extending this class to complete initialization. (Inherited from FunctionMemberDescriptorBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForWiring | Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.
Public method | SetValue | Sets the value. (Inherited from FunctionMemberDescriptorBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ArrayMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ArrayMemberDescriptor.PrepareForWiring Method

ArrayMemberDescriptorPrepareForWiring Method
Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void PrepareForWiring(
    Table t
)
Public Sub PrepareForWiring (
    t As Table
)
public:
virtual void PrepareForWiring(
    Table^ t
) sealed
abstract PrepareForWiring :
        t : Table -> unit
override PrepareForWiring :
        t : Table -> unit

Parameters

t
Type: MoonSharp.InterpreterTable
The table to be filled

Implements

IWireableDescriptorPrepareForWiring(Table)
See Also

Reference

ArrayMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


CompositeUserDataDescriptor Class

CompositeUserDataDescriptor Class
A user data descriptor which aggregates multiple descriptors and tries dispatching members on them, in order. Used, for example, for objects implementing multiple interfaces but for which no descriptor is specifically registered.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropCompositeUserDataDescriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class CompositeUserDataDescriptor : IUserDataDescriptor
Public Class CompositeUserDataDescriptor
    Implements IUserDataDescriptor
public ref class CompositeUserDataDescriptor : IUserDataDescriptor
type CompositeUserDataDescriptor =
    class
        interface IUserDataDescriptor
    end

The CompositeUserDataDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | CompositeUserDataDescriptor | Initializes a new instance of the CompositeUserDataDescriptor class.
Top
Properties
 | Name | Description
Public property | Descriptors | Gets the descriptors aggregated by this object, allowing changes to the descriptor list
Public property | Name | Gets the name of the descriptor (usually, the name of the type described).
Public property | Type | Gets the type this descriptor refers to
Top
Methods
 | Name | Description
Public method | AsString | Converts this userdata to string
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Index | Performs an "index" "get" operation.
Public method | IsTypeCompatible | Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MetaIndex | Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). These standard metamethods can be supported (the return value should be a function accepting the classic parameters of the corresponding metamethod): __add, __sub, __mul, __div, __div, __pow, __unm, __eq, __lt, __le, __lt, __len, __concat, __pairs, __ipairs, __iterator, __call These standard metamethods are supported through other calls for efficiency: __index, __newindex, __tostring
Public method | SetIndex | Performs an "index" "set" operation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


CompositeUserDataDescriptor Constructor

CompositeUserDataDescriptor Constructor
Initializes a new instance of the CompositeUserDataDescriptor class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CompositeUserDataDescriptor(
    List<IUserDataDescriptor> descriptors,
    Type type
)
Public Sub New (
    descriptors As List(Of IUserDataDescriptor),
    type As Type
)
public:
CompositeUserDataDescriptor(
    List<IUserDataDescriptor^>^ descriptors,
    Type^ type
)
new :
        descriptors : List<IUserDataDescriptor> *
        type : Type -> CompositeUserDataDescriptor

Parameters

descriptors
Type: System.Collections.GenericList IUserDataDescriptor
The descriptors.
type
Type: SystemType
The type.
See Also

Reference

CompositeUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


CompositeUserDataDescriptor Properties

CompositeUserDataDescriptor Properties

The CompositeUserDataDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | Descriptors | Gets the descriptors aggregated by this object, allowing changes to the descriptor list
Public property | Name | Gets the name of the descriptor (usually, the name of the type described).
Public property | Type | Gets the type this descriptor refers to
Top
See Also

Reference

CompositeUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


CompositeUserDataDescriptor.Descriptors Property

CompositeUserDataDescriptorDescriptors Property
Gets the descriptors aggregated by this object, allowing changes to the descriptor list

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IList<IUserDataDescriptor> Descriptors { get; }
Public ReadOnly Property Descriptors As IList(Of IUserDataDescriptor)
    Get
public:
property IList<IUserDataDescriptor^>^ Descriptors {
    IList<IUserDataDescriptor^>^ get ();
}
member Descriptors : IList<IUserDataDescriptor> with get

Property Value

Type: IList IUserDataDescriptor
See Also

Reference

CompositeUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


CompositeUserDataDescriptor.Name Property

CompositeUserDataDescriptorName Property
Gets the name of the descriptor (usually, the name of the type described).

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IUserDataDescriptorName
See Also

Reference

CompositeUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


CompositeUserDataDescriptor.Type Property

CompositeUserDataDescriptorType Property
Gets the type this descriptor refers to

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Type Type { get; }
Public ReadOnly Property Type As Type
    Get
public:
virtual property Type^ Type {
    Type^ get () sealed;
}
abstract Type : Type with get
override Type : Type with get

Property Value

Type: Type

Implements

IUserDataDescriptorType
See Also

Reference

CompositeUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


CompositeUserDataDescriptor Methods

CompositeUserDataDescriptor Methods

The CompositeUserDataDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | AsString | Converts this userdata to string
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Index | Performs an "index" "get" operation.
Public method | IsTypeCompatible | Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MetaIndex | Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). These standard metamethods can be supported (the return value should be a function accepting the classic parameters of the corresponding metamethod): __add, __sub, __mul, __div, __div, __pow, __unm, __eq, __lt, __le, __lt, __len, __concat, __pairs, __ipairs, __iterator, __call These standard metamethods are supported through other calls for efficiency: __index, __newindex, __tostring
Public method | SetIndex | Performs an "index" "set" operation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompositeUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


CompositeUserDataDescriptor.AsString Method

CompositeUserDataDescriptorAsString Method
Converts this userdata to string

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string AsString(
    Object obj
)
Public Function AsString (
    obj As Object
) As String
public:
virtual String^ AsString(
    Object^ obj
) sealed
abstract AsString :
        obj : Object -> string
override AsString :
        obj : Object -> string

Parameters

obj
Type: SystemObject
The object.

Return Value

Type: String

Implements

IUserDataDescriptorAsString(Object)
See Also

Reference

CompositeUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


CompositeUserDataDescriptor.Index Method

CompositeUserDataDescriptorIndex Method
Performs an "index" "get" operation.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Index(
    Script script,
    Object obj,
    DynValue index,
    bool isNameIndex
)
Public Function Index (
    script As Script,
    obj As Object,
    index As DynValue,
    isNameIndex As Boolean
) As DynValue
public:
virtual DynValue^ Index(
    Script^ script,
    Object^ obj,
    DynValue^ index,
    bool isNameIndex
) sealed
abstract Index :
        script : Script *
        obj : Object *
        index : DynValue *
        isNameIndex : bool -> DynValue
override Index :
        script : Script *
        obj : Object *
        index : DynValue *
        isNameIndex : bool -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script originating the request
obj
Type: SystemObject
The object (null if a static request is done)
index
Type: MoonSharp.InterpreterDynValue
The index.
isNameIndex
Type: SystemBoolean

[Missing <param name="isNameIndex"/> documentation for "M:MoonSharp.Interpreter.Interop.CompositeUserDataDescriptor.Index(MoonSharp.Interpreter.Script,System.Object,MoonSharp.Interpreter.DynValue,System.Boolean)"]

Return Value

Type: DynValue

Implements

IUserDataDescriptorIndex(Script, Object, DynValue, Boolean)
See Also

Reference

CompositeUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


CompositeUserDataDescriptor.IsTypeCompatible Method

CompositeUserDataDescriptorIsTypeCompatible Method
Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTypeCompatible(
    Type type,
    Object obj
)
Public Function IsTypeCompatible (
    type As Type,
    obj As Object
) As Boolean
public:
virtual bool IsTypeCompatible(
    Type^ type,
    Object^ obj
) sealed
abstract IsTypeCompatible :
        type : Type *
        obj : Object -> bool
override IsTypeCompatible :
        type : Type *
        obj : Object -> bool

Parameters

type
Type: SystemType
The type.
obj
Type: SystemObject
The object.

Return Value

Type: Boolean

Implements

IUserDataDescriptorIsTypeCompatible(Type, Object)
See Also

Reference

CompositeUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


CompositeUserDataDescriptor.MetaIndex Method

CompositeUserDataDescriptorMetaIndex Method
Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). These standard metamethods can be supported (the return value should be a function accepting the classic parameters of the corresponding metamethod): __add, __sub, __mul, __div, __div, __pow, __unm, __eq, __lt, __le, __lt, __len, __concat, __pairs, __ipairs, __iterator, __call These standard metamethods are supported through other calls for efficiency: __index, __newindex, __tostring

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue MetaIndex(
    Script script,
    Object obj,
    string metaname
)
Public Function MetaIndex (
    script As Script,
    obj As Object,
    metaname As String
) As DynValue
public:
virtual DynValue^ MetaIndex(
    Script^ script,
    Object^ obj,
    String^ metaname
) sealed
abstract MetaIndex :
        script : Script *
        obj : Object *
        metaname : string -> DynValue
override MetaIndex :
        script : Script *
        obj : Object *
        metaname : string -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script originating the request
obj
Type: SystemObject
The object (null if a static request is done)
metaname
Type: SystemString
The name of the metamember.

Return Value

Type: DynValue

Implements

IUserDataDescriptorMetaIndex(Script, Object, String)
See Also

Reference

CompositeUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


CompositeUserDataDescriptor.SetIndex Method

CompositeUserDataDescriptorSetIndex Method
Performs an "index" "set" operation.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool SetIndex(
    Script script,
    Object obj,
    DynValue index,
    DynValue value,
    bool isNameIndex
)
Public Function SetIndex (
    script As Script,
    obj As Object,
    index As DynValue,
    value As DynValue,
    isNameIndex As Boolean
) As Boolean
public:
virtual bool SetIndex(
    Script^ script,
    Object^ obj,
    DynValue^ index,
    DynValue^ value,
    bool isNameIndex
) sealed
abstract SetIndex :
        script : Script *
        obj : Object *
        index : DynValue *
        value : DynValue *
        isNameIndex : bool -> bool
override SetIndex :
        script : Script *
        obj : Object *
        index : DynValue *
        value : DynValue *
        isNameIndex : bool -> bool

Parameters

script
Type: MoonSharp.InterpreterScript
The script originating the request
obj
Type: SystemObject
The object (null if a static request is done)
index
Type: MoonSharp.InterpreterDynValue
The index.
value
Type: MoonSharp.InterpreterDynValue
The value to be set
isNameIndex
Type: SystemBoolean

[Missing <param name="isNameIndex"/> documentation for "M:MoonSharp.Interpreter.Interop.CompositeUserDataDescriptor.SetIndex(MoonSharp.Interpreter.Script,System.Object,MoonSharp.Interpreter.DynValue,MoonSharp.Interpreter.DynValue,System.Boolean)"]

Return Value

Type: Boolean

Implements

IUserDataDescriptorSetIndex(Script, Object, DynValue, DynValue, Boolean)
See Also

Reference

CompositeUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


CustomConvertersCollection Class

CustomConvertersCollection Class
A collection of custom converters between MoonSharp types and CLR types. If a converter function is not specified or returns null, the standard conversion path applies.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropCustomConvertersCollection

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class CustomConvertersCollection
Public Class CustomConvertersCollection
public ref class CustomConvertersCollection
type CustomConvertersCollection =  class end

The CustomConvertersCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes all converters.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetClrToScriptCustomConversion | Gets a custom converter from a CLR data type, or null
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetScriptToClrCustomConversion | Gets a custom converter from a script data type to a CLR data type, or null
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetClrToScriptCustomConversion(Type, FuncObject, DynValue) | Obsolete.
Public method | SetClrToScriptCustomConversion(Type, FuncScript, Object, DynValue) | Sets a custom converter from a CLR data type. Set null to remove a previous custom converter.
Public method | SetClrToScriptCustomConversionT(FuncT, DynValue) | Obsolete. Sets a custom converter from a CLR data type. Set null to remove a previous custom converter.
Public method | SetClrToScriptCustomConversionT(FuncScript, T, DynValue) | Sets a custom converter from a CLR data type. Set null to remove a previous custom converter.
Public method | SetScriptToClrCustomConversion | Sets a custom converter from a script data type to a CLR data type. Set null to remove a previous custom converter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


CustomConvertersCollection Methods

CustomConvertersCollection Methods

The CustomConvertersCollection type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Removes all converters.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetClrToScriptCustomConversion | Gets a custom converter from a CLR data type, or null
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetScriptToClrCustomConversion | Gets a custom converter from a script data type to a CLR data type, or null
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetClrToScriptCustomConversion(Type, FuncObject, DynValue) | Obsolete.
Public method | SetClrToScriptCustomConversion(Type, FuncScript, Object, DynValue) | Sets a custom converter from a CLR data type. Set null to remove a previous custom converter.
Public method | SetClrToScriptCustomConversionT(FuncT, DynValue) | Obsolete. Sets a custom converter from a CLR data type. Set null to remove a previous custom converter.
Public method | SetClrToScriptCustomConversionT(FuncScript, T, DynValue) | Sets a custom converter from a CLR data type. Set null to remove a previous custom converter.
Public method | SetScriptToClrCustomConversion | Sets a custom converter from a script data type to a CLR data type. Set null to remove a previous custom converter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CustomConvertersCollection Class
MoonSharp.Interpreter.Interop Namespace


CustomConvertersCollection.Clear Method

CustomConvertersCollectionClear Method
Removes all converters.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

CustomConvertersCollection Class
MoonSharp.Interpreter.Interop Namespace


CustomConvertersCollection.GetClrToScriptCustomConversion Method

CustomConvertersCollectionGetClrToScriptCustomConversion Method
Gets a custom converter from a CLR data type, or null

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Func<Script, Object, DynValue> GetClrToScriptCustomConversion(
    Type clrDataType
)
Public Function GetClrToScriptCustomConversion (
    clrDataType As Type
) As Func(Of Script, Object, DynValue)
public:
Func<Script^, Object^, DynValue^>^ GetClrToScriptCustomConversion(
    Type^ clrDataType
)
member GetClrToScriptCustomConversion :
        clrDataType : Type -> Func<Script, Object, DynValue>

Parameters

clrDataType
Type: SystemType
Type of the color data.

Return Value

Type: Func Script, Object, DynValue
The converter function, or null if not found
See Also

Reference

CustomConvertersCollection Class
MoonSharp.Interpreter.Interop Namespace


CustomConvertersCollection.GetScriptToClrCustomConversion Method

CustomConvertersCollectionGetScriptToClrCustomConversion Method
Gets a custom converter from a script data type to a CLR data type, or null

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Func<DynValue, Object> GetScriptToClrCustomConversion(
    DataType scriptDataType,
    Type clrDataType
)
Public Function GetScriptToClrCustomConversion (
    scriptDataType As DataType,
    clrDataType As Type
) As Func(Of DynValue, Object)
public:
Func<DynValue^, Object^>^ GetScriptToClrCustomConversion(
    DataType scriptDataType,
    Type^ clrDataType
)
member GetScriptToClrCustomConversion :
        scriptDataType : DataType *
        clrDataType : Type -> Func<DynValue, Object>

Parameters

scriptDataType
Type: MoonSharp.InterpreterDataType
The script data type
clrDataType
Type: SystemType
The CLR data type.

Return Value

Type: Func DynValue, Object
The converter function, or null if not found
See Also

Reference

CustomConvertersCollection Class
MoonSharp.Interpreter.Interop Namespace


CustomConvertersCollection.SetClrToScriptCustomConversion Method

CustomConvertersCollectionSetClrToScriptCustomConversion Method
Overload List
 | Name | Description
Public method | SetClrToScriptCustomConversionT(FuncT, DynValue) | Obsolete. Sets a custom converter from a CLR data type. Set null to remove a previous custom converter.
Public method | SetClrToScriptCustomConversionT(FuncScript, T, DynValue) | Sets a custom converter from a CLR data type. Set null to remove a previous custom converter.
Public method | SetClrToScriptCustomConversion(Type, FuncObject, DynValue) | Obsolete.
Public method | SetClrToScriptCustomConversion(Type, FuncScript, Object, DynValue) | Sets a custom converter from a CLR data type. Set null to remove a previous custom converter.
Top
See Also

Reference

CustomConvertersCollection Class
MoonSharp.Interpreter.Interop Namespace


CustomConvertersCollection.SetClrToScriptCustomConversion(T) Method (Func(T, DynValue))

CustomConvertersCollectionSetClrToScriptCustomConversionT Method (FuncT, DynValue)

Note: This API is now obsolete.

Sets a custom converter from a CLR data type. Set null to remove a previous custom converter.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated. Use the overloads accepting functions with a Script argument.")]
public void SetClrToScriptCustomConversion<T>(
    Func<T, DynValue> converter = null
)

<ObsoleteAttribute("This method is deprecated. Use the overloads accepting functions with a Script argument.")>
Public Sub SetClrToScriptCustomConversion(Of T) (
    Optional converter As Func(Of T, DynValue) = Nothing
)
public:
[ObsoleteAttribute(L"This method is deprecated. Use the overloads accepting functions with a Script argument.")]
generic<typename T>
void SetClrToScriptCustomConversion(
    Func<T, DynValue^>^ converter = nullptr
)
[<ObsoleteAttribute("This method is deprecated. Use the overloads accepting functions with a Script argument.")>]
member SetClrToScriptCustomConversion :
        ?converter : Func<'T, DynValue>
(* Defaults:
        let _converter = defaultArg converter null
*)
-> unit

Parameters

converter (Optional)
Type: SystemFunc T, DynValue
The converter, or null.

Type Parameters

T
The CLR data type.
See Also

Reference

CustomConvertersCollection Class
SetClrToScriptCustomConversion Overload
MoonSharp.Interpreter.Interop Namespace


CustomConvertersCollection.SetClrToScriptCustomConversion(T) Method (Func(Script, T, DynValue))

CustomConvertersCollectionSetClrToScriptCustomConversionT Method (FuncScript, T, DynValue)
Sets a custom converter from a CLR data type. Set null to remove a previous custom converter.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void SetClrToScriptCustomConversion<T>(
    Func<Script, T, DynValue> converter = null
)

Public Sub SetClrToScriptCustomConversion(Of T) (
    Optional converter As Func(Of Script, T, DynValue) = Nothing
)
public:
generic<typename T>
void SetClrToScriptCustomConversion(
    Func<Script^, T, DynValue^>^ converter = nullptr
)
member SetClrToScriptCustomConversion :
        ?converter : Func<Script, 'T, DynValue>
(* Defaults:
        let _converter = defaultArg converter null
*)
-> unit

Parameters

converter (Optional)
Type: SystemFunc Script, T, DynValue
The converter, or null.

Type Parameters

T
The CLR data type.
See Also

Reference

CustomConvertersCollection Class
SetClrToScriptCustomConversion Overload
MoonSharp.Interpreter.Interop Namespace


CustomConvertersCollection.SetClrToScriptCustomConversion Method (Type, Func(Object, DynValue))

CustomConvertersCollectionSetClrToScriptCustomConversion Method (Type, FuncObject, DynValue)

Note: This API is now obsolete.

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.CustomConvertersCollection.SetClrToScriptCustomConversion(System.Type,System.Func{System.Object,MoonSharp.Interpreter.DynValue})"]

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This method is deprecated. Use the overloads accepting functions with a Script argument.")]
public void SetClrToScriptCustomConversion(
    Type clrDataType,
    Func<Object, DynValue> converter = null
)
<ObsoleteAttribute("This method is deprecated. Use the overloads accepting functions with a Script argument.")>
Public Sub SetClrToScriptCustomConversion (
    clrDataType As Type,
    Optional converter As Func(Of Object, DynValue) = Nothing
)
public:
[ObsoleteAttribute(L"This method is deprecated. Use the overloads accepting functions with a Script argument.")]
void SetClrToScriptCustomConversion(
    Type^ clrDataType,
    Func<Object^, DynValue^>^ converter = nullptr
)
[<ObsoleteAttribute("This method is deprecated. Use the overloads accepting functions with a Script argument.")>]
member SetClrToScriptCustomConversion :
        clrDataType : Type *
        ?converter : Func<Object, DynValue>
(* Defaults:
        let _converter = defaultArg converter null
*)
-> unit

Parameters

clrDataType
Type: SystemType

[Missing <param name="clrDataType"/> documentation for "M:MoonSharp.Interpreter.Interop.CustomConvertersCollection.SetClrToScriptCustomConversion(System.Type,System.Func{System.Object,MoonSharp.Interpreter.DynValue})"]

converter (Optional)
Type: SystemFunc Object, DynValue

[Missing <param name="converter"/> documentation for "M:MoonSharp.Interpreter.Interop.CustomConvertersCollection.SetClrToScriptCustomConversion(System.Type,System.Func{System.Object,MoonSharp.Interpreter.DynValue})"]

See Also

Reference

CustomConvertersCollection Class
SetClrToScriptCustomConversion Overload
MoonSharp.Interpreter.Interop Namespace


CustomConvertersCollection.SetClrToScriptCustomConversion Method (Type, Func(Script, Object, DynValue))

CustomConvertersCollectionSetClrToScriptCustomConversion Method (Type, FuncScript, Object, DynValue)
Sets a custom converter from a CLR data type. Set null to remove a previous custom converter.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void SetClrToScriptCustomConversion(
    Type clrDataType,
    Func<Script, Object, DynValue> converter = null
)
Public Sub SetClrToScriptCustomConversion (
    clrDataType As Type,
    Optional converter As Func(Of Script, Object, DynValue) = Nothing
)
public:
void SetClrToScriptCustomConversion(
    Type^ clrDataType,
    Func<Script^, Object^, DynValue^>^ converter = nullptr
)
member SetClrToScriptCustomConversion :
        clrDataType : Type *
        ?converter : Func<Script, Object, DynValue>
(* Defaults:
        let _converter = defaultArg converter null
*)
-> unit

Parameters

clrDataType
Type: SystemType
The CLR data type.
converter (Optional)
Type: SystemFunc Script, Object, DynValue
The converter, or null.
See Also

Reference

CustomConvertersCollection Class
SetClrToScriptCustomConversion Overload
MoonSharp.Interpreter.Interop Namespace


CustomConvertersCollection.SetScriptToClrCustomConversion Method

CustomConvertersCollectionSetScriptToClrCustomConversion Method
Sets a custom converter from a script data type to a CLR data type. Set null to remove a previous custom converter.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void SetScriptToClrCustomConversion(
    DataType scriptDataType,
    Type clrDataType,
    Func<DynValue, Object> converter = null
)
Public Sub SetScriptToClrCustomConversion (
    scriptDataType As DataType,
    clrDataType As Type,
    Optional converter As Func(Of DynValue, Object) = Nothing
)
public:
void SetScriptToClrCustomConversion(
    DataType scriptDataType,
    Type^ clrDataType,
    Func<DynValue^, Object^>^ converter = nullptr
)
member SetScriptToClrCustomConversion :
        scriptDataType : DataType *
        clrDataType : Type *
        ?converter : Func<DynValue, Object>
(* Defaults:
        let _converter = defaultArg converter null
*)
-> unit

Parameters

scriptDataType
Type: MoonSharp.InterpreterDataType
The script data type
clrDataType
Type: SystemType
The CLR data type.
converter (Optional)
Type: SystemFunc DynValue, Object
The converter, or null.
See Also

Reference

CustomConvertersCollection Class
MoonSharp.Interpreter.Interop Namespace


DelegateProxyFactory(TProxy, TTarget) Class

DelegateProxyFactoryTProxy, TTarget Class
Implementation of IProxyFactory taking two delegates for simple instancing of proxies.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropDelegateProxyFactoryTProxy, TTarget

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class DelegateProxyFactory<TProxy, TTarget> : IProxyFactory<TProxy, TTarget>,
    IProxyFactory
where TProxy : class
where TTarget : class

Public Class DelegateProxyFactory(Of TProxy As Class, TTarget As Class)
    Implements IProxyFactory(Of TProxy, TTarget), IProxyFactory
generic<typename TProxy, typename TTarget>
where TProxy : ref class
where TTarget : ref class
public ref class DelegateProxyFactory : IProxyFactory<TProxy, TTarget>,
    IProxyFactory
type DelegateProxyFactory<'TProxy, 'TTarget when 'TProxy : not struct when 'TTarget : not struct> =
    class
        interface IProxyFactory<'TProxy, 'TTarget>
        interface IProxyFactory
    end

Type Parameters

TProxy
The type of the proxy.
TTarget
The type of the target.

The DelegateProxyFactoryTProxy, TTarget type exposes the following members.

Constructors
 | Name | Description
Public method | DelegateProxyFactoryTProxy, TTarget | Initializes a new instance of the DelegateProxyFactoryTProxy, TTarget class.
Top
Properties
 | Name | Description
Public property | ProxyType | Gets the proxy type
Public property | TargetType | Gets the proxied type
Top
Methods
 | Name | Description
Public method | CreateProxyObject(Object) | Takes an instance of a target object and returns a proxy object wrapping it
Public method | CreateProxyObject(TTarget) | Takes an instance of a target object and returns a proxy object wrapping it
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


DelegateProxyFactory(TProxy, TTarget) Constructor

DelegateProxyFactoryTProxy, TTarget Constructor
Initializes a new instance of the DelegateProxyFactoryTProxy, TTarget class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DelegateProxyFactory(
    Func<TTarget, TProxy> wrapDelegate
)
Public Sub New (
    wrapDelegate As Func(Of TTarget, TProxy)
)
public:
DelegateProxyFactory(
    Func<TTarget, TProxy>^ wrapDelegate
)
new :
        wrapDelegate : Func<'TTarget, 'TProxy> -> DelegateProxyFactory

Parameters

wrapDelegate
Type: SystemFunc TTarget, TProxy
The proxy.
See Also

Reference

DelegateProxyFactoryTProxy, TTarget Class
MoonSharp.Interpreter.Interop Namespace


DelegateProxyFactory(TProxy, TTarget) Properties

DelegateProxyFactoryTProxy, TTarget Properties

The DelegateProxyFactoryTProxy, TTarget generic type exposes the following members.

Properties
 | Name | Description
Public property | ProxyType | Gets the proxy type
Public property | TargetType | Gets the proxied type
Top
See Also

Reference

DelegateProxyFactoryTProxy, TTarget Class
MoonSharp.Interpreter.Interop Namespace


DelegateProxyFactory(TProxy, TTarget).ProxyType Property

DelegateProxyFactoryTProxy, TTargetProxyType Property
Gets the proxy type

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Type ProxyType { get; }
Public ReadOnly Property ProxyType As Type
    Get
public:
virtual property Type^ ProxyType {
    Type^ get () sealed;
}
abstract ProxyType : Type with get
override ProxyType : Type with get

Property Value

Type: Type

Implements

IProxyFactoryProxyType
See Also

Reference

DelegateProxyFactoryTProxy, TTarget Class
MoonSharp.Interpreter.Interop Namespace


DelegateProxyFactory(TProxy, TTarget).TargetType Property

DelegateProxyFactoryTProxy, TTargetTargetType Property
Gets the proxied type

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Type TargetType { get; }
Public ReadOnly Property TargetType As Type
    Get
public:
virtual property Type^ TargetType {
    Type^ get () sealed;
}
abstract TargetType : Type with get
override TargetType : Type with get

Return Value

Type: Type

Implements

IProxyFactoryTargetType
See Also

Reference

DelegateProxyFactoryTProxy, TTarget Class
MoonSharp.Interpreter.Interop Namespace


DelegateProxyFactory(TProxy, TTarget) Methods

DelegateProxyFactoryTProxy, TTarget Methods

The DelegateProxyFactoryTProxy, TTarget generic type exposes the following members.

Methods
 | Name | Description
Public method | CreateProxyObject(Object) | Takes an instance of a target object and returns a proxy object wrapping it
Public method | CreateProxyObject(TTarget) | Takes an instance of a target object and returns a proxy object wrapping it
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DelegateProxyFactoryTProxy, TTarget Class
MoonSharp.Interpreter.Interop Namespace


DelegateProxyFactory(TProxy, TTarget).CreateProxyObject Method

DelegateProxyFactoryTProxy, TTargetCreateProxyObject Method
Overload List
 | Name | Description
Public method | CreateProxyObject(Object) | Takes an instance of a target object and returns a proxy object wrapping it
Public method | CreateProxyObject(TTarget) | Takes an instance of a target object and returns a proxy object wrapping it
Top
See Also

Reference

DelegateProxyFactoryTProxy, TTarget Class
MoonSharp.Interpreter.Interop Namespace


DelegateProxyFactory(TProxy, TTarget).CreateProxyObject Method (Object)

DelegateProxyFactoryTProxy, TTargetCreateProxyObject Method (Object)
Takes an instance of a target object and returns a proxy object wrapping it

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Object CreateProxyObject(
    Object o
)
Public Function CreateProxyObject (
    o As Object
) As Object
public:
virtual Object^ CreateProxyObject(
    Object^ o
) sealed
abstract CreateProxyObject :
        o : Object -> Object
override CreateProxyObject :
        o : Object -> Object

Parameters

o
Type: SystemObject

[Missing <param name="o"/> documentation for "M:MoonSharp.Interpreter.Interop.DelegateProxyFactory`2.CreateProxyObject(System.Object)"]

Return Value

Type: Object

Implements

IProxyFactoryCreateProxyObject(Object)
See Also

Reference

DelegateProxyFactoryTProxy, TTarget Class
CreateProxyObject Overload
MoonSharp.Interpreter.Interop Namespace


DelegateProxyFactory(TProxy, TTarget).CreateProxyObject Method (TTarget)

DelegateProxyFactoryTProxy, TTargetCreateProxyObject Method (TTarget)
Takes an instance of a target object and returns a proxy object wrapping it

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public TProxy CreateProxyObject(
    TTarget target
)
Public Function CreateProxyObject (
    target As TTarget
) As TProxy
public:
virtual TProxy CreateProxyObject(
    TTarget target
) sealed
abstract CreateProxyObject :
        target : 'TTarget -> 'TProxy
override CreateProxyObject :
        target : 'TTarget -> 'TProxy

Parameters

target
Type: TTarget

[Missing <param name="target"/> documentation for "M:MoonSharp.Interpreter.Interop.DelegateProxyFactory`2.CreateProxyObject(`1)"]

Return Value

Type: TProxy

Implements

IProxyFactoryTProxy, TTargetCreateProxyObject(TTarget)
See Also

Reference

DelegateProxyFactoryTProxy, TTarget Class
CreateProxyObject Overload
MoonSharp.Interpreter.Interop Namespace


DescriptorHelpers Class

DescriptorHelpers Class
Helper extension methods used to simplify some parts of userdata descriptor implementations
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropDescriptorHelpers

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static class DescriptorHelpers
<ExtensionAttribute>
Public NotInheritable Class DescriptorHelpers
[ExtensionAttribute]
public ref class DescriptorHelpers abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type DescriptorHelpers =  class end

The DescriptorHelpers type exposes the following members.

Methods
Name | Description
Camelify | Converts the specified name from underscore_case to camelCase.
GetAllImplementedTypes | Gets all implemented types by a given type
GetClrVisibility(FieldInfo) | Gets a string representing visibility of the given member type
GetClrVisibility(MethodBase) | Gets a string representing visibility of the given member type
GetClrVisibility(PropertyInfo) | Gets a string representing visibility of the given member type
GetClrVisibility(Type) | Gets the visibility of the type as a string
GetConversionMethodName | Gets the name of a conversion method to be exposed to Lua scripts
GetMetaNamesFromAttributes | Gets the list of metamethod names from attributes - in practice the list of metamethods declared through MoonSharpUserDataMetamethodAttribute .
GetVisibilityFromAttributes | Determines whether a MoonSharpVisibleAttribute or a MoonSharpHiddenAttribute is changing visibility of a member to scripts.
IsDelegateType |
IsPropertyInfoPublic | Determines whether the specified PropertyInfo is visible publicly (either the getter or the setter is public).
IsValidSimpleIdentifier | Determines whether the string is a valid simple identifier (starts with letter or underscore and contains only letters, digits and underscores).
SafeGetTypes | Gets the Types implemented in the assembly, catching the ReflectionTypeLoadException just in case..
ToValidSimpleIdentifier | Converts the string to a valid simple identifier (starts with letter or underscore and contains only letters, digits and underscores).
UpperFirstLetter | Converts the specified name to one with an uppercase first letter (something to Something).
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


DescriptorHelpers Methods

DescriptorHelpers Methods

The DescriptorHelpers type exposes the following members.

Methods
Name | Description
Camelify | Converts the specified name from underscore_case to camelCase.
GetAllImplementedTypes | Gets all implemented types by a given type
GetClrVisibility(FieldInfo) | Gets a string representing visibility of the given member type
GetClrVisibility(MethodBase) | Gets a string representing visibility of the given member type
GetClrVisibility(PropertyInfo) | Gets a string representing visibility of the given member type
GetClrVisibility(Type) | Gets the visibility of the type as a string
GetConversionMethodName | Gets the name of a conversion method to be exposed to Lua scripts
GetMetaNamesFromAttributes | Gets the list of metamethod names from attributes - in practice the list of metamethods declared through MoonSharpUserDataMetamethodAttribute .
GetVisibilityFromAttributes | Determines whether a MoonSharpVisibleAttribute or a MoonSharpHiddenAttribute is changing visibility of a member to scripts.
IsDelegateType |
IsPropertyInfoPublic | Determines whether the specified PropertyInfo is visible publicly (either the getter or the setter is public).
IsValidSimpleIdentifier | Determines whether the string is a valid simple identifier (starts with letter or underscore and contains only letters, digits and underscores).
SafeGetTypes | Gets the Types implemented in the assembly, catching the ReflectionTypeLoadException just in case..
ToValidSimpleIdentifier | Converts the string to a valid simple identifier (starts with letter or underscore and contains only letters, digits and underscores).
UpperFirstLetter | Converts the specified name to one with an uppercase first letter (something to Something).
Top
See Also

Reference

DescriptorHelpers Class
MoonSharp.Interpreter.Interop Namespace


DescriptorHelpers.Camelify Method

DescriptorHelpersCamelify Method
Converts the specified name from underscore_case to camelCase.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string Camelify(
    string name
)
Public Shared Function Camelify (
    name As String
) As String
public:
static String^ Camelify(
    String^ name
)
static member Camelify :
        name : string -> string

Parameters

name
Type: SystemString
The name.

Return Value

Type: String
See Also

Reference

DescriptorHelpers Class
MoonSharp.Interpreter.Interop Namespace


DescriptorHelpers.GetAllImplementedTypes Method

DescriptorHelpersGetAllImplementedTypes Method
Gets all implemented types by a given type

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IEnumerable<Type> GetAllImplementedTypes(
    this Type t
)
<ExtensionAttribute>
Public Shared Function GetAllImplementedTypes (
    t As Type
) As IEnumerable(Of Type)
public:
[ExtensionAttribute]
static IEnumerable<Type^>^ GetAllImplementedTypes(
    Type^ t
)
[<ExtensionAttribute>]
static member GetAllImplementedTypes :
        t : Type -> IEnumerable<Type>

Parameters

t
Type: SystemType
The t.

Return Value

Type: IEnumerable Type

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DescriptorHelpers Class
MoonSharp.Interpreter.Interop Namespace


DescriptorHelpers.GetClrVisibility Method

DescriptorHelpersGetClrVisibility Method
Overload List
Name | Description
GetClrVisibility(FieldInfo) | Gets a string representing visibility of the given member type
GetClrVisibility(MethodBase) | Gets a string representing visibility of the given member type
GetClrVisibility(PropertyInfo) | Gets a string representing visibility of the given member type
GetClrVisibility(Type) | Gets the visibility of the type as a string
Top
See Also

Reference

DescriptorHelpers Class
MoonSharp.Interpreter.Interop Namespace


DescriptorHelpers.GetClrVisibility Method (FieldInfo)

DescriptorHelpersGetClrVisibility Method (FieldInfo)
Gets a string representing visibility of the given member type

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetClrVisibility(
    this FieldInfo info
)
<ExtensionAttribute>
Public Shared Function GetClrVisibility (
    info As FieldInfo
) As String
public:
[ExtensionAttribute]
static String^ GetClrVisibility(
    FieldInfo^ info
)
[<ExtensionAttribute>]
static member GetClrVisibility :
        info : FieldInfo -> string

Parameters

info
Type: System.ReflectionFieldInfo

[Missing <param name="info"/> documentation for "M:MoonSharp.Interpreter.Interop.DescriptorHelpers.GetClrVisibility(System.Reflection.FieldInfo)"]

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type FieldInfo. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DescriptorHelpers Class
GetClrVisibility Overload
MoonSharp.Interpreter.Interop Namespace


DescriptorHelpers.GetClrVisibility Method (MethodBase)

DescriptorHelpersGetClrVisibility Method (MethodBase)
Gets a string representing visibility of the given member type

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetClrVisibility(
    this MethodBase info
)
<ExtensionAttribute>
Public Shared Function GetClrVisibility (
    info As MethodBase
) As String
public:
[ExtensionAttribute]
static String^ GetClrVisibility(
    MethodBase^ info
)
[<ExtensionAttribute>]
static member GetClrVisibility :
        info : MethodBase -> string

Parameters

info
Type: System.ReflectionMethodBase

[Missing <param name="info"/> documentation for "M:MoonSharp.Interpreter.Interop.DescriptorHelpers.GetClrVisibility(System.Reflection.MethodBase)"]

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type MethodBase. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DescriptorHelpers Class
GetClrVisibility Overload
MoonSharp.Interpreter.Interop Namespace


DescriptorHelpers.GetClrVisibility Method (PropertyInfo)

DescriptorHelpersGetClrVisibility Method (PropertyInfo)
Gets a string representing visibility of the given member type

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetClrVisibility(
    this PropertyInfo info
)
<ExtensionAttribute>
Public Shared Function GetClrVisibility (
    info As PropertyInfo
) As String
public:
[ExtensionAttribute]
static String^ GetClrVisibility(
    PropertyInfo^ info
)
[<ExtensionAttribute>]
static member GetClrVisibility :
        info : PropertyInfo -> string

Parameters

info
Type: System.ReflectionPropertyInfo

[Missing <param name="info"/> documentation for "M:MoonSharp.Interpreter.Interop.DescriptorHelpers.GetClrVisibility(System.Reflection.PropertyInfo)"]

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PropertyInfo. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DescriptorHelpers Class
GetClrVisibility Overload
MoonSharp.Interpreter.Interop Namespace


DescriptorHelpers.GetClrVisibility Method (Type)

DescriptorHelpersGetClrVisibility Method (Type)
Gets the visibility of the type as a string

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetClrVisibility(
    this Type type
)
<ExtensionAttribute>
Public Shared Function GetClrVisibility (
    type As Type
) As String
public:
[ExtensionAttribute]
static String^ GetClrVisibility(
    Type^ type
)
[<ExtensionAttribute>]
static member GetClrVisibility :
        type : Type -> string

Parameters

type
Type: SystemType

[Missing <param name="type"/> documentation for "M:MoonSharp.Interpreter.Interop.DescriptorHelpers.GetClrVisibility(System.Type)"]

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DescriptorHelpers Class
GetClrVisibility Overload
MoonSharp.Interpreter.Interop Namespace


DescriptorHelpers.GetConversionMethodName Method

DescriptorHelpersGetConversionMethodName Method
Gets the name of a conversion method to be exposed to Lua scripts

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string GetConversionMethodName(
    this Type type
)
<ExtensionAttribute>
Public Shared Function GetConversionMethodName (
    type As Type
) As String
public:
[ExtensionAttribute]
static String^ GetConversionMethodName(
    Type^ type
)
[<ExtensionAttribute>]
static member GetConversionMethodName :
        type : Type -> string

Parameters

type
Type: SystemType
The type.

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DescriptorHelpers Class
MoonSharp.Interpreter.Interop Namespace


DescriptorHelpers.GetMetaNamesFromAttributes Method

DescriptorHelpersGetMetaNamesFromAttributes Method
Gets the list of metamethod names from attributes - in practice the list of metamethods declared through MoonSharpUserDataMetamethodAttribute .

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static List<string> GetMetaNamesFromAttributes(
    this MethodInfo mi
)
<ExtensionAttribute>
Public Shared Function GetMetaNamesFromAttributes (
    mi As MethodInfo
) As List(Of String)
public:
[ExtensionAttribute]
static List<String^>^ GetMetaNamesFromAttributes(
    MethodInfo^ mi
)
[<ExtensionAttribute>]
static member GetMetaNamesFromAttributes :
        mi : MethodInfo -> List<string>

Parameters

mi
Type: System.ReflectionMethodInfo
The mi.

Return Value

Type: List String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type MethodInfo. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DescriptorHelpers Class
MoonSharp.Interpreter.Interop Namespace


DescriptorHelpers.GetVisibilityFromAttributes Method

DescriptorHelpersGetVisibilityFromAttributes Method
Determines whether a MoonSharpVisibleAttribute or a MoonSharpHiddenAttribute is changing visibility of a member to scripts.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Nullable<bool> GetVisibilityFromAttributes(
    this MemberInfo mi
)
<ExtensionAttribute>
Public Shared Function GetVisibilityFromAttributes (
    mi As MemberInfo
) As Nullable(Of Boolean)
public:
[ExtensionAttribute]
static Nullable<bool> GetVisibilityFromAttributes(
    MemberInfo^ mi
)
[<ExtensionAttribute>]
static member GetVisibilityFromAttributes :
        mi : MemberInfo -> Nullable<bool>

Parameters

mi
Type: System.ReflectionMemberInfo
The member to check.

Return Value

Type: Nullable Boolean
true if visibility is forced visible, false if visibility is forced hidden or the specified MemberInfo is null, if no attribute was found

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type MemberInfo. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
InvalidOperationException | If both MoonSharpHiddenAttribute and MoonSharpVisibleAttribute are specified and they convey different messages.
See Also

Reference

DescriptorHelpers Class
MoonSharp.Interpreter.Interop Namespace


DescriptorHelpers.IsDelegateType Method

DescriptorHelpersIsDelegateType Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.DescriptorHelpers.IsDelegateType(System.Type)"]

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsDelegateType(
    this Type t
)
<ExtensionAttribute>
Public Shared Function IsDelegateType (
    t As Type
) As Boolean
public:
[ExtensionAttribute]
static bool IsDelegateType(
    Type^ t
)
[<ExtensionAttribute>]
static member IsDelegateType :
        t : Type -> bool

Parameters

t
Type: SystemType

[Missing <param name="t"/> documentation for "M:MoonSharp.Interpreter.Interop.DescriptorHelpers.IsDelegateType(System.Type)"]

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DescriptorHelpers Class
MoonSharp.Interpreter.Interop Namespace


DescriptorHelpers.IsPropertyInfoPublic Method

DescriptorHelpersIsPropertyInfoPublic Method
Determines whether the specified PropertyInfo is visible publicly (either the getter or the setter is public).

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsPropertyInfoPublic(
    this PropertyInfo pi
)
<ExtensionAttribute>
Public Shared Function IsPropertyInfoPublic (
    pi As PropertyInfo
) As Boolean
public:
[ExtensionAttribute]
static bool IsPropertyInfoPublic(
    PropertyInfo^ pi
)
[<ExtensionAttribute>]
static member IsPropertyInfoPublic :
        pi : PropertyInfo -> bool

Parameters

pi
Type: System.ReflectionPropertyInfo
The PropertyInfo.

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PropertyInfo. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DescriptorHelpers Class
MoonSharp.Interpreter.Interop Namespace


DescriptorHelpers.IsValidSimpleIdentifier Method

DescriptorHelpersIsValidSimpleIdentifier Method
Determines whether the string is a valid simple identifier (starts with letter or underscore and contains only letters, digits and underscores).

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsValidSimpleIdentifier(
    string str
)
Public Shared Function IsValidSimpleIdentifier (
    str As String
) As Boolean
public:
static bool IsValidSimpleIdentifier(
    String^ str
)
static member IsValidSimpleIdentifier :
        str : string -> bool

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:MoonSharp.Interpreter.Interop.DescriptorHelpers.IsValidSimpleIdentifier(System.String)"]

Return Value

Type: Boolean
See Also

Reference

DescriptorHelpers Class
MoonSharp.Interpreter.Interop Namespace


DescriptorHelpers.SafeGetTypes Method

DescriptorHelpersSafeGetTypes Method
Gets the Types implemented in the assembly, catching the ReflectionTypeLoadException just in case..

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Type[] SafeGetTypes(
    this Assembly asm
)
<ExtensionAttribute>
Public Shared Function SafeGetTypes (
    asm As Assembly
) As Type()
public:
[ExtensionAttribute]
static array<Type^>^ SafeGetTypes(
    Assembly^ asm
)
[<ExtensionAttribute>]
static member SafeGetTypes :
        asm : Assembly -> Type[]

Parameters

asm
Type: System.ReflectionAssembly
The assebly

Return Value

Type: Type

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DescriptorHelpers Class
MoonSharp.Interpreter.Interop Namespace


DescriptorHelpers.ToValidSimpleIdentifier Method

DescriptorHelpersToValidSimpleIdentifier Method
Converts the string to a valid simple identifier (starts with letter or underscore and contains only letters, digits and underscores).

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string ToValidSimpleIdentifier(
    string str
)
Public Shared Function ToValidSimpleIdentifier (
    str As String
) As String
public:
static String^ ToValidSimpleIdentifier(
    String^ str
)
static member ToValidSimpleIdentifier :
        str : string -> string

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:MoonSharp.Interpreter.Interop.DescriptorHelpers.ToValidSimpleIdentifier(System.String)"]

Return Value

Type: String
See Also

Reference

DescriptorHelpers Class
MoonSharp.Interpreter.Interop Namespace


DescriptorHelpers.UpperFirstLetter Method

DescriptorHelpersUpperFirstLetter Method
Converts the specified name to one with an uppercase first letter (something to Something).

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string UpperFirstLetter(
    string name
)
Public Shared Function UpperFirstLetter (
    name As String
) As String
public:
static String^ UpperFirstLetter(
    String^ name
)
static member UpperFirstLetter :
        name : string -> string

Parameters

name
Type: SystemString
The name.

Return Value

Type: String
See Also

Reference

DescriptorHelpers Class
MoonSharp.Interpreter.Interop Namespace


DynValueMemberDescriptor Class

DynValueMemberDescriptor Class
Class providing a simple descriptor for constant DynValues in userdata
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropDynValueMemberDescriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class DynValueMemberDescriptor : IMemberDescriptor,
    IWireableDescriptor
Public Class DynValueMemberDescriptor
    Implements IMemberDescriptor, IWireableDescriptor
public ref class DynValueMemberDescriptor : IMemberDescriptor,
    IWireableDescriptor
type DynValueMemberDescriptor =
    class
        interface IMemberDescriptor
        interface IWireableDescriptor
    end

The DynValueMemberDescriptor type exposes the following members.

Constructors
 | Name | Description
Protected method | DynValueMemberDescriptor(String) | Initializes a new instance of the DynValueMemberDescriptor class.
Public method | DynValueMemberDescriptor(String, DynValue) | Initializes a new instance of the DynValueMemberDescriptor class.
Protected method | DynValueMemberDescriptor(String, String) | Initializes a new instance of the DynValueMemberDescriptor class.
Top
Properties
 | Name | Description
Public property | IsStatic | Gets a value indicating whether the described member is static.
Public property | MemberAccess | Gets the types of access supported by this member
Public property | Name | Gets the name of the member
Public property | Value | Gets the value wrapped by this descriptor
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForWiring | Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.
Public method | SetValue | Sets the value of this member from a DynValue.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


DynValueMemberDescriptor Constructor

DynValueMemberDescriptor Constructor
Overload List
 | Name | Description
Protected method | DynValueMemberDescriptor(String) | Initializes a new instance of the DynValueMemberDescriptor class.
Public method | DynValueMemberDescriptor(String, DynValue) | Initializes a new instance of the DynValueMemberDescriptor class.
Protected method | DynValueMemberDescriptor(String, String) | Initializes a new instance of the DynValueMemberDescriptor class.
Top
See Also

Reference

DynValueMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


DynValueMemberDescriptor Constructor (String)

DynValueMemberDescriptor Constructor (String)
Initializes a new instance of the DynValueMemberDescriptor class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected DynValueMemberDescriptor(
    string name
)
Protected Sub New (
    name As String
)
protected:
DynValueMemberDescriptor(
    String^ name
)
new :
        name : string -> DynValueMemberDescriptor

Parameters

name
Type: SystemString
The name.
See Also

Reference

DynValueMemberDescriptor Class
DynValueMemberDescriptor Overload
MoonSharp.Interpreter.Interop Namespace


DynValueMemberDescriptor Constructor (String, DynValue)

DynValueMemberDescriptor Constructor (String, DynValue)
Initializes a new instance of the DynValueMemberDescriptor class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValueMemberDescriptor(
    string name,
    DynValue value
)
Public Sub New (
    name As String,
    value As DynValue
)
public:
DynValueMemberDescriptor(
    String^ name,
    DynValue^ value
)
new :
        name : string *
        value : DynValue -> DynValueMemberDescriptor

Parameters

name
Type: SystemString
The name.
value
Type: MoonSharp.InterpreterDynValue
The value.
See Also

Reference

DynValueMemberDescriptor Class
DynValueMemberDescriptor Overload
MoonSharp.Interpreter.Interop Namespace


DynValueMemberDescriptor Constructor (String, String)

DynValueMemberDescriptor Constructor (String, String)
Initializes a new instance of the DynValueMemberDescriptor class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected DynValueMemberDescriptor(
    string name,
    string serializedTableValue
)
Protected Sub New (
    name As String,
    serializedTableValue As String
)
protected:
DynValueMemberDescriptor(
    String^ name,
    String^ serializedTableValue
)
new :
        name : string *
        serializedTableValue : string -> DynValueMemberDescriptor

Parameters

name
Type: SystemString
The name.
serializedTableValue
Type: SystemString
A string containing a table whose first member is the dynvalue to be deserialized (convoluted...).
See Also

Reference

DynValueMemberDescriptor Class
DynValueMemberDescriptor Overload
MoonSharp.Interpreter.Interop Namespace


DynValueMemberDescriptor Properties

DynValueMemberDescriptor Properties

The DynValueMemberDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | IsStatic | Gets a value indicating whether the described member is static.
Public property | MemberAccess | Gets the types of access supported by this member
Public property | Name | Gets the name of the member
Public property | Value | Gets the value wrapped by this descriptor
Top
See Also

Reference

DynValueMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


DynValueMemberDescriptor.IsStatic Property

DynValueMemberDescriptorIsStatic Property
Gets a value indicating whether the described member is static.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStatic { get; }
Public ReadOnly Property IsStatic As Boolean
    Get
public:
virtual property bool IsStatic {
    bool get () sealed;
}
abstract IsStatic : bool with get
override IsStatic : bool with get

Property Value

Type: Boolean

Implements

IMemberDescriptorIsStatic
See Also

Reference

DynValueMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


DynValueMemberDescriptor.MemberAccess Property

DynValueMemberDescriptorMemberAccess Property
Gets the types of access supported by this member

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MemberDescriptorAccess MemberAccess { get; }
Public ReadOnly Property MemberAccess As MemberDescriptorAccess
    Get
public:
virtual property MemberDescriptorAccess MemberAccess {
    MemberDescriptorAccess get () sealed;
}
abstract MemberAccess : MemberDescriptorAccess with get
override MemberAccess : MemberDescriptorAccess with get

Property Value

Type: MemberDescriptorAccess

Implements

IMemberDescriptorMemberAccess
See Also

Reference

DynValueMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


DynValueMemberDescriptor.Name Property

DynValueMemberDescriptorName Property
Gets the name of the member

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IMemberDescriptorName
See Also

Reference

DynValueMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


DynValueMemberDescriptor.Value Property

DynValueMemberDescriptorValue Property
Gets the value wrapped by this descriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DynValue Value { get; }
Public Overridable ReadOnly Property Value As DynValue
    Get
public:
virtual property DynValue^ Value {
    DynValue^ get ();
}
abstract Value : DynValue with get
override Value : DynValue with get

Property Value

Type: DynValue
See Also

Reference

DynValueMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


DynValueMemberDescriptor Methods

DynValueMemberDescriptor Methods

The DynValueMemberDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForWiring | Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.
Public method | SetValue | Sets the value of this member from a DynValue.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

DynValueMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


DynValueMemberDescriptor.GetValue Method

DynValueMemberDescriptorGetValue Method
Gets the value of this member as a DynValue to be exposed to scripts.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue GetValue(
    Script script,
    Object obj
)
Public Function GetValue (
    script As Script,
    obj As Object
) As DynValue
public:
virtual DynValue^ GetValue(
    Script^ script,
    Object^ obj
) sealed
abstract GetValue :
        script : Script *
        obj : Object -> DynValue
override GetValue :
        script : Script *
        obj : Object -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object owning this member, or null if static.

Return Value

Type: DynValue
The value of this member as a DynValue.

Implements

IMemberDescriptorGetValue(Script, Object)
See Also

Reference

DynValueMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


DynValueMemberDescriptor.PrepareForWiring Method

DynValueMemberDescriptorPrepareForWiring Method
Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void PrepareForWiring(
    Table t
)
Public Sub PrepareForWiring (
    t As Table
)
public:
virtual void PrepareForWiring(
    Table^ t
) sealed
abstract PrepareForWiring :
        t : Table -> unit
override PrepareForWiring :
        t : Table -> unit

Parameters

t
Type: MoonSharp.InterpreterTable
The table to be filled

Implements

IWireableDescriptorPrepareForWiring(Table)
See Also

Reference

DynValueMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


DynValueMemberDescriptor.SetValue Method

DynValueMemberDescriptorSetValue Method
Sets the value of this member from a DynValue.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    Script script,
    Object obj,
    DynValue value
)
Public Sub SetValue (
    script As Script,
    obj As Object,
    value As DynValue
)
public:
virtual void SetValue(
    Script^ script,
    Object^ obj,
    DynValue^ value
) sealed
abstract SetValue :
        script : Script *
        obj : Object *
        value : DynValue -> unit
override SetValue :
        script : Script *
        obj : Object *
        value : DynValue -> unit

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object owning this member, or null if static.
value
Type: MoonSharp.InterpreterDynValue
The value to be set.

Implements

IMemberDescriptorSetValue(Script, Object, DynValue)
Exceptions
Exception | Condition
ScriptRuntimeException | userdata '{0}' cannot be written to.
See Also

Reference

DynValueMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


EventMemberDescriptor Class

EventMemberDescriptor Class
Class providing easier marshalling of CLR events. Handling is limited to a narrow range of handler signatures, which, however, covers in practice most of all available events.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropEventMemberDescriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class EventMemberDescriptor : IMemberDescriptor
Public Class EventMemberDescriptor
    Implements IMemberDescriptor
public ref class EventMemberDescriptor : IMemberDescriptor
type EventMemberDescriptor =
    class
        interface IMemberDescriptor
    end

The EventMemberDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | EventMemberDescriptor | Initializes a new instance of the EventMemberDescriptor class.
Top
Properties
 | Name | Description
Public property | EventInfo | Gets the EventInfo object of the event described by this descriptor
Public property | IsStatic | Gets a value indicating whether the event described by this descriptor is static.
Public property | MemberAccess | Gets the types of access supported by this member
Public property | Name | Gets the name of the member
Top
Methods
 | Name | Description
 | CheckEventIsCompatible | Checks if the event is compatible with a standard descriptor
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets a dynvalue which is a facade supporting add/remove methods which is callable from scripts
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValue | Sets the value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryCreateIfVisible | Tries to create a new StandardUserDataEventDescriptor, returning null in case the method is not visible to script code.
Top
Fields
Name | Description
MAX_ARGS_IN_DELEGATE | The maximum number of arguments supported in an event handler delegate
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


EventMemberDescriptor Constructor

EventMemberDescriptor Constructor
Initializes a new instance of the EventMemberDescriptor class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public EventMemberDescriptor(
    EventInfo ei,
    InteropAccessMode accessMode = InteropAccessMode.Default
)
Public Sub New (
    ei As EventInfo,
    Optional accessMode As InteropAccessMode = InteropAccessMode.Default
)
public:
EventMemberDescriptor(
    EventInfo^ ei,
    InteropAccessMode accessMode = InteropAccessMode::Default
)
new :
        ei : EventInfo *
        ?accessMode : InteropAccessMode
(* Defaults:
        let _accessMode = defaultArg accessMode InteropAccessMode.Default
*)
-> EventMemberDescriptor

Parameters

ei
Type: System.ReflectionEventInfo
The ei.
accessMode (Optional)
Type: MoonSharp.InterpreterInteropAccessMode
The access mode.
See Also

Reference

EventMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


EventMemberDescriptor Properties

EventMemberDescriptor Properties

The EventMemberDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | EventInfo | Gets the EventInfo object of the event described by this descriptor
Public property | IsStatic | Gets a value indicating whether the event described by this descriptor is static.
Public property | MemberAccess | Gets the types of access supported by this member
Public property | Name | Gets the name of the member
Top
See Also

Reference

EventMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


EventMemberDescriptor.EventInfo Property

EventMemberDescriptorEventInfo Property
Gets the EventInfo object of the event described by this descriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public EventInfo EventInfo { get; }
Public ReadOnly Property EventInfo As EventInfo
    Get
public:
property EventInfo^ EventInfo {
    EventInfo^ get ();
}
member EventInfo : EventInfo with get

Property Value

Type: EventInfo
See Also

Reference

EventMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


EventMemberDescriptor.IsStatic Property

EventMemberDescriptorIsStatic Property
Gets a value indicating whether the event described by this descriptor is static.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStatic { get; }
Public ReadOnly Property IsStatic As Boolean
    Get
public:
virtual property bool IsStatic {
    bool get () sealed;
}
abstract IsStatic : bool with get
override IsStatic : bool with get

Property Value

Type: Boolean

Implements

IMemberDescriptorIsStatic
See Also

Reference

EventMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


EventMemberDescriptor.MemberAccess Property

EventMemberDescriptorMemberAccess Property
Gets the types of access supported by this member

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MemberDescriptorAccess MemberAccess { get; }
Public ReadOnly Property MemberAccess As MemberDescriptorAccess
    Get
public:
virtual property MemberDescriptorAccess MemberAccess {
    MemberDescriptorAccess get () sealed;
}
abstract MemberAccess : MemberDescriptorAccess with get
override MemberAccess : MemberDescriptorAccess with get

Property Value

Type: MemberDescriptorAccess

Implements

IMemberDescriptorMemberAccess
See Also

Reference

EventMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


EventMemberDescriptor.Name Property

EventMemberDescriptorName Property
Gets the name of the member

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IMemberDescriptorName
See Also

Reference

EventMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


EventMemberDescriptor Methods

EventMemberDescriptor Methods

The EventMemberDescriptor type exposes the following members.

Methods
 | Name | Description
 | CheckEventIsCompatible | Checks if the event is compatible with a standard descriptor
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets a dynvalue which is a facade supporting add/remove methods which is callable from scripts
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValue | Sets the value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryCreateIfVisible | Tries to create a new StandardUserDataEventDescriptor, returning null in case the method is not visible to script code.
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

EventMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


EventMemberDescriptor.CheckEventIsCompatible Method

EventMemberDescriptorCheckEventIsCompatible Method
Checks if the event is compatible with a standard descriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckEventIsCompatible(
    EventInfo ei,
    bool throwException
)
Public Shared Function CheckEventIsCompatible (
    ei As EventInfo,
    throwException As Boolean
) As Boolean
public:
static bool CheckEventIsCompatible(
    EventInfo^ ei,
    bool throwException
)
static member CheckEventIsCompatible :
        ei : EventInfo *
        throwException : bool -> bool

Parameters

ei
Type: System.ReflectionEventInfo
The EventInfo.
throwException
Type: SystemBoolean
if set to true an exception with the proper error message is thrown if not compatible.

Return Value

Type: Boolean
Exceptions
Exception | Condition
ArgumentException | Thrown if throwException is true and one of this applies: The event is declared in a value type or The event does not have both add and remove methods or The event handler type doesn't implement a public Invoke method or The event handler has a return type which is not System.Void or The event handler has more than MAX_ARGS_IN_DELEGATE parameters or The event handler has a value type parameter or a by ref parameter or The event handler signature is not a valid method according to CheckMethodIsCompatible(MethodBase, Boolean)
See Also

Reference

EventMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


EventMemberDescriptor.GetValue Method

EventMemberDescriptorGetValue Method
Gets a dynvalue which is a facade supporting add/remove methods which is callable from scripts

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue GetValue(
    Script script,
    Object obj
)
Public Function GetValue (
    script As Script,
    obj As Object
) As DynValue
public:
virtual DynValue^ GetValue(
    Script^ script,
    Object^ obj
) sealed
abstract GetValue :
        script : Script *
        obj : Object -> DynValue
override GetValue :
        script : Script *
        obj : Object -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object for which the facade should be written.

Return Value

Type: DynValue

Implements

IMemberDescriptorGetValue(Script, Object)
See Also

Reference

EventMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


EventMemberDescriptor.SetValue Method

EventMemberDescriptorSetValue Method
Sets the value.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    Script script,
    Object obj,
    DynValue v
)
Public Sub SetValue (
    script As Script,
    obj As Object,
    v As DynValue
)
public:
virtual void SetValue(
    Script^ script,
    Object^ obj,
    DynValue^ v
) sealed
abstract SetValue :
        script : Script *
        obj : Object *
        v : DynValue -> unit
override SetValue :
        script : Script *
        obj : Object *
        v : DynValue -> unit

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object.
v
Type: MoonSharp.InterpreterDynValue
The v.

Implements

IMemberDescriptorSetValue(Script, Object, DynValue)
See Also

Reference

EventMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


EventMemberDescriptor.TryCreateIfVisible Method

EventMemberDescriptorTryCreateIfVisible Method
Tries to create a new StandardUserDataEventDescriptor, returning null in case the method is not visible to script code.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static EventMemberDescriptor TryCreateIfVisible(
    EventInfo ei,
    InteropAccessMode accessMode
)
Public Shared Function TryCreateIfVisible (
    ei As EventInfo,
    accessMode As InteropAccessMode
) As EventMemberDescriptor
public:
static EventMemberDescriptor^ TryCreateIfVisible(
    EventInfo^ ei,
    InteropAccessMode accessMode
)
static member TryCreateIfVisible :
        ei : EventInfo *
        accessMode : InteropAccessMode -> EventMemberDescriptor

Parameters

ei
Type: System.ReflectionEventInfo
The EventInfo.
accessMode
Type: MoonSharp.InterpreterInteropAccessMode
The InteropAccessMode

Return Value

Type: EventMemberDescriptor
A new StandardUserDataEventDescriptor or null.
See Also

Reference

EventMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


EventMemberDescriptor Fields

EventMemberDescriptor Fields

The EventMemberDescriptor type exposes the following members.

Fields
Name | Description
MAX_ARGS_IN_DELEGATE | The maximum number of arguments supported in an event handler delegate
Top
See Also

Reference

EventMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


EventMemberDescriptor.MAX_ARGS_IN_DELEGATE Field

EventMemberDescriptorMAX_ARGS_IN_DELEGATE Field
The maximum number of arguments supported in an event handler delegate

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public const int MAX_ARGS_IN_DELEGATE = 16
Public Const MAX_ARGS_IN_DELEGATE As Integer = 16
public:
literal int MAX_ARGS_IN_DELEGATE = 16
static val mutable MAX_ARGS_IN_DELEGATE: int

Field Value

Type: Int32
See Also

Reference

EventMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


FieldMemberDescriptor Class

FieldMemberDescriptor Class
Class providing easier marshalling of CLR fields
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropFieldMemberDescriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class FieldMemberDescriptor : IMemberDescriptor,
    IOptimizableDescriptor, IWireableDescriptor
Public Class FieldMemberDescriptor
    Implements IMemberDescriptor, IOptimizableDescriptor, IWireableDescriptor
public ref class FieldMemberDescriptor : IMemberDescriptor,
    IOptimizableDescriptor, IWireableDescriptor
type FieldMemberDescriptor =
    class
        interface IMemberDescriptor
        interface IOptimizableDescriptor
        interface IWireableDescriptor
    end

The FieldMemberDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | FieldMemberDescriptor | Initializes a new instance of the PropertyMemberDescriptor class.
Top
Properties
 | Name | Description
Public property | AccessMode | Gets the InteropAccessMode
Public property | FieldInfo | Gets the FieldInfo got by reflection
Public property | IsConst | Gets a value indicating whether this instance is a constant
Public property | IsReadonly | Gets a value indicating whether this instance is readonly
Public property | IsStatic | Gets a value indicating whether the described property is static.
Public property | MemberAccess | Gets the types of access supported by this member
Public property | Name | Gets the name of the property
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of the property
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForWiring | Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.
Public method | SetValue | Sets the value of the property
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryCreateIfVisible | Tries to create a new StandardUserDataFieldDescriptor, returning null in case the field is not visible to script code.
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


FieldMemberDescriptor Constructor

FieldMemberDescriptor Constructor
Initializes a new instance of the PropertyMemberDescriptor class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public FieldMemberDescriptor(
    FieldInfo fi,
    InteropAccessMode accessMode
)
Public Sub New (
    fi As FieldInfo,
    accessMode As InteropAccessMode
)
public:
FieldMemberDescriptor(
    FieldInfo^ fi,
    InteropAccessMode accessMode
)
new :
        fi : FieldInfo *
        accessMode : InteropAccessMode -> FieldMemberDescriptor

Parameters

fi
Type: System.ReflectionFieldInfo
The FieldInfo.
accessMode
Type: MoonSharp.InterpreterInteropAccessMode
The InteropAccessMode
See Also

Reference

FieldMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


FieldMemberDescriptor Properties

FieldMemberDescriptor Properties

The FieldMemberDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | AccessMode | Gets the InteropAccessMode
Public property | FieldInfo | Gets the FieldInfo got by reflection
Public property | IsConst | Gets a value indicating whether this instance is a constant
Public property | IsReadonly | Gets a value indicating whether this instance is readonly
Public property | IsStatic | Gets a value indicating whether the described property is static.
Public property | MemberAccess | Gets the types of access supported by this member
Public property | Name | Gets the name of the property
Top
See Also

Reference

FieldMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


FieldMemberDescriptor.AccessMode Property

FieldMemberDescriptorAccessMode Property
Gets the InteropAccessMode

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public InteropAccessMode AccessMode { get; }
Public ReadOnly Property AccessMode As InteropAccessMode
    Get
public:
property InteropAccessMode AccessMode {
    InteropAccessMode get ();
}
member AccessMode : InteropAccessMode with get

Property Value

Type: InteropAccessMode
See Also

Reference

FieldMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


FieldMemberDescriptor.FieldInfo Property

FieldMemberDescriptorFieldInfo Property
Gets the FieldInfo got by reflection

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public FieldInfo FieldInfo { get; }
Public ReadOnly Property FieldInfo As FieldInfo
    Get
public:
property FieldInfo^ FieldInfo {
    FieldInfo^ get ();
}
member FieldInfo : FieldInfo with get

Property Value

Type: FieldInfo
See Also

Reference

FieldMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


FieldMemberDescriptor.IsConst Property

FieldMemberDescriptorIsConst Property
Gets a value indicating whether this instance is a constant

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsConst { get; }
Public ReadOnly Property IsConst As Boolean
    Get
public:
property bool IsConst {
    bool get ();
}
member IsConst : bool with get

Property Value

Type: Boolean
See Also

Reference

FieldMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


FieldMemberDescriptor.IsReadonly Property

FieldMemberDescriptorIsReadonly Property
Gets a value indicating whether this instance is readonly

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReadonly { get; }
Public ReadOnly Property IsReadonly As Boolean
    Get
public:
property bool IsReadonly {
    bool get ();
}
member IsReadonly : bool with get

Property Value

Type: Boolean
See Also

Reference

FieldMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


FieldMemberDescriptor.IsStatic Property

FieldMemberDescriptorIsStatic Property
Gets a value indicating whether the described property is static.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStatic { get; }
Public ReadOnly Property IsStatic As Boolean
    Get
public:
virtual property bool IsStatic {
    bool get () sealed;
}
abstract IsStatic : bool with get
override IsStatic : bool with get

Property Value

Type: Boolean

Implements

IMemberDescriptorIsStatic
See Also

Reference

FieldMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


FieldMemberDescriptor.MemberAccess Property

FieldMemberDescriptorMemberAccess Property
Gets the types of access supported by this member

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MemberDescriptorAccess MemberAccess { get; }
Public ReadOnly Property MemberAccess As MemberDescriptorAccess
    Get
public:
virtual property MemberDescriptorAccess MemberAccess {
    MemberDescriptorAccess get () sealed;
}
abstract MemberAccess : MemberDescriptorAccess with get
override MemberAccess : MemberDescriptorAccess with get

Property Value

Type: MemberDescriptorAccess

Implements

IMemberDescriptorMemberAccess
See Also

Reference

FieldMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


FieldMemberDescriptor.Name Property

FieldMemberDescriptorName Property
Gets the name of the property

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IMemberDescriptorName
See Also

Reference

FieldMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


FieldMemberDescriptor Methods

FieldMemberDescriptor Methods

The FieldMemberDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of the property
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForWiring | Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.
Public method | SetValue | Sets the value of the property
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryCreateIfVisible | Tries to create a new StandardUserDataFieldDescriptor, returning null in case the field is not visible to script code.
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

FieldMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


FieldMemberDescriptor.GetValue Method

FieldMemberDescriptorGetValue Method
Gets the value of the property

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue GetValue(
    Script script,
    Object obj
)
Public Function GetValue (
    script As Script,
    obj As Object
) As DynValue
public:
virtual DynValue^ GetValue(
    Script^ script,
    Object^ obj
) sealed
abstract GetValue :
        script : Script *
        obj : Object -> DynValue
override GetValue :
        script : Script *
        obj : Object -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object.

Return Value

Type: DynValue

Implements

IMemberDescriptorGetValue(Script, Object)
See Also

Reference

FieldMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


FieldMemberDescriptor.PrepareForWiring Method

FieldMemberDescriptorPrepareForWiring Method
Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void PrepareForWiring(
    Table t
)
Public Sub PrepareForWiring (
    t As Table
)
public:
virtual void PrepareForWiring(
    Table^ t
) sealed
abstract PrepareForWiring :
        t : Table -> unit
override PrepareForWiring :
        t : Table -> unit

Parameters

t
Type: MoonSharp.InterpreterTable
The table to be filled

Implements

IWireableDescriptorPrepareForWiring(Table)
See Also

Reference

FieldMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


FieldMemberDescriptor.SetValue Method

FieldMemberDescriptorSetValue Method
Sets the value of the property

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    Script script,
    Object obj,
    DynValue v
)
Public Sub SetValue (
    script As Script,
    obj As Object,
    v As DynValue
)
public:
virtual void SetValue(
    Script^ script,
    Object^ obj,
    DynValue^ v
) sealed
abstract SetValue :
        script : Script *
        obj : Object *
        v : DynValue -> unit
override SetValue :
        script : Script *
        obj : Object *
        v : DynValue -> unit

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object.
v
Type: MoonSharp.InterpreterDynValue
The value to set.

Implements

IMemberDescriptorSetValue(Script, Object, DynValue)
See Also

Reference

FieldMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


FieldMemberDescriptor.TryCreateIfVisible Method

FieldMemberDescriptorTryCreateIfVisible Method
Tries to create a new StandardUserDataFieldDescriptor, returning null in case the field is not visible to script code.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static FieldMemberDescriptor TryCreateIfVisible(
    FieldInfo fi,
    InteropAccessMode accessMode
)
Public Shared Function TryCreateIfVisible (
    fi As FieldInfo,
    accessMode As InteropAccessMode
) As FieldMemberDescriptor
public:
static FieldMemberDescriptor^ TryCreateIfVisible(
    FieldInfo^ fi,
    InteropAccessMode accessMode
)
static member TryCreateIfVisible :
        fi : FieldInfo *
        accessMode : InteropAccessMode -> FieldMemberDescriptor

Parameters

fi
Type: System.ReflectionFieldInfo
The FieldInfo.
accessMode
Type: MoonSharp.InterpreterInteropAccessMode
The InteropAccessMode

Return Value

Type: FieldMemberDescriptor
A new StandardUserDataFieldDescriptor or null.
See Also

Reference

FieldMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase Class

FunctionMemberDescriptorBase Class
Class providing easier marshalling of CLR functions
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropFunctionMemberDescriptorBase
MoonSharp.Interpreter.InteropMethodMemberDescriptor
MoonSharp.Interpreter.InteropObjectCallbackMemberDescriptor
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptorsHardwiredMethodMemberDescriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class FunctionMemberDescriptorBase : IOverloadableMemberDescriptor,
    IMemberDescriptor
Public MustInherit Class FunctionMemberDescriptorBase
    Implements IOverloadableMemberDescriptor, IMemberDescriptor
public ref class FunctionMemberDescriptorBase abstract : IOverloadableMemberDescriptor,
    IMemberDescriptor
[<AbstractClassAttribute>]
type FunctionMemberDescriptorBase =
    class
        interface IOverloadableMemberDescriptor
        interface IMemberDescriptor
    end

The FunctionMemberDescriptorBase type exposes the following members.

Constructors
 | Name | Description
Protected method | FunctionMemberDescriptorBase | Initializes a new instance of the FunctionMemberDescriptorBase class
Top
Properties
 | Name | Description
Public property | ExtensionMethodType | Gets the type which this extension method extends, null if this is not an extension method.
Public property | IsStatic | Gets a value indicating whether the described method is static.
Public property | MemberAccess | Gets the types of access supported by this member
Public property | Name | Gets the name of the described method
Public property | Parameters | Gets the type of the arguments of the underlying CLR function
Public property | SortDiscriminant | Gets a sort discriminant to give consistent overload resolution matching in case of perfectly equal scores
Public property | VarArgsArrayType | Gets a value indicating the type of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned.
Public property | VarArgsElementType | Gets a value indicating the type of the elements of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned.
Top
Methods
 | Name | Description
Protected method | BuildArgumentList | Builds the argument list.
 | BuildReturnValue | Builds the return value of a call
 | CreateCallbackDynValue | Creates a callback DynValue starting from a MethodInfo.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | The internal callback which actually executes the method
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCallback | Gets a callback function as a delegate
Public method | GetCallbackAsDynValue | Gets the callback function as a DynValue.
Public method | GetCallbackFunction | Gets the callback function.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts.
Protected method | Initialize | Initializes this instance. This *MUST* be called by the constructors extending this class to complete initialization.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValue | Sets the value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase Constructor

FunctionMemberDescriptorBase Constructor
Initializes a new instance of the FunctionMemberDescriptorBase class

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected FunctionMemberDescriptorBase()
Protected Sub New
protected:
FunctionMemberDescriptorBase()
new : unit -> FunctionMemberDescriptorBase
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase Properties

FunctionMemberDescriptorBase Properties

The FunctionMemberDescriptorBase type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionMethodType | Gets the type which this extension method extends, null if this is not an extension method.
Public property | IsStatic | Gets a value indicating whether the described method is static.
Public property | MemberAccess | Gets the types of access supported by this member
Public property | Name | Gets the name of the described method
Public property | Parameters | Gets the type of the arguments of the underlying CLR function
Public property | SortDiscriminant | Gets a sort discriminant to give consistent overload resolution matching in case of perfectly equal scores
Public property | VarArgsArrayType | Gets a value indicating the type of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned.
Public property | VarArgsElementType | Gets a value indicating the type of the elements of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned.
Top
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase.ExtensionMethodType Property

FunctionMemberDescriptorBaseExtensionMethodType Property
Gets the type which this extension method extends, null if this is not an extension method.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Type ExtensionMethodType { get; }
Public ReadOnly Property ExtensionMethodType As Type
    Get
public:
virtual property Type^ ExtensionMethodType {
    Type^ get () sealed;
}
abstract ExtensionMethodType : Type with get
override ExtensionMethodType : Type with get

Property Value

Type: Type

Implements

IOverloadableMemberDescriptorExtensionMethodType
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase.IsStatic Property

FunctionMemberDescriptorBaseIsStatic Property
Gets a value indicating whether the described method is static.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStatic { get; }
Public ReadOnly Property IsStatic As Boolean
    Get
public:
virtual property bool IsStatic {
    bool get () sealed;
}
abstract IsStatic : bool with get
override IsStatic : bool with get

Property Value

Type: Boolean

Implements

IMemberDescriptorIsStatic
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase.MemberAccess Property

FunctionMemberDescriptorBaseMemberAccess Property
Gets the types of access supported by this member

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MemberDescriptorAccess MemberAccess { get; }
Public ReadOnly Property MemberAccess As MemberDescriptorAccess
    Get
public:
virtual property MemberDescriptorAccess MemberAccess {
    MemberDescriptorAccess get () sealed;
}
abstract MemberAccess : MemberDescriptorAccess with get
override MemberAccess : MemberDescriptorAccess with get

Property Value

Type: MemberDescriptorAccess

Implements

IMemberDescriptorMemberAccess
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase.Name Property

FunctionMemberDescriptorBaseName Property
Gets the name of the described method

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IMemberDescriptorName
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase.Parameters Property

FunctionMemberDescriptorBaseParameters Property
Gets the type of the arguments of the underlying CLR function

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterDescriptor[] Parameters { get; }
Public ReadOnly Property Parameters As ParameterDescriptor()
    Get
public:
virtual property array<ParameterDescriptor^>^ Parameters {
    array<ParameterDescriptor^>^ get () sealed;
}
abstract Parameters : ParameterDescriptor[] with get
override Parameters : ParameterDescriptor[] with get

Property Value

Type: ParameterDescriptor

Implements

IOverloadableMemberDescriptorParameters
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase.SortDiscriminant Property

FunctionMemberDescriptorBaseSortDiscriminant Property
Gets a sort discriminant to give consistent overload resolution matching in case of perfectly equal scores

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string SortDiscriminant { get; }
Public ReadOnly Property SortDiscriminant As String
    Get
public:
virtual property String^ SortDiscriminant {
    String^ get () sealed;
}
abstract SortDiscriminant : string with get
override SortDiscriminant : string with get

Property Value

Type: String

Implements

IOverloadableMemberDescriptorSortDiscriminant
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase.VarArgsArrayType Property

FunctionMemberDescriptorBaseVarArgsArrayType Property
Gets a value indicating the type of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Type VarArgsArrayType { get; }
Public ReadOnly Property VarArgsArrayType As Type
    Get
public:
virtual property Type^ VarArgsArrayType {
    Type^ get () sealed;
}
abstract VarArgsArrayType : Type with get
override VarArgsArrayType : Type with get

Property Value

Type: Type

Implements

IOverloadableMemberDescriptorVarArgsArrayType
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase.VarArgsElementType Property

FunctionMemberDescriptorBaseVarArgsElementType Property
Gets a value indicating the type of the elements of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Type VarArgsElementType { get; }
Public ReadOnly Property VarArgsElementType As Type
    Get
public:
virtual property Type^ VarArgsElementType {
    Type^ get () sealed;
}
abstract VarArgsElementType : Type with get
override VarArgsElementType : Type with get

Property Value

Type: Type

Implements

IOverloadableMemberDescriptorVarArgsElementType
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase Methods

FunctionMemberDescriptorBase Methods

The FunctionMemberDescriptorBase type exposes the following members.

Methods
 | Name | Description
Protected method | BuildArgumentList | Builds the argument list.
 | BuildReturnValue | Builds the return value of a call
 | CreateCallbackDynValue | Creates a callback DynValue starting from a MethodInfo.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | The internal callback which actually executes the method
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCallback | Gets a callback function as a delegate
Public method | GetCallbackAsDynValue | Gets the callback function as a DynValue.
Public method | GetCallbackFunction | Gets the callback function.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts.
Protected method | Initialize | Initializes this instance. This *MUST* be called by the constructors extending this class to complete initialization.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValue | Sets the value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase.BuildArgumentList Method

FunctionMemberDescriptorBaseBuildArgumentList Method
Builds the argument list.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual Object[] BuildArgumentList(
    Script script,
    Object obj,
    ScriptExecutionContext context,
    CallbackArguments args,
    out List<int> outParams
)
Protected Overridable Function BuildArgumentList (
    script As Script,
    obj As Object,
    context As ScriptExecutionContext,
    args As CallbackArguments,
    <OutAttribute> ByRef outParams As List(Of Integer)
) As Object()
protected:
virtual array<Object^>^ BuildArgumentList(
    Script^ script,
    Object^ obj,
    ScriptExecutionContext^ context,
    CallbackArguments^ args,
    [OutAttribute] List<int>^% outParams
)
abstract BuildArgumentList :
        script : Script *
        obj : Object *
        context : ScriptExecutionContext *
        args : CallbackArguments *
        outParams : List<int> byref -> Object[]
override BuildArgumentList :
        script : Script *
        obj : Object *
        context : ScriptExecutionContext *
        args : CallbackArguments *
        outParams : List<int> byref -> Object[]

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object.
context
Type: MoonSharp.InterpreterScriptExecutionContext
The context.
args
Type: MoonSharp.InterpreterCallbackArguments
The arguments.
outParams
Type: System.Collections.GenericList Int32
Output: A list containing the indices of all "out" parameters, or null if no out parameters are specified.

Return Value

Type: Object
The arguments, appropriately converted.
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase.BuildReturnValue Method

FunctionMemberDescriptorBaseBuildReturnValue Method
Builds the return value of a call

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static DynValue BuildReturnValue(
    Script script,
    List<int> outParams,
    Object[] pars,
    Object retv
)
Protected Shared Function BuildReturnValue (
    script As Script,
    outParams As List(Of Integer),
    pars As Object(),
    retv As Object
) As DynValue
protected:
static DynValue^ BuildReturnValue(
    Script^ script,
    List<int>^ outParams,
    array<Object^>^ pars,
    Object^ retv
)
static member BuildReturnValue :
        script : Script *
        outParams : List<int> *
        pars : Object[] *
        retv : Object -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
outParams
Type: System.Collections.GenericList Int32
The out parameters indices, or null. See BuildArgumentList(Script, Object, ScriptExecutionContext, CallbackArguments, ListInt32).
pars
Type: SystemObject
The parameters passed to the function.
retv
Type: SystemObject
The return value from the function. Use DynValue.Void if the function returned no value.

Return Value

Type: DynValue
A DynValue to be returned to scripts
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase.CreateCallbackDynValue Method

FunctionMemberDescriptorBaseCreateCallbackDynValue Method
Creates a callback DynValue starting from a MethodInfo.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue CreateCallbackDynValue(
    Script script,
    MethodInfo mi,
    Object obj = null
)
Public Shared Function CreateCallbackDynValue (
    script As Script,
    mi As MethodInfo,
    Optional obj As Object = Nothing
) As DynValue
public:
static DynValue^ CreateCallbackDynValue(
    Script^ script,
    MethodInfo^ mi,
    Object^ obj = nullptr
)
static member CreateCallbackDynValue :
        script : Script *
        mi : MethodInfo *
        ?obj : Object
(* Defaults:
        let _obj = defaultArg obj null
*)
-> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
mi
Type: System.ReflectionMethodInfo
The mi.
obj (Optional)
Type: SystemObject
The object.

Return Value

Type: DynValue
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase.Execute Method

FunctionMemberDescriptorBaseExecute Method
The internal callback which actually executes the method

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract DynValue Execute(
    Script script,
    Object obj,
    ScriptExecutionContext context,
    CallbackArguments args
)
Public MustOverride Function Execute (
    script As Script,
    obj As Object,
    context As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
virtual DynValue^ Execute(
    Script^ script,
    Object^ obj,
    ScriptExecutionContext^ context,
    CallbackArguments^ args
) abstract
abstract Execute :
        script : Script *
        obj : Object *
        context : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object.
context
Type: MoonSharp.InterpreterScriptExecutionContext
The context.
args
Type: MoonSharp.InterpreterCallbackArguments
The arguments.

Return Value

Type: DynValue

Implements

IOverloadableMemberDescriptorExecute(Script, Object, ScriptExecutionContext, CallbackArguments)
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase.GetCallback Method

FunctionMemberDescriptorBaseGetCallback Method
Gets a callback function as a delegate

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Func<ScriptExecutionContext, CallbackArguments, DynValue> GetCallback(
    Script script,
    Object obj = null
)
Public Function GetCallback (
    script As Script,
    Optional obj As Object = Nothing
) As Func(Of ScriptExecutionContext, CallbackArguments, DynValue)
public:
Func<ScriptExecutionContext^, CallbackArguments^, DynValue^>^ GetCallback(
    Script^ script,
    Object^ obj = nullptr
)
member GetCallback :
        script : Script *
        ?obj : Object
(* Defaults:
        let _obj = defaultArg obj null
*)
-> Func<ScriptExecutionContext, CallbackArguments, DynValue>

Parameters

script
Type: MoonSharp.InterpreterScript
The script for which the callback must be generated.
obj (Optional)
Type: SystemObject
The object (null for static).

Return Value

Type: Func ScriptExecutionContext, CallbackArguments, DynValue
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase.GetCallbackAsDynValue Method

FunctionMemberDescriptorBaseGetCallbackAsDynValue Method
Gets the callback function as a DynValue.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue GetCallbackAsDynValue(
    Script script,
    Object obj = null
)
Public Function GetCallbackAsDynValue (
    script As Script,
    Optional obj As Object = Nothing
) As DynValue
public:
DynValue^ GetCallbackAsDynValue(
    Script^ script,
    Object^ obj = nullptr
)
member GetCallbackAsDynValue :
        script : Script *
        ?obj : Object
(* Defaults:
        let _obj = defaultArg obj null
*)
-> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script for which the callback must be generated.
obj (Optional)
Type: SystemObject
The object (null for static).

Return Value

Type: DynValue
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase.GetCallbackFunction Method

FunctionMemberDescriptorBaseGetCallbackFunction Method
Gets the callback function.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CallbackFunction GetCallbackFunction(
    Script script,
    Object obj = null
)
Public Function GetCallbackFunction (
    script As Script,
    Optional obj As Object = Nothing
) As CallbackFunction
public:
CallbackFunction^ GetCallbackFunction(
    Script^ script,
    Object^ obj = nullptr
)
member GetCallbackFunction :
        script : Script *
        ?obj : Object
(* Defaults:
        let _obj = defaultArg obj null
*)
-> CallbackFunction

Parameters

script
Type: MoonSharp.InterpreterScript
The script for which the callback must be generated.
obj (Optional)
Type: SystemObject
The object (null for static).

Return Value

Type: CallbackFunction
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase.GetValue Method

FunctionMemberDescriptorBaseGetValue Method
Gets the value of this member as a DynValue to be exposed to scripts.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DynValue GetValue(
    Script script,
    Object obj
)
Public Overridable Function GetValue (
    script As Script,
    obj As Object
) As DynValue
public:
virtual DynValue^ GetValue(
    Script^ script,
    Object^ obj
)
abstract GetValue :
        script : Script *
        obj : Object -> DynValue
override GetValue :
        script : Script *
        obj : Object -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object owning this member, or null if static.

Return Value

Type: DynValue
The value of this member as a DynValue.

Implements

IMemberDescriptorGetValue(Script, Object)
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase.Initialize Method

FunctionMemberDescriptorBaseInitialize Method
Initializes this instance. This *MUST* be called by the constructors extending this class to complete initialization.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected void Initialize(
    string funcName,
    bool isStatic,
    ParameterDescriptor[] parameters,
    bool isExtensionMethod
)
Protected Sub Initialize (
    funcName As String,
    isStatic As Boolean,
    parameters As ParameterDescriptor(),
    isExtensionMethod As Boolean
)
protected:
void Initialize(
    String^ funcName,
    bool isStatic,
    array<ParameterDescriptor^>^ parameters,
    bool isExtensionMethod
)
member Initialize :
        funcName : string *
        isStatic : bool *
        parameters : ParameterDescriptor[] *
        isExtensionMethod : bool -> unit

Parameters

funcName
Type: SystemString
Name of the function.
isStatic
Type: SystemBoolean
if set to true [is static].
parameters
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsParameterDescriptor
The parameters.
isExtensionMethod
Type: SystemBoolean
if set to true [is extension method].
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


FunctionMemberDescriptorBase.SetValue Method

FunctionMemberDescriptorBaseSetValue Method
Sets the value.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public virtual void SetValue(
    Script script,
    Object obj,
    DynValue v
)
Public Overridable Sub SetValue (
    script As Script,
    obj As Object,
    v As DynValue
)
public:
virtual void SetValue(
    Script^ script,
    Object^ obj,
    DynValue^ v
)
abstract SetValue :
        script : Script *
        obj : Object *
        v : DynValue -> unit
override SetValue :
        script : Script *
        obj : Object *
        v : DynValue -> unit

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object.
v
Type: MoonSharp.InterpreterDynValue
The v.

Implements

IMemberDescriptorSetValue(Script, Object, DynValue)
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

FunctionMemberDescriptorBase Class
MoonSharp.Interpreter.Interop Namespace


IGeneratorUserDataDescriptor Interface

IGeneratorUserDataDescriptor Interface
An interface for type descriptors having the ability to generate other descriptors on the fly.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public interface IGeneratorUserDataDescriptor : IUserDataDescriptor
Public Interface IGeneratorUserDataDescriptor
    Inherits IUserDataDescriptor
public interface class IGeneratorUserDataDescriptor : IUserDataDescriptor
type IGeneratorUserDataDescriptor =
    interface
        interface IUserDataDescriptor
    end

The IGeneratorUserDataDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the name of the descriptor (usually, the name of the type described). (Inherited from IUserDataDescriptor.)
Public property | Type | Gets the type this descriptor refers to (Inherited from IUserDataDescriptor.)
Top
Methods
Name Description
Public method AsString
Converts this userdata to string
(Inherited from IUserDataDescriptor.)
Public method Generate
Generates a new descriptor for the specified type. The purpose is to allow a mechanism by which a type descriptor can replace itself with another descriptor for a specific type. For example, descriptors can be created on the fly to support generic types through this mechanism. The return value should be: null - if this descriptor is simply skipped for the specified type this - acts as if the descriptor was a vanilla descriptor a new descriptor - if a new descriptor should be used in place of this one It's recommended that instances of descriptors are cached for future references. One possible way, to do the caching is to have the generator register the descriptor through RegisterType(Type, InteropAccessMode, String). In that case, it should query whether the type is exactly registered, through IsTypeRegistered(Type) NOTE-1 : the search for descriptors does NOT stop with the descriptor returned by this type, but other descriptors (e.g. for interfaces) might still be added. NOTE-2 : the descriptor generation mechanism is not triggered on an exact match of types. NOTE-3 : the method is called in the context of a lock over the descriptors registry so no unpredictable changes to the registry can come from other threads during the execution of this method. However this method should not take other locks, to avoid deadlocks.
Public method Index
Performs an "index" "get" operation.
(Inherited from IUserDataDescriptor.)
Public method IsTypeCompatible
Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "
(Inherited from IUserDataDescriptor.)
Public method MetaIndex
Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). These standard metamethods can be supported (the return value should be a function accepting the classic parameters of the corresponding metamethod): __add, __sub, __mul, __div, __div, __pow, __unm, __eq, __lt, __le, __lt, __len, __concat, __pairs, __ipairs, __iterator, __call These standard metamethods are supported through other calls for efficiency: __index, __newindex, __tostring
(Inherited from IUserDataDescriptor.)
Public method SetIndex
Performs an "index" "set" operation.
(Inherited from IUserDataDescriptor.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


IGeneratorUserDataDescriptor Properties

IGeneratorUserDataDescriptor Properties

The IGeneratorUserDataDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the name of the descriptor (usually, the name of the type described). (Inherited from IUserDataDescriptor.)
Public property | Type | Gets the type this descriptor refers to (Inherited from IUserDataDescriptor.)
Top
See Also

Reference

IGeneratorUserDataDescriptor Interface
MoonSharp.Interpreter.Interop Namespace


IGeneratorUserDataDescriptor Methods

IGeneratorUserDataDescriptor Methods

The IGeneratorUserDataDescriptor type exposes the following members.

Methods
Name Description
Public method AsString
Converts this userdata to string
(Inherited from IUserDataDescriptor.)
Public method Generate
Generates a new descriptor for the specified type. The purpose is to allow a mechanism by which a type descriptor can replace itself with another descriptor for a specific type. For example, descriptors can be created on the fly to support generic types through this mechanism. The return value should be: null - if this descriptor is simply skipped for the specified type this - acts as if the descriptor was a vanilla descriptor a new descriptor - if a new descriptor should be used in place of this one It's recommended that instances of descriptors are cached for future references. One possible way, to do the caching is to have the generator register the descriptor through RegisterType(Type, InteropAccessMode, String). In that case, it should query whether the type is exactly registered, through IsTypeRegistered(Type) NOTE-1 : the search for descriptors does NOT stop with the descriptor returned by this type, but other descriptors (e.g. for interfaces) might still be added. NOTE-2 : the descriptor generation mechanism is not triggered on an exact match of types. NOTE-3 : the method is called in the context of a lock over the descriptors registry so no unpredictable changes to the registry can come from other threads during the execution of this method. However this method should not take other locks, to avoid deadlocks.
Public method Index
Performs an "index" "get" operation.
(Inherited from IUserDataDescriptor.)
Public method IsTypeCompatible
Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "
(Inherited from IUserDataDescriptor.)
Public method MetaIndex
Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). These standard metamethods can be supported (the return value should be a function accepting the classic parameters of the corresponding metamethod): __add, __sub, __mul, __div, __div, __pow, __unm, __eq, __lt, __le, __lt, __len, __concat, __pairs, __ipairs, __iterator, __call These standard metamethods are supported through other calls for efficiency: __index, __newindex, __tostring
(Inherited from IUserDataDescriptor.)
Public method SetIndex
Performs an "index" "set" operation.
(Inherited from IUserDataDescriptor.)
Top
See Also

Reference

IGeneratorUserDataDescriptor Interface
MoonSharp.Interpreter.Interop Namespace


IGeneratorUserDataDescriptor.Generate Method

IGeneratorUserDataDescriptorGenerate Method
Generates a new descriptor for the specified type. The purpose is to allow a mechanism by which a type descriptor can replace itself with another descriptor for a specific type. For example, descriptors can be created on the fly to support generic types through this mechanism. The return value should be: null - if this descriptor is simply skipped for the specified type this - acts as if the descriptor was a vanilla descriptor a new descriptor - if a new descriptor should be used in place of this one It's recommended that instances of descriptors are cached for future references. One possible way, to do the caching is to have the generator register the descriptor through RegisterType(Type, InteropAccessMode, String). In that case, it should query whether the type is exactly registered, through IsTypeRegistered(Type) NOTE-1 : the search for descriptors does NOT stop with the descriptor returned by this type, but other descriptors (e.g. for interfaces) might still be added. NOTE-2 : the descriptor generation mechanism is not triggered on an exact match of types. NOTE-3 : the method is called in the context of a lock over the descriptors registry so no unpredictable changes to the registry can come from other threads during the execution of this method. However this method should not take other locks, to avoid deadlocks.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
IUserDataDescriptor Generate(
    Type type
)
Function Generate (
    type As Type
) As IUserDataDescriptor
IUserDataDescriptor^ Generate(
    Type^ type
)
abstract Generate :
        type : Type -> IUserDataDescriptor

Parameters

type
Type: SystemType
The type.

Return Value

Type: IUserDataDescriptor
Null, this object instance or a new descriptor.
See Also

Reference

IGeneratorUserDataDescriptor Interface
MoonSharp.Interpreter.Interop Namespace


InteropRegistrationPolicy Class

InteropRegistrationPolicy Class
Collection of the standard policies to handle UserData type registrations. Provided mostly for compile-time backward compatibility with old code. See also : IRegistrationPolicy .
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropInteropRegistrationPolicy

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static class InteropRegistrationPolicy
Public NotInheritable Class InteropRegistrationPolicy
public ref class InteropRegistrationPolicy abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type InteropRegistrationPolicy =  class end

The InteropRegistrationPolicy type exposes the following members.

Properties
Name | Description
Automatic | Types are automatically registered if not found in the registry. This is easier to use but potentially unsafe.
Default | The default registration policy used by MoonSharp unless explicitely replaced. Deregistrations are allowed, but registration of a new descriptor are not allowed if a descriptor is already registered for that type. Types must be explicitly registered.
Explicit | Obsolete. The default registration policy used by MoonSharp unless explicitely replaced. Deregistrations are allowed, but registration of a new descriptor are not allowed if a descriptor is already registered for that type. Types must be explicitly registered.
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


InteropRegistrationPolicy Properties

InteropRegistrationPolicy Properties

The InteropRegistrationPolicy type exposes the following members.

Properties
Name | Description
Automatic | Types are automatically registered if not found in the registry. This is easier to use but potentially unsafe.
Default | The default registration policy used by MoonSharp unless explicitely replaced. Deregistrations are allowed, but registration of a new descriptor are not allowed if a descriptor is already registered for that type. Types must be explicitly registered.
Explicit | Obsolete. The default registration policy used by MoonSharp unless explicitely replaced. Deregistrations are allowed, but registration of a new descriptor are not allowed if a descriptor is already registered for that type. Types must be explicitly registered.
Top
See Also

Reference

InteropRegistrationPolicy Class
MoonSharp.Interpreter.Interop Namespace


InteropRegistrationPolicy.Automatic Property

InteropRegistrationPolicyAutomatic Property
Types are automatically registered if not found in the registry. This is easier to use but potentially unsafe.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IRegistrationPolicy Automatic { get; }
Public Shared ReadOnly Property Automatic As IRegistrationPolicy
    Get
public:
static property IRegistrationPolicy^ Automatic {
    IRegistrationPolicy^ get ();
}
static member Automatic : IRegistrationPolicy with get

Property Value

Type: IRegistrationPolicy
See Also

Reference

InteropRegistrationPolicy Class
MoonSharp.Interpreter.Interop Namespace


InteropRegistrationPolicy.Default Property

InteropRegistrationPolicyDefault Property
The default registration policy used by MoonSharp unless explicitely replaced. Deregistrations are allowed, but registration of a new descriptor are not allowed if a descriptor is already registered for that type. Types must be explicitly registered.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IRegistrationPolicy Default { get; }
Public Shared ReadOnly Property Default As IRegistrationPolicy
    Get
public:
static property IRegistrationPolicy^ Default {
    IRegistrationPolicy^ get ();
}
static member Default : IRegistrationPolicy with get

Property Value

Type: IRegistrationPolicy
See Also

Reference

InteropRegistrationPolicy Class
MoonSharp.Interpreter.Interop Namespace


InteropRegistrationPolicy.Explicit Property

InteropRegistrationPolicyExplicit Property

Note: This API is now obsolete.

The default registration policy used by MoonSharp unless explicitely replaced. Deregistrations are allowed, but registration of a new descriptor are not allowed if a descriptor is already registered for that type. Types must be explicitly registered.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Please use InteropRegistrationPolicy.Default instead.")]
public static IRegistrationPolicy Explicit { get; }
<ObsoleteAttribute("Please use InteropRegistrationPolicy.Default instead.")>
Public Shared ReadOnly Property Explicit As IRegistrationPolicy
    Get
public:
[ObsoleteAttribute(L"Please use InteropRegistrationPolicy.Default instead.")]
static property IRegistrationPolicy^ Explicit {
    IRegistrationPolicy^ get ();
}
[<ObsoleteAttribute("Please use InteropRegistrationPolicy.Default instead.")>]
static member Explicit : IRegistrationPolicy with get

Property Value

Type: IRegistrationPolicy
See Also

Reference

InteropRegistrationPolicy Class
MoonSharp.Interpreter.Interop Namespace


IPropertyTableAssigner Interface

IPropertyTableAssigner Interface
Common interface for property assigners - basically used for sub-assigners

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPropertyTableAssigner
Public Interface IPropertyTableAssigner
public interface class IPropertyTableAssigner
type IPropertyTableAssigner =  interface end

The IPropertyTableAssigner type exposes the following members.

Methods
 | Name | Description
Public method | AssignObjectUnchecked | Assigns the properties of the specified object without checking the type.
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


IPropertyTableAssigner Methods

IPropertyTableAssigner Methods

The IPropertyTableAssigner type exposes the following members.

Methods
 | Name | Description
Public method | AssignObjectUnchecked | Assigns the properties of the specified object without checking the type.
Top
See Also

Reference

IPropertyTableAssigner Interface
MoonSharp.Interpreter.Interop Namespace


IPropertyTableAssigner.AssignObjectUnchecked Method

IPropertyTableAssignerAssignObjectUnchecked Method
Assigns the properties of the specified object without checking the type.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
void AssignObjectUnchecked(
    Object o,
    Table data
)
Sub AssignObjectUnchecked (
    o As Object,
    data As Table
)
void AssignObjectUnchecked(
    Object^ o,
    Table^ data
)
abstract AssignObjectUnchecked :
        o : Object *
        data : Table -> unit

Parameters

o
Type: SystemObject
The object.
data
Type: MoonSharp.InterpreterTable
The data.
See Also

Reference

IPropertyTableAssigner Interface
MoonSharp.Interpreter.Interop Namespace


IProxyFactory Interface

IProxyFactory Interface
Interface for proxy objects (type unsafe version)

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public interface IProxyFactory
Public Interface IProxyFactory
public interface class IProxyFactory
type IProxyFactory =  interface end

The IProxyFactory type exposes the following members.

Properties
 | Name | Description
Public property | ProxyType | Gets the proxy type
Public property | TargetType | Gets the proxied type
Top
Methods
 | Name | Description
Public method | CreateProxyObject | Takes an instance of a target object and returns a proxy object wrapping it
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


IProxyFactory Properties

IProxyFactory Properties

The IProxyFactory type exposes the following members.

Properties
 | Name | Description
Public property | ProxyType | Gets the proxy type
Public property | TargetType | Gets the proxied type
Top
See Also

Reference

IProxyFactory Interface
MoonSharp.Interpreter.Interop Namespace


IProxyFactory.ProxyType Property

IProxyFactoryProxyType Property
Gets the proxy type

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
Type ProxyType { get; }
ReadOnly Property ProxyType As Type
    Get
property Type^ ProxyType {
    Type^ get ();
}
abstract ProxyType : Type with get

Property Value

Type: Type
See Also

Reference

IProxyFactory Interface
MoonSharp.Interpreter.Interop Namespace


IProxyFactory.TargetType Property

IProxyFactoryTargetType Property
Gets the proxied type

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
Type TargetType { get; }
ReadOnly Property TargetType As Type
    Get
property Type^ TargetType {
    Type^ get ();
}
abstract TargetType : Type with get

Property Value

Type: Type
See Also

Reference

IProxyFactory Interface
MoonSharp.Interpreter.Interop Namespace


IProxyFactory Methods

IProxyFactory Methods

The IProxyFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateProxyObject | Takes an instance of a target object and returns a proxy object wrapping it
Top
See Also

Reference

IProxyFactory Interface
MoonSharp.Interpreter.Interop Namespace


IProxyFactory.CreateProxyObject Method

IProxyFactoryCreateProxyObject Method
Takes an instance of a target object and returns a proxy object wrapping it

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
Object CreateProxyObject(
    Object o
)
Function CreateProxyObject (
    o As Object
) As Object
Object^ CreateProxyObject(
    Object^ o
)
abstract CreateProxyObject :
        o : Object -> Object

Parameters

o
Type: SystemObject

[Missing <param name="o"/> documentation for "M:MoonSharp.Interpreter.Interop.IProxyFactory.CreateProxyObject(System.Object)"]

Return Value

Type: Object
See Also

Reference

IProxyFactory Interface
MoonSharp.Interpreter.Interop Namespace


IProxyFactory(TProxy, TTarget) Interface

IProxyFactoryTProxy, TTarget Interface
Interface for proxy objects (type safe version)

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public interface IProxyFactory<TProxy, TTarget> : IProxyFactory
where TProxy : class
where TTarget : class

Public Interface IProxyFactory(Of TProxy As Class, TTarget As Class)
    Inherits IProxyFactory
generic<typename TProxy, typename TTarget>
where TProxy : ref class
where TTarget : ref class
public interface class IProxyFactory : IProxyFactory
type IProxyFactory<'TProxy, 'TTarget when 'TProxy : not struct when 'TTarget : not struct> =
    interface
        interface IProxyFactory
    end

Type Parameters

TProxy
The type of the proxy.
TTarget
The type of the target.

The IProxyFactoryTProxy, TTarget type exposes the following members.

Properties
 | Name | Description
Public property | ProxyType | Gets the proxy type (Inherited from IProxyFactory.)
Public property | TargetType | Gets the proxied type (Inherited from IProxyFactory.)
Top
Methods
 | Name | Description
Public method | CreateProxyObject(Object) | Takes an instance of a target object and returns a proxy object wrapping it (Inherited from IProxyFactory.)
Public method | CreateProxyObject(TTarget) | Takes an instance of a target object and returns a proxy object wrapping it
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


IProxyFactory(TProxy, TTarget) Properties

IProxyFactoryTProxy, TTarget Properties

The IProxyFactoryTProxy, TTarget generic type exposes the following members.

Properties
 | Name | Description
Public property | ProxyType | Gets the proxy type (Inherited from IProxyFactory.)
Public property | TargetType | Gets the proxied type (Inherited from IProxyFactory.)
Top
See Also

Reference

IProxyFactoryTProxy, TTarget Interface
MoonSharp.Interpreter.Interop Namespace


IProxyFactory(TProxy, TTarget) Methods

IProxyFactoryTProxy, TTarget Methods
Methods
 | Name | Description
Public method | CreateProxyObject(Object) | Takes an instance of a target object and returns a proxy object wrapping it (Inherited from IProxyFactory.)
Public method | CreateProxyObject(TTarget) | Takes an instance of a target object and returns a proxy object wrapping it
Top
See Also

Reference

IProxyFactoryTProxy, TTarget Interface
MoonSharp.Interpreter.Interop Namespace


IProxyFactory(TProxy, TTarget).CreateProxyObject Method

IProxyFactoryTProxy, TTargetCreateProxyObject Method
Overload List
 | Name | Description
Public method | CreateProxyObject(Object) | Takes an instance of a target object and returns a proxy object wrapping it (Inherited from IProxyFactory.)
Public method | CreateProxyObject(TTarget) | Takes an instance of a target object and returns a proxy object wrapping it
Top
See Also

Reference

IProxyFactoryTProxy, TTarget Interface
MoonSharp.Interpreter.Interop Namespace


IProxyFactory(TProxy, TTarget).CreateProxyObject Method (TTarget)

IProxyFactoryTProxy, TTargetCreateProxyObject Method (TTarget)
Takes an instance of a target object and returns a proxy object wrapping it

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
TProxy CreateProxyObject(
    TTarget target
)
Function CreateProxyObject (
    target As TTarget
) As TProxy
TProxy CreateProxyObject(
    TTarget target
)
abstract CreateProxyObject :
        target : 'TTarget -> 'TProxy

Parameters

target
Type: TTarget

[Missing <param name="target"/> documentation for "M:MoonSharp.Interpreter.Interop.IProxyFactory`2.CreateProxyObject(`1)"]

Return Value

Type: TProxy
See Also

Reference

IProxyFactoryTProxy, TTarget Interface
CreateProxyObject Overload
MoonSharp.Interpreter.Interop Namespace


IUserDataDescriptor Interface

IUserDataDescriptor Interface
Interface used by MoonSharp to access objects of a given type from scripts.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public interface IUserDataDescriptor
Public Interface IUserDataDescriptor
public interface class IUserDataDescriptor
type IUserDataDescriptor =  interface end

The IUserDataDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the name of the descriptor (usually, the name of the type described).
Public property | Type | Gets the type this descriptor refers to
Top
Methods
 | Name | Description
Public method | AsString | Converts this userdata to string
Public method | Index | Performs an "index" "get" operation.
Public method | IsTypeCompatible | Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "
Public method | MetaIndex | Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). These standard metamethods can be supported (the return value should be a function accepting the classic parameters of the corresponding metamethod): __add, __sub, __mul, __div, __div, __pow, __unm, __eq, __lt, __le, __lt, __len, __concat, __pairs, __ipairs, __iterator, __call These standard metamethods are supported through other calls for efficiency: __index, __newindex, __tostring
Public method | SetIndex | Performs an "index" "set" operation.
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


IUserDataDescriptor Properties

IUserDataDescriptor Properties

The IUserDataDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the name of the descriptor (usually, the name of the type described).
Public property | Type | Gets the type this descriptor refers to
Top
See Also

Reference

IUserDataDescriptor Interface
MoonSharp.Interpreter.Interop Namespace


IUserDataDescriptor.Name Property

IUserDataDescriptorName Property
Gets the name of the descriptor (usually, the name of the type described).

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IUserDataDescriptor Interface
MoonSharp.Interpreter.Interop Namespace


IUserDataDescriptor.Type Property

IUserDataDescriptorType Property
Gets the type this descriptor refers to

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
Type Type { get; }
ReadOnly Property Type As Type
    Get
property Type^ Type {
    Type^ get ();
}
abstract Type : Type with get

Property Value

Type: Type
See Also

Reference

IUserDataDescriptor Interface
MoonSharp.Interpreter.Interop Namespace


IUserDataDescriptor Methods

IUserDataDescriptor Methods

The IUserDataDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | AsString | Converts this userdata to string
Public method | Index | Performs an "index" "get" operation.
Public method | IsTypeCompatible | Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "
Public method | MetaIndex | Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). These standard metamethods can be supported (the return value should be a function accepting the classic parameters of the corresponding metamethod): __add, __sub, __mul, __div, __div, __pow, __unm, __eq, __lt, __le, __lt, __len, __concat, __pairs, __ipairs, __iterator, __call These standard metamethods are supported through other calls for efficiency: __index, __newindex, __tostring
Public method | SetIndex | Performs an "index" "set" operation.
Top
See Also

Reference

IUserDataDescriptor Interface
MoonSharp.Interpreter.Interop Namespace


IUserDataDescriptor.AsString Method

IUserDataDescriptorAsString Method
Converts this userdata to string

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
string AsString(
    Object obj
)
Function AsString (
    obj As Object
) As String
String^ AsString(
    Object^ obj
)
abstract AsString :
        obj : Object -> string

Parameters

obj
Type: SystemObject
The object.

Return Value

Type: String
See Also

Reference

IUserDataDescriptor Interface
MoonSharp.Interpreter.Interop Namespace


IUserDataDescriptor.Index Method

IUserDataDescriptorIndex Method
Performs an "index" "get" operation.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
DynValue Index(
    Script script,
    Object obj,
    DynValue index,
    bool isDirectIndexing
)
Function Index (
    script As Script,
    obj As Object,
    index As DynValue,
    isDirectIndexing As Boolean
) As DynValue
DynValue^ Index(
    Script^ script,
    Object^ obj,
    DynValue^ index,
    bool isDirectIndexing
)
abstract Index :
        script : Script *
        obj : Object *
        index : DynValue *
        isDirectIndexing : bool -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script originating the request
obj
Type: SystemObject
The object (null if a static request is done)
index
Type: MoonSharp.InterpreterDynValue
The index.
isDirectIndexing
Type: SystemBoolean
If set to true, it's indexed with a name, if false it's indexed through brackets.

Return Value

Type: DynValue
See Also

Reference

IUserDataDescriptor Interface
MoonSharp.Interpreter.Interop Namespace


IUserDataDescriptor.IsTypeCompatible Method

IUserDataDescriptorIsTypeCompatible Method
Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
bool IsTypeCompatible(
    Type type,
    Object obj
)
Function IsTypeCompatible (
    type As Type,
    obj As Object
) As Boolean
bool IsTypeCompatible(
    Type^ type,
    Object^ obj
)
abstract IsTypeCompatible :
        type : Type *
        obj : Object -> bool

Parameters

type
Type: SystemType
The type.
obj
Type: SystemObject
The object.

Return Value

Type: Boolean
See Also

Reference

IUserDataDescriptor Interface
MoonSharp.Interpreter.Interop Namespace


IUserDataDescriptor.MetaIndex Method

IUserDataDescriptorMetaIndex Method
Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). These standard metamethods can be supported (the return value should be a function accepting the classic parameters of the corresponding metamethod): __add, __sub, __mul, __div, __div, __pow, __unm, __eq, __lt, __le, __lt, __len, __concat, __pairs, __ipairs, __iterator, __call These standard metamethods are supported through other calls for efficiency: __index, __newindex, __tostring

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
DynValue MetaIndex(
    Script script,
    Object obj,
    string metaname
)
Function MetaIndex (
    script As Script,
    obj As Object,
    metaname As String
) As DynValue
DynValue^ MetaIndex(
    Script^ script,
    Object^ obj,
    String^ metaname
)
abstract MetaIndex :
        script : Script *
        obj : Object *
        metaname : string -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script originating the request
obj
Type: SystemObject
The object (null if a static request is done)
metaname
Type: SystemString
The name of the metamember.

Return Value

Type: DynValue
See Also

Reference

IUserDataDescriptor Interface
MoonSharp.Interpreter.Interop Namespace


IUserDataDescriptor.SetIndex Method

IUserDataDescriptorSetIndex Method
Performs an "index" "set" operation.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
bool SetIndex(
    Script script,
    Object obj,
    DynValue index,
    DynValue value,
    bool isDirectIndexing
)
Function SetIndex (
    script As Script,
    obj As Object,
    index As DynValue,
    value As DynValue,
    isDirectIndexing As Boolean
) As Boolean
bool SetIndex(
    Script^ script,
    Object^ obj,
    DynValue^ index,
    DynValue^ value,
    bool isDirectIndexing
)
abstract SetIndex :
        script : Script *
        obj : Object *
        index : DynValue *
        value : DynValue *
        isDirectIndexing : bool -> bool

Parameters

script
Type: MoonSharp.InterpreterScript
The script originating the request
obj
Type: SystemObject
The object (null if a static request is done)
index
Type: MoonSharp.InterpreterDynValue
The index.
value
Type: MoonSharp.InterpreterDynValue
The value to be set
isDirectIndexing
Type: SystemBoolean
If set to true, it's indexed with a name, if false it's indexed through brackets.

Return Value

Type: Boolean
See Also

Reference

IUserDataDescriptor Interface
MoonSharp.Interpreter.Interop Namespace


IUserDataType Interface

IUserDataType Interface
As a convenience, every type deriving from IUserDataType is "self-described". That is, no descriptor is needed/generated and the object itself is used to describe the type for interop. See also UserData, IUserDataDescriptor and StandardUserDataDescriptor .

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public interface IUserDataType
Public Interface IUserDataType
public interface class IUserDataType
type IUserDataType =  interface end

The IUserDataType type exposes the following members.

Methods
 | Name | Description
Public method | Index | Performs an "index" "get" operation.
Public method | MetaIndex | Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). These standard metamethods can be supported (the return value should be a function accepting the classic parameters of the corresponding metamethod): __add, __sub, __mul, __div, __div, __pow, __unm, __eq, __lt, __le, __lt, __len, __concat, __pairs, __ipairs, __iterator, __call These standard metamethods are supported through other calls for efficiency: __index, __newindex, __tostring
Public method | SetIndex | Performs an "index" "set" operation.
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


IUserDataType Methods

IUserDataType Methods

The IUserDataType type exposes the following members.

Methods
 | Name | Description
Public method | Index | Performs an "index" "get" operation.
Public method | MetaIndex | Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). These standard metamethods can be supported (the return value should be a function accepting the classic parameters of the corresponding metamethod): __add, __sub, __mul, __div, __div, __pow, __unm, __eq, __lt, __le, __lt, __len, __concat, __pairs, __ipairs, __iterator, __call These standard metamethods are supported through other calls for efficiency: __index, __newindex, __tostring
Public method | SetIndex | Performs an "index" "set" operation.
Top
See Also

Reference

IUserDataType Interface
MoonSharp.Interpreter.Interop Namespace


IUserDataType.Index Method

IUserDataTypeIndex Method
Performs an "index" "get" operation.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
DynValue Index(
    Script script,
    DynValue index,
    bool isDirectIndexing
)
Function Index (
    script As Script,
    index As DynValue,
    isDirectIndexing As Boolean
) As DynValue
DynValue^ Index(
    Script^ script,
    DynValue^ index,
    bool isDirectIndexing
)
abstract Index :
        script : Script *
        index : DynValue *
        isDirectIndexing : bool -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script originating the request
index
Type: MoonSharp.InterpreterDynValue
The index.
isDirectIndexing
Type: SystemBoolean
If set to true, it's indexed with a name, if false it's indexed through brackets.

Return Value

Type: DynValue
See Also

Reference

IUserDataType Interface
MoonSharp.Interpreter.Interop Namespace


IUserDataType.MetaIndex Method

IUserDataTypeMetaIndex Method
Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). These standard metamethods can be supported (the return value should be a function accepting the classic parameters of the corresponding metamethod): __add, __sub, __mul, __div, __div, __pow, __unm, __eq, __lt, __le, __lt, __len, __concat, __pairs, __ipairs, __iterator, __call These standard metamethods are supported through other calls for efficiency: __index, __newindex, __tostring

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
DynValue MetaIndex(
    Script script,
    string metaname
)
Function MetaIndex (
    script As Script,
    metaname As String
) As DynValue
DynValue^ MetaIndex(
    Script^ script,
    String^ metaname
)
abstract MetaIndex :
        script : Script *
        metaname : string -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script originating the request
metaname
Type: SystemString
The name of the metamember.

Return Value

Type: DynValue
See Also

Reference

IUserDataType Interface
MoonSharp.Interpreter.Interop Namespace


IUserDataType.SetIndex Method

IUserDataTypeSetIndex Method
Performs an "index" "set" operation.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
bool SetIndex(
    Script script,
    DynValue index,
    DynValue value,
    bool isDirectIndexing
)
Function SetIndex (
    script As Script,
    index As DynValue,
    value As DynValue,
    isDirectIndexing As Boolean
) As Boolean
bool SetIndex(
    Script^ script,
    DynValue^ index,
    DynValue^ value,
    bool isDirectIndexing
)
abstract SetIndex :
        script : Script *
        index : DynValue *
        value : DynValue *
        isDirectIndexing : bool -> bool

Parameters

script
Type: MoonSharp.InterpreterScript
The script originating the request
index
Type: MoonSharp.InterpreterDynValue
The index.
value
Type: MoonSharp.InterpreterDynValue
The value to be set
isDirectIndexing
Type: SystemBoolean
If set to true, it's indexed with a name, if false it's indexed through brackets.

Return Value

Type: Boolean
See Also

Reference

IUserDataType Interface
MoonSharp.Interpreter.Interop Namespace


MethodMemberDescriptor Class

MethodMemberDescriptor Class
Class providing easier marshalling of CLR functions
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropFunctionMemberDescriptorBase
MoonSharp.Interpreter.InteropMethodMemberDescriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class MethodMemberDescriptor : FunctionMemberDescriptorBase,
    IOptimizableDescriptor, IWireableDescriptor
Public Class MethodMemberDescriptor
    Inherits FunctionMemberDescriptorBase
    Implements IOptimizableDescriptor, IWireableDescriptor
public ref class MethodMemberDescriptor : public FunctionMemberDescriptorBase,
    IOptimizableDescriptor, IWireableDescriptor
type MethodMemberDescriptor =
    class
        inherit FunctionMemberDescriptorBase
        interface IOptimizableDescriptor
        interface IWireableDescriptor
    end

The MethodMemberDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | MethodMemberDescriptor | Initializes a new instance of the MethodMemberDescriptor class.
Top
Properties
 | Name | Description
Public property | AccessMode | Gets the access mode used for interop
Public property | ExtensionMethodType | Gets the type which this extension method extends, null if this is not an extension method. (Inherited from FunctionMemberDescriptorBase.)
Public property | IsConstructor | Gets a value indicating whether the described method is a constructor
Public property | IsStatic | Gets a value indicating whether the described method is static. (Inherited from FunctionMemberDescriptorBase.)
Public property | MemberAccess | Gets the types of access supported by this member (Inherited from FunctionMemberDescriptorBase.)
Public property | MethodInfo | Gets the method information (can be a MethodInfo or ConstructorInfo)
Public property | Name | Gets the name of the described method (Inherited from FunctionMemberDescriptorBase.)
Public property | Parameters | Gets the type of the arguments of the underlying CLR function (Inherited from FunctionMemberDescriptorBase.)
Public property | SortDiscriminant | Gets a sort discriminant to give consistent overload resolution matching in case of perfectly equal scores (Inherited from FunctionMemberDescriptorBase.)
Public property | VarArgsArrayType | Gets a value indicating the type of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned. (Inherited from FunctionMemberDescriptorBase.)
Public property | VarArgsElementType | Gets a value indicating the type of the elements of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned. (Inherited from FunctionMemberDescriptorBase.)
Top
Methods
 | Name | Description
Protected method | BuildArgumentList | Builds the argument list. (Inherited from FunctionMemberDescriptorBase.)
 | CheckMethodIsCompatible | Checks if the method is compatible with a standard descriptor
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | The internal callback which actually executes the method (Overrides FunctionMemberDescriptorBaseExecute(Script, Object, ScriptExecutionContext, CallbackArguments).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCallback | Gets a callback function as a delegate (Inherited from FunctionMemberDescriptorBase.)
Public method | GetCallbackAsDynValue | Gets the callback function as a DynValue. (Inherited from FunctionMemberDescriptorBase.)
Public method | GetCallbackFunction | Gets the callback function. (Inherited from FunctionMemberDescriptorBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts. (Inherited from FunctionMemberDescriptorBase.)
Protected method | Initialize | Initializes this instance. This *MUST* be called by the constructors extending this class to complete initialization. (Inherited from FunctionMemberDescriptorBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForWiring | Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.
Public method | SetValue | Sets the value. (Inherited from FunctionMemberDescriptorBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryCreateIfVisible | Tries to create a new MethodMemberDescriptor, returning null in case the method is not visible to script code.
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


MethodMemberDescriptor Constructor

MethodMemberDescriptor Constructor
Initializes a new instance of the MethodMemberDescriptor class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MethodMemberDescriptor(
    MethodBase methodBase,
    InteropAccessMode accessMode = InteropAccessMode.Default
)
Public Sub New (
    methodBase As MethodBase,
    Optional accessMode As InteropAccessMode = InteropAccessMode.Default
)
public:
MethodMemberDescriptor(
    MethodBase^ methodBase,
    InteropAccessMode accessMode = InteropAccessMode::Default
)
new :
        methodBase : MethodBase *
        ?accessMode : InteropAccessMode
(* Defaults:
        let _accessMode = defaultArg accessMode InteropAccessMode.Default
*)
-> MethodMemberDescriptor

Parameters

methodBase
Type: System.ReflectionMethodBase
The MethodBase (MethodInfo or ConstructorInfo) got through reflection.
accessMode (Optional)
Type: MoonSharp.InterpreterInteropAccessMode
The interop access mode.
Exceptions
Exception | Condition
ArgumentException | Invalid accessMode
See Also

Reference

MethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


MethodMemberDescriptor Properties

MethodMemberDescriptor Properties

The MethodMemberDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | AccessMode | Gets the access mode used for interop
Public property | ExtensionMethodType | Gets the type which this extension method extends, null if this is not an extension method. (Inherited from FunctionMemberDescriptorBase.)
Public property | IsConstructor | Gets a value indicating whether the described method is a constructor
Public property | IsStatic | Gets a value indicating whether the described method is static. (Inherited from FunctionMemberDescriptorBase.)
Public property | MemberAccess | Gets the types of access supported by this member (Inherited from FunctionMemberDescriptorBase.)
Public property | MethodInfo | Gets the method information (can be a MethodInfo or ConstructorInfo)
Public property | Name | Gets the name of the described method (Inherited from FunctionMemberDescriptorBase.)
Public property | Parameters | Gets the type of the arguments of the underlying CLR function (Inherited from FunctionMemberDescriptorBase.)
Public property | SortDiscriminant | Gets a sort discriminant to give consistent overload resolution matching in case of perfectly equal scores (Inherited from FunctionMemberDescriptorBase.)
Public property | VarArgsArrayType | Gets a value indicating the type of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned. (Inherited from FunctionMemberDescriptorBase.)
Public property | VarArgsElementType | Gets a value indicating the type of the elements of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned. (Inherited from FunctionMemberDescriptorBase.)
Top
See Also

Reference

MethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


MethodMemberDescriptor.AccessMode Property

MethodMemberDescriptorAccessMode Property
Gets the access mode used for interop

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public InteropAccessMode AccessMode { get; }
Public ReadOnly Property AccessMode As InteropAccessMode
    Get
public:
property InteropAccessMode AccessMode {
    InteropAccessMode get ();
}
member AccessMode : InteropAccessMode with get

Property Value

Type: InteropAccessMode
See Also

Reference

MethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


MethodMemberDescriptor.IsConstructor Property

MethodMemberDescriptorIsConstructor Property
Gets a value indicating whether the described method is a constructor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsConstructor { get; }
Public ReadOnly Property IsConstructor As Boolean
    Get
public:
property bool IsConstructor {
    bool get ();
}
member IsConstructor : bool with get

Property Value

Type: Boolean
See Also

Reference

MethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


MethodMemberDescriptor.MethodInfo Property

MethodMemberDescriptorMethodInfo Property
Gets the method information (can be a MethodInfo or ConstructorInfo)

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MethodBase MethodInfo { get; }
Public ReadOnly Property MethodInfo As MethodBase
    Get
public:
property MethodBase^ MethodInfo {
    MethodBase^ get ();
}
member MethodInfo : MethodBase with get

Property Value

Type: MethodBase
See Also

Reference

MethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


MethodMemberDescriptor Methods

MethodMemberDescriptor Methods

The MethodMemberDescriptor type exposes the following members.

Methods
 | Name | Description
Protected method | BuildArgumentList | Builds the argument list. (Inherited from FunctionMemberDescriptorBase.)
 | CheckMethodIsCompatible | Checks if the method is compatible with a standard descriptor
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | The internal callback which actually executes the method (Overrides FunctionMemberDescriptorBaseExecute(Script, Object, ScriptExecutionContext, CallbackArguments).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCallback | Gets a callback function as a delegate (Inherited from FunctionMemberDescriptorBase.)
Public method | GetCallbackAsDynValue | Gets the callback function as a DynValue. (Inherited from FunctionMemberDescriptorBase.)
Public method | GetCallbackFunction | Gets the callback function. (Inherited from FunctionMemberDescriptorBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts. (Inherited from FunctionMemberDescriptorBase.)
Protected method | Initialize | Initializes this instance. This *MUST* be called by the constructors extending this class to complete initialization. (Inherited from FunctionMemberDescriptorBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForWiring | Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.
Public method | SetValue | Sets the value. (Inherited from FunctionMemberDescriptorBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryCreateIfVisible | Tries to create a new MethodMemberDescriptor, returning null in case the method is not visible to script code.
Top
See Also

Reference

MethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


MethodMemberDescriptor.CheckMethodIsCompatible Method

MethodMemberDescriptorCheckMethodIsCompatible Method
Checks if the method is compatible with a standard descriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckMethodIsCompatible(
    MethodBase methodBase,
    bool throwException
)
Public Shared Function CheckMethodIsCompatible (
    methodBase As MethodBase,
    throwException As Boolean
) As Boolean
public:
static bool CheckMethodIsCompatible(
    MethodBase^ methodBase,
    bool throwException
)
static member CheckMethodIsCompatible :
        methodBase : MethodBase *
        throwException : bool -> bool

Parameters

methodBase
Type: System.ReflectionMethodBase
The MethodBase.
throwException
Type: SystemBoolean
if set to true an exception with the proper error message is thrown if not compatible.

Return Value

Type: Boolean
Exceptions
Exception | Condition
ArgumentException | Thrown if throwException is true and one of this applies: The method contains unresolved generic parameters, or has an unresolved generic return type or The method contains pointer parameters, or has a pointer return type
See Also

Reference

MethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


MethodMemberDescriptor.Execute Method

MethodMemberDescriptorExecute Method
The internal callback which actually executes the method

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override DynValue Execute(
    Script script,
    Object obj,
    ScriptExecutionContext context,
    CallbackArguments args
)
Public Overrides Function Execute (
    script As Script,
    obj As Object,
    context As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
virtual DynValue^ Execute(
    Script^ script,
    Object^ obj,
    ScriptExecutionContext^ context,
    CallbackArguments^ args
) override
abstract Execute :
        script : Script *
        obj : Object *
        context : ScriptExecutionContext *
        args : CallbackArguments -> DynValue
override Execute :
        script : Script *
        obj : Object *
        context : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object.
context
Type: MoonSharp.InterpreterScriptExecutionContext
The context.
args
Type: MoonSharp.InterpreterCallbackArguments
The arguments.

Return Value

Type: DynValue

Implements

IOverloadableMemberDescriptorExecute(Script, Object, ScriptExecutionContext, CallbackArguments)
See Also

Reference

MethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


MethodMemberDescriptor.PrepareForWiring Method

MethodMemberDescriptorPrepareForWiring Method
Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void PrepareForWiring(
    Table t
)
Public Sub PrepareForWiring (
    t As Table
)
public:
virtual void PrepareForWiring(
    Table^ t
) sealed
abstract PrepareForWiring :
        t : Table -> unit
override PrepareForWiring :
        t : Table -> unit

Parameters

t
Type: MoonSharp.InterpreterTable
The table to be filled

Implements

IWireableDescriptorPrepareForWiring(Table)
See Also

Reference

MethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


MethodMemberDescriptor.TryCreateIfVisible Method

MethodMemberDescriptorTryCreateIfVisible Method
Tries to create a new MethodMemberDescriptor, returning null in case the method is not visible to script code.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static MethodMemberDescriptor TryCreateIfVisible(
    MethodBase methodBase,
    InteropAccessMode accessMode,
    bool forceVisibility = false
)
Public Shared Function TryCreateIfVisible (
    methodBase As MethodBase,
    accessMode As InteropAccessMode,
    Optional forceVisibility As Boolean = false
) As MethodMemberDescriptor
public:
static MethodMemberDescriptor^ TryCreateIfVisible(
    MethodBase^ methodBase,
    InteropAccessMode accessMode,
    bool forceVisibility = false
)
static member TryCreateIfVisible :
        methodBase : MethodBase *
        accessMode : InteropAccessMode *
        ?forceVisibility : bool
(* Defaults:
        let _forceVisibility = defaultArg forceVisibility false
*)
-> MethodMemberDescriptor

Parameters

methodBase
Type: System.ReflectionMethodBase
The MethodBase.
accessMode
Type: MoonSharp.InterpreterInteropAccessMode
The InteropAccessMode
forceVisibility (Optional)
Type: SystemBoolean
if set to true forces visibility.

Return Value

Type: MethodMemberDescriptor
A new MethodMemberDescriptor or null.
See Also

Reference

MethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


MoonSharpVisibleAttribute Class

MoonSharpVisibleAttribute Class
Forces a class member visibility to scripts. Can be used to hide public members or to expose non-public ones.
Inheritance Hierarchy
SystemObject
SystemAttribute
MoonSharp.Interpreter.InteropMoonSharpVisibleAttribute

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MoonSharpVisibleAttribute : Attribute
Public NotInheritable Class MoonSharpVisibleAttribute
    Inherits Attribute
public ref class MoonSharpVisibleAttribute sealed : public Attribute
[<SealedAttribute>]
type MoonSharpVisibleAttribute =
    class
        inherit Attribute
    end

The MoonSharpVisibleAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | MoonSharpVisibleAttribute | Initializes a new instance of the MoonSharpVisibleAttribute class.
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Visible | Gets a value indicating whether this MoonSharpVisibleAttribute is set to "visible".
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


MoonSharpVisibleAttribute Constructor

MoonSharpVisibleAttribute Constructor
Initializes a new instance of the MoonSharpVisibleAttribute class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MoonSharpVisibleAttribute(
    bool visible
)
Public Sub New (
    visible As Boolean
)
public:
MoonSharpVisibleAttribute(
    bool visible
)
new :
        visible : bool -> MoonSharpVisibleAttribute

Parameters

visible
Type: SystemBoolean
if set to true the member will be exposed to scripts, if false the member will be hidden.
See Also

Reference

MoonSharpVisibleAttribute Class
MoonSharp.Interpreter.Interop Namespace


MoonSharpVisibleAttribute Properties

MoonSharpVisibleAttribute Properties

The MoonSharpVisibleAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Visible | Gets a value indicating whether this MoonSharpVisibleAttribute is set to "visible".
Top
See Also

Reference

MoonSharpVisibleAttribute Class
MoonSharp.Interpreter.Interop Namespace


MoonSharpVisibleAttribute.Visible Property

MoonSharpVisibleAttributeVisible Property
Gets a value indicating whether this MoonSharpVisibleAttribute is set to "visible".

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool Visible { get; }
Public ReadOnly Property Visible As Boolean
    Get
public:
property bool Visible {
    bool get ();
}
member Visible : bool with get

Property Value

Type: Boolean
See Also

Reference

MoonSharpVisibleAttribute Class
MoonSharp.Interpreter.Interop Namespace


MoonSharpVisibleAttribute Methods

MoonSharpVisibleAttribute Methods

The MoonSharpVisibleAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharpVisibleAttribute Class
MoonSharp.Interpreter.Interop Namespace


ObjectCallbackMemberDescriptor Class

ObjectCallbackMemberDescriptor Class
Member descriptor which allows to define new members which behave similarly to class instance members
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropFunctionMemberDescriptorBase
MoonSharp.Interpreter.InteropObjectCallbackMemberDescriptor
MoonSharp.Interpreter.InteropArrayMemberDescriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class ObjectCallbackMemberDescriptor : FunctionMemberDescriptorBase
Public Class ObjectCallbackMemberDescriptor
    Inherits FunctionMemberDescriptorBase
public ref class ObjectCallbackMemberDescriptor : public FunctionMemberDescriptorBase
type ObjectCallbackMemberDescriptor =
    class
        inherit FunctionMemberDescriptorBase
    end

The ObjectCallbackMemberDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectCallbackMemberDescriptor(String) | Initializes a new instance of the ObjectCallbackMemberDescriptor class. A new member descriptor is defined, which is a function taking no parameters and returning void, doing nothing.
Public method | ObjectCallbackMemberDescriptor(String, FuncObject, ScriptExecutionContext, CallbackArguments, Object) | Initializes a new instance of the ObjectCallbackMemberDescriptor class. The function described by descriptors created by this callback are defined as if they take no parameters and thus don't support overload resolution well (unless they really take no parameters) but can freely be used if no overload resolution is required.
Public method | ObjectCallbackMemberDescriptor(String, FuncObject, ScriptExecutionContext, CallbackArguments, Object, ParameterDescriptor) | Initializes a new instance of the ObjectCallbackMemberDescriptor class. Members defined with this constructor will support overload resolution.
Top
Properties
 | Name | Description
Public property | ExtensionMethodType | Gets the type which this extension method extends, null if this is not an extension method. (Inherited from FunctionMemberDescriptorBase.)
Public property | IsStatic | Gets a value indicating whether the described method is static. (Inherited from FunctionMemberDescriptorBase.)
Public property | MemberAccess | Gets the types of access supported by this member (Inherited from FunctionMemberDescriptorBase.)
Public property | Name | Gets the name of the described method (Inherited from FunctionMemberDescriptorBase.)
Public property | Parameters | Gets the type of the arguments of the underlying CLR function (Inherited from FunctionMemberDescriptorBase.)
Public property | SortDiscriminant | Gets a sort discriminant to give consistent overload resolution matching in case of perfectly equal scores (Inherited from FunctionMemberDescriptorBase.)
Public property | VarArgsArrayType | Gets a value indicating the type of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned. (Inherited from FunctionMemberDescriptorBase.)
Public property | VarArgsElementType | Gets a value indicating the type of the elements of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned. (Inherited from FunctionMemberDescriptorBase.)
Top
Methods
 | Name | Description
Protected method | BuildArgumentList | Builds the argument list. (Inherited from FunctionMemberDescriptorBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | The internal callback which actually executes the method (Overrides FunctionMemberDescriptorBaseExecute(Script, Object, ScriptExecutionContext, CallbackArguments).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCallback | Gets a callback function as a delegate (Inherited from FunctionMemberDescriptorBase.)
Public method | GetCallbackAsDynValue | Gets the callback function as a DynValue. (Inherited from FunctionMemberDescriptorBase.)
Public method | GetCallbackFunction | Gets the callback function. (Inherited from FunctionMemberDescriptorBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts. (Inherited from FunctionMemberDescriptorBase.)
Protected method | Initialize | Initializes this instance. This *MUST* be called by the constructors extending this class to complete initialization. (Inherited from FunctionMemberDescriptorBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValue | Sets the value. (Inherited from FunctionMemberDescriptorBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


ObjectCallbackMemberDescriptor Constructor

ObjectCallbackMemberDescriptor Constructor
Overload List
 | Name | Description
Public method | ObjectCallbackMemberDescriptor(String) | Initializes a new instance of the ObjectCallbackMemberDescriptor class. A new member descriptor is defined, which is a function taking no parameters and returning void, doing nothing.
Public method | ObjectCallbackMemberDescriptor(String, FuncObject, ScriptExecutionContext, CallbackArguments, Object) | Initializes a new instance of the ObjectCallbackMemberDescriptor class. The function described by descriptors created by this callback are defined as if they take no parameters and thus don't support overload resolution well (unless they really take no parameters) but can freely be used if no overload resolution is required.
Public method | ObjectCallbackMemberDescriptor(String, FuncObject, ScriptExecutionContext, CallbackArguments, Object, ParameterDescriptor) | Initializes a new instance of the ObjectCallbackMemberDescriptor class. Members defined with this constructor will support overload resolution.
Top
See Also

Reference

ObjectCallbackMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ObjectCallbackMemberDescriptor Constructor (String)

ObjectCallbackMemberDescriptor Constructor (String)
Initializes a new instance of the ObjectCallbackMemberDescriptor class. A new member descriptor is defined, which is a function taking no parameters and returning void, doing nothing.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ObjectCallbackMemberDescriptor(
    string funcName
)
Public Sub New (
    funcName As String
)
public:
ObjectCallbackMemberDescriptor(
    String^ funcName
)
new :
        funcName : string -> ObjectCallbackMemberDescriptor

Parameters

funcName
Type: SystemString
Name of the function.
See Also

Reference

ObjectCallbackMemberDescriptor Class
ObjectCallbackMemberDescriptor Overload
MoonSharp.Interpreter.Interop Namespace


ObjectCallbackMemberDescriptor Constructor (String, Func(Object, ScriptExecutionContext, CallbackArguments, Object))

ObjectCallbackMemberDescriptor Constructor (String, FuncObject, ScriptExecutionContext, CallbackArguments, Object)
Initializes a new instance of the ObjectCallbackMemberDescriptor class. The function described by descriptors created by this callback are defined as if they take no parameters and thus don't support overload resolution well (unless they really take no parameters) but can freely be used if no overload resolution is required.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ObjectCallbackMemberDescriptor(
    string funcName,
    Func<Object, ScriptExecutionContext, CallbackArguments, Object> callBack
)
Public Sub New (
    funcName As String,
    callBack As Func(Of Object, ScriptExecutionContext, CallbackArguments, Object)
)
public:
ObjectCallbackMemberDescriptor(
    String^ funcName,
    Func<Object^, ScriptExecutionContext^, CallbackArguments^, Object^>^ callBack
)
new :
        funcName : string *
        callBack : Func<Object, ScriptExecutionContext, CallbackArguments, Object> -> ObjectCallbackMemberDescriptor

Parameters

funcName
Type: SystemString
Name of the function.
callBack
Type: SystemFunc Object, ScriptExecutionContext, CallbackArguments, Object
The callback function.
See Also

Reference

ObjectCallbackMemberDescriptor Class
ObjectCallbackMemberDescriptor Overload
MoonSharp.Interpreter.Interop Namespace


ObjectCallbackMemberDescriptor Constructor (String, Func(Object, ScriptExecutionContext, CallbackArguments, Object), ParameterDescriptor[])

ObjectCallbackMemberDescriptor Constructor (String, FuncObject, ScriptExecutionContext, CallbackArguments, Object, ParameterDescriptor)
Initializes a new instance of the ObjectCallbackMemberDescriptor class. Members defined with this constructor will support overload resolution.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ObjectCallbackMemberDescriptor(
    string funcName,
    Func<Object, ScriptExecutionContext, CallbackArguments, Object> callBack,
    ParameterDescriptor[] parameters
)
Public Sub New (
    funcName As String,
    callBack As Func(Of Object, ScriptExecutionContext, CallbackArguments, Object),
    parameters As ParameterDescriptor()
)
public:
ObjectCallbackMemberDescriptor(
    String^ funcName,
    Func<Object^, ScriptExecutionContext^, CallbackArguments^, Object^>^ callBack,
    array<ParameterDescriptor^>^ parameters
)
new :
        funcName : string *
        callBack : Func<Object, ScriptExecutionContext, CallbackArguments, Object> *
        parameters : ParameterDescriptor[] -> ObjectCallbackMemberDescriptor

Parameters

funcName
Type: SystemString
Name of the function.
callBack
Type: SystemFunc Object, ScriptExecutionContext, CallbackArguments, Object
The call back.
parameters
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsParameterDescriptor
The parameters.
See Also

Reference

ObjectCallbackMemberDescriptor Class
ObjectCallbackMemberDescriptor Overload
MoonSharp.Interpreter.Interop Namespace


ObjectCallbackMemberDescriptor Properties

ObjectCallbackMemberDescriptor Properties

The ObjectCallbackMemberDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionMethodType | Gets the type which this extension method extends, null if this is not an extension method. (Inherited from FunctionMemberDescriptorBase.)
Public property | IsStatic | Gets a value indicating whether the described method is static. (Inherited from FunctionMemberDescriptorBase.)
Public property | MemberAccess | Gets the types of access supported by this member (Inherited from FunctionMemberDescriptorBase.)
Public property | Name | Gets the name of the described method (Inherited from FunctionMemberDescriptorBase.)
Public property | Parameters | Gets the type of the arguments of the underlying CLR function (Inherited from FunctionMemberDescriptorBase.)
Public property | SortDiscriminant | Gets a sort discriminant to give consistent overload resolution matching in case of perfectly equal scores (Inherited from FunctionMemberDescriptorBase.)
Public property | VarArgsArrayType | Gets a value indicating the type of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned. (Inherited from FunctionMemberDescriptorBase.)
Public property | VarArgsElementType | Gets a value indicating the type of the elements of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned. (Inherited from FunctionMemberDescriptorBase.)
Top
See Also

Reference

ObjectCallbackMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ObjectCallbackMemberDescriptor Methods

ObjectCallbackMemberDescriptor Methods

The ObjectCallbackMemberDescriptor type exposes the following members.

Methods
 | Name | Description
Protected method | BuildArgumentList | Builds the argument list. (Inherited from FunctionMemberDescriptorBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | The internal callback which actually executes the method (Overrides FunctionMemberDescriptorBaseExecute(Script, Object, ScriptExecutionContext, CallbackArguments).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCallback | Gets a callback function as a delegate (Inherited from FunctionMemberDescriptorBase.)
Public method | GetCallbackAsDynValue | Gets the callback function as a DynValue. (Inherited from FunctionMemberDescriptorBase.)
Public method | GetCallbackFunction | Gets the callback function. (Inherited from FunctionMemberDescriptorBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts. (Inherited from FunctionMemberDescriptorBase.)
Protected method | Initialize | Initializes this instance. This *MUST* be called by the constructors extending this class to complete initialization. (Inherited from FunctionMemberDescriptorBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValue | Sets the value. (Inherited from FunctionMemberDescriptorBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ObjectCallbackMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ObjectCallbackMemberDescriptor.Execute Method

ObjectCallbackMemberDescriptorExecute Method
The internal callback which actually executes the method

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override DynValue Execute(
    Script script,
    Object obj,
    ScriptExecutionContext context,
    CallbackArguments args
)
Public Overrides Function Execute (
    script As Script,
    obj As Object,
    context As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
virtual DynValue^ Execute(
    Script^ script,
    Object^ obj,
    ScriptExecutionContext^ context,
    CallbackArguments^ args
) override
abstract Execute :
        script : Script *
        obj : Object *
        context : ScriptExecutionContext *
        args : CallbackArguments -> DynValue
override Execute :
        script : Script *
        obj : Object *
        context : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object.
context
Type: MoonSharp.InterpreterScriptExecutionContext
The context.
args
Type: MoonSharp.InterpreterCallbackArguments
The arguments.

Return Value

Type: DynValue

Implements

IOverloadableMemberDescriptorExecute(Script, Object, ScriptExecutionContext, CallbackArguments)
See Also

Reference

ObjectCallbackMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor Class

OverloadedMethodMemberDescriptor Class
Class providing easier marshalling of overloaded CLR functions
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropOverloadedMethodMemberDescriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class OverloadedMethodMemberDescriptor : IOptimizableDescriptor,
    IMemberDescriptor, IWireableDescriptor
Public Class OverloadedMethodMemberDescriptor
    Implements IOptimizableDescriptor, IMemberDescriptor, IWireableDescriptor
public ref class OverloadedMethodMemberDescriptor : IOptimizableDescriptor,
    IMemberDescriptor, IWireableDescriptor
type OverloadedMethodMemberDescriptor =
    class
        interface IOptimizableDescriptor
        interface IMemberDescriptor
        interface IWireableDescriptor
    end

The OverloadedMethodMemberDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | OverloadedMethodMemberDescriptor(String, Type) | Initializes a new instance of the OverloadedMethodMemberDescriptor class.
Public method | OverloadedMethodMemberDescriptor(String, Type, IOverloadableMemberDescriptor) | Initializes a new instance of the OverloadedMethodMemberDescriptor class.
Public method | OverloadedMethodMemberDescriptor(String, Type, IEnumerableIOverloadableMemberDescriptor) | Initializes a new instance of the OverloadedMethodMemberDescriptor class.
Top
Properties
 | Name | Description
Public property | DeclaringType | Gets the name of the first described overload
Public property | IgnoreExtensionMethods | Gets or sets a value indicating whether this instance ignores extension methods.
Public property | IsStatic | Gets a value indicating whether there is at least one static method in the resolution list
Public property | MemberAccess | Gets the types of access supported by this member
Public property | Name | Gets the name of the first described overload
Public property | OverloadCount | Gets the number of overloaded methods contained in this collection
Top
Methods
 | Name | Description
Public method | AddOverload | Adds an overload.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCallback | Gets a callback function as a delegate
Public method | GetCallbackFunction | Gets the callback function.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForWiring | Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.
Public method | SetValue | Sets the value of this member from a DynValue.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor Constructor

OverloadedMethodMemberDescriptor Constructor
Overload List
 | Name | Description
Public method | OverloadedMethodMemberDescriptor(String, Type) | Initializes a new instance of the OverloadedMethodMemberDescriptor class.
Public method | OverloadedMethodMemberDescriptor(String, Type, IOverloadableMemberDescriptor) | Initializes a new instance of the OverloadedMethodMemberDescriptor class.
Public method | OverloadedMethodMemberDescriptor(String, Type, IEnumerableIOverloadableMemberDescriptor) | Initializes a new instance of the OverloadedMethodMemberDescriptor class.
Top
See Also

Reference

OverloadedMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor Constructor (String, Type)

OverloadedMethodMemberDescriptor Constructor (String, Type)
Initializes a new instance of the OverloadedMethodMemberDescriptor class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public OverloadedMethodMemberDescriptor(
    string name,
    Type declaringType
)
Public Sub New (
    name As String,
    declaringType As Type
)
public:
OverloadedMethodMemberDescriptor(
    String^ name,
    Type^ declaringType
)
new :
        name : string *
        declaringType : Type -> OverloadedMethodMemberDescriptor

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:MoonSharp.Interpreter.Interop.OverloadedMethodMemberDescriptor.#ctor(System.String,System.Type)"]

declaringType
Type: SystemType

[Missing <param name="declaringType"/> documentation for "M:MoonSharp.Interpreter.Interop.OverloadedMethodMemberDescriptor.#ctor(System.String,System.Type)"]

See Also

Reference

OverloadedMethodMemberDescriptor Class
OverloadedMethodMemberDescriptor Overload
MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor Constructor (String, Type, IOverloadableMemberDescriptor)

OverloadedMethodMemberDescriptor Constructor (String, Type, IOverloadableMemberDescriptor)
Initializes a new instance of the OverloadedMethodMemberDescriptor class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public OverloadedMethodMemberDescriptor(
    string name,
    Type declaringType,
    IOverloadableMemberDescriptor descriptor
)
Public Sub New (
    name As String,
    declaringType As Type,
    descriptor As IOverloadableMemberDescriptor
)
public:
OverloadedMethodMemberDescriptor(
    String^ name,
    Type^ declaringType,
    IOverloadableMemberDescriptor^ descriptor
)
new :
        name : string *
        declaringType : Type *
        descriptor : IOverloadableMemberDescriptor -> OverloadedMethodMemberDescriptor

Parameters

name
Type: SystemString
The name.
declaringType
Type: SystemType
The declaring type.
descriptor
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsIOverloadableMemberDescriptor
The descriptor of the first overloaded method.
See Also

Reference

OverloadedMethodMemberDescriptor Class
OverloadedMethodMemberDescriptor Overload
MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor Constructor (String, Type, IEnumerable(IOverloadableMemberDescriptor))

OverloadedMethodMemberDescriptor Constructor (String, Type, IEnumerableIOverloadableMemberDescriptor)
Initializes a new instance of the OverloadedMethodMemberDescriptor class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public OverloadedMethodMemberDescriptor(
    string name,
    Type declaringType,
    IEnumerable<IOverloadableMemberDescriptor> descriptors
)
Public Sub New (
    name As String,
    declaringType As Type,
    descriptors As IEnumerable(Of IOverloadableMemberDescriptor)
)
public:
OverloadedMethodMemberDescriptor(
    String^ name,
    Type^ declaringType,
    IEnumerable<IOverloadableMemberDescriptor^>^ descriptors
)
new :
        name : string *
        declaringType : Type *
        descriptors : IEnumerable<IOverloadableMemberDescriptor> -> OverloadedMethodMemberDescriptor

Parameters

name
Type: SystemString
The name.
declaringType
Type: SystemType
The declaring type.
descriptors
Type: System.Collections.GenericIEnumerable IOverloadableMemberDescriptor
The descriptors of the overloaded methods.
See Also

Reference

OverloadedMethodMemberDescriptor Class
OverloadedMethodMemberDescriptor Overload
MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor Properties

OverloadedMethodMemberDescriptor Properties

The OverloadedMethodMemberDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | DeclaringType | Gets the name of the first described overload
Public property | IgnoreExtensionMethods | Gets or sets a value indicating whether this instance ignores extension methods.
Public property | IsStatic | Gets a value indicating whether there is at least one static method in the resolution list
Public property | MemberAccess | Gets the types of access supported by this member
Public property | Name | Gets the name of the first described overload
Public property | OverloadCount | Gets the number of overloaded methods contained in this collection
Top
See Also

Reference

OverloadedMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor.DeclaringType Property

OverloadedMethodMemberDescriptorDeclaringType Property
Gets the name of the first described overload

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Type DeclaringType { get; }
Public ReadOnly Property DeclaringType As Type
    Get
public:
property Type^ DeclaringType {
    Type^ get ();
}
member DeclaringType : Type with get

Property Value

Type: Type
See Also

Reference

OverloadedMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor.IgnoreExtensionMethods Property

OverloadedMethodMemberDescriptorIgnoreExtensionMethods Property
Gets or sets a value indicating whether this instance ignores extension methods.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IgnoreExtensionMethods { get; set; }
Public Property IgnoreExtensionMethods As Boolean
    Get
    Set
public:
property bool IgnoreExtensionMethods {
    bool get ();
    void set (bool value);
}
member IgnoreExtensionMethods : bool with get, set

Property Value

Type: Boolean
See Also

Reference

OverloadedMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor.IsStatic Property

OverloadedMethodMemberDescriptorIsStatic Property
Gets a value indicating whether there is at least one static method in the resolution list

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStatic { get; }
Public ReadOnly Property IsStatic As Boolean
    Get
public:
virtual property bool IsStatic {
    bool get () sealed;
}
abstract IsStatic : bool with get
override IsStatic : bool with get

Property Value

Type: Boolean

Implements

IMemberDescriptorIsStatic
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

OverloadedMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor.MemberAccess Property

OverloadedMethodMemberDescriptorMemberAccess Property
Gets the types of access supported by this member

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MemberDescriptorAccess MemberAccess { get; }
Public ReadOnly Property MemberAccess As MemberDescriptorAccess
    Get
public:
virtual property MemberDescriptorAccess MemberAccess {
    MemberDescriptorAccess get () sealed;
}
abstract MemberAccess : MemberDescriptorAccess with get
override MemberAccess : MemberDescriptorAccess with get

Property Value

Type: MemberDescriptorAccess

Implements

IMemberDescriptorMemberAccess
See Also

Reference

OverloadedMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor.Name Property

OverloadedMethodMemberDescriptorName Property
Gets the name of the first described overload

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IMemberDescriptorName
See Also

Reference

OverloadedMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor.OverloadCount Property

OverloadedMethodMemberDescriptorOverloadCount Property
Gets the number of overloaded methods contained in this collection

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int OverloadCount { get; }
Public ReadOnly Property OverloadCount As Integer
    Get
public:
property int OverloadCount {
    int get ();
}
member OverloadCount : int with get

Property Value

Type: Int32
The overload count.
See Also

Reference

OverloadedMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor Methods

OverloadedMethodMemberDescriptor Methods

The OverloadedMethodMemberDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | AddOverload | Adds an overload.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCallback | Gets a callback function as a delegate
Public method | GetCallbackFunction | Gets the callback function.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForWiring | Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.
Public method | SetValue | Sets the value of this member from a DynValue.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

OverloadedMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor.AddOverload Method

OverloadedMethodMemberDescriptorAddOverload Method
Adds an overload.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void AddOverload(
    IOverloadableMemberDescriptor overload
)
Public Sub AddOverload (
    overload As IOverloadableMemberDescriptor
)
public:
void AddOverload(
    IOverloadableMemberDescriptor^ overload
)
member AddOverload :
        overload : IOverloadableMemberDescriptor -> unit

Parameters

overload
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsIOverloadableMemberDescriptor
The overload.
See Also

Reference

OverloadedMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor.GetCallback Method

OverloadedMethodMemberDescriptorGetCallback Method
Gets a callback function as a delegate

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Func<ScriptExecutionContext, CallbackArguments, DynValue> GetCallback(
    Script script,
    Object obj
)
Public Function GetCallback (
    script As Script,
    obj As Object
) As Func(Of ScriptExecutionContext, CallbackArguments, DynValue)
public:
Func<ScriptExecutionContext^, CallbackArguments^, DynValue^>^ GetCallback(
    Script^ script,
    Object^ obj
)
member GetCallback :
        script : Script *
        obj : Object -> Func<ScriptExecutionContext, CallbackArguments, DynValue>

Parameters

script
Type: MoonSharp.InterpreterScript
The script for which the callback must be generated.
obj
Type: SystemObject
The object (null for static).

Return Value

Type: Func ScriptExecutionContext, CallbackArguments, DynValue
See Also

Reference

OverloadedMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor.GetCallbackFunction Method

OverloadedMethodMemberDescriptorGetCallbackFunction Method
Gets the callback function.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CallbackFunction GetCallbackFunction(
    Script script,
    Object obj = null
)
Public Function GetCallbackFunction (
    script As Script,
    Optional obj As Object = Nothing
) As CallbackFunction
public:
CallbackFunction^ GetCallbackFunction(
    Script^ script,
    Object^ obj = nullptr
)
member GetCallbackFunction :
        script : Script *
        ?obj : Object
(* Defaults:
        let _obj = defaultArg obj null
*)
-> CallbackFunction

Parameters

script
Type: MoonSharp.InterpreterScript
The script for which the callback must be generated.
obj (Optional)
Type: SystemObject
The object (null for static).

Return Value

Type: CallbackFunction
See Also

Reference

OverloadedMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor.GetValue Method

OverloadedMethodMemberDescriptorGetValue Method
Gets the value of this member as a DynValue to be exposed to scripts.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue GetValue(
    Script script,
    Object obj
)
Public Function GetValue (
    script As Script,
    obj As Object
) As DynValue
public:
virtual DynValue^ GetValue(
    Script^ script,
    Object^ obj
) sealed
abstract GetValue :
        script : Script *
        obj : Object -> DynValue
override GetValue :
        script : Script *
        obj : Object -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object owning this member, or null if static.

Return Value

Type: DynValue
The value of this member as a DynValue.

Implements

IMemberDescriptorGetValue(Script, Object)
See Also

Reference

OverloadedMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor.PrepareForWiring Method

OverloadedMethodMemberDescriptorPrepareForWiring Method
Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void PrepareForWiring(
    Table t
)
Public Sub PrepareForWiring (
    t As Table
)
public:
virtual void PrepareForWiring(
    Table^ t
) sealed
abstract PrepareForWiring :
        t : Table -> unit
override PrepareForWiring :
        t : Table -> unit

Parameters

t
Type: MoonSharp.InterpreterTable
The table to be filled

Implements

IWireableDescriptorPrepareForWiring(Table)
See Also

Reference

OverloadedMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


OverloadedMethodMemberDescriptor.SetValue Method

OverloadedMethodMemberDescriptorSetValue Method
Sets the value of this member from a DynValue.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    Script script,
    Object obj,
    DynValue value
)
Public Sub SetValue (
    script As Script,
    obj As Object,
    value As DynValue
)
public:
virtual void SetValue(
    Script^ script,
    Object^ obj,
    DynValue^ value
) sealed
abstract SetValue :
        script : Script *
        obj : Object *
        value : DynValue -> unit
override SetValue :
        script : Script *
        obj : Object *
        value : DynValue -> unit

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object owning this member, or null if static.
value
Type: MoonSharp.InterpreterDynValue
The value to be set.

Implements

IMemberDescriptorSetValue(Script, Object, DynValue)
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

OverloadedMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


PropertyMemberDescriptor Class

PropertyMemberDescriptor Class
Class providing easier marshalling of CLR properties
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropPropertyMemberDescriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class PropertyMemberDescriptor : IMemberDescriptor,
    IOptimizableDescriptor, IWireableDescriptor
Public Class PropertyMemberDescriptor
    Implements IMemberDescriptor, IOptimizableDescriptor, IWireableDescriptor
public ref class PropertyMemberDescriptor : IMemberDescriptor,
    IOptimizableDescriptor, IWireableDescriptor
type PropertyMemberDescriptor =
    class
        interface IMemberDescriptor
        interface IOptimizableDescriptor
        interface IWireableDescriptor
    end

The PropertyMemberDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyMemberDescriptor(PropertyInfo, InteropAccessMode) | Initializes a new instance of the PropertyMemberDescriptor class. NOTE: This constructor gives get/set visibility based exclusively on the CLR visibility of the getter and setter methods.
Public method | PropertyMemberDescriptor(PropertyInfo, InteropAccessMode, MethodInfo, MethodInfo) | Initializes a new instance of the PropertyMemberDescriptor class.
Top
Properties
 | Name | Description
Public property | AccessMode | Gets the InteropAccessMode
Public property | CanRead | Gets a value indicating whether this instance can be read from
Public property | CanWrite | Gets a value indicating whether this instance can be written to.
Public property | IsStatic | Gets a value indicating whether the described property is static.
Public property | MemberAccess | Gets the types of access supported by this member
Public property | Name | Gets the name of the property
Public property | PropertyInfo | Gets the PropertyInfo got by reflection
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of the property
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForWiring | Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.
Public method | SetValue | Sets the value of the property
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryCreateIfVisible | Tries to create a new StandardUserDataPropertyDescriptor, returning null in case the property is not visible to script code.
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


PropertyMemberDescriptor Constructor

PropertyMemberDescriptor Constructor
Overload List
 | Name | Description
Public method | PropertyMemberDescriptor(PropertyInfo, InteropAccessMode) | Initializes a new instance of the PropertyMemberDescriptor class. NOTE: This constructor gives get/set visibility based exclusively on the CLR visibility of the getter and setter methods.
Public method | PropertyMemberDescriptor(PropertyInfo, InteropAccessMode, MethodInfo, MethodInfo) | Initializes a new instance of the PropertyMemberDescriptor class.
Top
See Also

Reference

PropertyMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


PropertyMemberDescriptor Constructor (PropertyInfo, InteropAccessMode)

PropertyMemberDescriptor Constructor (PropertyInfo, InteropAccessMode)
Initializes a new instance of the PropertyMemberDescriptor class. NOTE: This constructor gives get/set visibility based exclusively on the CLR visibility of the getter and setter methods.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public PropertyMemberDescriptor(
    PropertyInfo pi,
    InteropAccessMode accessMode
)
Public Sub New (
    pi As PropertyInfo,
    accessMode As InteropAccessMode
)
public:
PropertyMemberDescriptor(
    PropertyInfo^ pi,
    InteropAccessMode accessMode
)
new :
        pi : PropertyInfo *
        accessMode : InteropAccessMode -> PropertyMemberDescriptor

Parameters

pi
Type: System.ReflectionPropertyInfo
The pi.
accessMode
Type: MoonSharp.InterpreterInteropAccessMode
The access mode.
See Also

Reference

PropertyMemberDescriptor Class
PropertyMemberDescriptor Overload
MoonSharp.Interpreter.Interop Namespace


PropertyMemberDescriptor Constructor (PropertyInfo, InteropAccessMode, MethodInfo, MethodInfo)

PropertyMemberDescriptor Constructor (PropertyInfo, InteropAccessMode, MethodInfo, MethodInfo)
Initializes a new instance of the PropertyMemberDescriptor class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public PropertyMemberDescriptor(
    PropertyInfo pi,
    InteropAccessMode accessMode,
    MethodInfo getter,
    MethodInfo setter
)
Public Sub New (
    pi As PropertyInfo,
    accessMode As InteropAccessMode,
    getter As MethodInfo,
    setter As MethodInfo
)
public:
PropertyMemberDescriptor(
    PropertyInfo^ pi,
    InteropAccessMode accessMode,
    MethodInfo^ getter,
    MethodInfo^ setter
)
new :
        pi : PropertyInfo *
        accessMode : InteropAccessMode *
        getter : MethodInfo *
        setter : MethodInfo -> PropertyMemberDescriptor

Parameters

pi
Type: System.ReflectionPropertyInfo
The PropertyInfo.
accessMode
Type: MoonSharp.InterpreterInteropAccessMode
The InteropAccessMode
getter
Type: System.ReflectionMethodInfo
The getter method. Use null to make the property writeonly.
setter
Type: System.ReflectionMethodInfo
The setter method. Use null to make the property readonly.
See Also

Reference

PropertyMemberDescriptor Class
PropertyMemberDescriptor Overload
MoonSharp.Interpreter.Interop Namespace


PropertyMemberDescriptor Properties

PropertyMemberDescriptor Properties

The PropertyMemberDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | AccessMode | Gets the InteropAccessMode
Public property | CanRead | Gets a value indicating whether this instance can be read from
Public property | CanWrite | Gets a value indicating whether this instance can be written to.
Public property | IsStatic | Gets a value indicating whether the described property is static.
Public property | MemberAccess | Gets the types of access supported by this member
Public property | Name | Gets the name of the property
Public property | PropertyInfo | Gets the PropertyInfo got by reflection
Top
See Also

Reference

PropertyMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


PropertyMemberDescriptor.AccessMode Property

PropertyMemberDescriptorAccessMode Property
Gets the InteropAccessMode

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public InteropAccessMode AccessMode { get; }
Public ReadOnly Property AccessMode As InteropAccessMode
    Get
public:
property InteropAccessMode AccessMode {
    InteropAccessMode get ();
}
member AccessMode : InteropAccessMode with get

Property Value

Type: InteropAccessMode
See Also

Reference

PropertyMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


PropertyMemberDescriptor.CanRead Property

PropertyMemberDescriptorCanRead Property
Gets a value indicating whether this instance can be read from

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanRead { get; }
Public ReadOnly Property CanRead As Boolean
    Get
public:
property bool CanRead {
    bool get ();
}
member CanRead : bool with get

Property Value

Type: Boolean
true if this instance can be read from; otherwise, false.
See Also

Reference

PropertyMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


PropertyMemberDescriptor.CanWrite Property

PropertyMemberDescriptorCanWrite Property
Gets a value indicating whether this instance can be written to.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanWrite { get; }
Public ReadOnly Property CanWrite As Boolean
    Get
public:
property bool CanWrite {
    bool get ();
}
member CanWrite : bool with get

Property Value

Type: Boolean
true if this instance can be written to; otherwise, false.
See Also

Reference

PropertyMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


PropertyMemberDescriptor.IsStatic Property

PropertyMemberDescriptorIsStatic Property
Gets a value indicating whether the described property is static.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStatic { get; }
Public ReadOnly Property IsStatic As Boolean
    Get
public:
virtual property bool IsStatic {
    bool get () sealed;
}
abstract IsStatic : bool with get
override IsStatic : bool with get

Property Value

Type: Boolean

Implements

IMemberDescriptorIsStatic
See Also

Reference

PropertyMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


PropertyMemberDescriptor.MemberAccess Property

PropertyMemberDescriptorMemberAccess Property
Gets the types of access supported by this member

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MemberDescriptorAccess MemberAccess { get; }
Public ReadOnly Property MemberAccess As MemberDescriptorAccess
    Get
public:
virtual property MemberDescriptorAccess MemberAccess {
    MemberDescriptorAccess get () sealed;
}
abstract MemberAccess : MemberDescriptorAccess with get
override MemberAccess : MemberDescriptorAccess with get

Property Value

Type: MemberDescriptorAccess

Implements

IMemberDescriptorMemberAccess
See Also

Reference

PropertyMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


PropertyMemberDescriptor.Name Property

PropertyMemberDescriptorName Property
Gets the name of the property

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IMemberDescriptorName
See Also

Reference

PropertyMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


PropertyMemberDescriptor.PropertyInfo Property

PropertyMemberDescriptorPropertyInfo Property
Gets the PropertyInfo got by reflection

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public PropertyInfo PropertyInfo { get; }
Public ReadOnly Property PropertyInfo As PropertyInfo
    Get
public:
property PropertyInfo^ PropertyInfo {
    PropertyInfo^ get ();
}
member PropertyInfo : PropertyInfo with get

Property Value

Type: PropertyInfo
See Also

Reference

PropertyMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


PropertyMemberDescriptor Methods

PropertyMemberDescriptor Methods

The PropertyMemberDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of the property
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForWiring | Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.
Public method | SetValue | Sets the value of the property
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryCreateIfVisible | Tries to create a new StandardUserDataPropertyDescriptor, returning null in case the property is not visible to script code.
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

PropertyMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


PropertyMemberDescriptor.GetValue Method

PropertyMemberDescriptorGetValue Method
Gets the value of the property

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue GetValue(
    Script script,
    Object obj
)
Public Function GetValue (
    script As Script,
    obj As Object
) As DynValue
public:
virtual DynValue^ GetValue(
    Script^ script,
    Object^ obj
) sealed
abstract GetValue :
        script : Script *
        obj : Object -> DynValue
override GetValue :
        script : Script *
        obj : Object -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object.

Return Value

Type: DynValue

Implements

IMemberDescriptorGetValue(Script, Object)
See Also

Reference

PropertyMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


PropertyMemberDescriptor.PrepareForWiring Method

PropertyMemberDescriptorPrepareForWiring Method
Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void PrepareForWiring(
    Table t
)
Public Sub PrepareForWiring (
    t As Table
)
public:
virtual void PrepareForWiring(
    Table^ t
) sealed
abstract PrepareForWiring :
        t : Table -> unit
override PrepareForWiring :
        t : Table -> unit

Parameters

t
Type: MoonSharp.InterpreterTable
The table to be filled

Implements

IWireableDescriptorPrepareForWiring(Table)
See Also

Reference

PropertyMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


PropertyMemberDescriptor.SetValue Method

PropertyMemberDescriptorSetValue Method
Sets the value of the property

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    Script script,
    Object obj,
    DynValue v
)
Public Sub SetValue (
    script As Script,
    obj As Object,
    v As DynValue
)
public:
virtual void SetValue(
    Script^ script,
    Object^ obj,
    DynValue^ v
) sealed
abstract SetValue :
        script : Script *
        obj : Object *
        v : DynValue -> unit
override SetValue :
        script : Script *
        obj : Object *
        v : DynValue -> unit

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object.
v
Type: MoonSharp.InterpreterDynValue
The value to set.

Implements

IMemberDescriptorSetValue(Script, Object, DynValue)
See Also

Reference

PropertyMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


PropertyMemberDescriptor.TryCreateIfVisible Method

PropertyMemberDescriptorTryCreateIfVisible Method
Tries to create a new StandardUserDataPropertyDescriptor, returning null in case the property is not visible to script code.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static PropertyMemberDescriptor TryCreateIfVisible(
    PropertyInfo pi,
    InteropAccessMode accessMode
)
Public Shared Function TryCreateIfVisible (
    pi As PropertyInfo,
    accessMode As InteropAccessMode
) As PropertyMemberDescriptor
public:
static PropertyMemberDescriptor^ TryCreateIfVisible(
    PropertyInfo^ pi,
    InteropAccessMode accessMode
)
static member TryCreateIfVisible :
        pi : PropertyInfo *
        accessMode : InteropAccessMode -> PropertyMemberDescriptor

Parameters

pi
Type: System.ReflectionPropertyInfo
The PropertyInfo.
accessMode
Type: MoonSharp.InterpreterInteropAccessMode
The InteropAccessMode

Return Value

Type: PropertyMemberDescriptor
A new StandardUserDataPropertyDescriptor or null.
See Also

Reference

PropertyMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


PropertyTableAssigner Class

PropertyTableAssigner Class
Utility class which may be used to set properties on an object from values contained in a Lua table. Properties must be decorated with the MoonSharpPropertyAttribute. See PropertyTableAssignerT for a generic compile time type-safe version.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropPropertyTableAssigner

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class PropertyTableAssigner : IPropertyTableAssigner
Public Class PropertyTableAssigner
    Implements IPropertyTableAssigner
public ref class PropertyTableAssigner : IPropertyTableAssigner
type PropertyTableAssigner =
    class
        interface IPropertyTableAssigner
    end

The PropertyTableAssigner type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyTableAssigner | Initializes a new instance of the PropertyTableAssigner class.
Top
Methods
 | Name | Description
Public method | AddExpectedMissingProperty | Adds an expected missing property, that is an expected field in the table with no corresponding property in the object.
Public method | AssignObject | Assigns properties from tables to an object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetSubassignerForType | Sets the subassigner for the given type. Pass null to remove usage of subassigner for the given type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


PropertyTableAssigner Constructor

PropertyTableAssigner Constructor
Initializes a new instance of the PropertyTableAssigner class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public PropertyTableAssigner(
    Type type,
    params string[] expectedMissingProperties
)
Public Sub New (
    type As Type,
    ParamArray expectedMissingProperties As String()
)
public:
PropertyTableAssigner(
    Type^ type,
    ... array<String^>^ expectedMissingProperties
)
new :
        type : Type *
        expectedMissingProperties : string[] -> PropertyTableAssigner

Parameters

type
Type: SystemType
The type of the object.
expectedMissingProperties
Type: SystemString
The expected missing properties, that is expected fields in the table with no corresponding property in the object.
Exceptions
Exception | Condition
ArgumentException | Type cannot be a value type.
See Also

Reference

PropertyTableAssigner Class
MoonSharp.Interpreter.Interop Namespace


PropertyTableAssigner Methods

PropertyTableAssigner Methods

The PropertyTableAssigner type exposes the following members.

Methods
 | Name | Description
Public method | AddExpectedMissingProperty | Adds an expected missing property, that is an expected field in the table with no corresponding property in the object.
Public method | AssignObject | Assigns properties from tables to an object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetSubassignerForType | Sets the subassigner for the given type. Pass null to remove usage of subassigner for the given type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertyTableAssigner Class
MoonSharp.Interpreter.Interop Namespace


PropertyTableAssigner.AddExpectedMissingProperty Method

PropertyTableAssignerAddExpectedMissingProperty Method
Adds an expected missing property, that is an expected field in the table with no corresponding property in the object.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void AddExpectedMissingProperty(
    string name
)
Public Sub AddExpectedMissingProperty (
    name As String
)
public:
void AddExpectedMissingProperty(
    String^ name
)
member AddExpectedMissingProperty :
        name : string -> unit

Parameters

name
Type: SystemString
The name.
See Also

Reference

PropertyTableAssigner Class
MoonSharp.Interpreter.Interop Namespace


PropertyTableAssigner.AssignObject Method

PropertyTableAssignerAssignObject Method
Assigns properties from tables to an object.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void AssignObject(
    Object obj,
    Table data
)
Public Sub AssignObject (
    obj As Object,
    data As Table
)
public:
void AssignObject(
    Object^ obj,
    Table^ data
)
member AssignObject :
        obj : Object *
        data : Table -> unit

Parameters

obj
Type: SystemObject
The object.
data
Type: MoonSharp.InterpreterTable
The table.
Exceptions
Exception | Condition
ArgumentNullException | Object is null
ArgumentException | The object is of an incompatible type.
ScriptRuntimeException | A field does not correspond to any property and that property is not one of the expected missing ones.
See Also

Reference

PropertyTableAssigner Class
MoonSharp.Interpreter.Interop Namespace


PropertyTableAssigner.SetSubassignerForType Method

PropertyTableAssignerSetSubassignerForType Method
Sets the subassigner for the given type. Pass null to remove usage of subassigner for the given type.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSubassignerForType(
    Type propertyType,
    IPropertyTableAssigner assigner
)
Public Sub SetSubassignerForType (
    propertyType As Type,
    assigner As IPropertyTableAssigner
)
public:
void SetSubassignerForType(
    Type^ propertyType,
    IPropertyTableAssigner^ assigner
)
member SetSubassignerForType :
        propertyType : Type *
        assigner : IPropertyTableAssigner -> unit

Parameters

propertyType
Type: SystemType
Type of the property for which the subassigner will be used.
assigner
Type: MoonSharp.Interpreter.InteropIPropertyTableAssigner
The property assigner.
See Also

Reference

PropertyTableAssigner Class
MoonSharp.Interpreter.Interop Namespace


PropertyTableAssigner(T) Class

PropertyTableAssignerT Class
Utility class which may be used to set properties on an object of type T, from values contained in a Lua table. Properties must be decorated with the MoonSharpPropertyAttribute. This is a generic version of PropertyTableAssigner.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropPropertyTableAssignerT

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class PropertyTableAssigner<T> : IPropertyTableAssigner

Public Class PropertyTableAssigner(Of T)
    Implements IPropertyTableAssigner
generic<typename T>
public ref class PropertyTableAssigner : IPropertyTableAssigner
type PropertyTableAssigner<'T> =
    class
        interface IPropertyTableAssigner
    end

Type Parameters

T
The type of the object.

The PropertyTableAssignerT type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyTableAssignerT | Initializes a new instance of the PropertyTableAssignerT class.
Top
Methods
 | Name | Description
Public method | AddExpectedMissingProperty | Adds an expected missing property, that is an expected field in the table with no corresponding property in the object.
Public method | AssignObject | Assigns properties from tables to an object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeUnsafeAssigner | Gets the type-unsafe assigner corresponding to this object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetSubassignerSubassignerType | Sets the subassigner for the given type
Public method | SetSubassignerForType | Sets the subassigner for the given type. Pass null to remove usage of subassigner for the given type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


PropertyTableAssigner(T) Constructor

PropertyTableAssignerT Constructor
Initializes a new instance of the PropertyTableAssignerT class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public PropertyTableAssigner(
    params string[] expectedMissingProperties
)
Public Sub New (
    ParamArray expectedMissingProperties As String()
)
public:
PropertyTableAssigner(
    ... array<String^>^ expectedMissingProperties
)
new :
        expectedMissingProperties : string[] -> PropertyTableAssigner

Parameters

expectedMissingProperties
Type: SystemString
The expected missing properties, that is expected fields in the table with no corresponding property in the object.
See Also

Reference

PropertyTableAssignerT Class
MoonSharp.Interpreter.Interop Namespace


PropertyTableAssigner(T) Methods

PropertyTableAssignerT Methods

The PropertyTableAssignerT generic type exposes the following members.

Methods
 | Name | Description
Public method | AddExpectedMissingProperty | Adds an expected missing property, that is an expected field in the table with no corresponding property in the object.
Public method | AssignObject | Assigns properties from tables to an object.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeUnsafeAssigner | Gets the type-unsafe assigner corresponding to this object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetSubassignerSubassignerType | Sets the subassigner for the given type
Public method | SetSubassignerForType | Sets the subassigner for the given type. Pass null to remove usage of subassigner for the given type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertyTableAssignerT Class
MoonSharp.Interpreter.Interop Namespace


PropertyTableAssigner(T).AddExpectedMissingProperty Method

PropertyTableAssignerTAddExpectedMissingProperty Method
Adds an expected missing property, that is an expected field in the table with no corresponding property in the object.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void AddExpectedMissingProperty(
    string name
)
Public Sub AddExpectedMissingProperty (
    name As String
)
public:
void AddExpectedMissingProperty(
    String^ name
)
member AddExpectedMissingProperty :
        name : string -> unit

Parameters

name
Type: SystemString
The name.
See Also

Reference

PropertyTableAssignerT Class
MoonSharp.Interpreter.Interop Namespace


PropertyTableAssigner(T).AssignObject Method

PropertyTableAssignerTAssignObject Method
Assigns properties from tables to an object.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void AssignObject(
    T obj,
    Table data
)
Public Sub AssignObject (
    obj As T,
    data As Table
)
public:
void AssignObject(
    T obj,
    Table^ data
)
member AssignObject :
        obj : 'T *
        data : Table -> unit

Parameters

obj
Type: T
The object.
data
Type: MoonSharp.InterpreterTable
The table.
Exceptions
Exception | Condition
ArgumentNullException | Object is null
ScriptRuntimeException | A field does not correspond to any property and that property is not one of the expected missing ones.
See Also

Reference

PropertyTableAssignerT Class
MoonSharp.Interpreter.Interop Namespace


PropertyTableAssigner(T).GetTypeUnsafeAssigner Method

PropertyTableAssignerTGetTypeUnsafeAssigner Method
Gets the type-unsafe assigner corresponding to this object.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public PropertyTableAssigner GetTypeUnsafeAssigner()
Public Function GetTypeUnsafeAssigner As PropertyTableAssigner
public:
PropertyTableAssigner^ GetTypeUnsafeAssigner()
member GetTypeUnsafeAssigner : unit -> PropertyTableAssigner

Return Value

Type: PropertyTableAssigner
See Also

Reference

PropertyTableAssignerT Class
MoonSharp.Interpreter.Interop Namespace


PropertyTableAssigner(T).SetSubassigner(SubassignerType) Method

PropertyTableAssignerTSetSubassignerSubassignerType Method
Sets the subassigner for the given type

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSubassigner<SubassignerType>(
    PropertyTableAssigner<SubassignerType> assigner
)

Public Sub SetSubassigner(Of SubassignerType) (
    assigner As PropertyTableAssigner(Of SubassignerType)
)
public:
generic<typename SubassignerType>
void SetSubassigner(
    PropertyTableAssigner<SubassignerType>^ assigner
)
member SetSubassigner :
        assigner : PropertyTableAssigner<'SubassignerType> -> unit

Parameters

assigner
Type: MoonSharp.Interpreter.InteropPropertyTableAssigner SubassignerType
The property assigner.

Type Parameters

SubassignerType
Type of the property for which the subassigner will be used.
See Also

Reference

PropertyTableAssignerT Class
MoonSharp.Interpreter.Interop Namespace


PropertyTableAssigner(T).SetSubassignerForType Method

PropertyTableAssignerTSetSubassignerForType Method
Sets the subassigner for the given type. Pass null to remove usage of subassigner for the given type.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void SetSubassignerForType(
    Type propertyType,
    IPropertyTableAssigner assigner
)
Public Sub SetSubassignerForType (
    propertyType As Type,
    assigner As IPropertyTableAssigner
)
public:
void SetSubassignerForType(
    Type^ propertyType,
    IPropertyTableAssigner^ assigner
)
member SetSubassignerForType :
        propertyType : Type *
        assigner : IPropertyTableAssigner -> unit

Parameters

propertyType
Type: SystemType
Type of the property for which the subassigner will be used.
assigner
Type: MoonSharp.Interpreter.InteropIPropertyTableAssigner
The property assigner.
See Also

Reference

PropertyTableAssignerT Class
MoonSharp.Interpreter.Interop Namespace


ProxyUserDataDescriptor Class

ProxyUserDataDescriptor Class
Data descriptor used for proxy objects
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropProxyUserDataDescriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ProxyUserDataDescriptor : IUserDataDescriptor
Public NotInheritable Class ProxyUserDataDescriptor
    Implements IUserDataDescriptor
public ref class ProxyUserDataDescriptor sealed : IUserDataDescriptor
[<SealedAttribute>]
type ProxyUserDataDescriptor =
    class
        interface IUserDataDescriptor
    end

The ProxyUserDataDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | InnerDescriptor | Gets the descriptor which describes the proxy object
Public property | Name | Gets the name of the descriptor (usually, the name of the type described).
Public property | Type | Gets the type this descriptor refers to
Top
Methods
 | Name | Description
Public method | AsString | Converts this userdata to string
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Index | Performs an "index" "get" operation.
Public method | IsTypeCompatible | Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "
Public method | MetaIndex | Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). These standard metamethods can be supported (the return value should be a function accepting the classic parameters of the corresponding metamethod): __add, __sub, __mul, __div, __div, __pow, __unm, __eq, __lt, __le, __lt, __len, __concat, __pairs, __ipairs, __iterator, __call These standard metamethods are supported through other calls for efficiency: __index, __newindex, __tostring
Public method | SetIndex | Performs an "index" "set" operation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


ProxyUserDataDescriptor Properties

ProxyUserDataDescriptor Properties

The ProxyUserDataDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | InnerDescriptor | Gets the descriptor which describes the proxy object
Public property | Name | Gets the name of the descriptor (usually, the name of the type described).
Public property | Type | Gets the type this descriptor refers to
Top
See Also

Reference

ProxyUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ProxyUserDataDescriptor.InnerDescriptor Property

ProxyUserDataDescriptorInnerDescriptor Property
Gets the descriptor which describes the proxy object

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IUserDataDescriptor InnerDescriptor { get; }
Public ReadOnly Property InnerDescriptor As IUserDataDescriptor
    Get
public:
property IUserDataDescriptor^ InnerDescriptor {
    IUserDataDescriptor^ get ();
}
member InnerDescriptor : IUserDataDescriptor with get

Property Value

Type: IUserDataDescriptor
See Also

Reference

ProxyUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ProxyUserDataDescriptor.Name Property

ProxyUserDataDescriptorName Property
Gets the name of the descriptor (usually, the name of the type described).

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IUserDataDescriptorName
See Also

Reference

ProxyUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ProxyUserDataDescriptor.Type Property

ProxyUserDataDescriptorType Property
Gets the type this descriptor refers to

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Type Type { get; }
Public ReadOnly Property Type As Type
    Get
public:
virtual property Type^ Type {
    Type^ get () sealed;
}
abstract Type : Type with get
override Type : Type with get

Property Value

Type: Type

Implements

IUserDataDescriptorType
See Also

Reference

ProxyUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ProxyUserDataDescriptor Methods

ProxyUserDataDescriptor Methods

The ProxyUserDataDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | AsString | Converts this userdata to string
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Index | Performs an "index" "get" operation.
Public method | IsTypeCompatible | Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "
Public method | MetaIndex | Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). These standard metamethods can be supported (the return value should be a function accepting the classic parameters of the corresponding metamethod): __add, __sub, __mul, __div, __div, __pow, __unm, __eq, __lt, __le, __lt, __len, __concat, __pairs, __ipairs, __iterator, __call These standard metamethods are supported through other calls for efficiency: __index, __newindex, __tostring
Public method | SetIndex | Performs an "index" "set" operation.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProxyUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ProxyUserDataDescriptor.AsString Method

ProxyUserDataDescriptorAsString Method
Converts this userdata to string

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string AsString(
    Object obj
)
Public Function AsString (
    obj As Object
) As String
public:
virtual String^ AsString(
    Object^ obj
) sealed
abstract AsString :
        obj : Object -> string
override AsString :
        obj : Object -> string

Parameters

obj
Type: SystemObject
The object.

Return Value

Type: String

Implements

IUserDataDescriptorAsString(Object)
See Also

Reference

ProxyUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ProxyUserDataDescriptor.Index Method

ProxyUserDataDescriptorIndex Method
Performs an "index" "get" operation.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Index(
    Script script,
    Object obj,
    DynValue index,
    bool isDirectIndexing
)
Public Function Index (
    script As Script,
    obj As Object,
    index As DynValue,
    isDirectIndexing As Boolean
) As DynValue
public:
virtual DynValue^ Index(
    Script^ script,
    Object^ obj,
    DynValue^ index,
    bool isDirectIndexing
) sealed
abstract Index :
        script : Script *
        obj : Object *
        index : DynValue *
        isDirectIndexing : bool -> DynValue
override Index :
        script : Script *
        obj : Object *
        index : DynValue *
        isDirectIndexing : bool -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script originating the request
obj
Type: SystemObject
The object (null if a static request is done)
index
Type: MoonSharp.InterpreterDynValue
The index.
isDirectIndexing
Type: SystemBoolean
If set to true, it's indexed with a name, if false it's indexed through brackets.

Return Value

Type: DynValue

Implements

IUserDataDescriptorIndex(Script, Object, DynValue, Boolean)
See Also

Reference

ProxyUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ProxyUserDataDescriptor.IsTypeCompatible Method

ProxyUserDataDescriptorIsTypeCompatible Method
Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTypeCompatible(
    Type type,
    Object obj
)
Public Function IsTypeCompatible (
    type As Type,
    obj As Object
) As Boolean
public:
virtual bool IsTypeCompatible(
    Type^ type,
    Object^ obj
) sealed
abstract IsTypeCompatible :
        type : Type *
        obj : Object -> bool
override IsTypeCompatible :
        type : Type *
        obj : Object -> bool

Parameters

type
Type: SystemType
The type.
obj
Type: SystemObject
The object.

Return Value

Type: Boolean

Implements

IUserDataDescriptorIsTypeCompatible(Type, Object)
See Also

Reference

ProxyUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ProxyUserDataDescriptor.MetaIndex Method

ProxyUserDataDescriptorMetaIndex Method
Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). These standard metamethods can be supported (the return value should be a function accepting the classic parameters of the corresponding metamethod): __add, __sub, __mul, __div, __div, __pow, __unm, __eq, __lt, __le, __lt, __len, __concat, __pairs, __ipairs, __iterator, __call These standard metamethods are supported through other calls for efficiency: __index, __newindex, __tostring

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue MetaIndex(
    Script script,
    Object obj,
    string metaname
)
Public Function MetaIndex (
    script As Script,
    obj As Object,
    metaname As String
) As DynValue
public:
virtual DynValue^ MetaIndex(
    Script^ script,
    Object^ obj,
    String^ metaname
) sealed
abstract MetaIndex :
        script : Script *
        obj : Object *
        metaname : string -> DynValue
override MetaIndex :
        script : Script *
        obj : Object *
        metaname : string -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script originating the request
obj
Type: SystemObject
The object (null if a static request is done)
metaname
Type: SystemString
The name of the metamember.

Return Value

Type: DynValue

Implements

IUserDataDescriptorMetaIndex(Script, Object, String)
See Also

Reference

ProxyUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ProxyUserDataDescriptor.SetIndex Method

ProxyUserDataDescriptorSetIndex Method
Performs an "index" "set" operation.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool SetIndex(
    Script script,
    Object obj,
    DynValue index,
    DynValue value,
    bool isDirectIndexing
)
Public Function SetIndex (
    script As Script,
    obj As Object,
    index As DynValue,
    value As DynValue,
    isDirectIndexing As Boolean
) As Boolean
public:
virtual bool SetIndex(
    Script^ script,
    Object^ obj,
    DynValue^ index,
    DynValue^ value,
    bool isDirectIndexing
) sealed
abstract SetIndex :
        script : Script *
        obj : Object *
        index : DynValue *
        value : DynValue *
        isDirectIndexing : bool -> bool
override SetIndex :
        script : Script *
        obj : Object *
        index : DynValue *
        value : DynValue *
        isDirectIndexing : bool -> bool

Parameters

script
Type: MoonSharp.InterpreterScript
The script originating the request
obj
Type: SystemObject
The object (null if a static request is done)
index
Type: MoonSharp.InterpreterDynValue
The index.
value
Type: MoonSharp.InterpreterDynValue
The value to be set
isDirectIndexing
Type: SystemBoolean
If set to true, it's indexed with a name, if false it's indexed through brackets.

Return Value

Type: Boolean

Implements

IUserDataDescriptorSetIndex(Script, Object, DynValue, DynValue, Boolean)
See Also

Reference

ProxyUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ReflectionSpecialName Structure

ReflectionSpecialName Structure
Class helping identifying special names found with reflection

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public struct ReflectionSpecialName
Public Structure ReflectionSpecialName
public value class ReflectionSpecialName
[<SealedAttribute>]
type ReflectionSpecialName =  struct end

The ReflectionSpecialName type exposes the following members.

Constructors
 | Name | Description
Public method | ReflectionSpecialName(String) | Initializes a new instance of the ReflectionSpecialName class
Public method | ReflectionSpecialName(ReflectionSpecialNameType, String) | Initializes a new instance of the ReflectionSpecialName class
Top
Properties
 | Name | Description
Public property | Argument |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


ReflectionSpecialName Constructor

ReflectionSpecialName Constructor
Overload List
 | Name | Description
Public method | ReflectionSpecialName(String) | Initializes a new instance of the ReflectionSpecialName class
Public method | ReflectionSpecialName(ReflectionSpecialNameType, String) | Initializes a new instance of the ReflectionSpecialName class
Top
See Also

Reference

ReflectionSpecialName Structure
MoonSharp.Interpreter.Interop Namespace


ReflectionSpecialName Constructor (String)

ReflectionSpecialName Constructor (String)
Initializes a new instance of the ReflectionSpecialName class

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ReflectionSpecialName(
    string name
)
Public Sub New (
    name As String
)
public:
ReflectionSpecialName(
    String^ name
)
new :
        name : string -> ReflectionSpecialName

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:MoonSharp.Interpreter.Interop.ReflectionSpecialName.#ctor(System.String)"]

See Also

Reference

ReflectionSpecialName Structure
ReflectionSpecialName Overload
MoonSharp.Interpreter.Interop Namespace


ReflectionSpecialName Constructor (ReflectionSpecialNameType, String)

ReflectionSpecialName Constructor (ReflectionSpecialNameType, String)
Initializes a new instance of the ReflectionSpecialName class

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ReflectionSpecialName(
    ReflectionSpecialNameType type,
    string argument = null
)
Public Sub New (
    type As ReflectionSpecialNameType,
    Optional argument As String = Nothing
)
public:
ReflectionSpecialName(
    ReflectionSpecialNameType type,
    String^ argument = nullptr
)
new :
        type : ReflectionSpecialNameType *
        ?argument : string
(* Defaults:
        let _argument = defaultArg argument null
*)
-> ReflectionSpecialName

Parameters

type
Type: MoonSharp.Interpreter.InteropReflectionSpecialNameType

[Missing <param name="type"/> documentation for "M:MoonSharp.Interpreter.Interop.ReflectionSpecialName.#ctor(MoonSharp.Interpreter.Interop.ReflectionSpecialNameType,System.String)"]

argument (Optional)
Type: SystemString

[Missing <param name="argument"/> documentation for "M:MoonSharp.Interpreter.Interop.ReflectionSpecialName.#ctor(MoonSharp.Interpreter.Interop.ReflectionSpecialNameType,System.String)"]

See Also

Reference

ReflectionSpecialName Structure
ReflectionSpecialName Overload
MoonSharp.Interpreter.Interop Namespace


ReflectionSpecialName Properties

ReflectionSpecialName Properties

The ReflectionSpecialName type exposes the following members.

Properties
 | Name | Description
Public property | Argument |
Public property | Type |
Top
See Also

Reference

ReflectionSpecialName Structure
MoonSharp.Interpreter.Interop Namespace


ReflectionSpecialName.Argument Property

ReflectionSpecialNameArgument Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.Interop.ReflectionSpecialName.Argument"]

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Argument { get; }
Public ReadOnly Property Argument As String
    Get
public:
property String^ Argument {
    String^ get ();
}
member Argument : string with get

Property Value

Type: String
See Also

Reference

ReflectionSpecialName Structure
MoonSharp.Interpreter.Interop Namespace


ReflectionSpecialName.Type Property

ReflectionSpecialNameType Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.Interop.ReflectionSpecialName.Type"]

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ReflectionSpecialNameType Type { get; }
Public ReadOnly Property Type As ReflectionSpecialNameType
    Get
public:
property ReflectionSpecialNameType Type {
    ReflectionSpecialNameType get ();
}
member Type : ReflectionSpecialNameType with get

Property Value

Type: ReflectionSpecialNameType
See Also

Reference

ReflectionSpecialName Structure
MoonSharp.Interpreter.Interop Namespace


ReflectionSpecialName Methods

ReflectionSpecialName Methods

The ReflectionSpecialName type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
See Also

Reference

ReflectionSpecialName Structure
MoonSharp.Interpreter.Interop Namespace


ReflectionSpecialNameType Enumeration

ReflectionSpecialNameType Enumeration
Helps identifying a reflection special name

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public enum ReflectionSpecialNameType
Public Enumeration ReflectionSpecialNameType
public enum class ReflectionSpecialNameType
type ReflectionSpecialNameType
Members
Member name | Value | Description
IndexGetter | 0 |
IndexSetter | 1 |
ImplicitCast | 2 |
ExplicitCast | 3 |
OperatorTrue | 4 |
OperatorFalse | 5 |
PropertyGetter | 6 |
PropertySetter | 7 |
AddEvent | 8 |
RemoveEvent | 9 |
OperatorAdd | 10 |
OperatorAnd | 11 |
OperatorOr | 12 |
OperatorDec | 13 |
OperatorDiv | 14 |
OperatorEq | 15 |
OperatorXor | 16 |
OperatorGt | 17 |
OperatorGte | 18 |
OperatorInc | 19 |
OperatorNeq | 20 |
OperatorLt | 21 |
OperatorLte | 22 |
OperatorNot | 23 |
OperatorMod | 24 |
OperatorMul | 25 |
OperatorCompl | 26 |
OperatorSub | 27 |
OperatorNeg | 28 |
OperatorUnaryPlus | 29 |
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


StandardEnumUserDataDescriptor Class

StandardEnumUserDataDescriptor Class
Standard descriptor for Enum values
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.Interop.BasicDescriptorsDispatchingUserDataDescriptor
MoonSharp.Interpreter.InteropStandardEnumUserDataDescriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class StandardEnumUserDataDescriptor : DispatchingUserDataDescriptor
Public Class StandardEnumUserDataDescriptor
    Inherits DispatchingUserDataDescriptor
public ref class StandardEnumUserDataDescriptor : public DispatchingUserDataDescriptor
type StandardEnumUserDataDescriptor =
    class
        inherit DispatchingUserDataDescriptor
    end

The StandardEnumUserDataDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | StandardEnumUserDataDescriptor | Initializes a new instance of the StandardEnumUserDataDescriptor class.
Top
Properties
 | Name | Description
Public property | FriendlyName | Gets a human readable friendly name of the descriptor (Inherited from DispatchingUserDataDescriptor.)
Public property | IsFlags | Gets a value indicating whether this instance describes a flags enumeration.
Public property | IsUnsigned | Gets a value indicating whether underlying type of the enum is unsigned.
Public property | MemberNames | Gets the member names. (Inherited from DispatchingUserDataDescriptor.)
Public property | Members | Gets the members. (Inherited from DispatchingUserDataDescriptor.)
Public property | MetaMemberNames | Gets the meta member names. (Inherited from DispatchingUserDataDescriptor.)
Public property | MetaMembers | Gets the meta members. (Inherited from DispatchingUserDataDescriptor.)
Public property | Name | Gets the name of the descriptor (usually, the name of the type described). (Inherited from DispatchingUserDataDescriptor.)
Public property | Type | Gets the type this descriptor refers to (Inherited from DispatchingUserDataDescriptor.)
Public property | UnderlyingType | Gets the underlying type of the enum.
Top
Methods
 | Name | Description
Public method | AddDynValue | Adds a DynValue as a member (Inherited from DispatchingUserDataDescriptor.)
Public method | AddMember | Adds a property to the member list (Inherited from DispatchingUserDataDescriptor.)
Public method | AddMetaMember | Adds a member to the meta-members list. (Inherited from DispatchingUserDataDescriptor.)
Public method | AsString | Converts this userdata to string (Inherited from DispatchingUserDataDescriptor.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | ExecuteIndexer | Executes the specified indexer method. (Inherited from DispatchingUserDataDescriptor.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindMember | Finds the member with a given name. If not found, null is returned. (Inherited from DispatchingUserDataDescriptor.)
Public method | FindMetaMember | Finds the meta member with a given name. If not found, null is returned. (Inherited from DispatchingUserDataDescriptor.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMember | Determines whether the descriptor contains the specified member (by exact name) (Inherited from DispatchingUserDataDescriptor.)
Public method | HasMetaMember | Determines whether the descriptor contains the specified member in the meta list (by exact name) (Inherited from DispatchingUserDataDescriptor.)
Public method | Index | Performs an "index" "get" operation. This tries to resolve minor variations of member names. (Inherited from DispatchingUserDataDescriptor.)
Public method | IsTypeCompatible | Determines whether the specified object is compatible with the specified type. (Overrides DispatchingUserDataDescriptorIsTypeCompatible(Type, Object).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MetaIndex | Gets a "meta" operation on this userdata. In this specific case, only the concat operator is supported, only on flags enums and it implements the 'or' operator. (Overrides DispatchingUserDataDescriptorMetaIndex(Script, Object, String).)
Public method | RemoveMember | Removes the member with a given name. In case of overloaded functions, all overloads are removed. (Inherited from DispatchingUserDataDescriptor.)
Public method | RemoveMetaMember | Removes the meta member with a given name. In case of overloaded functions, all overloads are removed. (Inherited from DispatchingUserDataDescriptor.)
Public method | SetIndex | Performs an "index" "set" operation. This tries to resolve minor variations of member names. (Inherited from DispatchingUserDataDescriptor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TryIndex | Tries to perform an indexing operation by checking methods and properties for the given indexName (Inherited from DispatchingUserDataDescriptor.)
Protected method | TrySetIndex | Tries to perform an indexing "set" operation by checking methods and properties for the given indexName (Inherited from DispatchingUserDataDescriptor.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


StandardEnumUserDataDescriptor Constructor

StandardEnumUserDataDescriptor Constructor
Initializes a new instance of the StandardEnumUserDataDescriptor class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public StandardEnumUserDataDescriptor(
    Type enumType,
    string friendlyName = null,
    string[] names = null,
    Object[] values = null,
    Type underlyingType = null
)
Public Sub New (
    enumType As Type,
    Optional friendlyName As String = Nothing,
    Optional names As String() = Nothing,
    Optional values As Object() = Nothing,
    Optional underlyingType As Type = Nothing
)
public:
StandardEnumUserDataDescriptor(
    Type^ enumType,
    String^ friendlyName = nullptr,
    array<String^>^ names = nullptr,
    array<Object^>^ values = nullptr,
    Type^ underlyingType = nullptr
)
new :
        enumType : Type *
        ?friendlyName : string *
        ?names : string[] *
        ?values : Object[] *
        ?underlyingType : Type
(* Defaults:
        let _friendlyName = defaultArg friendlyName null
        let _names = defaultArg names null
        let _values = defaultArg values null
        let _underlyingType = defaultArg underlyingType null
*)
-> StandardEnumUserDataDescriptor

Parameters

enumType
Type: SystemType
Type of the enum.
friendlyName (Optional)
Type: SystemString
Name of the friendly.
names (Optional)
Type: SystemString

[Missing <param name="names"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardEnumUserDataDescriptor.#ctor(System.Type,System.String,System.String[],System.Object[],System.Type)"]

values (Optional)
Type: SystemObject

[Missing <param name="values"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardEnumUserDataDescriptor.#ctor(System.Type,System.String,System.String[],System.Object[],System.Type)"]

underlyingType (Optional)
Type: SystemType

[Missing <param name="underlyingType"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardEnumUserDataDescriptor.#ctor(System.Type,System.String,System.String[],System.Object[],System.Type)"]

Exceptions
Exception | Condition
ArgumentException | enumType must be an enum!
See Also

Reference

StandardEnumUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardEnumUserDataDescriptor Properties

StandardEnumUserDataDescriptor Properties

The StandardEnumUserDataDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | FriendlyName | Gets a human readable friendly name of the descriptor (Inherited from DispatchingUserDataDescriptor.)
Public property | IsFlags | Gets a value indicating whether this instance describes a flags enumeration.
Public property | IsUnsigned | Gets a value indicating whether underlying type of the enum is unsigned.
Public property | MemberNames | Gets the member names. (Inherited from DispatchingUserDataDescriptor.)
Public property | Members | Gets the members. (Inherited from DispatchingUserDataDescriptor.)
Public property | MetaMemberNames | Gets the meta member names. (Inherited from DispatchingUserDataDescriptor.)
Public property | MetaMembers | Gets the meta members. (Inherited from DispatchingUserDataDescriptor.)
Public property | Name | Gets the name of the descriptor (usually, the name of the type described). (Inherited from DispatchingUserDataDescriptor.)
Public property | Type | Gets the type this descriptor refers to (Inherited from DispatchingUserDataDescriptor.)
Public property | UnderlyingType | Gets the underlying type of the enum.
Top
See Also

Reference

StandardEnumUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardEnumUserDataDescriptor.IsFlags Property

StandardEnumUserDataDescriptorIsFlags Property
Gets a value indicating whether this instance describes a flags enumeration.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsFlags { get; }
Public ReadOnly Property IsFlags As Boolean
    Get
public:
property bool IsFlags {
    bool get ();
}
member IsFlags : bool with get

Property Value

Type: Boolean
See Also

Reference

StandardEnumUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardEnumUserDataDescriptor.IsUnsigned Property

StandardEnumUserDataDescriptorIsUnsigned Property
Gets a value indicating whether underlying type of the enum is unsigned.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsUnsigned { get; }
Public ReadOnly Property IsUnsigned As Boolean
    Get
public:
property bool IsUnsigned {
    bool get ();
}
member IsUnsigned : bool with get

Property Value

Type: Boolean
See Also

Reference

StandardEnumUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardEnumUserDataDescriptor.UnderlyingType Property

StandardEnumUserDataDescriptorUnderlyingType Property
Gets the underlying type of the enum.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Type UnderlyingType { get; }
Public ReadOnly Property UnderlyingType As Type
    Get
public:
property Type^ UnderlyingType {
    Type^ get ();
}
member UnderlyingType : Type with get

Property Value

Type: Type
See Also

Reference

StandardEnumUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardEnumUserDataDescriptor Methods

StandardEnumUserDataDescriptor Methods

The StandardEnumUserDataDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | AddDynValue | Adds a DynValue as a member (Inherited from DispatchingUserDataDescriptor.)
Public method | AddMember | Adds a property to the member list (Inherited from DispatchingUserDataDescriptor.)
Public method | AddMetaMember | Adds a member to the meta-members list. (Inherited from DispatchingUserDataDescriptor.)
Public method | AsString | Converts this userdata to string (Inherited from DispatchingUserDataDescriptor.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | ExecuteIndexer | Executes the specified indexer method. (Inherited from DispatchingUserDataDescriptor.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindMember | Finds the member with a given name. If not found, null is returned. (Inherited from DispatchingUserDataDescriptor.)
Public method | FindMetaMember | Finds the meta member with a given name. If not found, null is returned. (Inherited from DispatchingUserDataDescriptor.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasMember | Determines whether the descriptor contains the specified member (by exact name) (Inherited from DispatchingUserDataDescriptor.)
Public method | HasMetaMember | Determines whether the descriptor contains the specified member in the meta list (by exact name) (Inherited from DispatchingUserDataDescriptor.)
Public method | Index | Performs an "index" "get" operation. This tries to resolve minor variations of member names. (Inherited from DispatchingUserDataDescriptor.)
Public method | IsTypeCompatible | Determines whether the specified object is compatible with the specified type. (Overrides DispatchingUserDataDescriptorIsTypeCompatible(Type, Object).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MetaIndex | Gets a "meta" operation on this userdata. In this specific case, only the concat operator is supported, only on flags enums and it implements the 'or' operator. (Overrides DispatchingUserDataDescriptorMetaIndex(Script, Object, String).)
Public method | RemoveMember | Removes the member with a given name. In case of overloaded functions, all overloads are removed. (Inherited from DispatchingUserDataDescriptor.)
Public method | RemoveMetaMember | Removes the meta member with a given name. In case of overloaded functions, all overloads are removed. (Inherited from DispatchingUserDataDescriptor.)
Public method | SetIndex | Performs an "index" "set" operation. This tries to resolve minor variations of member names. (Inherited from DispatchingUserDataDescriptor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TryIndex | Tries to perform an indexing operation by checking methods and properties for the given indexName (Inherited from DispatchingUserDataDescriptor.)
Protected method | TrySetIndex | Tries to perform an indexing "set" operation by checking methods and properties for the given indexName (Inherited from DispatchingUserDataDescriptor.)
Top
See Also

Reference

StandardEnumUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardEnumUserDataDescriptor.IsTypeCompatible Method

StandardEnumUserDataDescriptorIsTypeCompatible Method
Determines whether the specified object is compatible with the specified type.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override bool IsTypeCompatible(
    Type type,
    Object obj
)
Public Overrides Function IsTypeCompatible (
    type As Type,
    obj As Object
) As Boolean
public:
virtual bool IsTypeCompatible(
    Type^ type,
    Object^ obj
) override
abstract IsTypeCompatible :
        type : Type *
        obj : Object -> bool
override IsTypeCompatible :
        type : Type *
        obj : Object -> bool

Parameters

type
Type: SystemType
The type.
obj
Type: SystemObject
The object.

Return Value

Type: Boolean

Implements

IUserDataDescriptorIsTypeCompatible(Type, Object)
See Also

Reference

StandardEnumUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardEnumUserDataDescriptor.MetaIndex Method

StandardEnumUserDataDescriptorMetaIndex Method
Gets a "meta" operation on this userdata. In this specific case, only the concat operator is supported, only on flags enums and it implements the 'or' operator.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override DynValue MetaIndex(
    Script script,
    Object obj,
    string metaname
)
Public Overrides Function MetaIndex (
    script As Script,
    obj As Object,
    metaname As String
) As DynValue
public:
virtual DynValue^ MetaIndex(
    Script^ script,
    Object^ obj,
    String^ metaname
) override
abstract MetaIndex :
        script : Script *
        obj : Object *
        metaname : string -> DynValue
override MetaIndex :
        script : Script *
        obj : Object *
        metaname : string -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript

[Missing <param name="script"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardEnumUserDataDescriptor.MetaIndex(MoonSharp.Interpreter.Script,System.Object,System.String)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardEnumUserDataDescriptor.MetaIndex(MoonSharp.Interpreter.Script,System.Object,System.String)"]

metaname
Type: SystemString

[Missing <param name="metaname"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardEnumUserDataDescriptor.MetaIndex(MoonSharp.Interpreter.Script,System.Object,System.String)"]

Return Value

Type: DynValue

Implements

IUserDataDescriptorMetaIndex(Script, Object, String)
See Also

Reference

StandardEnumUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardGenericsUserDataDescriptor Class

StandardGenericsUserDataDescriptor Class
Standard user data descriptor used to instantiate generics.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropStandardGenericsUserDataDescriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class StandardGenericsUserDataDescriptor : IUserDataDescriptor,
    IGeneratorUserDataDescriptor
Public Class StandardGenericsUserDataDescriptor
    Implements IUserDataDescriptor, IGeneratorUserDataDescriptor
public ref class StandardGenericsUserDataDescriptor : IUserDataDescriptor,
    IGeneratorUserDataDescriptor
type StandardGenericsUserDataDescriptor =
    class
        interface IUserDataDescriptor
        interface IGeneratorUserDataDescriptor
    end

The StandardGenericsUserDataDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | StandardGenericsUserDataDescriptor | Initializes a new instance of the StandardUserDataDescriptor class.
Top
Properties
 | Name | Description
Public property | AccessMode | Gets the interop access mode this descriptor uses for members access
Public property | Name | Gets the name of the descriptor (usually, the name of the type described).
Public property | Type | Gets the type this descriptor refers to
Top
Methods
Name Description
Public method AsString
Converts this userdata to string
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method Generate
Generates a new descriptor for the specified type. The purpose is to allow a mechanism by which a type descriptor can replace itself with another descriptor for a specific type. For example, descriptors can be created on the fly to support generic types through this mechanism. The return value should be: null - if this descriptor is simply skipped for the specified type this - acts as if the descriptor was a vanilla descriptor a new descriptor - if a new descriptor should be used in place of this one It's recommended that instances of descriptors are cached for future references. One possible way, to do the caching is to have the generator register the descriptor through RegisterType(Type, InteropAccessMode, String). In that case, it should query whether the type is exactly registered, through IsTypeRegistered(Type) NOTE-1 : the search for descriptors does NOT stop with the descriptor returned by this type, but other descriptors (e.g. for interfaces) might still be added. NOTE-2 : the descriptor generation mechanism is not triggered on an exact match of types. NOTE-3 : the method is called in the context of a lock over the descriptors registry so no unpredictable changes to the registry can come from other threads during the execution of this method. However this method should not take other locks, to avoid deadlocks.
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method Index
Performs an "index" "get" operation.
Public method IsTypeCompatible
Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method MetaIndex
Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). These standard metamethods can be supported (the return value should be a function accepting the classic parameters of the corresponding metamethod): __add, __sub, __mul, __div, __div, __pow, __unm, __eq, __lt, __le, __lt, __len, __concat, __pairs, __ipairs, __iterator, __call These standard metamethods are supported through other calls for efficiency: __index, __newindex, __tostring
Public method SetIndex
Performs an "index" "set" operation.
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


StandardGenericsUserDataDescriptor Constructor

StandardGenericsUserDataDescriptor Constructor
Initializes a new instance of the StandardUserDataDescriptor class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public StandardGenericsUserDataDescriptor(
    Type type,
    InteropAccessMode accessMode
)
Public Sub New (
    type As Type,
    accessMode As InteropAccessMode
)
public:
StandardGenericsUserDataDescriptor(
    Type^ type,
    InteropAccessMode accessMode
)
new :
        type : Type *
        accessMode : InteropAccessMode -> StandardGenericsUserDataDescriptor

Parameters

type
Type: SystemType
The type this descriptor refers to.
accessMode
Type: MoonSharp.InterpreterInteropAccessMode
The interop access mode this descriptor uses for members access
See Also

Reference

StandardGenericsUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardGenericsUserDataDescriptor Properties

StandardGenericsUserDataDescriptor Properties

The StandardGenericsUserDataDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | AccessMode | Gets the interop access mode this descriptor uses for members access
Public property | Name | Gets the name of the descriptor (usually, the name of the type described).
Public property | Type | Gets the type this descriptor refers to
Top
See Also

Reference

StandardGenericsUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardGenericsUserDataDescriptor.AccessMode Property

StandardGenericsUserDataDescriptorAccessMode Property
Gets the interop access mode this descriptor uses for members access

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public InteropAccessMode AccessMode { get; }
Public ReadOnly Property AccessMode As InteropAccessMode
    Get
public:
property InteropAccessMode AccessMode {
    InteropAccessMode get ();
}
member AccessMode : InteropAccessMode with get

Property Value

Type: InteropAccessMode
See Also

Reference

StandardGenericsUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardGenericsUserDataDescriptor.Name Property

StandardGenericsUserDataDescriptorName Property
Gets the name of the descriptor (usually, the name of the type described).

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IUserDataDescriptorName
See Also

Reference

StandardGenericsUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardGenericsUserDataDescriptor.Type Property

StandardGenericsUserDataDescriptorType Property
Gets the type this descriptor refers to

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Type Type { get; }
Public ReadOnly Property Type As Type
    Get
public:
virtual property Type^ Type {
    Type^ get () sealed;
}
abstract Type : Type with get
override Type : Type with get

Property Value

Type: Type

Implements

IUserDataDescriptorType
See Also

Reference

StandardGenericsUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardGenericsUserDataDescriptor Methods

StandardGenericsUserDataDescriptor Methods

The StandardGenericsUserDataDescriptor type exposes the following members.

Methods
Name Description
Public method AsString
Converts this userdata to string
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method Generate
Generates a new descriptor for the specified type. The purpose is to allow a mechanism by which a type descriptor can replace itself with another descriptor for a specific type. For example, descriptors can be created on the fly to support generic types through this mechanism. The return value should be: null - if this descriptor is simply skipped for the specified type this - acts as if the descriptor was a vanilla descriptor a new descriptor - if a new descriptor should be used in place of this one It's recommended that instances of descriptors are cached for future references. One possible way, to do the caching is to have the generator register the descriptor through RegisterType(Type, InteropAccessMode, String). In that case, it should query whether the type is exactly registered, through IsTypeRegistered(Type) NOTE-1 : the search for descriptors does NOT stop with the descriptor returned by this type, but other descriptors (e.g. for interfaces) might still be added. NOTE-2 : the descriptor generation mechanism is not triggered on an exact match of types. NOTE-3 : the method is called in the context of a lock over the descriptors registry so no unpredictable changes to the registry can come from other threads during the execution of this method. However this method should not take other locks, to avoid deadlocks.
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method Index
Performs an "index" "get" operation.
Public method IsTypeCompatible
Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method MetaIndex
Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). These standard metamethods can be supported (the return value should be a function accepting the classic parameters of the corresponding metamethod): __add, __sub, __mul, __div, __div, __pow, __unm, __eq, __lt, __le, __lt, __len, __concat, __pairs, __ipairs, __iterator, __call These standard metamethods are supported through other calls for efficiency: __index, __newindex, __tostring
Public method SetIndex
Performs an "index" "set" operation.
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Top
See Also

Reference

StandardGenericsUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardGenericsUserDataDescriptor.AsString Method

StandardGenericsUserDataDescriptorAsString Method
Converts this userdata to string

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string AsString(
    Object obj
)
Public Function AsString (
    obj As Object
) As String
public:
virtual String^ AsString(
    Object^ obj
) sealed
abstract AsString :
        obj : Object -> string
override AsString :
        obj : Object -> string

Parameters

obj
Type: SystemObject
The object.

Return Value

Type: String

Implements

IUserDataDescriptorAsString(Object)
See Also

Reference

StandardGenericsUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardGenericsUserDataDescriptor.Generate Method

StandardGenericsUserDataDescriptorGenerate Method
Generates a new descriptor for the specified type. The purpose is to allow a mechanism by which a type descriptor can replace itself with another descriptor for a specific type. For example, descriptors can be created on the fly to support generic types through this mechanism. The return value should be: null - if this descriptor is simply skipped for the specified type this - acts as if the descriptor was a vanilla descriptor a new descriptor - if a new descriptor should be used in place of this one It's recommended that instances of descriptors are cached for future references. One possible way, to do the caching is to have the generator register the descriptor through RegisterType(Type, InteropAccessMode, String). In that case, it should query whether the type is exactly registered, through IsTypeRegistered(Type) NOTE-1 : the search for descriptors does NOT stop with the descriptor returned by this type, but other descriptors (e.g. for interfaces) might still be added. NOTE-2 : the descriptor generation mechanism is not triggered on an exact match of types. NOTE-3 : the method is called in the context of a lock over the descriptors registry so no unpredictable changes to the registry can come from other threads during the execution of this method. However this method should not take other locks, to avoid deadlocks.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IUserDataDescriptor Generate(
    Type type
)
Public Function Generate (
    type As Type
) As IUserDataDescriptor
public:
virtual IUserDataDescriptor^ Generate(
    Type^ type
) sealed
abstract Generate :
        type : Type -> IUserDataDescriptor
override Generate :
        type : Type -> IUserDataDescriptor

Parameters

type
Type: SystemType
The type.

Return Value

Type: IUserDataDescriptor
Null, this object instance or a new descriptor.

Implements

IGeneratorUserDataDescriptorGenerate(Type)
See Also

Reference

StandardGenericsUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardGenericsUserDataDescriptor.Index Method

StandardGenericsUserDataDescriptorIndex Method
Performs an "index" "get" operation.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Index(
    Script script,
    Object obj,
    DynValue index,
    bool isDirectIndexing
)
Public Function Index (
    script As Script,
    obj As Object,
    index As DynValue,
    isDirectIndexing As Boolean
) As DynValue
public:
virtual DynValue^ Index(
    Script^ script,
    Object^ obj,
    DynValue^ index,
    bool isDirectIndexing
) sealed
abstract Index :
        script : Script *
        obj : Object *
        index : DynValue *
        isDirectIndexing : bool -> DynValue
override Index :
        script : Script *
        obj : Object *
        index : DynValue *
        isDirectIndexing : bool -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script originating the request
obj
Type: SystemObject
The object (null if a static request is done)
index
Type: MoonSharp.InterpreterDynValue
The index.
isDirectIndexing
Type: SystemBoolean
If set to true, it's indexed with a name, if false it's indexed through brackets.

Return Value

Type: DynValue

Implements

IUserDataDescriptorIndex(Script, Object, DynValue, Boolean)
See Also

Reference

StandardGenericsUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardGenericsUserDataDescriptor.IsTypeCompatible Method

StandardGenericsUserDataDescriptorIsTypeCompatible Method
Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTypeCompatible(
    Type type,
    Object obj
)
Public Function IsTypeCompatible (
    type As Type,
    obj As Object
) As Boolean
public:
virtual bool IsTypeCompatible(
    Type^ type,
    Object^ obj
) sealed
abstract IsTypeCompatible :
        type : Type *
        obj : Object -> bool
override IsTypeCompatible :
        type : Type *
        obj : Object -> bool

Parameters

type
Type: SystemType
The type.
obj
Type: SystemObject
The object.

Return Value

Type: Boolean

Implements

IUserDataDescriptorIsTypeCompatible(Type, Object)
See Also

Reference

StandardGenericsUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardGenericsUserDataDescriptor.MetaIndex Method

StandardGenericsUserDataDescriptorMetaIndex Method
Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). These standard metamethods can be supported (the return value should be a function accepting the classic parameters of the corresponding metamethod): __add, __sub, __mul, __div, __div, __pow, __unm, __eq, __lt, __le, __lt, __len, __concat, __pairs, __ipairs, __iterator, __call These standard metamethods are supported through other calls for efficiency: __index, __newindex, __tostring

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue MetaIndex(
    Script script,
    Object obj,
    string metaname
)
Public Function MetaIndex (
    script As Script,
    obj As Object,
    metaname As String
) As DynValue
public:
virtual DynValue^ MetaIndex(
    Script^ script,
    Object^ obj,
    String^ metaname
) sealed
abstract MetaIndex :
        script : Script *
        obj : Object *
        metaname : string -> DynValue
override MetaIndex :
        script : Script *
        obj : Object *
        metaname : string -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script originating the request
obj
Type: SystemObject
The object (null if a static request is done)
metaname
Type: SystemString
The name of the metamember.

Return Value

Type: DynValue

Implements

IUserDataDescriptorMetaIndex(Script, Object, String)
See Also

Reference

StandardGenericsUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardGenericsUserDataDescriptor.SetIndex Method

StandardGenericsUserDataDescriptorSetIndex Method
Performs an "index" "set" operation.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool SetIndex(
    Script script,
    Object obj,
    DynValue index,
    DynValue value,
    bool isDirectIndexing
)
Public Function SetIndex (
    script As Script,
    obj As Object,
    index As DynValue,
    value As DynValue,
    isDirectIndexing As Boolean
) As Boolean
public:
virtual bool SetIndex(
    Script^ script,
    Object^ obj,
    DynValue^ index,
    DynValue^ value,
    bool isDirectIndexing
) sealed
abstract SetIndex :
        script : Script *
        obj : Object *
        index : DynValue *
        value : DynValue *
        isDirectIndexing : bool -> bool
override SetIndex :
        script : Script *
        obj : Object *
        index : DynValue *
        value : DynValue *
        isDirectIndexing : bool -> bool

Parameters

script
Type: MoonSharp.InterpreterScript
The script originating the request
obj
Type: SystemObject
The object (null if a static request is done)
index
Type: MoonSharp.InterpreterDynValue
The index.
value
Type: MoonSharp.InterpreterDynValue
The value to be set
isDirectIndexing
Type: SystemBoolean
If set to true, it's indexed with a name, if false it's indexed through brackets.

Return Value

Type: Boolean

Implements

IUserDataDescriptorSetIndex(Script, Object, DynValue, DynValue, Boolean)
See Also

Reference

StandardGenericsUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardUserDataDescriptor Class

StandardUserDataDescriptor Class
Standard descriptor for userdata types.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.Interop.BasicDescriptorsDispatchingUserDataDescriptor
MoonSharp.Interpreter.InteropStandardUserDataDescriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class StandardUserDataDescriptor : DispatchingUserDataDescriptor,
    IWireableDescriptor
Public Class StandardUserDataDescriptor
    Inherits DispatchingUserDataDescriptor
    Implements IWireableDescriptor
public ref class StandardUserDataDescriptor : public DispatchingUserDataDescriptor,
    IWireableDescriptor
type StandardUserDataDescriptor =
    class
        inherit DispatchingUserDataDescriptor
        interface IWireableDescriptor
    end

The StandardUserDataDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | StandardUserDataDescriptor | Initializes a new instance of the StandardUserDataDescriptor class.
Top
Properties
 | Name | Description
Public property | AccessMode | Gets the interop access mode this descriptor uses for members access
Public property | FriendlyName | Gets a human readable friendly name of the descriptor (Inherited from DispatchingUserDataDescriptor.)
Public property | MemberNames | Gets the member names. (Inherited from DispatchingUserDataDescriptor.)
Public property | Members | Gets the members. (Inherited from DispatchingUserDataDescriptor.)
Public property | MetaMemberNames | Gets the meta member names. (Inherited from DispatchingUserDataDescriptor.)
Public property | MetaMembers | Gets the meta members. (Inherited from DispatchingUserDataDescriptor.)
Public property | Name | Gets the name of the descriptor (usually, the name of the type described). (Inherited from DispatchingUserDataDescriptor.)
Public property | Type | Gets the type this descriptor refers to (Inherited from DispatchingUserDataDescriptor.)
Top
Methods
Name | Description
Public method AddDynValue
Adds a DynValue as a member
(Inherited from DispatchingUserDataDescriptor.)
Public method AddMember
Adds a property to the member list
(Inherited from DispatchingUserDataDescriptor.)
Public method AddMetaMember
Adds a member to the meta-members list.
(Inherited from DispatchingUserDataDescriptor.)
Public method AsString
Converts this userdata to string
(Inherited from DispatchingUserDataDescriptor.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method ExecuteIndexer
Executes the specified indexer method.
(Inherited from DispatchingUserDataDescriptor.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method FindMember
Finds the member with a given name. If not found, null is returned.
(Inherited from DispatchingUserDataDescriptor.)
Public method FindMetaMember
Finds the meta member with a given name. If not found, null is returned.
(Inherited from DispatchingUserDataDescriptor.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasMember
Determines whether the descriptor contains the specified member (by exact name)
(Inherited from DispatchingUserDataDescriptor.)
Public method HasMetaMember
Determines whether the descriptor contains the specified member in the meta list (by exact name)
(Inherited from DispatchingUserDataDescriptor.)
Public method Index
Performs an "index" "get" operation. This tries to resolve minor variations of member names.
(Inherited from DispatchingUserDataDescriptor.)
Public method IsTypeCompatible
Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "
(Inherited from DispatchingUserDataDescriptor.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method MetaIndex
Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). See MetaIndex(Script, Object, String) for further details. If a method exists marked with MoonSharpUserDataMetamethodAttribute for the specific metamethod requested, that method is returned. If the above fails, the following dispatching occur: __add, __sub, __mul, __div, __mod and __unm are dispatched to C# operator overloads (if they exist) __eq is dispatched to System.Object.Equals. __lt and __le are dispatched IComparable.Compare, if the type implements IComparable or IComparable{object} __len is dispatched to Length and Count properties, if those exist. __iterator is handled if the object implements IEnumerable or IEnumerator. __tonumber is dispatched to implicit or explicit conversion operators to standard numeric types. __tobool is dispatched to an implicit or explicit conversion operator to bool. If that fails, operator true is used. The script originating the requestThe object (null if a static request is done)The name of the metamember.
(Inherited from DispatchingUserDataDescriptor.)
Public method | PrepareForWiring
Public method RemoveMember
Removes the member with a given name. In case of overloaded functions, all overloads are removed.
(Inherited from DispatchingUserDataDescriptor.)
Public method RemoveMetaMember
Removes the meta member with a given name. In case of overloaded functions, all overloads are removed.
(Inherited from DispatchingUserDataDescriptor.)
Public method SetIndex
Performs an "index" "set" operation. This tries to resolve minor variations of member names.
(Inherited from DispatchingUserDataDescriptor.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Protected method TryIndex
Tries to perform an indexing operation by checking methods and properties for the given indexName
(Inherited from DispatchingUserDataDescriptor.)
Protected method TrySetIndex
Tries to perform an indexing "set" operation by checking methods and properties for the given indexName
(Inherited from DispatchingUserDataDescriptor.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


StandardUserDataDescriptor Constructor

StandardUserDataDescriptor Constructor
Initializes a new instance of the StandardUserDataDescriptor class.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public StandardUserDataDescriptor(
    Type type,
    InteropAccessMode accessMode,
    string friendlyName = null
)
Public Sub New (
    type As Type,
    accessMode As InteropAccessMode,
    Optional friendlyName As String = Nothing
)
public:
StandardUserDataDescriptor(
    Type^ type,
    InteropAccessMode accessMode,
    String^ friendlyName = nullptr
)
new :
        type : Type *
        accessMode : InteropAccessMode *
        ?friendlyName : string
(* Defaults:
        let _friendlyName = defaultArg friendlyName null
*)
-> StandardUserDataDescriptor

Parameters

type
Type: SystemType
The type this descriptor refers to.
accessMode
Type: MoonSharp.InterpreterInteropAccessMode
The interop access mode this descriptor uses for members access
friendlyName (Optional)
Type: SystemString
A human readable friendly name of the descriptor.
See Also

Reference

StandardUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardUserDataDescriptor Properties

StandardUserDataDescriptor Properties

The StandardUserDataDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | AccessMode | Gets the interop access mode this descriptor uses for members access
Public property | FriendlyName | Gets a human readable friendly name of the descriptor (Inherited from DispatchingUserDataDescriptor.)
Public property | MemberNames | Gets the member names. (Inherited from DispatchingUserDataDescriptor.)
Public property | Members | Gets the members. (Inherited from DispatchingUserDataDescriptor.)
Public property | MetaMemberNames | Gets the meta member names. (Inherited from DispatchingUserDataDescriptor.)
Public property | MetaMembers | Gets the meta members. (Inherited from DispatchingUserDataDescriptor.)
Public property | Name | Gets the name of the descriptor (usually, the name of the type described). (Inherited from DispatchingUserDataDescriptor.)
Public property | Type | Gets the type this descriptor refers to (Inherited from DispatchingUserDataDescriptor.)
Top
See Also

Reference

StandardUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardUserDataDescriptor.AccessMode Property

StandardUserDataDescriptorAccessMode Property
Gets the interop access mode this descriptor uses for members access

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public InteropAccessMode AccessMode { get; }
Public ReadOnly Property AccessMode As InteropAccessMode
    Get
public:
property InteropAccessMode AccessMode {
    InteropAccessMode get ();
}
member AccessMode : InteropAccessMode with get

Property Value

Type: InteropAccessMode
See Also

Reference

StandardUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardUserDataDescriptor Methods

StandardUserDataDescriptor Methods

The StandardUserDataDescriptor type exposes the following members.

Methods
Name | Description
Public method AddDynValue
Adds a DynValue as a member
(Inherited from DispatchingUserDataDescriptor.)
Public method AddMember
Adds a property to the member list
(Inherited from DispatchingUserDataDescriptor.)
Public method AddMetaMember
Adds a member to the meta-members list.
(Inherited from DispatchingUserDataDescriptor.)
Public method AsString
Converts this userdata to string
(Inherited from DispatchingUserDataDescriptor.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method ExecuteIndexer
Executes the specified indexer method.
(Inherited from DispatchingUserDataDescriptor.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method FindMember
Finds the member with a given name. If not found, null is returned.
(Inherited from DispatchingUserDataDescriptor.)
Public method FindMetaMember
Finds the meta member with a given name. If not found, null is returned.
(Inherited from DispatchingUserDataDescriptor.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasMember
Determines whether the descriptor contains the specified member (by exact name)
(Inherited from DispatchingUserDataDescriptor.)
Public method HasMetaMember
Determines whether the descriptor contains the specified member in the meta list (by exact name)
(Inherited from DispatchingUserDataDescriptor.)
Public method Index
Performs an "index" "get" operation. This tries to resolve minor variations of member names.
(Inherited from DispatchingUserDataDescriptor.)
Public method IsTypeCompatible
Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "
(Inherited from DispatchingUserDataDescriptor.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method MetaIndex
Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). See MetaIndex(Script, Object, String) for further details. If a method exists marked with MoonSharpUserDataMetamethodAttribute for the specific metamethod requested, that method is returned. If the above fails, the following dispatching occur: __add, __sub, __mul, __div, __mod and __unm are dispatched to C# operator overloads (if they exist) __eq is dispatched to System.Object.Equals. __lt and __le are dispatched IComparable.Compare, if the type implements IComparable or IComparable{object} __len is dispatched to Length and Count properties, if those exist. __iterator is handled if the object implements IEnumerable or IEnumerator. __tonumber is dispatched to implicit or explicit conversion operators to standard numeric types. __tobool is dispatched to an implicit or explicit conversion operator to bool. If that fails, operator true is used. The script originating the requestThe object (null if a static request is done)The name of the metamember.
(Inherited from DispatchingUserDataDescriptor.)
Public method | PrepareForWiring
Public method RemoveMember
Removes the member with a given name. In case of overloaded functions, all overloads are removed.
(Inherited from DispatchingUserDataDescriptor.)
Public method RemoveMetaMember
Removes the meta member with a given name. In case of overloaded functions, all overloads are removed.
(Inherited from DispatchingUserDataDescriptor.)
Public method SetIndex
Performs an "index" "set" operation. This tries to resolve minor variations of member names.
(Inherited from DispatchingUserDataDescriptor.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Protected method TryIndex
Tries to perform an indexing operation by checking methods and properties for the given indexName
(Inherited from DispatchingUserDataDescriptor.)
Protected method TrySetIndex
Tries to perform an indexing "set" operation by checking methods and properties for the given indexName
(Inherited from DispatchingUserDataDescriptor.)
Top
See Also

Reference

StandardUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


StandardUserDataDescriptor.PrepareForWiring Method

StandardUserDataDescriptorPrepareForWiring Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.StandardUserDataDescriptor.PrepareForWiring(MoonSharp.Interpreter.Table)"]

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void PrepareForWiring(
    Table t
)
Public Sub PrepareForWiring (
    t As Table
)
public:
virtual void PrepareForWiring(
    Table^ t
) sealed
abstract PrepareForWiring :
        t : Table -> unit
override PrepareForWiring :
        t : Table -> unit

Parameters

t
Type: MoonSharp.InterpreterTable

[Missing <param name="t"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardUserDataDescriptor.PrepareForWiring(MoonSharp.Interpreter.Table)"]

Implements

IWireableDescriptorPrepareForWiring(Table)
See Also

Reference

StandardUserDataDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ValueTypeDefaultCtorMemberDescriptor Class

ValueTypeDefaultCtorMemberDescriptor Class
Member descriptor for the default constructor of value types.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropValueTypeDefaultCtorMemberDescriptor

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class ValueTypeDefaultCtorMemberDescriptor : IOverloadableMemberDescriptor,
    IMemberDescriptor, IWireableDescriptor
Public Class ValueTypeDefaultCtorMemberDescriptor
    Implements IOverloadableMemberDescriptor, IMemberDescriptor, IWireableDescriptor
public ref class ValueTypeDefaultCtorMemberDescriptor : IOverloadableMemberDescriptor,
    IMemberDescriptor, IWireableDescriptor
type ValueTypeDefaultCtorMemberDescriptor =
    class
        interface IOverloadableMemberDescriptor
        interface IMemberDescriptor
        interface IWireableDescriptor
    end

The ValueTypeDefaultCtorMemberDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | ValueTypeDefaultCtorMemberDescriptor | Initializes a new instance of the MethodMemberDescriptor class representing the default empty ctor for a value type.
Top
Properties
 | Name | Description
Public property | ExtensionMethodType | Gets the type which this extension method extends, null if this is not an extension method.
Public property | IsStatic | Gets a value indicating whether the described method is static.
Public property | MemberAccess | Gets the types of access supported by this member
Public property | Name | Gets the name of the described method
Public property | Parameters | Gets the type of the arguments of the underlying CLR function
Public property | SortDiscriminant | Gets a sort discriminant to give consistent overload resolution matching in case of perfectly equal scores
Public property | ValueTypeDefaultCtor | This property is equal to the value type to be constructed.
Public property | VarArgsArrayType | Gets a value indicating the type of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned.
Public property | VarArgsElementType | Gets a value indicating the type of the elements of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Invokes the member from script. Implementors should raise exceptions if the value cannot be executed or if access to an instance member through a static userdata is attempted.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts. Implementors should raise exceptions if the value cannot be read or if access to an instance member through a static userdata is attempted.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForWiring | Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.
Public method | SetValue | Sets the value of this member from a DynValue. Implementors should raise exceptions if the value cannot be read or if access to an instance member through a static userdata is attempted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop Namespace


ValueTypeDefaultCtorMemberDescriptor Constructor

ValueTypeDefaultCtorMemberDescriptor Constructor
Initializes a new instance of the MethodMemberDescriptor class representing the default empty ctor for a value type.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ValueTypeDefaultCtorMemberDescriptor(
    Type valueType
)
Public Sub New (
    valueType As Type
)
public:
ValueTypeDefaultCtorMemberDescriptor(
    Type^ valueType
)
new :
        valueType : Type -> ValueTypeDefaultCtorMemberDescriptor

Parameters

valueType
Type: SystemType
Type of the value.
Exceptions
Exception | Condition
ArgumentException | valueType is not a value type
See Also

Reference

ValueTypeDefaultCtorMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ValueTypeDefaultCtorMemberDescriptor Properties

ValueTypeDefaultCtorMemberDescriptor Properties

The ValueTypeDefaultCtorMemberDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionMethodType | Gets the type which this extension method extends, null if this is not an extension method.
Public property | IsStatic | Gets a value indicating whether the described method is static.
Public property | MemberAccess | Gets the types of access supported by this member
Public property | Name | Gets the name of the described method
Public property | Parameters | Gets the type of the arguments of the underlying CLR function
Public property | SortDiscriminant | Gets a sort discriminant to give consistent overload resolution matching in case of perfectly equal scores
Public property | ValueTypeDefaultCtor | This property is equal to the value type to be constructed.
Public property | VarArgsArrayType | Gets a value indicating the type of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned.
Public property | VarArgsElementType | Gets a value indicating the type of the elements of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned.
Top
See Also

Reference

ValueTypeDefaultCtorMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ValueTypeDefaultCtorMemberDescriptor.ExtensionMethodType Property

ValueTypeDefaultCtorMemberDescriptorExtensionMethodType Property
Gets the type which this extension method extends, null if this is not an extension method.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Type ExtensionMethodType { get; }
Public ReadOnly Property ExtensionMethodType As Type
    Get
public:
virtual property Type^ ExtensionMethodType {
    Type^ get () sealed;
}
abstract ExtensionMethodType : Type with get
override ExtensionMethodType : Type with get

Property Value

Type: Type

Implements

IOverloadableMemberDescriptorExtensionMethodType
See Also

Reference

ValueTypeDefaultCtorMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ValueTypeDefaultCtorMemberDescriptor.IsStatic Property

ValueTypeDefaultCtorMemberDescriptorIsStatic Property
Gets a value indicating whether the described method is static.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStatic { get; }
Public ReadOnly Property IsStatic As Boolean
    Get
public:
virtual property bool IsStatic {
    bool get () sealed;
}
abstract IsStatic : bool with get
override IsStatic : bool with get

Property Value

Type: Boolean

Implements

IMemberDescriptorIsStatic
See Also

Reference

ValueTypeDefaultCtorMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ValueTypeDefaultCtorMemberDescriptor.MemberAccess Property

ValueTypeDefaultCtorMemberDescriptorMemberAccess Property
Gets the types of access supported by this member

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MemberDescriptorAccess MemberAccess { get; }
Public ReadOnly Property MemberAccess As MemberDescriptorAccess
    Get
public:
virtual property MemberDescriptorAccess MemberAccess {
    MemberDescriptorAccess get () sealed;
}
abstract MemberAccess : MemberDescriptorAccess with get
override MemberAccess : MemberDescriptorAccess with get

Property Value

Type: MemberDescriptorAccess

Implements

IMemberDescriptorMemberAccess
See Also

Reference

ValueTypeDefaultCtorMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ValueTypeDefaultCtorMemberDescriptor.Name Property

ValueTypeDefaultCtorMemberDescriptorName Property
Gets the name of the described method

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IMemberDescriptorName
See Also

Reference

ValueTypeDefaultCtorMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ValueTypeDefaultCtorMemberDescriptor.Parameters Property

ValueTypeDefaultCtorMemberDescriptorParameters Property
Gets the type of the arguments of the underlying CLR function

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterDescriptor[] Parameters { get; }
Public ReadOnly Property Parameters As ParameterDescriptor()
    Get
public:
virtual property array<ParameterDescriptor^>^ Parameters {
    array<ParameterDescriptor^>^ get () sealed;
}
abstract Parameters : ParameterDescriptor[] with get
override Parameters : ParameterDescriptor[] with get

Property Value

Type: ParameterDescriptor

Implements

IOverloadableMemberDescriptorParameters
See Also

Reference

ValueTypeDefaultCtorMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ValueTypeDefaultCtorMemberDescriptor.SortDiscriminant Property

ValueTypeDefaultCtorMemberDescriptorSortDiscriminant Property
Gets a sort discriminant to give consistent overload resolution matching in case of perfectly equal scores

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string SortDiscriminant { get; }
Public ReadOnly Property SortDiscriminant As String
    Get
public:
virtual property String^ SortDiscriminant {
    String^ get () sealed;
}
abstract SortDiscriminant : string with get
override SortDiscriminant : string with get

Property Value

Type: String

Implements

IOverloadableMemberDescriptorSortDiscriminant
See Also

Reference

ValueTypeDefaultCtorMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ValueTypeDefaultCtorMemberDescriptor.ValueTypeDefaultCtor Property

ValueTypeDefaultCtorMemberDescriptorValueTypeDefaultCtor Property
This property is equal to the value type to be constructed.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Type ValueTypeDefaultCtor { get; }
Public ReadOnly Property ValueTypeDefaultCtor As Type
    Get
public:
property Type^ ValueTypeDefaultCtor {
    Type^ get ();
}
member ValueTypeDefaultCtor : Type with get

Property Value

Type: Type
See Also

Reference

ValueTypeDefaultCtorMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ValueTypeDefaultCtorMemberDescriptor.VarArgsArrayType Property

ValueTypeDefaultCtorMemberDescriptorVarArgsArrayType Property
Gets a value indicating the type of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Type VarArgsArrayType { get; }
Public ReadOnly Property VarArgsArrayType As Type
    Get
public:
virtual property Type^ VarArgsArrayType {
    Type^ get () sealed;
}
abstract VarArgsArrayType : Type with get
override VarArgsArrayType : Type with get

Property Value

Type: Type

Implements

IOverloadableMemberDescriptorVarArgsArrayType
See Also

Reference

ValueTypeDefaultCtorMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ValueTypeDefaultCtorMemberDescriptor.VarArgsElementType Property

ValueTypeDefaultCtorMemberDescriptorVarArgsElementType Property
Gets a value indicating the type of the elements of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Type VarArgsElementType { get; }
Public ReadOnly Property VarArgsElementType As Type
    Get
public:
virtual property Type^ VarArgsElementType {
    Type^ get () sealed;
}
abstract VarArgsElementType : Type with get
override VarArgsElementType : Type with get

Property Value

Type: Type

Implements

IOverloadableMemberDescriptorVarArgsElementType
See Also

Reference

ValueTypeDefaultCtorMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ValueTypeDefaultCtorMemberDescriptor Methods

ValueTypeDefaultCtorMemberDescriptor Methods

The ValueTypeDefaultCtorMemberDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | Invokes the member from script. Implementors should raise exceptions if the value cannot be executed or if access to an instance member through a static userdata is attempted.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts. Implementors should raise exceptions if the value cannot be read or if access to an instance member through a static userdata is attempted.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForWiring | Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.
Public method | SetValue | Sets the value of this member from a DynValue. Implementors should raise exceptions if the value cannot be read or if access to an instance member through a static userdata is attempted.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

ValueTypeDefaultCtorMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ValueTypeDefaultCtorMemberDescriptor.Execute Method

ValueTypeDefaultCtorMemberDescriptorExecute Method
Invokes the member from script. Implementors should raise exceptions if the value cannot be executed or if access to an instance member through a static userdata is attempted.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Execute(
    Script script,
    Object obj,
    ScriptExecutionContext context,
    CallbackArguments args
)
Public Function Execute (
    script As Script,
    obj As Object,
    context As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
virtual DynValue^ Execute(
    Script^ script,
    Object^ obj,
    ScriptExecutionContext^ context,
    CallbackArguments^ args
) sealed
abstract Execute :
        script : Script *
        obj : Object *
        context : ScriptExecutionContext *
        args : CallbackArguments -> DynValue
override Execute :
        script : Script *
        obj : Object *
        context : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object.
context
Type: MoonSharp.InterpreterScriptExecutionContext
The context.
args
Type: MoonSharp.InterpreterCallbackArguments
The arguments.

Return Value

Type: DynValue

Implements

IOverloadableMemberDescriptorExecute(Script, Object, ScriptExecutionContext, CallbackArguments)
See Also

Reference

ValueTypeDefaultCtorMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ValueTypeDefaultCtorMemberDescriptor.GetValue Method

ValueTypeDefaultCtorMemberDescriptorGetValue Method
Gets the value of this member as a DynValue to be exposed to scripts. Implementors should raise exceptions if the value cannot be read or if access to an instance member through a static userdata is attempted.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue GetValue(
    Script script,
    Object obj
)
Public Function GetValue (
    script As Script,
    obj As Object
) As DynValue
public:
virtual DynValue^ GetValue(
    Script^ script,
    Object^ obj
) sealed
abstract GetValue :
        script : Script *
        obj : Object -> DynValue
override GetValue :
        script : Script *
        obj : Object -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object owning this member, or null if static.

Return Value

Type: DynValue
The value of this member as a DynValue.

Implements

IMemberDescriptorGetValue(Script, Object)
See Also

Reference

ValueTypeDefaultCtorMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ValueTypeDefaultCtorMemberDescriptor.PrepareForWiring Method

ValueTypeDefaultCtorMemberDescriptorPrepareForWiring Method
Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void PrepareForWiring(
    Table t
)
Public Sub PrepareForWiring (
    t As Table
)
public:
virtual void PrepareForWiring(
    Table^ t
) sealed
abstract PrepareForWiring :
        t : Table -> unit
override PrepareForWiring :
        t : Table -> unit

Parameters

t
Type: MoonSharp.InterpreterTable
The table to be filled

Implements

IWireableDescriptorPrepareForWiring(Table)
See Also

Reference

ValueTypeDefaultCtorMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


ValueTypeDefaultCtorMemberDescriptor.SetValue Method

ValueTypeDefaultCtorMemberDescriptorSetValue Method
Sets the value of this member from a DynValue. Implementors should raise exceptions if the value cannot be read or if access to an instance member through a static userdata is attempted.

Namespace: MoonSharp.Interpreter.Interop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    Script script,
    Object obj,
    DynValue value
)
Public Sub SetValue (
    script As Script,
    obj As Object,
    value As DynValue
)
public:
virtual void SetValue(
    Script^ script,
    Object^ obj,
    DynValue^ value
) sealed
abstract SetValue :
        script : Script *
        obj : Object *
        value : DynValue -> unit
override SetValue :
        script : Script *
        obj : Object *
        value : DynValue -> unit

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object owning this member, or null if static.
value
Type: MoonSharp.InterpreterDynValue
The value to be set.

Implements

IMemberDescriptorSetValue(Script, Object, DynValue)
See Also

Reference

ValueTypeDefaultCtorMemberDescriptor Class
MoonSharp.Interpreter.Interop Namespace


MoonSharp.Interpreter.Interop.BasicDescriptors Namespace

MoonSharp.Interpreter.Interop.BasicDescriptors Namespace

[Missing <summary> documentation for "N:MoonSharp.Interpreter.Interop.BasicDescriptors"]

Classes
 | Class | Description
Public class | DispatchingUserDataDescriptor | An abstract user data descriptor which accepts members described by IMemberDescriptor objects and correctly dispatches to them. Metamethods are also by default dispatched to operator overloads and other similar methods - see MetaIndex(Script, Object, String) .
Public class | MemberDescriptor | Extension methods for IMemberDescriptor and MemberDescriptorAccess .
Public class | ParameterDescriptor | Descriptor of parameters used in IOverloadableMemberDescriptor implementations.
Interfaces
 | Interface | Description
Public interface | IMemberDescriptor | Base interface to describe access to members of a given type. While it's not infrastructural to implement custom type descriptors, it's needed for classes extending DispatchingUserDataDescriptor.
Public interface | IOptimizableDescriptor | Interface for descriptors of any kind which support optimizations of their implementation according to InteropAccessMode modes. This should seldom - if ever - be implemented in user code.
Public interface | IOverloadableMemberDescriptor | Specialized IMemberDescriptor for members supporting overloads resolution.
Public interface | IWireableDescriptor | Interface for descriptors with the capability of being serialized for later hardwiring.
Enumerations
 | Enumeration | Description
Public enumeration | MemberDescriptorAccess | Permissions for members access


DispatchingUserDataDescriptor Class

DispatchingUserDataDescriptor Class
An abstract user data descriptor which accepts members described by IMemberDescriptor objects and correctly dispatches to them. Metamethods are also by default dispatched to operator overloads and other similar methods - see MetaIndex(Script, Object, String) .
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.Interop.BasicDescriptorsDispatchingUserDataDescriptor
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptorsHardwiredUserDataDescriptor
MoonSharp.Interpreter.InteropStandardEnumUserDataDescriptor
MoonSharp.Interpreter.InteropStandardUserDataDescriptor

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class DispatchingUserDataDescriptor : IUserDataDescriptor,
    IOptimizableDescriptor
Public MustInherit Class DispatchingUserDataDescriptor
    Implements IUserDataDescriptor, IOptimizableDescriptor
public ref class DispatchingUserDataDescriptor abstract : IUserDataDescriptor,
    IOptimizableDescriptor
[<AbstractClassAttribute>]
type DispatchingUserDataDescriptor =
    class
        interface IUserDataDescriptor
        interface IOptimizableDescriptor
    end

The DispatchingUserDataDescriptor type exposes the following members.

Constructors
 | Name | Description
Protected method | DispatchingUserDataDescriptor | Initializes a new instance of the StandardUserDataDescriptor class.
Top
Properties
 | Name | Description
Public property | FriendlyName | Gets a human readable friendly name of the descriptor
Public property | MemberNames | Gets the member names.
Public property | Members | Gets the members.
Public property | MetaMemberNames | Gets the meta member names.
Public property | MetaMembers | Gets the meta members.
Public property | Name | Gets the name of the descriptor (usually, the name of the type described).
Public property | Type | Gets the type this descriptor refers to
Top
Methods
Name Description
Public method AddDynValue
Adds a DynValue as a member
Public method AddMember
Adds a property to the member list
Public method AddMetaMember
Adds a member to the meta-members list.
Public method AsString
Converts this userdata to string
Camelify
Converts the specified name from underscore_case to camelCase. Just a wrapper over the DescriptorHelpers method with the same name,
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method ExecuteIndexer
Executes the specified indexer method.
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method FindMember
Finds the member with a given name. If not found, null is returned.
Public method FindMetaMember
Finds the meta member with a given name. If not found, null is returned.
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasMember
Determines whether the descriptor contains the specified member (by exact name)
Public method HasMetaMember
Determines whether the descriptor contains the specified member in the meta list (by exact name)
Public method Index
Performs an "index" "get" operation. This tries to resolve minor variations of member names.
Public method IsTypeCompatible
Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method MetaIndex
Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). See MetaIndex(Script, Object, String) for further details. If a method exists marked with MoonSharpUserDataMetamethodAttribute for the specific metamethod requested, that method is returned. If the above fails, the following dispatching occur: __add, __sub, __mul, __div, __mod and __unm are dispatched to C# operator overloads (if they exist) __eq is dispatched to System.Object.Equals. __lt and __le are dispatched IComparable.Compare, if the type implements IComparable or IComparable{object} __len is dispatched to Length and Count properties, if those exist. __iterator is handled if the object implements IEnumerable or IEnumerator. __tonumber is dispatched to implicit or explicit conversion operators to standard numeric types. __tobool is dispatched to an implicit or explicit conversion operator to bool. If that fails, operator true is used. The script originating the requestThe object (null if a static request is done)The name of the metamember.
Public method RemoveMember
Removes the member with a given name. In case of overloaded functions, all overloads are removed.
Public method RemoveMetaMember
Removes the meta member with a given name. In case of overloaded functions, all overloads are removed.
Public method SetIndex
Performs an "index" "set" operation. This tries to resolve minor variations of member names.
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Protected method TryIndex
Tries to perform an indexing operation by checking methods and properties for the given indexName
Protected method TrySetIndex
Tries to perform an indexing "set" operation by checking methods and properties for the given indexName
UpperFirstLetter
Converts the specified name to one with an uppercase first letter (something to Something). Just a wrapper over the DescriptorHelpers method with the same name,
Top
Fields
Name | Description
SPECIALNAME_CAST_EXPLICIT | The special name used by CLR for explicit cast conversions
SPECIALNAME_CAST_IMPLICIT | The special name used by CLR for implicit cast conversions
SPECIALNAME_INDEXER_GET | The special name used by CLR for indexer getters
SPECIALNAME_INDEXER_SET | The special name used by CLR for indexer setters
Top
See Also

Reference

MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor Constructor

DispatchingUserDataDescriptor Constructor
Initializes a new instance of the StandardUserDataDescriptor class.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected DispatchingUserDataDescriptor(
    Type type,
    string friendlyName = null
)
Protected Sub New (
    type As Type,
    Optional friendlyName As String = Nothing
)
protected:
DispatchingUserDataDescriptor(
    Type^ type,
    String^ friendlyName = nullptr
)
new :
        type : Type *
        ?friendlyName : string
(* Defaults:
        let _friendlyName = defaultArg friendlyName null
*)
-> DispatchingUserDataDescriptor

Parameters

type
Type: SystemType
The type this descriptor refers to.
friendlyName (Optional)
Type: SystemString
A friendly name for the type, or null.
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor Properties

DispatchingUserDataDescriptor Properties

The DispatchingUserDataDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | FriendlyName | Gets a human readable friendly name of the descriptor
Public property | MemberNames | Gets the member names.
Public property | Members | Gets the members.
Public property | MetaMemberNames | Gets the meta member names.
Public property | MetaMembers | Gets the meta members.
Public property | Name | Gets the name of the descriptor (usually, the name of the type described).
Public property | Type | Gets the type this descriptor refers to
Top
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.FriendlyName Property

DispatchingUserDataDescriptorFriendlyName Property
Gets a human readable friendly name of the descriptor

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string FriendlyName { get; }
Public ReadOnly Property FriendlyName As String
    Get
public:
property String^ FriendlyName {
    String^ get ();
}
member FriendlyName : string with get

Property Value

Type: String
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.MemberNames Property

DispatchingUserDataDescriptorMemberNames Property
Gets the member names.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> MemberNames { get; }
Public ReadOnly Property MemberNames As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ MemberNames {
    IEnumerable<String^>^ get ();
}
member MemberNames : IEnumerable<string> with get

Property Value

Type: IEnumerable String
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.Members Property

DispatchingUserDataDescriptorMembers Property
Gets the members.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<KeyValuePair<string, IMemberDescriptor>> Members { get; }
Public ReadOnly Property Members As IEnumerable(Of KeyValuePair(Of String, IMemberDescriptor))
    Get
public:
property IEnumerable<KeyValuePair<String^, IMemberDescriptor^>>^ Members {
    IEnumerable<KeyValuePair<String^, IMemberDescriptor^>>^ get ();
}
member Members : IEnumerable<KeyValuePair<string, IMemberDescriptor>> with get

Property Value

Type: IEnumerable KeyValuePair String, IMemberDescriptor
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.MetaMemberNames Property

DispatchingUserDataDescriptorMetaMemberNames Property
Gets the meta member names.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> MetaMemberNames { get; }
Public ReadOnly Property MetaMemberNames As IEnumerable(Of String)
    Get
public:
property IEnumerable<String^>^ MetaMemberNames {
    IEnumerable<String^>^ get ();
}
member MetaMemberNames : IEnumerable<string> with get

Property Value

Type: IEnumerable String
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.MetaMembers Property

DispatchingUserDataDescriptorMetaMembers Property
Gets the meta members.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<KeyValuePair<string, IMemberDescriptor>> MetaMembers { get; }
Public ReadOnly Property MetaMembers As IEnumerable(Of KeyValuePair(Of String, IMemberDescriptor))
    Get
public:
property IEnumerable<KeyValuePair<String^, IMemberDescriptor^>>^ MetaMembers {
    IEnumerable<KeyValuePair<String^, IMemberDescriptor^>>^ get ();
}
member MetaMembers : IEnumerable<KeyValuePair<string, IMemberDescriptor>> with get

Property Value

Type: IEnumerable KeyValuePair String, IMemberDescriptor
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.Name Property

DispatchingUserDataDescriptorName Property
Gets the name of the descriptor (usually, the name of the type described).

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IUserDataDescriptorName
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.Type Property

DispatchingUserDataDescriptorType Property
Gets the type this descriptor refers to

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Type Type { get; }
Public ReadOnly Property Type As Type
    Get
public:
virtual property Type^ Type {
    Type^ get () sealed;
}
abstract Type : Type with get
override Type : Type with get

Property Value

Type: Type

Implements

IUserDataDescriptorType
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor Methods

DispatchingUserDataDescriptor Methods

The DispatchingUserDataDescriptor type exposes the following members.

Methods
Name Description
Public method AddDynValue
Adds a DynValue as a member
Public method AddMember
Adds a property to the member list
Public method AddMetaMember
Adds a member to the meta-members list.
Public method AsString
Converts this userdata to string
Camelify
Converts the specified name from underscore_case to camelCase. Just a wrapper over the DescriptorHelpers method with the same name,
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method ExecuteIndexer
Executes the specified indexer method.
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method FindMember
Finds the member with a given name. If not found, null is returned.
Public method FindMetaMember
Finds the meta member with a given name. If not found, null is returned.
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasMember
Determines whether the descriptor contains the specified member (by exact name)
Public method HasMetaMember
Determines whether the descriptor contains the specified member in the meta list (by exact name)
Public method Index
Performs an "index" "get" operation. This tries to resolve minor variations of member names.
Public method IsTypeCompatible
Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method MetaIndex
Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). See MetaIndex(Script, Object, String) for further details. If a method exists marked with MoonSharpUserDataMetamethodAttribute for the specific metamethod requested, that method is returned. If the above fails, the following dispatching occur: __add, __sub, __mul, __div, __mod and __unm are dispatched to C# operator overloads (if they exist) __eq is dispatched to System.Object.Equals. __lt and __le are dispatched IComparable.Compare, if the type implements IComparable or IComparable{object} __len is dispatched to Length and Count properties, if those exist. __iterator is handled if the object implements IEnumerable or IEnumerator. __tonumber is dispatched to implicit or explicit conversion operators to standard numeric types. __tobool is dispatched to an implicit or explicit conversion operator to bool. If that fails, operator true is used. The script originating the requestThe object (null if a static request is done)The name of the metamember.
Public method RemoveMember
Removes the member with a given name. In case of overloaded functions, all overloads are removed.
Public method RemoveMetaMember
Removes the meta member with a given name. In case of overloaded functions, all overloads are removed.
Public method SetIndex
Performs an "index" "set" operation. This tries to resolve minor variations of member names.
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Protected method TryIndex
Tries to perform an indexing operation by checking methods and properties for the given indexName
Protected method TrySetIndex
Tries to perform an indexing "set" operation by checking methods and properties for the given indexName
UpperFirstLetter
Converts the specified name to one with an uppercase first letter (something to Something). Just a wrapper over the DescriptorHelpers method with the same name,
Top
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.AddDynValue Method

DispatchingUserDataDescriptorAddDynValue Method
Adds a DynValue as a member

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void AddDynValue(
    string name,
    DynValue value
)
Public Sub AddDynValue (
    name As String,
    value As DynValue
)
public:
void AddDynValue(
    String^ name,
    DynValue^ value
)
member AddDynValue :
        name : string *
        value : DynValue -> unit

Parameters

name
Type: SystemString
The name.
value
Type: MoonSharp.InterpreterDynValue
The value.
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.AddMember Method

DispatchingUserDataDescriptorAddMember Method
Adds a property to the member list

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void AddMember(
    string name,
    IMemberDescriptor desc
)
Public Sub AddMember (
    name As String,
    desc As IMemberDescriptor
)
public:
void AddMember(
    String^ name,
    IMemberDescriptor^ desc
)
member AddMember :
        name : string *
        desc : IMemberDescriptor -> unit

Parameters

name
Type: SystemString
The name.
desc
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsIMemberDescriptor
The descriptor.
Exceptions
Exception | Condition
ArgumentException | Thrown if a name conflict is detected and one of the conflicting members does not support overloads.
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.AddMetaMember Method

DispatchingUserDataDescriptorAddMetaMember Method
Adds a member to the meta-members list.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void AddMetaMember(
    string name,
    IMemberDescriptor desc
)
Public Sub AddMetaMember (
    name As String,
    desc As IMemberDescriptor
)
public:
void AddMetaMember(
    String^ name,
    IMemberDescriptor^ desc
)
member AddMetaMember :
        name : string *
        desc : IMemberDescriptor -> unit

Parameters

name
Type: SystemString
The name of the metamethod.
desc
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsIMemberDescriptor
The desc.
Exceptions
Exception | Condition
ArgumentException | Thrown if a name conflict is detected and one of the conflicting members does not support overloads.
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.AsString Method

DispatchingUserDataDescriptorAsString Method
Converts this userdata to string

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string AsString(
    Object obj
)
Public Overridable Function AsString (
    obj As Object
) As String
public:
virtual String^ AsString(
    Object^ obj
)
abstract AsString :
        obj : Object -> string
override AsString :
        obj : Object -> string

Parameters

obj
Type: SystemObject
The object.

Return Value

Type: String

Implements

IUserDataDescriptorAsString(Object)
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.Camelify Method

DispatchingUserDataDescriptorCamelify Method
Converts the specified name from underscore_case to camelCase. Just a wrapper over the DescriptorHelpers method with the same name,

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static string Camelify(
    string name
)
Protected Shared Function Camelify (
    name As String
) As String
protected:
static String^ Camelify(
    String^ name
)
static member Camelify :
        name : string -> string

Parameters

name
Type: SystemString
The name.

Return Value

Type: String
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.ExecuteIndexer Method

DispatchingUserDataDescriptorExecuteIndexer Method
Executes the specified indexer method.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual DynValue ExecuteIndexer(
    IMemberDescriptor mdesc,
    Script script,
    Object obj,
    DynValue index,
    DynValue value
)
Protected Overridable Function ExecuteIndexer (
    mdesc As IMemberDescriptor,
    script As Script,
    obj As Object,
    index As DynValue,
    value As DynValue
) As DynValue
protected:
virtual DynValue^ ExecuteIndexer(
    IMemberDescriptor^ mdesc,
    Script^ script,
    Object^ obj,
    DynValue^ index,
    DynValue^ value
)
abstract ExecuteIndexer :
        mdesc : IMemberDescriptor *
        script : Script *
        obj : Object *
        index : DynValue *
        value : DynValue -> DynValue
override ExecuteIndexer :
        mdesc : IMemberDescriptor *
        script : Script *
        obj : Object *
        index : DynValue *
        value : DynValue -> DynValue

Parameters

mdesc
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsIMemberDescriptor
The method descriptor
script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object.
index
Type: MoonSharp.InterpreterDynValue
The indexer parameter
value
Type: MoonSharp.InterpreterDynValue
The dynvalue to set on a setter, or null.

Return Value

Type: DynValue
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.FindMember Method

DispatchingUserDataDescriptorFindMember Method
Finds the member with a given name. If not found, null is returned.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IMemberDescriptor FindMember(
    string memberName
)
Public Function FindMember (
    memberName As String
) As IMemberDescriptor
public:
IMemberDescriptor^ FindMember(
    String^ memberName
)
member FindMember :
        memberName : string -> IMemberDescriptor

Parameters

memberName
Type: SystemString
Name of the member.

Return Value

Type: IMemberDescriptor
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.FindMetaMember Method

DispatchingUserDataDescriptorFindMetaMember Method
Finds the meta member with a given name. If not found, null is returned.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IMemberDescriptor FindMetaMember(
    string memberName
)
Public Function FindMetaMember (
    memberName As String
) As IMemberDescriptor
public:
IMemberDescriptor^ FindMetaMember(
    String^ memberName
)
member FindMetaMember :
        memberName : string -> IMemberDescriptor

Parameters

memberName
Type: SystemString
Name of the member.

Return Value

Type: IMemberDescriptor
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.HasMember Method

DispatchingUserDataDescriptorHasMember Method
Determines whether the descriptor contains the specified member (by exact name)

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasMember(
    string exactName
)
Public Function HasMember (
    exactName As String
) As Boolean
public:
bool HasMember(
    String^ exactName
)
member HasMember :
        exactName : string -> bool

Parameters

exactName
Type: SystemString
Name of the member.

Return Value

Type: Boolean
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.HasMetaMember Method

DispatchingUserDataDescriptorHasMetaMember Method
Determines whether the descriptor contains the specified member in the meta list (by exact name)

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasMetaMember(
    string exactName
)
Public Function HasMetaMember (
    exactName As String
) As Boolean
public:
bool HasMetaMember(
    String^ exactName
)
member HasMetaMember :
        exactName : string -> bool

Parameters

exactName
Type: SystemString
Name of the meta-member.

Return Value

Type: Boolean
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.Index Method

DispatchingUserDataDescriptorIndex Method
Performs an "index" "get" operation. This tries to resolve minor variations of member names.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DynValue Index(
    Script script,
    Object obj,
    DynValue index,
    bool isDirectIndexing
)
Public Overridable Function Index (
    script As Script,
    obj As Object,
    index As DynValue,
    isDirectIndexing As Boolean
) As DynValue
public:
virtual DynValue^ Index(
    Script^ script,
    Object^ obj,
    DynValue^ index,
    bool isDirectIndexing
)
abstract Index :
        script : Script *
        obj : Object *
        index : DynValue *
        isDirectIndexing : bool -> DynValue
override Index :
        script : Script *
        obj : Object *
        index : DynValue *
        isDirectIndexing : bool -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script originating the request
obj
Type: SystemObject
The object (null if a static request is done)
index
Type: MoonSharp.InterpreterDynValue
The index.
isDirectIndexing
Type: SystemBoolean
If set to true, it's indexed with a name, if false it's indexed through brackets.

Return Value

Type: DynValue

Implements

IUserDataDescriptorIndex(Script, Object, DynValue, Boolean)
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.IsTypeCompatible Method

DispatchingUserDataDescriptorIsTypeCompatible Method
Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsTypeCompatible(
    Type type,
    Object obj
)
Public Overridable Function IsTypeCompatible (
    type As Type,
    obj As Object
) As Boolean
public:
virtual bool IsTypeCompatible(
    Type^ type,
    Object^ obj
)
abstract IsTypeCompatible :
        type : Type *
        obj : Object -> bool
override IsTypeCompatible :
        type : Type *
        obj : Object -> bool

Parameters

type
Type: SystemType
The type.
obj
Type: SystemObject
The object.

Return Value

Type: Boolean

Implements

IUserDataDescriptorIsTypeCompatible(Type, Object)
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.MetaIndex Method

DispatchingUserDataDescriptorMetaIndex Method
Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). See MetaIndex(Script, Object, String) for further details. If a method exists marked with MoonSharpUserDataMetamethodAttribute for the specific metamethod requested, that method is returned. If the above fails, the following dispatching occur: __add, __sub, __mul, __div, __mod and __unm are dispatched to C# operator overloads (if they exist) __eq is dispatched to System.Object.Equals. __lt and __le are dispatched IComparable.Compare, if the type implements IComparable or IComparable{object} __len is dispatched to Length and Count properties, if those exist. __iterator is handled if the object implements IEnumerable or IEnumerator. __tonumber is dispatched to implicit or explicit conversion operators to standard numeric types. __tobool is dispatched to an implicit or explicit conversion operator to bool. If that fails, operator true is used. The script originating the requestThe object (null if a static request is done)The name of the metamember.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DynValue MetaIndex(
    Script script,
    Object obj,
    string metaname
)
Public Overridable Function MetaIndex (
    script As Script,
    obj As Object,
    metaname As String
) As DynValue
public:
virtual DynValue^ MetaIndex(
    Script^ script,
    Object^ obj,
    String^ metaname
)
abstract MetaIndex :
        script : Script *
        obj : Object *
        metaname : string -> DynValue
override MetaIndex :
        script : Script *
        obj : Object *
        metaname : string -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript

[Missing <param name="script"/> documentation for "M:MoonSharp.Interpreter.Interop.BasicDescriptors.DispatchingUserDataDescriptor.MetaIndex(MoonSharp.Interpreter.Script,System.Object,System.String)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:MoonSharp.Interpreter.Interop.BasicDescriptors.DispatchingUserDataDescriptor.MetaIndex(MoonSharp.Interpreter.Script,System.Object,System.String)"]

metaname
Type: SystemString

[Missing <param name="metaname"/> documentation for "M:MoonSharp.Interpreter.Interop.BasicDescriptors.DispatchingUserDataDescriptor.MetaIndex(MoonSharp.Interpreter.Script,System.Object,System.String)"]

Return Value

Type: DynValue

Implements

IUserDataDescriptorMetaIndex(Script, Object, String)
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.RemoveMember Method

DispatchingUserDataDescriptorRemoveMember Method
Removes the member with a given name. In case of overloaded functions, all overloads are removed.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveMember(
    string memberName
)
Public Sub RemoveMember (
    memberName As String
)
public:
void RemoveMember(
    String^ memberName
)
member RemoveMember :
        memberName : string -> unit

Parameters

memberName
Type: SystemString
Name of the member.
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.RemoveMetaMember Method

DispatchingUserDataDescriptorRemoveMetaMember Method
Removes the meta member with a given name. In case of overloaded functions, all overloads are removed.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void RemoveMetaMember(
    string memberName
)
Public Sub RemoveMetaMember (
    memberName As String
)
public:
void RemoveMetaMember(
    String^ memberName
)
member RemoveMetaMember :
        memberName : string -> unit

Parameters

memberName
Type: SystemString
Name of the member.
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.SetIndex Method

DispatchingUserDataDescriptorSetIndex Method
Performs an "index" "set" operation. This tries to resolve minor variations of member names.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool SetIndex(
    Script script,
    Object obj,
    DynValue index,
    DynValue value,
    bool isDirectIndexing
)
Public Overridable Function SetIndex (
    script As Script,
    obj As Object,
    index As DynValue,
    value As DynValue,
    isDirectIndexing As Boolean
) As Boolean
public:
virtual bool SetIndex(
    Script^ script,
    Object^ obj,
    DynValue^ index,
    DynValue^ value,
    bool isDirectIndexing
)
abstract SetIndex :
        script : Script *
        obj : Object *
        index : DynValue *
        value : DynValue *
        isDirectIndexing : bool -> bool
override SetIndex :
        script : Script *
        obj : Object *
        index : DynValue *
        value : DynValue *
        isDirectIndexing : bool -> bool

Parameters

script
Type: MoonSharp.InterpreterScript
The script originating the request
obj
Type: SystemObject
The object (null if a static request is done)
index
Type: MoonSharp.InterpreterDynValue
The index.
value
Type: MoonSharp.InterpreterDynValue
The value to be set
isDirectIndexing
Type: SystemBoolean
If set to true, it's indexed with a name, if false it's indexed through brackets.

Return Value

Type: Boolean

Implements

IUserDataDescriptorSetIndex(Script, Object, DynValue, DynValue, Boolean)
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.TryIndex Method

DispatchingUserDataDescriptorTryIndex Method
Tries to perform an indexing operation by checking methods and properties for the given indexName

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual DynValue TryIndex(
    Script script,
    Object obj,
    string indexName
)
Protected Overridable Function TryIndex (
    script As Script,
    obj As Object,
    indexName As String
) As DynValue
protected:
virtual DynValue^ TryIndex(
    Script^ script,
    Object^ obj,
    String^ indexName
)
abstract TryIndex :
        script : Script *
        obj : Object *
        indexName : string -> DynValue
override TryIndex :
        script : Script *
        obj : Object *
        indexName : string -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object.
indexName
Type: SystemString
Member name to be indexed.

Return Value

Type: DynValue
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.TrySetIndex Method

DispatchingUserDataDescriptorTrySetIndex Method
Tries to perform an indexing "set" operation by checking methods and properties for the given indexName

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual bool TrySetIndex(
    Script script,
    Object obj,
    string indexName,
    DynValue value
)
Protected Overridable Function TrySetIndex (
    script As Script,
    obj As Object,
    indexName As String,
    value As DynValue
) As Boolean
protected:
virtual bool TrySetIndex(
    Script^ script,
    Object^ obj,
    String^ indexName,
    DynValue^ value
)
abstract TrySetIndex :
        script : Script *
        obj : Object *
        indexName : string *
        value : DynValue -> bool
override TrySetIndex :
        script : Script *
        obj : Object *
        indexName : string *
        value : DynValue -> bool

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object.
indexName
Type: SystemString
Member name to be indexed.
value
Type: MoonSharp.InterpreterDynValue
The value.

Return Value

Type: Boolean
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.UpperFirstLetter Method

DispatchingUserDataDescriptorUpperFirstLetter Method
Converts the specified name to one with an uppercase first letter (something to Something). Just a wrapper over the DescriptorHelpers method with the same name,

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static string UpperFirstLetter(
    string name
)
Protected Shared Function UpperFirstLetter (
    name As String
) As String
protected:
static String^ UpperFirstLetter(
    String^ name
)
static member UpperFirstLetter :
        name : string -> string

Parameters

name
Type: SystemString
The name.

Return Value

Type: String
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor Fields

DispatchingUserDataDescriptor Fields

The DispatchingUserDataDescriptor type exposes the following members.

Fields
Name | Description
SPECIALNAME_CAST_EXPLICIT | The special name used by CLR for explicit cast conversions
SPECIALNAME_CAST_IMPLICIT | The special name used by CLR for implicit cast conversions
SPECIALNAME_INDEXER_GET | The special name used by CLR for indexer getters
SPECIALNAME_INDEXER_SET | The special name used by CLR for indexer setters
Top
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.SPECIALNAME_CAST_EXPLICIT Field

DispatchingUserDataDescriptorSPECIALNAME_CAST_EXPLICIT Field
The special name used by CLR for explicit cast conversions

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected const string SPECIALNAME_CAST_EXPLICIT = "op_Explicit"
Protected Const SPECIALNAME_CAST_EXPLICIT As String = "op_Explicit"
protected:
literal String^ SPECIALNAME_CAST_EXPLICIT = "op_Explicit"
static val mutable SPECIALNAME_CAST_EXPLICIT: string

Field Value

Type: String
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.SPECIALNAME_CAST_IMPLICIT Field

DispatchingUserDataDescriptorSPECIALNAME_CAST_IMPLICIT Field
The special name used by CLR for implicit cast conversions

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected const string SPECIALNAME_CAST_IMPLICIT = "op_Implicit"
Protected Const SPECIALNAME_CAST_IMPLICIT As String = "op_Implicit"
protected:
literal String^ SPECIALNAME_CAST_IMPLICIT = "op_Implicit"
static val mutable SPECIALNAME_CAST_IMPLICIT: string

Field Value

Type: String
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.SPECIALNAME_INDEXER_GET Field

DispatchingUserDataDescriptorSPECIALNAME_INDEXER_GET Field
The special name used by CLR for indexer getters

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected const string SPECIALNAME_INDEXER_GET = "get_Item"
Protected Const SPECIALNAME_INDEXER_GET As String = "get_Item"
protected:
literal String^ SPECIALNAME_INDEXER_GET = "get_Item"
static val mutable SPECIALNAME_INDEXER_GET: string

Field Value

Type: String
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


DispatchingUserDataDescriptor.SPECIALNAME_INDEXER_SET Field

DispatchingUserDataDescriptorSPECIALNAME_INDEXER_SET Field
The special name used by CLR for indexer setters

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected const string SPECIALNAME_INDEXER_SET = "set_Item"
Protected Const SPECIALNAME_INDEXER_SET As String = "set_Item"
protected:
literal String^ SPECIALNAME_INDEXER_SET = "set_Item"
static val mutable SPECIALNAME_INDEXER_SET: string

Field Value

Type: String
See Also

Reference

DispatchingUserDataDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IMemberDescriptor Interface

IMemberDescriptor Interface
Base interface to describe access to members of a given type. While it's not infrastructural to implement custom type descriptors, it's needed for classes extending DispatchingUserDataDescriptor.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public interface IMemberDescriptor
Public Interface IMemberDescriptor
public interface class IMemberDescriptor
type IMemberDescriptor =  interface end

The IMemberDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | IsStatic | Gets a value indicating whether the described member is static.
Public property | MemberAccess | Gets the types of access supported by this member
Public property | Name | Gets the name of the member
Top
Methods
 | Name | Description
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts. Implementors should raise exceptions if the value cannot be read or if access to an instance member through a static userdata is attempted.
Public method | SetValue | Sets the value of this member from a DynValue. Implementors should raise exceptions if the value cannot be read or if access to an instance member through a static userdata is attempted.
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IMemberDescriptor Properties

IMemberDescriptor Properties

The IMemberDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | IsStatic | Gets a value indicating whether the described member is static.
Public property | MemberAccess | Gets the types of access supported by this member
Public property | Name | Gets the name of the member
Top
See Also

Reference

IMemberDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IMemberDescriptor.IsStatic Property

IMemberDescriptorIsStatic Property
Gets a value indicating whether the described member is static.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
bool IsStatic { get; }
ReadOnly Property IsStatic As Boolean
    Get
property bool IsStatic {
    bool get ();
}
abstract IsStatic : bool with get

Property Value

Type: Boolean
See Also

Reference

IMemberDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IMemberDescriptor.MemberAccess Property

IMemberDescriptorMemberAccess Property
Gets the types of access supported by this member

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
MemberDescriptorAccess MemberAccess { get; }
ReadOnly Property MemberAccess As MemberDescriptorAccess
    Get
property MemberDescriptorAccess MemberAccess {
    MemberDescriptorAccess get ();
}
abstract MemberAccess : MemberDescriptorAccess with get

Property Value

Type: MemberDescriptorAccess
See Also

Reference

IMemberDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IMemberDescriptor.Name Property

IMemberDescriptorName Property
Gets the name of the member

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IMemberDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IMemberDescriptor Methods

IMemberDescriptor Methods

The IMemberDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts. Implementors should raise exceptions if the value cannot be read or if access to an instance member through a static userdata is attempted.
Public method | SetValue | Sets the value of this member from a DynValue. Implementors should raise exceptions if the value cannot be read or if access to an instance member through a static userdata is attempted.
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

IMemberDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IMemberDescriptor.GetValue Method

IMemberDescriptorGetValue Method
Gets the value of this member as a DynValue to be exposed to scripts. Implementors should raise exceptions if the value cannot be read or if access to an instance member through a static userdata is attempted.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
DynValue GetValue(
    Script script,
    Object obj
)
Function GetValue (
    script As Script,
    obj As Object
) As DynValue
DynValue^ GetValue(
    Script^ script,
    Object^ obj
)
abstract GetValue :
        script : Script *
        obj : Object -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object owning this member, or null if static.

Return Value

Type: DynValue
The value of this member as a DynValue.
See Also

Reference

IMemberDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IMemberDescriptor.SetValue Method

IMemberDescriptorSetValue Method
Sets the value of this member from a DynValue. Implementors should raise exceptions if the value cannot be read or if access to an instance member through a static userdata is attempted.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
void SetValue(
    Script script,
    Object obj,
    DynValue value
)
Sub SetValue (
    script As Script,
    obj As Object,
    value As DynValue
)
void SetValue(
    Script^ script,
    Object^ obj,
    DynValue^ value
)
abstract SetValue :
        script : Script *
        obj : Object *
        value : DynValue -> unit

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object owning this member, or null if static.
value
Type: MoonSharp.InterpreterDynValue
The value to be set.
See Also

Reference

IMemberDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IOptimizableDescriptor Interface

IOptimizableDescriptor Interface
Interface for descriptors of any kind which support optimizations of their implementation according to InteropAccessMode modes. This should seldom - if ever - be implemented in user code.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public interface IOptimizableDescriptor
Public Interface IOptimizableDescriptor
public interface class IOptimizableDescriptor
type IOptimizableDescriptor =  interface end

The IOptimizableDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Optimize | Called by standard descriptors when background optimization or preoptimization needs to be performed.
Top
See Also

Reference

MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IOptimizableDescriptor Methods

IOptimizableDescriptor Methods

The IOptimizableDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Optimize | Called by standard descriptors when background optimization or preoptimization needs to be performed.
Top
See Also

Reference

IOptimizableDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IOptimizableDescriptor.Optimize Method

IOptimizableDescriptorOptimize Method
Called by standard descriptors when background optimization or preoptimization needs to be performed.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
void Optimize()
Sub Optimize
void Optimize()
abstract Optimize : unit -> unit
See Also

Reference

IOptimizableDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IOverloadableMemberDescriptor Interface

IOverloadableMemberDescriptor Interface
Specialized IMemberDescriptor for members supporting overloads resolution.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public interface IOverloadableMemberDescriptor : IMemberDescriptor
Public Interface IOverloadableMemberDescriptor
    Inherits IMemberDescriptor
public interface class IOverloadableMemberDescriptor : IMemberDescriptor
type IOverloadableMemberDescriptor =
    interface
        interface IMemberDescriptor
    end

The IOverloadableMemberDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionMethodType | Gets the type which this extension method extends, null if this is not an extension method.
Public property | IsStatic | Gets a value indicating whether the described member is static. (Inherited from IMemberDescriptor.)
Public property | MemberAccess | Gets the types of access supported by this member (Inherited from IMemberDescriptor.)
Public property | Name | Gets the name of the member (Inherited from IMemberDescriptor.)
Public property | Parameters | Gets the type of the arguments of the underlying CLR function
Public property | SortDiscriminant | Gets a sort discriminant to give consistent overload resolution matching in case of perfectly equal scores
Public property | VarArgsArrayType | Gets a value indicating the type of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned.
Public property | VarArgsElementType | Gets a value indicating the type of the elements of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned.
Top
Methods
 | Name | Description
Public method | Execute | Invokes the member from script. Implementors should raise exceptions if the value cannot be executed or if access to an instance member through a static userdata is attempted.
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts. Implementors should raise exceptions if the value cannot be read or if access to an instance member through a static userdata is attempted. (Inherited from IMemberDescriptor.)
Public method | SetValue | Sets the value of this member from a DynValue. Implementors should raise exceptions if the value cannot be read or if access to an instance member through a static userdata is attempted. (Inherited from IMemberDescriptor.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IOverloadableMemberDescriptor Properties

IOverloadableMemberDescriptor Properties

The IOverloadableMemberDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionMethodType | Gets the type which this extension method extends, null if this is not an extension method.
Public property | IsStatic | Gets a value indicating whether the described member is static. (Inherited from IMemberDescriptor.)
Public property | MemberAccess | Gets the types of access supported by this member (Inherited from IMemberDescriptor.)
Public property | Name | Gets the name of the member (Inherited from IMemberDescriptor.)
Public property | Parameters | Gets the type of the arguments of the underlying CLR function
Public property | SortDiscriminant | Gets a sort discriminant to give consistent overload resolution matching in case of perfectly equal scores
Public property | VarArgsArrayType | Gets a value indicating the type of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned.
Public property | VarArgsElementType | Gets a value indicating the type of the elements of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned.
Top
See Also

Reference

IOverloadableMemberDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IOverloadableMemberDescriptor.ExtensionMethodType Property

IOverloadableMemberDescriptorExtensionMethodType Property
Gets the type which this extension method extends, null if this is not an extension method.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
Type ExtensionMethodType { get; }
ReadOnly Property ExtensionMethodType As Type
    Get
property Type^ ExtensionMethodType {
    Type^ get ();
}
abstract ExtensionMethodType : Type with get

Property Value

Type: Type
See Also

Reference

IOverloadableMemberDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IOverloadableMemberDescriptor.Parameters Property

IOverloadableMemberDescriptorParameters Property
Gets the type of the arguments of the underlying CLR function

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
ParameterDescriptor[] Parameters { get; }
ReadOnly Property Parameters As ParameterDescriptor()
    Get
property array<ParameterDescriptor^>^ Parameters {
    array<ParameterDescriptor^>^ get ();
}
abstract Parameters : ParameterDescriptor[] with get

Property Value

Type: ParameterDescriptor
See Also

Reference

IOverloadableMemberDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IOverloadableMemberDescriptor.SortDiscriminant Property

IOverloadableMemberDescriptorSortDiscriminant Property
Gets a sort discriminant to give consistent overload resolution matching in case of perfectly equal scores

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
string SortDiscriminant { get; }
ReadOnly Property SortDiscriminant As String
    Get
property String^ SortDiscriminant {
    String^ get ();
}
abstract SortDiscriminant : string with get

Property Value

Type: String
See Also

Reference

IOverloadableMemberDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IOverloadableMemberDescriptor.VarArgsArrayType Property

IOverloadableMemberDescriptorVarArgsArrayType Property
Gets a value indicating the type of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
Type VarArgsArrayType { get; }
ReadOnly Property VarArgsArrayType As Type
    Get
property Type^ VarArgsArrayType {
    Type^ get ();
}
abstract VarArgsArrayType : Type with get

Property Value

Type: Type
See Also

Reference

IOverloadableMemberDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IOverloadableMemberDescriptor.VarArgsElementType Property

IOverloadableMemberDescriptorVarArgsElementType Property
Gets a value indicating the type of the elements of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
Type VarArgsElementType { get; }
ReadOnly Property VarArgsElementType As Type
    Get
property Type^ VarArgsElementType {
    Type^ get ();
}
abstract VarArgsElementType : Type with get

Property Value

Type: Type
See Also

Reference

IOverloadableMemberDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IOverloadableMemberDescriptor Methods

IOverloadableMemberDescriptor Methods

The IOverloadableMemberDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Execute | Invokes the member from script. Implementors should raise exceptions if the value cannot be executed or if access to an instance member through a static userdata is attempted.
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts. Implementors should raise exceptions if the value cannot be read or if access to an instance member through a static userdata is attempted. (Inherited from IMemberDescriptor.)
Public method | SetValue | Sets the value of this member from a DynValue. Implementors should raise exceptions if the value cannot be read or if access to an instance member through a static userdata is attempted. (Inherited from IMemberDescriptor.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

IOverloadableMemberDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IOverloadableMemberDescriptor.Execute Method

IOverloadableMemberDescriptorExecute Method
Invokes the member from script. Implementors should raise exceptions if the value cannot be executed or if access to an instance member through a static userdata is attempted.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
DynValue Execute(
    Script script,
    Object obj,
    ScriptExecutionContext context,
    CallbackArguments args
)
Function Execute (
    script As Script,
    obj As Object,
    context As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
DynValue^ Execute(
    Script^ script,
    Object^ obj,
    ScriptExecutionContext^ context,
    CallbackArguments^ args
)
abstract Execute :
        script : Script *
        obj : Object *
        context : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object.
context
Type: MoonSharp.InterpreterScriptExecutionContext
The context.
args
Type: MoonSharp.InterpreterCallbackArguments
The arguments.

Return Value

Type: DynValue
See Also

Reference

IOverloadableMemberDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IWireableDescriptor Interface

IWireableDescriptor Interface
Interface for descriptors with the capability of being serialized for later hardwiring.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public interface IWireableDescriptor
Public Interface IWireableDescriptor
public interface class IWireableDescriptor
type IWireableDescriptor =  interface end

The IWireableDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | PrepareForWiring | Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.
Top
See Also

Reference

MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IWireableDescriptor Methods

IWireableDescriptor Methods

The IWireableDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | PrepareForWiring | Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.
Top
See Also

Reference

IWireableDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


IWireableDescriptor.PrepareForWiring Method

IWireableDescriptorPrepareForWiring Method
Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
void PrepareForWiring(
    Table t
)
Sub PrepareForWiring (
    t As Table
)
void PrepareForWiring(
    Table^ t
)
abstract PrepareForWiring :
        t : Table -> unit

Parameters

t
Type: MoonSharp.InterpreterTable
The table to be filled
See Also

Reference

IWireableDescriptor Interface
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


MemberDescriptor Class

MemberDescriptor Class
Extension methods for IMemberDescriptor and MemberDescriptorAccess .
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.Interop.BasicDescriptorsMemberDescriptor

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static class MemberDescriptor
<ExtensionAttribute>
Public NotInheritable Class MemberDescriptor
[ExtensionAttribute]
public ref class MemberDescriptor abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type MemberDescriptor =  class end

The MemberDescriptor type exposes the following members.

Methods
Name | Description
CanExecute | Determines whether this instance can be executed (called as a function)
CanRead | Determines whether this instance can be read
CanWrite | Determines whether this instance can be written to
CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas.
GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback
HasAllFlags | Determines whether the specified MemberDescriptorAccess has ALL the specified flags.
WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null.
Top
See Also

Reference

MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


MemberDescriptor Methods

MemberDescriptor Methods

The MemberDescriptor type exposes the following members.

Methods
Name | Description
CanExecute | Determines whether this instance can be executed (called as a function)
CanRead | Determines whether this instance can be read
CanWrite | Determines whether this instance can be written to
CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas.
GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback
HasAllFlags | Determines whether the specified MemberDescriptorAccess has ALL the specified flags.
WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null.
Top
See Also

Reference

MemberDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


MemberDescriptor.CanExecute Method

MemberDescriptorCanExecute Method
Determines whether this instance can be executed (called as a function)

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanExecute(
    this IMemberDescriptor desc
)
<ExtensionAttribute>
Public Shared Function CanExecute (
    desc As IMemberDescriptor
) As Boolean
public:
[ExtensionAttribute]
static bool CanExecute(
    IMemberDescriptor^ desc
)
[<ExtensionAttribute>]
static member CanExecute :
        desc : IMemberDescriptor -> bool

Parameters

desc
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsIMemberDescriptor
The descriptor instance.

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMemberDescriptor. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MemberDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


MemberDescriptor.CanRead Method

MemberDescriptorCanRead Method
Determines whether this instance can be read

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanRead(
    this IMemberDescriptor desc
)
<ExtensionAttribute>
Public Shared Function CanRead (
    desc As IMemberDescriptor
) As Boolean
public:
[ExtensionAttribute]
static bool CanRead(
    IMemberDescriptor^ desc
)
[<ExtensionAttribute>]
static member CanRead :
        desc : IMemberDescriptor -> bool

Parameters

desc
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsIMemberDescriptor
The descriptor instance.

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMemberDescriptor. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MemberDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


MemberDescriptor.CanWrite Method

MemberDescriptorCanWrite Method
Determines whether this instance can be written to

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CanWrite(
    this IMemberDescriptor desc
)
<ExtensionAttribute>
Public Shared Function CanWrite (
    desc As IMemberDescriptor
) As Boolean
public:
[ExtensionAttribute]
static bool CanWrite(
    IMemberDescriptor^ desc
)
[<ExtensionAttribute>]
static member CanWrite :
        desc : IMemberDescriptor -> bool

Parameters

desc
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsIMemberDescriptor
The descriptor instance.

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMemberDescriptor. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MemberDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


MemberDescriptor.CheckAccess Method

MemberDescriptorCheckAccess Method
Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static void CheckAccess(
    this IMemberDescriptor desc,
    MemberDescriptorAccess access,
    Object obj
)
<ExtensionAttribute>
Public Shared Sub CheckAccess (
    desc As IMemberDescriptor,
    access As MemberDescriptorAccess,
    obj As Object
)
public:
[ExtensionAttribute]
static void CheckAccess(
    IMemberDescriptor^ desc,
    MemberDescriptorAccess access,
    Object^ obj
)
[<ExtensionAttribute>]
static member CheckAccess :
        desc : IMemberDescriptor *
        access : MemberDescriptorAccess *
        obj : Object -> unit

Parameters

desc
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsIMemberDescriptor
The desc.
access
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsMemberDescriptorAccess
The access.
obj
Type: SystemObject
The object to be checked for access.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMemberDescriptor. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MemberDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


MemberDescriptor.GetGetterCallbackAsDynValue Method

MemberDescriptorGetGetterCallbackAsDynValue Method
Gets the getter of the member as a DynValue containing a callback

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue GetGetterCallbackAsDynValue(
    this IMemberDescriptor desc,
    Script script,
    Object obj
)
<ExtensionAttribute>
Public Shared Function GetGetterCallbackAsDynValue (
    desc As IMemberDescriptor,
    script As Script,
    obj As Object
) As DynValue
public:
[ExtensionAttribute]
static DynValue^ GetGetterCallbackAsDynValue(
    IMemberDescriptor^ desc,
    Script^ script,
    Object^ obj
)
[<ExtensionAttribute>]
static member GetGetterCallbackAsDynValue :
        desc : IMemberDescriptor *
        script : Script *
        obj : Object -> DynValue

Parameters

desc
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsIMemberDescriptor
The descriptor instance.
script
Type: MoonSharp.InterpreterScript
The script.
obj
Type: SystemObject
The object.

Return Value

Type: DynValue

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMemberDescriptor. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MemberDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


MemberDescriptor.HasAllFlags Method

MemberDescriptorHasAllFlags Method
Determines whether the specified MemberDescriptorAccess has ALL the specified flags.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool HasAllFlags(
    this MemberDescriptorAccess access,
    MemberDescriptorAccess flag
)
<ExtensionAttribute>
Public Shared Function HasAllFlags (
    access As MemberDescriptorAccess,
    flag As MemberDescriptorAccess
) As Boolean
public:
[ExtensionAttribute]
static bool HasAllFlags(
    MemberDescriptorAccess access,
    MemberDescriptorAccess flag
)
[<ExtensionAttribute>]
static member HasAllFlags :
        access : MemberDescriptorAccess *
        flag : MemberDescriptorAccess -> bool

Parameters

access
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsMemberDescriptorAccess
The access.
flag
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsMemberDescriptorAccess
The flag.

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type MemberDescriptorAccess. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MemberDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


MemberDescriptor.WithAccessOrNull Method

MemberDescriptorWithAccessOrNull Method
Returns the specified descriptor if it supports all the specified access modes, otherwise returns null.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static IMemberDescriptor WithAccessOrNull(
    this IMemberDescriptor desc,
    MemberDescriptorAccess access
)
<ExtensionAttribute>
Public Shared Function WithAccessOrNull (
    desc As IMemberDescriptor,
    access As MemberDescriptorAccess
) As IMemberDescriptor
public:
[ExtensionAttribute]
static IMemberDescriptor^ WithAccessOrNull(
    IMemberDescriptor^ desc,
    MemberDescriptorAccess access
)
[<ExtensionAttribute>]
static member WithAccessOrNull :
        desc : IMemberDescriptor *
        access : MemberDescriptorAccess -> IMemberDescriptor

Parameters

desc
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsIMemberDescriptor
The descriptor instance.
access
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsMemberDescriptorAccess
The access mode(s).

Return Value

Type: IMemberDescriptor

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMemberDescriptor. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MemberDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


MemberDescriptorAccess Enumeration

MemberDescriptorAccess Enumeration
Permissions for members access

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum MemberDescriptorAccess
<FlagsAttribute>
Public Enumeration MemberDescriptorAccess
[FlagsAttribute]
public enum class MemberDescriptorAccess
[<FlagsAttribute>]
type MemberDescriptorAccess
Members
Member name | Value | Description
CanRead | 1 | The member can be read from
CanWrite | 2 | The member can be written to
CanExecute | 4 | The can be invoked
See Also

Reference

MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor Class

ParameterDescriptor Class
Descriptor of parameters used in IOverloadableMemberDescriptor implementations.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.Interop.BasicDescriptorsParameterDescriptor

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ParameterDescriptor : IWireableDescriptor
Public NotInheritable Class ParameterDescriptor
    Implements IWireableDescriptor
public ref class ParameterDescriptor sealed : IWireableDescriptor
[<SealedAttribute>]
type ParameterDescriptor =
    class
        interface IWireableDescriptor
    end

The ParameterDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | ParameterDescriptor(ParameterInfo) | Initializes a new instance of the ParameterDescriptor class.
Public method | ParameterDescriptor(String, Type, Boolean, Object, Boolean, Boolean, Boolean) | Initializes a new instance of the ParameterDescriptor class.
Public method | ParameterDescriptor(String, Type, Boolean, Object, Boolean, Boolean, Boolean, Type) | Initializes a new instance of the ParameterDescriptor class.
Top
Properties
 | Name | Description
Public property | DefaultValue | Gets the default value
Public property | HasBeenRestricted | Gets a value indicating whether this instance has been restricted.
Public property | HasDefaultValue | Gets a value indicating whether this instance has a default value.
Public property | IsOut | Gets a value indicating whether this instance is an out parameter
Public property | IsRef | Gets a value indicating whether this instance is a "ref" parameter
Public property | IsVarArgs | Gets a value indicating whether this instance is a variable arguments param
Public property | Name | Gets the name of the parameter
Public property | OriginalType | Gets the original type of the parameter before any restriction has been applied.
Public property | Type | Gets the type of the parameter
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PrepareForWiring | Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.
Public method | RestrictType | Restricts the type of this parameter to a tighter constraint. Restrictions must be applied before the IOverloadableMemberDescriptor containing this parameter is used in any way.
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor Constructor

ParameterDescriptor Constructor
Overload List
 | Name | Description
Public method | ParameterDescriptor(ParameterInfo) | Initializes a new instance of the ParameterDescriptor class.
Public method | ParameterDescriptor(String, Type, Boolean, Object, Boolean, Boolean, Boolean) | Initializes a new instance of the ParameterDescriptor class.
Public method | ParameterDescriptor(String, Type, Boolean, Object, Boolean, Boolean, Boolean, Type) | Initializes a new instance of the ParameterDescriptor class.
Top
See Also

Reference

ParameterDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor Constructor (ParameterInfo)

ParameterDescriptor Constructor (ParameterInfo)
Initializes a new instance of the ParameterDescriptor class.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterDescriptor(
    ParameterInfo pi
)
Public Sub New (
    pi As ParameterInfo
)
public:
ParameterDescriptor(
    ParameterInfo^ pi
)
new :
        pi : ParameterInfo -> ParameterDescriptor

Parameters

pi
Type: System.ReflectionParameterInfo
A ParameterInfo taken from reflection.
See Also

Reference

ParameterDescriptor Class
ParameterDescriptor Overload
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor Constructor (String, Type, Boolean, Object, Boolean, Boolean, Boolean)

ParameterDescriptor Constructor (String, Type, Boolean, Object, Boolean, Boolean, Boolean)
Initializes a new instance of the ParameterDescriptor class.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterDescriptor(
    string name,
    Type type,
    bool hasDefaultValue = false,
    Object defaultValue = null,
    bool isOut = false,
    bool isRef = false,
    bool isVarArgs = false
)
Public Sub New (
    name As String,
    type As Type,
    Optional hasDefaultValue As Boolean = false,
    Optional defaultValue As Object = Nothing,
    Optional isOut As Boolean = false,
    Optional isRef As Boolean = false,
    Optional isVarArgs As Boolean = false
)
public:
ParameterDescriptor(
    String^ name,
    Type^ type,
    bool hasDefaultValue = false,
    Object^ defaultValue = nullptr,
    bool isOut = false,
    bool isRef = false,
    bool isVarArgs = false
)
new :
        name : string *
        type : Type *
        ?hasDefaultValue : bool *
        ?defaultValue : Object *
        ?isOut : bool *
        ?isRef : bool *
        ?isVarArgs : bool
(* Defaults:
        let _hasDefaultValue = defaultArg hasDefaultValue false
        let _defaultValue = defaultArg defaultValue null
        let _isOut = defaultArg isOut false
        let _isRef = defaultArg isRef false
        let _isVarArgs = defaultArg isVarArgs false
*)
-> ParameterDescriptor

Parameters

name
Type: SystemString
The name.
type
Type: SystemType
The type.
hasDefaultValue (Optional)
Type: SystemBoolean
if set to true the parameter has default value.
defaultValue (Optional)
Type: SystemObject
The default value.
isOut (Optional)
Type: SystemBoolean
if set to true, is an out param.
isRef (Optional)
Type: SystemBoolean
if set to true is a ref param.
isVarArgs (Optional)
Type: SystemBoolean
if set to true is variable arguments param.
See Also

Reference

ParameterDescriptor Class
ParameterDescriptor Overload
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor Constructor (String, Type, Boolean, Object, Boolean, Boolean, Boolean, Type)

ParameterDescriptor Constructor (String, Type, Boolean, Object, Boolean, Boolean, Boolean, Type)
Initializes a new instance of the ParameterDescriptor class.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ParameterDescriptor(
    string name,
    Type type,
    bool hasDefaultValue,
    Object defaultValue,
    bool isOut,
    bool isRef,
    bool isVarArgs,
    Type typeRestriction
)
Public Sub New (
    name As String,
    type As Type,
    hasDefaultValue As Boolean,
    defaultValue As Object,
    isOut As Boolean,
    isRef As Boolean,
    isVarArgs As Boolean,
    typeRestriction As Type
)
public:
ParameterDescriptor(
    String^ name,
    Type^ type,
    bool hasDefaultValue,
    Object^ defaultValue,
    bool isOut,
    bool isRef,
    bool isVarArgs,
    Type^ typeRestriction
)
new :
        name : string *
        type : Type *
        hasDefaultValue : bool *
        defaultValue : Object *
        isOut : bool *
        isRef : bool *
        isVarArgs : bool *
        typeRestriction : Type -> ParameterDescriptor

Parameters

name
Type: SystemString
The name.
type
Type: SystemType
The type.
hasDefaultValue
Type: SystemBoolean
if set to true the parameter has default value.
defaultValue
Type: SystemObject
The default value.
isOut
Type: SystemBoolean
if set to true, is an out param.
isRef
Type: SystemBoolean
if set to true is a ref param.
isVarArgs
Type: SystemBoolean
if set to true is variable arguments param.
typeRestriction
Type: SystemType
The type restriction, or nll.
See Also

Reference

ParameterDescriptor Class
ParameterDescriptor Overload
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor Properties

ParameterDescriptor Properties

The ParameterDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Gets the default value
Public property | HasBeenRestricted | Gets a value indicating whether this instance has been restricted.
Public property | HasDefaultValue | Gets a value indicating whether this instance has a default value.
Public property | IsOut | Gets a value indicating whether this instance is an out parameter
Public property | IsRef | Gets a value indicating whether this instance is a "ref" parameter
Public property | IsVarArgs | Gets a value indicating whether this instance is a variable arguments param
Public property | Name | Gets the name of the parameter
Public property | OriginalType | Gets the original type of the parameter before any restriction has been applied.
Public property | Type | Gets the type of the parameter
Top
See Also

Reference

ParameterDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor.DefaultValue Property

ParameterDescriptorDefaultValue Property
Gets the default value

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Object DefaultValue { get; }
Public ReadOnly Property DefaultValue As Object
    Get
public:
property Object^ DefaultValue {
    Object^ get ();
}
member DefaultValue : Object with get

Property Value

Type: Object
See Also

Reference

ParameterDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor.HasBeenRestricted Property

ParameterDescriptorHasBeenRestricted Property
Gets a value indicating whether this instance has been restricted.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasBeenRestricted { get; }
Public ReadOnly Property HasBeenRestricted As Boolean
    Get
public:
property bool HasBeenRestricted {
    bool get ();
}
member HasBeenRestricted : bool with get

Property Value

Type: Boolean
See Also

Reference

ParameterDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor.HasDefaultValue Property

ParameterDescriptorHasDefaultValue Property
Gets a value indicating whether this instance has a default value.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasDefaultValue { get; }
Public ReadOnly Property HasDefaultValue As Boolean
    Get
public:
property bool HasDefaultValue {
    bool get ();
}
member HasDefaultValue : bool with get

Property Value

Type: Boolean
See Also

Reference

ParameterDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor.IsOut Property

ParameterDescriptorIsOut Property
Gets a value indicating whether this instance is an out parameter

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOut { get; }
Public ReadOnly Property IsOut As Boolean
    Get
public:
property bool IsOut {
    bool get ();
}
member IsOut : bool with get

Property Value

Type: Boolean
See Also

Reference

ParameterDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor.IsRef Property

ParameterDescriptorIsRef Property
Gets a value indicating whether this instance is a "ref" parameter

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsRef { get; }
Public ReadOnly Property IsRef As Boolean
    Get
public:
property bool IsRef {
    bool get ();
}
member IsRef : bool with get

Property Value

Type: Boolean
See Also

Reference

ParameterDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor.IsVarArgs Property

ParameterDescriptorIsVarArgs Property
Gets a value indicating whether this instance is a variable arguments param

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsVarArgs { get; }
Public ReadOnly Property IsVarArgs As Boolean
    Get
public:
property bool IsVarArgs {
    bool get ();
}
member IsVarArgs : bool with get

Property Value

Type: Boolean
See Also

Reference

ParameterDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor.Name Property

ParameterDescriptorName Property
Gets the name of the parameter

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

ParameterDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor.OriginalType Property

ParameterDescriptorOriginalType Property
Gets the original type of the parameter before any restriction has been applied.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Type OriginalType { get; }
Public ReadOnly Property OriginalType As Type
    Get
public:
property Type^ OriginalType {
    Type^ get ();
}
member OriginalType : Type with get

Property Value

Type: Type
See Also

Reference

ParameterDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor.Type Property

ParameterDescriptorType Property
Gets the type of the parameter

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Type Type { get; }
Public ReadOnly Property Type As Type
    Get
public:
property Type^ Type {
    Type^ get ();
}
member Type : Type with get

Property Value

Type: Type
See Also

Reference

ParameterDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor Methods

ParameterDescriptor Methods

The ParameterDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PrepareForWiring | Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.
Public method | RestrictType | Restricts the type of this parameter to a tighter constraint. Restrictions must be applied before the IOverloadableMemberDescriptor containing this parameter is used in any way.
Public method | ToString | Returns a String that represents this instance. (Overrides ObjectToString.)
Top
See Also

Reference

ParameterDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor.PrepareForWiring Method

ParameterDescriptorPrepareForWiring Method
Prepares the descriptor for hard-wiring. The descriptor fills the passed table with all the needed data for hardwire generators to generate the appropriate code.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void PrepareForWiring(
    Table table
)
Public Sub PrepareForWiring (
    table As Table
)
public:
virtual void PrepareForWiring(
    Table^ table
) sealed
abstract PrepareForWiring :
        table : Table -> unit
override PrepareForWiring :
        table : Table -> unit

Parameters

table
Type: MoonSharp.InterpreterTable

[Missing <param name="table"/> documentation for "M:MoonSharp.Interpreter.Interop.BasicDescriptors.ParameterDescriptor.PrepareForWiring(MoonSharp.Interpreter.Table)"]

Implements

IWireableDescriptorPrepareForWiring(Table)
See Also

Reference

ParameterDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor.RestrictType Method

ParameterDescriptorRestrictType Method
Restricts the type of this parameter to a tighter constraint. Restrictions must be applied before the IOverloadableMemberDescriptor containing this parameter is used in any way.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void RestrictType(
    Type type
)
Public Sub RestrictType (
    type As Type
)
public:
void RestrictType(
    Type^ type
)
member RestrictType :
        type : Type -> unit

Parameters

type
Type: SystemType
The new type.
Exceptions
Exception | Condition
InvalidOperationException | Cannot restrict a ref/out or varargs param or Specified operation is not a restriction
See Also

Reference

ParameterDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


ParameterDescriptor.ToString Method

ParameterDescriptorToString Method
Returns a String that represents this instance.

Namespace: MoonSharp.Interpreter.Interop.BasicDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
A String that represents this instance.
See Also

Reference

ParameterDescriptor Class
MoonSharp.Interpreter.Interop.BasicDescriptors Namespace


MoonSharp.Interpreter.Interop.LuaStateInterop Namespace

MoonSharp.Interpreter.Interop.LuaStateInterop Namespace
Namespace containing classes used to provide a minimal support for porting code based on the classic "LuaState" model (e.g. code based on KopiLua, UniLua or Lua itself).
Classes
 | Class | Description
Public class | CharPtr |
Public class | LuaBase | Classes using the classic interface should inherit from this class. This class defines only static methods and is really meant to be used only from C# and not other .NET languages. For easier operation they should also define: using ptrdiff_t = System.Int32; using lua_Integer = System.Int32; using LUA_INTFRM_T = System.Int64; using UNSIGNED_LUA_INTFRM_T = System.UInt64;
Public class | LuaLBuffer |
Public class | LuaState |


CharPtr Class

CharPtr Class

[Missing <summary> documentation for "T:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr"]

Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class CharPtr
Public Class CharPtr
public ref class CharPtr
type CharPtr =  class end

The CharPtr type exposes the following members.

Constructors
 | Name | Description
Public method | CharPtr | Initializes a new instance of the CharPtr class
Public method | CharPtr(Byte) | Initializes a new instance of the CharPtr class
Public method | CharPtr(Char) | Initializes a new instance of the CharPtr class
Public method | CharPtr(IntPtr) | Initializes a new instance of the CharPtr class
Public method | CharPtr(String) | Initializes a new instance of the CharPtr class
Public method | CharPtr(CharPtr) | Initializes a new instance of the CharPtr class
Public method | CharPtr(Char, Int32) | Initializes a new instance of the CharPtr class
Public method | CharPtr(CharPtr, Int32) | Initializes a new instance of the CharPtr class
Top
Properties
 | Name | Description
Public property | ItemInt32 |
Public property | ItemInt64 |
Public property | ItemUInt32 |
Top
Methods
 | Name | Description
Public method | add |
Public method | dec |
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | inc |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | next |
Public method | prev |
Public method | sub |
Public method | ToString | (Overrides ObjectToString.)
Public method | ToString(Int32) |
Top
Operators
Name | Description
Addition(CharPtr, CharPtr) |
Addition(CharPtr, Int32) |
Addition(CharPtr, UInt32) |
Equality(Char, CharPtr) |
Equality(CharPtr, CharPtr) |
Equality(CharPtr, Char) |
GreaterThan |
GreaterThanOrEqual |
(Byte to CharPtr) |
(Char to CharPtr) |
(String to CharPtr) |
Inequality(Char, CharPtr) |
Inequality(CharPtr, CharPtr) |
Inequality(CharPtr, Char) |
LessThan |
LessThanOrEqual |
Subtraction(CharPtr, CharPtr) |
Subtraction(CharPtr, Int32) |
Subtraction(CharPtr, UInt32) |
Top
Fields
 | Name | Description
Public field | chars |
Public field | index |
Top
See Also

Reference

MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr Constructor

CharPtr Constructor
Overload List
 | Name | Description
Public method | CharPtr | Initializes a new instance of the CharPtr class
Public method | CharPtr(Byte) | Initializes a new instance of the CharPtr class
Public method | CharPtr(Char) | Initializes a new instance of the CharPtr class
Public method | CharPtr(IntPtr) | Initializes a new instance of the CharPtr class
Public method | CharPtr(String) | Initializes a new instance of the CharPtr class
Public method | CharPtr(CharPtr) | Initializes a new instance of the CharPtr class
Public method | CharPtr(Char, Int32) | Initializes a new instance of the CharPtr class
Public method | CharPtr(CharPtr, Int32) | Initializes a new instance of the CharPtr class
Top
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr Constructor

CharPtr Constructor
Initializes a new instance of the CharPtr class

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CharPtr()
Public Sub New
public:
CharPtr()
new : unit -> CharPtr
See Also

Reference

CharPtr Class
CharPtr Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr Constructor (Byte[])

CharPtr Constructor (Byte)
Initializes a new instance of the CharPtr class

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CharPtr(
    byte[] bytes
)
Public Sub New (
    bytes As Byte()
)
public:
CharPtr(
    array<unsigned char>^ bytes
)
new :
        bytes : byte[] -> CharPtr

Parameters

bytes
Type: SystemByte

[Missing <param name="bytes"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.#ctor(System.Byte[])"]

See Also

Reference

CharPtr Class
CharPtr Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr Constructor (Char[])

CharPtr Constructor (Char)
Initializes a new instance of the CharPtr class

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CharPtr(
    char[] chars
)
Public Sub New (
    chars As Char()
)
public:
CharPtr(
    array<wchar_t>^ chars
)
new :
        chars : char[] -> CharPtr

Parameters

chars
Type: SystemChar

[Missing <param name="chars"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.#ctor(System.Char[])"]

See Also

Reference

CharPtr Class
CharPtr Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr Constructor (IntPtr)

CharPtr Constructor (IntPtr)
Initializes a new instance of the CharPtr class

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CharPtr(
    IntPtr ptr
)
Public Sub New (
    ptr As IntPtr
)
public:
CharPtr(
    IntPtr ptr
)
new :
        ptr : IntPtr -> CharPtr

Parameters

ptr
Type: SystemIntPtr

[Missing <param name="ptr"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.#ctor(System.IntPtr)"]

See Also

Reference

CharPtr Class
CharPtr Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr Constructor (String)

CharPtr Constructor (String)
Initializes a new instance of the CharPtr class

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CharPtr(
    string str
)
Public Sub New (
    str As String
)
public:
CharPtr(
    String^ str
)
new :
        str : string -> CharPtr

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.#ctor(System.String)"]

See Also

Reference

CharPtr Class
CharPtr Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr Constructor (CharPtr)

CharPtr Constructor (CharPtr)
Initializes a new instance of the CharPtr class

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CharPtr(
    CharPtr ptr
)
Public Sub New (
    ptr As CharPtr
)
public:
CharPtr(
    CharPtr^ ptr
)
new :
        ptr : CharPtr -> CharPtr

Parameters

ptr
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.#ctor(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

See Also

Reference

CharPtr Class
CharPtr Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr Constructor (Char[], Int32)

CharPtr Constructor (Char, Int32)
Initializes a new instance of the CharPtr class

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CharPtr(
    char[] chars,
    int index
)
Public Sub New (
    chars As Char(),
    index As Integer
)
public:
CharPtr(
    array<wchar_t>^ chars,
    int index
)
new :
        chars : char[] *
        index : int -> CharPtr

Parameters

chars
Type: SystemChar

[Missing <param name="chars"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.#ctor(System.Char[],System.Int32)"]

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.#ctor(System.Char[],System.Int32)"]

See Also

Reference

CharPtr Class
CharPtr Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr Constructor (CharPtr, Int32)

CharPtr Constructor (CharPtr, Int32)
Initializes a new instance of the CharPtr class

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CharPtr(
    CharPtr ptr,
    int index
)
Public Sub New (
    ptr As CharPtr,
    index As Integer
)
public:
CharPtr(
    CharPtr^ ptr,
    int index
)
new :
        ptr : CharPtr *
        index : int -> CharPtr

Parameters

ptr
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.#ctor(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Int32)"]

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.#ctor(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Int32)"]

See Also

Reference

CharPtr Class
CharPtr Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr Properties

CharPtr Properties
Properties
 | Name | Description
Public property | ItemInt32 |
Public property | ItemInt64 |
Public property | ItemUInt32 |
Top
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Item Property

CharPtrItem Property
Overload List
 | Name | Description
Public property | ItemInt32 |
Public property | ItemInt64 |
Public property | ItemUInt32 |
Top
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Item Property (Int32)

CharPtrItem Property (Int32)

[Missing <summary> documentation for "P:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.Item(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public char this[
    int offset
] { get; set; }
Public Default Property Item (
    offset As Integer
) As Char
    Get
    Set
public:
property wchar_t default[int offset] {
    wchar_t get (int offset);
    void set (int offset, wchar_t value);
}
member Item : char with get, set

Parameters

offset
Type: SystemInt32

Property Value

Type: Char
See Also

Reference

CharPtr Class
Item Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Item Property (Int64)

CharPtrItem Property (Int64)

[Missing <summary> documentation for "P:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.Item(System.Int64)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public char this[
    long offset
] { get; set; }
Public Default Property Item (
    offset As Long
) As Char
    Get
    Set
public:
property wchar_t default[long long offset] {
    wchar_t get (long long offset);
    void set (long long offset, wchar_t value);
}
member Item : char with get, set

Parameters

offset
Type: SystemInt64

Property Value

Type: Char
See Also

Reference

CharPtr Class
Item Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Item Property (UInt32)

CharPtrItem Property (UInt32)

[Missing <summary> documentation for "P:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.Item(System.UInt32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public char this[
    uint offset
] { get; set; }
Public Default Property Item (
    offset As UInteger
) As Char
    Get
    Set
public:
property wchar_t default[unsigned int offset] {
    wchar_t get (unsigned int offset);
    void set (unsigned int offset, wchar_t value);
}
member Item : char with get, set

Parameters

offset
Type: SystemUInt32

Property Value

Type: Char
See Also

Reference

CharPtr Class
Item Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr Methods

CharPtr Methods

The CharPtr type exposes the following members.

Methods
 | Name | Description
Public method | add |
Public method | dec |
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | inc |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | next |
Public method | prev |
Public method | sub |
Public method | ToString | (Overrides ObjectToString.)
Public method | ToString(Int32) |
Top
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.add Method

CharPtradd Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.add(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CharPtr add(
    int ofs
)
Public Function add (
    ofs As Integer
) As CharPtr
public:
CharPtr^ add(
    int ofs
)
member add :
        ofs : int -> CharPtr

Parameters

ofs
Type: SystemInt32

[Missing <param name="ofs"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.add(System.Int32)"]

Return Value

Type: CharPtr
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.dec Method

CharPtrdec Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.dec"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void dec()
Public Sub dec
public:
void dec()
member dec : unit -> unit
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Equals Method

CharPtrEquals Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.Equals(System.Object)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object o
)
Public Overrides Function Equals (
    o As Object
) As Boolean
public:
virtual bool Equals(
    Object^ o
) override
abstract Equals :
        o : Object -> bool
override Equals :
        o : Object -> bool

Parameters

o
Type: SystemObject

[Missing <param name="o"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.Equals(System.Object)"]

Return Value

Type: Boolean
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.GetHashCode Method

CharPtrGetHashCode Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.GetHashCode"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.inc Method

CharPtrinc Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.inc"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void inc()
Public Sub inc
public:
void inc()
member inc : unit -> unit
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.next Method

CharPtrnext Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.next"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CharPtr next()
Public Function next As CharPtr
public:
CharPtr^ next()
member next : unit -> CharPtr

Return Value

Type: CharPtr
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.prev Method

CharPtrprev Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.prev"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CharPtr prev()
Public Function prev As CharPtr
public:
CharPtr^ prev()
member prev : unit -> CharPtr

Return Value

Type: CharPtr
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.sub Method

CharPtrsub Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.sub(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public CharPtr sub(
    int ofs
)
Public Function sub (
    ofs As Integer
) As CharPtr
public:
CharPtr^ sub(
    int ofs
)
member sub :
        ofs : int -> CharPtr

Parameters

ofs
Type: SystemInt32

[Missing <param name="ofs"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.sub(System.Int32)"]

Return Value

Type: CharPtr
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.ToString Method

CharPtrToString Method
Overload List
 | Name | Description
Public method | ToString | (Overrides ObjectToString.)
Public method | ToString(Int32) |
Top
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.ToString Method

CharPtrToString Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.ToString"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

CharPtr Class
ToString Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.ToString Method (Int32)

CharPtrToString Method (Int32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.ToString(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string ToString(
    int length
)
Public Function ToString (
    length As Integer
) As String
public:
String^ ToString(
    int length
)
member ToString :
        length : int -> string

Parameters

length
Type: SystemInt32

[Missing <param name="length"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.ToString(System.Int32)"]

Return Value

Type: String
See Also

Reference

CharPtr Class
ToString Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr Operators and Type Conversions

CharPtr Operators and Type Conversions

The CharPtr type exposes the following members.

Operators
Name | Description
Addition(CharPtr, CharPtr) |
Addition(CharPtr, Int32) |
Addition(CharPtr, UInt32) |
Equality(Char, CharPtr) |
Equality(CharPtr, CharPtr) |
Equality(CharPtr, Char) |
GreaterThan |
GreaterThanOrEqual |
(Byte to CharPtr) |
(Char to CharPtr) |
(String to CharPtr) |
Inequality(Char, CharPtr) |
Inequality(CharPtr, CharPtr) |
Inequality(CharPtr, Char) |
LessThan |
LessThanOrEqual |
Subtraction(CharPtr, CharPtr) |
Subtraction(CharPtr, Int32) |
Subtraction(CharPtr, UInt32) |
Top
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Addition Operator

CharPtrAddition Operator
Overload List
Name | Description
Addition(CharPtr, CharPtr) |
Addition(CharPtr, Int32) |
Addition(CharPtr, UInt32) |
Top
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Addition Operator (CharPtr, CharPtr)

CharPtrAddition Operator (CharPtr, CharPtr)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Addition(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static CharPtr operator +(
    CharPtr ptr1,
    CharPtr ptr2
)
Public Shared Operator + (
    ptr1 As CharPtr,
    ptr2 As CharPtr
) As CharPtr
public:
static CharPtr^ operator +(
    CharPtr^ ptr1,
    CharPtr^ ptr2
)
static let inline (+)
        ptr1 : CharPtr *
        ptr2 : CharPtr  : CharPtr

Parameters

ptr1
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr1"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Addition(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

ptr2
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr2"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Addition(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Return Value

Type: CharPtr
See Also

Reference

CharPtr Class
Addition Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Addition Operator (CharPtr, Int32)

CharPtrAddition Operator (CharPtr, Int32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Addition(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static CharPtr operator +(
    CharPtr ptr,
    int offset
)
Public Shared Operator + (
    ptr As CharPtr,
    offset As Integer
) As CharPtr
public:
static CharPtr^ operator +(
    CharPtr^ ptr,
    int offset
)
static let inline (+)
        ptr : CharPtr *
        offset : int  : CharPtr

Parameters

ptr
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Addition(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Int32)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Addition(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Int32)"]

Return Value

Type: CharPtr
See Also

Reference

CharPtr Class
Addition Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Addition Operator (CharPtr, UInt32)

CharPtrAddition Operator (CharPtr, UInt32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Addition(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.UInt32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static CharPtr operator +(
    CharPtr ptr,
    uint offset
)
Public Shared Operator + (
    ptr As CharPtr,
    offset As UInteger
) As CharPtr
public:
static CharPtr^ operator +(
    CharPtr^ ptr,
    unsigned int offset
)
static let inline (+)
        ptr : CharPtr *
        offset : uint32  : CharPtr

Parameters

ptr
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Addition(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.UInt32)"]

offset
Type: SystemUInt32

[Missing <param name="offset"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Addition(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.UInt32)"]

Return Value

Type: CharPtr
See Also

Reference

CharPtr Class
Addition Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Equality Operator

CharPtrEquality Operator
Overload List
Name | Description
Equality(Char, CharPtr) |
Equality(CharPtr, CharPtr) |
Equality(CharPtr, Char) |
Top
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Equality Operator (Char, CharPtr)

CharPtrEquality Operator (Char, CharPtr)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Equality(System.Char,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    char ch,
    CharPtr ptr
)
Public Shared Operator = (
    ch As Char,
    ptr As CharPtr
) As Boolean
public:
static bool operator ==(
    wchar_t ch,
    CharPtr^ ptr
)
static let inline (=)
        ch : char *
        ptr : CharPtr  : bool

Parameters

ch
Type: SystemChar

[Missing <param name="ch"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Equality(System.Char,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

ptr
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Equality(System.Char,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Return Value

Type: Boolean
See Also

Reference

CharPtr Class
Equality Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Equality Operator (CharPtr, CharPtr)

CharPtrEquality Operator (CharPtr, CharPtr)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Equality(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    CharPtr ptr1,
    CharPtr ptr2
)
Public Shared Operator = (
    ptr1 As CharPtr,
    ptr2 As CharPtr
) As Boolean
public:
static bool operator ==(
    CharPtr^ ptr1,
    CharPtr^ ptr2
)
static let inline (=)
        ptr1 : CharPtr *
        ptr2 : CharPtr  : bool

Parameters

ptr1
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr1"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Equality(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

ptr2
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr2"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Equality(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Return Value

Type: Boolean
See Also

Reference

CharPtr Class
Equality Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Equality Operator (CharPtr, Char)

CharPtrEquality Operator (CharPtr, Char)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Equality(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Char)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator ==(
    CharPtr ptr,
    char ch
)
Public Shared Operator = (
    ptr As CharPtr,
    ch As Char
) As Boolean
public:
static bool operator ==(
    CharPtr^ ptr,
    wchar_t ch
)
static let inline (=)
        ptr : CharPtr *
        ch : char  : bool

Parameters

ptr
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Equality(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Char)"]

ch
Type: SystemChar

[Missing <param name="ch"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Equality(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Char)"]

Return Value

Type: Boolean
See Also

Reference

CharPtr Class
Equality Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.GreaterThan Operator

CharPtrGreaterThan Operator

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_GreaterThan(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator >(
    CharPtr ptr1,
    CharPtr ptr2
)
Public Shared Operator > (
    ptr1 As CharPtr,
    ptr2 As CharPtr
) As Boolean
public:
static bool operator >(
    CharPtr^ ptr1,
    CharPtr^ ptr2
)
static let inline (>)
        ptr1 : CharPtr *
        ptr2 : CharPtr  : bool

Parameters

ptr1
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr1"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_GreaterThan(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

ptr2
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr2"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_GreaterThan(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Return Value

Type: Boolean
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.GreaterThanOrEqual Operator

CharPtrGreaterThanOrEqual Operator

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_GreaterThanOrEqual(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator >=(
    CharPtr ptr1,
    CharPtr ptr2
)
Public Shared Operator >= (
    ptr1 As CharPtr,
    ptr2 As CharPtr
) As Boolean
public:
static bool operator >=(
    CharPtr^ ptr1,
    CharPtr^ ptr2
)
static let inline (>=)
        ptr1 : CharPtr *
        ptr2 : CharPtr  : bool

Parameters

ptr1
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr1"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_GreaterThanOrEqual(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

ptr2
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr2"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_GreaterThanOrEqual(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Return Value

Type: Boolean
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr Implicit Conversion Operators

CharPtr Conversion Operators
Overload List
Name | Description
(Byte to CharPtr) |
(Char to CharPtr) |
(String to CharPtr) |
Top
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr Implicit Conversion (Byte[] to CharPtr)

CharPtr Conversion (Byte to CharPtr)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Implicit(System.Byte[])~MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static implicit operator CharPtr (
    byte[] bytes
)
Public Shared Widening Operator CType (
    bytes As Byte()
) As CharPtr
static implicit operator CharPtr^ (
    array<unsigned char>^ bytes
)
F# does not support the declaration of new casting operators.

Parameters

bytes
Type: SystemByte

[Missing <param name="bytes"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Implicit(System.Byte[])~MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr"]

Return Value

Type: CharPtr
See Also

Reference

CharPtr Class
Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr Implicit Conversion (Char[] to CharPtr)

CharPtr Conversion (Char to CharPtr)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Implicit(System.Char[])~MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static implicit operator CharPtr (
    char[] chars
)
Public Shared Widening Operator CType (
    chars As Char()
) As CharPtr
static implicit operator CharPtr^ (
    array<wchar_t>^ chars
)
F# does not support the declaration of new casting operators.

Parameters

chars
Type: SystemChar

[Missing <param name="chars"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Implicit(System.Char[])~MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr"]

Return Value

Type: CharPtr
See Also

Reference

CharPtr Class
Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr Implicit Conversion (String to CharPtr)

CharPtr Conversion (String to CharPtr)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Implicit(System.String)~MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static implicit operator CharPtr (
    string str
)
Public Shared Widening Operator CType (
    str As String
) As CharPtr
static implicit operator CharPtr^ (
    String^ str
)
F# does not support the declaration of new casting operators.

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Implicit(System.String)~MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr"]

Return Value

Type: CharPtr
See Also

Reference

CharPtr Class
Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Inequality Operator

CharPtrInequality Operator
Overload List
Name | Description
Inequality(Char, CharPtr) |
Inequality(CharPtr, CharPtr) |
Inequality(CharPtr, Char) |
Top
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Inequality Operator (Char, CharPtr)

CharPtrInequality Operator (Char, CharPtr)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Inequality(System.Char,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    char ch,
    CharPtr ptr
)
Public Shared Operator <> (
    ch As Char,
    ptr As CharPtr
) As Boolean
public:
static bool operator !=(
    wchar_t ch,
    CharPtr^ ptr
)
static let inline (<>)
        ch : char *
        ptr : CharPtr  : bool

Parameters

ch
Type: SystemChar

[Missing <param name="ch"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Inequality(System.Char,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

ptr
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Inequality(System.Char,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Return Value

Type: Boolean
See Also

Reference

CharPtr Class
Inequality Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Inequality Operator (CharPtr, CharPtr)

CharPtrInequality Operator (CharPtr, CharPtr)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Inequality(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    CharPtr ptr1,
    CharPtr ptr2
)
Public Shared Operator <> (
    ptr1 As CharPtr,
    ptr2 As CharPtr
) As Boolean
public:
static bool operator !=(
    CharPtr^ ptr1,
    CharPtr^ ptr2
)
static let inline (<>)
        ptr1 : CharPtr *
        ptr2 : CharPtr  : bool

Parameters

ptr1
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr1"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Inequality(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

ptr2
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr2"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Inequality(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Return Value

Type: Boolean
See Also

Reference

CharPtr Class
Inequality Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Inequality Operator (CharPtr, Char)

CharPtrInequality Operator (CharPtr, Char)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Inequality(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Char)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator !=(
    CharPtr ptr,
    char ch
)
Public Shared Operator <> (
    ptr As CharPtr,
    ch As Char
) As Boolean
public:
static bool operator !=(
    CharPtr^ ptr,
    wchar_t ch
)
static let inline (<>)
        ptr : CharPtr *
        ch : char  : bool

Parameters

ptr
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Inequality(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Char)"]

ch
Type: SystemChar

[Missing <param name="ch"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Inequality(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Char)"]

Return Value

Type: Boolean
See Also

Reference

CharPtr Class
Inequality Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.LessThan Operator

CharPtrLessThan Operator

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_LessThan(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator <(
    CharPtr ptr1,
    CharPtr ptr2
)
Public Shared Operator < (
    ptr1 As CharPtr,
    ptr2 As CharPtr
) As Boolean
public:
static bool operator <(
    CharPtr^ ptr1,
    CharPtr^ ptr2
)
static let inline (<)
        ptr1 : CharPtr *
        ptr2 : CharPtr  : bool

Parameters

ptr1
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr1"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_LessThan(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

ptr2
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr2"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_LessThan(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Return Value

Type: Boolean
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.LessThanOrEqual Operator

CharPtrLessThanOrEqual Operator

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_LessThanOrEqual(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool operator <=(
    CharPtr ptr1,
    CharPtr ptr2
)
Public Shared Operator <= (
    ptr1 As CharPtr,
    ptr2 As CharPtr
) As Boolean
public:
static bool operator <=(
    CharPtr^ ptr1,
    CharPtr^ ptr2
)
static let inline (<=)
        ptr1 : CharPtr *
        ptr2 : CharPtr  : bool

Parameters

ptr1
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr1"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_LessThanOrEqual(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

ptr2
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr2"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_LessThanOrEqual(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Return Value

Type: Boolean
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Subtraction Operator

CharPtrSubtraction Operator
Overload List
Name | Description
Subtraction(CharPtr, CharPtr) |
Subtraction(CharPtr, Int32) |
Subtraction(CharPtr, UInt32) |
Top
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Subtraction Operator (CharPtr, CharPtr)

CharPtrSubtraction Operator (CharPtr, CharPtr)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Subtraction(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static int operator -(
    CharPtr ptr1,
    CharPtr ptr2
)
Public Shared Operator - (
    ptr1 As CharPtr,
    ptr2 As CharPtr
) As Integer
public:
static int operator -(
    CharPtr^ ptr1,
    CharPtr^ ptr2
)
static let inline (-)
        ptr1 : CharPtr *
        ptr2 : CharPtr  : int

Parameters

ptr1
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr1"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Subtraction(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

ptr2
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr2"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Subtraction(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Return Value

Type: Int32
See Also

Reference

CharPtr Class
Subtraction Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Subtraction Operator (CharPtr, Int32)

CharPtrSubtraction Operator (CharPtr, Int32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Subtraction(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static CharPtr operator -(
    CharPtr ptr,
    int offset
)
Public Shared Operator - (
    ptr As CharPtr,
    offset As Integer
) As CharPtr
public:
static CharPtr^ operator -(
    CharPtr^ ptr,
    int offset
)
static let inline (-)
        ptr : CharPtr *
        offset : int  : CharPtr

Parameters

ptr
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Subtraction(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Int32)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Subtraction(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Int32)"]

Return Value

Type: CharPtr
See Also

Reference

CharPtr Class
Subtraction Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.Subtraction Operator (CharPtr, UInt32)

CharPtrSubtraction Operator (CharPtr, UInt32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Subtraction(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.UInt32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static CharPtr operator -(
    CharPtr ptr,
    uint offset
)
Public Shared Operator - (
    ptr As CharPtr,
    offset As UInteger
) As CharPtr
public:
static CharPtr^ operator -(
    CharPtr^ ptr,
    unsigned int offset
)
static let inline (-)
        ptr : CharPtr *
        offset : uint32  : CharPtr

Parameters

ptr
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Subtraction(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.UInt32)"]

offset
Type: SystemUInt32

[Missing <param name="offset"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.op_Subtraction(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.UInt32)"]

Return Value

Type: CharPtr
See Also

Reference

CharPtr Class
Subtraction Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr Fields

CharPtr Fields

The CharPtr type exposes the following members.

Fields
 | Name | Description
Public field | chars |
Public field | index |
Top
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.chars Field

CharPtrchars Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.chars"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public char[] chars
Public chars As Char()
public:
array<wchar_t>^ chars
val mutable chars: char[]

Field Value

Type: Char
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


CharPtr.index Field

CharPtrindex Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr.index"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int index
Public index As Integer
public:
int index
val mutable index: int

Field Value

Type: Int32
See Also

Reference

CharPtr Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase Class

LuaBase Class
Classes using the classic interface should inherit from this class. This class defines only static methods and is really meant to be used only from C# and not other .NET languages. For easier operation they should also define: using ptrdiff_t = System.Int32; using lua_Integer = System.Int32; using LUA_INTFRM_T = System.Int64; using UNSIGNED_LUA_INTFRM_T = System.UInt64;
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.Interop.LuaStateInteropLuaBase

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class LuaBase
Public Class LuaBase
public ref class LuaBase
type LuaBase =  class end

The LuaBase type exposes the following members.

Constructors
 | Name | Description
Public method | LuaBase | Initializes a new instance of the LuaBase class
Top
Methods
 | Name | Description
 | ArgAsType |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetArgument |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | isalnum(Char) |
 | isalnum(Int32) |
 | isalpha(Char) |
 | isalpha(Int32) |
 | iscntrl(Char) |
 | iscntrl(Int32) |
 | isdigit(Char) |
 | isdigit(Int32) |
 | isgraph(Char) |
 | isgraph(Int32) |
 | islower(Char) |
 | islower(Int32) |
 | ispunct(Char) |
 | ispunct(Int32) |
 | isspace(Char) |
 | isspace(Int32) |
 | isupper(Char) |
 | isupper(Int32) |
 | isxdigit |
 | LUA_QL |
 | LuaAssert |
 | LuaCall | Calls a function. To call a function you must use the following protocol: first, the function to be called is pushed onto the stack; then, the arguments to the function are pushed in direct order; that is, the first argument is pushed first. Finally you call lua_call; nargs is the number of arguments that you pushed onto the stack. All arguments and the function value are popped from the stack when the function is called. The function results are pushed onto the stack when the function returns. The number of results is adjusted to nresults, unless nresults is LUA_MULTRET. In this case, all results from the function are pushed. Lua takes care that the returned values fit into the stack space. The function results are pushed onto the stack in direct order (the first result is pushed first), so that after the call the last result is on the top of the stack.
 | LuaGetTable |
 | LuaGetTop |
 | LuaIsString |
 | LuaLAddChar |
 | LuaLAddLString |
 | LuaLAddString |
 | LuaLAddValue |
 | LuaLArgCheck |
 | LuaLArgError |
 | LuaLBuffInit |
 | LuaLCheckInt |
 | LuaLCheckInteger |
 | LuaLCheckLString |
 | LuaLCheckNumber |
 | LuaLCheckStack |
 | LuaLCheckString |
 | LuaLCheckStringStr |
 | LuaLError |
 | LuaLOptInt |
 | LuaLOptInteger |
 | LuaLPushResult |
 | LuaLTypeName |
 | LuaPop |
 | LuaPushInteger |
 | LuaPushLiteral |
 | LuaPushLString |
 | LuaPushNil |
 | LuaPushValue |
 | LuaToBoolean |
 | LuaToLString |
 | LuaToString |
 | LuaType |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | memchr |
 | memcmp(CharPtr, CharPtr, Int32) |
 | memcmp(CharPtr, CharPtr, UInt32) |
 | sprintf |
 | strchr |
 | strcpy |
 | strlen |
 | strncpy |
 | strpbrk |
 | tolower(Char) |
 | tolower(Int32) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | toupper(Char) |
 | toupper(Int32) |
Top
Fields
Name | Description
LUA_INTFRMLEN |
LUA_MULTRET |
LUA_TBOOLEAN |
LUA_TFUNCTION |
LUA_TLIGHTUSERDATA |
LUA_TNIL |
LUA_TNONE |
LUA_TNUMBER |
LUA_TSTRING |
LUA_TTABLE |
LUA_TTHREAD |
LUA_TUSERDATA |
Top
See Also

Reference

MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase Constructor

LuaBase Constructor
Initializes a new instance of the LuaBase class

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public LuaBase()
Public Sub New
public:
LuaBase()
new : unit -> LuaBase
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase Methods

LuaBase Methods

The LuaBase type exposes the following members.

Methods
 | Name | Description
 | ArgAsType |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetArgument |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | isalnum(Char) |
 | isalnum(Int32) |
 | isalpha(Char) |
 | isalpha(Int32) |
 | iscntrl(Char) |
 | iscntrl(Int32) |
 | isdigit(Char) |
 | isdigit(Int32) |
 | isgraph(Char) |
 | isgraph(Int32) |
 | islower(Char) |
 | islower(Int32) |
 | ispunct(Char) |
 | ispunct(Int32) |
 | isspace(Char) |
 | isspace(Int32) |
 | isupper(Char) |
 | isupper(Int32) |
 | isxdigit |
 | LUA_QL |
 | LuaAssert |
 | LuaCall | Calls a function. To call a function you must use the following protocol: first, the function to be called is pushed onto the stack; then, the arguments to the function are pushed in direct order; that is, the first argument is pushed first. Finally you call lua_call; nargs is the number of arguments that you pushed onto the stack. All arguments and the function value are popped from the stack when the function is called. The function results are pushed onto the stack when the function returns. The number of results is adjusted to nresults, unless nresults is LUA_MULTRET. In this case, all results from the function are pushed. Lua takes care that the returned values fit into the stack space. The function results are pushed onto the stack in direct order (the first result is pushed first), so that after the call the last result is on the top of the stack.
 | LuaGetTable |
 | LuaGetTop |
 | LuaIsString |
 | LuaLAddChar |
 | LuaLAddLString |
 | LuaLAddString |
 | LuaLAddValue |
 | LuaLArgCheck |
 | LuaLArgError |
 | LuaLBuffInit |
 | LuaLCheckInt |
 | LuaLCheckInteger |
 | LuaLCheckLString |
 | LuaLCheckNumber |
 | LuaLCheckStack |
 | LuaLCheckString |
 | LuaLCheckStringStr |
 | LuaLError |
 | LuaLOptInt |
 | LuaLOptInteger |
 | LuaLPushResult |
 | LuaLTypeName |
 | LuaPop |
 | LuaPushInteger |
 | LuaPushLiteral |
 | LuaPushLString |
 | LuaPushNil |
 | LuaPushValue |
 | LuaToBoolean |
 | LuaToLString |
 | LuaToString |
 | LuaType |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | memchr |
 | memcmp(CharPtr, CharPtr, Int32) |
 | memcmp(CharPtr, CharPtr, UInt32) |
 | sprintf |
 | strchr |
 | strcpy |
 | strlen |
 | strncpy |
 | strpbrk |
 | tolower(Char) |
 | tolower(Int32) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | toupper(Char) |
 | toupper(Int32) |
Top
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.ArgAsType Method

LuaBaseArgAsType Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.ArgAsType(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,MoonSharp.Interpreter.DataType,System.Boolean)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static DynValue ArgAsType(
    LuaState L,
    int pos,
    DataType type,
    bool allowNil = false
)
Protected Shared Function ArgAsType (
    L As LuaState,
    pos As Integer,
    type As DataType,
    Optional allowNil As Boolean = false
) As DynValue
protected:
static DynValue^ ArgAsType(
    LuaState^ L,
    int pos,
    DataType type,
    bool allowNil = false
)
static member ArgAsType :
        L : LuaState *
        pos : int *
        type : DataType *
        ?allowNil : bool
(* Defaults:
        let _allowNil = defaultArg allowNil false
*)
-> DynValue

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.ArgAsType(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,MoonSharp.Interpreter.DataType,System.Boolean)"]

pos
Type: SystemInt32

[Missing <param name="pos"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.ArgAsType(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,MoonSharp.Interpreter.DataType,System.Boolean)"]

type
Type: MoonSharp.InterpreterDataType

[Missing <param name="type"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.ArgAsType(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,MoonSharp.Interpreter.DataType,System.Boolean)"]

allowNil (Optional)
Type: SystemBoolean

[Missing <param name="allowNil"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.ArgAsType(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,MoonSharp.Interpreter.DataType,System.Boolean)"]

Return Value

Type: DynValue
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.GetArgument Method

LuaBaseGetArgument Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.GetArgument(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static DynValue GetArgument(
    LuaState L,
    int pos
)
Protected Shared Function GetArgument (
    L As LuaState,
    pos As Integer
) As DynValue
protected:
static DynValue^ GetArgument(
    LuaState^ L,
    int pos
)
static member GetArgument :
        L : LuaState *
        pos : int -> DynValue

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.GetArgument(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

pos
Type: SystemInt32

[Missing <param name="pos"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.GetArgument(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Return Value

Type: DynValue
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isalnum Method

LuaBaseisalnum Method
Overload List
Name | Description
isalnum(Char) |
isalnum(Int32) |
Top
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isalnum Method (Char)

LuaBaseisalnum Method (Char)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isalnum(System.Char)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool isalnum(
    char c
)
Protected Shared Function isalnum (
    c As Char
) As Boolean
protected:
static bool isalnum(
    wchar_t c
)
static member isalnum :
        c : char -> bool

Parameters

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isalnum(System.Char)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
isalnum Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isalnum Method (Int32)

LuaBaseisalnum Method (Int32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isalnum(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool isalnum(
    int c
)
Protected Shared Function isalnum (
    c As Integer
) As Boolean
protected:
static bool isalnum(
    int c
)
static member isalnum :
        c : int -> bool

Parameters

c
Type: SystemInt32

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isalnum(System.Int32)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
isalnum Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isalpha Method

LuaBaseisalpha Method
Overload List
Name | Description
isalpha(Char) |
isalpha(Int32) |
Top
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isalpha Method (Char)

LuaBaseisalpha Method (Char)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isalpha(System.Char)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool isalpha(
    char c
)
Protected Shared Function isalpha (
    c As Char
) As Boolean
protected:
static bool isalpha(
    wchar_t c
)
static member isalpha :
        c : char -> bool

Parameters

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isalpha(System.Char)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
isalpha Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isalpha Method (Int32)

LuaBaseisalpha Method (Int32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isalpha(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool isalpha(
    int c
)
Protected Shared Function isalpha (
    c As Integer
) As Boolean
protected:
static bool isalpha(
    int c
)
static member isalpha :
        c : int -> bool

Parameters

c
Type: SystemInt32

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isalpha(System.Int32)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
isalpha Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.iscntrl Method

LuaBaseiscntrl Method
Overload List
Name | Description
iscntrl(Char) |
iscntrl(Int32) |
Top
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.iscntrl Method (Char)

LuaBaseiscntrl Method (Char)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.iscntrl(System.Char)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool iscntrl(
    char c
)
Protected Shared Function iscntrl (
    c As Char
) As Boolean
protected:
static bool iscntrl(
    wchar_t c
)
static member iscntrl :
        c : char -> bool

Parameters

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.iscntrl(System.Char)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
iscntrl Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.iscntrl Method (Int32)

LuaBaseiscntrl Method (Int32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.iscntrl(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool iscntrl(
    int c
)
Protected Shared Function iscntrl (
    c As Integer
) As Boolean
protected:
static bool iscntrl(
    int c
)
static member iscntrl :
        c : int -> bool

Parameters

c
Type: SystemInt32

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.iscntrl(System.Int32)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
iscntrl Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isdigit Method

LuaBaseisdigit Method
Overload List
Name | Description
isdigit(Char) |
isdigit(Int32) |
Top
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isdigit Method (Char)

LuaBaseisdigit Method (Char)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isdigit(System.Char)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool isdigit(
    char c
)
Protected Shared Function isdigit (
    c As Char
) As Boolean
protected:
static bool isdigit(
    wchar_t c
)
static member isdigit :
        c : char -> bool

Parameters

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isdigit(System.Char)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
isdigit Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isdigit Method (Int32)

LuaBaseisdigit Method (Int32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isdigit(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool isdigit(
    int c
)
Protected Shared Function isdigit (
    c As Integer
) As Boolean
protected:
static bool isdigit(
    int c
)
static member isdigit :
        c : int -> bool

Parameters

c
Type: SystemInt32

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isdigit(System.Int32)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
isdigit Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isgraph Method

LuaBaseisgraph Method
Overload List
Name | Description
isgraph(Char) |
isgraph(Int32) |
Top
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isgraph Method (Char)

LuaBaseisgraph Method (Char)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isgraph(System.Char)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool isgraph(
    char c
)
Protected Shared Function isgraph (
    c As Char
) As Boolean
protected:
static bool isgraph(
    wchar_t c
)
static member isgraph :
        c : char -> bool

Parameters

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isgraph(System.Char)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
isgraph Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isgraph Method (Int32)

LuaBaseisgraph Method (Int32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isgraph(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool isgraph(
    int c
)
Protected Shared Function isgraph (
    c As Integer
) As Boolean
protected:
static bool isgraph(
    int c
)
static member isgraph :
        c : int -> bool

Parameters

c
Type: SystemInt32

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isgraph(System.Int32)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
isgraph Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.islower Method

LuaBaseislower Method
Overload List
Name | Description
islower(Char) |
islower(Int32) |
Top
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.islower Method (Char)

LuaBaseislower Method (Char)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.islower(System.Char)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool islower(
    char c
)
Protected Shared Function islower (
    c As Char
) As Boolean
protected:
static bool islower(
    wchar_t c
)
static member islower :
        c : char -> bool

Parameters

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.islower(System.Char)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
islower Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.islower Method (Int32)

LuaBaseislower Method (Int32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.islower(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool islower(
    int c
)
Protected Shared Function islower (
    c As Integer
) As Boolean
protected:
static bool islower(
    int c
)
static member islower :
        c : int -> bool

Parameters

c
Type: SystemInt32

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.islower(System.Int32)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
islower Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.ispunct Method

LuaBaseispunct Method
Overload List
Name | Description
ispunct(Char) |
ispunct(Int32) |
Top
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.ispunct Method (Char)

LuaBaseispunct Method (Char)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.ispunct(System.Char)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool ispunct(
    char c
)
Protected Shared Function ispunct (
    c As Char
) As Boolean
protected:
static bool ispunct(
    wchar_t c
)
static member ispunct :
        c : char -> bool

Parameters

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.ispunct(System.Char)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
ispunct Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.ispunct Method (Int32)

LuaBaseispunct Method (Int32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.ispunct(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool ispunct(
    int c
)
Protected Shared Function ispunct (
    c As Integer
) As Boolean
protected:
static bool ispunct(
    int c
)
static member ispunct :
        c : int -> bool

Parameters

c
Type: SystemInt32

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.ispunct(System.Int32)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
ispunct Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isspace Method

LuaBaseisspace Method
Overload List
Name | Description
isspace(Char) |
isspace(Int32) |
Top
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isspace Method (Char)

LuaBaseisspace Method (Char)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isspace(System.Char)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool isspace(
    char c
)
Protected Shared Function isspace (
    c As Char
) As Boolean
protected:
static bool isspace(
    wchar_t c
)
static member isspace :
        c : char -> bool

Parameters

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isspace(System.Char)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
isspace Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isspace Method (Int32)

LuaBaseisspace Method (Int32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isspace(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool isspace(
    int c
)
Protected Shared Function isspace (
    c As Integer
) As Boolean
protected:
static bool isspace(
    int c
)
static member isspace :
        c : int -> bool

Parameters

c
Type: SystemInt32

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isspace(System.Int32)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
isspace Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isupper Method

LuaBaseisupper Method
Overload List
Name | Description
isupper(Char) |
isupper(Int32) |
Top
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isupper Method (Char)

LuaBaseisupper Method (Char)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isupper(System.Char)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool isupper(
    char c
)
Protected Shared Function isupper (
    c As Char
) As Boolean
protected:
static bool isupper(
    wchar_t c
)
static member isupper :
        c : char -> bool

Parameters

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isupper(System.Char)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
isupper Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isupper Method (Int32)

LuaBaseisupper Method (Int32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isupper(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool isupper(
    int c
)
Protected Shared Function isupper (
    c As Integer
) As Boolean
protected:
static bool isupper(
    int c
)
static member isupper :
        c : int -> bool

Parameters

c
Type: SystemInt32

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isupper(System.Int32)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
isupper Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.isxdigit Method

LuaBaseisxdigit Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isxdigit(System.Char)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static bool isxdigit(
    char c
)
Protected Shared Function isxdigit (
    c As Char
) As Boolean
protected:
static bool isxdigit(
    wchar_t c
)
static member isxdigit :
        c : char -> bool

Parameters

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.isxdigit(System.Char)"]

Return Value

Type: Boolean
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LUA_QL Method

LuaBaseLUA_QL Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LUA_QL(System.String)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static string LUA_QL(
    string p
)
Protected Shared Function LUA_QL (
    p As String
) As String
protected:
static String^ LUA_QL(
    String^ p
)
static member LUA_QL :
        p : string -> string

Parameters

p
Type: SystemString

[Missing <param name="p"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LUA_QL(System.String)"]

Return Value

Type: String
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaAssert Method

LuaBaseLuaAssert Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaAssert(System.Boolean)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static void LuaAssert(
    bool p
)
Protected Shared Sub LuaAssert (
    p As Boolean
)
protected:
static void LuaAssert(
    bool p
)
static member LuaAssert :
        p : bool -> unit

Parameters

p
Type: SystemBoolean

[Missing <param name="p"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaAssert(System.Boolean)"]

See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaCall Method

LuaBaseLuaCall Method
Calls a function. To call a function you must use the following protocol: first, the function to be called is pushed onto the stack; then, the arguments to the function are pushed in direct order; that is, the first argument is pushed first. Finally you call lua_call; nargs is the number of arguments that you pushed onto the stack. All arguments and the function value are popped from the stack when the function is called. The function results are pushed onto the stack when the function returns. The number of results is adjusted to nresults, unless nresults is LUA_MULTRET. In this case, all results from the function are pushed. Lua takes care that the returned values fit into the stack space. The function results are pushed onto the stack in direct order (the first result is pushed first), so that after the call the last result is on the top of the stack.

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static void LuaCall(
    LuaState L,
    int nargs,
    int nresults = -1
)
Protected Shared Sub LuaCall (
    L As LuaState,
    nargs As Integer,
    Optional nresults As Integer = -1
)
protected:
static void LuaCall(
    LuaState^ L,
    int nargs,
    int nresults = -1
)
static member LuaCall :
        L : LuaState *
        nargs : int *
        ?nresults : int
(* Defaults:
        let _nresults = defaultArg nresults -1
*)
-> unit

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState
The LuaState
nargs
Type: SystemInt32
The number of arguments.
nresults (Optional)
Type: SystemInt32
The number of expected results.
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaGetTable Method

LuaBaseLuaGetTable Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaGetTable(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static void LuaGetTable(
    LuaState L,
    int p
)
Protected Shared Sub LuaGetTable (
    L As LuaState,
    p As Integer
)
protected:
static void LuaGetTable(
    LuaState^ L,
    int p
)
static member LuaGetTable :
        L : LuaState *
        p : int -> unit

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaGetTable(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

p
Type: SystemInt32

[Missing <param name="p"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaGetTable(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaGetTop Method

LuaBaseLuaGetTop Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaGetTop(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static int LuaGetTop(
    LuaState L
)
Protected Shared Function LuaGetTop (
    L As LuaState
) As Integer
protected:
static int LuaGetTop(
    LuaState^ L
)
static member LuaGetTop :
        L : LuaState -> int

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaGetTop(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState)"]

Return Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaIsString Method

LuaBaseLuaIsString Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaIsString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static int LuaIsString(
    LuaState L,
    int p
)
Protected Shared Function LuaIsString (
    L As LuaState,
    p As Integer
) As Integer
protected:
static int LuaIsString(
    LuaState^ L,
    int p
)
static member LuaIsString :
        L : LuaState *
        p : int -> int

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaIsString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

p
Type: SystemInt32

[Missing <param name="p"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaIsString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Return Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLAddChar Method

LuaBaseLuaLAddChar Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLAddChar(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer,System.Char)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static void LuaLAddChar(
    LuaLBuffer b,
    char p
)
Protected Shared Sub LuaLAddChar (
    b As LuaLBuffer,
    p As Char
)
protected:
static void LuaLAddChar(
    LuaLBuffer^ b,
    wchar_t p
)
static member LuaLAddChar :
        b : LuaLBuffer *
        p : char -> unit

Parameters

b
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaLBuffer

[Missing <param name="b"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLAddChar(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer,System.Char)"]

p
Type: SystemChar

[Missing <param name="p"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLAddChar(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer,System.Char)"]

See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLAddLString Method

LuaBaseLuaLAddLString Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLAddLString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.UInt32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static void LuaLAddLString(
    LuaLBuffer b,
    CharPtr s,
    uint p
)
Protected Shared Sub LuaLAddLString (
    b As LuaLBuffer,
    s As CharPtr,
    p As UInteger
)
protected:
static void LuaLAddLString(
    LuaLBuffer^ b,
    CharPtr^ s,
    unsigned int p
)
static member LuaLAddLString :
        b : LuaLBuffer *
        s : CharPtr *
        p : uint32 -> unit

Parameters

b
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaLBuffer

[Missing <param name="b"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLAddLString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.UInt32)"]

s
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="s"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLAddLString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.UInt32)"]

p
Type: SystemUInt32

[Missing <param name="p"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLAddLString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.UInt32)"]

See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLAddString Method

LuaBaseLuaLAddString Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLAddString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer,System.String)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static void LuaLAddString(
    LuaLBuffer b,
    string s
)
Protected Shared Sub LuaLAddString (
    b As LuaLBuffer,
    s As String
)
protected:
static void LuaLAddString(
    LuaLBuffer^ b,
    String^ s
)
static member LuaLAddString :
        b : LuaLBuffer *
        s : string -> unit

Parameters

b
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaLBuffer

[Missing <param name="b"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLAddString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer,System.String)"]

s
Type: SystemString

[Missing <param name="s"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLAddString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer,System.String)"]

See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLAddValue Method

LuaBaseLuaLAddValue Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLAddValue(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static void LuaLAddValue(
    LuaLBuffer b
)
Protected Shared Sub LuaLAddValue (
    b As LuaLBuffer
)
protected:
static void LuaLAddValue(
    LuaLBuffer^ b
)
static member LuaLAddValue :
        b : LuaLBuffer -> unit

Parameters

b
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaLBuffer

[Missing <param name="b"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLAddValue(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer)"]

See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLArgCheck Method

LuaBaseLuaLArgCheck Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLArgCheck(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Boolean,System.Int32,System.String)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static void LuaLArgCheck(
    LuaState L,
    bool condition,
    int argNum,
    string message
)
Protected Shared Sub LuaLArgCheck (
    L As LuaState,
    condition As Boolean,
    argNum As Integer,
    message As String
)
protected:
static void LuaLArgCheck(
    LuaState^ L,
    bool condition,
    int argNum,
    String^ message
)
static member LuaLArgCheck :
        L : LuaState *
        condition : bool *
        argNum : int *
        message : string -> unit

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLArgCheck(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Boolean,System.Int32,System.String)"]

condition
Type: SystemBoolean

[Missing <param name="condition"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLArgCheck(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Boolean,System.Int32,System.String)"]

argNum
Type: SystemInt32

[Missing <param name="argNum"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLArgCheck(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Boolean,System.Int32,System.String)"]

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLArgCheck(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Boolean,System.Int32,System.String)"]

See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLArgError Method

LuaBaseLuaLArgError Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLArgError(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.String)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static void LuaLArgError(
    LuaState L,
    int arg,
    string p
)
Protected Shared Sub LuaLArgError (
    L As LuaState,
    arg As Integer,
    p As String
)
protected:
static void LuaLArgError(
    LuaState^ L,
    int arg,
    String^ p
)
static member LuaLArgError :
        L : LuaState *
        arg : int *
        p : string -> unit

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLArgError(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.String)"]

arg
Type: SystemInt32

[Missing <param name="arg"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLArgError(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.String)"]

p
Type: SystemString

[Missing <param name="p"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLArgError(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.String)"]

See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLBuffInit Method

LuaBaseLuaLBuffInit Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLBuffInit(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static void LuaLBuffInit(
    LuaState L,
    LuaLBuffer b
)
Protected Shared Sub LuaLBuffInit (
    L As LuaState,
    b As LuaLBuffer
)
protected:
static void LuaLBuffInit(
    LuaState^ L,
    LuaLBuffer^ b
)
static member LuaLBuffInit :
        L : LuaState *
        b : LuaLBuffer -> unit

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLBuffInit(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer)"]

b
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaLBuffer

[Missing <param name="b"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLBuffInit(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer)"]

See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLCheckInt Method

LuaBaseLuaLCheckInt Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckInt(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static int LuaLCheckInt(
    LuaState L,
    int argNum
)
Protected Shared Function LuaLCheckInt (
    L As LuaState,
    argNum As Integer
) As Integer
protected:
static int LuaLCheckInt(
    LuaState^ L,
    int argNum
)
static member LuaLCheckInt :
        L : LuaState *
        argNum : int -> int

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckInt(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

argNum
Type: SystemInt32

[Missing <param name="argNum"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckInt(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Return Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLCheckInteger Method

LuaBaseLuaLCheckInteger Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckInteger(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static int LuaLCheckInteger(
    LuaState L,
    int pos
)
Protected Shared Function LuaLCheckInteger (
    L As LuaState,
    pos As Integer
) As Integer
protected:
static int LuaLCheckInteger(
    LuaState^ L,
    int pos
)
static member LuaLCheckInteger :
        L : LuaState *
        pos : int -> int

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckInteger(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

pos
Type: SystemInt32

[Missing <param name="pos"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckInteger(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Return Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLCheckLString Method

LuaBaseLuaLCheckLString Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckLString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.UInt32@)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static string LuaLCheckLString(
    LuaState L,
    int argNum,
    out uint l
)
Protected Shared Function LuaLCheckLString (
    L As LuaState,
    argNum As Integer,
    <OutAttribute> ByRef l As UInteger
) As String
protected:
static String^ LuaLCheckLString(
    LuaState^ L,
    int argNum,
    [OutAttribute] unsigned int% l
)
static member LuaLCheckLString :
        L : LuaState *
        argNum : int *
        l : uint32 byref -> string

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckLString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.UInt32@)"]

argNum
Type: SystemInt32

[Missing <param name="argNum"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckLString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.UInt32@)"]

l
Type: SystemUInt32

[Missing <param name="l"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckLString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.UInt32@)"]

Return Value

Type: String
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLCheckNumber Method

LuaBaseLuaLCheckNumber Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckNumber(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static double LuaLCheckNumber(
    LuaState L,
    int pos
)
Protected Shared Function LuaLCheckNumber (
    L As LuaState,
    pos As Integer
) As Double
protected:
static double LuaLCheckNumber(
    LuaState^ L,
    int pos
)
static member LuaLCheckNumber :
        L : LuaState *
        pos : int -> float

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckNumber(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

pos
Type: SystemInt32

[Missing <param name="pos"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckNumber(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Return Value

Type: Double
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLCheckStack Method

LuaBaseLuaLCheckStack Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckStack(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.String)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static void LuaLCheckStack(
    LuaState L,
    int n,
    string message
)
Protected Shared Sub LuaLCheckStack (
    L As LuaState,
    n As Integer,
    message As String
)
protected:
static void LuaLCheckStack(
    LuaState^ L,
    int n,
    String^ message
)
static member LuaLCheckStack :
        L : LuaState *
        n : int *
        message : string -> unit

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckStack(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.String)"]

n
Type: SystemInt32

[Missing <param name="n"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckStack(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.String)"]

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckStack(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.String)"]

See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLCheckString Method

LuaBaseLuaLCheckString Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static CharPtr LuaLCheckString(
    LuaState L,
    int p
)
Protected Shared Function LuaLCheckString (
    L As LuaState,
    p As Integer
) As CharPtr
protected:
static CharPtr^ LuaLCheckString(
    LuaState^ L,
    int p
)
static member LuaLCheckString :
        L : LuaState *
        p : int -> CharPtr

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

p
Type: SystemInt32

[Missing <param name="p"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Return Value

Type: CharPtr
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLCheckStringStr Method

LuaBaseLuaLCheckStringStr Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckStringStr(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static string LuaLCheckStringStr(
    LuaState L,
    int p
)
Protected Shared Function LuaLCheckStringStr (
    L As LuaState,
    p As Integer
) As String
protected:
static String^ LuaLCheckStringStr(
    LuaState^ L,
    int p
)
static member LuaLCheckStringStr :
        L : LuaState *
        p : int -> string

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckStringStr(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

p
Type: SystemInt32

[Missing <param name="p"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLCheckStringStr(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Return Value

Type: String
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLError Method

LuaBaseLuaLError Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLError(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.String,System.Object[])"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static int LuaLError(
    LuaState luaState,
    string message,
    params Object[] args
)
Protected Shared Function LuaLError (
    luaState As LuaState,
    message As String,
    ParamArray args As Object()
) As Integer
protected:
static int LuaLError(
    LuaState^ luaState,
    String^ message,
    ... array<Object^>^ args
)
static member LuaLError :
        luaState : LuaState *
        message : string *
        args : Object[] -> int

Parameters

luaState
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="luaState"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLError(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.String,System.Object[])"]

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLError(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.String,System.Object[])"]

args
Type: SystemObject

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLError(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.String,System.Object[])"]

Return Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLOptInt Method

LuaBaseLuaLOptInt Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLOptInt(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static int LuaLOptInt(
    LuaState L,
    int pos,
    int def
)
Protected Shared Function LuaLOptInt (
    L As LuaState,
    pos As Integer,
    def As Integer
) As Integer
protected:
static int LuaLOptInt(
    LuaState^ L,
    int pos,
    int def
)
static member LuaLOptInt :
        L : LuaState *
        pos : int *
        def : int -> int

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLOptInt(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.Int32)"]

pos
Type: SystemInt32

[Missing <param name="pos"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLOptInt(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.Int32)"]

def
Type: SystemInt32

[Missing <param name="def"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLOptInt(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.Int32)"]

Return Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLOptInteger Method

LuaBaseLuaLOptInteger Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLOptInteger(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static int LuaLOptInteger(
    LuaState L,
    int pos,
    int def
)
Protected Shared Function LuaLOptInteger (
    L As LuaState,
    pos As Integer,
    def As Integer
) As Integer
protected:
static int LuaLOptInteger(
    LuaState^ L,
    int pos,
    int def
)
static member LuaLOptInteger :
        L : LuaState *
        pos : int *
        def : int -> int

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLOptInteger(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.Int32)"]

pos
Type: SystemInt32

[Missing <param name="pos"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLOptInteger(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.Int32)"]

def
Type: SystemInt32

[Missing <param name="def"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLOptInteger(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.Int32)"]

Return Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLPushResult Method

LuaBaseLuaLPushResult Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLPushResult(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static void LuaLPushResult(
    LuaLBuffer b
)
Protected Shared Sub LuaLPushResult (
    b As LuaLBuffer
)
protected:
static void LuaLPushResult(
    LuaLBuffer^ b
)
static member LuaLPushResult :
        b : LuaLBuffer -> unit

Parameters

b
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaLBuffer

[Missing <param name="b"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLPushResult(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer)"]

See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaLTypeName Method

LuaBaseLuaLTypeName Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLTypeName(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static string LuaLTypeName(
    LuaState L,
    int p
)
Protected Shared Function LuaLTypeName (
    L As LuaState,
    p As Integer
) As String
protected:
static String^ LuaLTypeName(
    LuaState^ L,
    int p
)
static member LuaLTypeName :
        L : LuaState *
        p : int -> string

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLTypeName(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

p
Type: SystemInt32

[Missing <param name="p"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaLTypeName(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Return Value

Type: String
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaPop Method

LuaBaseLuaPop Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaPop(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static void LuaPop(
    LuaState L,
    int p
)
Protected Shared Sub LuaPop (
    L As LuaState,
    p As Integer
)
protected:
static void LuaPop(
    LuaState^ L,
    int p
)
static member LuaPop :
        L : LuaState *
        p : int -> unit

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaPop(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

p
Type: SystemInt32

[Missing <param name="p"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaPop(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaPushInteger Method

LuaBaseLuaPushInteger Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaPushInteger(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static void LuaPushInteger(
    LuaState L,
    int val
)
Protected Shared Sub LuaPushInteger (
    L As LuaState,
    val As Integer
)
protected:
static void LuaPushInteger(
    LuaState^ L,
    int val
)
static member LuaPushInteger :
        L : LuaState *
        val : int -> unit

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaPushInteger(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

val
Type: SystemInt32

[Missing <param name="val"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaPushInteger(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaPushLiteral Method

LuaBaseLuaPushLiteral Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaPushLiteral(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.String)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static void LuaPushLiteral(
    LuaState L,
    string literalString
)
Protected Shared Sub LuaPushLiteral (
    L As LuaState,
    literalString As String
)
protected:
static void LuaPushLiteral(
    LuaState^ L,
    String^ literalString
)
static member LuaPushLiteral :
        L : LuaState *
        literalString : string -> unit

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaPushLiteral(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.String)"]

literalString
Type: SystemString

[Missing <param name="literalString"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaPushLiteral(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.String)"]

See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaPushLString Method

LuaBaseLuaPushLString Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaPushLString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.UInt32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static void LuaPushLString(
    LuaState L,
    CharPtr s,
    uint len
)
Protected Shared Sub LuaPushLString (
    L As LuaState,
    s As CharPtr,
    len As UInteger
)
protected:
static void LuaPushLString(
    LuaState^ L,
    CharPtr^ s,
    unsigned int len
)
static member LuaPushLString :
        L : LuaState *
        s : CharPtr *
        len : uint32 -> unit

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaPushLString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.UInt32)"]

s
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="s"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaPushLString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.UInt32)"]

len
Type: SystemUInt32

[Missing <param name="len"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaPushLString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.UInt32)"]

See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaPushNil Method

LuaBaseLuaPushNil Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaPushNil(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static void LuaPushNil(
    LuaState L
)
Protected Shared Sub LuaPushNil (
    L As LuaState
)
protected:
static void LuaPushNil(
    LuaState^ L
)
static member LuaPushNil :
        L : LuaState -> unit

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaPushNil(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState)"]

See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaPushValue Method

LuaBaseLuaPushValue Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaPushValue(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static void LuaPushValue(
    LuaState L,
    int arg
)
Protected Shared Sub LuaPushValue (
    L As LuaState,
    arg As Integer
)
protected:
static void LuaPushValue(
    LuaState^ L,
    int arg
)
static member LuaPushValue :
        L : LuaState *
        arg : int -> unit

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaPushValue(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

arg
Type: SystemInt32

[Missing <param name="arg"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaPushValue(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaToBoolean Method

LuaBaseLuaToBoolean Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaToBoolean(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static int LuaToBoolean(
    LuaState L,
    int p
)
Protected Shared Function LuaToBoolean (
    L As LuaState,
    p As Integer
) As Integer
protected:
static int LuaToBoolean(
    LuaState^ L,
    int p
)
static member LuaToBoolean :
        L : LuaState *
        p : int -> int

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaToBoolean(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

p
Type: SystemInt32

[Missing <param name="p"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaToBoolean(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Return Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaToLString Method

LuaBaseLuaToLString Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaToLString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.UInt32@)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static string LuaToLString(
    LuaState luaState,
    int p,
    out uint l
)
Protected Shared Function LuaToLString (
    luaState As LuaState,
    p As Integer,
    <OutAttribute> ByRef l As UInteger
) As String
protected:
static String^ LuaToLString(
    LuaState^ luaState,
    int p,
    [OutAttribute] unsigned int% l
)
static member LuaToLString :
        luaState : LuaState *
        p : int *
        l : uint32 byref -> string

Parameters

luaState
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="luaState"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaToLString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.UInt32@)"]

p
Type: SystemInt32

[Missing <param name="p"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaToLString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.UInt32@)"]

l
Type: SystemUInt32

[Missing <param name="l"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaToLString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32,System.UInt32@)"]

Return Value

Type: String
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaToString Method

LuaBaseLuaToString Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaToString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static string LuaToString(
    LuaState luaState,
    int p
)
Protected Shared Function LuaToString (
    luaState As LuaState,
    p As Integer
) As String
protected:
static String^ LuaToString(
    LuaState^ luaState,
    int p
)
static member LuaToString :
        luaState : LuaState *
        p : int -> string

Parameters

luaState
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="luaState"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaToString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

p
Type: SystemInt32

[Missing <param name="p"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaToString(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Return Value

Type: String
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LuaType Method

LuaBaseLuaType Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaType(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static int LuaType(
    LuaState L,
    int p
)
Protected Shared Function LuaType (
    L As LuaState,
    p As Integer
) As Integer
protected:
static int LuaType(
    LuaState^ L,
    int p
)
static member LuaType :
        L : LuaState *
        p : int -> int

Parameters

L
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="L"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaType(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

p
Type: SystemInt32

[Missing <param name="p"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LuaType(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState,System.Int32)"]

Return Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.memchr Method

LuaBasememchr Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.memchr(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Char,System.UInt32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static CharPtr memchr(
    CharPtr ptr,
    char c,
    uint count
)
Protected Shared Function memchr (
    ptr As CharPtr,
    c As Char,
    count As UInteger
) As CharPtr
protected:
static CharPtr^ memchr(
    CharPtr^ ptr,
    wchar_t c,
    unsigned int count
)
static member memchr :
        ptr : CharPtr *
        c : char *
        count : uint32 -> CharPtr

Parameters

ptr
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.memchr(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Char,System.UInt32)"]

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.memchr(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Char,System.UInt32)"]

count
Type: SystemUInt32

[Missing <param name="count"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.memchr(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Char,System.UInt32)"]

Return Value

Type: CharPtr
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.memcmp Method

LuaBasememcmp Method
Overload List
Name | Description
memcmp(CharPtr, CharPtr, Int32) |
memcmp(CharPtr, CharPtr, UInt32) |
Top
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.memcmp Method (CharPtr, CharPtr, Int32)

LuaBasememcmp Method (CharPtr, CharPtr, Int32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.memcmp(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static int memcmp(
    CharPtr ptr1,
    CharPtr ptr2,
    int size
)
Protected Shared Function memcmp (
    ptr1 As CharPtr,
    ptr2 As CharPtr,
    size As Integer
) As Integer
protected:
static int memcmp(
    CharPtr^ ptr1,
    CharPtr^ ptr2,
    int size
)
static member memcmp :
        ptr1 : CharPtr *
        ptr2 : CharPtr *
        size : int -> int

Parameters

ptr1
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr1"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.memcmp(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Int32)"]

ptr2
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr2"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.memcmp(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Int32)"]

size
Type: SystemInt32

[Missing <param name="size"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.memcmp(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Int32)"]

Return Value

Type: Int32
See Also

Reference

LuaBase Class
memcmp Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.memcmp Method (CharPtr, CharPtr, UInt32)

LuaBasememcmp Method (CharPtr, CharPtr, UInt32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.memcmp(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.UInt32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static int memcmp(
    CharPtr ptr1,
    CharPtr ptr2,
    uint size
)
Protected Shared Function memcmp (
    ptr1 As CharPtr,
    ptr2 As CharPtr,
    size As UInteger
) As Integer
protected:
static int memcmp(
    CharPtr^ ptr1,
    CharPtr^ ptr2,
    unsigned int size
)
static member memcmp :
        ptr1 : CharPtr *
        ptr2 : CharPtr *
        size : uint32 -> int

Parameters

ptr1
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr1"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.memcmp(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.UInt32)"]

ptr2
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="ptr2"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.memcmp(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.UInt32)"]

size
Type: SystemUInt32

[Missing <param name="size"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.memcmp(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.UInt32)"]

Return Value

Type: Int32
See Also

Reference

LuaBase Class
memcmp Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.sprintf Method

LuaBasesprintf Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.sprintf(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Object[])"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static void sprintf(
    CharPtr buffer,
    CharPtr str,
    params Object[] argv
)
Public Shared Sub sprintf (
    buffer As CharPtr,
    str As CharPtr,
    ParamArray argv As Object()
)
public:
static void sprintf(
    CharPtr^ buffer,
    CharPtr^ str,
    ... array<Object^>^ argv
)
static member sprintf :
        buffer : CharPtr *
        str : CharPtr *
        argv : Object[] -> unit

Parameters

buffer
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="buffer"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.sprintf(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Object[])"]

str
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="str"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.sprintf(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Object[])"]

argv
Type: SystemObject

[Missing <param name="argv"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.sprintf(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Object[])"]

See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.strchr Method

LuaBasestrchr Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.strchr(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Char)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static CharPtr strchr(
    CharPtr str,
    char c
)
Protected Shared Function strchr (
    str As CharPtr,
    c As Char
) As CharPtr
protected:
static CharPtr^ strchr(
    CharPtr^ str,
    wchar_t c
)
static member strchr :
        str : CharPtr *
        c : char -> CharPtr

Parameters

str
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="str"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.strchr(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Char)"]

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.strchr(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Char)"]

Return Value

Type: CharPtr
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.strcpy Method

LuaBasestrcpy Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.strcpy(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static CharPtr strcpy(
    CharPtr dst,
    CharPtr src
)
Protected Shared Function strcpy (
    dst As CharPtr,
    src As CharPtr
) As CharPtr
protected:
static CharPtr^ strcpy(
    CharPtr^ dst,
    CharPtr^ src
)
static member strcpy :
        dst : CharPtr *
        src : CharPtr -> CharPtr

Parameters

dst
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="dst"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.strcpy(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

src
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="src"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.strcpy(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Return Value

Type: CharPtr
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.strlen Method

LuaBasestrlen Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.strlen(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static int strlen(
    CharPtr str
)
Protected Shared Function strlen (
    str As CharPtr
) As Integer
protected:
static int strlen(
    CharPtr^ str
)
static member strlen :
        str : CharPtr -> int

Parameters

str
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="str"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.strlen(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Return Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.strncpy Method

LuaBasestrncpy Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.strncpy(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static CharPtr strncpy(
    CharPtr dst,
    CharPtr src,
    int length
)
Protected Shared Function strncpy (
    dst As CharPtr,
    src As CharPtr,
    length As Integer
) As CharPtr
protected:
static CharPtr^ strncpy(
    CharPtr^ dst,
    CharPtr^ src,
    int length
)
static member strncpy :
        dst : CharPtr *
        src : CharPtr *
        length : int -> CharPtr

Parameters

dst
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="dst"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.strncpy(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Int32)"]

src
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="src"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.strncpy(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Int32)"]

length
Type: SystemInt32

[Missing <param name="length"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.strncpy(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,System.Int32)"]

Return Value

Type: CharPtr
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.strpbrk Method

LuaBasestrpbrk Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.strpbrk(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static CharPtr strpbrk(
    CharPtr str,
    CharPtr charset
)
Protected Shared Function strpbrk (
    str As CharPtr,
    charset As CharPtr
) As CharPtr
protected:
static CharPtr^ strpbrk(
    CharPtr^ str,
    CharPtr^ charset
)
static member strpbrk :
        str : CharPtr *
        charset : CharPtr -> CharPtr

Parameters

str
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="str"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.strpbrk(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

charset
Type: MoonSharp.Interpreter.Interop.LuaStateInteropCharPtr

[Missing <param name="charset"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.strpbrk(MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr,MoonSharp.Interpreter.Interop.LuaStateInterop.CharPtr)"]

Return Value

Type: CharPtr
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.tolower Method

LuaBasetolower Method
Overload List
Name | Description
tolower(Char) |
tolower(Int32) |
Top
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.tolower Method (Char)

LuaBasetolower Method (Char)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.tolower(System.Char)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static char tolower(
    char c
)
Protected Shared Function tolower (
    c As Char
) As Char
protected:
static wchar_t tolower(
    wchar_t c
)
static member tolower :
        c : char -> char

Parameters

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.tolower(System.Char)"]

Return Value

Type: Char
See Also

Reference

LuaBase Class
tolower Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.tolower Method (Int32)

LuaBasetolower Method (Int32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.tolower(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static char tolower(
    int c
)
Protected Shared Function tolower (
    c As Integer
) As Char
protected:
static wchar_t tolower(
    int c
)
static member tolower :
        c : int -> char

Parameters

c
Type: SystemInt32

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.tolower(System.Int32)"]

Return Value

Type: Char
See Also

Reference

LuaBase Class
tolower Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.toupper Method

LuaBasetoupper Method
Overload List
Name | Description
toupper(Char) |
toupper(Int32) |
Top
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.toupper Method (Char)

LuaBasetoupper Method (Char)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.toupper(System.Char)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static char toupper(
    char c
)
Protected Shared Function toupper (
    c As Char
) As Char
protected:
static wchar_t toupper(
    wchar_t c
)
static member toupper :
        c : char -> char

Parameters

c
Type: SystemChar

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.toupper(System.Char)"]

Return Value

Type: Char
See Also

Reference

LuaBase Class
toupper Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.toupper Method (Int32)

LuaBasetoupper Method (Int32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.toupper(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected static char toupper(
    int c
)
Protected Shared Function toupper (
    c As Integer
) As Char
protected:
static wchar_t toupper(
    int c
)
static member toupper :
        c : int -> char

Parameters

c
Type: SystemInt32

[Missing <param name="c"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.toupper(System.Int32)"]

Return Value

Type: Char
See Also

Reference

LuaBase Class
toupper Overload
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase Fields

LuaBase Fields

The LuaBase type exposes the following members.

Fields
Name | Description
LUA_INTFRMLEN |
LUA_MULTRET |
LUA_TBOOLEAN |
LUA_TFUNCTION |
LUA_TLIGHTUSERDATA |
LUA_TNIL |
LUA_TNONE |
LUA_TNUMBER |
LUA_TSTRING |
LUA_TTABLE |
LUA_TTHREAD |
LUA_TUSERDATA |
Top
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LUA_INTFRMLEN Field

LuaBaseLUA_INTFRMLEN Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LUA_INTFRMLEN"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected const string LUA_INTFRMLEN = "l"
Protected Const LUA_INTFRMLEN As String = "l"
protected:
literal String^ LUA_INTFRMLEN = "l"
static val mutable LUA_INTFRMLEN: string

Field Value

Type: String
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LUA_MULTRET Field

LuaBaseLUA_MULTRET Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LUA_MULTRET"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected const int LUA_MULTRET = -1
Protected Const LUA_MULTRET As Integer = -1
protected:
literal int LUA_MULTRET = -1
static val mutable LUA_MULTRET: int

Field Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LUA_TBOOLEAN Field

LuaBaseLUA_TBOOLEAN Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LUA_TBOOLEAN"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected const int LUA_TBOOLEAN = 1
Protected Const LUA_TBOOLEAN As Integer = 1
protected:
literal int LUA_TBOOLEAN = 1
static val mutable LUA_TBOOLEAN: int

Field Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LUA_TFUNCTION Field

LuaBaseLUA_TFUNCTION Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LUA_TFUNCTION"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected const int LUA_TFUNCTION = 6
Protected Const LUA_TFUNCTION As Integer = 6
protected:
literal int LUA_TFUNCTION = 6
static val mutable LUA_TFUNCTION: int

Field Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LUA_TLIGHTUSERDATA Field

LuaBaseLUA_TLIGHTUSERDATA Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LUA_TLIGHTUSERDATA"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected const int LUA_TLIGHTUSERDATA = 2
Protected Const LUA_TLIGHTUSERDATA As Integer = 2
protected:
literal int LUA_TLIGHTUSERDATA = 2
static val mutable LUA_TLIGHTUSERDATA: int

Field Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LUA_TNIL Field

LuaBaseLUA_TNIL Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LUA_TNIL"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected const int LUA_TNIL = 0
Protected Const LUA_TNIL As Integer = 0
protected:
literal int LUA_TNIL = 0
static val mutable LUA_TNIL: int

Field Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LUA_TNONE Field

LuaBaseLUA_TNONE Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LUA_TNONE"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected const int LUA_TNONE = -1
Protected Const LUA_TNONE As Integer = -1
protected:
literal int LUA_TNONE = -1
static val mutable LUA_TNONE: int

Field Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LUA_TNUMBER Field

LuaBaseLUA_TNUMBER Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LUA_TNUMBER"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected const int LUA_TNUMBER = 3
Protected Const LUA_TNUMBER As Integer = 3
protected:
literal int LUA_TNUMBER = 3
static val mutable LUA_TNUMBER: int

Field Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LUA_TSTRING Field

LuaBaseLUA_TSTRING Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LUA_TSTRING"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected const int LUA_TSTRING = 4
Protected Const LUA_TSTRING As Integer = 4
protected:
literal int LUA_TSTRING = 4
static val mutable LUA_TSTRING: int

Field Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LUA_TTABLE Field

LuaBaseLUA_TTABLE Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LUA_TTABLE"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected const int LUA_TTABLE = 5
Protected Const LUA_TTABLE As Integer = 5
protected:
literal int LUA_TTABLE = 5
static val mutable LUA_TTABLE: int

Field Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LUA_TTHREAD Field

LuaBaseLUA_TTHREAD Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LUA_TTHREAD"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected const int LUA_TTHREAD = 8
Protected Const LUA_TTHREAD As Integer = 8
protected:
literal int LUA_TTHREAD = 8
static val mutable LUA_TTHREAD: int

Field Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaBase.LUA_TUSERDATA Field

LuaBaseLUA_TUSERDATA Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaBase.LUA_TUSERDATA"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected const int LUA_TUSERDATA = 7
Protected Const LUA_TUSERDATA As Integer = 7
protected:
literal int LUA_TUSERDATA = 7
static val mutable LUA_TUSERDATA: int

Field Value

Type: Int32
See Also

Reference

LuaBase Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaLBuffer Class

LuaLBuffer Class

[Missing <summary> documentation for "T:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer"]

Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.Interop.LuaStateInteropLuaLBuffer

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class LuaLBuffer
Public Class LuaLBuffer
public ref class LuaLBuffer
type LuaLBuffer =  class end

The LuaLBuffer type exposes the following members.

Constructors
 | Name | Description
Public method | LuaLBuffer | Initializes a new instance of the LuaLBuffer class
Top
Properties
 | Name | Description
Public property | LuaState |
Public property | StringBuilder |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaLBuffer Constructor

LuaLBuffer Constructor
Initializes a new instance of the LuaLBuffer class

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public LuaLBuffer(
    LuaState l
)
Public Sub New (
    l As LuaState
)
public:
LuaLBuffer(
    LuaState^ l
)
new :
        l : LuaState -> LuaLBuffer

Parameters

l
Type: MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

[Missing <param name="l"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer.#ctor(MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState)"]

See Also

Reference

LuaLBuffer Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaLBuffer Properties

LuaLBuffer Properties

The LuaLBuffer type exposes the following members.

Properties
 | Name | Description
Public property | LuaState |
Public property | StringBuilder |
Top
See Also

Reference

LuaLBuffer Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaLBuffer.LuaState Property

LuaLBufferLuaState Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer.LuaState"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public LuaState LuaState { get; }
Public ReadOnly Property LuaState As LuaState
    Get
public:
property LuaState^ LuaState {
    LuaState^ get ();
}
member LuaState : LuaState with get

Property Value

Type: LuaState
See Also

Reference

LuaLBuffer Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaLBuffer.StringBuilder Property

LuaLBufferStringBuilder Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaLBuffer.StringBuilder"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public StringBuilder StringBuilder { get; }
Public ReadOnly Property StringBuilder As StringBuilder
    Get
public:
property StringBuilder^ StringBuilder {
    StringBuilder^ get ();
}
member StringBuilder : StringBuilder with get

Property Value

Type: StringBuilder
See Also

Reference

LuaLBuffer Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaLBuffer Methods

LuaLBuffer Methods

The LuaLBuffer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LuaLBuffer Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaState Class

LuaState Class

[Missing <summary> documentation for "T:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState"]

Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.Interop.LuaStateInteropLuaState

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class LuaState
Public Class LuaState
public ref class LuaState
type LuaState =  class end

The LuaState type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | ExecutionContext |
Public property | FunctionName |
Top
Methods
 | Name | Description
Public method | At |
Public method | Discard |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetReturnValue |
Public method | GetTopArray |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pop |
Public method | Push |
Public method | Top |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaState Properties

LuaState Properties

The LuaState type exposes the following members.

Properties
 | Name | Description
Public property | Count |
Public property | ExecutionContext |
Public property | FunctionName |
Top
See Also

Reference

LuaState Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaState.Count Property

LuaStateCount Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState.Count"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
public:
property int Count {
    int get ();
}
member Count : int with get

Property Value

Type: Int32
See Also

Reference

LuaState Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaState.ExecutionContext Property

LuaStateExecutionContext Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState.ExecutionContext"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptExecutionContext ExecutionContext { get; }
Public ReadOnly Property ExecutionContext As ScriptExecutionContext
    Get
public:
property ScriptExecutionContext^ ExecutionContext {
    ScriptExecutionContext^ get ();
}
member ExecutionContext : ScriptExecutionContext with get

Property Value

Type: ScriptExecutionContext
See Also

Reference

LuaState Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaState.FunctionName Property

LuaStateFunctionName Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState.FunctionName"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string FunctionName { get; }
Public ReadOnly Property FunctionName As String
    Get
public:
property String^ FunctionName {
    String^ get ();
}
member FunctionName : string with get

Property Value

Type: String
See Also

Reference

LuaState Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaState Methods

LuaState Methods

The LuaState type exposes the following members.

Methods
 | Name | Description
Public method | At |
Public method | Discard |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetReturnValue |
Public method | GetTopArray |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Pop |
Public method | Push |
Public method | Top |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LuaState Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaState.At Method

LuaStateAt Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState.At(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue At(
    int pos
)
Public Function At (
    pos As Integer
) As DynValue
public:
DynValue^ At(
    int pos
)
member At :
        pos : int -> DynValue

Parameters

pos
Type: SystemInt32

[Missing <param name="pos"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState.At(System.Int32)"]

Return Value

Type: DynValue
See Also

Reference

LuaState Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaState.Discard Method

LuaStateDiscard Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState.Discard(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void Discard(
    int nargs
)
Public Sub Discard (
    nargs As Integer
)
public:
void Discard(
    int nargs
)
member Discard :
        nargs : int -> unit

Parameters

nargs
Type: SystemInt32

[Missing <param name="nargs"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState.Discard(System.Int32)"]

See Also

Reference

LuaState Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaState.GetReturnValue Method

LuaStateGetReturnValue Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState.GetReturnValue(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue GetReturnValue(
    int retvals
)
Public Function GetReturnValue (
    retvals As Integer
) As DynValue
public:
DynValue^ GetReturnValue(
    int retvals
)
member GetReturnValue :
        retvals : int -> DynValue

Parameters

retvals
Type: SystemInt32

[Missing <param name="retvals"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState.GetReturnValue(System.Int32)"]

Return Value

Type: DynValue
See Also

Reference

LuaState Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaState.GetTopArray Method

LuaStateGetTopArray Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState.GetTopArray(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue[] GetTopArray(
    int num
)
Public Function GetTopArray (
    num As Integer
) As DynValue()
public:
array<DynValue^>^ GetTopArray(
    int num
)
member GetTopArray :
        num : int -> DynValue[]

Parameters

num
Type: SystemInt32

[Missing <param name="num"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState.GetTopArray(System.Int32)"]

Return Value

Type: DynValue
See Also

Reference

LuaState Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaState.Pop Method

LuaStatePop Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState.Pop"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Pop()
Public Function Pop As DynValue
public:
DynValue^ Pop()
member Pop : unit -> DynValue

Return Value

Type: DynValue
See Also

Reference

LuaState Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaState.Push Method

LuaStatePush Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState.Push(MoonSharp.Interpreter.DynValue)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void Push(
    DynValue v
)
Public Sub Push (
    v As DynValue
)
public:
void Push(
    DynValue^ v
)
member Push :
        v : DynValue -> unit

Parameters

v
Type: MoonSharp.InterpreterDynValue

[Missing <param name="v"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState.Push(MoonSharp.Interpreter.DynValue)"]

See Also

Reference

LuaState Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


LuaState.Top Method

LuaStateTop Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState.Top(System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.LuaStateInterop
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue Top(
    int pos = 0
)
Public Function Top (
    Optional pos As Integer = 0
) As DynValue
public:
DynValue^ Top(
    int pos = 0
)
member Top :
        ?pos : int
(* Defaults:
        let _pos = defaultArg pos 0
*)
-> DynValue

Parameters

pos (Optional)
Type: SystemInt32

[Missing <param name="pos"/> documentation for "M:MoonSharp.Interpreter.Interop.LuaStateInterop.LuaState.Top(System.Int32)"]

Return Value

Type: DynValue
See Also

Reference

LuaState Class
MoonSharp.Interpreter.Interop.LuaStateInterop Namespace


MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace

MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace

[Missing <summary> documentation for "N:MoonSharp.Interpreter.Interop.RegistrationPolicies"]

Classes
 | Class | Description
Public class | AutomaticRegistrationPolicy | Similar to DefaultRegistrationPolicy, but with automatic type registration is disabled.
Public class | DefaultRegistrationPolicy | The default registration policy used by MoonSharp unless explicitely replaced. Deregistrations are allowed, but registration of a new descriptor are not allowed if a descriptor is already registered for that type. Automatic type registration is disabled.
Public class | PermanentRegistrationPolicy | A registration policy which makes registration permanent and not deletable. Deregistrations are not allowed and registrations of a new descriptor are not allowed if a descriptor is already registered for that type.
Interfaces
 | Interface | Description
Public interface | IRegistrationPolicy | Interface for managing how to handle


AutomaticRegistrationPolicy Class

AutomaticRegistrationPolicy Class
Similar to DefaultRegistrationPolicy, but with automatic type registration is disabled.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.Interop.RegistrationPoliciesDefaultRegistrationPolicy
MoonSharp.Interpreter.Interop.RegistrationPoliciesAutomaticRegistrationPolicy

Namespace: MoonSharp.Interpreter.Interop.RegistrationPolicies
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class AutomaticRegistrationPolicy : DefaultRegistrationPolicy
Public Class AutomaticRegistrationPolicy
    Inherits DefaultRegistrationPolicy
public ref class AutomaticRegistrationPolicy : public DefaultRegistrationPolicy
type AutomaticRegistrationPolicy =
    class
        inherit DefaultRegistrationPolicy
    end

The AutomaticRegistrationPolicy type exposes the following members.

Constructors
 | Name | Description
Public method | AutomaticRegistrationPolicy | Initializes a new instance of the AutomaticRegistrationPolicy class
Top
Methods
 | Name | Description
Public method | AllowTypeAutoRegistration | Allows type automatic registration for the specified type. NOTE: automatic type registration is NOT recommended. (Overrides DefaultRegistrationPolicyAllowTypeAutoRegistration(Type).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleRegistration | Called to handle the registration or deregistration of a type descriptor. Must return the type descriptor to be registered, or null to remove the registration. (Inherited from DefaultRegistrationPolicy.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace


AutomaticRegistrationPolicy Constructor

AutomaticRegistrationPolicy Constructor
Initializes a new instance of the AutomaticRegistrationPolicy class

Namespace: MoonSharp.Interpreter.Interop.RegistrationPolicies
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public AutomaticRegistrationPolicy()
Public Sub New
public:
AutomaticRegistrationPolicy()
new : unit -> AutomaticRegistrationPolicy
See Also

Reference

AutomaticRegistrationPolicy Class
MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace


AutomaticRegistrationPolicy Methods

AutomaticRegistrationPolicy Methods

The AutomaticRegistrationPolicy type exposes the following members.

Methods
 | Name | Description
Public method | AllowTypeAutoRegistration | Allows type automatic registration for the specified type. NOTE: automatic type registration is NOT recommended. (Overrides DefaultRegistrationPolicyAllowTypeAutoRegistration(Type).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleRegistration | Called to handle the registration or deregistration of a type descriptor. Must return the type descriptor to be registered, or null to remove the registration. (Inherited from DefaultRegistrationPolicy.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AutomaticRegistrationPolicy Class
MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace


AutomaticRegistrationPolicy.AllowTypeAutoRegistration Method

AutomaticRegistrationPolicyAllowTypeAutoRegistration Method
Allows type automatic registration for the specified type. NOTE: automatic type registration is NOT recommended.

Namespace: MoonSharp.Interpreter.Interop.RegistrationPolicies
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override bool AllowTypeAutoRegistration(
    Type type
)
Public Overrides Function AllowTypeAutoRegistration (
    type As Type
) As Boolean
public:
virtual bool AllowTypeAutoRegistration(
    Type^ type
) override
abstract AllowTypeAutoRegistration :
        type : Type -> bool
override AllowTypeAutoRegistration :
        type : Type -> bool

Parameters

type
Type: SystemType
The type.

Return Value

Type: Boolean
True to register the type automatically, false otherwise.

Implements

IRegistrationPolicyAllowTypeAutoRegistration(Type)
See Also

Reference

AutomaticRegistrationPolicy Class
MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace


DefaultRegistrationPolicy Class

DefaultRegistrationPolicy Class
The default registration policy used by MoonSharp unless explicitely replaced. Deregistrations are allowed, but registration of a new descriptor are not allowed if a descriptor is already registered for that type. Automatic type registration is disabled.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.Interop.RegistrationPoliciesDefaultRegistrationPolicy
MoonSharp.Interpreter.Interop.RegistrationPoliciesAutomaticRegistrationPolicy

Namespace: MoonSharp.Interpreter.Interop.RegistrationPolicies
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class DefaultRegistrationPolicy : IRegistrationPolicy
Public Class DefaultRegistrationPolicy
    Implements IRegistrationPolicy
public ref class DefaultRegistrationPolicy : IRegistrationPolicy
type DefaultRegistrationPolicy =
    class
        interface IRegistrationPolicy
    end

The DefaultRegistrationPolicy type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultRegistrationPolicy | Initializes a new instance of the DefaultRegistrationPolicy class
Top
Methods
 | Name | Description
Public method | AllowTypeAutoRegistration | Allows type automatic registration for the specified type. NOTE: automatic type registration is NOT recommended.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleRegistration | Called to handle the registration or deregistration of a type descriptor. Must return the type descriptor to be registered, or null to remove the registration.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace


DefaultRegistrationPolicy Constructor

DefaultRegistrationPolicy Constructor
Initializes a new instance of the DefaultRegistrationPolicy class

Namespace: MoonSharp.Interpreter.Interop.RegistrationPolicies
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DefaultRegistrationPolicy()
Public Sub New
public:
DefaultRegistrationPolicy()
new : unit -> DefaultRegistrationPolicy
See Also

Reference

DefaultRegistrationPolicy Class
MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace


DefaultRegistrationPolicy Methods

DefaultRegistrationPolicy Methods

The DefaultRegistrationPolicy type exposes the following members.

Methods
 | Name | Description
Public method | AllowTypeAutoRegistration | Allows type automatic registration for the specified type. NOTE: automatic type registration is NOT recommended.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleRegistration | Called to handle the registration or deregistration of a type descriptor. Must return the type descriptor to be registered, or null to remove the registration.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DefaultRegistrationPolicy Class
MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace


DefaultRegistrationPolicy.AllowTypeAutoRegistration Method

DefaultRegistrationPolicyAllowTypeAutoRegistration Method
Allows type automatic registration for the specified type. NOTE: automatic type registration is NOT recommended.

Namespace: MoonSharp.Interpreter.Interop.RegistrationPolicies
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool AllowTypeAutoRegistration(
    Type type
)
Public Overridable Function AllowTypeAutoRegistration (
    type As Type
) As Boolean
public:
virtual bool AllowTypeAutoRegistration(
    Type^ type
)
abstract AllowTypeAutoRegistration :
        type : Type -> bool
override AllowTypeAutoRegistration :
        type : Type -> bool

Parameters

type
Type: SystemType
The type.

Return Value

Type: Boolean
True to register the type automatically, false otherwise.

Implements

IRegistrationPolicyAllowTypeAutoRegistration(Type)
See Also

Reference

DefaultRegistrationPolicy Class
MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace


DefaultRegistrationPolicy.HandleRegistration Method

DefaultRegistrationPolicyHandleRegistration Method
Called to handle the registration or deregistration of a type descriptor. Must return the type descriptor to be registered, or null to remove the registration.

Namespace: MoonSharp.Interpreter.Interop.RegistrationPolicies
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IUserDataDescriptor HandleRegistration(
    IUserDataDescriptor newDescriptor,
    IUserDataDescriptor oldDescriptor
)
Public Function HandleRegistration (
    newDescriptor As IUserDataDescriptor,
    oldDescriptor As IUserDataDescriptor
) As IUserDataDescriptor
public:
virtual IUserDataDescriptor^ HandleRegistration(
    IUserDataDescriptor^ newDescriptor,
    IUserDataDescriptor^ oldDescriptor
) sealed
abstract HandleRegistration :
        newDescriptor : IUserDataDescriptor *
        oldDescriptor : IUserDataDescriptor -> IUserDataDescriptor
override HandleRegistration :
        newDescriptor : IUserDataDescriptor *
        oldDescriptor : IUserDataDescriptor -> IUserDataDescriptor

Parameters

newDescriptor
Type: MoonSharp.Interpreter.InteropIUserDataDescriptor
The new descriptor, or null if this is a deregistration.
oldDescriptor
Type: MoonSharp.Interpreter.InteropIUserDataDescriptor
The old descriptor, or null if no descriptor was previously registered for this type.

Return Value

Type: IUserDataDescriptor

Implements

IRegistrationPolicyHandleRegistration(IUserDataDescriptor, IUserDataDescriptor)
See Also

Reference

DefaultRegistrationPolicy Class
MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace


IRegistrationPolicy Interface

IRegistrationPolicy Interface
Interface for managing how to handle

Namespace: MoonSharp.Interpreter.Interop.RegistrationPolicies
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public interface IRegistrationPolicy
Public Interface IRegistrationPolicy
public interface class IRegistrationPolicy
type IRegistrationPolicy =  interface end

The IRegistrationPolicy type exposes the following members.

Methods
 | Name | Description
Public method | AllowTypeAutoRegistration | Allows type automatic registration for the specified type. NOTE: automatic type registration is NOT recommended.
Public method | HandleRegistration | Called to handle the registration or deregistration of a type descriptor. Must return the type descriptor to be registered, or null to remove the registration.
Top
See Also

Reference

MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace


IRegistrationPolicy Methods

IRegistrationPolicy Methods

The IRegistrationPolicy type exposes the following members.

Methods
 | Name | Description
Public method | AllowTypeAutoRegistration | Allows type automatic registration for the specified type. NOTE: automatic type registration is NOT recommended.
Public method | HandleRegistration | Called to handle the registration or deregistration of a type descriptor. Must return the type descriptor to be registered, or null to remove the registration.
Top
See Also

Reference

IRegistrationPolicy Interface
MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace


IRegistrationPolicy.AllowTypeAutoRegistration Method

IRegistrationPolicyAllowTypeAutoRegistration Method
Allows type automatic registration for the specified type. NOTE: automatic type registration is NOT recommended.

Namespace: MoonSharp.Interpreter.Interop.RegistrationPolicies
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
bool AllowTypeAutoRegistration(
    Type type
)
Function AllowTypeAutoRegistration (
    type As Type
) As Boolean
bool AllowTypeAutoRegistration(
    Type^ type
)
abstract AllowTypeAutoRegistration :
        type : Type -> bool

Parameters

type
Type: SystemType
The type.

Return Value

Type: Boolean
True to register the type automatically, false otherwise.
See Also

Reference

IRegistrationPolicy Interface
MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace


IRegistrationPolicy.HandleRegistration Method

IRegistrationPolicyHandleRegistration Method
Called to handle the registration or deregistration of a type descriptor. Must return the type descriptor to be registered, or null to remove the registration.

Namespace: MoonSharp.Interpreter.Interop.RegistrationPolicies
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
IUserDataDescriptor HandleRegistration(
    IUserDataDescriptor newDescriptor,
    IUserDataDescriptor oldDescriptor
)
Function HandleRegistration (
    newDescriptor As IUserDataDescriptor,
    oldDescriptor As IUserDataDescriptor
) As IUserDataDescriptor
IUserDataDescriptor^ HandleRegistration(
    IUserDataDescriptor^ newDescriptor,
    IUserDataDescriptor^ oldDescriptor
)
abstract HandleRegistration :
        newDescriptor : IUserDataDescriptor *
        oldDescriptor : IUserDataDescriptor -> IUserDataDescriptor

Parameters

newDescriptor
Type: MoonSharp.Interpreter.InteropIUserDataDescriptor
The new descriptor, or null if this is a deregistration.
oldDescriptor
Type: MoonSharp.Interpreter.InteropIUserDataDescriptor
The old descriptor, or null if no descriptor was previously registered for this type.

Return Value

Type: IUserDataDescriptor
See Also

Reference

IRegistrationPolicy Interface
MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace


PermanentRegistrationPolicy Class

PermanentRegistrationPolicy Class
A registration policy which makes registration permanent and not deletable. Deregistrations are not allowed and registrations of a new descriptor are not allowed if a descriptor is already registered for that type.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.Interop.RegistrationPoliciesPermanentRegistrationPolicy

Namespace: MoonSharp.Interpreter.Interop.RegistrationPolicies
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class PermanentRegistrationPolicy : IRegistrationPolicy
Public Class PermanentRegistrationPolicy
    Implements IRegistrationPolicy
public ref class PermanentRegistrationPolicy : IRegistrationPolicy
type PermanentRegistrationPolicy =
    class
        interface IRegistrationPolicy
    end

The PermanentRegistrationPolicy type exposes the following members.

Constructors
 | Name | Description
Public method | PermanentRegistrationPolicy | Initializes a new instance of the PermanentRegistrationPolicy class
Top
Methods
 | Name | Description
Public method | AllowTypeAutoRegistration | Allows type automatic registration for the specified type. NOTE: automatic type registration is NOT recommended.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleRegistration | Called to handle the registration or deregistration of a type descriptor. Must return the type descriptor to be registered, or null to remove the registration.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace


PermanentRegistrationPolicy Constructor

PermanentRegistrationPolicy Constructor
Initializes a new instance of the PermanentRegistrationPolicy class

Namespace: MoonSharp.Interpreter.Interop.RegistrationPolicies
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public PermanentRegistrationPolicy()
Public Sub New
public:
PermanentRegistrationPolicy()
new : unit -> PermanentRegistrationPolicy
See Also

Reference

PermanentRegistrationPolicy Class
MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace


PermanentRegistrationPolicy Methods

PermanentRegistrationPolicy Methods

The PermanentRegistrationPolicy type exposes the following members.

Methods
 | Name | Description
Public method | AllowTypeAutoRegistration | Allows type automatic registration for the specified type. NOTE: automatic type registration is NOT recommended.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleRegistration | Called to handle the registration or deregistration of a type descriptor. Must return the type descriptor to be registered, or null to remove the registration.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PermanentRegistrationPolicy Class
MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace


PermanentRegistrationPolicy.AllowTypeAutoRegistration Method

PermanentRegistrationPolicyAllowTypeAutoRegistration Method
Allows type automatic registration for the specified type. NOTE: automatic type registration is NOT recommended.

Namespace: MoonSharp.Interpreter.Interop.RegistrationPolicies
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool AllowTypeAutoRegistration(
    Type type
)
Public Function AllowTypeAutoRegistration (
    type As Type
) As Boolean
public:
virtual bool AllowTypeAutoRegistration(
    Type^ type
) sealed
abstract AllowTypeAutoRegistration :
        type : Type -> bool
override AllowTypeAutoRegistration :
        type : Type -> bool

Parameters

type
Type: SystemType
The type.

Return Value

Type: Boolean
True to register the type automatically, false otherwise.

Implements

IRegistrationPolicyAllowTypeAutoRegistration(Type)
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

PermanentRegistrationPolicy Class
MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace


PermanentRegistrationPolicy.HandleRegistration Method

PermanentRegistrationPolicyHandleRegistration Method
Called to handle the registration or deregistration of a type descriptor. Must return the type descriptor to be registered, or null to remove the registration.

Namespace: MoonSharp.Interpreter.Interop.RegistrationPolicies
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public IUserDataDescriptor HandleRegistration(
    IUserDataDescriptor newDescriptor,
    IUserDataDescriptor oldDescriptor
)
Public Function HandleRegistration (
    newDescriptor As IUserDataDescriptor,
    oldDescriptor As IUserDataDescriptor
) As IUserDataDescriptor
public:
virtual IUserDataDescriptor^ HandleRegistration(
    IUserDataDescriptor^ newDescriptor,
    IUserDataDescriptor^ oldDescriptor
) sealed
abstract HandleRegistration :
        newDescriptor : IUserDataDescriptor *
        oldDescriptor : IUserDataDescriptor -> IUserDataDescriptor
override HandleRegistration :
        newDescriptor : IUserDataDescriptor *
        oldDescriptor : IUserDataDescriptor -> IUserDataDescriptor

Parameters

newDescriptor
Type: MoonSharp.Interpreter.InteropIUserDataDescriptor
The new descriptor, or null if this is a deregistration.
oldDescriptor
Type: MoonSharp.Interpreter.InteropIUserDataDescriptor
The old descriptor, or null if no descriptor was previously registered for this type.

Return Value

Type: IUserDataDescriptor

Implements

IRegistrationPolicyHandleRegistration(IUserDataDescriptor, IUserDataDescriptor)
See Also

Reference

PermanentRegistrationPolicy Class
MoonSharp.Interpreter.Interop.RegistrationPolicies Namespace


MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace

MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace

[Missing <summary> documentation for "N:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors"]

Classes
 | Class | Description
Public class | DefaultValue |
Public class | HardwiredMemberDescriptor |
Public class | HardwiredMethodMemberDescriptor |
Public class | HardwiredUserDataDescriptor |


DefaultValue Class

DefaultValue Class

[Missing <summary> documentation for "T:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.DefaultValue"]

Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptorsDefaultValue

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DefaultValue
Public NotInheritable Class DefaultValue
public ref class DefaultValue sealed
[<SealedAttribute>]
type DefaultValue =  class end

The DefaultValue type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultValue | Initializes a new instance of the DefaultValue class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
Instance |
Top
See Also

Reference

MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


DefaultValue Constructor

DefaultValue Constructor
Initializes a new instance of the DefaultValue class

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DefaultValue()
Public Sub New
public:
DefaultValue()
new : unit -> DefaultValue
See Also

Reference

DefaultValue Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


DefaultValue Methods

DefaultValue Methods

The DefaultValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DefaultValue Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


DefaultValue Fields

DefaultValue Fields

The DefaultValue type exposes the following members.

Fields
Name | Description
Instance |
Top
See Also

Reference

DefaultValue Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


DefaultValue.Instance Field

DefaultValueInstance Field

[Missing <summary> documentation for "F:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.DefaultValue.Instance"]

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static readonly DefaultValue Instance
Public Shared ReadOnly Instance As DefaultValue
public:
static initonly DefaultValue^ Instance
static val Instance: DefaultValue

Field Value

Type: DefaultValue
See Also

Reference

DefaultValue Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredMemberDescriptor Class

HardwiredMemberDescriptor Class

[Missing <summary> documentation for "T:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor"]

Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptorsHardwiredMemberDescriptor

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class HardwiredMemberDescriptor : IMemberDescriptor
Public MustInherit Class HardwiredMemberDescriptor
    Implements IMemberDescriptor
public ref class HardwiredMemberDescriptor abstract : IMemberDescriptor
[<AbstractClassAttribute>]
type HardwiredMemberDescriptor =
    class
        interface IMemberDescriptor
    end

The HardwiredMemberDescriptor type exposes the following members.

Constructors
 | Name | Description
Protected method | HardwiredMemberDescriptor | Initializes a new instance of the HardwiredMemberDescriptor class
Top
Properties
 | Name | Description
Public property | IsStatic |
Public property | MemberAccess |
Public property | MemberType |
Public property | Name |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue |
Protected method | GetValueImpl |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValue |
Protected method | SetValueImpl |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredMemberDescriptor Constructor

HardwiredMemberDescriptor Constructor
Initializes a new instance of the HardwiredMemberDescriptor class

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected HardwiredMemberDescriptor(
    Type memberType,
    string name,
    bool isStatic,
    MemberDescriptorAccess access
)
Protected Sub New (
    memberType As Type,
    name As String,
    isStatic As Boolean,
    access As MemberDescriptorAccess
)
protected:
HardwiredMemberDescriptor(
    Type^ memberType,
    String^ name,
    bool isStatic,
    MemberDescriptorAccess access
)
new :
        memberType : Type *
        name : string *
        isStatic : bool *
        access : MemberDescriptorAccess -> HardwiredMemberDescriptor

Parameters

memberType
Type: SystemType

[Missing <param name="memberType"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.#ctor(System.Type,System.String,System.Boolean,MoonSharp.Interpreter.Interop.BasicDescriptors.MemberDescriptorAccess)"]

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.#ctor(System.Type,System.String,System.Boolean,MoonSharp.Interpreter.Interop.BasicDescriptors.MemberDescriptorAccess)"]

isStatic
Type: SystemBoolean

[Missing <param name="isStatic"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.#ctor(System.Type,System.String,System.Boolean,MoonSharp.Interpreter.Interop.BasicDescriptors.MemberDescriptorAccess)"]

access
Type: MoonSharp.Interpreter.Interop.BasicDescriptorsMemberDescriptorAccess

[Missing <param name="access"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.#ctor(System.Type,System.String,System.Boolean,MoonSharp.Interpreter.Interop.BasicDescriptors.MemberDescriptorAccess)"]

See Also

Reference

HardwiredMemberDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredMemberDescriptor Properties

HardwiredMemberDescriptor Properties

The HardwiredMemberDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | IsStatic |
Public property | MemberAccess |
Public property | MemberType |
Public property | Name |
Top
See Also

Reference

HardwiredMemberDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredMemberDescriptor.IsStatic Property

HardwiredMemberDescriptorIsStatic Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.IsStatic"]

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsStatic { get; }
Public ReadOnly Property IsStatic As Boolean
    Get
public:
virtual property bool IsStatic {
    bool get () sealed;
}
abstract IsStatic : bool with get
override IsStatic : bool with get

Property Value

Type: Boolean

Implements

IMemberDescriptorIsStatic
See Also

Reference

HardwiredMemberDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredMemberDescriptor.MemberAccess Property

HardwiredMemberDescriptorMemberAccess Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.MemberAccess"]

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public MemberDescriptorAccess MemberAccess { get; }
Public ReadOnly Property MemberAccess As MemberDescriptorAccess
    Get
public:
virtual property MemberDescriptorAccess MemberAccess {
    MemberDescriptorAccess get () sealed;
}
abstract MemberAccess : MemberDescriptorAccess with get
override MemberAccess : MemberDescriptorAccess with get

Property Value

Type: MemberDescriptorAccess

Implements

IMemberDescriptorMemberAccess
See Also

Reference

HardwiredMemberDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredMemberDescriptor.MemberType Property

HardwiredMemberDescriptorMemberType Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.MemberType"]

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public Type MemberType { get; }
Public ReadOnly Property MemberType As Type
    Get
public:
property Type^ MemberType {
    Type^ get ();
}
member MemberType : Type with get

Property Value

Type: Type
See Also

Reference

HardwiredMemberDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredMemberDescriptor.Name Property

HardwiredMemberDescriptorName Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.Name"]

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () sealed;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IMemberDescriptorName
See Also

Reference

HardwiredMemberDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredMemberDescriptor Methods

HardwiredMemberDescriptor Methods

The HardwiredMemberDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue |
Protected method | GetValueImpl |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValue |
Protected method | SetValueImpl |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CanExecute | Determines whether this instance can be executed (called as a function) (Defined by MemberDescriptor.)
Public Extension Method | CanRead | Determines whether this instance can be read (Defined by MemberDescriptor.)
Public Extension Method | CanWrite | Determines whether this instance can be written to (Defined by MemberDescriptor.)
Public Extension Method | CheckAccess | Raises an appropriate ScriptRuntimeException if the specified access is not supported. Checks are made for the MemberDescriptorAccess permissions AND for the access of instance members through static userdatas. (Defined by MemberDescriptor.)
Public Extension Method | GetGetterCallbackAsDynValue | Gets the getter of the member as a DynValue containing a callback (Defined by MemberDescriptor.)
Public Extension Method | WithAccessOrNull | Returns the specified descriptor if it supports all the specified access modes, otherwise returns null. (Defined by MemberDescriptor.)
Top
See Also

Reference

HardwiredMemberDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredMemberDescriptor.GetValue Method

HardwiredMemberDescriptorGetValue Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.GetValue(MoonSharp.Interpreter.Script,System.Object)"]

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public DynValue GetValue(
    Script script,
    Object obj
)
Public Function GetValue (
    script As Script,
    obj As Object
) As DynValue
public:
virtual DynValue^ GetValue(
    Script^ script,
    Object^ obj
) sealed
abstract GetValue :
        script : Script *
        obj : Object -> DynValue
override GetValue :
        script : Script *
        obj : Object -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript

[Missing <param name="script"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.GetValue(MoonSharp.Interpreter.Script,System.Object)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.GetValue(MoonSharp.Interpreter.Script,System.Object)"]

Return Value

Type: DynValue

Implements

IMemberDescriptorGetValue(Script, Object)
See Also

Reference

HardwiredMemberDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredMemberDescriptor.GetValueImpl Method

HardwiredMemberDescriptorGetValueImpl Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.GetValueImpl(MoonSharp.Interpreter.Script,System.Object)"]

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual Object GetValueImpl(
    Script script,
    Object obj
)
Protected Overridable Function GetValueImpl (
    script As Script,
    obj As Object
) As Object
protected:
virtual Object^ GetValueImpl(
    Script^ script,
    Object^ obj
)
abstract GetValueImpl :
        script : Script *
        obj : Object -> Object
override GetValueImpl :
        script : Script *
        obj : Object -> Object

Parameters

script
Type: MoonSharp.InterpreterScript

[Missing <param name="script"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.GetValueImpl(MoonSharp.Interpreter.Script,System.Object)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.GetValueImpl(MoonSharp.Interpreter.Script,System.Object)"]

Return Value

Type: Object
See Also

Reference

HardwiredMemberDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredMemberDescriptor.SetValue Method

HardwiredMemberDescriptorSetValue Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.SetValue(MoonSharp.Interpreter.Script,System.Object,MoonSharp.Interpreter.DynValue)"]

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public void SetValue(
    Script script,
    Object obj,
    DynValue value
)
Public Sub SetValue (
    script As Script,
    obj As Object,
    value As DynValue
)
public:
virtual void SetValue(
    Script^ script,
    Object^ obj,
    DynValue^ value
) sealed
abstract SetValue :
        script : Script *
        obj : Object *
        value : DynValue -> unit
override SetValue :
        script : Script *
        obj : Object *
        value : DynValue -> unit

Parameters

script
Type: MoonSharp.InterpreterScript

[Missing <param name="script"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.SetValue(MoonSharp.Interpreter.Script,System.Object,MoonSharp.Interpreter.DynValue)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.SetValue(MoonSharp.Interpreter.Script,System.Object,MoonSharp.Interpreter.DynValue)"]

value
Type: MoonSharp.InterpreterDynValue

[Missing <param name="value"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.SetValue(MoonSharp.Interpreter.Script,System.Object,MoonSharp.Interpreter.DynValue)"]

Implements

IMemberDescriptorSetValue(Script, Object, DynValue)
See Also

Reference

HardwiredMemberDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredMemberDescriptor.SetValueImpl Method

HardwiredMemberDescriptorSetValueImpl Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.SetValueImpl(MoonSharp.Interpreter.Script,System.Object,System.Object)"]

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual void SetValueImpl(
    Script script,
    Object obj,
    Object value
)
Protected Overridable Sub SetValueImpl (
    script As Script,
    obj As Object,
    value As Object
)
protected:
virtual void SetValueImpl(
    Script^ script,
    Object^ obj,
    Object^ value
)
abstract SetValueImpl :
        script : Script *
        obj : Object *
        value : Object -> unit
override SetValueImpl :
        script : Script *
        obj : Object *
        value : Object -> unit

Parameters

script
Type: MoonSharp.InterpreterScript

[Missing <param name="script"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.SetValueImpl(MoonSharp.Interpreter.Script,System.Object,System.Object)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.SetValueImpl(MoonSharp.Interpreter.Script,System.Object,System.Object)"]

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMemberDescriptor.SetValueImpl(MoonSharp.Interpreter.Script,System.Object,System.Object)"]

See Also

Reference

HardwiredMemberDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredMethodMemberDescriptor Class

HardwiredMethodMemberDescriptor Class

[Missing <summary> documentation for "T:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMethodMemberDescriptor"]

Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.InteropFunctionMemberDescriptorBase
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptorsHardwiredMethodMemberDescriptor

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class HardwiredMethodMemberDescriptor : FunctionMemberDescriptorBase
Public MustInherit Class HardwiredMethodMemberDescriptor
    Inherits FunctionMemberDescriptorBase
public ref class HardwiredMethodMemberDescriptor abstract : public FunctionMemberDescriptorBase
[<AbstractClassAttribute>]
type HardwiredMethodMemberDescriptor =
    class
        inherit FunctionMemberDescriptorBase
    end

The HardwiredMethodMemberDescriptor type exposes the following members.

Constructors
 | Name | Description
Protected method | HardwiredMethodMemberDescriptor | Initializes a new instance of the HardwiredMethodMemberDescriptor class
Top
Properties
 | Name | Description
Public property | ExtensionMethodType | Gets the type which this extension method extends, null if this is not an extension method. (Inherited from FunctionMemberDescriptorBase.)
Public property | IsStatic | Gets a value indicating whether the described method is static. (Inherited from FunctionMemberDescriptorBase.)
Public property | MemberAccess | Gets the types of access supported by this member (Inherited from FunctionMemberDescriptorBase.)
Public property | Name | Gets the name of the described method (Inherited from FunctionMemberDescriptorBase.)
Public property | Parameters | Gets the type of the arguments of the underlying CLR function (Inherited from FunctionMemberDescriptorBase.)
Public property | SortDiscriminant | Gets a sort discriminant to give consistent overload resolution matching in case of perfectly equal scores (Inherited from FunctionMemberDescriptorBase.)
Public property | VarArgsArrayType | Gets a value indicating the type of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned. (Inherited from FunctionMemberDescriptorBase.)
Public property | VarArgsElementType | Gets a value indicating the type of the elements of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned. (Inherited from FunctionMemberDescriptorBase.)
Top
Methods
 | Name | Description
Protected method | BuildArgumentList | Builds the argument list. (Inherited from FunctionMemberDescriptorBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | (Overrides FunctionMemberDescriptorBaseExecute(Script, Object, ScriptExecutionContext, CallbackArguments).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCallback | Gets a callback function as a delegate (Inherited from FunctionMemberDescriptorBase.)
Public method | GetCallbackAsDynValue | Gets the callback function as a DynValue. (Inherited from FunctionMemberDescriptorBase.)
Public method | GetCallbackFunction | Gets the callback function. (Inherited from FunctionMemberDescriptorBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts. (Inherited from FunctionMemberDescriptorBase.)
Protected method | Initialize | Initializes this instance. This *MUST* be called by the constructors extending this class to complete initialization. (Inherited from FunctionMemberDescriptorBase.)
Protected method | Invoke |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValue | Sets the value. (Inherited from FunctionMemberDescriptorBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredMethodMemberDescriptor Constructor

HardwiredMethodMemberDescriptor Constructor
Initializes a new instance of the HardwiredMethodMemberDescriptor class

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected HardwiredMethodMemberDescriptor()
Protected Sub New
protected:
HardwiredMethodMemberDescriptor()
new : unit -> HardwiredMethodMemberDescriptor
See Also

Reference

HardwiredMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredMethodMemberDescriptor Properties

HardwiredMethodMemberDescriptor Properties

The HardwiredMethodMemberDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | ExtensionMethodType | Gets the type which this extension method extends, null if this is not an extension method. (Inherited from FunctionMemberDescriptorBase.)
Public property | IsStatic | Gets a value indicating whether the described method is static. (Inherited from FunctionMemberDescriptorBase.)
Public property | MemberAccess | Gets the types of access supported by this member (Inherited from FunctionMemberDescriptorBase.)
Public property | Name | Gets the name of the described method (Inherited from FunctionMemberDescriptorBase.)
Public property | Parameters | Gets the type of the arguments of the underlying CLR function (Inherited from FunctionMemberDescriptorBase.)
Public property | SortDiscriminant | Gets a sort discriminant to give consistent overload resolution matching in case of perfectly equal scores (Inherited from FunctionMemberDescriptorBase.)
Public property | VarArgsArrayType | Gets a value indicating the type of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned. (Inherited from FunctionMemberDescriptorBase.)
Public property | VarArgsElementType | Gets a value indicating the type of the elements of the ParamArray parameter of a var-args function. If the function is not var-args, null is returned. (Inherited from FunctionMemberDescriptorBase.)
Top
See Also

Reference

HardwiredMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredMethodMemberDescriptor Methods

HardwiredMethodMemberDescriptor Methods

The HardwiredMethodMemberDescriptor type exposes the following members.

Methods
 | Name | Description
Protected method | BuildArgumentList | Builds the argument list. (Inherited from FunctionMemberDescriptorBase.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Execute | (Overrides FunctionMemberDescriptorBaseExecute(Script, Object, ScriptExecutionContext, CallbackArguments).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCallback | Gets a callback function as a delegate (Inherited from FunctionMemberDescriptorBase.)
Public method | GetCallbackAsDynValue | Gets the callback function as a DynValue. (Inherited from FunctionMemberDescriptorBase.)
Public method | GetCallbackFunction | Gets the callback function. (Inherited from FunctionMemberDescriptorBase.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets the value of this member as a DynValue to be exposed to scripts. (Inherited from FunctionMemberDescriptorBase.)
Protected method | Initialize | Initializes this instance. This *MUST* be called by the constructors extending this class to complete initialization. (Inherited from FunctionMemberDescriptorBase.)
Protected method | Invoke |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValue | Sets the value. (Inherited from FunctionMemberDescriptorBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HardwiredMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredMethodMemberDescriptor.Execute Method

HardwiredMethodMemberDescriptorExecute Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMethodMemberDescriptor.Execute(MoonSharp.Interpreter.Script,System.Object,MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override DynValue Execute(
    Script script,
    Object obj,
    ScriptExecutionContext context,
    CallbackArguments args
)
Public Overrides Function Execute (
    script As Script,
    obj As Object,
    context As ScriptExecutionContext,
    args As CallbackArguments
) As DynValue
public:
virtual DynValue^ Execute(
    Script^ script,
    Object^ obj,
    ScriptExecutionContext^ context,
    CallbackArguments^ args
) override
abstract Execute :
        script : Script *
        obj : Object *
        context : ScriptExecutionContext *
        args : CallbackArguments -> DynValue
override Execute :
        script : Script *
        obj : Object *
        context : ScriptExecutionContext *
        args : CallbackArguments -> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript

[Missing <param name="script"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMethodMemberDescriptor.Execute(MoonSharp.Interpreter.Script,System.Object,MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMethodMemberDescriptor.Execute(MoonSharp.Interpreter.Script,System.Object,MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

context
Type: MoonSharp.InterpreterScriptExecutionContext

[Missing <param name="context"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMethodMemberDescriptor.Execute(MoonSharp.Interpreter.Script,System.Object,MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

args
Type: MoonSharp.InterpreterCallbackArguments

[Missing <param name="args"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMethodMemberDescriptor.Execute(MoonSharp.Interpreter.Script,System.Object,MoonSharp.Interpreter.ScriptExecutionContext,MoonSharp.Interpreter.CallbackArguments)"]

Return Value

Type: DynValue

Implements

IOverloadableMemberDescriptorExecute(Script, Object, ScriptExecutionContext, CallbackArguments)
See Also

Reference

HardwiredMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredMethodMemberDescriptor.Invoke Method

HardwiredMethodMemberDescriptorInvoke Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMethodMemberDescriptor.Invoke(MoonSharp.Interpreter.Script,System.Object,System.Object[],System.Int32)"]

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected abstract Object Invoke(
    Script script,
    Object obj,
    Object[] pars,
    int argscount
)
Protected MustOverride Function Invoke (
    script As Script,
    obj As Object,
    pars As Object(),
    argscount As Integer
) As Object
protected:
virtual Object^ Invoke(
    Script^ script,
    Object^ obj,
    array<Object^>^ pars,
    int argscount
) abstract
abstract Invoke :
        script : Script *
        obj : Object *
        pars : Object[] *
        argscount : int -> Object

Parameters

script
Type: MoonSharp.InterpreterScript

[Missing <param name="script"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMethodMemberDescriptor.Invoke(MoonSharp.Interpreter.Script,System.Object,System.Object[],System.Int32)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMethodMemberDescriptor.Invoke(MoonSharp.Interpreter.Script,System.Object,System.Object[],System.Int32)"]

pars
Type: SystemObject

[Missing <param name="pars"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMethodMemberDescriptor.Invoke(MoonSharp.Interpreter.Script,System.Object,System.Object[],System.Int32)"]

argscount
Type: SystemInt32

[Missing <param name="argscount"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredMethodMemberDescriptor.Invoke(MoonSharp.Interpreter.Script,System.Object,System.Object[],System.Int32)"]

Return Value

Type: Object
See Also

Reference

HardwiredMethodMemberDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredUserDataDescriptor Class

HardwiredUserDataDescriptor Class

[Missing <summary> documentation for "T:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredUserDataDescriptor"]

Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.Interop.BasicDescriptorsDispatchingUserDataDescriptor
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptorsHardwiredUserDataDescriptor

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class HardwiredUserDataDescriptor : DispatchingUserDataDescriptor
Public MustInherit Class HardwiredUserDataDescriptor
    Inherits DispatchingUserDataDescriptor
public ref class HardwiredUserDataDescriptor abstract : public DispatchingUserDataDescriptor
[<AbstractClassAttribute>]
type HardwiredUserDataDescriptor =
    class
        inherit DispatchingUserDataDescriptor
    end

The HardwiredUserDataDescriptor type exposes the following members.

Constructors
 | Name | Description
Protected method | HardwiredUserDataDescriptor | Initializes a new instance of the HardwiredUserDataDescriptor class
Top
Properties
 | Name | Description
Public property | FriendlyName | Gets a human readable friendly name of the descriptor (Inherited from DispatchingUserDataDescriptor.)
Public property | MemberNames | Gets the member names. (Inherited from DispatchingUserDataDescriptor.)
Public property | Members | Gets the members. (Inherited from DispatchingUserDataDescriptor.)
Public property | MetaMemberNames | Gets the meta member names. (Inherited from DispatchingUserDataDescriptor.)
Public property | MetaMembers | Gets the meta members. (Inherited from DispatchingUserDataDescriptor.)
Public property | Name | Gets the name of the descriptor (usually, the name of the type described). (Inherited from DispatchingUserDataDescriptor.)
Public property | Type | Gets the type this descriptor refers to (Inherited from DispatchingUserDataDescriptor.)
Top
Methods
Name Description
Public method AddDynValue
Adds a DynValue as a member
(Inherited from DispatchingUserDataDescriptor.)
Public method AddMember
Adds a property to the member list
(Inherited from DispatchingUserDataDescriptor.)
Public method AddMetaMember
Adds a member to the meta-members list.
(Inherited from DispatchingUserDataDescriptor.)
Public method AsString
Converts this userdata to string
(Inherited from DispatchingUserDataDescriptor.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method ExecuteIndexer
Executes the specified indexer method.
(Inherited from DispatchingUserDataDescriptor.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method FindMember
Finds the member with a given name. If not found, null is returned.
(Inherited from DispatchingUserDataDescriptor.)
Public method FindMetaMember
Finds the meta member with a given name. If not found, null is returned.
(Inherited from DispatchingUserDataDescriptor.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasMember
Determines whether the descriptor contains the specified member (by exact name)
(Inherited from DispatchingUserDataDescriptor.)
Public method HasMetaMember
Determines whether the descriptor contains the specified member in the meta list (by exact name)
(Inherited from DispatchingUserDataDescriptor.)
Public method Index
Performs an "index" "get" operation. This tries to resolve minor variations of member names.
(Inherited from DispatchingUserDataDescriptor.)
Public method IsTypeCompatible
Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "
(Inherited from DispatchingUserDataDescriptor.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method MetaIndex
Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). See MetaIndex(Script, Object, String) for further details. If a method exists marked with MoonSharpUserDataMetamethodAttribute for the specific metamethod requested, that method is returned. If the above fails, the following dispatching occur: __add, __sub, __mul, __div, __mod and __unm are dispatched to C# operator overloads (if they exist) __eq is dispatched to System.Object.Equals. __lt and __le are dispatched IComparable.Compare, if the type implements IComparable or IComparable{object} __len is dispatched to Length and Count properties, if those exist. __iterator is handled if the object implements IEnumerable or IEnumerator. __tonumber is dispatched to implicit or explicit conversion operators to standard numeric types. __tobool is dispatched to an implicit or explicit conversion operator to bool. If that fails, operator true is used. The script originating the requestThe object (null if a static request is done)The name of the metamember.
(Inherited from DispatchingUserDataDescriptor.)
Public method RemoveMember
Removes the member with a given name. In case of overloaded functions, all overloads are removed.
(Inherited from DispatchingUserDataDescriptor.)
Public method RemoveMetaMember
Removes the meta member with a given name. In case of overloaded functions, all overloads are removed.
(Inherited from DispatchingUserDataDescriptor.)
Public method SetIndex
Performs an "index" "set" operation. This tries to resolve minor variations of member names.
(Inherited from DispatchingUserDataDescriptor.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Protected method TryIndex
Tries to perform an indexing operation by checking methods and properties for the given indexName
(Inherited from DispatchingUserDataDescriptor.)
Protected method TrySetIndex
Tries to perform an indexing "set" operation by checking methods and properties for the given indexName
(Inherited from DispatchingUserDataDescriptor.)
Top
See Also

Reference

MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredUserDataDescriptor Constructor

HardwiredUserDataDescriptor Constructor
Initializes a new instance of the HardwiredUserDataDescriptor class

Namespace: MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected HardwiredUserDataDescriptor(
    Type T
)
Protected Sub New (
    T As Type
)
protected:
HardwiredUserDataDescriptor(
    Type^ T
)
new :
        T : Type -> HardwiredUserDataDescriptor

Parameters

T
Type: SystemType

[Missing <param name="T"/> documentation for "M:MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors.HardwiredUserDataDescriptor.#ctor(System.Type)"]

See Also

Reference

HardwiredUserDataDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredUserDataDescriptor Properties

HardwiredUserDataDescriptor Properties

The HardwiredUserDataDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | FriendlyName | Gets a human readable friendly name of the descriptor (Inherited from DispatchingUserDataDescriptor.)
Public property | MemberNames | Gets the member names. (Inherited from DispatchingUserDataDescriptor.)
Public property | Members | Gets the members. (Inherited from DispatchingUserDataDescriptor.)
Public property | MetaMemberNames | Gets the meta member names. (Inherited from DispatchingUserDataDescriptor.)
Public property | MetaMembers | Gets the meta members. (Inherited from DispatchingUserDataDescriptor.)
Public property | Name | Gets the name of the descriptor (usually, the name of the type described). (Inherited from DispatchingUserDataDescriptor.)
Public property | Type | Gets the type this descriptor refers to (Inherited from DispatchingUserDataDescriptor.)
Top
See Also

Reference

HardwiredUserDataDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


HardwiredUserDataDescriptor Methods

HardwiredUserDataDescriptor Methods

The HardwiredUserDataDescriptor type exposes the following members.

Methods
Name Description
Public method AddDynValue
Adds a DynValue as a member
(Inherited from DispatchingUserDataDescriptor.)
Public method AddMember
Adds a property to the member list
(Inherited from DispatchingUserDataDescriptor.)
Public method AddMetaMember
Adds a member to the meta-members list.
(Inherited from DispatchingUserDataDescriptor.)
Public method AsString
Converts this userdata to string
(Inherited from DispatchingUserDataDescriptor.)
Public method Equals
Determines whether the specified object is equal to the current object.
(Inherited from Object.)
Protected method ExecuteIndexer
Executes the specified indexer method.
(Inherited from DispatchingUserDataDescriptor.)
Protected method Finalize
Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection.
(Inherited from Object.)
Public method FindMember
Finds the member with a given name. If not found, null is returned.
(Inherited from DispatchingUserDataDescriptor.)
Public method FindMetaMember
Finds the meta member with a given name. If not found, null is returned.
(Inherited from DispatchingUserDataDescriptor.)
Public method GetHashCode
Serves as the default hash function.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method HasMember
Determines whether the descriptor contains the specified member (by exact name)
(Inherited from DispatchingUserDataDescriptor.)
Public method HasMetaMember
Determines whether the descriptor contains the specified member in the meta list (by exact name)
(Inherited from DispatchingUserDataDescriptor.)
Public method Index
Performs an "index" "get" operation. This tries to resolve minor variations of member names.
(Inherited from DispatchingUserDataDescriptor.)
Public method IsTypeCompatible
Determines whether the specified object is compatible with the specified type. Unless a very specific behaviour is needed, the correct implementation is a simple " return type.IsInstanceOfType(obj); "
(Inherited from DispatchingUserDataDescriptor.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method MetaIndex
Gets a "meta" operation on this userdata. If a descriptor does not support this functionality, it should return "null" (not a nil). See MetaIndex(Script, Object, String) for further details. If a method exists marked with MoonSharpUserDataMetamethodAttribute for the specific metamethod requested, that method is returned. If the above fails, the following dispatching occur: __add, __sub, __mul, __div, __mod and __unm are dispatched to C# operator overloads (if they exist) __eq is dispatched to System.Object.Equals. __lt and __le are dispatched IComparable.Compare, if the type implements IComparable or IComparable{object} __len is dispatched to Length and Count properties, if those exist. __iterator is handled if the object implements IEnumerable or IEnumerator. __tonumber is dispatched to implicit or explicit conversion operators to standard numeric types. __tobool is dispatched to an implicit or explicit conversion operator to bool. If that fails, operator true is used. The script originating the requestThe object (null if a static request is done)The name of the metamember.
(Inherited from DispatchingUserDataDescriptor.)
Public method RemoveMember
Removes the member with a given name. In case of overloaded functions, all overloads are removed.
(Inherited from DispatchingUserDataDescriptor.)
Public method RemoveMetaMember
Removes the meta member with a given name. In case of overloaded functions, all overloads are removed.
(Inherited from DispatchingUserDataDescriptor.)
Public method SetIndex
Performs an "index" "set" operation. This tries to resolve minor variations of member names.
(Inherited from DispatchingUserDataDescriptor.)
Public method ToString
Returns a string that represents the current object.
(Inherited from Object.)
Protected method TryIndex
Tries to perform an indexing operation by checking methods and properties for the given indexName
(Inherited from DispatchingUserDataDescriptor.)
Protected method TrySetIndex
Tries to perform an indexing "set" operation by checking methods and properties for the given indexName
(Inherited from DispatchingUserDataDescriptor.)
Top
See Also

Reference

HardwiredUserDataDescriptor Class
MoonSharp.Interpreter.Interop.StandardDescriptors.HardwiredDescriptors Namespace


MoonSharp.Interpreter.IO Namespace

MoonSharp.Interpreter.IO Namespace

[Missing <summary> documentation for "N:MoonSharp.Interpreter.IO"]

Classes
 | Class | Description
Public class | BinDumpBinaryReader | "Optimized" BinaryReader which shares strings and use a dumb compression for integers
Public class | BinDumpBinaryWriter | "Optimized" BinaryWriter which shares strings and use a dumb compression for integers
Public class | UndisposableStream | An adapter over Stream which bypasses the Dispose and Close methods. Used to work around the pesky wrappers .NET has over Stream (BinaryReader, StreamWriter, etc.) which think they own the Stream and close them when they shouldn't. Damn.


BinDumpBinaryReader Class

BinDumpBinaryReader Class
"Optimized" BinaryReader which shares strings and use a dumb compression for integers
Inheritance Hierarchy
SystemObject
System.IOBinaryReader
MoonSharp.Interpreter.IOBinDumpBinaryReader

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class BinDumpBinaryReader : BinaryReader
Public Class BinDumpBinaryReader
    Inherits BinaryReader
public ref class BinDumpBinaryReader : public BinaryReader
type BinDumpBinaryReader =
    class
        inherit BinaryReader
    end

The BinDumpBinaryReader type exposes the following members.

Constructors
 | Name | Description
Public method | BinDumpBinaryReader(Stream) | Initializes a new instance of the BinDumpBinaryReader class
Public method | BinDumpBinaryReader(Stream, Encoding) | Initializes a new instance of the BinDumpBinaryReader class
Top
Properties
 | Name | Description
Public property | BaseStream | (Inherited from BinaryReader.)
Top
Methods
 | Name | Description
Public method | Close | Closes the current reader and the underlying stream. (Inherited from BinaryReader.)
Public method | Dispose | (Inherited from BinaryReader.)
Protected method | Dispose(Boolean) | (Inherited from BinaryReader.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | FillBuffer | (Inherited from BinaryReader.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PeekChar | (Inherited from BinaryReader.)
Public method | Read | (Inherited from BinaryReader.)
Public method | Read(Char, Int32, Int32) | (Inherited from BinaryReader.)
Public method | Read(Byte, Int32, Int32) | (Inherited from BinaryReader.)
Protected method | Read7BitEncodedInt | (Inherited from BinaryReader.)
Public method | ReadBoolean | (Inherited from BinaryReader.)
Public method | ReadByte | (Inherited from BinaryReader.)
Public method | ReadBytes | (Inherited from BinaryReader.)
Public method | ReadChar | (Inherited from BinaryReader.)
Public method | ReadChars | (Inherited from BinaryReader.)
Public method | ReadDecimal | (Inherited from BinaryReader.)
Public method | ReadDouble | (Inherited from BinaryReader.)
Public method | ReadInt16 | (Inherited from BinaryReader.)
Public method | ReadInt32 | (Overrides BinaryReaderReadInt32.)
Public method | ReadInt64 | (Inherited from BinaryReader.)
Public method | ReadSByte | (Inherited from BinaryReader.)
Public method | ReadSingle | (Inherited from BinaryReader.)
Public method | ReadString | (Overrides BinaryReaderReadString.)
Public method | ReadUInt16 | (Inherited from BinaryReader.)
Public method | ReadUInt32 | (Overrides BinaryReaderReadUInt32.)
Public method | ReadUInt64 | (Inherited from BinaryReader.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.IO Namespace


BinDumpBinaryReader Constructor

BinDumpBinaryReader Constructor
Overload List
 | Name | Description
Public method | BinDumpBinaryReader(Stream) | Initializes a new instance of the BinDumpBinaryReader class
Public method | BinDumpBinaryReader(Stream, Encoding) | Initializes a new instance of the BinDumpBinaryReader class
Top
See Also

Reference

BinDumpBinaryReader Class
MoonSharp.Interpreter.IO Namespace


BinDumpBinaryReader Constructor (Stream)

BinDumpBinaryReader Constructor (Stream)
Initializes a new instance of the BinDumpBinaryReader class

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public BinDumpBinaryReader(
    Stream s
)
Public Sub New (
    s As Stream
)
public:
BinDumpBinaryReader(
    Stream^ s
)
new :
        s : Stream -> BinDumpBinaryReader

Parameters

s
Type: System.IOStream

[Missing <param name="s"/> documentation for "M:MoonSharp.Interpreter.IO.BinDumpBinaryReader.#ctor(System.IO.Stream)"]

See Also

Reference

BinDumpBinaryReader Class
BinDumpBinaryReader Overload
MoonSharp.Interpreter.IO Namespace


BinDumpBinaryReader Constructor (Stream, Encoding)

BinDumpBinaryReader Constructor (Stream, Encoding)
Initializes a new instance of the BinDumpBinaryReader class

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public BinDumpBinaryReader(
    Stream s,
    Encoding e
)
Public Sub New (
    s As Stream,
    e As Encoding
)
public:
BinDumpBinaryReader(
    Stream^ s,
    Encoding^ e
)
new :
        s : Stream *
        e : Encoding -> BinDumpBinaryReader

Parameters

s
Type: System.IOStream

[Missing <param name="s"/> documentation for "M:MoonSharp.Interpreter.IO.BinDumpBinaryReader.#ctor(System.IO.Stream,System.Text.Encoding)"]

e
Type: System.TextEncoding

[Missing <param name="e"/> documentation for "M:MoonSharp.Interpreter.IO.BinDumpBinaryReader.#ctor(System.IO.Stream,System.Text.Encoding)"]

See Also

Reference

BinDumpBinaryReader Class
BinDumpBinaryReader Overload
MoonSharp.Interpreter.IO Namespace


BinDumpBinaryReader Properties

BinDumpBinaryReader Properties

The BinDumpBinaryReader type exposes the following members.

Properties
 | Name | Description
Public property | BaseStream | (Inherited from BinaryReader.)
Top
See Also

Reference

BinDumpBinaryReader Class
MoonSharp.Interpreter.IO Namespace


BinDumpBinaryReader Methods

BinDumpBinaryReader Methods

The BinDumpBinaryReader type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the current reader and the underlying stream. (Inherited from BinaryReader.)
Public method | Dispose | (Inherited from BinaryReader.)
Protected method | Dispose(Boolean) | (Inherited from BinaryReader.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | FillBuffer | (Inherited from BinaryReader.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PeekChar | (Inherited from BinaryReader.)
Public method | Read | (Inherited from BinaryReader.)
Public method | Read(Char, Int32, Int32) | (Inherited from BinaryReader.)
Public method | Read(Byte, Int32, Int32) | (Inherited from BinaryReader.)
Protected method | Read7BitEncodedInt | (Inherited from BinaryReader.)
Public method | ReadBoolean | (Inherited from BinaryReader.)
Public method | ReadByte | (Inherited from BinaryReader.)
Public method | ReadBytes | (Inherited from BinaryReader.)
Public method | ReadChar | (Inherited from BinaryReader.)
Public method | ReadChars | (Inherited from BinaryReader.)
Public method | ReadDecimal | (Inherited from BinaryReader.)
Public method | ReadDouble | (Inherited from BinaryReader.)
Public method | ReadInt16 | (Inherited from BinaryReader.)
Public method | ReadInt32 | (Overrides BinaryReaderReadInt32.)
Public method | ReadInt64 | (Inherited from BinaryReader.)
Public method | ReadSByte | (Inherited from BinaryReader.)
Public method | ReadSingle | (Inherited from BinaryReader.)
Public method | ReadString | (Overrides BinaryReaderReadString.)
Public method | ReadUInt16 | (Inherited from BinaryReader.)
Public method | ReadUInt32 | (Overrides BinaryReaderReadUInt32.)
Public method | ReadUInt64 | (Inherited from BinaryReader.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BinDumpBinaryReader Class
MoonSharp.Interpreter.IO Namespace


BinDumpBinaryReader.ReadInt32 Method

BinDumpBinaryReaderReadInt32 Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.BinDumpBinaryReader.ReadInt32"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override int ReadInt32()
Public Overrides Function ReadInt32 As Integer
public:
virtual int ReadInt32() override
abstract ReadInt32 : unit -> int
override ReadInt32 : unit -> int

Return Value

Type: Int32
See Also

Reference

BinDumpBinaryReader Class
MoonSharp.Interpreter.IO Namespace


BinDumpBinaryReader.ReadString Method

BinDumpBinaryReaderReadString Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.BinDumpBinaryReader.ReadString"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override string ReadString()
Public Overrides Function ReadString As String
public:
virtual String^ ReadString() override
abstract ReadString : unit -> string
override ReadString : unit -> string

Return Value

Type: String
See Also

Reference

BinDumpBinaryReader Class
MoonSharp.Interpreter.IO Namespace


BinDumpBinaryReader.ReadUInt32 Method

BinDumpBinaryReaderReadUInt32 Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.BinDumpBinaryReader.ReadUInt32"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override uint ReadUInt32()
Public Overrides Function ReadUInt32 As UInteger
public:
virtual unsigned int ReadUInt32() override
abstract ReadUInt32 : unit -> uint32
override ReadUInt32 : unit -> uint32

Return Value

Type: UInt32
See Also

Reference

BinDumpBinaryReader Class
MoonSharp.Interpreter.IO Namespace


BinDumpBinaryWriter Class

BinDumpBinaryWriter Class
"Optimized" BinaryWriter which shares strings and use a dumb compression for integers
Inheritance Hierarchy
SystemObject
System.IOBinaryWriter
MoonSharp.Interpreter.IOBinDumpBinaryWriter

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class BinDumpBinaryWriter : BinaryWriter
Public Class BinDumpBinaryWriter
    Inherits BinaryWriter
public ref class BinDumpBinaryWriter : public BinaryWriter
type BinDumpBinaryWriter =
    class
        inherit BinaryWriter
    end

The BinDumpBinaryWriter type exposes the following members.

Constructors
 | Name | Description
Public method | BinDumpBinaryWriter(Stream) | Initializes a new instance of the BinDumpBinaryWriter class
Public method | BinDumpBinaryWriter(Stream, Encoding) | Initializes a new instance of the BinDumpBinaryWriter class
Top
Properties
 | Name | Description
Public property | BaseStream | (Inherited from BinaryWriter.)
Top
Methods
 | Name | Description
Public method | Close | Closes the current BinaryWriter and the underlying stream. (Inherited from BinaryWriter.)
Public method | Dispose | (Inherited from BinaryWriter.)
Protected method | Dispose(Boolean) | (Inherited from BinaryWriter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | (Inherited from BinaryWriter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Seek | (Inherited from BinaryWriter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(Boolean) | (Inherited from BinaryWriter.)
Public method | Write(Byte) | (Inherited from BinaryWriter.)
Public method | Write(SByte) | (Inherited from BinaryWriter.)
Public method | Write(Byte) | (Inherited from BinaryWriter.)
Public method | Write(Char) | (Inherited from BinaryWriter.)
Public method | Write(Char) | (Inherited from BinaryWriter.)
Public method | Write(Double) | (Inherited from BinaryWriter.)
Public method | Write(Decimal) | (Inherited from BinaryWriter.)
Public method | Write(Int16) | (Inherited from BinaryWriter.)
Public method | Write(UInt16) | (Inherited from BinaryWriter.)
Public method | Write(Int64) | (Inherited from BinaryWriter.)
Public method | Write(UInt64) | (Inherited from BinaryWriter.)
Public method | Write(Single) | (Inherited from BinaryWriter.)
Public method | Write(Int32) | (Overrides BinaryWriterWrite(Int32).)
Public method | Write(String) | (Overrides BinaryWriterWrite(String).)
Public method | Write(UInt32) | (Overrides BinaryWriterWrite(UInt32).)
Public method | Write(Byte, Int32, Int32) | (Inherited from BinaryWriter.)
Public method | Write(Char, Int32, Int32) | (Inherited from BinaryWriter.)
Protected method | Write7BitEncodedInt | (Inherited from BinaryWriter.)
Top
Fields
 | Name | Description
Protected field | OutStream | (Inherited from BinaryWriter.)
Top
See Also

Reference

MoonSharp.Interpreter.IO Namespace


BinDumpBinaryWriter Constructor

BinDumpBinaryWriter Constructor
Overload List
 | Name | Description
Public method | BinDumpBinaryWriter(Stream) | Initializes a new instance of the BinDumpBinaryWriter class
Public method | BinDumpBinaryWriter(Stream, Encoding) | Initializes a new instance of the BinDumpBinaryWriter class
Top
See Also

Reference

BinDumpBinaryWriter Class
MoonSharp.Interpreter.IO Namespace


BinDumpBinaryWriter Constructor (Stream)

BinDumpBinaryWriter Constructor (Stream)
Initializes a new instance of the BinDumpBinaryWriter class

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public BinDumpBinaryWriter(
    Stream s
)
Public Sub New (
    s As Stream
)
public:
BinDumpBinaryWriter(
    Stream^ s
)
new :
        s : Stream -> BinDumpBinaryWriter

Parameters

s
Type: System.IOStream

[Missing <param name="s"/> documentation for "M:MoonSharp.Interpreter.IO.BinDumpBinaryWriter.#ctor(System.IO.Stream)"]

See Also

Reference

BinDumpBinaryWriter Class
BinDumpBinaryWriter Overload
MoonSharp.Interpreter.IO Namespace


BinDumpBinaryWriter Constructor (Stream, Encoding)

BinDumpBinaryWriter Constructor (Stream, Encoding)
Initializes a new instance of the BinDumpBinaryWriter class

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public BinDumpBinaryWriter(
    Stream s,
    Encoding e
)
Public Sub New (
    s As Stream,
    e As Encoding
)
public:
BinDumpBinaryWriter(
    Stream^ s,
    Encoding^ e
)
new :
        s : Stream *
        e : Encoding -> BinDumpBinaryWriter

Parameters

s
Type: System.IOStream

[Missing <param name="s"/> documentation for "M:MoonSharp.Interpreter.IO.BinDumpBinaryWriter.#ctor(System.IO.Stream,System.Text.Encoding)"]

e
Type: System.TextEncoding

[Missing <param name="e"/> documentation for "M:MoonSharp.Interpreter.IO.BinDumpBinaryWriter.#ctor(System.IO.Stream,System.Text.Encoding)"]

See Also

Reference

BinDumpBinaryWriter Class
BinDumpBinaryWriter Overload
MoonSharp.Interpreter.IO Namespace


BinDumpBinaryWriter Properties

BinDumpBinaryWriter Properties

The BinDumpBinaryWriter type exposes the following members.

Properties
 | Name | Description
Public property | BaseStream | (Inherited from BinaryWriter.)
Top
See Also

Reference

BinDumpBinaryWriter Class
MoonSharp.Interpreter.IO Namespace


BinDumpBinaryWriter Methods

BinDumpBinaryWriter Methods

The BinDumpBinaryWriter type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the current BinaryWriter and the underlying stream. (Inherited from BinaryWriter.)
Public method | Dispose | (Inherited from BinaryWriter.)
Protected method | Dispose(Boolean) | (Inherited from BinaryWriter.)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | (Inherited from BinaryWriter.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Seek | (Inherited from BinaryWriter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(Boolean) | (Inherited from BinaryWriter.)
Public method | Write(Byte) | (Inherited from BinaryWriter.)
Public method | Write(SByte) | (Inherited from BinaryWriter.)
Public method | Write(Byte) | (Inherited from BinaryWriter.)
Public method | Write(Char) | (Inherited from BinaryWriter.)
Public method | Write(Char) | (Inherited from BinaryWriter.)
Public method | Write(Double) | (Inherited from BinaryWriter.)
Public method | Write(Decimal) | (Inherited from BinaryWriter.)
Public method | Write(Int16) | (Inherited from BinaryWriter.)
Public method | Write(UInt16) | (Inherited from BinaryWriter.)
Public method | Write(Int64) | (Inherited from BinaryWriter.)
Public method | Write(UInt64) | (Inherited from BinaryWriter.)
Public method | Write(Single) | (Inherited from BinaryWriter.)
Public method | Write(Int32) | (Overrides BinaryWriterWrite(Int32).)
Public method | Write(String) | (Overrides BinaryWriterWrite(String).)
Public method | Write(UInt32) | (Overrides BinaryWriterWrite(UInt32).)
Public method | Write(Byte, Int32, Int32) | (Inherited from BinaryWriter.)
Public method | Write(Char, Int32, Int32) | (Inherited from BinaryWriter.)
Protected method | Write7BitEncodedInt | (Inherited from BinaryWriter.)
Top
See Also

Reference

BinDumpBinaryWriter Class
MoonSharp.Interpreter.IO Namespace


BinDumpBinaryWriter.Write Method

BinDumpBinaryWriterWrite Method
Overload List
 | Name | Description
Public method | Write(Boolean) | (Inherited from BinaryWriter.)
Public method | Write(Byte) | (Inherited from BinaryWriter.)
Public method | Write(SByte) | (Inherited from BinaryWriter.)
Public method | Write(Byte) | (Inherited from BinaryWriter.)
Public method | Write(Char) | (Inherited from BinaryWriter.)
Public method | Write(Char) | (Inherited from BinaryWriter.)
Public method | Write(Double) | (Inherited from BinaryWriter.)
Public method | Write(Decimal) | (Inherited from BinaryWriter.)
Public method | Write(Int16) | (Inherited from BinaryWriter.)
Public method | Write(UInt16) | (Inherited from BinaryWriter.)
Public method | Write(Int64) | (Inherited from BinaryWriter.)
Public method | Write(UInt64) | (Inherited from BinaryWriter.)
Public method | Write(Single) | (Inherited from BinaryWriter.)
Public method | Write(Int32) | (Overrides BinaryWriterWrite(Int32).)
Public method | Write(String) | (Overrides BinaryWriterWrite(String).)
Public method | Write(UInt32) | (Overrides BinaryWriterWrite(UInt32).)
Public method | Write(Byte, Int32, Int32) | (Inherited from BinaryWriter.)
Public method | Write(Char, Int32, Int32) | (Inherited from BinaryWriter.)
Top
See Also

Reference

BinDumpBinaryWriter Class
MoonSharp.Interpreter.IO Namespace


BinDumpBinaryWriter.Write Method (Int32)

BinDumpBinaryWriterWrite Method (Int32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.BinDumpBinaryWriter.Write(System.Int32)"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void Write(
    int value
)
Public Overrides Sub Write (
    value As Integer
)
public:
virtual void Write(
    int value
) override
abstract Write :
        value : int -> unit
override Write :
        value : int -> unit

Parameters

value
Type: SystemInt32

[Missing <param name="value"/> documentation for "M:MoonSharp.Interpreter.IO.BinDumpBinaryWriter.Write(System.Int32)"]

See Also

Reference

BinDumpBinaryWriter Class
Write Overload
MoonSharp.Interpreter.IO Namespace


BinDumpBinaryWriter.Write Method (String)

BinDumpBinaryWriterWrite Method (String)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.BinDumpBinaryWriter.Write(System.String)"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void Write(
    string value
)
Public Overrides Sub Write (
    value As String
)
public:
virtual void Write(
    String^ value
) override
abstract Write :
        value : string -> unit
override Write :
        value : string -> unit

Parameters

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:MoonSharp.Interpreter.IO.BinDumpBinaryWriter.Write(System.String)"]

See Also

Reference

BinDumpBinaryWriter Class
Write Overload
MoonSharp.Interpreter.IO Namespace


BinDumpBinaryWriter.Write Method (UInt32)

BinDumpBinaryWriterWrite Method (UInt32)

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.BinDumpBinaryWriter.Write(System.UInt32)"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void Write(
    uint value
)
Public Overrides Sub Write (
    value As UInteger
)
public:
virtual void Write(
    unsigned int value
) override
abstract Write :
        value : uint32 -> unit
override Write :
        value : uint32 -> unit

Parameters

value
Type: SystemUInt32

[Missing <param name="value"/> documentation for "M:MoonSharp.Interpreter.IO.BinDumpBinaryWriter.Write(System.UInt32)"]

See Also

Reference

BinDumpBinaryWriter Class
Write Overload
MoonSharp.Interpreter.IO Namespace


BinDumpBinaryWriter Fields

BinDumpBinaryWriter Fields

The BinDumpBinaryWriter type exposes the following members.

Fields
 | Name | Description
Protected field | OutStream | (Inherited from BinaryWriter.)
Top
See Also

Reference

BinDumpBinaryWriter Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream Class

UndisposableStream Class
An adapter over Stream which bypasses the Dispose and Close methods. Used to work around the pesky wrappers .NET has over Stream (BinaryReader, StreamWriter, etc.) which think they own the Stream and close them when they shouldn't. Damn.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
MoonSharp.Interpreter.IOUndisposableStream

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class UndisposableStream : Stream
Public Class UndisposableStream
    Inherits Stream
public ref class UndisposableStream : public Stream
type UndisposableStream =
    class
        inherit Stream
    end

The UndisposableStream type exposes the following members.

Constructors
 | Name | Description
Public method | UndisposableStream | Initializes a new instance of the UndisposableStream class
Top
Properties
 | Name | Description
Public property | CanRead | (Overrides StreamCanRead.)
Public property | CanSeek | (Overrides StreamCanSeek.)
Public property | CanTimeout | (Overrides StreamCanTimeout.)
Public property | CanWrite | (Overrides StreamCanWrite.)
Public property | Length | (Overrides StreamLength.)
Public property | Position | (Overrides StreamPosition.)
Public property | ReadTimeout | (Overrides StreamReadTimeout.)
Public property | WriteTimeout | (Overrides StreamWriteTimeout.)
Top
Methods
 | Name | Description
Public method | BeginRead | (Overrides StreamBeginRead(Byte, Int32, Int32, AsyncCallback, Object).)
Public method | BeginWrite | (Overrides StreamBeginWrite(Byte, Int32, Int32, AsyncCallback, Object).)
Public method | Close | (Overrides StreamClose.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the UndisposableStream and optionally releases the managed resources (Overrides StreamDispose(Boolean).)
Public method | EndRead | (Overrides StreamEndRead(IAsyncResult).)
Public method | EndWrite | (Overrides StreamEndWrite(IAsyncResult).)
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | (Overrides StreamFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Public method | Read | (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | (Overrides StreamReadByte.)
Public method | Seek | (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides StreamSetLength(Int64).)
Public method | ToString | (Overrides ObjectToString.)
Public method | Write | (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | (Overrides StreamWriteByte(Byte).)
Top
See Also

Reference

MoonSharp.Interpreter.IO Namespace


UndisposableStream Constructor

UndisposableStream Constructor
Initializes a new instance of the UndisposableStream class

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public UndisposableStream(
    Stream stream
)
Public Sub New (
    stream As Stream
)
public:
UndisposableStream(
    Stream^ stream
)
new :
        stream : Stream -> UndisposableStream

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.#ctor(System.IO.Stream)"]

See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream Properties

UndisposableStream Properties

The UndisposableStream type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | (Overrides StreamCanRead.)
Public property | CanSeek | (Overrides StreamCanSeek.)
Public property | CanTimeout | (Overrides StreamCanTimeout.)
Public property | CanWrite | (Overrides StreamCanWrite.)
Public property | Length | (Overrides StreamLength.)
Public property | Position | (Overrides StreamPosition.)
Public property | ReadTimeout | (Overrides StreamReadTimeout.)
Public property | WriteTimeout | (Overrides StreamWriteTimeout.)
Top
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.CanRead Property

UndisposableStreamCanRead Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.IO.UndisposableStream.CanRead"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
public:
virtual property bool CanRead {
    bool get () override;
}
abstract CanRead : bool with get
override CanRead : bool with get

Property Value

Type: Boolean
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.CanSeek Property

UndisposableStreamCanSeek Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.IO.UndisposableStream.CanSeek"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
public:
virtual property bool CanSeek {
    bool get () override;
}
abstract CanSeek : bool with get
override CanSeek : bool with get

Property Value

Type: Boolean
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.CanTimeout Property

UndisposableStreamCanTimeout Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.IO.UndisposableStream.CanTimeout"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CanTimeout { get; }
Public Overrides ReadOnly Property CanTimeout As Boolean
    Get
public:
virtual property bool CanTimeout {
    bool get () override;
}
abstract CanTimeout : bool with get
override CanTimeout : bool with get

Property Value

Type: Boolean
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.CanWrite Property

UndisposableStreamCanWrite Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.IO.UndisposableStream.CanWrite"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
public:
virtual property bool CanWrite {
    bool get () override;
}
abstract CanWrite : bool with get
override CanWrite : bool with get

Property Value

Type: Boolean
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.Length Property

UndisposableStreamLength Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.IO.UndisposableStream.Length"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
public:
virtual property long long Length {
    long long get () override;
}
abstract Length : int64 with get
override Length : int64 with get

Property Value

Type: Int64
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.Position Property

UndisposableStreamPosition Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.IO.UndisposableStream.Position"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}
abstract Position : int64 with get, set
override Position : int64 with get, set

Property Value

Type: Int64
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.ReadTimeout Property

UndisposableStreamReadTimeout Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.IO.UndisposableStream.ReadTimeout"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override int ReadTimeout { get; set; }
Public Overrides Property ReadTimeout As Integer
    Get
    Set
public:
virtual property int ReadTimeout {
    int get () override;
    void set (int value) override;
}
abstract ReadTimeout : int with get, set
override ReadTimeout : int with get, set

Property Value

Type: Int32
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.WriteTimeout Property

UndisposableStreamWriteTimeout Property

[Missing <summary> documentation for "P:MoonSharp.Interpreter.IO.UndisposableStream.WriteTimeout"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override int WriteTimeout { get; set; }
Public Overrides Property WriteTimeout As Integer
    Get
    Set
public:
virtual property int WriteTimeout {
    int get () override;
    void set (int value) override;
}
abstract WriteTimeout : int with get, set
override WriteTimeout : int with get, set

Property Value

Type: Int32
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream Methods

UndisposableStream Methods

The UndisposableStream type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | (Overrides StreamBeginRead(Byte, Int32, Int32, AsyncCallback, Object).)
Public method | BeginWrite | (Overrides StreamBeginWrite(Byte, Int32, Int32, AsyncCallback, Object).)
Public method | Close | (Overrides StreamClose.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | (Overrides StreamDispose(Boolean).)
Public method | EndRead | (Overrides StreamEndRead(IAsyncResult).)
Public method | EndWrite | (Overrides StreamEndWrite(IAsyncResult).)
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | (Overrides StreamFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Public method | Read | (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | (Overrides StreamReadByte.)
Public method | Seek | (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides StreamSetLength(Int64).)
Public method | ToString | (Overrides ObjectToString.)
Public method | Write | (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | (Overrides StreamWriteByte(Byte).)
Top
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.BeginRead Method

UndisposableStreamBeginRead Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.BeginRead(System.Byte[],System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override IAsyncResult BeginRead(
    byte[] buffer,
    int offset,
    int count,
    AsyncCallback callback,
    Object state
)
Public Overrides Function BeginRead (
    buffer As Byte(),
    offset As Integer,
    count As Integer,
    callback As AsyncCallback,
    state As Object
) As IAsyncResult
public:
virtual IAsyncResult^ BeginRead(
    array<unsigned char>^ buffer,
    int offset,
    int count,
    AsyncCallback^ callback,
    Object^ state
) override
abstract BeginRead :
        buffer : byte[] *
        offset : int *
        count : int *
        callback : AsyncCallback *
        state : Object -> IAsyncResult
override BeginRead :
        buffer : byte[] *
        offset : int *
        count : int *
        callback : AsyncCallback *
        state : Object -> IAsyncResult

Parameters

buffer
Type: SystemByte

[Missing <param name="buffer"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.BeginRead(System.Byte[],System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.BeginRead(System.Byte[],System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.BeginRead(System.Byte[],System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

callback
Type: SystemAsyncCallback

[Missing <param name="callback"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.BeginRead(System.Byte[],System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

state
Type: SystemObject

[Missing <param name="state"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.BeginRead(System.Byte[],System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

Type: IAsyncResult
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.BeginWrite Method

UndisposableStreamBeginWrite Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.BeginWrite(System.Byte[],System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override IAsyncResult BeginWrite(
    byte[] buffer,
    int offset,
    int count,
    AsyncCallback callback,
    Object state
)
Public Overrides Function BeginWrite (
    buffer As Byte(),
    offset As Integer,
    count As Integer,
    callback As AsyncCallback,
    state As Object
) As IAsyncResult
public:
virtual IAsyncResult^ BeginWrite(
    array<unsigned char>^ buffer,
    int offset,
    int count,
    AsyncCallback^ callback,
    Object^ state
) override
abstract BeginWrite :
        buffer : byte[] *
        offset : int *
        count : int *
        callback : AsyncCallback *
        state : Object -> IAsyncResult
override BeginWrite :
        buffer : byte[] *
        offset : int *
        count : int *
        callback : AsyncCallback *
        state : Object -> IAsyncResult

Parameters

buffer
Type: SystemByte

[Missing <param name="buffer"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.BeginWrite(System.Byte[],System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.BeginWrite(System.Byte[],System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.BeginWrite(System.Byte[],System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

callback
Type: SystemAsyncCallback

[Missing <param name="callback"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.BeginWrite(System.Byte[],System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

state
Type: SystemObject

[Missing <param name="state"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.BeginWrite(System.Byte[],System.Int32,System.Int32,System.AsyncCallback,System.Object)"]

Return Value

Type: IAsyncResult
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.Close Method

UndisposableStreamClose Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.Close"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void Close()
Public Overrides Sub Close
public:
virtual void Close() override
abstract Close : unit -> unit
override Close : unit -> unit
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.Dispose Method

UndisposableStreamDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the UndisposableStream and optionally releases the managed resources (Overrides StreamDispose(Boolean).)
Top
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.Dispose Method (Boolean)

UndisposableStreamDispose Method (Boolean)
Releases the unmanaged resources used by the UndisposableStream and optionally releases the managed resources

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
protected:
virtual void Dispose(
    bool disposing
) override
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

UndisposableStream Class
Dispose Overload
MoonSharp.Interpreter.IO Namespace


UndisposableStream.EndRead Method

UndisposableStreamEndRead Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.EndRead(System.IAsyncResult)"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override int EndRead(
    IAsyncResult asyncResult
)
Public Overrides Function EndRead (
    asyncResult As IAsyncResult
) As Integer
public:
virtual int EndRead(
    IAsyncResult^ asyncResult
) override
abstract EndRead :
        asyncResult : IAsyncResult -> int
override EndRead :
        asyncResult : IAsyncResult -> int

Parameters

asyncResult
Type: SystemIAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.EndRead(System.IAsyncResult)"]

Return Value

Type: Int32
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.EndWrite Method

UndisposableStreamEndWrite Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.EndWrite(System.IAsyncResult)"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void EndWrite(
    IAsyncResult asyncResult
)
Public Overrides Sub EndWrite (
    asyncResult As IAsyncResult
)
public:
virtual void EndWrite(
    IAsyncResult^ asyncResult
) override
abstract EndWrite :
        asyncResult : IAsyncResult -> unit
override EndWrite :
        asyncResult : IAsyncResult -> unit

Parameters

asyncResult
Type: SystemIAsyncResult

[Missing <param name="asyncResult"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.EndWrite(System.IAsyncResult)"]

See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.Equals Method

UndisposableStreamEquals Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.Equals(System.Object)"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.Equals(System.Object)"]

Return Value

Type: Boolean
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.Flush Method

UndisposableStreamFlush Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.Flush"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void Flush()
Public Overrides Sub Flush
public:
virtual void Flush() override
abstract Flush : unit -> unit
override Flush : unit -> unit
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.GetHashCode Method

UndisposableStreamGetHashCode Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.GetHashCode"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.Read Method

UndisposableStreamRead Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.Read(System.Byte[],System.Int32,System.Int32)"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int

Parameters

buffer
Type: SystemByte

[Missing <param name="buffer"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.Read(System.Byte[],System.Int32,System.Int32)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.Read(System.Byte[],System.Int32,System.Int32)"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.Read(System.Byte[],System.Int32,System.Int32)"]

Return Value

Type: Int32
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.ReadByte Method

UndisposableStreamReadByte Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.ReadByte"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override int ReadByte()
Public Overrides Function ReadByte As Integer
public:
virtual int ReadByte() override
abstract ReadByte : unit -> int
override ReadByte : unit -> int

Return Value

Type: Int32
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.Seek Method

UndisposableStreamSeek Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.Seek(System.Int64,System.IO.SeekOrigin)"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64

Parameters

offset
Type: SystemInt64

[Missing <param name="offset"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.Seek(System.Int64,System.IO.SeekOrigin)"]

origin
Type: System.IOSeekOrigin

[Missing <param name="origin"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.Seek(System.Int64,System.IO.SeekOrigin)"]

Return Value

Type: Int64
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.SetLength Method

UndisposableStreamSetLength Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.SetLength(System.Int64)"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
public:
virtual void SetLength(
    long long value
) override
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit

Parameters

value
Type: SystemInt64

[Missing <param name="value"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.SetLength(System.Int64)"]

See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.ToString Method

UndisposableStreamToString Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.ToString"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String
See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.Write Method

UndisposableStreamWrite Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.Write(System.Byte[],System.Int32,System.Int32)"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit

Parameters

buffer
Type: SystemByte

[Missing <param name="buffer"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.Write(System.Byte[],System.Int32,System.Int32)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.Write(System.Byte[],System.Int32,System.Int32)"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.Write(System.Byte[],System.Int32,System.Int32)"]

See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


UndisposableStream.WriteByte Method

UndisposableStreamWriteByte Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.WriteByte(System.Byte)"]

Namespace: MoonSharp.Interpreter.IO
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void WriteByte(
    byte value
)
Public Overrides Sub WriteByte (
    value As Byte
)
public:
virtual void WriteByte(
    unsigned char value
) override
abstract WriteByte :
        value : byte -> unit
override WriteByte :
        value : byte -> unit

Parameters

value
Type: SystemByte

[Missing <param name="value"/> documentation for "M:MoonSharp.Interpreter.IO.UndisposableStream.WriteByte(System.Byte)"]

See Also

Reference

UndisposableStream Class
MoonSharp.Interpreter.IO Namespace


MoonSharp.Interpreter.Loaders Namespace

MoonSharp.Interpreter.Loaders Namespace
Namespace containing classes used to customized how scripts are loaded from external files.
Classes
 | Class | Description
Public class | EmbeddedResourcesScriptLoader | A script loader loading scripts from an assembly resources
Public class | FileSystemScriptLoader | A script loader loading scripts directly from the file system (does not go through platform object)
Public class | ScriptLoaderBase | A base implementation of IScriptLoader, offering resolution of module names.
Public class | UnityAssetsScriptLoader | A script loader which can load scripts from assets in Unity3D. Scripts should be saved as .txt files in a subdirectory of Assets/Resources. When MoonSharp is activated on Unity3D and the default script loader is used, scripts should be saved as .txt files in Assets/Resources/MoonSharp/Scripts.
Interfaces
 | Interface | Description
Public interface | IScriptLoader | Class dictating how requests to read scripts from files are handled. It's recommended that no class implement IScriptLoader directly, and rather extend ScriptLoaderBase.


EmbeddedResourcesScriptLoader Class

EmbeddedResourcesScriptLoader Class
A script loader loading scripts from an assembly resources
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.LoadersScriptLoaderBase
MoonSharp.Interpreter.LoadersEmbeddedResourcesScriptLoader

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class EmbeddedResourcesScriptLoader : ScriptLoaderBase
Public Class EmbeddedResourcesScriptLoader
    Inherits ScriptLoaderBase
public ref class EmbeddedResourcesScriptLoader : public ScriptLoaderBase
type EmbeddedResourcesScriptLoader =
    class
        inherit ScriptLoaderBase
    end

The EmbeddedResourcesScriptLoader type exposes the following members.

Constructors
 | Name | Description
Public method | EmbeddedResourcesScriptLoader | Initializes a new instance of the EmbeddedResourcesScriptLoader class.
Top
Properties
 | Name | Description
Public property | IgnoreLuaPathGlobal | Gets or sets a value indicating whether the LUA_PATH global is checked or not to get the path where modules are contained. If true, the LUA_PATH global is NOT checked. (Inherited from ScriptLoaderBase.)
Public property | ModulePaths | Gets or sets the modules paths used by the "require" function. If null, the default paths are used (using environment variables etc.). (Inherited from ScriptLoaderBase.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFile | Opens a file for reading the script code. It can return either a string, a byte[] or a Stream. If a byte[] is returned, the content is assumed to be a serialized (dumped) bytecode. If it's a string, it's assumed to be either a script or the output of a string.dump call. If a Stream, autodetection takes place. (Overrides ScriptLoaderBaseLoadFile(String, Table).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResolveFileName | Resolves a filename [applying paths, etc.] (Inherited from ScriptLoaderBase.)
Public method | ResolveModuleName(String, Table) | Resolves the name of a module to a filename (which will later be passed to OpenScriptFile). The resolution happens first on paths included in the LUA_PATH global variable (if and only if the IgnoreLuaPathGlobal is false), and - if the variable does not exist - by consulting the ScriptOptions.ModulesPaths array. Override to provide a different behaviour. (Inherited from ScriptLoaderBase.)
Protected method | ResolveModuleName(String, String) | Resolves the name of a module on a set of paths. (Inherited from ScriptLoaderBase.)
Public method | ScriptFileExists | Checks if a script file exists. (Overrides ScriptLoaderBaseScriptFileExists(String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Loaders Namespace


EmbeddedResourcesScriptLoader Constructor

EmbeddedResourcesScriptLoader Constructor
Initializes a new instance of the EmbeddedResourcesScriptLoader class.

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public EmbeddedResourcesScriptLoader(
    Assembly resourceAssembly = null
)
Public Sub New (
    Optional resourceAssembly As Assembly = Nothing
)
public:
EmbeddedResourcesScriptLoader(
    Assembly^ resourceAssembly = nullptr
)
new :
        ?resourceAssembly : Assembly
(* Defaults:
        let _resourceAssembly = defaultArg resourceAssembly null
*)
-> EmbeddedResourcesScriptLoader

Parameters

resourceAssembly (Optional)
Type: System.ReflectionAssembly
The assembly containing the scripts as embedded resources or null to use the calling assembly.
See Also

Reference

EmbeddedResourcesScriptLoader Class
MoonSharp.Interpreter.Loaders Namespace


EmbeddedResourcesScriptLoader Properties

EmbeddedResourcesScriptLoader Properties

The EmbeddedResourcesScriptLoader type exposes the following members.

Properties
 | Name | Description
Public property | IgnoreLuaPathGlobal | Gets or sets a value indicating whether the LUA_PATH global is checked or not to get the path where modules are contained. If true, the LUA_PATH global is NOT checked. (Inherited from ScriptLoaderBase.)
Public property | ModulePaths | Gets or sets the modules paths used by the "require" function. If null, the default paths are used (using environment variables etc.). (Inherited from ScriptLoaderBase.)
Top
See Also

Reference

EmbeddedResourcesScriptLoader Class
MoonSharp.Interpreter.Loaders Namespace


EmbeddedResourcesScriptLoader Methods

EmbeddedResourcesScriptLoader Methods

The EmbeddedResourcesScriptLoader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFile | Opens a file for reading the script code. It can return either a string, a byte[] or a Stream. If a byte[] is returned, the content is assumed to be a serialized (dumped) bytecode. If it's a string, it's assumed to be either a script or the output of a string.dump call. If a Stream, autodetection takes place. (Overrides ScriptLoaderBaseLoadFile(String, Table).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResolveFileName | Resolves a filename [applying paths, etc.] (Inherited from ScriptLoaderBase.)
Public method | ResolveModuleName(String, Table) | Resolves the name of a module to a filename (which will later be passed to OpenScriptFile). The resolution happens first on paths included in the LUA_PATH global variable (if and only if the IgnoreLuaPathGlobal is false), and - if the variable does not exist - by consulting the ScriptOptions.ModulesPaths array. Override to provide a different behaviour. (Inherited from ScriptLoaderBase.)
Protected method | ResolveModuleName(String, String) | Resolves the name of a module on a set of paths. (Inherited from ScriptLoaderBase.)
Public method | ScriptFileExists | Checks if a script file exists. (Overrides ScriptLoaderBaseScriptFileExists(String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmbeddedResourcesScriptLoader Class
MoonSharp.Interpreter.Loaders Namespace


EmbeddedResourcesScriptLoader.LoadFile Method

EmbeddedResourcesScriptLoaderLoadFile Method
Opens a file for reading the script code. It can return either a string, a byte[] or a Stream. If a byte[] is returned, the content is assumed to be a serialized (dumped) bytecode. If it's a string, it's assumed to be either a script or the output of a string.dump call. If a Stream, autodetection takes place.

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override Object LoadFile(
    string file,
    Table globalContext
)
Public Overrides Function LoadFile (
    file As String,
    globalContext As Table
) As Object
public:
virtual Object^ LoadFile(
    String^ file,
    Table^ globalContext
) override
abstract LoadFile :
        file : string *
        globalContext : Table -> Object
override LoadFile :
        file : string *
        globalContext : Table -> Object

Parameters

file
Type: SystemString
The file.
globalContext
Type: MoonSharp.InterpreterTable
The global context.

Return Value

Type: Object
A string, a byte[] or a Stream.

Implements

IScriptLoaderLoadFile(String, Table)
See Also

Reference

EmbeddedResourcesScriptLoader Class
MoonSharp.Interpreter.Loaders Namespace


EmbeddedResourcesScriptLoader.ScriptFileExists Method

EmbeddedResourcesScriptLoaderScriptFileExists Method
Checks if a script file exists.

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ScriptFileExists(
    string name
)
Public Overrides Function ScriptFileExists (
    name As String
) As Boolean
public:
virtual bool ScriptFileExists(
    String^ name
) override
abstract ScriptFileExists :
        name : string -> bool
override ScriptFileExists :
        name : string -> bool

Parameters

name
Type: SystemString
The script filename.

Return Value

Type: Boolean
See Also

Reference

EmbeddedResourcesScriptLoader Class
MoonSharp.Interpreter.Loaders Namespace


FileSystemScriptLoader Class

FileSystemScriptLoader Class
A script loader loading scripts directly from the file system (does not go through platform object)
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.LoadersScriptLoaderBase
MoonSharp.Interpreter.LoadersFileSystemScriptLoader
MoonSharp.Interpreter.REPLReplInterpreterScriptLoader

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class FileSystemScriptLoader : ScriptLoaderBase
Public Class FileSystemScriptLoader
    Inherits ScriptLoaderBase
public ref class FileSystemScriptLoader : public ScriptLoaderBase
type FileSystemScriptLoader =
    class
        inherit ScriptLoaderBase
    end

The FileSystemScriptLoader type exposes the following members.

Constructors
 | Name | Description
Public method | FileSystemScriptLoader | Initializes a new instance of the FileSystemScriptLoader class
Top
Properties
 | Name | Description
Public property | IgnoreLuaPathGlobal | Gets or sets a value indicating whether the LUA_PATH global is checked or not to get the path where modules are contained. If true, the LUA_PATH global is NOT checked. (Inherited from ScriptLoaderBase.)
Public property | ModulePaths | Gets or sets the modules paths used by the "require" function. If null, the default paths are used (using environment variables etc.). (Inherited from ScriptLoaderBase.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFile | Opens a file for reading the script code. It can return either a string, a byte[] or a Stream. If a byte[] is returned, the content is assumed to be a serialized (dumped) bytecode. If it's a string, it's assumed to be either a script or the output of a string.dump call. If a Stream, autodetection takes place. (Overrides ScriptLoaderBaseLoadFile(String, Table).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResolveFileName | Resolves a filename [applying paths, etc.] (Inherited from ScriptLoaderBase.)
Public method | ResolveModuleName(String, Table) | Resolves the name of a module to a filename (which will later be passed to OpenScriptFile). The resolution happens first on paths included in the LUA_PATH global variable (if and only if the IgnoreLuaPathGlobal is false), and - if the variable does not exist - by consulting the ScriptOptions.ModulesPaths array. Override to provide a different behaviour. (Inherited from ScriptLoaderBase.)
Protected method | ResolveModuleName(String, String) | Resolves the name of a module on a set of paths. (Inherited from ScriptLoaderBase.)
Public method | ScriptFileExists | Checks if a script file exists. (Overrides ScriptLoaderBaseScriptFileExists(String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Loaders Namespace


FileSystemScriptLoader Constructor

FileSystemScriptLoader Constructor
Initializes a new instance of the FileSystemScriptLoader class

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public FileSystemScriptLoader()
Public Sub New
public:
FileSystemScriptLoader()
new : unit -> FileSystemScriptLoader
See Also

Reference

FileSystemScriptLoader Class
MoonSharp.Interpreter.Loaders Namespace


FileSystemScriptLoader Properties

FileSystemScriptLoader Properties

The FileSystemScriptLoader type exposes the following members.

Properties
 | Name | Description
Public property | IgnoreLuaPathGlobal | Gets or sets a value indicating whether the LUA_PATH global is checked or not to get the path where modules are contained. If true, the LUA_PATH global is NOT checked. (Inherited from ScriptLoaderBase.)
Public property | ModulePaths | Gets or sets the modules paths used by the "require" function. If null, the default paths are used (using environment variables etc.). (Inherited from ScriptLoaderBase.)
Top
See Also

Reference

FileSystemScriptLoader Class
MoonSharp.Interpreter.Loaders Namespace


FileSystemScriptLoader Methods

FileSystemScriptLoader Methods

The FileSystemScriptLoader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFile | Opens a file for reading the script code. It can return either a string, a byte[] or a Stream. If a byte[] is returned, the content is assumed to be a serialized (dumped) bytecode. If it's a string, it's assumed to be either a script or the output of a string.dump call. If a Stream, autodetection takes place. (Overrides ScriptLoaderBaseLoadFile(String, Table).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResolveFileName | Resolves a filename [applying paths, etc.] (Inherited from ScriptLoaderBase.)
Public method | ResolveModuleName(String, Table) | Resolves the name of a module to a filename (which will later be passed to OpenScriptFile). The resolution happens first on paths included in the LUA_PATH global variable (if and only if the IgnoreLuaPathGlobal is false), and - if the variable does not exist - by consulting the ScriptOptions.ModulesPaths array. Override to provide a different behaviour. (Inherited from ScriptLoaderBase.)
Protected method | ResolveModuleName(String, String) | Resolves the name of a module on a set of paths. (Inherited from ScriptLoaderBase.)
Public method | ScriptFileExists | Checks if a script file exists. (Overrides ScriptLoaderBaseScriptFileExists(String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileSystemScriptLoader Class
MoonSharp.Interpreter.Loaders Namespace


FileSystemScriptLoader.LoadFile Method

FileSystemScriptLoaderLoadFile Method
Opens a file for reading the script code. It can return either a string, a byte[] or a Stream. If a byte[] is returned, the content is assumed to be a serialized (dumped) bytecode. If it's a string, it's assumed to be either a script or the output of a string.dump call. If a Stream, autodetection takes place.

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override Object LoadFile(
    string file,
    Table globalContext
)
Public Overrides Function LoadFile (
    file As String,
    globalContext As Table
) As Object
public:
virtual Object^ LoadFile(
    String^ file,
    Table^ globalContext
) override
abstract LoadFile :
        file : string *
        globalContext : Table -> Object
override LoadFile :
        file : string *
        globalContext : Table -> Object

Parameters

file
Type: SystemString
The file.
globalContext
Type: MoonSharp.InterpreterTable
The global context.

Return Value

Type: Object
A string, a byte[] or a Stream.

Implements

IScriptLoaderLoadFile(String, Table)
See Also

Reference

FileSystemScriptLoader Class
MoonSharp.Interpreter.Loaders Namespace


FileSystemScriptLoader.ScriptFileExists Method

FileSystemScriptLoaderScriptFileExists Method
Checks if a script file exists.

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ScriptFileExists(
    string name
)
Public Overrides Function ScriptFileExists (
    name As String
) As Boolean
public:
virtual bool ScriptFileExists(
    String^ name
) override
abstract ScriptFileExists :
        name : string -> bool
override ScriptFileExists :
        name : string -> bool

Parameters

name
Type: SystemString
The script filename.

Return Value

Type: Boolean
See Also

Reference

FileSystemScriptLoader Class
MoonSharp.Interpreter.Loaders Namespace


IScriptLoader Interface

IScriptLoader Interface
Class dictating how requests to read scripts from files are handled. It's recommended that no class implement IScriptLoader directly, and rather extend ScriptLoaderBase.

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public interface IScriptLoader
Public Interface IScriptLoader
public interface class IScriptLoader
type IScriptLoader =  interface end

The IScriptLoader type exposes the following members.

Methods
 | Name | Description
Public method | LoadFile | Opens a file for reading the script code. It can return either a string, a byte[] or a Stream. If a byte[] is returned, the content is assumed to be a serialized (dumped) bytecode. If it's a string, it's assumed to be either a script or the output of a string.dump call. If a Stream, autodetection takes place.
Public method | ResolveFileName | Obsolete. Resolves a filename [applying paths, etc.]
Public method | ResolveModuleName | Resolves the name of a module to a filename (which will later be passed to OpenScriptFile)
Top
See Also

Reference

MoonSharp.Interpreter.Loaders Namespace


IScriptLoader Methods

IScriptLoader Methods

The IScriptLoader type exposes the following members.

Methods
 | Name | Description
Public method | LoadFile | Opens a file for reading the script code. It can return either a string, a byte[] or a Stream. If a byte[] is returned, the content is assumed to be a serialized (dumped) bytecode. If it's a string, it's assumed to be either a script or the output of a string.dump call. If a Stream, autodetection takes place.
Public method | ResolveFileName | Obsolete. Resolves a filename [applying paths, etc.]
Public method | ResolveModuleName | Resolves the name of a module to a filename (which will later be passed to OpenScriptFile)
Top
See Also

Reference

IScriptLoader Interface
MoonSharp.Interpreter.Loaders Namespace


IScriptLoader.LoadFile Method

IScriptLoaderLoadFile Method
Opens a file for reading the script code. It can return either a string, a byte[] or a Stream. If a byte[] is returned, the content is assumed to be a serialized (dumped) bytecode. If it's a string, it's assumed to be either a script or the output of a string.dump call. If a Stream, autodetection takes place.

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
Object LoadFile(
    string file,
    Table globalContext
)
Function LoadFile (
    file As String,
    globalContext As Table
) As Object
Object^ LoadFile(
    String^ file,
    Table^ globalContext
)
abstract LoadFile :
        file : string *
        globalContext : Table -> Object

Parameters

file
Type: SystemString
The file.
globalContext
Type: MoonSharp.InterpreterTable
The global context.

Return Value

Type: Object
A string, a byte[] or a Stream.
See Also

Reference

IScriptLoader Interface
MoonSharp.Interpreter.Loaders Namespace


IScriptLoader.ResolveFileName Method

IScriptLoaderResolveFileName Method

Note: This API is now obsolete.

Resolves a filename [applying paths, etc.]

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("This serves almost no purpose. Kept here just to preserve backward compatibility.")]
string ResolveFileName(
    string filename,
    Table globalContext
)
<ObsoleteAttribute("This serves almost no purpose. Kept here just to preserve backward compatibility.")>
Function ResolveFileName (
    filename As String,
    globalContext As Table
) As String
[ObsoleteAttribute(L"This serves almost no purpose. Kept here just to preserve backward compatibility.")]
String^ ResolveFileName(
    String^ filename,
    Table^ globalContext
)
[<ObsoleteAttribute("This serves almost no purpose. Kept here just to preserve backward compatibility.")>]
abstract ResolveFileName :
        filename : string *
        globalContext : Table -> string

Parameters

filename
Type: SystemString
The filename.
globalContext
Type: MoonSharp.InterpreterTable
The global context.

Return Value

Type: String
See Also

Reference

IScriptLoader Interface
MoonSharp.Interpreter.Loaders Namespace


IScriptLoader.ResolveModuleName Method

IScriptLoaderResolveModuleName Method
Resolves the name of a module to a filename (which will later be passed to OpenScriptFile)

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
string ResolveModuleName(
    string modname,
    Table globalContext
)
Function ResolveModuleName (
    modname As String,
    globalContext As Table
) As String
String^ ResolveModuleName(
    String^ modname,
    Table^ globalContext
)
abstract ResolveModuleName :
        modname : string *
        globalContext : Table -> string

Parameters

modname
Type: SystemString
The modname.
globalContext
Type: MoonSharp.InterpreterTable
The global context.

Return Value

Type: String
See Also

Reference

IScriptLoader Interface
MoonSharp.Interpreter.Loaders Namespace


ScriptLoaderBase Class

ScriptLoaderBase Class
A base implementation of IScriptLoader, offering resolution of module names.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.LoadersScriptLoaderBase
MoonSharp.Interpreter.LoadersEmbeddedResourcesScriptLoader
MoonSharp.Interpreter.LoadersFileSystemScriptLoader
MoonSharp.Interpreter.LoadersUnityAssetsScriptLoader

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ScriptLoaderBase : IScriptLoader
Public MustInherit Class ScriptLoaderBase
    Implements IScriptLoader
public ref class ScriptLoaderBase abstract : IScriptLoader
[<AbstractClassAttribute>]
type ScriptLoaderBase =
    class
        interface IScriptLoader
    end

The ScriptLoaderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ScriptLoaderBase | Initializes a new instance of the ScriptLoaderBase class
Top
Properties
 | Name | Description
Public property | IgnoreLuaPathGlobal | Gets or sets a value indicating whether the LUA_PATH global is checked or not to get the path where modules are contained. If true, the LUA_PATH global is NOT checked.
Public property | ModulePaths | Gets or sets the modules paths used by the "require" function. If null, the default paths are used (using environment variables etc.).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefaultEnvironmentPaths | Gets the default environment paths.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFile | Opens a file for reading the script code. It can return either a string, a byte[] or a Stream. If a byte[] is returned, the content is assumed to be a serialized (dumped) bytecode. If it's a string, it's assumed to be either a script or the output of a string.dump call. If a Stream, autodetection takes place.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResolveFileName | Resolves a filename [applying paths, etc.]
Public method | ResolveModuleName(String, Table) | Resolves the name of a module to a filename (which will later be passed to OpenScriptFile). The resolution happens first on paths included in the LUA_PATH global variable (if and only if the IgnoreLuaPathGlobal is false), and - if the variable does not exist - by consulting the ScriptOptions.ModulesPaths array. Override to provide a different behaviour.
Protected method | ResolveModuleName(String, String) | Resolves the name of a module on a set of paths.
Public method | ScriptFileExists | Checks if a script file exists.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UnpackStringPaths | Unpacks a string path in a form like "?;?.lua" to an array
Top
See Also

Reference

MoonSharp.Interpreter.Loaders Namespace


ScriptLoaderBase Constructor

ScriptLoaderBase Constructor
Initializes a new instance of the ScriptLoaderBase class

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected ScriptLoaderBase()
Protected Sub New
protected:
ScriptLoaderBase()
new : unit -> ScriptLoaderBase
See Also

Reference

ScriptLoaderBase Class
MoonSharp.Interpreter.Loaders Namespace


ScriptLoaderBase Properties

ScriptLoaderBase Properties

The ScriptLoaderBase type exposes the following members.

Properties
 | Name | Description
Public property | IgnoreLuaPathGlobal | Gets or sets a value indicating whether the LUA_PATH global is checked or not to get the path where modules are contained. If true, the LUA_PATH global is NOT checked.
Public property | ModulePaths | Gets or sets the modules paths used by the "require" function. If null, the default paths are used (using environment variables etc.).
Top
See Also

Reference

ScriptLoaderBase Class
MoonSharp.Interpreter.Loaders Namespace


ScriptLoaderBase.IgnoreLuaPathGlobal Property

ScriptLoaderBaseIgnoreLuaPathGlobal Property
Gets or sets a value indicating whether the LUA_PATH global is checked or not to get the path where modules are contained. If true, the LUA_PATH global is NOT checked.

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool IgnoreLuaPathGlobal { get; set; }
Public Property IgnoreLuaPathGlobal As Boolean
    Get
    Set
public:
property bool IgnoreLuaPathGlobal {
    bool get ();
    void set (bool value);
}
member IgnoreLuaPathGlobal : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ScriptLoaderBase Class
MoonSharp.Interpreter.Loaders Namespace


ScriptLoaderBase.ModulePaths Property

ScriptLoaderBaseModulePaths Property
Gets or sets the modules paths used by the "require" function. If null, the default paths are used (using environment variables etc.).

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string[] ModulePaths { get; set; }
Public Property ModulePaths As String()
    Get
    Set
public:
property array<String^>^ ModulePaths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member ModulePaths : string[] with get, set

Property Value

Type: String
See Also

Reference

ScriptLoaderBase Class
MoonSharp.Interpreter.Loaders Namespace


ScriptLoaderBase Methods

ScriptLoaderBase Methods

The ScriptLoaderBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefaultEnvironmentPaths | Gets the default environment paths.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFile | Opens a file for reading the script code. It can return either a string, a byte[] or a Stream. If a byte[] is returned, the content is assumed to be a serialized (dumped) bytecode. If it's a string, it's assumed to be either a script or the output of a string.dump call. If a Stream, autodetection takes place.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResolveFileName | Resolves a filename [applying paths, etc.]
Public method | ResolveModuleName(String, Table) | Resolves the name of a module to a filename (which will later be passed to OpenScriptFile). The resolution happens first on paths included in the LUA_PATH global variable (if and only if the IgnoreLuaPathGlobal is false), and - if the variable does not exist - by consulting the ScriptOptions.ModulesPaths array. Override to provide a different behaviour.
Protected method | ResolveModuleName(String, String) | Resolves the name of a module on a set of paths.
Public method | ScriptFileExists | Checks if a script file exists.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UnpackStringPaths | Unpacks a string path in a form like "?;?.lua" to an array
Top
See Also

Reference

ScriptLoaderBase Class
MoonSharp.Interpreter.Loaders Namespace


ScriptLoaderBase.GetDefaultEnvironmentPaths Method

ScriptLoaderBaseGetDefaultEnvironmentPaths Method
Gets the default environment paths.

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string[] GetDefaultEnvironmentPaths()
Public Shared Function GetDefaultEnvironmentPaths As String()
public:
static array<String^>^ GetDefaultEnvironmentPaths()
static member GetDefaultEnvironmentPaths : unit -> string[]

Return Value

Type: String
See Also

Reference

ScriptLoaderBase Class
MoonSharp.Interpreter.Loaders Namespace


ScriptLoaderBase.LoadFile Method

ScriptLoaderBaseLoadFile Method
Opens a file for reading the script code. It can return either a string, a byte[] or a Stream. If a byte[] is returned, the content is assumed to be a serialized (dumped) bytecode. If it's a string, it's assumed to be either a script or the output of a string.dump call. If a Stream, autodetection takes place.

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract Object LoadFile(
    string file,
    Table globalContext
)
Public MustOverride Function LoadFile (
    file As String,
    globalContext As Table
) As Object
public:
virtual Object^ LoadFile(
    String^ file,
    Table^ globalContext
) abstract
abstract LoadFile :
        file : string *
        globalContext : Table -> Object

Parameters

file
Type: SystemString
The file.
globalContext
Type: MoonSharp.InterpreterTable
The global context.

Return Value

Type: Object
A string, a byte[] or a Stream.

Implements

IScriptLoaderLoadFile(String, Table)
See Also

Reference

ScriptLoaderBase Class
MoonSharp.Interpreter.Loaders Namespace


ScriptLoaderBase.ResolveFileName Method

ScriptLoaderBaseResolveFileName Method
Resolves a filename [applying paths, etc.]

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string ResolveFileName(
    string filename,
    Table globalContext
)
Public Overridable Function ResolveFileName (
    filename As String,
    globalContext As Table
) As String
public:
virtual String^ ResolveFileName(
    String^ filename,
    Table^ globalContext
)
abstract ResolveFileName :
        filename : string *
        globalContext : Table -> string
override ResolveFileName :
        filename : string *
        globalContext : Table -> string

Parameters

filename
Type: SystemString
The filename.
globalContext
Type: MoonSharp.InterpreterTable
The global context.

Return Value

Type: String

Implements

IScriptLoaderResolveFileName(String, Table)
See Also

Reference

ScriptLoaderBase Class
MoonSharp.Interpreter.Loaders Namespace


ScriptLoaderBase.ResolveModuleName Method

ScriptLoaderBaseResolveModuleName Method
Overload List
 | Name | Description
Public method | ResolveModuleName(String, Table) | Resolves the name of a module to a filename (which will later be passed to OpenScriptFile). The resolution happens first on paths included in the LUA_PATH global variable (if and only if the IgnoreLuaPathGlobal is false), and - if the variable does not exist - by consulting the ScriptOptions.ModulesPaths array. Override to provide a different behaviour.
Protected method | ResolveModuleName(String, String) | Resolves the name of a module on a set of paths.
Top
See Also

Reference

ScriptLoaderBase Class
MoonSharp.Interpreter.Loaders Namespace


ScriptLoaderBase.ResolveModuleName Method (String, Table)

ScriptLoaderBaseResolveModuleName Method (String, Table)
Resolves the name of a module to a filename (which will later be passed to OpenScriptFile). The resolution happens first on paths included in the LUA_PATH global variable (if and only if the IgnoreLuaPathGlobal is false), and - if the variable does not exist - by consulting the ScriptOptions.ModulesPaths array. Override to provide a different behaviour.

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string ResolveModuleName(
    string modname,
    Table globalContext
)
Public Overridable Function ResolveModuleName (
    modname As String,
    globalContext As Table
) As String
public:
virtual String^ ResolveModuleName(
    String^ modname,
    Table^ globalContext
)
abstract ResolveModuleName :
        modname : string *
        globalContext : Table -> string
override ResolveModuleName :
        modname : string *
        globalContext : Table -> string

Parameters

modname
Type: SystemString
The modname.
globalContext
Type: MoonSharp.InterpreterTable
The global context.

Return Value

Type: String

Implements

IScriptLoaderResolveModuleName(String, Table)
See Also

Reference

ScriptLoaderBase Class
ResolveModuleName Overload
MoonSharp.Interpreter.Loaders Namespace


ScriptLoaderBase.ResolveModuleName Method (String, String[])

ScriptLoaderBaseResolveModuleName Method (String, String)
Resolves the name of a module on a set of paths.

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected virtual string ResolveModuleName(
    string modname,
    string[] paths
)
Protected Overridable Function ResolveModuleName (
    modname As String,
    paths As String()
) As String
protected:
virtual String^ ResolveModuleName(
    String^ modname,
    array<String^>^ paths
)
abstract ResolveModuleName :
        modname : string *
        paths : string[] -> string
override ResolveModuleName :
        modname : string *
        paths : string[] -> string

Parameters

modname
Type: SystemString
The modname.
paths
Type: SystemString
The paths.

Return Value

Type: String
See Also

Reference

ScriptLoaderBase Class
ResolveModuleName Overload
MoonSharp.Interpreter.Loaders Namespace


ScriptLoaderBase.ScriptFileExists Method

ScriptLoaderBaseScriptFileExists Method
Checks if a script file exists.

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract bool ScriptFileExists(
    string name
)
Public MustOverride Function ScriptFileExists (
    name As String
) As Boolean
public:
virtual bool ScriptFileExists(
    String^ name
) abstract
abstract ScriptFileExists :
        name : string -> bool

Parameters

name
Type: SystemString
The script filename.

Return Value

Type: Boolean
See Also

Reference

ScriptLoaderBase Class
MoonSharp.Interpreter.Loaders Namespace


ScriptLoaderBase.UnpackStringPaths Method

ScriptLoaderBaseUnpackStringPaths Method
Unpacks a string path in a form like "?;?.lua" to an array

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string[] UnpackStringPaths(
    string str
)
Public Shared Function UnpackStringPaths (
    str As String
) As String()
public:
static array<String^>^ UnpackStringPaths(
    String^ str
)
static member UnpackStringPaths :
        str : string -> string[]

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:MoonSharp.Interpreter.Loaders.ScriptLoaderBase.UnpackStringPaths(System.String)"]

Return Value

Type: String
See Also

Reference

ScriptLoaderBase Class
MoonSharp.Interpreter.Loaders Namespace


UnityAssetsScriptLoader Class

UnityAssetsScriptLoader Class
A script loader which can load scripts from assets in Unity3D. Scripts should be saved as .txt files in a subdirectory of Assets/Resources. When MoonSharp is activated on Unity3D and the default script loader is used, scripts should be saved as .txt files in Assets/Resources/MoonSharp/Scripts.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.LoadersScriptLoaderBase
MoonSharp.Interpreter.LoadersUnityAssetsScriptLoader

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class UnityAssetsScriptLoader : ScriptLoaderBase
Public Class UnityAssetsScriptLoader
    Inherits ScriptLoaderBase
public ref class UnityAssetsScriptLoader : public ScriptLoaderBase
type UnityAssetsScriptLoader =
    class
        inherit ScriptLoaderBase
    end

The UnityAssetsScriptLoader type exposes the following members.

Constructors
 | Name | Description
Public method | UnityAssetsScriptLoader(DictionaryString, String) | Initializes a new instance of the UnityAssetsScriptLoader class.
Public method | UnityAssetsScriptLoader(String) | Initializes a new instance of the UnityAssetsScriptLoader class.
Top
Properties
 | Name | Description
Public property | IgnoreLuaPathGlobal | Gets or sets a value indicating whether the LUA_PATH global is checked or not to get the path where modules are contained. If true, the LUA_PATH global is NOT checked. (Inherited from ScriptLoaderBase.)
Public property | ModulePaths | Gets or sets the modules paths used by the "require" function. If null, the default paths are used (using environment variables etc.). (Inherited from ScriptLoaderBase.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLoadedScripts | Gets the list of loaded scripts filenames (useful for debugging purposes).
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFile | Opens a file for reading the script code. It can return either a string, a byte[] or a Stream. If a byte[] is returned, the content is assumed to be a serialized (dumped) bytecode. If it's a string, it's assumed to be either a script or the output of a string.dump call. If a Stream, autodetection takes place. (Overrides ScriptLoaderBaseLoadFile(String, Table).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResolveFileName | Resolves a filename [applying paths, etc.] (Inherited from ScriptLoaderBase.)
Public method | ResolveModuleName(String, Table) | Resolves the name of a module to a filename (which will later be passed to OpenScriptFile). The resolution happens first on paths included in the LUA_PATH global variable (if and only if the IgnoreLuaPathGlobal is false), and - if the variable does not exist - by consulting the ScriptOptions.ModulesPaths array. Override to provide a different behaviour. (Inherited from ScriptLoaderBase.)
Protected method | ResolveModuleName(String, String) | Resolves the name of a module on a set of paths. (Inherited from ScriptLoaderBase.)
Public method | ScriptFileExists | Checks if a given file exists (Overrides ScriptLoaderBaseScriptFileExists(String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
Name | Description
DEFAULT_PATH | The default path where scripts are meant to be stored (if not changed)
Top
See Also

Reference

MoonSharp.Interpreter.Loaders Namespace


UnityAssetsScriptLoader Constructor

UnityAssetsScriptLoader Constructor
Overload List
 | Name | Description
Public method | UnityAssetsScriptLoader(DictionaryString, String) | Initializes a new instance of the UnityAssetsScriptLoader class.
Public method | UnityAssetsScriptLoader(String) | Initializes a new instance of the UnityAssetsScriptLoader class.
Top
See Also

Reference

UnityAssetsScriptLoader Class
MoonSharp.Interpreter.Loaders Namespace


UnityAssetsScriptLoader Constructor (Dictionary(String, String))

UnityAssetsScriptLoader Constructor (DictionaryString, String)
Initializes a new instance of the UnityAssetsScriptLoader class.

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public UnityAssetsScriptLoader(
    Dictionary<string, string> scriptToCodeMap
)
Public Sub New (
    scriptToCodeMap As Dictionary(Of String, String)
)
public:
UnityAssetsScriptLoader(
    Dictionary<String^, String^>^ scriptToCodeMap
)
new :
        scriptToCodeMap : Dictionary<string, string> -> UnityAssetsScriptLoader

Parameters

scriptToCodeMap
Type: System.Collections.GenericDictionary String, String
A dictionary mapping filenames to the proper Lua script code.
See Also

Reference

UnityAssetsScriptLoader Class
UnityAssetsScriptLoader Overload
MoonSharp.Interpreter.Loaders Namespace


UnityAssetsScriptLoader Constructor (String)

UnityAssetsScriptLoader Constructor (String)
Initializes a new instance of the UnityAssetsScriptLoader class.

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public UnityAssetsScriptLoader(
    string assetsPath = null
)
Public Sub New (
    Optional assetsPath As String = Nothing
)
public:
UnityAssetsScriptLoader(
    String^ assetsPath = nullptr
)
new :
        ?assetsPath : string
(* Defaults:
        let _assetsPath = defaultArg assetsPath null
*)
-> UnityAssetsScriptLoader

Parameters

assetsPath (Optional)
Type: SystemString
The path, relative to Assets/Resources. For example if your scripts are stored under Assets/Resources/Scripts, you should pass the value "Scripts". If null, "MoonSharp/Scripts" is used.
See Also

Reference

UnityAssetsScriptLoader Class
UnityAssetsScriptLoader Overload
MoonSharp.Interpreter.Loaders Namespace


UnityAssetsScriptLoader Properties

UnityAssetsScriptLoader Properties

The UnityAssetsScriptLoader type exposes the following members.

Properties
 | Name | Description
Public property | IgnoreLuaPathGlobal | Gets or sets a value indicating whether the LUA_PATH global is checked or not to get the path where modules are contained. If true, the LUA_PATH global is NOT checked. (Inherited from ScriptLoaderBase.)
Public property | ModulePaths | Gets or sets the modules paths used by the "require" function. If null, the default paths are used (using environment variables etc.). (Inherited from ScriptLoaderBase.)
Top
See Also

Reference

UnityAssetsScriptLoader Class
MoonSharp.Interpreter.Loaders Namespace


UnityAssetsScriptLoader Methods

UnityAssetsScriptLoader Methods

The UnityAssetsScriptLoader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetLoadedScripts | Gets the list of loaded scripts filenames (useful for debugging purposes).
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFile | Opens a file for reading the script code. It can return either a string, a byte[] or a Stream. If a byte[] is returned, the content is assumed to be a serialized (dumped) bytecode. If it's a string, it's assumed to be either a script or the output of a string.dump call. If a Stream, autodetection takes place. (Overrides ScriptLoaderBaseLoadFile(String, Table).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResolveFileName | Resolves a filename [applying paths, etc.] (Inherited from ScriptLoaderBase.)
Public method | ResolveModuleName(String, Table) | Resolves the name of a module to a filename (which will later be passed to OpenScriptFile). The resolution happens first on paths included in the LUA_PATH global variable (if and only if the IgnoreLuaPathGlobal is false), and - if the variable does not exist - by consulting the ScriptOptions.ModulesPaths array. Override to provide a different behaviour. (Inherited from ScriptLoaderBase.)
Protected method | ResolveModuleName(String, String) | Resolves the name of a module on a set of paths. (Inherited from ScriptLoaderBase.)
Public method | ScriptFileExists | Checks if a given file exists (Overrides ScriptLoaderBaseScriptFileExists(String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UnityAssetsScriptLoader Class
MoonSharp.Interpreter.Loaders Namespace


UnityAssetsScriptLoader.GetLoadedScripts Method

UnityAssetsScriptLoaderGetLoadedScripts Method
Gets the list of loaded scripts filenames (useful for debugging purposes).

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string[] GetLoadedScripts()
Public Function GetLoadedScripts As String()
public:
array<String^>^ GetLoadedScripts()
member GetLoadedScripts : unit -> string[]

Return Value

Type: String
See Also

Reference

UnityAssetsScriptLoader Class
MoonSharp.Interpreter.Loaders Namespace


UnityAssetsScriptLoader.LoadFile Method

UnityAssetsScriptLoaderLoadFile Method
Opens a file for reading the script code. It can return either a string, a byte[] or a Stream. If a byte[] is returned, the content is assumed to be a serialized (dumped) bytecode. If it's a string, it's assumed to be either a script or the output of a string.dump call. If a Stream, autodetection takes place.

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override Object LoadFile(
    string file,
    Table globalContext
)
Public Overrides Function LoadFile (
    file As String,
    globalContext As Table
) As Object
public:
virtual Object^ LoadFile(
    String^ file,
    Table^ globalContext
) override
abstract LoadFile :
        file : string *
        globalContext : Table -> Object
override LoadFile :
        file : string *
        globalContext : Table -> Object

Parameters

file
Type: SystemString
The file.
globalContext
Type: MoonSharp.InterpreterTable
The global context.

Return Value

Type: Object
A string, a byte[] or a Stream.

Implements

IScriptLoaderLoadFile(String, Table)
Exceptions
Exception | Condition
Exception | UnityAssetsScriptLoader.LoadFile : Cannot load + file
See Also

Reference

UnityAssetsScriptLoader Class
MoonSharp.Interpreter.Loaders Namespace


UnityAssetsScriptLoader.ScriptFileExists Method

UnityAssetsScriptLoaderScriptFileExists Method
Checks if a given file exists

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override bool ScriptFileExists(
    string file
)
Public Overrides Function ScriptFileExists (
    file As String
) As Boolean
public:
virtual bool ScriptFileExists(
    String^ file
) override
abstract ScriptFileExists :
        file : string -> bool
override ScriptFileExists :
        file : string -> bool

Parameters

file
Type: SystemString
The file.

Return Value

Type: Boolean
See Also

Reference

UnityAssetsScriptLoader Class
MoonSharp.Interpreter.Loaders Namespace


UnityAssetsScriptLoader Fields

UnityAssetsScriptLoader Fields

The UnityAssetsScriptLoader type exposes the following members.

Fields
Name | Description
DEFAULT_PATH | The default path where scripts are meant to be stored (if not changed)
Top
See Also

Reference

UnityAssetsScriptLoader Class
MoonSharp.Interpreter.Loaders Namespace


UnityAssetsScriptLoader.DEFAULT_PATH Field

UnityAssetsScriptLoaderDEFAULT_PATH Field
The default path where scripts are meant to be stored (if not changed)

Namespace: MoonSharp.Interpreter.Loaders
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public const string DEFAULT_PATH = "MoonSharp/Scripts"
Public Const DEFAULT_PATH As String = "MoonSharp/Scripts"
public:
literal String^ DEFAULT_PATH = "MoonSharp/Scripts"
static val mutable DEFAULT_PATH: string

Field Value

Type: String
See Also

Reference

UnityAssetsScriptLoader Class
MoonSharp.Interpreter.Loaders Namespace


MoonSharp.Interpreter.Platforms Namespace

MoonSharp.Interpreter.Platforms Namespace
Namespace containing classes used to customize how the interfacing with the operative system happens for the 'os' and 'io' modules, and for future modules/classes which may require OS access. See IPlatformAccessor and Platform .
Classes
 | Class | Description
Public class | LimitedPlatformAccessor | A class implementing all the bits needed to have a minimal support of a platform. This does not support the 'io'/'file' modules and has partial support of the 'os' module.
Public class | PlatformAccessorBase | An abstract class which offers basic services on top of IPlatformAccessor to provide easier implementation of platforms.
Public class | PlatformAutoDetector | A static class offering properties for autodetection of system/platform details
Public class | StandardPlatformAccessor | Class providing the IPlatformAccessor interface for standard full-feaured implementations.
Interfaces
 | Interface | Description
Public interface | IPlatformAccessor | Interface to abstract all accesses made to the underlying platform (OS, framework) by the scripting engine. Can be used both to support "non-standard" platforms (i.e. non-posix, non-windows) and/or to sandbox the behaviour of the scripting engine. It's recommended that no class implement IPlatformAccessor directly, and rather extend PlatformAccessorBase.
Enumerations
 | Enumeration | Description
Public enumeration | StandardFileType | Enumeration of standard file handles


IPlatformAccessor Interface

IPlatformAccessor Interface
Interface to abstract all accesses made to the underlying platform (OS, framework) by the scripting engine. Can be used both to support "non-standard" platforms (i.e. non-posix, non-windows) and/or to sandbox the behaviour of the scripting engine. It's recommended that no class implement IPlatformAccessor directly, and rather extend PlatformAccessorBase.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public interface IPlatformAccessor
Public Interface IPlatformAccessor
public interface class IPlatformAccessor
type IPlatformAccessor =  interface end

The IPlatformAccessor type exposes the following members.

Methods
 | Name | Description
Public method | DefaultInput | Default handler for interactive line input calls. Can be customized in ScriptOptions. If a meaningful implementation cannot be provided, this method should return null.
Public method | DefaultPrint | Default handler for 'print' calls. Can be customized in ScriptOptions
Public method | FilterSupportedCoreModules | Filters the CoreModules enumeration to exclude non-supported operations
Public method | GetEnvironmentVariable | Gets an environment variable. Must be implemented, but an implementation is allowed to always return null if a more meaningful implementation cannot be achieved or is not desired.
Public method | GetPlatformName | Gets the name of the platform (used for debug purposes).
Public method | IO_GetStandardStream | Gets a standard stream (stdin, stdout, stderr).
Public method | IO_OpenFile | A function used to open files in the 'io' module. Can have an invalid implementation if 'io' module is filtered out. It should return a correctly initialized Stream for the given file and access
Public method | IO_OS_GetTempFilename | Gets a temporary filename. Used in 'io' and 'os' modules. Can have an invalid implementation if 'io' and 'os' modules are filtered out.
Public method | IsRunningOnAOT | Determines whether the application is running in AOT (ahead-of-time) mode
Public method | OS_Execute | Executes the specified command line, returning the child process exit code and blocking in the meantime. Can have an invalid implementation if the 'os' module is filtered out.
Public method | OS_ExitFast | Exits the process, returning the specified exit code. Can have an invalid implementation if the 'os' module is filtered out.
Public method | OS_FileDelete | Deletes the specified file. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.
Public method | OS_FileExists | Checks if a file exists. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.
Public method | OS_FileMove | Moves the specified file. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.
Top
See Also

Reference

MoonSharp.Interpreter.Platforms Namespace


IPlatformAccessor Methods

IPlatformAccessor Methods

The IPlatformAccessor type exposes the following members.

Methods
 | Name | Description
Public method | DefaultInput | Default handler for interactive line input calls. Can be customized in ScriptOptions. If a meaningful implementation cannot be provided, this method should return null.
Public method | DefaultPrint | Default handler for 'print' calls. Can be customized in ScriptOptions
Public method | FilterSupportedCoreModules | Filters the CoreModules enumeration to exclude non-supported operations
Public method | GetEnvironmentVariable | Gets an environment variable. Must be implemented, but an implementation is allowed to always return null if a more meaningful implementation cannot be achieved or is not desired.
Public method | GetPlatformName | Gets the name of the platform (used for debug purposes).
Public method | IO_GetStandardStream | Gets a standard stream (stdin, stdout, stderr).
Public method | IO_OpenFile | A function used to open files in the 'io' module. Can have an invalid implementation if 'io' module is filtered out. It should return a correctly initialized Stream for the given file and access
Public method | IO_OS_GetTempFilename | Gets a temporary filename. Used in 'io' and 'os' modules. Can have an invalid implementation if 'io' and 'os' modules are filtered out.
Public method | IsRunningOnAOT | Determines whether the application is running in AOT (ahead-of-time) mode
Public method | OS_Execute | Executes the specified command line, returning the child process exit code and blocking in the meantime. Can have an invalid implementation if the 'os' module is filtered out.
Public method | OS_ExitFast | Exits the process, returning the specified exit code. Can have an invalid implementation if the 'os' module is filtered out.
Public method | OS_FileDelete | Deletes the specified file. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.
Public method | OS_FileExists | Checks if a file exists. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.
Public method | OS_FileMove | Moves the specified file. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.
Top
See Also

Reference

IPlatformAccessor Interface
MoonSharp.Interpreter.Platforms Namespace


IPlatformAccessor.DefaultInput Method

IPlatformAccessorDefaultInput Method
Default handler for interactive line input calls. Can be customized in ScriptOptions. If a meaningful implementation cannot be provided, this method should return null.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
string DefaultInput(
    string prompt
)
Function DefaultInput (
    prompt As String
) As String
String^ DefaultInput(
    String^ prompt
)
abstract DefaultInput :
        prompt : string -> string

Parameters

prompt
Type: SystemString

[Missing <param name="prompt"/> documentation for "M:MoonSharp.Interpreter.Platforms.IPlatformAccessor.DefaultInput(System.String)"]

Return Value

Type: String
See Also

Reference

IPlatformAccessor Interface
MoonSharp.Interpreter.Platforms Namespace


IPlatformAccessor.DefaultPrint Method

IPlatformAccessorDefaultPrint Method
Default handler for 'print' calls. Can be customized in ScriptOptions

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
void DefaultPrint(
    string content
)
Sub DefaultPrint (
    content As String
)
void DefaultPrint(
    String^ content
)
abstract DefaultPrint :
        content : string -> unit

Parameters

content
Type: SystemString
The content.
See Also

Reference

IPlatformAccessor Interface
MoonSharp.Interpreter.Platforms Namespace


IPlatformAccessor.FilterSupportedCoreModules Method

IPlatformAccessorFilterSupportedCoreModules Method
Filters the CoreModules enumeration to exclude non-supported operations

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
CoreModules FilterSupportedCoreModules(
    CoreModules module
)
Function FilterSupportedCoreModules (
    module As CoreModules
) As CoreModules
CoreModules FilterSupportedCoreModules(
    CoreModules module
)
abstract FilterSupportedCoreModules :
        module : CoreModules -> CoreModules

Parameters

module
Type: MoonSharp.InterpreterCoreModules
The requested modules.

Return Value

Type: CoreModules
The requested modules, with unsupported modules filtered out.
See Also

Reference

IPlatformAccessor Interface
MoonSharp.Interpreter.Platforms Namespace


IPlatformAccessor.GetEnvironmentVariable Method

IPlatformAccessorGetEnvironmentVariable Method
Gets an environment variable. Must be implemented, but an implementation is allowed to always return null if a more meaningful implementation cannot be achieved or is not desired.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
string GetEnvironmentVariable(
    string envvarname
)
Function GetEnvironmentVariable (
    envvarname As String
) As String
String^ GetEnvironmentVariable(
    String^ envvarname
)
abstract GetEnvironmentVariable :
        envvarname : string -> string

Parameters

envvarname
Type: SystemString
The envvarname.

Return Value

Type: String
The environment variable value, or null if not found
See Also

Reference

IPlatformAccessor Interface
MoonSharp.Interpreter.Platforms Namespace


IPlatformAccessor.GetPlatformName Method

IPlatformAccessorGetPlatformName Method
Gets the name of the platform (used for debug purposes).

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
string GetPlatformName()
Function GetPlatformName As String
String^ GetPlatformName()
abstract GetPlatformName : unit -> string

Return Value

Type: String
The name of the platform (used for debug purposes)
See Also

Reference

IPlatformAccessor Interface
MoonSharp.Interpreter.Platforms Namespace


IPlatformAccessor.IO_GetStandardStream Method

IPlatformAccessorIO_GetStandardStream Method
Gets a standard stream (stdin, stdout, stderr).

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
Stream IO_GetStandardStream(
    StandardFileType type
)
Function IO_GetStandardStream (
    type As StandardFileType
) As Stream
Stream^ IO_GetStandardStream(
    StandardFileType type
)
abstract IO_GetStandardStream :
        type : StandardFileType -> Stream

Parameters

type
Type: MoonSharp.Interpreter.PlatformsStandardFileType
The type.

Return Value

Type: Stream
See Also

Reference

IPlatformAccessor Interface
MoonSharp.Interpreter.Platforms Namespace


IPlatformAccessor.IO_OpenFile Method

IPlatformAccessorIO_OpenFile Method
A function used to open files in the 'io' module. Can have an invalid implementation if 'io' module is filtered out. It should return a correctly initialized Stream for the given file and access

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
Stream IO_OpenFile(
    Script script,
    string filename,
    Encoding encoding,
    string mode
)
Function IO_OpenFile (
    script As Script,
    filename As String,
    encoding As Encoding,
    mode As String
) As Stream
Stream^ IO_OpenFile(
    Script^ script,
    String^ filename,
    Encoding^ encoding,
    String^ mode
)
abstract IO_OpenFile :
        script : Script *
        filename : string *
        encoding : Encoding *
        mode : string -> Stream

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
filename
Type: SystemString
The filename.
encoding
Type: System.TextEncoding
The encoding.
mode
Type: SystemString
The mode (as per Lua usage - e.g. 'w+', 'rb', etc.).

Return Value

Type: Stream
See Also

Reference

IPlatformAccessor Interface
MoonSharp.Interpreter.Platforms Namespace


IPlatformAccessor.IO_OS_GetTempFilename Method

IPlatformAccessorIO_OS_GetTempFilename Method
Gets a temporary filename. Used in 'io' and 'os' modules. Can have an invalid implementation if 'io' and 'os' modules are filtered out.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
string IO_OS_GetTempFilename()
Function IO_OS_GetTempFilename As String
String^ IO_OS_GetTempFilename()
abstract IO_OS_GetTempFilename : unit -> string

Return Value

Type: String
See Also

Reference

IPlatformAccessor Interface
MoonSharp.Interpreter.Platforms Namespace


IPlatformAccessor.IsRunningOnAOT Method

IPlatformAccessorIsRunningOnAOT Method
Determines whether the application is running in AOT (ahead-of-time) mode

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
bool IsRunningOnAOT()
Function IsRunningOnAOT As Boolean
bool IsRunningOnAOT()
abstract IsRunningOnAOT : unit -> bool

Return Value

Type: Boolean
See Also

Reference

IPlatformAccessor Interface
MoonSharp.Interpreter.Platforms Namespace


IPlatformAccessor.OS_Execute Method

IPlatformAccessorOS_Execute Method
Executes the specified command line, returning the child process exit code and blocking in the meantime. Can have an invalid implementation if the 'os' module is filtered out.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
int OS_Execute(
    string cmdline
)
Function OS_Execute (
    cmdline As String
) As Integer
int OS_Execute(
    String^ cmdline
)
abstract OS_Execute :
        cmdline : string -> int

Parameters

cmdline
Type: SystemString
The cmdline.

Return Value

Type: Int32
See Also

Reference

IPlatformAccessor Interface
MoonSharp.Interpreter.Platforms Namespace


IPlatformAccessor.OS_ExitFast Method

IPlatformAccessorOS_ExitFast Method
Exits the process, returning the specified exit code. Can have an invalid implementation if the 'os' module is filtered out.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
void OS_ExitFast(
    int exitCode
)
Sub OS_ExitFast (
    exitCode As Integer
)
void OS_ExitFast(
    int exitCode
)
abstract OS_ExitFast :
        exitCode : int -> unit

Parameters

exitCode
Type: SystemInt32
The exit code.
See Also

Reference

IPlatformAccessor Interface
MoonSharp.Interpreter.Platforms Namespace


IPlatformAccessor.OS_FileDelete Method

IPlatformAccessorOS_FileDelete Method
Deletes the specified file. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
void OS_FileDelete(
    string file
)
Sub OS_FileDelete (
    file As String
)
void OS_FileDelete(
    String^ file
)
abstract OS_FileDelete :
        file : string -> unit

Parameters

file
Type: SystemString
The file.
See Also

Reference

IPlatformAccessor Interface
MoonSharp.Interpreter.Platforms Namespace


IPlatformAccessor.OS_FileExists Method

IPlatformAccessorOS_FileExists Method
Checks if a file exists. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
bool OS_FileExists(
    string file
)
Function OS_FileExists (
    file As String
) As Boolean
bool OS_FileExists(
    String^ file
)
abstract OS_FileExists :
        file : string -> bool

Parameters

file
Type: SystemString
The file.

Return Value

Type: Boolean
True if the file exists, false otherwise.
See Also

Reference

IPlatformAccessor Interface
MoonSharp.Interpreter.Platforms Namespace


IPlatformAccessor.OS_FileMove Method

IPlatformAccessorOS_FileMove Method
Moves the specified file. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
void OS_FileMove(
    string src,
    string dst
)
Sub OS_FileMove (
    src As String,
    dst As String
)
void OS_FileMove(
    String^ src,
    String^ dst
)
abstract OS_FileMove :
        src : string *
        dst : string -> unit

Parameters

src
Type: SystemString
The source.
dst
Type: SystemString
The DST.
See Also

Reference

IPlatformAccessor Interface
MoonSharp.Interpreter.Platforms Namespace


LimitedPlatformAccessor Class

LimitedPlatformAccessor Class
A class implementing all the bits needed to have a minimal support of a platform. This does not support the 'io'/'file' modules and has partial support of the 'os' module.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.PlatformsPlatformAccessorBase
MoonSharp.Interpreter.PlatformsLimitedPlatformAccessor

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class LimitedPlatformAccessor : PlatformAccessorBase
Public Class LimitedPlatformAccessor
    Inherits PlatformAccessorBase
public ref class LimitedPlatformAccessor : public PlatformAccessorBase
type LimitedPlatformAccessor =
    class
        inherit PlatformAccessorBase
    end

The LimitedPlatformAccessor type exposes the following members.

Constructors
 | Name | Description
Public method | LimitedPlatformAccessor | Initializes a new instance of the LimitedPlatformAccessor class
Top
Methods
 | Name | Description
Public method | DefaultInput | Obsolete. DEPRECATED. This is kept for backward compatibility, see the overload taking a prompt as an input parameter. Default handler for interactive line input calls. Can be customized in ScriptOptions. If an inheriting class whants to give a meaningful implementation, this method MUST be overridden. (Inherited from PlatformAccessorBase.)
Public method | DefaultInput(String) | Default handler for interactive line input calls. Can be customized in ScriptOptions. If an inheriting class whants to give a meaningful implementation, this method MUST be overridden. (Inherited from PlatformAccessorBase.)
Public method | DefaultPrint | Default handler for 'print' calls. Can be customized in ScriptOptions (Overrides PlatformAccessorBaseDefaultPrint(String).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FilterSupportedCoreModules | Filters the CoreModules enumeration to exclude non-supported operations (Overrides PlatformAccessorBaseFilterSupportedCoreModules(CoreModules).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnvironmentVariable | Gets an environment variable. Must be implemented, but an implementation is allowed to always return null if a more meaningful implementation cannot be achieved or is not desired. (Overrides PlatformAccessorBaseGetEnvironmentVariable(String).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPlatformName | Gets the name of the platform (used for debug purposes). (Inherited from PlatformAccessorBase.)
Public method | GetPlatformNamePrefix | Gets the platform name prefix (Overrides PlatformAccessorBaseGetPlatformNamePrefix.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IO_GetStandardStream | Gets a standard stream (stdin, stdout, stderr). LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules. (Overrides PlatformAccessorBaseIO_GetStandardStream(StandardFileType).)
Public method | IO_OpenFile | A function used to open files in the 'io' module. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules. (Overrides PlatformAccessorBaseIO_OpenFile(Script, String, Encoding, String).)
Public method | IO_OS_GetTempFilename | Gets a temporary filename. Used in 'io' and 'os' modules. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules. (Overrides PlatformAccessorBaseIO_OS_GetTempFilename.)
Public method | IsRunningOnAOT | Determines whether the application is running in AOT (ahead-of-time) mode (Inherited from PlatformAccessorBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OS_Execute | Executes the specified command line, returning the child process exit code and blocking in the meantime. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules. (Overrides PlatformAccessorBaseOS_Execute(String).)
Public method | OS_ExitFast | Exits the process, returning the specified exit code. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules. (Overrides PlatformAccessorBaseOS_ExitFast(Int32).)
Public method | OS_FileDelete | Deletes the specified file. Used by the 'os' module. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules. (Overrides PlatformAccessorBaseOS_FileDelete(String).)
Public method | OS_FileExists | Checks if a file exists. Used by the 'os' module. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules. (Overrides PlatformAccessorBaseOS_FileExists(String).)
Public method | OS_FileMove | Moves the specified file. Used by the 'os' module. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules. (Overrides PlatformAccessorBaseOS_FileMove(String, String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Platforms Namespace


LimitedPlatformAccessor Constructor

LimitedPlatformAccessor Constructor
Initializes a new instance of the LimitedPlatformAccessor class

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public LimitedPlatformAccessor()
Public Sub New
public:
LimitedPlatformAccessor()
new : unit -> LimitedPlatformAccessor
See Also

Reference

LimitedPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


LimitedPlatformAccessor Methods

LimitedPlatformAccessor Methods

The LimitedPlatformAccessor type exposes the following members.

Methods
 | Name | Description
Public method | DefaultInput | Obsolete. DEPRECATED. This is kept for backward compatibility, see the overload taking a prompt as an input parameter. Default handler for interactive line input calls. Can be customized in ScriptOptions. If an inheriting class whants to give a meaningful implementation, this method MUST be overridden. (Inherited from PlatformAccessorBase.)
Public method | DefaultInput(String) | Default handler for interactive line input calls. Can be customized in ScriptOptions. If an inheriting class whants to give a meaningful implementation, this method MUST be overridden. (Inherited from PlatformAccessorBase.)
Public method | DefaultPrint | Default handler for 'print' calls. Can be customized in ScriptOptions (Overrides PlatformAccessorBaseDefaultPrint(String).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FilterSupportedCoreModules | Filters the CoreModules enumeration to exclude non-supported operations (Overrides PlatformAccessorBaseFilterSupportedCoreModules(CoreModules).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnvironmentVariable | Gets an environment variable. Must be implemented, but an implementation is allowed to always return null if a more meaningful implementation cannot be achieved or is not desired. (Overrides PlatformAccessorBaseGetEnvironmentVariable(String).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPlatformName | Gets the name of the platform (used for debug purposes). (Inherited from PlatformAccessorBase.)
Public method | GetPlatformNamePrefix | Gets the platform name prefix (Overrides PlatformAccessorBaseGetPlatformNamePrefix.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IO_GetStandardStream | Gets a standard stream (stdin, stdout, stderr). LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules. (Overrides PlatformAccessorBaseIO_GetStandardStream(StandardFileType).)
Public method | IO_OpenFile | A function used to open files in the 'io' module. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules. (Overrides PlatformAccessorBaseIO_OpenFile(Script, String, Encoding, String).)
Public method | IO_OS_GetTempFilename | Gets a temporary filename. Used in 'io' and 'os' modules. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules. (Overrides PlatformAccessorBaseIO_OS_GetTempFilename.)
Public method | IsRunningOnAOT | Determines whether the application is running in AOT (ahead-of-time) mode (Inherited from PlatformAccessorBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OS_Execute | Executes the specified command line, returning the child process exit code and blocking in the meantime. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules. (Overrides PlatformAccessorBaseOS_Execute(String).)
Public method | OS_ExitFast | Exits the process, returning the specified exit code. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules. (Overrides PlatformAccessorBaseOS_ExitFast(Int32).)
Public method | OS_FileDelete | Deletes the specified file. Used by the 'os' module. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules. (Overrides PlatformAccessorBaseOS_FileDelete(String).)
Public method | OS_FileExists | Checks if a file exists. Used by the 'os' module. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules. (Overrides PlatformAccessorBaseOS_FileExists(String).)
Public method | OS_FileMove | Moves the specified file. Used by the 'os' module. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules. (Overrides PlatformAccessorBaseOS_FileMove(String, String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LimitedPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


LimitedPlatformAccessor.DefaultPrint Method

LimitedPlatformAccessorDefaultPrint Method
Default handler for 'print' calls. Can be customized in ScriptOptions

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void DefaultPrint(
    string content
)
Public Overrides Sub DefaultPrint (
    content As String
)
public:
virtual void DefaultPrint(
    String^ content
) override
abstract DefaultPrint :
        content : string -> unit
override DefaultPrint :
        content : string -> unit

Parameters

content
Type: SystemString
The content.

Implements

IPlatformAccessorDefaultPrint(String)
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

LimitedPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


LimitedPlatformAccessor.FilterSupportedCoreModules Method

LimitedPlatformAccessorFilterSupportedCoreModules Method
Filters the CoreModules enumeration to exclude non-supported operations

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override CoreModules FilterSupportedCoreModules(
    CoreModules module
)
Public Overrides Function FilterSupportedCoreModules (
    module As CoreModules
) As CoreModules
public:
virtual CoreModules FilterSupportedCoreModules(
    CoreModules module
) override
abstract FilterSupportedCoreModules :
        module : CoreModules -> CoreModules
override FilterSupportedCoreModules :
        module : CoreModules -> CoreModules

Parameters

module
Type: MoonSharp.InterpreterCoreModules
The requested modules.

Return Value

Type: CoreModules
The requested modules, with unsupported modules filtered out.

Implements

IPlatformAccessorFilterSupportedCoreModules(CoreModules)
See Also

Reference

LimitedPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


LimitedPlatformAccessor.GetEnvironmentVariable Method

LimitedPlatformAccessorGetEnvironmentVariable Method
Gets an environment variable. Must be implemented, but an implementation is allowed to always return null if a more meaningful implementation cannot be achieved or is not desired.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetEnvironmentVariable(
    string envvarname
)
Public Overrides Function GetEnvironmentVariable (
    envvarname As String
) As String
public:
virtual String^ GetEnvironmentVariable(
    String^ envvarname
) override
abstract GetEnvironmentVariable :
        envvarname : string -> string
override GetEnvironmentVariable :
        envvarname : string -> string

Parameters

envvarname
Type: SystemString
The envvarname.

Return Value

Type: String
The environment variable value, or null if not found

Implements

IPlatformAccessorGetEnvironmentVariable(String)
See Also

Reference

LimitedPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


LimitedPlatformAccessor.GetPlatformNamePrefix Method

LimitedPlatformAccessorGetPlatformNamePrefix Method
Gets the platform name prefix

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetPlatformNamePrefix()
Public Overrides Function GetPlatformNamePrefix As String
public:
virtual String^ GetPlatformNamePrefix() override
abstract GetPlatformNamePrefix : unit -> string
override GetPlatformNamePrefix : unit -> string

Return Value

Type: String
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

LimitedPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


LimitedPlatformAccessor.IO_GetStandardStream Method

LimitedPlatformAccessorIO_GetStandardStream Method
Gets a standard stream (stdin, stdout, stderr). LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override Stream IO_GetStandardStream(
    StandardFileType type
)
Public Overrides Function IO_GetStandardStream (
    type As StandardFileType
) As Stream
public:
virtual Stream^ IO_GetStandardStream(
    StandardFileType type
) override
abstract IO_GetStandardStream :
        type : StandardFileType -> Stream
override IO_GetStandardStream :
        type : StandardFileType -> Stream

Parameters

type
Type: MoonSharp.Interpreter.PlatformsStandardFileType
The type.

Return Value

Type: Stream

Implements

IPlatformAccessorIO_GetStandardStream(StandardFileType)
Exceptions
Exception | Condition
NotImplementedException | The current platform accessor does not support 'io' and 'os' operations. Provide your own implementation of platform to work around this limitation, if needed.
See Also

Reference

LimitedPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


LimitedPlatformAccessor.IO_OpenFile Method

LimitedPlatformAccessorIO_OpenFile Method
A function used to open files in the 'io' module. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override Stream IO_OpenFile(
    Script script,
    string filename,
    Encoding encoding,
    string mode
)
Public Overrides Function IO_OpenFile (
    script As Script,
    filename As String,
    encoding As Encoding,
    mode As String
) As Stream
public:
virtual Stream^ IO_OpenFile(
    Script^ script,
    String^ filename,
    Encoding^ encoding,
    String^ mode
) override
abstract IO_OpenFile :
        script : Script *
        filename : string *
        encoding : Encoding *
        mode : string -> Stream
override IO_OpenFile :
        script : Script *
        filename : string *
        encoding : Encoding *
        mode : string -> Stream

Parameters

script
Type: MoonSharp.InterpreterScript

[Missing <param name="script"/> documentation for "M:MoonSharp.Interpreter.Platforms.LimitedPlatformAccessor.IO_OpenFile(MoonSharp.Interpreter.Script,System.String,System.Text.Encoding,System.String)"]

filename
Type: SystemString
The filename.
encoding
Type: System.TextEncoding
The encoding.
mode
Type: SystemString
The mode (as per Lua usage - e.g. 'w+', 'rb', etc.).

Return Value

Type: Stream

Implements

IPlatformAccessorIO_OpenFile(Script, String, Encoding, String)
Exceptions
Exception | Condition
NotImplementedException | The current platform accessor does not support 'io' and 'os' operations. Provide your own implementation of platform to work around this limitation, if needed.
See Also

Reference

LimitedPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


LimitedPlatformAccessor.IO_OS_GetTempFilename Method

LimitedPlatformAccessorIO_OS_GetTempFilename Method
Gets a temporary filename. Used in 'io' and 'os' modules. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override string IO_OS_GetTempFilename()
Public Overrides Function IO_OS_GetTempFilename As String
public:
virtual String^ IO_OS_GetTempFilename() override
abstract IO_OS_GetTempFilename : unit -> string
override IO_OS_GetTempFilename : unit -> string

Return Value

Type: String

Implements

IPlatformAccessorIO_OS_GetTempFilename
Exceptions
Exception | Condition
NotImplementedException | The current platform accessor does not support 'io' and 'os' operations. Provide your own implementation of platform to work around this limitation, if needed.
See Also

Reference

LimitedPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


LimitedPlatformAccessor.OS_Execute Method

LimitedPlatformAccessorOS_Execute Method
Executes the specified command line, returning the child process exit code and blocking in the meantime. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override int OS_Execute(
    string cmdline
)
Public Overrides Function OS_Execute (
    cmdline As String
) As Integer
public:
virtual int OS_Execute(
    String^ cmdline
) override
abstract OS_Execute :
        cmdline : string -> int
override OS_Execute :
        cmdline : string -> int

Parameters

cmdline
Type: SystemString
The cmdline.

Return Value

Type: Int32

Implements

IPlatformAccessorOS_Execute(String)
Exceptions
Exception | Condition
NotImplementedException | The current platform accessor does not support 'io' and 'os' operations. Provide your own implementation of platform to work around this limitation, if needed.
See Also

Reference

LimitedPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


LimitedPlatformAccessor.OS_ExitFast Method

LimitedPlatformAccessorOS_ExitFast Method
Exits the process, returning the specified exit code. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void OS_ExitFast(
    int exitCode
)
Public Overrides Sub OS_ExitFast (
    exitCode As Integer
)
public:
virtual void OS_ExitFast(
    int exitCode
) override
abstract OS_ExitFast :
        exitCode : int -> unit
override OS_ExitFast :
        exitCode : int -> unit

Parameters

exitCode
Type: SystemInt32
The exit code.

Implements

IPlatformAccessorOS_ExitFast(Int32)
Exceptions
Exception | Condition
NotImplementedException | The current platform accessor does not support 'io' and 'os' operations. Provide your own implementation of platform to work around this limitation, if needed.
See Also

Reference

LimitedPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


LimitedPlatformAccessor.OS_FileDelete Method

LimitedPlatformAccessorOS_FileDelete Method
Deletes the specified file. Used by the 'os' module. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void OS_FileDelete(
    string file
)
Public Overrides Sub OS_FileDelete (
    file As String
)
public:
virtual void OS_FileDelete(
    String^ file
) override
abstract OS_FileDelete :
        file : string -> unit
override OS_FileDelete :
        file : string -> unit

Parameters

file
Type: SystemString
The file.

Implements

IPlatformAccessorOS_FileDelete(String)
Exceptions
Exception | Condition
NotImplementedException | The current platform accessor does not support 'io' and 'os' operations. Provide your own implementation of platform to work around this limitation, if needed.
See Also

Reference

LimitedPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


LimitedPlatformAccessor.OS_FileExists Method

LimitedPlatformAccessorOS_FileExists Method
Checks if a file exists. Used by the 'os' module. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override bool OS_FileExists(
    string file
)
Public Overrides Function OS_FileExists (
    file As String
) As Boolean
public:
virtual bool OS_FileExists(
    String^ file
) override
abstract OS_FileExists :
        file : string -> bool
override OS_FileExists :
        file : string -> bool

Parameters

file
Type: SystemString
The file.

Return Value

Type: Boolean
True if the file exists, false otherwise.

Implements

IPlatformAccessorOS_FileExists(String)
Exceptions
Exception | Condition
NotImplementedException | The current platform accessor does not support 'io' and 'os' operations. Provide your own implementation of platform to work around this limitation, if needed.
See Also

Reference

LimitedPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


LimitedPlatformAccessor.OS_FileMove Method

LimitedPlatformAccessorOS_FileMove Method
Moves the specified file. Used by the 'os' module. LimitedPlatformAccessorBase does NOT offer a meaningful implementation of this method and thus does not support 'io' and 'os' modules.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void OS_FileMove(
    string src,
    string dst
)
Public Overrides Sub OS_FileMove (
    src As String,
    dst As String
)
public:
virtual void OS_FileMove(
    String^ src,
    String^ dst
) override
abstract OS_FileMove :
        src : string *
        dst : string -> unit
override OS_FileMove :
        src : string *
        dst : string -> unit

Parameters

src
Type: SystemString
The source.
dst
Type: SystemString
The DST.

Implements

IPlatformAccessorOS_FileMove(String, String)
Exceptions
Exception | Condition
NotImplementedException | The current platform accessor does not support 'io' and 'os' operations. Provide your own implementation of platform to work around this limitation, if needed.
See Also

Reference

LimitedPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase Class

PlatformAccessorBase Class
An abstract class which offers basic services on top of IPlatformAccessor to provide easier implementation of platforms.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.PlatformsPlatformAccessorBase
MoonSharp.Interpreter.PlatformsLimitedPlatformAccessor
MoonSharp.Interpreter.PlatformsStandardPlatformAccessor

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class PlatformAccessorBase : IPlatformAccessor
Public MustInherit Class PlatformAccessorBase
    Implements IPlatformAccessor
public ref class PlatformAccessorBase abstract : IPlatformAccessor
[<AbstractClassAttribute>]
type PlatformAccessorBase =
    class
        interface IPlatformAccessor
    end

The PlatformAccessorBase type exposes the following members.

Constructors
 | Name | Description
Protected method | PlatformAccessorBase | Initializes a new instance of the PlatformAccessorBase class
Top
Methods
 | Name | Description
Public method | DefaultInput | Obsolete. DEPRECATED. This is kept for backward compatibility, see the overload taking a prompt as an input parameter. Default handler for interactive line input calls. Can be customized in ScriptOptions. If an inheriting class whants to give a meaningful implementation, this method MUST be overridden.
Public method | DefaultInput(String) | Default handler for interactive line input calls. Can be customized in ScriptOptions. If an inheriting class whants to give a meaningful implementation, this method MUST be overridden.
Public method | DefaultPrint | Default handler for 'print' calls. Can be customized in ScriptOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FilterSupportedCoreModules | Filters the CoreModules enumeration to exclude non-supported operations
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnvironmentVariable | Gets an environment variable. Must be implemented, but an implementation is allowed to always return null if a more meaningful implementation cannot be achieved or is not desired.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPlatformName | Gets the name of the platform (used for debug purposes).
Public method | GetPlatformNamePrefix | Gets the platform name prefix
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IO_GetStandardStream | Gets a standard stream (stdin, stdout, stderr).
Public method | IO_OpenFile | A function used to open files in the 'io' module. Can have an invalid implementation if 'io' module is filtered out. It should return a correctly initialized Stream for the given file and access
Public method | IO_OS_GetTempFilename | Gets a temporary filename. Used in 'io' and 'os' modules. Can have an invalid implementation if 'io' and 'os' modules are filtered out.
Public method | IsRunningOnAOT | Determines whether the application is running in AOT (ahead-of-time) mode
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OS_Execute | Executes the specified command line, returning the child process exit code and blocking in the meantime. Can have an invalid implementation if the 'os' module is filtered out.
Public method | OS_ExitFast | Exits the process, returning the specified exit code. Can have an invalid implementation if the 'os' module is filtered out.
Public method | OS_FileDelete | Deletes the specified file. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.
Public method | OS_FileExists | Checks if a file exists. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.
Public method | OS_FileMove | Moves the specified file. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase Constructor

PlatformAccessorBase Constructor
Initializes a new instance of the PlatformAccessorBase class

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
protected PlatformAccessorBase()
Protected Sub New
protected:
PlatformAccessorBase()
new : unit -> PlatformAccessorBase
See Also

Reference

PlatformAccessorBase Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase Methods

PlatformAccessorBase Methods

The PlatformAccessorBase type exposes the following members.

Methods
 | Name | Description
Public method | DefaultInput | Obsolete. DEPRECATED. This is kept for backward compatibility, see the overload taking a prompt as an input parameter. Default handler for interactive line input calls. Can be customized in ScriptOptions. If an inheriting class whants to give a meaningful implementation, this method MUST be overridden.
Public method | DefaultInput(String) | Default handler for interactive line input calls. Can be customized in ScriptOptions. If an inheriting class whants to give a meaningful implementation, this method MUST be overridden.
Public method | DefaultPrint | Default handler for 'print' calls. Can be customized in ScriptOptions
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FilterSupportedCoreModules | Filters the CoreModules enumeration to exclude non-supported operations
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnvironmentVariable | Gets an environment variable. Must be implemented, but an implementation is allowed to always return null if a more meaningful implementation cannot be achieved or is not desired.
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPlatformName | Gets the name of the platform (used for debug purposes).
Public method | GetPlatformNamePrefix | Gets the platform name prefix
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IO_GetStandardStream | Gets a standard stream (stdin, stdout, stderr).
Public method | IO_OpenFile | A function used to open files in the 'io' module. Can have an invalid implementation if 'io' module is filtered out. It should return a correctly initialized Stream for the given file and access
Public method | IO_OS_GetTempFilename | Gets a temporary filename. Used in 'io' and 'os' modules. Can have an invalid implementation if 'io' and 'os' modules are filtered out.
Public method | IsRunningOnAOT | Determines whether the application is running in AOT (ahead-of-time) mode
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OS_Execute | Executes the specified command line, returning the child process exit code and blocking in the meantime. Can have an invalid implementation if the 'os' module is filtered out.
Public method | OS_ExitFast | Exits the process, returning the specified exit code. Can have an invalid implementation if the 'os' module is filtered out.
Public method | OS_FileDelete | Deletes the specified file. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.
Public method | OS_FileExists | Checks if a file exists. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.
Public method | OS_FileMove | Moves the specified file. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PlatformAccessorBase Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase.DefaultInput Method

PlatformAccessorBaseDefaultInput Method
Overload List
 | Name | Description
Public method | DefaultInput | Obsolete. DEPRECATED. This is kept for backward compatibility, see the overload taking a prompt as an input parameter. Default handler for interactive line input calls. Can be customized in ScriptOptions. If an inheriting class whants to give a meaningful implementation, this method MUST be overridden.
Public method | DefaultInput(String) | Default handler for interactive line input calls. Can be customized in ScriptOptions. If an inheriting class whants to give a meaningful implementation, this method MUST be overridden.
Top
See Also

Reference

PlatformAccessorBase Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase.DefaultInput Method

PlatformAccessorBaseDefaultInput Method

Note: This API is now obsolete.

DEPRECATED. This is kept for backward compatibility, see the overload taking a prompt as an input parameter. Default handler for interactive line input calls. Can be customized in ScriptOptions. If an inheriting class whants to give a meaningful implementation, this method MUST be overridden.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("Replace with DefaultInput(string)")]
public virtual string DefaultInput()
<ObsoleteAttribute("Replace with DefaultInput(string)")>
Public Overridable Function DefaultInput As String
public:
[ObsoleteAttribute(L"Replace with DefaultInput(string)")]
virtual String^ DefaultInput()
[<ObsoleteAttribute("Replace with DefaultInput(string)")>]
abstract DefaultInput : unit -> string
[<ObsoleteAttribute("Replace with DefaultInput(string)")>]
override DefaultInput : unit -> string

Return Value

Type: String
null
See Also

Reference

PlatformAccessorBase Class
DefaultInput Overload
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase.DefaultInput Method (String)

PlatformAccessorBaseDefaultInput Method (String)
Default handler for interactive line input calls. Can be customized in ScriptOptions. If an inheriting class whants to give a meaningful implementation, this method MUST be overridden.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string DefaultInput(
    string prompt
)
Public Overridable Function DefaultInput (
    prompt As String
) As String
public:
virtual String^ DefaultInput(
    String^ prompt
)
abstract DefaultInput :
        prompt : string -> string
override DefaultInput :
        prompt : string -> string

Parameters

prompt
Type: SystemString

[Missing <param name="prompt"/> documentation for "M:MoonSharp.Interpreter.Platforms.PlatformAccessorBase.DefaultInput(System.String)"]

Return Value

Type: String
null

Implements

IPlatformAccessorDefaultInput(String)
See Also

Reference

PlatformAccessorBase Class
DefaultInput Overload
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase.DefaultPrint Method

PlatformAccessorBaseDefaultPrint Method
Default handler for 'print' calls. Can be customized in ScriptOptions

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract void DefaultPrint(
    string content
)
Public MustOverride Sub DefaultPrint (
    content As String
)
public:
virtual void DefaultPrint(
    String^ content
) abstract
abstract DefaultPrint :
        content : string -> unit

Parameters

content
Type: SystemString
The content.

Implements

IPlatformAccessorDefaultPrint(String)
See Also

Reference

PlatformAccessorBase Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase.FilterSupportedCoreModules Method

PlatformAccessorBaseFilterSupportedCoreModules Method
Filters the CoreModules enumeration to exclude non-supported operations

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract CoreModules FilterSupportedCoreModules(
    CoreModules module
)
Public MustOverride Function FilterSupportedCoreModules (
    module As CoreModules
) As CoreModules
public:
virtual CoreModules FilterSupportedCoreModules(
    CoreModules module
) abstract
abstract FilterSupportedCoreModules :
        module : CoreModules -> CoreModules

Parameters

module
Type: MoonSharp.InterpreterCoreModules
The requested modules.

Return Value

Type: CoreModules
The requested modules, with unsupported modules filtered out.

Implements

IPlatformAccessorFilterSupportedCoreModules(CoreModules)
See Also

Reference

PlatformAccessorBase Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase.GetEnvironmentVariable Method

PlatformAccessorBaseGetEnvironmentVariable Method
Gets an environment variable. Must be implemented, but an implementation is allowed to always return null if a more meaningful implementation cannot be achieved or is not desired.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract string GetEnvironmentVariable(
    string envvarname
)
Public MustOverride Function GetEnvironmentVariable (
    envvarname As String
) As String
public:
virtual String^ GetEnvironmentVariable(
    String^ envvarname
) abstract
abstract GetEnvironmentVariable :
        envvarname : string -> string

Parameters

envvarname
Type: SystemString
The envvarname.

Return Value

Type: String
The environment variable value, or null if not found

Implements

IPlatformAccessorGetEnvironmentVariable(String)
See Also

Reference

PlatformAccessorBase Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase.GetPlatformName Method

PlatformAccessorBaseGetPlatformName Method
Gets the name of the platform (used for debug purposes).

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string GetPlatformName()
Public Function GetPlatformName As String
public:
virtual String^ GetPlatformName() sealed
abstract GetPlatformName : unit -> string
override GetPlatformName : unit -> string

Return Value

Type: String
The name of the platform (used for debug purposes)

Implements

IPlatformAccessorGetPlatformName
See Also

Reference

PlatformAccessorBase Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase.GetPlatformNamePrefix Method

PlatformAccessorBaseGetPlatformNamePrefix Method
Gets the platform name prefix

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract string GetPlatformNamePrefix()
Public MustOverride Function GetPlatformNamePrefix As String
public:
virtual String^ GetPlatformNamePrefix() abstract
abstract GetPlatformNamePrefix : unit -> string

Return Value

Type: String
See Also

Reference

PlatformAccessorBase Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase.IO_GetStandardStream Method

PlatformAccessorBaseIO_GetStandardStream Method
Gets a standard stream (stdin, stdout, stderr).

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract Stream IO_GetStandardStream(
    StandardFileType type
)
Public MustOverride Function IO_GetStandardStream (
    type As StandardFileType
) As Stream
public:
virtual Stream^ IO_GetStandardStream(
    StandardFileType type
) abstract
abstract IO_GetStandardStream :
        type : StandardFileType -> Stream

Parameters

type
Type: MoonSharp.Interpreter.PlatformsStandardFileType
The type.

Return Value

Type: Stream

Implements

IPlatformAccessorIO_GetStandardStream(StandardFileType)
See Also

Reference

PlatformAccessorBase Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase.IO_OpenFile Method

PlatformAccessorBaseIO_OpenFile Method
A function used to open files in the 'io' module. Can have an invalid implementation if 'io' module is filtered out. It should return a correctly initialized Stream for the given file and access

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract Stream IO_OpenFile(
    Script script,
    string filename,
    Encoding encoding,
    string mode
)
Public MustOverride Function IO_OpenFile (
    script As Script,
    filename As String,
    encoding As Encoding,
    mode As String
) As Stream
public:
virtual Stream^ IO_OpenFile(
    Script^ script,
    String^ filename,
    Encoding^ encoding,
    String^ mode
) abstract
abstract IO_OpenFile :
        script : Script *
        filename : string *
        encoding : Encoding *
        mode : string -> Stream

Parameters

script
Type: MoonSharp.InterpreterScript

[Missing <param name="script"/> documentation for "M:MoonSharp.Interpreter.Platforms.PlatformAccessorBase.IO_OpenFile(MoonSharp.Interpreter.Script,System.String,System.Text.Encoding,System.String)"]

filename
Type: SystemString
The filename.
encoding
Type: System.TextEncoding
The encoding.
mode
Type: SystemString
The mode (as per Lua usage - e.g. 'w+', 'rb', etc.).

Return Value

Type: Stream

Implements

IPlatformAccessorIO_OpenFile(Script, String, Encoding, String)
See Also

Reference

PlatformAccessorBase Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase.IO_OS_GetTempFilename Method

PlatformAccessorBaseIO_OS_GetTempFilename Method
Gets a temporary filename. Used in 'io' and 'os' modules. Can have an invalid implementation if 'io' and 'os' modules are filtered out.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract string IO_OS_GetTempFilename()
Public MustOverride Function IO_OS_GetTempFilename As String
public:
virtual String^ IO_OS_GetTempFilename() abstract
abstract IO_OS_GetTempFilename : unit -> string

Return Value

Type: String

Implements

IPlatformAccessorIO_OS_GetTempFilename
See Also

Reference

PlatformAccessorBase Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase.IsRunningOnAOT Method

PlatformAccessorBaseIsRunningOnAOT Method
Determines whether the application is running in AOT (ahead-of-time) mode

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsRunningOnAOT()
Public Overridable Function IsRunningOnAOT As Boolean
public:
virtual bool IsRunningOnAOT()
abstract IsRunningOnAOT : unit -> bool
override IsRunningOnAOT : unit -> bool

Return Value

Type: Boolean

Implements

IPlatformAccessorIsRunningOnAOT
See Also

Reference

PlatformAccessorBase Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase.OS_Execute Method

PlatformAccessorBaseOS_Execute Method
Executes the specified command line, returning the child process exit code and blocking in the meantime. Can have an invalid implementation if the 'os' module is filtered out.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract int OS_Execute(
    string cmdline
)
Public MustOverride Function OS_Execute (
    cmdline As String
) As Integer
public:
virtual int OS_Execute(
    String^ cmdline
) abstract
abstract OS_Execute :
        cmdline : string -> int

Parameters

cmdline
Type: SystemString
The cmdline.

Return Value

Type: Int32

Implements

IPlatformAccessorOS_Execute(String)
See Also

Reference

PlatformAccessorBase Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase.OS_ExitFast Method

PlatformAccessorBaseOS_ExitFast Method
Exits the process, returning the specified exit code. Can have an invalid implementation if the 'os' module is filtered out.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract void OS_ExitFast(
    int exitCode
)
Public MustOverride Sub OS_ExitFast (
    exitCode As Integer
)
public:
virtual void OS_ExitFast(
    int exitCode
) abstract
abstract OS_ExitFast :
        exitCode : int -> unit

Parameters

exitCode
Type: SystemInt32
The exit code.

Implements

IPlatformAccessorOS_ExitFast(Int32)
See Also

Reference

PlatformAccessorBase Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase.OS_FileDelete Method

PlatformAccessorBaseOS_FileDelete Method
Deletes the specified file. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract void OS_FileDelete(
    string file
)
Public MustOverride Sub OS_FileDelete (
    file As String
)
public:
virtual void OS_FileDelete(
    String^ file
) abstract
abstract OS_FileDelete :
        file : string -> unit

Parameters

file
Type: SystemString
The file.

Implements

IPlatformAccessorOS_FileDelete(String)
See Also

Reference

PlatformAccessorBase Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase.OS_FileExists Method

PlatformAccessorBaseOS_FileExists Method
Checks if a file exists. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract bool OS_FileExists(
    string file
)
Public MustOverride Function OS_FileExists (
    file As String
) As Boolean
public:
virtual bool OS_FileExists(
    String^ file
) abstract
abstract OS_FileExists :
        file : string -> bool

Parameters

file
Type: SystemString
The file.

Return Value

Type: Boolean
True if the file exists, false otherwise.

Implements

IPlatformAccessorOS_FileExists(String)
See Also

Reference

PlatformAccessorBase Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAccessorBase.OS_FileMove Method

PlatformAccessorBaseOS_FileMove Method
Moves the specified file. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public abstract void OS_FileMove(
    string src,
    string dst
)
Public MustOverride Sub OS_FileMove (
    src As String,
    dst As String
)
public:
virtual void OS_FileMove(
    String^ src,
    String^ dst
) abstract
abstract OS_FileMove :
        src : string *
        dst : string -> unit

Parameters

src
Type: SystemString
The source.
dst
Type: SystemString
The DST.

Implements

IPlatformAccessorOS_FileMove(String, String)
See Also

Reference

PlatformAccessorBase Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAutoDetector Class

PlatformAutoDetector Class
A static class offering properties for autodetection of system/platform details
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.PlatformsPlatformAutoDetector

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static class PlatformAutoDetector
Public NotInheritable Class PlatformAutoDetector
public ref class PlatformAutoDetector abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PlatformAutoDetector =  class end

The PlatformAutoDetector type exposes the following members.

Properties
Name | Description
IsPortableFramework | Gets a value indicating whether this instance has been built as a Portable Class Library
IsRunningOnAOT | Gets a value indicating whether this instance is running a system using Ahead-Of-Time compilation and not supporting JIT.
IsRunningOnClr4 | Gets a value indicating whether this instance is running on a CLR4 compatible implementation
IsRunningOnMono | Gets a value indicating whether this instance is running on mono.
IsRunningOnUnity | Gets a value indicating whether this instance is running on Unity-3D
IsUnityIL2CPP | Gets a value indicating whether this instance has been compiled natively in Unity AND is using IL2CPP
IsUnityNative | Gets a value indicating whether this instance has been compiled natively in Unity (as opposite to importing a DLL).
Top
See Also

Reference

MoonSharp.Interpreter.Platforms Namespace


PlatformAutoDetector Properties

PlatformAutoDetector Properties

The PlatformAutoDetector type exposes the following members.

Properties
Name | Description
IsPortableFramework | Gets a value indicating whether this instance has been built as a Portable Class Library
IsRunningOnAOT | Gets a value indicating whether this instance is running a system using Ahead-Of-Time compilation and not supporting JIT.
IsRunningOnClr4 | Gets a value indicating whether this instance is running on a CLR4 compatible implementation
IsRunningOnMono | Gets a value indicating whether this instance is running on mono.
IsRunningOnUnity | Gets a value indicating whether this instance is running on Unity-3D
IsUnityIL2CPP | Gets a value indicating whether this instance has been compiled natively in Unity AND is using IL2CPP
IsUnityNative | Gets a value indicating whether this instance has been compiled natively in Unity (as opposite to importing a DLL).
Top
See Also

Reference

PlatformAutoDetector Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAutoDetector.IsPortableFramework Property

PlatformAutoDetectorIsPortableFramework Property
Gets a value indicating whether this instance has been built as a Portable Class Library

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsPortableFramework { get; }
Public Shared ReadOnly Property IsPortableFramework As Boolean
    Get
public:
static property bool IsPortableFramework {
    bool get ();
}
static member IsPortableFramework : bool with get

Property Value

Type: Boolean
See Also

Reference

PlatformAutoDetector Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAutoDetector.IsRunningOnAOT Property

PlatformAutoDetectorIsRunningOnAOT Property
Gets a value indicating whether this instance is running a system using Ahead-Of-Time compilation and not supporting JIT.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsRunningOnAOT { get; }
Public Shared ReadOnly Property IsRunningOnAOT As Boolean
    Get
public:
static property bool IsRunningOnAOT {
    bool get ();
}
static member IsRunningOnAOT : bool with get

Property Value

Type: Boolean
See Also

Reference

PlatformAutoDetector Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAutoDetector.IsRunningOnClr4 Property

PlatformAutoDetectorIsRunningOnClr4 Property
Gets a value indicating whether this instance is running on a CLR4 compatible implementation

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsRunningOnClr4 { get; }
Public Shared ReadOnly Property IsRunningOnClr4 As Boolean
    Get
public:
static property bool IsRunningOnClr4 {
    bool get ();
}
static member IsRunningOnClr4 : bool with get

Property Value

Type: Boolean
See Also

Reference

PlatformAutoDetector Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAutoDetector.IsRunningOnMono Property

PlatformAutoDetectorIsRunningOnMono Property
Gets a value indicating whether this instance is running on mono.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsRunningOnMono { get; }
Public Shared ReadOnly Property IsRunningOnMono As Boolean
    Get
public:
static property bool IsRunningOnMono {
    bool get ();
}
static member IsRunningOnMono : bool with get

Property Value

Type: Boolean
See Also

Reference

PlatformAutoDetector Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAutoDetector.IsRunningOnUnity Property

PlatformAutoDetectorIsRunningOnUnity Property
Gets a value indicating whether this instance is running on Unity-3D

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsRunningOnUnity { get; }
Public Shared ReadOnly Property IsRunningOnUnity As Boolean
    Get
public:
static property bool IsRunningOnUnity {
    bool get ();
}
static member IsRunningOnUnity : bool with get

Property Value

Type: Boolean
See Also

Reference

PlatformAutoDetector Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAutoDetector.IsUnityIL2CPP Property

PlatformAutoDetectorIsUnityIL2CPP Property
Gets a value indicating whether this instance has been compiled natively in Unity AND is using IL2CPP

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsUnityIL2CPP { get; }
Public Shared ReadOnly Property IsUnityIL2CPP As Boolean
    Get
public:
static property bool IsUnityIL2CPP {
    bool get ();
}
static member IsUnityIL2CPP : bool with get

Property Value

Type: Boolean
See Also

Reference

PlatformAutoDetector Class
MoonSharp.Interpreter.Platforms Namespace


PlatformAutoDetector.IsUnityNative Property

PlatformAutoDetectorIsUnityNative Property
Gets a value indicating whether this instance has been compiled natively in Unity (as opposite to importing a DLL).

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsUnityNative { get; }
Public Shared ReadOnly Property IsUnityNative As Boolean
    Get
public:
static property bool IsUnityNative {
    bool get ();
}
static member IsUnityNative : bool with get

Property Value

Type: Boolean
See Also

Reference

PlatformAutoDetector Class
MoonSharp.Interpreter.Platforms Namespace


StandardFileType Enumeration

StandardFileType Enumeration
Enumeration of standard file handles

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public enum StandardFileType
Public Enumeration StandardFileType
public enum class StandardFileType
type StandardFileType
Members
Member name | Value | Description
StdIn | 0 | Standard Input
StdOut | 1 | Standard Output
StdErr | 2 | Standard Error Output
See Also

Reference

MoonSharp.Interpreter.Platforms Namespace


StandardPlatformAccessor Class

StandardPlatformAccessor Class
Class providing the IPlatformAccessor interface for standard full-feaured implementations.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.PlatformsPlatformAccessorBase
MoonSharp.Interpreter.PlatformsStandardPlatformAccessor

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class StandardPlatformAccessor : PlatformAccessorBase
Public Class StandardPlatformAccessor
    Inherits PlatformAccessorBase
public ref class StandardPlatformAccessor : public PlatformAccessorBase
type StandardPlatformAccessor =
    class
        inherit PlatformAccessorBase
    end

The StandardPlatformAccessor type exposes the following members.

Constructors
 | Name | Description
Public method | StandardPlatformAccessor | Initializes a new instance of the StandardPlatformAccessor class
Top
Methods
 | Name | Description
Public method | DefaultInput | Obsolete. DEPRECATED. This is kept for backward compatibility, see the overload taking a prompt as an input parameter. Default handler for interactive line input calls. Can be customized in ScriptOptions. If an inheriting class whants to give a meaningful implementation, this method MUST be overridden. (Inherited from PlatformAccessorBase.)
Public method | DefaultInput(String) | Default handler for interactive line input calls. Can be customized in ScriptOptions. If an inheriting class whants to give a meaningful implementation, this method MUST be overridden. (Inherited from PlatformAccessorBase.)
Public method | DefaultPrint | Default handler for 'print' calls. Can be customized in ScriptOptions (Overrides PlatformAccessorBaseDefaultPrint(String).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FilterSupportedCoreModules | Filters the CoreModules enumeration to exclude non-supported operations (Overrides PlatformAccessorBaseFilterSupportedCoreModules(CoreModules).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnvironmentVariable | Gets an environment variable. Must be implemented, but an implementation is allowed to always return null if a more meaningful implementation cannot be achieved or is not desired. (Overrides PlatformAccessorBaseGetEnvironmentVariable(String).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPlatformName | Gets the name of the platform (used for debug purposes). (Inherited from PlatformAccessorBase.)
Public method | GetPlatformNamePrefix | Gets the platform name prefix (Overrides PlatformAccessorBaseGetPlatformNamePrefix.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IO_GetStandardStream | Gets a standard stream (stdin, stdout, stderr). (Overrides PlatformAccessorBaseIO_GetStandardStream(StandardFileType).)
Public method | IO_OpenFile | A function used to open files in the 'io' module. Can have an invalid implementation if 'io' module is filtered out. It should return a correctly initialized Stream for the given file and access (Overrides PlatformAccessorBaseIO_OpenFile(Script, String, Encoding, String).)
Public method | IO_OS_GetTempFilename | Gets a temporary filename. Used in 'io' and 'os' modules. Can have an invalid implementation if 'io' and 'os' modules are filtered out. (Overrides PlatformAccessorBaseIO_OS_GetTempFilename.)
Public method | IsRunningOnAOT | Determines whether the application is running in AOT (ahead-of-time) mode (Inherited from PlatformAccessorBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OS_Execute | Executes the specified command line, returning the child process exit code and blocking in the meantime. Can have an invalid implementation if the 'os' module is filtered out. (Overrides PlatformAccessorBaseOS_Execute(String).)
Public method | OS_ExitFast | Exits the process, returning the specified exit code. Can have an invalid implementation if the 'os' module is filtered out. (Overrides PlatformAccessorBaseOS_ExitFast(Int32).)
Public method | OS_FileDelete | Deletes the specified file. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out. (Overrides PlatformAccessorBaseOS_FileDelete(String).)
Public method | OS_FileExists | Checks if a file exists. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out. (Overrides PlatformAccessorBaseOS_FileExists(String).)
Public method | OS_FileMove | Moves the specified file. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out. (Overrides PlatformAccessorBaseOS_FileMove(String, String).)
 | ParseFileAccess | Converts a Lua string access mode to a FileAccess enum
 | ParseFileMode | Converts a Lua string access mode to a ParseFileMode enum
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Platforms Namespace


StandardPlatformAccessor Constructor

StandardPlatformAccessor Constructor
Initializes a new instance of the StandardPlatformAccessor class

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public StandardPlatformAccessor()
Public Sub New
public:
StandardPlatformAccessor()
new : unit -> StandardPlatformAccessor
See Also

Reference

StandardPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


StandardPlatformAccessor Methods

StandardPlatformAccessor Methods

The StandardPlatformAccessor type exposes the following members.

Methods
 | Name | Description
Public method | DefaultInput | Obsolete. DEPRECATED. This is kept for backward compatibility, see the overload taking a prompt as an input parameter. Default handler for interactive line input calls. Can be customized in ScriptOptions. If an inheriting class whants to give a meaningful implementation, this method MUST be overridden. (Inherited from PlatformAccessorBase.)
Public method | DefaultInput(String) | Default handler for interactive line input calls. Can be customized in ScriptOptions. If an inheriting class whants to give a meaningful implementation, this method MUST be overridden. (Inherited from PlatformAccessorBase.)
Public method | DefaultPrint | Default handler for 'print' calls. Can be customized in ScriptOptions (Overrides PlatformAccessorBaseDefaultPrint(String).)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | FilterSupportedCoreModules | Filters the CoreModules enumeration to exclude non-supported operations (Overrides PlatformAccessorBaseFilterSupportedCoreModules(CoreModules).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnvironmentVariable | Gets an environment variable. Must be implemented, but an implementation is allowed to always return null if a more meaningful implementation cannot be achieved or is not desired. (Overrides PlatformAccessorBaseGetEnvironmentVariable(String).)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetPlatformName | Gets the name of the platform (used for debug purposes). (Inherited from PlatformAccessorBase.)
Public method | GetPlatformNamePrefix | Gets the platform name prefix (Overrides PlatformAccessorBaseGetPlatformNamePrefix.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IO_GetStandardStream | Gets a standard stream (stdin, stdout, stderr). (Overrides PlatformAccessorBaseIO_GetStandardStream(StandardFileType).)
Public method | IO_OpenFile | A function used to open files in the 'io' module. Can have an invalid implementation if 'io' module is filtered out. It should return a correctly initialized Stream for the given file and access (Overrides PlatformAccessorBaseIO_OpenFile(Script, String, Encoding, String).)
Public method | IO_OS_GetTempFilename | Gets a temporary filename. Used in 'io' and 'os' modules. Can have an invalid implementation if 'io' and 'os' modules are filtered out. (Overrides PlatformAccessorBaseIO_OS_GetTempFilename.)
Public method | IsRunningOnAOT | Determines whether the application is running in AOT (ahead-of-time) mode (Inherited from PlatformAccessorBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OS_Execute | Executes the specified command line, returning the child process exit code and blocking in the meantime. Can have an invalid implementation if the 'os' module is filtered out. (Overrides PlatformAccessorBaseOS_Execute(String).)
Public method | OS_ExitFast | Exits the process, returning the specified exit code. Can have an invalid implementation if the 'os' module is filtered out. (Overrides PlatformAccessorBaseOS_ExitFast(Int32).)
Public method | OS_FileDelete | Deletes the specified file. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out. (Overrides PlatformAccessorBaseOS_FileDelete(String).)
Public method | OS_FileExists | Checks if a file exists. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out. (Overrides PlatformAccessorBaseOS_FileExists(String).)
Public method | OS_FileMove | Moves the specified file. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out. (Overrides PlatformAccessorBaseOS_FileMove(String, String).)
 | ParseFileAccess | Converts a Lua string access mode to a FileAccess enum
 | ParseFileMode | Converts a Lua string access mode to a ParseFileMode enum
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StandardPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


StandardPlatformAccessor.DefaultPrint Method

StandardPlatformAccessorDefaultPrint Method
Default handler for 'print' calls. Can be customized in ScriptOptions

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void DefaultPrint(
    string content
)
Public Overrides Sub DefaultPrint (
    content As String
)
public:
virtual void DefaultPrint(
    String^ content
) override
abstract DefaultPrint :
        content : string -> unit
override DefaultPrint :
        content : string -> unit

Parameters

content
Type: SystemString
The content.

Implements

IPlatformAccessorDefaultPrint(String)
See Also

Reference

StandardPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


StandardPlatformAccessor.FilterSupportedCoreModules Method

StandardPlatformAccessorFilterSupportedCoreModules Method
Filters the CoreModules enumeration to exclude non-supported operations

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override CoreModules FilterSupportedCoreModules(
    CoreModules module
)
Public Overrides Function FilterSupportedCoreModules (
    module As CoreModules
) As CoreModules
public:
virtual CoreModules FilterSupportedCoreModules(
    CoreModules module
) override
abstract FilterSupportedCoreModules :
        module : CoreModules -> CoreModules
override FilterSupportedCoreModules :
        module : CoreModules -> CoreModules

Parameters

module
Type: MoonSharp.InterpreterCoreModules
The requested modules.

Return Value

Type: CoreModules
The requested modules, with unsupported modules filtered out.

Implements

IPlatformAccessorFilterSupportedCoreModules(CoreModules)
See Also

Reference

StandardPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


StandardPlatformAccessor.GetEnvironmentVariable Method

StandardPlatformAccessorGetEnvironmentVariable Method
Gets an environment variable. Must be implemented, but an implementation is allowed to always return null if a more meaningful implementation cannot be achieved or is not desired.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetEnvironmentVariable(
    string envvarname
)
Public Overrides Function GetEnvironmentVariable (
    envvarname As String
) As String
public:
virtual String^ GetEnvironmentVariable(
    String^ envvarname
) override
abstract GetEnvironmentVariable :
        envvarname : string -> string
override GetEnvironmentVariable :
        envvarname : string -> string

Parameters

envvarname
Type: SystemString
The envvarname.

Return Value

Type: String
The environment variable value, or null if not found

Implements

IPlatformAccessorGetEnvironmentVariable(String)
See Also

Reference

StandardPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


StandardPlatformAccessor.GetPlatformNamePrefix Method

StandardPlatformAccessorGetPlatformNamePrefix Method
Gets the platform name prefix

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override string GetPlatformNamePrefix()
Public Overrides Function GetPlatformNamePrefix As String
public:
virtual String^ GetPlatformNamePrefix() override
abstract GetPlatformNamePrefix : unit -> string
override GetPlatformNamePrefix : unit -> string

Return Value

Type: String
Exceptions
Exception | Condition
NotImplementedException |
See Also

Reference

StandardPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


StandardPlatformAccessor.IO_GetStandardStream Method

StandardPlatformAccessorIO_GetStandardStream Method
Gets a standard stream (stdin, stdout, stderr).

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override Stream IO_GetStandardStream(
    StandardFileType type
)
Public Overrides Function IO_GetStandardStream (
    type As StandardFileType
) As Stream
public:
virtual Stream^ IO_GetStandardStream(
    StandardFileType type
) override
abstract IO_GetStandardStream :
        type : StandardFileType -> Stream
override IO_GetStandardStream :
        type : StandardFileType -> Stream

Parameters

type
Type: MoonSharp.Interpreter.PlatformsStandardFileType
The type.

Return Value

Type: Stream

Implements

IPlatformAccessorIO_GetStandardStream(StandardFileType)
Exceptions
Exception | Condition
ArgumentException | type
See Also

Reference

StandardPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


StandardPlatformAccessor.IO_OpenFile Method

StandardPlatformAccessorIO_OpenFile Method
A function used to open files in the 'io' module. Can have an invalid implementation if 'io' module is filtered out. It should return a correctly initialized Stream for the given file and access

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override Stream IO_OpenFile(
    Script script,
    string filename,
    Encoding encoding,
    string mode
)
Public Overrides Function IO_OpenFile (
    script As Script,
    filename As String,
    encoding As Encoding,
    mode As String
) As Stream
public:
virtual Stream^ IO_OpenFile(
    Script^ script,
    String^ filename,
    Encoding^ encoding,
    String^ mode
) override
abstract IO_OpenFile :
        script : Script *
        filename : string *
        encoding : Encoding *
        mode : string -> Stream
override IO_OpenFile :
        script : Script *
        filename : string *
        encoding : Encoding *
        mode : string -> Stream

Parameters

script
Type: MoonSharp.InterpreterScript

[Missing <param name="script"/> documentation for "M:MoonSharp.Interpreter.Platforms.StandardPlatformAccessor.IO_OpenFile(MoonSharp.Interpreter.Script,System.String,System.Text.Encoding,System.String)"]

filename
Type: SystemString
The filename.
encoding
Type: System.TextEncoding
The encoding.
mode
Type: SystemString
The mode (as per Lua usage - e.g. 'w+', 'rb', etc.).

Return Value

Type: Stream

Implements

IPlatformAccessorIO_OpenFile(Script, String, Encoding, String)
See Also

Reference

StandardPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


StandardPlatformAccessor.IO_OS_GetTempFilename Method

StandardPlatformAccessorIO_OS_GetTempFilename Method
Gets a temporary filename. Used in 'io' and 'os' modules. Can have an invalid implementation if 'io' and 'os' modules are filtered out.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override string IO_OS_GetTempFilename()
Public Overrides Function IO_OS_GetTempFilename As String
public:
virtual String^ IO_OS_GetTempFilename() override
abstract IO_OS_GetTempFilename : unit -> string
override IO_OS_GetTempFilename : unit -> string

Return Value

Type: String

Implements

IPlatformAccessorIO_OS_GetTempFilename
See Also

Reference

StandardPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


StandardPlatformAccessor.OS_Execute Method

StandardPlatformAccessorOS_Execute Method
Executes the specified command line, returning the child process exit code and blocking in the meantime. Can have an invalid implementation if the 'os' module is filtered out.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override int OS_Execute(
    string cmdline
)
Public Overrides Function OS_Execute (
    cmdline As String
) As Integer
public:
virtual int OS_Execute(
    String^ cmdline
) override
abstract OS_Execute :
        cmdline : string -> int
override OS_Execute :
        cmdline : string -> int

Parameters

cmdline
Type: SystemString
The cmdline.

Return Value

Type: Int32

Implements

IPlatformAccessorOS_Execute(String)
See Also

Reference

StandardPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


StandardPlatformAccessor.OS_ExitFast Method

StandardPlatformAccessorOS_ExitFast Method
Exits the process, returning the specified exit code. Can have an invalid implementation if the 'os' module is filtered out.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void OS_ExitFast(
    int exitCode
)
Public Overrides Sub OS_ExitFast (
    exitCode As Integer
)
public:
virtual void OS_ExitFast(
    int exitCode
) override
abstract OS_ExitFast :
        exitCode : int -> unit
override OS_ExitFast :
        exitCode : int -> unit

Parameters

exitCode
Type: SystemInt32
The exit code.

Implements

IPlatformAccessorOS_ExitFast(Int32)
See Also

Reference

StandardPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


StandardPlatformAccessor.OS_FileDelete Method

StandardPlatformAccessorOS_FileDelete Method
Deletes the specified file. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void OS_FileDelete(
    string file
)
Public Overrides Sub OS_FileDelete (
    file As String
)
public:
virtual void OS_FileDelete(
    String^ file
) override
abstract OS_FileDelete :
        file : string -> unit
override OS_FileDelete :
        file : string -> unit

Parameters

file
Type: SystemString
The file.

Implements

IPlatformAccessorOS_FileDelete(String)
See Also

Reference

StandardPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


StandardPlatformAccessor.OS_FileExists Method

StandardPlatformAccessorOS_FileExists Method
Checks if a file exists. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override bool OS_FileExists(
    string file
)
Public Overrides Function OS_FileExists (
    file As String
) As Boolean
public:
virtual bool OS_FileExists(
    String^ file
) override
abstract OS_FileExists :
        file : string -> bool
override OS_FileExists :
        file : string -> bool

Parameters

file
Type: SystemString
The file.

Return Value

Type: Boolean
True if the file exists, false otherwise.

Implements

IPlatformAccessorOS_FileExists(String)
See Also

Reference

StandardPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


StandardPlatformAccessor.OS_FileMove Method

StandardPlatformAccessorOS_FileMove Method
Moves the specified file. Used by the 'os' module. Can have an invalid implementation if the 'os' module is filtered out.

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override void OS_FileMove(
    string src,
    string dst
)
Public Overrides Sub OS_FileMove (
    src As String,
    dst As String
)
public:
virtual void OS_FileMove(
    String^ src,
    String^ dst
) override
abstract OS_FileMove :
        src : string *
        dst : string -> unit
override OS_FileMove :
        src : string *
        dst : string -> unit

Parameters

src
Type: SystemString
The source.
dst
Type: SystemString
The DST.

Implements

IPlatformAccessorOS_FileMove(String, String)
See Also

Reference

StandardPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


StandardPlatformAccessor.ParseFileAccess Method

StandardPlatformAccessorParseFileAccess Method
Converts a Lua string access mode to a FileAccess enum

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static FileAccess ParseFileAccess(
    string mode
)
Public Shared Function ParseFileAccess (
    mode As String
) As FileAccess
public:
static FileAccess ParseFileAccess(
    String^ mode
)
static member ParseFileAccess :
        mode : string -> FileAccess

Parameters

mode
Type: SystemString
The mode.

Return Value

Type: FileAccess
See Also

Reference

StandardPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


StandardPlatformAccessor.ParseFileMode Method

StandardPlatformAccessorParseFileMode Method
Converts a Lua string access mode to a ParseFileMode enum

Namespace: MoonSharp.Interpreter.Platforms
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static FileMode ParseFileMode(
    string mode
)
Public Shared Function ParseFileMode (
    mode As String
) As FileMode
public:
static FileMode ParseFileMode(
    String^ mode
)
static member ParseFileMode :
        mode : string -> FileMode

Parameters

mode
Type: SystemString
The mode.

Return Value

Type: FileMode
See Also

Reference

StandardPlatformAccessor Class
MoonSharp.Interpreter.Platforms Namespace


MoonSharp.Interpreter.REPL Namespace

MoonSharp.Interpreter.REPL Namespace
Contains classes useful to implement REPL interpreters. See : http://en.wikipedia.org/wiki/Read%E2%80%93eval%E2%80%93print_loop
Classes
 | Class | Description
Public class | ReplHistoryInterpreter | An implementation of ReplInterpreter which supports a very basic history of recent input lines.
Public class | ReplInterpreter | This class provides a simple REPL intepreter ready to be reused in a simple way.
Public class | ReplInterpreterScriptLoader | A script loader loading scripts directly from the file system (does not go through platform object) AND starts with module paths taken from environment variables (again, not going through the platform object). The paths are preconstructed using : * The MOONSHARP_PATH environment variable if it exists * The LUA_PATH_5_2 environment variable if MOONSHARP_PATH does not exists * The LUA_PATH environment variable if LUA_PATH_5_2 and MOONSHARP_PATH do not exists * The "?;?.lua" path if all the above fail Also, everytime a module is require(d), the "LUA_PATH" global variable is checked. If it exists, those paths will be used to load the module instead of the global ones.


ReplHistoryInterpreter Class

ReplHistoryInterpreter Class
An implementation of ReplInterpreter which supports a very basic history of recent input lines.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.REPLReplInterpreter
MoonSharp.Interpreter.REPLReplHistoryInterpreter

Namespace: MoonSharp.Interpreter.REPL
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class ReplHistoryInterpreter : ReplInterpreter
Public Class ReplHistoryInterpreter
    Inherits ReplInterpreter
public ref class ReplHistoryInterpreter : public ReplInterpreter
type ReplHistoryInterpreter =
    class
        inherit ReplInterpreter
    end

The ReplHistoryInterpreter type exposes the following members.

Constructors
 | Name | Description
Public method | ReplHistoryInterpreter | Initializes a new instance of the ReplHistoryInterpreter class.
Top
Properties
 | Name | Description
Public property | ClassicPrompt | Gets the classic prompt (">" or ">>") given the current state of the interpreter (Inherited from ReplInterpreter.)
Public property | CurrentPendingCommand | Gets the current pending command. (Inherited from ReplInterpreter.)
Public property | HandleClassicExprsSyntax | Gets or sets a value indicating whether this instances handle inputs starting with a "=" as a non-dynamic expression to evaluate (just like the Lua interpreter does by default). (Inherited from ReplInterpreter.)
Public property | HandleDynamicExprs | Gets or sets a value indicating whether this instances handle inputs starting with a "?" as a dynamic expression to evaluate instead of script code (likely invalid) (Inherited from ReplInterpreter.)
Public property | HasPendingCommand | Gets a value indicating whether this instance has a pending command (Inherited from ReplInterpreter.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Evaluate | Evaluate a REPL command. This method returns the result of the computation, or null if more input is needed for having valid code. In case of errors, exceptions are propagated to the caller. (Overrides ReplInterpreterEvaluate(String).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HistoryNext | Gets the next item in history, or null
Public method | HistoryPrev | Gets the previous item in history, or null
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | EvaluateAsync | Asynchronously evaluates a REPL command. This method returns the result of the computation, or null if more input is needed for having valid code. In case of errors, exceptions are propagated to the caller. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Top
See Also

Reference

MoonSharp.Interpreter.REPL Namespace


ReplHistoryInterpreter Constructor

ReplHistoryInterpreter Constructor
Initializes a new instance of the ReplHistoryInterpreter class.

Namespace: MoonSharp.Interpreter.REPL
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ReplHistoryInterpreter(
    Script script,
    int historySize
)
Public Sub New (
    script As Script,
    historySize As Integer
)
public:
ReplHistoryInterpreter(
    Script^ script,
    int historySize
)
new :
        script : Script *
        historySize : int -> ReplHistoryInterpreter

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
historySize
Type: SystemInt32
Size of the history.
See Also

Reference

ReplHistoryInterpreter Class
MoonSharp.Interpreter.REPL Namespace


ReplHistoryInterpreter Properties

ReplHistoryInterpreter Properties

The ReplHistoryInterpreter type exposes the following members.

Properties
 | Name | Description
Public property | ClassicPrompt | Gets the classic prompt (">" or ">>") given the current state of the interpreter (Inherited from ReplInterpreter.)
Public property | CurrentPendingCommand | Gets the current pending command. (Inherited from ReplInterpreter.)
Public property | HandleClassicExprsSyntax | Gets or sets a value indicating whether this instances handle inputs starting with a "=" as a non-dynamic expression to evaluate (just like the Lua interpreter does by default). (Inherited from ReplInterpreter.)
Public property | HandleDynamicExprs | Gets or sets a value indicating whether this instances handle inputs starting with a "?" as a dynamic expression to evaluate instead of script code (likely invalid) (Inherited from ReplInterpreter.)
Public property | HasPendingCommand | Gets a value indicating whether this instance has a pending command (Inherited from ReplInterpreter.)
Top
See Also

Reference

ReplHistoryInterpreter Class
MoonSharp.Interpreter.REPL Namespace


ReplHistoryInterpreter Methods

ReplHistoryInterpreter Methods

The ReplHistoryInterpreter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Evaluate | Evaluate a REPL command. This method returns the result of the computation, or null if more input is needed for having valid code. In case of errors, exceptions are propagated to the caller. (Overrides ReplInterpreterEvaluate(String).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HistoryNext | Gets the next item in history, or null
Public method | HistoryPrev | Gets the previous item in history, or null
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | EvaluateAsync | Asynchronously evaluates a REPL command. This method returns the result of the computation, or null if more input is needed for having valid code. In case of errors, exceptions are propagated to the caller. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Top
See Also

Reference

ReplHistoryInterpreter Class
MoonSharp.Interpreter.REPL Namespace


ReplHistoryInterpreter.Evaluate Method

ReplHistoryInterpreterEvaluate Method
Evaluate a REPL command. This method returns the result of the computation, or null if more input is needed for having valid code. In case of errors, exceptions are propagated to the caller.

Namespace: MoonSharp.Interpreter.REPL
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override DynValue Evaluate(
    string input
)
Public Overrides Function Evaluate (
    input As String
) As DynValue
public:
virtual DynValue^ Evaluate(
    String^ input
) override
abstract Evaluate :
        input : string -> DynValue
override Evaluate :
        input : string -> DynValue

Parameters

input
Type: SystemString
The input.

Return Value

Type: DynValue
This method returns the result of the computation, or null if more input is needed for a computation.
See Also

Reference

ReplHistoryInterpreter Class
MoonSharp.Interpreter.REPL Namespace


ReplHistoryInterpreter.HistoryNext Method

ReplHistoryInterpreterHistoryNext Method
Gets the next item in history, or null

Namespace: MoonSharp.Interpreter.REPL
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string HistoryNext()
Public Function HistoryNext As String
public:
String^ HistoryNext()
member HistoryNext : unit -> string

Return Value

Type: String
See Also

Reference

ReplHistoryInterpreter Class
MoonSharp.Interpreter.REPL Namespace


ReplHistoryInterpreter.HistoryPrev Method

ReplHistoryInterpreterHistoryPrev Method
Gets the previous item in history, or null

Namespace: MoonSharp.Interpreter.REPL
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public string HistoryPrev()
Public Function HistoryPrev As String
public:
String^ HistoryPrev()
member HistoryPrev : unit -> string

Return Value

Type: String
See Also

Reference

ReplHistoryInterpreter Class
MoonSharp.Interpreter.REPL Namespace


ReplInterpreter Class

ReplInterpreter Class
This class provides a simple REPL intepreter ready to be reused in a simple way.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.REPLReplInterpreter
MoonSharp.Interpreter.REPLReplHistoryInterpreter

Namespace: MoonSharp.Interpreter.REPL
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class ReplInterpreter
Public Class ReplInterpreter
public ref class ReplInterpreter
type ReplInterpreter =  class end

The ReplInterpreter type exposes the following members.

Constructors
 | Name | Description
Public method | ReplInterpreter | Initializes a new instance of the ReplInterpreter class.
Top
Properties
 | Name | Description
Public property | ClassicPrompt | Gets the classic prompt (">" or ">>") given the current state of the interpreter
Public property | CurrentPendingCommand | Gets the current pending command.
Public property | HandleClassicExprsSyntax | Gets or sets a value indicating whether this instances handle inputs starting with a "=" as a non-dynamic expression to evaluate (just like the Lua interpreter does by default).
Public property | HandleDynamicExprs | Gets or sets a value indicating whether this instances handle inputs starting with a "?" as a dynamic expression to evaluate instead of script code (likely invalid)
Public property | HasPendingCommand | Gets a value indicating whether this instance has a pending command
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Evaluate | Evaluate a REPL command. This method returns the result of the computation, or null if more input is needed for having valid code. In case of errors, exceptions are propagated to the caller.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | EvaluateAsync | Asynchronously evaluates a REPL command. This method returns the result of the computation, or null if more input is needed for having valid code. In case of errors, exceptions are propagated to the caller. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Top
See Also

Reference

MoonSharp.Interpreter.REPL Namespace


ReplInterpreter Constructor

ReplInterpreter Constructor
Initializes a new instance of the ReplInterpreter class.

Namespace: MoonSharp.Interpreter.REPL
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ReplInterpreter(
    Script script
)
Public Sub New (
    script As Script
)
public:
ReplInterpreter(
    Script^ script
)
new :
        script : Script -> ReplInterpreter

Parameters

script
Type: MoonSharp.InterpreterScript
The script.
See Also

Reference

ReplInterpreter Class
MoonSharp.Interpreter.REPL Namespace


ReplInterpreter Properties

ReplInterpreter Properties

The ReplInterpreter type exposes the following members.

Properties
 | Name | Description
Public property | ClassicPrompt | Gets the classic prompt (">" or ">>") given the current state of the interpreter
Public property | CurrentPendingCommand | Gets the current pending command.
Public property | HandleClassicExprsSyntax | Gets or sets a value indicating whether this instances handle inputs starting with a "=" as a non-dynamic expression to evaluate (just like the Lua interpreter does by default).
Public property | HandleDynamicExprs | Gets or sets a value indicating whether this instances handle inputs starting with a "?" as a dynamic expression to evaluate instead of script code (likely invalid)
Public property | HasPendingCommand | Gets a value indicating whether this instance has a pending command
Top
See Also

Reference

ReplInterpreter Class
MoonSharp.Interpreter.REPL Namespace


ReplInterpreter.ClassicPrompt Property

ReplInterpreterClassicPrompt Property
Gets the classic prompt (">" or ">>") given the current state of the interpreter

Namespace: MoonSharp.Interpreter.REPL
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string ClassicPrompt { get; }
Public Overridable ReadOnly Property ClassicPrompt As String
    Get
public:
virtual property String^ ClassicPrompt {
    String^ get ();
}
abstract ClassicPrompt : string with get
override ClassicPrompt : string with get

Property Value

Type: String
See Also

Reference

ReplInterpreter Class
MoonSharp.Interpreter.REPL Namespace


ReplInterpreter.CurrentPendingCommand Property

ReplInterpreterCurrentPendingCommand Property
Gets the current pending command.

Namespace: MoonSharp.Interpreter.REPL
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public virtual string CurrentPendingCommand { get; }
Public Overridable ReadOnly Property CurrentPendingCommand As String
    Get
public:
virtual property String^ CurrentPendingCommand {
    String^ get ();
}
abstract CurrentPendingCommand : string with get
override CurrentPendingCommand : string with get

Property Value

Type: String
See Also

Reference

ReplInterpreter Class
MoonSharp.Interpreter.REPL Namespace


ReplInterpreter.HandleClassicExprsSyntax Property

ReplInterpreterHandleClassicExprsSyntax Property
Gets or sets a value indicating whether this instances handle inputs starting with a "=" as a non-dynamic expression to evaluate (just like the Lua interpreter does by default).

Namespace: MoonSharp.Interpreter.REPL
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool HandleClassicExprsSyntax { get; set; }
Public Property HandleClassicExprsSyntax As Boolean
    Get
    Set
public:
property bool HandleClassicExprsSyntax {
    bool get ();
    void set (bool value);
}
member HandleClassicExprsSyntax : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReplInterpreter Class
MoonSharp.Interpreter.REPL Namespace


ReplInterpreter.HandleDynamicExprs Property

ReplInterpreterHandleDynamicExprs Property
Gets or sets a value indicating whether this instances handle inputs starting with a "?" as a dynamic expression to evaluate instead of script code (likely invalid)

Namespace: MoonSharp.Interpreter.REPL
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public bool HandleDynamicExprs { get; set; }
Public Property HandleDynamicExprs As Boolean
    Get
    Set
public:
property bool HandleDynamicExprs {
    bool get ();
    void set (bool value);
}
member HandleDynamicExprs : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ReplInterpreter Class
MoonSharp.Interpreter.REPL Namespace


ReplInterpreter.HasPendingCommand Property

ReplInterpreterHasPendingCommand Property
Gets a value indicating whether this instance has a pending command

Namespace: MoonSharp.Interpreter.REPL
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public virtual bool HasPendingCommand { get; }
Public Overridable ReadOnly Property HasPendingCommand As Boolean
    Get
public:
virtual property bool HasPendingCommand {
    bool get ();
}
abstract HasPendingCommand : bool with get
override HasPendingCommand : bool with get

Property Value

Type: Boolean
See Also

Reference

ReplInterpreter Class
MoonSharp.Interpreter.REPL Namespace


ReplInterpreter Methods

ReplInterpreter Methods

The ReplInterpreter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | Evaluate | Evaluate a REPL command. This method returns the result of the computation, or null if more input is needed for having valid code. In case of errors, exceptions are propagated to the caller.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | EvaluateAsync | Asynchronously evaluates a REPL command. This method returns the result of the computation, or null if more input is needed for having valid code. In case of errors, exceptions are propagated to the caller. This method is supported only on .NET 4.x and .NET 4.x PCL targets. (Defined by AsyncExtensions.)
Top
See Also

Reference

ReplInterpreter Class
MoonSharp.Interpreter.REPL Namespace


ReplInterpreter.Evaluate Method

ReplInterpreterEvaluate Method
Evaluate a REPL command. This method returns the result of the computation, or null if more input is needed for having valid code. In case of errors, exceptions are propagated to the caller.

Namespace: MoonSharp.Interpreter.REPL
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public virtual DynValue Evaluate(
    string input
)
Public Overridable Function Evaluate (
    input As String
) As DynValue
public:
virtual DynValue^ Evaluate(
    String^ input
)
abstract Evaluate :
        input : string -> DynValue
override Evaluate :
        input : string -> DynValue

Parameters

input
Type: SystemString
The input.

Return Value

Type: DynValue
This method returns the result of the computation, or null if more input is needed for a computation.
See Also

Reference

ReplInterpreter Class
MoonSharp.Interpreter.REPL Namespace


ReplInterpreterScriptLoader Class

ReplInterpreterScriptLoader Class
A script loader loading scripts directly from the file system (does not go through platform object) AND starts with module paths taken from environment variables (again, not going through the platform object). The paths are preconstructed using : * The MOONSHARP_PATH environment variable if it exists * The LUA_PATH_5_2 environment variable if MOONSHARP_PATH does not exists * The LUA_PATH environment variable if LUA_PATH_5_2 and MOONSHARP_PATH do not exists * The "?;?.lua" path if all the above fail Also, everytime a module is require(d), the "LUA_PATH" global variable is checked. If it exists, those paths will be used to load the module instead of the global ones.
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.LoadersScriptLoaderBase
MoonSharp.Interpreter.LoadersFileSystemScriptLoader
MoonSharp.Interpreter.REPLReplInterpreterScriptLoader

Namespace: MoonSharp.Interpreter.REPL
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public class ReplInterpreterScriptLoader : FileSystemScriptLoader
Public Class ReplInterpreterScriptLoader
    Inherits FileSystemScriptLoader
public ref class ReplInterpreterScriptLoader : public FileSystemScriptLoader
type ReplInterpreterScriptLoader =
    class
        inherit FileSystemScriptLoader
    end

The ReplInterpreterScriptLoader type exposes the following members.

Constructors
 | Name | Description
Public method | ReplInterpreterScriptLoader | Initializes a new instance of the ReplInterpreterScriptLoader class.
Top
Properties
 | Name | Description
Public property | IgnoreLuaPathGlobal | Gets or sets a value indicating whether the LUA_PATH global is checked or not to get the path where modules are contained. If true, the LUA_PATH global is NOT checked. (Inherited from ScriptLoaderBase.)
Public property | ModulePaths | Gets or sets the modules paths used by the "require" function. If null, the default paths are used (using environment variables etc.). (Inherited from ScriptLoaderBase.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFile | Opens a file for reading the script code. It can return either a string, a byte[] or a Stream. If a byte[] is returned, the content is assumed to be a serialized (dumped) bytecode. If it's a string, it's assumed to be either a script or the output of a string.dump call. If a Stream, autodetection takes place. (Inherited from FileSystemScriptLoader.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResolveFileName | Resolves a filename [applying paths, etc.] (Inherited from ScriptLoaderBase.)
Protected method | ResolveModuleName(String, String) | Resolves the name of a module on a set of paths. (Inherited from ScriptLoaderBase.)
Public method | ResolveModuleName(String, Table) | Resolves the name of a module to a filename (which will later be passed to OpenScriptFile). The resolution happens first on paths included in the LUA_PATH global variable, and - if the variable does not exist - by consulting the ScriptOptions.ModulesPaths array. Override to provide a different behaviour. (Overrides ScriptLoaderBaseResolveModuleName(String, Table).)
Public method | ScriptFileExists | Checks if a script file exists. (Inherited from FileSystemScriptLoader.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.REPL Namespace


ReplInterpreterScriptLoader Constructor

ReplInterpreterScriptLoader Constructor
Initializes a new instance of the ReplInterpreterScriptLoader class.

Namespace: MoonSharp.Interpreter.REPL
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public ReplInterpreterScriptLoader()
Public Sub New
public:
ReplInterpreterScriptLoader()
new : unit -> ReplInterpreterScriptLoader
See Also

Reference

ReplInterpreterScriptLoader Class
MoonSharp.Interpreter.REPL Namespace


ReplInterpreterScriptLoader Properties

ReplInterpreterScriptLoader Properties

The ReplInterpreterScriptLoader type exposes the following members.

Properties
 | Name | Description
Public property | IgnoreLuaPathGlobal | Gets or sets a value indicating whether the LUA_PATH global is checked or not to get the path where modules are contained. If true, the LUA_PATH global is NOT checked. (Inherited from ScriptLoaderBase.)
Public property | ModulePaths | Gets or sets the modules paths used by the "require" function. If null, the default paths are used (using environment variables etc.). (Inherited from ScriptLoaderBase.)
Top
See Also

Reference

ReplInterpreterScriptLoader Class
MoonSharp.Interpreter.REPL Namespace


ReplInterpreterScriptLoader Methods

ReplInterpreterScriptLoader Methods

The ReplInterpreterScriptLoader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFile | Opens a file for reading the script code. It can return either a string, a byte[] or a Stream. If a byte[] is returned, the content is assumed to be a serialized (dumped) bytecode. If it's a string, it's assumed to be either a script or the output of a string.dump call. If a Stream, autodetection takes place. (Inherited from FileSystemScriptLoader.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResolveFileName | Resolves a filename [applying paths, etc.] (Inherited from ScriptLoaderBase.)
Protected method | ResolveModuleName(String, String) | Resolves the name of a module on a set of paths. (Inherited from ScriptLoaderBase.)
Public method | ResolveModuleName(String, Table) | Resolves the name of a module to a filename (which will later be passed to OpenScriptFile). The resolution happens first on paths included in the LUA_PATH global variable, and - if the variable does not exist - by consulting the ScriptOptions.ModulesPaths array. Override to provide a different behaviour. (Overrides ScriptLoaderBaseResolveModuleName(String, Table).)
Public method | ScriptFileExists | Checks if a script file exists. (Inherited from FileSystemScriptLoader.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReplInterpreterScriptLoader Class
MoonSharp.Interpreter.REPL Namespace


ReplInterpreterScriptLoader.ResolveModuleName Method

ReplInterpreterScriptLoaderResolveModuleName Method
Overload List
 | Name | Description
Protected method | ResolveModuleName(String, String) | Resolves the name of a module on a set of paths. (Inherited from ScriptLoaderBase.)
Public method | ResolveModuleName(String, Table) | Resolves the name of a module to a filename (which will later be passed to OpenScriptFile). The resolution happens first on paths included in the LUA_PATH global variable, and - if the variable does not exist - by consulting the ScriptOptions.ModulesPaths array. Override to provide a different behaviour. (Overrides ScriptLoaderBaseResolveModuleName(String, Table).)
Top
See Also

Reference

ReplInterpreterScriptLoader Class
MoonSharp.Interpreter.REPL Namespace


ReplInterpreterScriptLoader.ResolveModuleName Method (String, Table)

ReplInterpreterScriptLoaderResolveModuleName Method (String, Table)
Resolves the name of a module to a filename (which will later be passed to OpenScriptFile). The resolution happens first on paths included in the LUA_PATH global variable, and - if the variable does not exist - by consulting the ScriptOptions.ModulesPaths array. Override to provide a different behaviour.

Namespace: MoonSharp.Interpreter.REPL
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public override string ResolveModuleName(
    string modname,
    Table globalContext
)
Public Overrides Function ResolveModuleName (
    modname As String,
    globalContext As Table
) As String
public:
virtual String^ ResolveModuleName(
    String^ modname,
    Table^ globalContext
) override
abstract ResolveModuleName :
        modname : string *
        globalContext : Table -> string
override ResolveModuleName :
        modname : string *
        globalContext : Table -> string

Parameters

modname
Type: SystemString
The modname.
globalContext
Type: MoonSharp.InterpreterTable
The global context.

Return Value

Type: String

Implements

IScriptLoaderResolveModuleName(String, Table)
See Also

Reference

ReplInterpreterScriptLoader Class
ResolveModuleName Overload
MoonSharp.Interpreter.REPL Namespace


MoonSharp.Interpreter.Serialization Namespace

MoonSharp.Interpreter.Serialization Namespace

[Missing <summary> documentation for "N:MoonSharp.Interpreter.Serialization"]

Classes
 | Class | Description
Public class | ObjectValueConverter |
Public class | SerializationExtensions |


ObjectValueConverter Class

ObjectValueConverter Class

[Missing <summary> documentation for "T:MoonSharp.Interpreter.Serialization.ObjectValueConverter"]

Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.SerializationObjectValueConverter

Namespace: MoonSharp.Interpreter.Serialization
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static class ObjectValueConverter
Public NotInheritable Class ObjectValueConverter
public ref class ObjectValueConverter abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ObjectValueConverter =  class end

The ObjectValueConverter type exposes the following members.

Methods
Name | Description
SerializeObjectToDynValue |
Top
See Also

Reference

MoonSharp.Interpreter.Serialization Namespace


ObjectValueConverter Methods

ObjectValueConverter Methods

The ObjectValueConverter type exposes the following members.

Methods
Name | Description
SerializeObjectToDynValue |
Top
See Also

Reference

ObjectValueConverter Class
MoonSharp.Interpreter.Serialization Namespace


ObjectValueConverter.SerializeObjectToDynValue Method

ObjectValueConverterSerializeObjectToDynValue Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Serialization.ObjectValueConverter.SerializeObjectToDynValue(MoonSharp.Interpreter.Script,System.Object,MoonSharp.Interpreter.DynValue)"]

Namespace: MoonSharp.Interpreter.Serialization
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue SerializeObjectToDynValue(
    Script script,
    Object o,
    DynValue valueForNulls = null
)
Public Shared Function SerializeObjectToDynValue (
    script As Script,
    o As Object,
    Optional valueForNulls As DynValue = Nothing
) As DynValue
public:
static DynValue^ SerializeObjectToDynValue(
    Script^ script,
    Object^ o,
    DynValue^ valueForNulls = nullptr
)
static member SerializeObjectToDynValue :
        script : Script *
        o : Object *
        ?valueForNulls : DynValue
(* Defaults:
        let _valueForNulls = defaultArg valueForNulls null
*)
-> DynValue

Parameters

script
Type: MoonSharp.InterpreterScript

[Missing <param name="script"/> documentation for "M:MoonSharp.Interpreter.Serialization.ObjectValueConverter.SerializeObjectToDynValue(MoonSharp.Interpreter.Script,System.Object,MoonSharp.Interpreter.DynValue)"]

o
Type: SystemObject

[Missing <param name="o"/> documentation for "M:MoonSharp.Interpreter.Serialization.ObjectValueConverter.SerializeObjectToDynValue(MoonSharp.Interpreter.Script,System.Object,MoonSharp.Interpreter.DynValue)"]

valueForNulls (Optional)
Type: MoonSharp.InterpreterDynValue

[Missing <param name="valueForNulls"/> documentation for "M:MoonSharp.Interpreter.Serialization.ObjectValueConverter.SerializeObjectToDynValue(MoonSharp.Interpreter.Script,System.Object,MoonSharp.Interpreter.DynValue)"]

Return Value

Type: DynValue
See Also

Reference

ObjectValueConverter Class
MoonSharp.Interpreter.Serialization Namespace


SerializationExtensions Class

SerializationExtensions Class

[Missing <summary> documentation for "T:MoonSharp.Interpreter.Serialization.SerializationExtensions"]

Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.SerializationSerializationExtensions

Namespace: MoonSharp.Interpreter.Serialization
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static class SerializationExtensions
<ExtensionAttribute>
Public NotInheritable Class SerializationExtensions
[ExtensionAttribute]
public ref class SerializationExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type SerializationExtensions =  class end

The SerializationExtensions type exposes the following members.

Methods
Name | Description
Serialize |
SerializeValue |
Top
See Also

Reference

MoonSharp.Interpreter.Serialization Namespace


SerializationExtensions Methods

SerializationExtensions Methods

The SerializationExtensions type exposes the following members.

Methods
Name | Description
Serialize |
SerializeValue |
Top
See Also

Reference

SerializationExtensions Class
MoonSharp.Interpreter.Serialization Namespace


SerializationExtensions.Serialize Method

SerializationExtensionsSerialize Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Serialization.SerializationExtensions.Serialize(MoonSharp.Interpreter.Table,System.Boolean,System.Int32)"]

Namespace: MoonSharp.Interpreter.Serialization
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string Serialize(
    this Table table,
    bool prefixReturn = false,
    int tabs = 0
)
<ExtensionAttribute>
Public Shared Function Serialize (
    table As Table,
    Optional prefixReturn As Boolean = false,
    Optional tabs As Integer = 0
) As String
public:
[ExtensionAttribute]
static String^ Serialize(
    Table^ table,
    bool prefixReturn = false,
    int tabs = 0
)
[<ExtensionAttribute>]
static member Serialize :
        table : Table *
        ?prefixReturn : bool *
        ?tabs : int
(* Defaults:
        let _prefixReturn = defaultArg prefixReturn false
        let _tabs = defaultArg tabs 0
*)
-> string

Parameters

table
Type: MoonSharp.InterpreterTable

[Missing <param name="table"/> documentation for "M:MoonSharp.Interpreter.Serialization.SerializationExtensions.Serialize(MoonSharp.Interpreter.Table,System.Boolean,System.Int32)"]

prefixReturn (Optional)
Type: SystemBoolean

[Missing <param name="prefixReturn"/> documentation for "M:MoonSharp.Interpreter.Serialization.SerializationExtensions.Serialize(MoonSharp.Interpreter.Table,System.Boolean,System.Int32)"]

tabs (Optional)
Type: SystemInt32

[Missing <param name="tabs"/> documentation for "M:MoonSharp.Interpreter.Serialization.SerializationExtensions.Serialize(MoonSharp.Interpreter.Table,System.Boolean,System.Int32)"]

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Table. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SerializationExtensions Class
MoonSharp.Interpreter.Serialization Namespace


SerializationExtensions.SerializeValue Method

SerializationExtensionsSerializeValue Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Serialization.SerializationExtensions.SerializeValue(MoonSharp.Interpreter.DynValue,System.Int32)"]

Namespace: MoonSharp.Interpreter.Serialization
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string SerializeValue(
    this DynValue dynValue,
    int tabs = 0
)
<ExtensionAttribute>
Public Shared Function SerializeValue (
    dynValue As DynValue,
    Optional tabs As Integer = 0
) As String
public:
[ExtensionAttribute]
static String^ SerializeValue(
    DynValue^ dynValue,
    int tabs = 0
)
[<ExtensionAttribute>]
static member SerializeValue :
        dynValue : DynValue *
        ?tabs : int
(* Defaults:
        let _tabs = defaultArg tabs 0
*)
-> string

Parameters

dynValue
Type: MoonSharp.InterpreterDynValue

[Missing <param name="dynValue"/> documentation for "M:MoonSharp.Interpreter.Serialization.SerializationExtensions.SerializeValue(MoonSharp.Interpreter.DynValue,System.Int32)"]

tabs (Optional)
Type: SystemInt32

[Missing <param name="tabs"/> documentation for "M:MoonSharp.Interpreter.Serialization.SerializationExtensions.SerializeValue(MoonSharp.Interpreter.DynValue,System.Int32)"]

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DynValue. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SerializationExtensions Class
MoonSharp.Interpreter.Serialization Namespace


MoonSharp.Interpreter.Serialization.Json Namespace

MoonSharp.Interpreter.Serialization.Json Namespace

[Missing <summary> documentation for "N:MoonSharp.Interpreter.Serialization.Json"]

Classes
 | Class | Description
Public class | JsonNull | UserData representing a null value in a table converted from Json
Public class | JsonTableConverter | Class performing conversions between Tables and Json. NOTE : the conversions are done respecting json syntax but using Lua constructs. This means mostly that: 1) Lua string escapes can be accepted while they are not technically valid JSON, and viceversa 2) Null values are represented using a static userdata of type JsonNull 3) Do not use it when input cannot be entirely trusted


JsonNull Class

JsonNull Class
UserData representing a null value in a table converted from Json
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.Serialization.JsonJsonNull

Namespace: MoonSharp.Interpreter.Serialization.Json
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class JsonNull
Public NotInheritable Class JsonNull
public ref class JsonNull sealed
[<SealedAttribute>]
type JsonNull =  class end

The JsonNull type exposes the following members.

Constructors
 | Name | Description
Public method | JsonNull | Initializes a new instance of the JsonNull class
Top
Methods
 | Name | Description
 | Create |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsJsonNull |
 | isNull |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MoonSharp.Interpreter.Serialization.Json Namespace


JsonNull Constructor

JsonNull Constructor
Initializes a new instance of the JsonNull class

Namespace: MoonSharp.Interpreter.Serialization.Json
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public JsonNull()
Public Sub New
public:
JsonNull()
new : unit -> JsonNull
See Also

Reference

JsonNull Class
MoonSharp.Interpreter.Serialization.Json Namespace


JsonNull Methods

JsonNull Methods

The JsonNull type exposes the following members.

Methods
 | Name | Description
 | Create |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsJsonNull |
 | isNull |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JsonNull Class
MoonSharp.Interpreter.Serialization.Json Namespace


JsonNull.Create Method

JsonNullCreate Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Serialization.Json.JsonNull.Create"]

Namespace: MoonSharp.Interpreter.Serialization.Json
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static DynValue Create()
Public Shared Function Create As DynValue
public:
static DynValue^ Create()
static member Create : unit -> DynValue

Return Value

Type: DynValue
See Also

Reference

JsonNull Class
MoonSharp.Interpreter.Serialization.Json Namespace


JsonNull.IsJsonNull Method

JsonNullIsJsonNull Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Serialization.Json.JsonNull.IsJsonNull(MoonSharp.Interpreter.DynValue)"]

Namespace: MoonSharp.Interpreter.Serialization.Json
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool IsJsonNull(
    DynValue v
)
Public Shared Function IsJsonNull (
    v As DynValue
) As Boolean
public:
static bool IsJsonNull(
    DynValue^ v
)
static member IsJsonNull :
        v : DynValue -> bool

Parameters

v
Type: MoonSharp.InterpreterDynValue

[Missing <param name="v"/> documentation for "M:MoonSharp.Interpreter.Serialization.Json.JsonNull.IsJsonNull(MoonSharp.Interpreter.DynValue)"]

Return Value

Type: Boolean
See Also

Reference

JsonNull Class
MoonSharp.Interpreter.Serialization.Json Namespace


JsonNull.isNull Method

JsonNullisNull Method

[Missing <summary> documentation for "M:MoonSharp.Interpreter.Serialization.Json.JsonNull.isNull"]

Namespace: MoonSharp.Interpreter.Serialization.Json
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool isNull()
Public Shared Function isNull As Boolean
public:
static bool isNull()
static member isNull : unit -> bool

Return Value

Type: Boolean
See Also

Reference

JsonNull Class
MoonSharp.Interpreter.Serialization.Json Namespace


JsonTableConverter Class

JsonTableConverter Class
Class performing conversions between Tables and Json. NOTE : the conversions are done respecting json syntax but using Lua constructs. This means mostly that: 1) Lua string escapes can be accepted while they are not technically valid JSON, and viceversa 2) Null values are represented using a static userdata of type JsonNull 3) Do not use it when input cannot be entirely trusted
Inheritance Hierarchy
SystemObject
MoonSharp.Interpreter.Serialization.JsonJsonTableConverter

Namespace: MoonSharp.Interpreter.Serialization.Json
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static class JsonTableConverter
<ExtensionAttribute>
Public NotInheritable Class JsonTableConverter
[ExtensionAttribute]
public ref class JsonTableConverter abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type JsonTableConverter =  class end

The JsonTableConverter type exposes the following members.

Methods
Name | Description
JsonToTable | Converts a json string to a table
ObjectToJson | Converts a generic object to JSON
TableToJson | Converts a table to a json string
Top
See Also

Reference

MoonSharp.Interpreter.Serialization.Json Namespace


JsonTableConverter Methods

JsonTableConverter Methods

The JsonTableConverter type exposes the following members.

Methods
Name | Description
JsonToTable | Converts a json string to a table
ObjectToJson | Converts a generic object to JSON
TableToJson | Converts a table to a json string
Top
See Also

Reference

JsonTableConverter Class
MoonSharp.Interpreter.Serialization.Json Namespace


JsonTableConverter.JsonToTable Method

JsonTableConverterJsonToTable Method
Converts a json string to a table

Namespace: MoonSharp.Interpreter.Serialization.Json
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Table JsonToTable(
    string json,
    Script script = null
)
Public Shared Function JsonToTable (
    json As String,
    Optional script As Script = Nothing
) As Table
public:
static Table^ JsonToTable(
    String^ json,
    Script^ script = nullptr
)
static member JsonToTable :
        json : string *
        ?script : Script
(* Defaults:
        let _script = defaultArg script null
*)
-> Table

Parameters

json
Type: SystemString
The json.
script (Optional)
Type: MoonSharp.InterpreterScript
The script to which the table is assigned (null for prime tables).

Return Value

Type: Table
A table containing the representation of the given json.
See Also

Reference

JsonTableConverter Class
MoonSharp.Interpreter.Serialization.Json Namespace


JsonTableConverter.ObjectToJson Method

JsonTableConverterObjectToJson Method
Converts a generic object to JSON

Namespace: MoonSharp.Interpreter.Serialization.Json
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string ObjectToJson(
    Object obj
)
Public Shared Function ObjectToJson (
    obj As Object
) As String
public:
static String^ ObjectToJson(
    Object^ obj
)
static member ObjectToJson :
        obj : Object -> string

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:MoonSharp.Interpreter.Serialization.Json.JsonTableConverter.ObjectToJson(System.Object)"]

Return Value

Type: String
See Also

Reference

JsonTableConverter Class
MoonSharp.Interpreter.Serialization.Json Namespace


JsonTableConverter.TableToJson Method

JsonTableConverterTableToJson Method
Converts a table to a json string

Namespace: MoonSharp.Interpreter.Serialization.Json
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static string TableToJson(
    this Table table
)
<ExtensionAttribute>
Public Shared Function TableToJson (
    table As Table
) As String
public:
[ExtensionAttribute]
static String^ TableToJson(
    Table^ table
)
[<ExtensionAttribute>]
static member TableToJson :
        table : Table -> string

Parameters

table
Type: MoonSharp.InterpreterTable
The table.

Return Value

Type: String

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Table. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

JsonTableConverter Class
MoonSharp.Interpreter.Serialization.Json Namespace


System Namespace

System Namespace

[Missing <summary> documentation for "N:System"]

Classes
 | Class | Description
Public class | AssemblyTools |
Public class | ReflectionExtensions |


AssemblyTools Class

AssemblyTools Class

[Missing <summary> documentation for "T:System.AssemblyTools"]

Inheritance Hierarchy
SystemObject
SystemAssemblyTools

Namespace: System
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static class AssemblyTools
Public NotInheritable Class AssemblyTools
public ref class AssemblyTools abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AssemblyTools =  class end

The AssemblyTools type exposes the following members.

Methods
Name | Description
GetCallingAssembly |
Top
See Also

Reference

System Namespace


AssemblyTools Methods

AssemblyTools Methods

The AssemblyTools type exposes the following members.

Methods
Name | Description
GetCallingAssembly |
Top
See Also

Reference

AssemblyTools Class
System Namespace


AssemblyTools.GetCallingAssembly Method

AssemblyToolsGetCallingAssembly Method

[Missing <summary> documentation for "M:System.AssemblyTools.GetCallingAssembly"]

Namespace: System
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Assembly GetCallingAssembly()
Public Shared Function GetCallingAssembly As Assembly
public:
static Assembly^ GetCallingAssembly()
static member GetCallingAssembly : unit -> Assembly

Return Value

Type: Assembly
See Also

Reference

AssemblyTools Class
System Namespace


ReflectionExtensions Class

ReflectionExtensions Class

[Missing <summary> documentation for "T:System.ReflectionExtensions"]

Inheritance Hierarchy
SystemObject
SystemReflectionExtensions

Namespace: System
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static class ReflectionExtensions
<ExtensionAttribute>
Public NotInheritable Class ReflectionExtensions
[ExtensionAttribute]
public ref class ReflectionExtensions abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ExtensionAttribute>]
type ReflectionExtensions =  class end

The ReflectionExtensions type exposes the following members.

Methods
Name | Description
CheckIsAbstract |
CheckIsEnum |
CheckIsGenericType |
CheckIsGenericTypeDefinition |
CheckIsInterface |
CheckIsNestedPublic |
CheckIsValueType |
GetAssembly |
GetBaseType |
Top
See Also

Reference

System Namespace


ReflectionExtensions Methods

ReflectionExtensions Methods

The ReflectionExtensions type exposes the following members.

Methods
Name | Description
CheckIsAbstract |
CheckIsEnum |
CheckIsGenericType |
CheckIsGenericTypeDefinition |
CheckIsInterface |
CheckIsNestedPublic |
CheckIsValueType |
GetAssembly |
GetBaseType |
Top
See Also

Reference

ReflectionExtensions Class
System Namespace


ReflectionExtensions.CheckIsAbstract Method

ReflectionExtensionsCheckIsAbstract Method

[Missing <summary> documentation for "M:System.ReflectionExtensions.CheckIsAbstract(System.Type)"]

Namespace: System
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckIsAbstract(
    this Type t
)
<ExtensionAttribute>
Public Shared Function CheckIsAbstract (
    t As Type
) As Boolean
public:
[ExtensionAttribute]
static bool CheckIsAbstract(
    Type^ t
)
[<ExtensionAttribute>]
static member CheckIsAbstract :
        t : Type -> bool

Parameters

t
Type: SystemType

[Missing <param name="t"/> documentation for "M:System.ReflectionExtensions.CheckIsAbstract(System.Type)"]

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ReflectionExtensions Class
System Namespace


ReflectionExtensions.CheckIsEnum Method

ReflectionExtensionsCheckIsEnum Method

[Missing <summary> documentation for "M:System.ReflectionExtensions.CheckIsEnum(System.Type)"]

Namespace: System
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckIsEnum(
    this Type t
)
<ExtensionAttribute>
Public Shared Function CheckIsEnum (
    t As Type
) As Boolean
public:
[ExtensionAttribute]
static bool CheckIsEnum(
    Type^ t
)
[<ExtensionAttribute>]
static member CheckIsEnum :
        t : Type -> bool

Parameters

t
Type: SystemType

[Missing <param name="t"/> documentation for "M:System.ReflectionExtensions.CheckIsEnum(System.Type)"]

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ReflectionExtensions Class
System Namespace


ReflectionExtensions.CheckIsGenericType Method

ReflectionExtensionsCheckIsGenericType Method

[Missing <summary> documentation for "M:System.ReflectionExtensions.CheckIsGenericType(System.Type)"]

Namespace: System
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckIsGenericType(
    this Type t
)
<ExtensionAttribute>
Public Shared Function CheckIsGenericType (
    t As Type
) As Boolean
public:
[ExtensionAttribute]
static bool CheckIsGenericType(
    Type^ t
)
[<ExtensionAttribute>]
static member CheckIsGenericType :
        t : Type -> bool

Parameters

t
Type: SystemType

[Missing <param name="t"/> documentation for "M:System.ReflectionExtensions.CheckIsGenericType(System.Type)"]

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ReflectionExtensions Class
System Namespace


ReflectionExtensions.CheckIsGenericTypeDefinition Method

ReflectionExtensionsCheckIsGenericTypeDefinition Method

[Missing <summary> documentation for "M:System.ReflectionExtensions.CheckIsGenericTypeDefinition(System.Type)"]

Namespace: System
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckIsGenericTypeDefinition(
    this Type t
)
<ExtensionAttribute>
Public Shared Function CheckIsGenericTypeDefinition (
    t As Type
) As Boolean
public:
[ExtensionAttribute]
static bool CheckIsGenericTypeDefinition(
    Type^ t
)
[<ExtensionAttribute>]
static member CheckIsGenericTypeDefinition :
        t : Type -> bool

Parameters

t
Type: SystemType

[Missing <param name="t"/> documentation for "M:System.ReflectionExtensions.CheckIsGenericTypeDefinition(System.Type)"]

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ReflectionExtensions Class
System Namespace


ReflectionExtensions.CheckIsInterface Method

ReflectionExtensionsCheckIsInterface Method

[Missing <summary> documentation for "M:System.ReflectionExtensions.CheckIsInterface(System.Type)"]

Namespace: System
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckIsInterface(
    this Type t
)
<ExtensionAttribute>
Public Shared Function CheckIsInterface (
    t As Type
) As Boolean
public:
[ExtensionAttribute]
static bool CheckIsInterface(
    Type^ t
)
[<ExtensionAttribute>]
static member CheckIsInterface :
        t : Type -> bool

Parameters

t
Type: SystemType

[Missing <param name="t"/> documentation for "M:System.ReflectionExtensions.CheckIsInterface(System.Type)"]

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ReflectionExtensions Class
System Namespace


ReflectionExtensions.CheckIsNestedPublic Method

ReflectionExtensionsCheckIsNestedPublic Method

[Missing <summary> documentation for "M:System.ReflectionExtensions.CheckIsNestedPublic(System.Type)"]

Namespace: System
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckIsNestedPublic(
    this Type t
)
<ExtensionAttribute>
Public Shared Function CheckIsNestedPublic (
    t As Type
) As Boolean
public:
[ExtensionAttribute]
static bool CheckIsNestedPublic(
    Type^ t
)
[<ExtensionAttribute>]
static member CheckIsNestedPublic :
        t : Type -> bool

Parameters

t
Type: SystemType

[Missing <param name="t"/> documentation for "M:System.ReflectionExtensions.CheckIsNestedPublic(System.Type)"]

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ReflectionExtensions Class
System Namespace


ReflectionExtensions.CheckIsValueType Method

ReflectionExtensionsCheckIsValueType Method

[Missing <summary> documentation for "M:System.ReflectionExtensions.CheckIsValueType(System.Type)"]

Namespace: System
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static bool CheckIsValueType(
    this Type t
)
<ExtensionAttribute>
Public Shared Function CheckIsValueType (
    t As Type
) As Boolean
public:
[ExtensionAttribute]
static bool CheckIsValueType(
    Type^ t
)
[<ExtensionAttribute>]
static member CheckIsValueType :
        t : Type -> bool

Parameters

t
Type: SystemType

[Missing <param name="t"/> documentation for "M:System.ReflectionExtensions.CheckIsValueType(System.Type)"]

Return Value

Type: Boolean

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ReflectionExtensions Class
System Namespace


ReflectionExtensions.GetAssembly Method

ReflectionExtensionsGetAssembly Method

[Missing <summary> documentation for "M:System.ReflectionExtensions.GetAssembly(System.Type)"]

Namespace: System
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Assembly GetAssembly(
    this Type t
)
<ExtensionAttribute>
Public Shared Function GetAssembly (
    t As Type
) As Assembly
public:
[ExtensionAttribute]
static Assembly^ GetAssembly(
    Type^ t
)
[<ExtensionAttribute>]
static member GetAssembly :
        t : Type -> Assembly

Parameters

t
Type: SystemType

[Missing <param name="t"/> documentation for "M:System.ReflectionExtensions.GetAssembly(System.Type)"]

Return Value

Type: Assembly

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ReflectionExtensions Class
System Namespace


ReflectionExtensions.GetBaseType Method

ReflectionExtensionsGetBaseType Method

[Missing <summary> documentation for "M:System.ReflectionExtensions.GetBaseType(System.Type)"]

Namespace: System
Assembly: MoonSharp.Interpreter (in MoonSharp.Interpreter.dll) Version: 1.8.5.0 (1.8.5.0)
Syntax
C#
VB
C++
F#
Copy
public static Type GetBaseType(
    this Type t
)
<ExtensionAttribute>
Public Shared Function GetBaseType (
    t As Type
) As Type
public:
[ExtensionAttribute]
static Type^ GetBaseType(
    Type^ t
)
[<ExtensionAttribute>]
static member GetBaseType :
        t : Type -> Type

Parameters

t
Type: SystemType

[Missing <param name="t"/> documentation for "M:System.ReflectionExtensions.GetBaseType(System.Type)"]

Return Value

Type: Type

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ReflectionExtensions Class
System Namespace